/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.157 Revision 1.158
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.157 2012/08/16 23:57:32 floppym Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.158 2012/09/27 15:41:56 floppym Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Gentoo Python Project <python@gentoo.org> 7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: Eclass for Python packages 8# @BLURB: Eclass for Python packages
21 21
22# Avoid processing this eclass more than once. 22# Avoid processing this eclass more than once.
23if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then 23if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
24_PYTHON_ECLASS_INHERITED="1" 24_PYTHON_ECLASS_INHERITED="1"
25 25
26if ! has "${EAPI:-0}" 0 1 2 3 4; then 26if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
27 die "API of python.eclass in EAPI=\"${EAPI}\" not established" 27 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
28fi 28fi
29 29
30_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7) 30_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
31_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2) 31_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2)
111 return 1 111 return 1
112 fi 112 fi
113} 113}
114 114
115_python_package_supporting_installation_for_multiple_python_abis() { 115_python_package_supporting_installation_for_multiple_python_abis() {
116 if has "${EAPI:-0}" 0 1 2 3 4; then
117 if [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 116 [[ -n "${SUPPORT_PYTHON_ABIS}" ]]
118 return 0
119 else
120 return 1
121 fi
122 else
123 die "${FUNCNAME}(): Support for EAPI=\"${EAPI}\" not implemented"
124 fi
125} 117}
126 118
127# @ECLASS-VARIABLE: PYTHON_DEPEND 119# @ECLASS-VARIABLE: PYTHON_DEPEND
128# @DESCRIPTION: 120# @DESCRIPTION:
129# Specification of dependency on dev-lang/python. 121# Specification of dependency on dev-lang/python.
750 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then 742 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
751 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install 743 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
752 fi 744 fi
753fi 745fi
754 746
755if has "${EAPI:-0}" 0 1 2 3 4; then
756 unset PYTHON_ABIS 747unset PYTHON_ABIS
757fi
758 748
759_python_calculate_PYTHON_ABIS() { 749_python_calculate_PYTHON_ABIS() {
760 if ! _python_package_supporting_installation_for_multiple_python_abis; then 750 if ! _python_package_supporting_installation_for_multiple_python_abis; then
761 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 751 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
762 fi 752 fi

Legend:
Removed from v.1.157  
changed lines
  Added in v.1.158

  ViewVC Help
Powered by ViewVC 1.1.20