/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.108 Revision 1.161
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.108 2010/12/31 21:51:41 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.161 2012/11/24 21:07:14 mgorny Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Gentoo Python Project <python@gentoo.org> 7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: Eclass for Python packages 8# @BLURB: Eclass for Python packages
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The python eclass contains miscellaneous, useful functions for Python packages. 10# The python eclass contains miscellaneous, useful functions for Python packages.
11 11
12if [[ ${_PYTHON_UTILS_R1} ]]; then
13 die 'python.eclass can not be used with python-r1 suite eclasses.'
14fi
15
16# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning.
17if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
12inherit multilib 18 inherit multilib
19fi
13 20
21# Export pkg_setup every time to avoid issues with eclass inheritance order.
22if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
23 EXPORT_FUNCTIONS pkg_setup
24fi
25
26# Avoid processing this eclass more than once.
27if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
28_PYTHON_ECLASS_INHERITED="1"
29
14if ! has "${EAPI:-0}" 0 1 2 3; then 30if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
15 die "API of python.eclass in EAPI=\"${EAPI}\" not established" 31 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
16fi 32fi
17 33
18_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7) 34_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
19_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.0 3.1 3.2) 35_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2 3.3)
20_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython) 36_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
37_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9)
21_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]}) 38_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]})
22 39
23# ================================================================================================ 40# ================================================================================================
24# ===================================== HANDLING OF METADATA ===================================== 41# ===================================== HANDLING OF METADATA =====================================
25# ================================================================================================ 42# ================================================================================================
26 43
44_PYTHON_ABI_PATTERN_REGEX="([[:alnum:]]|\.|-|\*|\[|\])+"
45
27_python_check_python_abi_matching() { 46_python_check_python_abi_matching() {
47 local pattern patterns patterns_list="0" PYTHON_ABI
48
49 while (($#)); do
50 case "$1" in
51 --patterns-list)
52 patterns_list="1"
53 ;;
54 --)
55 shift
56 break
57 ;;
58 -*)
59 die "${FUNCNAME}(): Unrecognized option '$1'"
60 ;;
61 *)
62 break
63 ;;
64 esac
65 shift
66 done
67
28 if [[ "$#" -ne 2 ]]; then 68 if [[ "$#" -ne 2 ]]; then
29 die "${FUNCNAME}() requires 2 arguments" 69 die "${FUNCNAME}() requires 2 arguments"
30 fi 70 fi
31 71
72 PYTHON_ABI="$1"
73
74 if [[ "${patterns_list}" == "0" ]]; then
75 pattern="$2"
76
32 if [[ "$2" == *"-cpython" ]]; then 77 if [[ "${pattern}" == *"-cpython" ]]; then
33 [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "$1" == ${2%-cpython} ]] 78 [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "${PYTHON_ABI}" == ${pattern%-cpython} ]]
34 elif [[ "$2" == *"-jython" ]]; then 79 elif [[ "${pattern}" == *"-jython" ]]; then
35 [[ "$1" == $2 ]] 80 [[ "${PYTHON_ABI}" == ${pattern} ]]
81 elif [[ "${pattern}" == *"-pypy-"* ]]; then
82 [[ "${PYTHON_ABI}" == ${pattern} ]]
83 else
84 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
85 [[ "${PYTHON_ABI}" == ${pattern} ]]
86 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
87 [[ "${PYTHON_ABI%-jython}" == ${pattern} ]]
88 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
89 [[ "${PYTHON_ABI%-pypy-*}" == ${pattern} ]]
90 else
91 die "${FUNCNAME}(): Unrecognized Python ABI '${PYTHON_ABI}'"
92 fi
93 fi
36 else 94 else
37 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then 95 patterns="${2// /$'\n'}"
38 [[ "$1" == $2 ]] 96
39 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then 97 while read pattern; do
40 [[ "${1%-jython}" == $2 ]] 98 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
99 return 0
100 fi
101 done <<< "${patterns}"
102
103 return 1
104 fi
105}
106
107_python_implementation() {
108 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
109 return 0
110 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
111 return 0
112 elif [[ "${CATEGORY}/${PN}" == "dev-python/pypy" ]]; then
113 return 0
41 else 114 else
42 die "${FUNCNAME}(): Unrecognized Python ABI '$1'" 115 return 1
43 fi 116 fi
44 fi 117}
118
119_python_package_supporting_installation_for_multiple_python_abis() {
120 [[ -n "${SUPPORT_PYTHON_ABIS}" ]]
45} 121}
46 122
47# @ECLASS-VARIABLE: PYTHON_DEPEND 123# @ECLASS-VARIABLE: PYTHON_DEPEND
48# @DESCRIPTION: 124# @DESCRIPTION:
49# Specification of dependency on dev-lang/python. 125# Specification of dependency on dev-lang/python.
175 else 251 else
176 die "Invalid syntax of PYTHON_DEPEND" 252 die "Invalid syntax of PYTHON_DEPEND"
177 fi 253 fi
178} 254}
179 255
256if _python_implementation; then
180DEPEND=">=app-admin/eselect-python-20091230" 257 DEPEND=">=app-admin/eselect-python-20091230"
181RDEPEND="${DEPEND}" 258 RDEPEND="${DEPEND}"
259 PDEPEND="app-admin/python-updater"
260fi
182 261
183if [[ -n "${PYTHON_DEPEND}" ]]; then 262if [[ -n "${PYTHON_DEPEND}" ]]; then
184 _python_parse_PYTHON_DEPEND 263 _python_parse_PYTHON_DEPEND
185else 264else
186 _PYTHON_ATOMS=("dev-lang/python") 265 _PYTHON_ATOMS=("dev-lang/python")
225 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}" 304 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}"
226 fi 305 fi
227 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then 306 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
228 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )" 307 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )"
229 fi 308 fi
230 DEPEND+=" ${_PYTHON_USE_WITH_ATOMS}" 309 DEPEND+="${DEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
231 RDEPEND+=" ${_PYTHON_USE_WITH_ATOMS}" 310 RDEPEND+="${RDEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
232 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY 311 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY
233fi 312fi
234 313
235unset _PYTHON_ATOMS 314unset _PYTHON_ATOMS
236 315
237# ================================================================================================ 316# ================================================================================================
238# =================================== MISCELLANEOUS FUNCTIONS ==================================== 317# =================================== MISCELLANEOUS FUNCTIONS ====================================
239# ================================================================================================ 318# ================================================================================================
240
241_python_implementation() {
242 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
243 return 0
244 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
245 return 0
246 else
247 return 1
248 fi
249}
250
251_python_package_supporting_installation_for_multiple_python_abis() {
252 if [[ "${EBUILD_PHASE}" == "depend" ]]; then
253 die "${FUNCNAME}() cannot be used in global scope"
254 fi
255
256 if has "${EAPI:-0}" 0 1 2 3 4; then
257 if [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
258 return 0
259 else
260 return 1
261 fi
262 else
263 die "${FUNCNAME}(): Support for EAPI=\"${EAPI}\" not implemented"
264 fi
265}
266 319
267_python_abi-specific_local_scope() { 320_python_abi-specific_local_scope() {
268 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]] 321 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]]
269} 322}
270 323
342 _CYAN= 395 _CYAN=
343 _NORMAL= 396 _NORMAL=
344 fi 397 fi
345} 398}
346 399
347unset PYTHON_PKG_SETUP_EXECUTED
348
349_python_check_python_pkg_setup_execution() { 400_python_check_python_pkg_setup_execution() {
350 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return 401 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
351 402
352 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then 403 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
353 die "python_pkg_setup() not called" 404 die "python_pkg_setup() not called"
358# @DESCRIPTION: 409# @DESCRIPTION:
359# Perform sanity checks and initialize environment. 410# Perform sanity checks and initialize environment.
360# 411#
361# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable 412# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable
362# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4. 413# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4.
363#
364# This function can be used only in pkg_setup() phase.
365python_pkg_setup() { 414python_pkg_setup() {
366 # Check if phase is pkg_setup(). 415 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
367 [[ "${EBUILD_PHASE}" != "setup" ]] && die "${FUNCNAME}() can be used only in pkg_setup() phase" 416 die "${FUNCNAME}() can be used only in pkg_setup() phase"
417 fi
368 418
369 if [[ "$#" -ne 0 ]]; then 419 if [[ "$#" -ne 0 ]]; then
370 die "${FUNCNAME}() does not accept arguments" 420 die "${FUNCNAME}() does not accept arguments"
371 fi 421 fi
372 422
422 fi 472 fi
423 473
424 PYTHON_PKG_SETUP_EXECUTED="1" 474 PYTHON_PKG_SETUP_EXECUTED="1"
425} 475}
426 476
427if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
428 EXPORT_FUNCTIONS pkg_setup
429fi
430
431_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|python)' 477_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|pypy-c|python)'
432 478
433# @FUNCTION: python_convert_shebangs 479# @FUNCTION: python_convert_shebangs
434# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories] 480# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories]
435# @DESCRIPTION: 481# @DESCRIPTION:
436# Convert shebangs in specified files. Directories can be specified only with --recursive option. 482# Convert shebangs in specified files. Directories can be specified only with --recursive option.
437python_convert_shebangs() { 483python_convert_shebangs() {
438 _python_check_python_pkg_setup_execution 484 _python_check_python_pkg_setup_execution
439 485
440 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0" 486 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0" shebangs_converted="0"
441 487
442 while (($#)); do 488 while (($#)); do
443 case "$1" in 489 case "$1" in
444 -r|--recursive) 490 -r|--recursive)
445 recursive="1" 491 recursive="1"
500 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue 546 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
501 547
502 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then 548 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then
503 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue 549 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue
504 550
551 shebangs_converted="1"
552
505 if [[ "${quiet}" == "0" ]]; then 553 if [[ "${quiet}" == "0" ]]; then
506 einfo "Converting shebang in '${file}'" 554 einfo "Converting shebang in '${file}'"
507 fi 555 fi
508 556
509 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed" 557 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|pypy-c\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed"
558 fi
559 done
560
561 if [[ "${shebangs_converted}" == "0" ]]; then
562 ewarn "${FUNCNAME}(): Python scripts not found"
510 fi 563 fi
564}
565
566# @FUNCTION: python_clean_py-compile_files
567# @USAGE: [-q|--quiet]
568# @DESCRIPTION:
569# Clean py-compile files to disable byte-compilation.
570python_clean_py-compile_files() {
571 _python_check_python_pkg_setup_execution
572
573 local file files=() quiet="0"
574
575 while (($#)); do
576 case "$1" in
577 -q|--quiet)
578 quiet="1"
579 ;;
580 -*)
581 die "${FUNCNAME}(): Unrecognized option '$1'"
582 ;;
583 *)
584 die "${FUNCNAME}(): Invalid usage"
585 ;;
586 esac
587 shift
588 done
589
590 while read -d $'\0' -r file; do
591 files+=("${file#./}")
592 done < <(find -name py-compile -type f -print0)
593
594 for file in "${files[@]}"; do
595 if [[ "${quiet}" == "0" ]]; then
596 einfo "Cleaning '${file}' file"
597 fi
598 echo "#!/bin/sh" > "${file}"
511 done 599 done
512} 600}
513 601
514# @FUNCTION: python_clean_installation_image 602# @FUNCTION: python_clean_installation_image
515# @USAGE: [-q|--quiet] 603# @USAGE: [-q|--quiet]
516# @DESCRIPTION: 604# @DESCRIPTION:
517# Delete needless files in installation image. 605# Delete needless files in installation image.
606#
607# This function can be used only in src_install() phase.
518python_clean_installation_image() { 608python_clean_installation_image() {
609 if [[ "${EBUILD_PHASE}" != "install" ]]; then
610 die "${FUNCNAME}() can be used only in src_install() phase"
611 fi
612
519 _python_check_python_pkg_setup_execution 613 _python_check_python_pkg_setup_execution
520 _python_initialize_prefix_variables 614 _python_initialize_prefix_variables
521 615
522 local file files=() quiet="0" 616 local file files=() quiet="0"
523
524 # Check if phase is src_install().
525 [[ "${EBUILD_PHASE}" != "install" ]] && die "${FUNCNAME}() can be used only in src_install() phase"
526 617
527 while (($#)); do 618 while (($#)); do
528 case "$1" in 619 case "$1" in
529 -q|--quiet) 620 -q|--quiet)
530 quiet="1" 621 quiet="1"
581# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS 672# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS
582# @DESCRIPTION: 673# @DESCRIPTION:
583# Set this in EAPI <= 4 to indicate that current package supports installation for 674# Set this in EAPI <= 4 to indicate that current package supports installation for
584# multiple Python ABIs. 675# multiple Python ABIs.
585 676
677# @ECLASS-VARIABLE: PYTHON_TESTS_RESTRICTED_ABIS
678# @DESCRIPTION:
679# Space-separated list of Python ABI patterns. Testing in Python ABIs matching any Python ABI
680# patterns specified in this list is skipped.
681
586# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS 682# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS
587# @DESCRIPTION: 683# @DESCRIPTION:
588# Set this to export phase functions for the following ebuild phases: 684# Set this to export phase functions for the following ebuild phases:
589# src_prepare, src_configure, src_compile, src_test, src_install. 685# src_prepare(), src_configure(), src_compile(), src_test(), src_install().
590if ! has "${EAPI:-0}" 0 1; then 686if ! has "${EAPI:-0}" 0 1; then
591 python_src_prepare() { 687 python_src_prepare() {
592 _python_check_python_pkg_setup_execution 688 if [[ "${EBUILD_PHASE}" != "prepare" ]]; then
689 die "${FUNCNAME}() can be used only in src_prepare() phase"
690 fi
593 691
594 if ! _python_package_supporting_installation_for_multiple_python_abis; then 692 if ! _python_package_supporting_installation_for_multiple_python_abis; then
595 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 693 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
596 fi 694 fi
597 695
696 _python_check_python_pkg_setup_execution
697
598 if [[ "$#" -ne 0 ]]; then 698 if [[ "$#" -ne 0 ]]; then
599 die "${FUNCNAME}() does not accept arguments" 699 die "${FUNCNAME}() does not accept arguments"
600 fi 700 fi
601 701
602 python_copy_sources 702 python_copy_sources
603 } 703 }
604 704
605 for python_default_function in src_configure src_compile src_test src_install; do 705 for python_default_function in src_configure src_compile src_test; do
606 eval "python_${python_default_function}() { 706 eval "python_${python_default_function}() {
607 _python_check_python_pkg_setup_execution 707 if [[ \"\${EBUILD_PHASE}\" != \"${python_default_function#src_}\" ]]; then
708 die \"\${FUNCNAME}() can be used only in ${python_default_function}() phase\"
709 fi
608 710
609 if ! _python_package_supporting_installation_for_multiple_python_abis; then 711 if ! _python_package_supporting_installation_for_multiple_python_abis; then
610 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\" 712 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\"
611 fi 713 fi
612 714
715 _python_check_python_pkg_setup_execution
716
613 python_execute_function -d -s -- \"\$@\" 717 python_execute_function -d -s -- \"\$@\"
614 }" 718 }"
615 done 719 done
616 unset python_default_function 720 unset python_default_function
617 721
722 python_src_install() {
723 if [[ "${EBUILD_PHASE}" != "install" ]]; then
724 die "${FUNCNAME}() can be used only in src_install() phase"
725 fi
726
727 if ! _python_package_supporting_installation_for_multiple_python_abis; then
728 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
729 fi
730
731 _python_check_python_pkg_setup_execution
732
733 if has "${EAPI:-0}" 0 1 2 3; then
734 python_execute_function -d -s -- "$@"
735 else
736 python_installation() {
737 emake DESTDIR="${T}/images/${PYTHON_ABI}" install "$@"
738 }
739 python_execute_function -s python_installation "$@"
740 unset python_installation
741
742 python_merge_intermediate_installation_images "${T}/images"
743 fi
744 }
745
618 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then 746 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
619 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install 747 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
620 fi 748 fi
621fi 749fi
622 750
623if has "${EAPI:-0}" 0 1 2 3; then
624 unset PYTHON_ABIS 751unset PYTHON_ABIS
625fi
626 752
627_python_calculate_PYTHON_ABIS() { 753_python_calculate_PYTHON_ABIS() {
628 if ! _python_package_supporting_installation_for_multiple_python_abis; then 754 if ! _python_package_supporting_installation_for_multiple_python_abis; then
629 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 755 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
630 fi 756 fi
631 757
632 _python_initial_sanity_checks 758 _python_initial_sanity_checks
633 759
634 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3; then 760 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]]; then
635 local PYTHON_ABI restricted_ABI restricted_ABIs support_ABI supported_PYTHON_ABIS 761 local PYTHON_ABI
636
637 restricted_ABIs="${RESTRICT_PYTHON_ABIS// /$'\n'}"
638 762
639 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then 763 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
640 local cpython_enabled="0" 764 local cpython_enabled="0"
641 765
642 if [[ -z "${USE_PYTHON}" ]]; then 766 if [[ -z "${USE_PYTHON}" ]]; then
650 774
651 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then 775 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then
652 cpython_enabled="1" 776 cpython_enabled="1"
653 fi 777 fi
654 778
655 support_ABI="1"
656 while read restricted_ABI; do
657 if _python_check_python_abi_matching "${PYTHON_ABI}" "${restricted_ABI}"; then 779 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
658 support_ABI="0" 780 export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
659 break
660 fi 781 fi
661 done <<< "${restricted_ABIs}"
662 [[ "${support_ABI}" == "1" ]] && export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
663 done 782 done
664 783
665 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then 784 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
666 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}" 785 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
667 fi 786 fi
668 787
669 if [[ "${cpython_enabled}" == "0" ]]; then 788 if [[ "${cpython_enabled}" == "0" ]]; then
670 die "USE_PYTHON variable does not enable any CPython ABI" 789 die "USE_PYTHON variable does not enable any CPython ABI"
671 fi 790 fi
672 else 791 else
673 local python_version python2_version= python3_version= support_python_major_version 792 local python_version python2_version python3_version support_python_major_version
674 793
675 if ! has_version "dev-lang/python"; then 794 if ! has_version "dev-lang/python"; then
676 die "${FUNCNAME}(): 'dev-lang/python' is not installed" 795 die "${FUNCNAME}(): 'dev-lang/python' is not installed"
677 fi 796 fi
678 797
683 die "'${EPREFIX}/usr/bin/python2' is not valid symlink" 802 die "'${EPREFIX}/usr/bin/python2' is not valid symlink"
684 fi 803 fi
685 804
686 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')" 805 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
687 806
807 support_python_major_version="0"
688 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do 808 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
809 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
689 support_python_major_version="1" 810 support_python_major_version="1"
690 while read restricted_ABI; do 811 break
691 if _python_check_python_abi_matching "${PYTHON_ABI}" "${restricted_ABI}"; then
692 support_python_major_version="0"
693 fi 812 fi
694 done <<< "${restricted_ABIs}"
695 [[ "${support_python_major_version}" == "1" ]] && break
696 done 813 done
697 if [[ "${support_python_major_version}" == "1" ]]; then 814 if [[ "${support_python_major_version}" == "1" ]]; then
698 while read restricted_ABI; do
699 if _python_check_python_abi_matching "${python2_version}" "${restricted_ABI}"; then 815 if _python_check_python_abi_matching --patterns-list "${python2_version}" "${RESTRICT_PYTHON_ABIS}"; then
700 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}" 816 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}"
701 fi 817 fi
702 done <<< "${restricted_ABIs}"
703 else 818 else
704 python2_version="" 819 python2_version=""
705 fi 820 fi
706 fi 821 fi
707 822
710 die "'${EPREFIX}/usr/bin/python3' is not valid symlink" 825 die "'${EPREFIX}/usr/bin/python3' is not valid symlink"
711 fi 826 fi
712 827
713 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')" 828 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
714 829
830 support_python_major_version="0"
715 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do 831 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
832 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
716 support_python_major_version="1" 833 support_python_major_version="1"
717 while read restricted_ABI; do 834 break
718 if _python_check_python_abi_matching "${PYTHON_ABI}" "${restricted_ABI}"; then
719 support_python_major_version="0"
720 fi 835 fi
721 done <<< "${restricted_ABIs}"
722 [[ "${support_python_major_version}" == "1" ]] && break
723 done 836 done
724 if [[ "${support_python_major_version}" == "1" ]]; then 837 if [[ "${support_python_major_version}" == "1" ]]; then
725 while read restricted_ABI; do
726 if _python_check_python_abi_matching "${python3_version}" "${restricted_ABI}"; then 838 if _python_check_python_abi_matching --patterns-list "${python3_version}" "${RESTRICT_PYTHON_ABIS}"; then
727 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}" 839 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
728 fi 840 fi
729 done <<< "${restricted_ABIs}"
730 else 841 else
731 python3_version="" 842 python3_version=""
732 fi 843 fi
844 fi
845
846 if [[ -z "${python2_version}" && -z "${python3_version}" ]]; then
847 eerror "${CATEGORY}/${PF} requires at least one of the following packages:"
848 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
849 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
850 eerror " dev-lang/python:${PYTHON_ABI}"
851 fi
852 done
853 die "No supported version of CPython installed"
733 fi 854 fi
734 855
735 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then 856 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
736 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink" 857 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
737 eerror "is set incorrectly. Use \`eselect python\` to fix configuration." 858 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
759 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\"" 880 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\""
760 for prefix in PYTHON_USER_ PYTHON_; do 881 for prefix in PYTHON_USER_ PYTHON_; do
761 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then 882 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then
762 eval "array=(\"\${${prefix}${variable}[@]}\")" 883 eval "array=(\"\${${prefix}${variable}[@]}\")"
763 for element in "${array[@]}"; do 884 for element in "${array[@]}"; do
764 if [[ "${element}" =~ ^([[:alnum:]]|\.|-|\*|\[|\])+\ (\+|-)\ .+ ]]; then 885 if [[ "${element}" =~ ^${_PYTHON_ABI_PATTERN_REGEX}\ (\+|-)\ .+ ]]; then
765 pattern="${element%% *}" 886 pattern="${element%% *}"
766 element="${element#* }" 887 element="${element#* }"
767 operator="${element%% *}" 888 operator="${element%% *}"
768 flags="${element#* }" 889 flags="${element#* }"
769 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then 890 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
808# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments] 929# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments]
809# @DESCRIPTION: 930# @DESCRIPTION:
810# Execute specified function for each value of PYTHON_ABIS, optionally passing additional 931# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
811# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables. 932# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
812python_execute_function() { 933python_execute_function() {
813 _python_check_python_pkg_setup_execution
814
815 if ! _python_package_supporting_installation_for_multiple_python_abis; then 934 if ! _python_package_supporting_installation_for_multiple_python_abis; then
816 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 935 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
817 fi 936 fi
818 937
938 _python_check_python_pkg_setup_execution
819 _python_set_color_variables 939 _python_set_color_variables
820 940
821 local action action_message action_message_template= default_function="0" failure_message failure_message_template= final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir= 941 local action action_message action_message_template default_function="0" failure_message failure_message_template final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir
822 942
823 while (($#)); do 943 while (($#)); do
824 case "$1" in 944 case "$1" in
825 --action-message) 945 --action-message)
826 action_message_template="$2" 946 action_message_template="$2"
896 python_default_function() { 1016 python_default_function() {
897 emake "$@" 1017 emake "$@"
898 } 1018 }
899 elif [[ "${EBUILD_PHASE}" == "test" ]]; then 1019 elif [[ "${EBUILD_PHASE}" == "test" ]]; then
900 python_default_function() { 1020 python_default_function() {
1021 # Stolen from portage's _eapi0_src_test()
1022 local emake_cmd="${MAKE:-make} ${MAKEOPTS} ${EXTRA_EMAKE}"
901 if emake -j1 -n check &> /dev/null; then 1023 if ${emake_cmd} -j1 -n check &> /dev/null; then
902 emake -j1 check "$@" 1024 ${emake_cmd} -j1 check "$@"
903 elif emake -j1 -n test &> /dev/null; then 1025 elif ${emake_cmd} -j1 -n test &> /dev/null; then
904 emake -j1 test "$@" 1026 ${emake_cmd} -j1 test "$@"
905 fi 1027 fi
906 } 1028 }
907 elif [[ "${EBUILD_PHASE}" == "install" ]]; then 1029 elif [[ "${EBUILD_PHASE}" == "install" ]]; then
908 python_default_function() { 1030 python_default_function() {
909 emake DESTDIR="${D}" install "$@" 1031 emake DESTDIR="${D}" install "$@"
938 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)" 1060 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)"
939 else 1061 else
940 iterated_PYTHON_ABIS="${PYTHON_ABIS}" 1062 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
941 fi 1063 fi
942 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do 1064 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1065 if [[ "${EBUILD_PHASE}" == "test" ]] && _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${PYTHON_TESTS_RESTRICTED_ABIS}"; then
1066 if [[ "${quiet}" == "0" ]]; then
1067 echo " ${_GREEN}*${_NORMAL} ${_BLUE}Testing of ${CATEGORY}/${PF} with $(python_get_implementation_and_version) skipped${_NORMAL}"
1068 fi
1069 continue
1070 fi
1071
943 _python_prepare_flags 1072 _python_prepare_flags
944 1073
945 if [[ "${quiet}" == "0" ]]; then 1074 if [[ "${quiet}" == "0" ]]; then
946 if [[ -n "${action_message_template}" ]]; then 1075 if [[ -n "${action_message_template}" ]]; then
947 eval "action_message=\"${action_message_template}\"" 1076 eval "action_message=\"${action_message_template}\""
948 else 1077 else
949 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation) $(python_get_version)..." 1078 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation_and_version)..."
950 fi 1079 fi
951 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}" 1080 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}"
952 fi 1081 fi
953 1082
954 if [[ "${separate_build_dirs}" == "1" ]]; then 1083 if [[ "${separate_build_dirs}" == "1" ]]; then
978 1107
979 if [[ "${return_code}" -ne 0 ]]; then 1108 if [[ "${return_code}" -ne 0 ]]; then
980 if [[ -n "${failure_message_template}" ]]; then 1109 if [[ -n "${failure_message_template}" ]]; then
981 eval "failure_message=\"${failure_message_template}\"" 1110 eval "failure_message=\"${failure_message_template}\""
982 else 1111 else
983 failure_message="${action} failed with $(python_get_implementation) $(python_get_version) in ${function}() function" 1112 failure_message="${action} failed with $(python_get_implementation_and_version) in ${function}() function"
984 fi 1113 fi
985 1114
986 if [[ "${nonfatal}" == "1" ]]; then 1115 if [[ "${nonfatal}" == "1" ]]; then
987 if [[ "${quiet}" == "0" ]]; then 1116 if [[ "${quiet}" == "0" ]]; then
988 ewarn "${failure_message}" 1117 ewarn "${failure_message}"
1041# @FUNCTION: python_copy_sources 1170# @FUNCTION: python_copy_sources
1042# @USAGE: <directory="${S}"> [directory] 1171# @USAGE: <directory="${S}"> [directory]
1043# @DESCRIPTION: 1172# @DESCRIPTION:
1044# Copy unpacked sources of current package to separate build directory for each Python ABI. 1173# Copy unpacked sources of current package to separate build directory for each Python ABI.
1045python_copy_sources() { 1174python_copy_sources() {
1046 _python_check_python_pkg_setup_execution
1047
1048 if ! _python_package_supporting_installation_for_multiple_python_abis; then 1175 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1049 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 1176 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1050 fi 1177 fi
1178
1179 _python_check_python_pkg_setup_execution
1051 1180
1052 local dir dirs=() PYTHON_ABI 1181 local dir dirs=() PYTHON_ABI
1053 1182
1054 if [[ "$#" -eq 0 ]]; then 1183 if [[ "$#" -eq 0 ]]; then
1055 if [[ "${WORKDIR}" == "${S}" ]]; then 1184 if [[ "${WORKDIR}" == "${S}" ]]; then
1072# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files] 1201# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files]
1073# @DESCRIPTION: 1202# @DESCRIPTION:
1074# Generate wrapper scripts. Existing files are overwritten only with --force option. 1203# Generate wrapper scripts. Existing files are overwritten only with --force option.
1075# If --respect-EPYTHON option is specified, then generated wrapper scripts will 1204# If --respect-EPYTHON option is specified, then generated wrapper scripts will
1076# respect EPYTHON variable at run time. 1205# respect EPYTHON variable at run time.
1206#
1207# This function can be used only in src_install() phase.
1077python_generate_wrapper_scripts() { 1208python_generate_wrapper_scripts() {
1078 _python_check_python_pkg_setup_execution 1209 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1210 die "${FUNCNAME}() can be used only in src_install() phase"
1211 fi
1079 1212
1080 if ! _python_package_supporting_installation_for_multiple_python_abis; then 1213 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1081 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 1214 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1082 fi 1215 fi
1083 1216
1217 _python_check_python_pkg_setup_execution
1084 _python_initialize_prefix_variables 1218 _python_initialize_prefix_variables
1085 1219
1086 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0" 1220 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0"
1087 1221
1088 while (($#)); do 1222 while (($#)); do
1154import os 1288import os
1155import re 1289import re
1156import subprocess 1290import subprocess
1157import sys 1291import sys
1158 1292
1159cpython_re = re.compile(r"^python(\d+\.\d+)$") 1293cpython_ABI_re = re.compile(r"^(\d+\.\d+)$")
1294jython_ABI_re = re.compile(r"^(\d+\.\d+)-jython$")
1295pypy_ABI_re = re.compile(r"^\d+\.\d+-pypy-(\d+\.\d+)$")
1296cpython_interpreter_re = re.compile(r"^python(\d+\.\d+)$")
1160jython_re = re.compile(r"^jython(\d+\.\d+)$") 1297jython_interpreter_re = re.compile(r"^jython(\d+\.\d+)$")
1298pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$")
1161python_shebang_re = re.compile(r"^#! *(${EPREFIX}/usr/bin/python|(${EPREFIX})?/usr/bin/env +(${EPREFIX}/usr/bin/)?python)") 1299cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)")
1300python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)")
1162python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$") 1301python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1163 1302
1164def get_PYTHON_ABI(EPYTHON): 1303pypy_versions_mapping = {
1165 cpython_matched = cpython_re.match(EPYTHON) 1304 "1.5": "2.7",
1166 jython_matched = jython_re.match(EPYTHON) 1305 "1.6": "2.7",
1306 "1.7": "2.7",
1307 "1.8": "2.7",
1308 "1.9": "2.7",
1309}
1310
1311def get_PYTHON_ABI(python_interpreter):
1312 cpython_matched = cpython_interpreter_re.match(python_interpreter)
1313 jython_matched = jython_interpreter_re.match(python_interpreter)
1314 pypy_matched = pypy_interpreter_re.match(python_interpreter)
1167 if cpython_matched is not None: 1315 if cpython_matched is not None:
1168 PYTHON_ABI = cpython_matched.group(1) 1316 PYTHON_ABI = cpython_matched.group(1)
1169 elif jython_matched is not None: 1317 elif jython_matched is not None:
1170 PYTHON_ABI = jython_matched.group(1) + "-jython" 1318 PYTHON_ABI = jython_matched.group(1) + "-jython"
1319 elif pypy_matched is not None:
1320 PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1)
1171 else: 1321 else:
1172 PYTHON_ABI = None 1322 PYTHON_ABI = None
1173 return PYTHON_ABI 1323 return PYTHON_ABI
1174 1324
1325def get_python_interpreter(PYTHON_ABI):
1326 cpython_matched = cpython_ABI_re.match(PYTHON_ABI)
1327 jython_matched = jython_ABI_re.match(PYTHON_ABI)
1328 pypy_matched = pypy_ABI_re.match(PYTHON_ABI)
1329 if cpython_matched is not None:
1330 python_interpreter = "python" + cpython_matched.group(1)
1331 elif jython_matched is not None:
1332 python_interpreter = "jython" + jython_matched.group(1)
1333 elif pypy_matched is not None:
1334 python_interpreter = "pypy-c" + pypy_matched.group(1)
1335 else:
1336 python_interpreter = None
1337 return python_interpreter
1338
1175EOF 1339EOF
1176 if [[ "$?" != "0" ]]; then 1340 if [[ "$?" != "0" ]]; then
1177 die "${FUNCNAME}(): Generation of '$1' failed" 1341 die "${FUNCNAME}(): Generation of '$1' failed"
1178 fi 1342 fi
1179 if [[ "${respect_EPYTHON}" == "1" ]]; then 1343 if [[ "${respect_EPYTHON}" == "1" ]]; then
1180 cat << EOF >> "${file}" 1344 cat << EOF >> "${file}"
1181EPYTHON = os.environ.get("EPYTHON") 1345python_interpreter = os.environ.get("EPYTHON")
1182if EPYTHON: 1346if python_interpreter:
1183 PYTHON_ABI = get_PYTHON_ABI(EPYTHON) 1347 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1184 if PYTHON_ABI is None: 1348 if PYTHON_ABI is None:
1185 sys.stderr.write("EPYTHON variable has unrecognized value '%s'\n" % EPYTHON) 1349 sys.stderr.write("%s: EPYTHON variable has unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1186 sys.exit(1) 1350 sys.exit(1)
1187else: 1351else:
1188 try: 1352 try:
1353 environment = os.environ.copy()
1354 environment["ROOT"] = "/"
1189 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], stdout=subprocess.PIPE) 1355 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1190 if eselect_process.wait() != 0: 1356 if eselect_process.wait() != 0:
1191 raise ValueError 1357 raise ValueError
1192 except (OSError, ValueError): 1358 except (OSError, ValueError):
1193 sys.stderr.write("Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n") 1359 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1194 sys.exit(1) 1360 sys.exit(1)
1195 1361
1196 EPYTHON = eselect_process.stdout.read() 1362 python_interpreter = eselect_process.stdout.read()
1197 if not isinstance(EPYTHON, str): 1363 if not isinstance(python_interpreter, str):
1198 # Python 3 1364 # Python 3
1199 EPYTHON = EPYTHON.decode() 1365 python_interpreter = python_interpreter.decode()
1200 EPYTHON = EPYTHON.rstrip("\n") 1366 python_interpreter = python_interpreter.rstrip("\n")
1201 1367
1202 PYTHON_ABI = get_PYTHON_ABI(EPYTHON) 1368 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1203 if PYTHON_ABI is None: 1369 if PYTHON_ABI is None:
1204 sys.stderr.write("'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % EPYTHON) 1370 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1205 sys.exit(1) 1371 sys.exit(1)
1206 1372
1207wrapper_script_path = os.path.realpath(sys.argv[0]) 1373wrapper_script_path = os.path.realpath(sys.argv[0])
1208target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI) 1374target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1209if not os.path.exists(target_executable_path): 1375if not os.path.exists(target_executable_path):
1210 sys.stderr.write("'%s' does not exist\n" % target_executable_path) 1376 sys.stderr.write("%s: '%s' does not exist\n" % (sys.argv[0], target_executable_path))
1211 sys.exit(1) 1377 sys.exit(1)
1212EOF 1378EOF
1213 if [[ "$?" != "0" ]]; then 1379 if [[ "$?" != "0" ]]; then
1214 die "${FUNCNAME}(): Generation of '$1' failed" 1380 die "${FUNCNAME}(): Generation of '$1' failed"
1215 fi 1381 fi
1216 else 1382 else
1217 cat << EOF >> "${file}" 1383 cat << EOF >> "${file}"
1218try: 1384try:
1385 environment = os.environ.copy()
1386 environment["ROOT"] = "/"
1219 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], stdout=subprocess.PIPE) 1387 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1220 if eselect_process.wait() != 0: 1388 if eselect_process.wait() != 0:
1221 raise ValueError 1389 raise ValueError
1222except (OSError, ValueError): 1390except (OSError, ValueError):
1223 sys.stderr.write("Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n") 1391 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1224 sys.exit(1) 1392 sys.exit(1)
1225 1393
1226EPYTHON = eselect_process.stdout.read() 1394python_interpreter = eselect_process.stdout.read()
1227if not isinstance(EPYTHON, str): 1395if not isinstance(python_interpreter, str):
1228 # Python 3 1396 # Python 3
1229 EPYTHON = EPYTHON.decode() 1397 python_interpreter = python_interpreter.decode()
1230EPYTHON = EPYTHON.rstrip("\n") 1398python_interpreter = python_interpreter.rstrip("\n")
1231 1399
1232PYTHON_ABI = get_PYTHON_ABI(EPYTHON) 1400PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1233if PYTHON_ABI is None: 1401if PYTHON_ABI is None:
1234 sys.stderr.write("'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % EPYTHON) 1402 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1235 sys.exit(1) 1403 sys.exit(1)
1236 1404
1237wrapper_script_path = os.path.realpath(sys.argv[0]) 1405wrapper_script_path = os.path.realpath(sys.argv[0])
1238for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]: 1406for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]:
1239 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI) 1407 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1240 if os.path.exists(target_executable_path): 1408 if os.path.exists(target_executable_path):
1241 break 1409 break
1242else: 1410else:
1243 sys.stderr.write("No target script exists for '%s'\n" % wrapper_script_path) 1411 sys.stderr.write("%s: No target script exists for '%s'\n" % (sys.argv[0], wrapper_script_path))
1412 sys.exit(1)
1413
1414python_interpreter = get_python_interpreter(PYTHON_ABI)
1415if python_interpreter is None:
1416 sys.stderr.write("%s: Unrecognized Python ABI '%s'\n" % (sys.argv[0], PYTHON_ABI))
1244 sys.exit(1) 1417 sys.exit(1)
1245EOF 1418EOF
1246 if [[ "$?" != "0" ]]; then 1419 if [[ "$?" != "0" ]]; then
1247 die "${FUNCNAME}(): Generation of '$1' failed" 1420 die "${FUNCNAME}(): Generation of '$1' failed"
1248 fi 1421 fi
1249 fi 1422 fi
1250 cat << EOF >> "${file}" 1423 cat << EOF >> "${file}"
1251 1424
1252target_executable = open(target_executable_path, "rb") 1425target_executable = open(target_executable_path, "rb")
1253target_executable_first_line = target_executable.readline() 1426target_executable_first_line = target_executable.readline()
1427target_executable.close()
1254if not isinstance(target_executable_first_line, str): 1428if not isinstance(target_executable_first_line, str):
1255 # Python 3 1429 # Python 3
1256 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace") 1430 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace")
1257 1431
1432options = []
1433python_shebang_options_matched = python_shebang_options_re.match(target_executable_first_line)
1434if python_shebang_options_matched is not None:
1435 options = [python_shebang_options_matched.group(1)]
1436
1258python_shebang_matched = python_shebang_re.match(target_executable_first_line) 1437cpython_shebang_matched = cpython_shebang_re.match(target_executable_first_line)
1259target_executable.close()
1260 1438
1261if python_shebang_matched is not None: 1439if cpython_shebang_matched is not None:
1262 try: 1440 try:
1263 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % EPYTHON 1441 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % python_interpreter
1264 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1" 1442 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1"
1265 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE) 1443 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE)
1266 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] 1444 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"]
1267 if python_verification_process.wait() != 0: 1445 if python_verification_process.wait() != 0:
1268 raise ValueError 1446 raise ValueError
1273 python_verification_output = python_verification_output.decode() 1451 python_verification_output = python_verification_output.decode()
1274 1452
1275 if not python_verification_output_re.match(python_verification_output): 1453 if not python_verification_output_re.match(python_verification_output):
1276 raise ValueError 1454 raise ValueError
1277 1455
1278 if cpython_re.match(EPYTHON) is not None: 1456 if cpython_interpreter_re.match(python_interpreter) is not None:
1279 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0]) 1457 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0])
1280 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0] 1458 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0]
1281 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path 1459 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path
1282 1460
1283 if hasattr(os, "execv"): 1461 if hasattr(os, "execv"):
1284 os.execv(python_interpreter_path, [python_interpreter_path] + sys.argv) 1462 os.execv(python_interpreter_path, [python_interpreter_path] + options + sys.argv)
1285 else: 1463 else:
1286 sys.exit(subprocess.Popen([python_interpreter_path] + sys.argv).wait()) 1464 sys.exit(subprocess.Popen([python_interpreter_path] + options + sys.argv).wait())
1287 except (KeyboardInterrupt, SystemExit): 1465 except (KeyboardInterrupt, SystemExit):
1288 raise 1466 raise
1289 except: 1467 except:
1290 pass 1468 pass
1291 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"): 1469 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"):
1319 1497
1320# @FUNCTION: python_merge_intermediate_installation_images 1498# @FUNCTION: python_merge_intermediate_installation_images
1321# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory> 1499# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory>
1322# @DESCRIPTION: 1500# @DESCRIPTION:
1323# Merge intermediate installation images into installation image. 1501# Merge intermediate installation images into installation image.
1502#
1503# This function can be used only in src_install() phase.
1324python_merge_intermediate_installation_images() { 1504python_merge_intermediate_installation_images() {
1505 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1506 die "${FUNCNAME}() can be used only in src_install() phase"
1507 fi
1508
1509 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1510 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1511 fi
1512
1325 _python_check_python_pkg_setup_execution 1513 _python_check_python_pkg_setup_execution
1326 _python_initialize_prefix_variables 1514 _python_initialize_prefix_variables
1327 1515
1328 local b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=() 1516 local absolute_file b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=()
1329
1330 # Check if phase is src_install().
1331 [[ "${EBUILD_PHASE}" != "install" ]] && die "${FUNCNAME}() can be used only in src_install() phase"
1332 1517
1333 while (($#)); do 1518 while (($#)); do
1334 case "$1" in 1519 case "$1" in
1335 -q|--quiet) 1520 -q|--quiet)
1336 quiet="1" 1521 quiet="1"
1418 break 1603 break
1419 fi 1604 fi
1420 done 1605 done
1421 fi 1606 fi
1422 1607
1423 [[ "${version_executable}" == "0" || ! -x "${file}" ]] && continue 1608 [[ "${version_executable}" == "0" ]] && continue
1424 1609
1610 if [[ -L "${file}" ]]; then
1611 absolute_file="$(readlink "${file}")"
1612 if [[ "${absolute_file}" == /* ]]; then
1613 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file##/}"
1614 else
1615 if [[ "${file}" == */* ]]; then
1616 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file%/*}/${absolute_file}"
1617 else
1618 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file}"
1619 fi
1620 fi
1621 else
1622 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file}"
1623 fi
1624
1625 [[ ! -x "${absolute_file}" ]] && continue
1626
1425 shebang="$(head -n1 "${file}")" || die "Extraction of shebang from '${file}' failed" 1627 shebang="$(head -n1 "${absolute_file}")" || die "Extraction of shebang from '${absolute_file}' failed"
1426 1628
1427 if [[ "${version_executable}" == "2" ]]; then 1629 if [[ "${version_executable}" == "2" ]]; then
1428 wrapper_scripts+=("${ED}${file}") 1630 wrapper_scripts+=("${ED}${file}")
1429 elif [[ "${version_executable}" == "1" ]]; then 1631 elif [[ "${version_executable}" == "1" ]]; then
1430 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then 1632 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then
1441 fi 1643 fi
1442 1644
1443 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed" 1645 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed"
1444 1646
1445 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then 1647 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then
1648 if [[ -L "${file}-${PYTHON_ABI}" ]]; then
1649 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${absolute_file}"
1650 else
1446 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}" 1651 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}"
1652 fi
1447 fi 1653 fi
1448 done 1654 done
1449 1655
1450 popd > /dev/null || die "popd failed" 1656 popd > /dev/null || die "popd failed"
1451 1657
1658 # This is per bug #390691, without the duplication refactor, and with
1659 # the 3-way structure per comment #6. This enable users with old
1660 # coreutils to upgrade a lot easier (you need to upgrade python+portage
1661 # before coreutils can be upgraded).
1662 if ROOT="/" has_version '>=sys-apps/coreutils-6.9.90'; then
1663 cp -fr --preserve=all --no-preserve=context "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1664 elif ROOT="/" has_version sys-apps/coreutils; then
1452 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed" 1665 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1666 else
1667 cp -fpr "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1668 fi
1453 done 1669 done
1454 1670
1455 rm -fr "${intermediate_installation_images_directory}" 1671 rm -fr "${intermediate_installation_images_directory}"
1456 1672
1457 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then 1673 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then
1472 stdout = sys.stdout.buffer 1688 stdout = sys.stdout.buffer
1473else: 1689else:
1474 # Python 2 1690 # Python 2
1475 stdout = sys.stdout 1691 stdout = sys.stdout
1476 1692
1693python_wrapper_scripts_file = open('${T}/python_wrapper_scripts', 'rb')
1477files = set(open('${T}/python_wrapper_scripts', 'rb').read().rstrip(${b}'\x00').split(${b}'\x00')) 1694files = set(python_wrapper_scripts_file.read().rstrip(${b}'\x00').split(${b}'\x00'))
1695python_wrapper_scripts_file.close()
1478 1696
1479for file in sorted(files): 1697for file in sorted(files):
1480 stdout.write(file) 1698 stdout.write(file)
1481 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts") 1699 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts")
1482 1700
1498# If 2 argument is specified, then active version of CPython 2 is used. 1716# If 2 argument is specified, then active version of CPython 2 is used.
1499# If 3 argument is specified, then active version of CPython 3 is used. 1717# If 3 argument is specified, then active version of CPython 3 is used.
1500# 1718#
1501# This function can be used only in pkg_setup() phase. 1719# This function can be used only in pkg_setup() phase.
1502python_set_active_version() { 1720python_set_active_version() {
1503 # Check if phase is pkg_setup(). 1721 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
1504 [[ "${EBUILD_PHASE}" != "setup" ]] && die "${FUNCNAME}() can be used only in pkg_setup() phase" 1722 die "${FUNCNAME}() can be used only in pkg_setup() phase"
1723 fi
1505 1724
1506 if _python_package_supporting_installation_for_multiple_python_abis; then 1725 if _python_package_supporting_installation_for_multiple_python_abis; then
1507 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs" 1726 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1508 fi 1727 fi
1509 1728
1546 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable. 1765 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable.
1547 PYTHON_REQUESTED_ACTIVE_VERSION="$1" 1766 PYTHON_REQUESTED_ACTIVE_VERSION="$1"
1548} 1767}
1549 1768
1550# @FUNCTION: python_need_rebuild 1769# @FUNCTION: python_need_rebuild
1770# @DESCRIPTION:
1551# @DESCRIPTION: Mark current package for rebuilding by python-updater after 1771# Mark current package for rebuilding by python-updater after
1552# switching of active version of Python. 1772# switching of active version of Python.
1553python_need_rebuild() { 1773python_need_rebuild() {
1554 _python_check_python_pkg_setup_execution
1555
1556 if _python_package_supporting_installation_for_multiple_python_abis; then 1774 if _python_package_supporting_installation_for_multiple_python_abis; then
1557 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs" 1775 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1558 fi 1776 fi
1777
1778 _python_check_python_pkg_setup_execution
1559 1779
1560 if [[ "$#" -ne 0 ]]; then 1780 if [[ "$#" -ne 0 ]]; then
1561 die "${FUNCNAME}() does not accept arguments" 1781 die "${FUNCNAME}() does not accept arguments"
1562 fi 1782 fi
1563 1783
1566 1786
1567# ================================================================================================ 1787# ================================================================================================
1568# ======================================= GETTER FUNCTIONS ======================================= 1788# ======================================= GETTER FUNCTIONS =======================================
1569# ================================================================================================ 1789# ================================================================================================
1570 1790
1571_PYTHON_ABI_EXTRACTION_COMMAND='import platform 1791_PYTHON_ABI_EXTRACTION_COMMAND=\
1792'import platform
1572import sys 1793import sys
1573sys.stdout.write(".".join(str(x) for x in sys.version_info[:2])) 1794sys.stdout.write(".".join(str(x) for x in sys.version_info[:2]))
1574if platform.system()[:4] == "Java": 1795if platform.system()[:4] == "Java":
1575 sys.stdout.write("-jython")' 1796 sys.stdout.write("-jython")
1797elif hasattr(platform, "python_implementation") and platform.python_implementation() == "PyPy":
1798 sys.stdout.write("-pypy-" + ".".join(str(x) for x in sys.pypy_version_info[:2]))'
1576 1799
1577_python_get_implementation() { 1800_python_get_implementation() {
1578 local ignore_invalid="0" 1801 local ignore_invalid="0"
1579 1802
1580 while (($#)); do 1803 while (($#)); do
1602 1825
1603 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then 1826 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
1604 echo "CPython" 1827 echo "CPython"
1605 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then 1828 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
1606 echo "Jython" 1829 echo "Jython"
1830 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
1831 echo "PyPy"
1607 else 1832 else
1608 if [[ "${ignore_invalid}" == "0" ]]; then 1833 if [[ "${ignore_invalid}" == "0" ]]; then
1609 die "${FUNCNAME}(): Unrecognized Python ABI '$1'" 1834 die "${FUNCNAME}(): Unrecognized Python ABI '$1'"
1610 fi 1835 fi
1611 fi 1836 fi
1674 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 1899 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1675 fi 1900 fi
1676 _python_calculate_PYTHON_ABIS 1901 _python_calculate_PYTHON_ABIS
1677 PYTHON_ABI="${PYTHON_ABIS##* }" 1902 PYTHON_ABI="${PYTHON_ABIS##* }"
1678 elif [[ "${python2}" == "1" ]]; then 1903 elif [[ "${python2}" == "1" ]]; then
1679 PYTHON_ABI="$(eselect python show --python2 --ABI)" 1904 PYTHON_ABI="$(ROOT="/" eselect python show --python2 --ABI)"
1680 if [[ -z "${PYTHON_ABI}" ]]; then 1905 if [[ -z "${PYTHON_ABI}" ]]; then
1681 die "${FUNCNAME}(): Active version of CPython 2 not set" 1906 die "${FUNCNAME}(): Active version of CPython 2 not set"
1682 elif [[ "${PYTHON_ABI}" != "2."* ]]; then 1907 elif [[ "${PYTHON_ABI}" != "2."* ]]; then
1683 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`" 1908 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`"
1684 fi 1909 fi
1685 elif [[ "${python3}" == "1" ]]; then 1910 elif [[ "${python3}" == "1" ]]; then
1686 PYTHON_ABI="$(eselect python show --python3 --ABI)" 1911 PYTHON_ABI="$(ROOT="/" eselect python show --python3 --ABI)"
1687 if [[ -z "${PYTHON_ABI}" ]]; then 1912 if [[ -z "${PYTHON_ABI}" ]]; then
1688 die "${FUNCNAME}(): Active version of CPython 3 not set" 1913 die "${FUNCNAME}(): Active version of CPython 3 not set"
1689 elif [[ "${PYTHON_ABI}" != "3."* ]]; then 1914 elif [[ "${PYTHON_ABI}" != "3."* ]]; then
1690 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`" 1915 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`"
1691 fi 1916 fi
1720 else 1945 else
1721 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then 1946 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1722 python_interpreter="python${PYTHON_ABI}" 1947 python_interpreter="python${PYTHON_ABI}"
1723 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 1948 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1724 python_interpreter="jython${PYTHON_ABI%-jython}" 1949 python_interpreter="jython${PYTHON_ABI%-jython}"
1950 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
1951 python_interpreter="pypy-c${PYTHON_ABI#*-pypy-}"
1725 fi 1952 fi
1726 1953
1727 if [[ "${absolute_path_output}" == "1" ]]; then 1954 if [[ "${absolute_path_output}" == "1" ]]; then
1728 echo -n "${EPREFIX}/usr/bin/${python_interpreter}" 1955 echo -n "${EPREFIX}/usr/bin/${python_interpreter}"
1729 else 1956 else
1822 if [[ "${EAPI:-0}" == "0" ]]; then 2049 if [[ "${EAPI:-0}" == "0" ]]; then
1823 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then 2050 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1824 echo "=dev-lang/python-${PYTHON_ABI}*" 2051 echo "=dev-lang/python-${PYTHON_ABI}*"
1825 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 2052 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1826 echo "=dev-java/jython-${PYTHON_ABI%-jython}*" 2053 echo "=dev-java/jython-${PYTHON_ABI%-jython}*"
2054 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2055 echo "=dev-python/pypy-${PYTHON_ABI#*-pypy-}*"
1827 fi 2056 fi
1828 else 2057 else
1829 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then 2058 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1830 echo "dev-lang/python:${PYTHON_ABI}" 2059 echo "dev-lang/python:${PYTHON_ABI}"
1831 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 2060 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1832 echo "dev-java/jython:${PYTHON_ABI%-jython}" 2061 echo "dev-java/jython:${PYTHON_ABI%-jython}"
2062 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2063 echo "dev-python/pypy:${PYTHON_ABI#*-pypy-}"
1833 fi 2064 fi
1834 fi 2065 fi
1835} 2066}
1836 2067
1837# @FUNCTION: python_get_includedir 2068# @FUNCTION: python_get_includedir
1884 2115
1885 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then 2116 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1886 echo "${prefix}usr/include/python${PYTHON_ABI}" 2117 echo "${prefix}usr/include/python${PYTHON_ABI}"
1887 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 2118 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1888 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include" 2119 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include"
2120 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2121 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/include"
1889 fi 2122 fi
1890} 2123}
1891 2124
1892# @FUNCTION: python_get_libdir 2125# @FUNCTION: python_get_libdir
1893# @USAGE: [-b|--base-path] [-f|--final-ABI] 2126# @USAGE: [-b|--base-path] [-f|--final-ABI]
1894# @DESCRIPTION: 2127# @DESCRIPTION:
1895# Print path to Python library directory. 2128# Print path to Python standard library directory.
1896# If --base-path option is specified, then path not prefixed with "/" is printed. 2129# If --base-path option is specified, then path not prefixed with "/" is printed.
1897# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used. 2130# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1898python_get_libdir() { 2131python_get_libdir() {
1899 _python_check_python_pkg_setup_execution 2132 _python_check_python_pkg_setup_execution
1900 2133
1939 2172
1940 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then 2173 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1941 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}" 2174 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}"
1942 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 2175 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1943 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib" 2176 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib"
2177 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2178 die "${FUNCNAME}(): PyPy has multiple standard library directories"
1944 fi 2179 fi
1945} 2180}
1946 2181
1947# @FUNCTION: python_get_sitedir 2182# @FUNCTION: python_get_sitedir
1948# @USAGE: [-b|--base-path] [-f|--final-ABI] 2183# @USAGE: [-b|--base-path] [-f|--final-ABI]
1951# If --base-path option is specified, then path not prefixed with "/" is printed. 2186# If --base-path option is specified, then path not prefixed with "/" is printed.
1952# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used. 2187# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1953python_get_sitedir() { 2188python_get_sitedir() {
1954 _python_check_python_pkg_setup_execution 2189 _python_check_python_pkg_setup_execution
1955 2190
1956 local final_ABI="0" options=() 2191 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
1957 2192
1958 while (($#)); do 2193 while (($#)); do
1959 case "$1" in 2194 case "$1" in
1960 -b|--base-path) 2195 -b|--base-path)
1961 options+=("$1") 2196 base_path="1"
1962 ;; 2197 ;;
1963 -f|--final-ABI) 2198 -f|--final-ABI)
1964 final_ABI="1" 2199 final_ABI="1"
1965 options+=("$1")
1966 ;; 2200 ;;
1967 -*) 2201 -*)
1968 die "${FUNCNAME}(): Unrecognized option '$1'" 2202 die "${FUNCNAME}(): Unrecognized option '$1'"
1969 ;; 2203 ;;
1970 *) 2204 *)
1971 die "${FUNCNAME}(): Invalid usage" 2205 die "${FUNCNAME}(): Invalid usage"
1972 ;; 2206 ;;
1973 esac 2207 esac
1974 shift 2208 shift
1975 done 2209 done
2210
2211 if [[ "${base_path}" == "0" ]]; then
2212 prefix="/"
2213 fi
1976 2214
1977 if [[ "${final_ABI}" == "1" ]]; then 2215 if [[ "${final_ABI}" == "1" ]]; then
1978 if ! _python_package_supporting_installation_for_multiple_python_abis; then 2216 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1979 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 2217 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1980 fi 2218 fi
2219 PYTHON_ABI="$(PYTHON -f --ABI)"
1981 else 2220 else
1982 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then 2221 if _python_package_supporting_installation_for_multiple_python_abis; then
2222 if ! _python_abi-specific_local_scope; then
1983 die "${FUNCNAME}() should be used in ABI-specific local scope" 2223 die "${FUNCNAME}() should be used in ABI-specific local scope"
1984 fi 2224 fi
2225 else
2226 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
1985 fi 2227 fi
2228 fi
1986 2229
1987 echo "$(python_get_libdir "${options[@]}")/site-packages" 2230 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2231 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}/site-packages"
2232 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2233 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib/site-packages"
2234 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2235 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/site-packages"
2236 fi
1988} 2237}
1989 2238
1990# @FUNCTION: python_get_library 2239# @FUNCTION: python_get_library
1991# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option] 2240# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option]
1992# @DESCRIPTION: 2241# @DESCRIPTION:
2049 else 2298 else
2050 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)" 2299 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)"
2051 fi 2300 fi
2052 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then 2301 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2053 die "${FUNCNAME}(): Jython does not have shared library" 2302 die "${FUNCNAME}(): Jython does not have shared library"
2303 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2304 die "${FUNCNAME}(): PyPy does not have shared library"
2054 fi 2305 fi
2055} 2306}
2056 2307
2057# @FUNCTION: python_get_version 2308# @FUNCTION: python_get_version
2058# @USAGE: [-f|--final-ABI] [--full] [--major] [--minor] [--micro] 2309# @USAGE: [-f|--final-ABI] [-l|--language] [--full] [--major] [--minor] [--micro]
2059# @DESCRIPTION: 2310# @DESCRIPTION:
2060# Print Python version. 2311# Print version of Python implementation.
2061# --full, --major, --minor and --micro options cannot be specified simultaneously. 2312# --full, --major, --minor and --micro options cannot be specified simultaneously.
2062# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed. 2313# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed.
2314# If --language option is specified, then version of Python language is printed.
2315# --language and --full options cannot be specified simultaneously.
2316# --language and --micro options cannot be specified simultaneously.
2063# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used. 2317# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2064python_get_version() { 2318python_get_version() {
2065 _python_check_python_pkg_setup_execution 2319 _python_check_python_pkg_setup_execution
2066 2320
2067 local final_ABI="0" full="0" major="0" minor="0" micro="0" python_command 2321 local final_ABI="0" language="0" language_version full="0" major="0" minor="0" micro="0" PYTHON_ABI="${PYTHON_ABI}" python_command
2068 2322
2069 while (($#)); do 2323 while (($#)); do
2070 case "$1" in 2324 case "$1" in
2071 -f|--final-ABI) 2325 -f|--final-ABI)
2072 final_ABI="1" 2326 final_ABI="1"
2073 ;; 2327 ;;
2328 -l|--language)
2329 language="1"
2330 ;;
2074 --full) 2331 --full)
2075 full="1" 2332 full="1"
2076 ;; 2333 ;;
2077 --major) 2334 --major)
2078 major="1" 2335 major="1"
2090 die "${FUNCNAME}(): Invalid usage" 2347 die "${FUNCNAME}(): Invalid usage"
2091 ;; 2348 ;;
2092 esac 2349 esac
2093 shift 2350 shift
2094 done 2351 done
2095
2096 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2097 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2098 fi
2099
2100 if [[ "${full}" == "1" ]]; then
2101 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:3]))"
2102 elif [[ "${major}" == "1" ]]; then
2103 python_command="from sys import version_info; print(version_info[0])"
2104 elif [[ "${minor}" == "1" ]]; then
2105 python_command="from sys import version_info; print(version_info[1])"
2106 elif [[ "${micro}" == "1" ]]; then
2107 python_command="from sys import version_info; print(version_info[2])"
2108 else
2109 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2110 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2111 echo "${PYTHON_ABI}"
2112 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2113 echo "${PYTHON_ABI%-jython}"
2114 fi
2115 return
2116 fi
2117 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2118 fi
2119 2352
2120 if [[ "${final_ABI}" == "1" ]]; then 2353 if [[ "${final_ABI}" == "1" ]]; then
2121 if ! _python_package_supporting_installation_for_multiple_python_abis; then 2354 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2122 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 2355 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2123 fi 2356 fi
2124 "$(PYTHON -f)" -c "${python_command}"
2125 else 2357 else
2126 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then 2358 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2127 die "${FUNCNAME}() should be used in ABI-specific local scope" 2359 die "${FUNCNAME}() should be used in ABI-specific local scope"
2128 fi 2360 fi
2361 fi
2362
2363 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2364 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2365 fi
2366
2367 if [[ "${language}" == "1" ]]; then
2368 if [[ "${final_ABI}" == "1" ]]; then
2369 PYTHON_ABI="$(PYTHON -f --ABI)"
2370 elif [[ -z "${PYTHON_ABI}" ]]; then
2371 PYTHON_ABI="$(PYTHON --ABI)"
2372 fi
2373 language_version="${PYTHON_ABI%%-*}"
2374 if [[ "${full}" == "1" ]]; then
2375 die "${FUNCNAME}(): '--language' and '--full' options cannot be specified simultaneously"
2376 elif [[ "${major}" == "1" ]]; then
2377 echo "${language_version%.*}"
2378 elif [[ "${minor}" == "1" ]]; then
2379 echo "${language_version#*.}"
2380 elif [[ "${micro}" == "1" ]]; then
2381 die "${FUNCNAME}(): '--language' and '--micro' options cannot be specified simultaneously"
2382 else
2383 echo "${language_version}"
2384 fi
2385 else
2386 if [[ "${full}" == "1" ]]; then
2387 python_command="import sys; print('.'.join(str(x) for x in getattr(sys, 'pypy_version_info', sys.version_info)[:3]))"
2388 elif [[ "${major}" == "1" ]]; then
2389 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[0])"
2390 elif [[ "${minor}" == "1" ]]; then
2391 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[1])"
2392 elif [[ "${micro}" == "1" ]]; then
2393 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[2])"
2394 else
2395 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2396 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2397 echo "${PYTHON_ABI}"
2398 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2399 echo "${PYTHON_ABI%-jython}"
2400 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2401 echo "${PYTHON_ABI#*-pypy-}"
2402 fi
2403 return
2404 fi
2405 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2406 fi
2407
2408 if [[ "${final_ABI}" == "1" ]]; then
2409 "$(PYTHON -f)" -c "${python_command}"
2410 else
2129 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}" 2411 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}"
2412 fi
2413 fi
2414}
2415
2416# @FUNCTION: python_get_implementation_and_version
2417# @USAGE: [-f|--final-ABI]
2418# @DESCRIPTION:
2419# Print name and version of Python implementation.
2420# If version of Python implementation is not bound to version of Python language, then
2421# version of Python language is additionally printed.
2422# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2423python_get_implementation_and_version() {
2424 _python_check_python_pkg_setup_execution
2425
2426 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2427
2428 while (($#)); do
2429 case "$1" in
2430 -f|--final-ABI)
2431 final_ABI="1"
2432 ;;
2433 -*)
2434 die "${FUNCNAME}(): Unrecognized option '$1'"
2435 ;;
2436 *)
2437 die "${FUNCNAME}(): Invalid usage"
2438 ;;
2439 esac
2440 shift
2441 done
2442
2443 if [[ "${final_ABI}" == "1" ]]; then
2444 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2445 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2446 fi
2447 PYTHON_ABI="$(PYTHON -f --ABI)"
2448 else
2449 if _python_package_supporting_installation_for_multiple_python_abis; then
2450 if ! _python_abi-specific_local_scope; then
2451 die "${FUNCNAME}() should be used in ABI-specific local scope"
2452 fi
2453 else
2454 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2455 fi
2456 fi
2457
2458 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-[[:alnum:]]+-[[:digit:]]+\.[[:digit:]]+$ ]]; then
2459 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI##*-} (Python ${PYTHON_ABI%%-*})"
2460 else
2461 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI%%-*}"
2130 fi 2462 fi
2131} 2463}
2132 2464
2133# ================================================================================================ 2465# ================================================================================================
2134# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================ 2466# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================
2143_python_test_hook() { 2475_python_test_hook() {
2144 if [[ "$#" -ne 1 ]]; then 2476 if [[ "$#" -ne 1 ]]; then
2145 die "${FUNCNAME}() requires 1 argument" 2477 die "${FUNCNAME}() requires 1 argument"
2146 fi 2478 fi
2147 2479
2148 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${FUNCNAME[3]}_$1_hook")" == "function" ]]; then 2480 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${_PYTHON_TEST_FUNCTION}_$1_hook")" == "function" ]]; then
2149 "${FUNCNAME[3]}_$1_hook" 2481 "${_PYTHON_TEST_FUNCTION}_$1_hook"
2150 fi 2482 fi
2151} 2483}
2152 2484
2153# @FUNCTION: python_execute_nosetests 2485# @FUNCTION: python_execute_nosetests
2154# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments] 2486# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2158# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined. 2490# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined.
2159python_execute_nosetests() { 2491python_execute_nosetests() {
2160 _python_check_python_pkg_setup_execution 2492 _python_check_python_pkg_setup_execution
2161 _python_set_color_variables 2493 _python_set_color_variables
2162 2494
2163 local PYTHONPATH_template= separate_build_dirs= 2495 local PYTHONPATH_template separate_build_dirs
2164 2496
2165 while (($#)); do 2497 while (($#)); do
2166 case "$1" in 2498 case "$1" in
2167 -P|--PYTHONPATH) 2499 -P|--PYTHONPATH)
2168 PYTHONPATH_template="$2" 2500 PYTHONPATH_template="$2"
2188 python_test_function() { 2520 python_test_function() {
2189 local evaluated_PYTHONPATH 2521 local evaluated_PYTHONPATH
2190 2522
2191 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\"" 2523 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2192 2524
2193 _python_test_hook pre 2525 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook pre
2194 2526
2195 if [[ -n "${evaluated_PYTHONPATH}" ]]; then 2527 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2196 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL} 2528 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2197 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?" 2529 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2198 else 2530 else
2199 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL} 2531 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2200 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?" 2532 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2201 fi 2533 fi
2202 2534
2203 _python_test_hook post 2535 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook post
2204 } 2536 }
2205 if _python_package_supporting_installation_for_multiple_python_abis; then 2537 if _python_package_supporting_installation_for_multiple_python_abis; then
2206 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@" 2538 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2207 else 2539 else
2208 if [[ -n "${separate_build_dirs}" ]]; then 2540 if [[ -n "${separate_build_dirs}" ]]; then
2222# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined. 2554# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined.
2223python_execute_py.test() { 2555python_execute_py.test() {
2224 _python_check_python_pkg_setup_execution 2556 _python_check_python_pkg_setup_execution
2225 _python_set_color_variables 2557 _python_set_color_variables
2226 2558
2227 local PYTHONPATH_template= separate_build_dirs= 2559 local PYTHONPATH_template separate_build_dirs
2228 2560
2229 while (($#)); do 2561 while (($#)); do
2230 case "$1" in 2562 case "$1" in
2231 -P|--PYTHONPATH) 2563 -P|--PYTHONPATH)
2232 PYTHONPATH_template="$2" 2564 PYTHONPATH_template="$2"
2252 python_test_function() { 2584 python_test_function() {
2253 local evaluated_PYTHONPATH 2585 local evaluated_PYTHONPATH
2254 2586
2255 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\"" 2587 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2256 2588
2257 _python_test_hook pre 2589 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook pre
2258 2590
2259 if [[ -n "${evaluated_PYTHONPATH}" ]]; then 2591 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2260 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL} 2592 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL}
2261 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?" 2593 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?"
2262 else 2594 else
2263 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL} 2595 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL}
2264 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?" 2596 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?"
2265 fi 2597 fi
2266 2598
2267 _python_test_hook post 2599 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook post
2268 } 2600 }
2269 if _python_package_supporting_installation_for_multiple_python_abis; then 2601 if _python_package_supporting_installation_for_multiple_python_abis; then
2270 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@" 2602 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2271 else 2603 else
2272 if [[ -n "${separate_build_dirs}" ]]; then 2604 if [[ -n "${separate_build_dirs}" ]]; then
2286# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined. 2618# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined.
2287python_execute_trial() { 2619python_execute_trial() {
2288 _python_check_python_pkg_setup_execution 2620 _python_check_python_pkg_setup_execution
2289 _python_set_color_variables 2621 _python_set_color_variables
2290 2622
2291 local PYTHONPATH_template= separate_build_dirs= 2623 local PYTHONPATH_template separate_build_dirs
2292 2624
2293 while (($#)); do 2625 while (($#)); do
2294 case "$1" in 2626 case "$1" in
2295 -P|--PYTHONPATH) 2627 -P|--PYTHONPATH)
2296 PYTHONPATH_template="$2" 2628 PYTHONPATH_template="$2"
2316 python_test_function() { 2648 python_test_function() {
2317 local evaluated_PYTHONPATH 2649 local evaluated_PYTHONPATH
2318 2650
2319 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\"" 2651 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2320 2652
2321 _python_test_hook pre 2653 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook pre
2322 2654
2323 if [[ -n "${evaluated_PYTHONPATH}" ]]; then 2655 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2324 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL} 2656 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2325 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?" 2657 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2326 else 2658 else
2327 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL} 2659 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2328 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?" 2660 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2329 fi 2661 fi
2330 2662
2331 _python_test_hook post 2663 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook post
2332 } 2664 }
2333 if _python_package_supporting_installation_for_multiple_python_abis; then 2665 if _python_package_supporting_installation_for_multiple_python_abis; then
2334 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@" 2666 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2335 else 2667 else
2336 if [[ -n "${separate_build_dirs}" ]]; then 2668 if [[ -n "${separate_build_dirs}" ]]; then
2373 fi 2705 fi
2374 2706
2375 export PYTHONDONTWRITEBYTECODE="1" 2707 export PYTHONDONTWRITEBYTECODE="1"
2376} 2708}
2377 2709
2710_python_vecho() {
2711 [[ -z ${PORTAGE_VERBOSE} ]] || echo "$@"
2712}
2713
2378_python_clean_compiled_modules() { 2714_python_clean_compiled_modules() {
2379 _python_initialize_prefix_variables 2715 _python_initialize_prefix_variables
2380 _python_set_color_variables 2716 _python_set_color_variables
2381 2717
2382 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage" 2718 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage"
2395 2731
2396 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then 2732 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then
2397 # Delete empty child directories. 2733 # Delete empty child directories.
2398 find "${path}" -type d | sort -r | while read -r dir; do 2734 find "${path}" -type d | sort -r | while read -r dir; do
2399 if rmdir "${dir}" 2> /dev/null; then 2735 if rmdir "${dir}" 2> /dev/null; then
2400 echo "${_CYAN}<<< ${dir}${_NORMAL}" 2736 _python_vecho "<<< ${dir}"
2401 fi 2737 fi
2402 done 2738 done
2403 fi 2739 fi
2404 elif [[ "${path}" == *.py ]]; then 2740 elif [[ "${path}" == *.py ]]; then
2405 base_module_name="${path##*/}" 2741 base_module_name="${path##*/}"
2428 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then 2764 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2429 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue 2765 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2430 else 2766 else
2431 [[ -f "${py_file}" ]] && continue 2767 [[ -f "${py_file}" ]] && continue
2432 fi 2768 fi
2433 echo "${_BLUE}<<< ${compiled_file%[co]}[co]${_NORMAL}" 2769 _python_vecho "<<< ${compiled_file%[co]}[co]"
2434 rm -f "${compiled_file%[co]}"[co] 2770 rm -f "${compiled_file%[co]}"[co]
2435 elif [[ "${compiled_file}" == *\$py.class ]]; then 2771 elif [[ "${compiled_file}" == *\$py.class ]]; then
2436 if [[ "${dir}" == "__pycache__" ]]; then 2772 if [[ "${dir}" == "__pycache__" ]]; then
2437 base_module_name="${compiled_file##*/}" 2773 base_module_name="${compiled_file##*/}"
2438 base_module_name="${base_module_name%\$py.class}" 2774 base_module_name="${base_module_name%\$py.class}"
2443 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then 2779 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2444 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue 2780 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2445 else 2781 else
2446 [[ -f "${py_file}" ]] && continue 2782 [[ -f "${py_file}" ]] && continue
2447 fi 2783 fi
2448 echo "${_BLUE}<<< ${compiled_file}${_NORMAL}" 2784 _python_vecho "<<< ${compiled_file}"
2449 rm -f "${compiled_file}" 2785 rm -f "${compiled_file}"
2450 else 2786 else
2451 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'" 2787 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'"
2452 fi 2788 fi
2453 2789
2454 # Delete empty parent directories. 2790 # Delete empty parent directories.
2455 dir="${compiled_file%/*}" 2791 dir="${compiled_file%/*}"
2456 while [[ "${dir}" != "${root}" ]]; do 2792 while [[ "${dir}" != "${root}" ]]; do
2457 if rmdir "${dir}" 2> /dev/null; then 2793 if rmdir "${dir}" 2> /dev/null; then
2458 echo "${_CYAN}<<< ${dir}${_NORMAL}" 2794 _python_vecho "<<< ${dir}"
2459 else 2795 else
2460 break 2796 break
2461 fi 2797 fi
2462 dir="${dir%/*}" 2798 dir="${dir%/*}"
2463 done 2799 done
2471# Byte-compile specified Python modules. 2807# Byte-compile specified Python modules.
2472# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py. 2808# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py.
2473# 2809#
2474# This function can be used only in pkg_postinst() phase. 2810# This function can be used only in pkg_postinst() phase.
2475python_mod_optimize() { 2811python_mod_optimize() {
2812 if [[ "${EBUILD_PHASE}" != "postinst" ]]; then
2813 die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2814 fi
2815
2476 _python_check_python_pkg_setup_execution 2816 _python_check_python_pkg_setup_execution
2477 _python_initialize_prefix_variables 2817 _python_initialize_prefix_variables
2478 2818
2479 # Check if phase is pkg_postinst().
2480 [[ "${EBUILD_PHASE}" != "postinst" ]] && die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2481
2482 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then 2819 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2483 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs. 2820 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs.
2484 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() 2821 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() stderr stderr_line
2485 2822
2486 if _python_package_supporting_installation_for_multiple_python_abis; then 2823 if _python_package_supporting_installation_for_multiple_python_abis; then
2487 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then 2824 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
2488 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called" 2825 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2489 fi 2826 fi
2584 options+=("-q") 2921 options+=("-q")
2585 2922
2586 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do 2923 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2587 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then 2924 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then
2588 return_code="0" 2925 return_code="0"
2926 stderr=""
2589 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)" 2927 ebegin "Compilation and optimization of Python modules for $(python_get_implementation_and_version)"
2590 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then 2928 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then
2591 for dir in "${site_packages_dirs[@]}"; do 2929 for dir in "${site_packages_dirs[@]}"; do
2592 dirs+=("${root}$(python_get_sitedir)/${dir}") 2930 dirs+=("${root}$(python_get_sitedir)/${dir}")
2593 done 2931 done
2594 for dir in "${evaluated_dirs[@]}"; do 2932 for dir in "${evaluated_dirs[@]}"; do
2595 eval "dirs+=(\"\${root}${dir}\")" 2933 eval "dirs+=(\"\${root}${dir}\")"
2596 done 2934 done
2597 "$(PYTHON)" "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${dirs[@]}" || return_code="1" 2935 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m compileall "${options[@]}" "${dirs[@]}" 2>&1)" || return_code="1"
2598 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then 2936 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2599 "$(PYTHON)" -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1" 2937 "$(PYTHON)" -O -m compileall "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1"
2600 fi 2938 fi
2601 _python_clean_compiled_modules "${dirs[@]}" 2939 _python_clean_compiled_modules "${dirs[@]}"
2602 fi 2940 fi
2603 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then 2941 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then
2604 for file in "${site_packages_files[@]}"; do 2942 for file in "${site_packages_files[@]}"; do
2605 files+=("${root}$(python_get_sitedir)/${file}") 2943 files+=("${root}$(python_get_sitedir)/${file}")
2606 done 2944 done
2607 for file in "${evaluated_files[@]}"; do 2945 for file in "${evaluated_files[@]}"; do
2608 eval "files+=(\"\${root}${file}\")" 2946 eval "files+=(\"\${root}${file}\")"
2609 done 2947 done
2610 "$(PYTHON)" "${root}$(python_get_libdir)/py_compile.py" "${files[@]}" || return_code="1" 2948 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m py_compile "${files[@]}" 2>&1)" || return_code="1"
2611 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then 2949 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2612 "$(PYTHON)" -O "${root}$(python_get_libdir)/py_compile.py" "${files[@]}" &> /dev/null || return_code="1" 2950 "$(PYTHON)" -O -m py_compile "${files[@]}" &> /dev/null || return_code="1"
2613 fi 2951 fi
2614 _python_clean_compiled_modules "${files[@]}" 2952 _python_clean_compiled_modules "${files[@]}"
2615 fi 2953 fi
2616 eend "${return_code}" 2954 eend "${return_code}"
2955 if [[ -n "${stderr}" ]]; then
2956 eerror "Syntax errors / warnings in Python modules for $(python_get_implementation_and_version):" &> /dev/null
2957 while read stderr_line; do
2958 eerror " ${stderr_line}"
2959 done <<< "${stderr}"
2960 fi
2617 fi 2961 fi
2618 unset dirs files 2962 unset dirs files
2619 done 2963 done
2620 2964
2621 if _python_package_supporting_installation_for_multiple_python_abis; then 2965 if _python_package_supporting_installation_for_multiple_python_abis; then
2627 fi 2971 fi
2628 fi 2972 fi
2629 2973
2630 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then 2974 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then
2631 return_code="0" 2975 return_code="0"
2976 stderr=""
2632 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation) $(python_get_version)" 2977 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation_and_version)"
2633 if ((${#other_dirs[@]})); then 2978 if ((${#other_dirs[@]})); then
2634 "$(PYTHON ${PYTHON_ABI})" "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" || return_code="1" 2979 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m compileall "${options[@]}" "${other_dirs[@]}" 2>&1)" || return_code="1"
2635 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then 2980 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2636 "$(PYTHON ${PYTHON_ABI})" -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1" 2981 "$(PYTHON ${PYTHON_ABI})" -O -m compileall "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1"
2637 fi 2982 fi
2638 _python_clean_compiled_modules "${other_dirs[@]}" 2983 _python_clean_compiled_modules "${other_dirs[@]}"
2639 fi 2984 fi
2640 if ((${#other_files[@]})); then 2985 if ((${#other_files[@]})); then
2641 "$(PYTHON ${PYTHON_ABI})" "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" || return_code="1" 2986 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m py_compile "${other_files[@]}" 2>&1)" || return_code="1"
2642 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then 2987 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2643 "$(PYTHON ${PYTHON_ABI})" -O "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" &> /dev/null || return_code="1" 2988 "$(PYTHON ${PYTHON_ABI})" -O -m py_compile "${other_files[@]}" &> /dev/null || return_code="1"
2644 fi 2989 fi
2645 _python_clean_compiled_modules "${other_files[@]}" 2990 _python_clean_compiled_modules "${other_files[@]}"
2646 fi 2991 fi
2647 eend "${return_code}" 2992 eend "${return_code}"
2993 if [[ -n "${stderr}" ]]; then
2994 eerror "Syntax errors / warnings in Python modules placed outside of site-packages directories for $(python_get_implementation_and_version):" &> /dev/null
2995 while read stderr_line; do
2996 eerror " ${stderr_line}"
2997 done <<< "${stderr}"
2998 fi
2648 fi 2999 fi
2649 else 3000 else
2650 # Deprecated part of python_mod_optimize() 3001 # Deprecated part of python_mod_optimize()
2651 # ewarn 3002 ewarn
2652 # ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation" 3003 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
2653 # ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-06-01." 3004 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
2654 # ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax." 3005 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
2655 # ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported." 3006 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
2656 # ewarn 3007 ewarn
2657 3008
2658 local myroot mydirs=() myfiles=() myopts=() return_code="0" 3009 local myroot mydirs=() myfiles=() myopts=() return_code="0"
2659 3010
2660 # strip trailing slash 3011 # strip trailing slash
2661 myroot="${EROOT%/}" 3012 myroot="${EROOT%/}"
2730# @DESCRIPTION: 3081# @DESCRIPTION:
2731# Delete orphaned byte-compiled Python modules corresponding to specified Python modules. 3082# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
2732# 3083#
2733# This function can be used only in pkg_postrm() phase. 3084# This function can be used only in pkg_postrm() phase.
2734python_mod_cleanup() { 3085python_mod_cleanup() {
3086 if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
3087 die "${FUNCNAME}() can be used only in pkg_postrm() phase"
3088 fi
3089
2735 _python_check_python_pkg_setup_execution 3090 _python_check_python_pkg_setup_execution
2736 _python_initialize_prefix_variables 3091 _python_initialize_prefix_variables
2737 3092
2738 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir 3093 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
2739
2740 # Check if phase is pkg_postrm().
2741 [[ "${EBUILD_PHASE}" != "postrm" ]] && die "${FUNCNAME}() can be used only in pkg_postrm() phase"
2742 3094
2743 if _python_package_supporting_installation_for_multiple_python_abis; then 3095 if _python_package_supporting_installation_for_multiple_python_abis; then
2744 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then 3096 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
2745 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called" 3097 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2746 fi 3098 fi
2810 fi 3162 fi
2811 shift 3163 shift
2812 done 3164 done
2813 else 3165 else
2814 # Deprecated part of python_mod_cleanup() 3166 # Deprecated part of python_mod_cleanup()
2815 # ewarn 3167 ewarn
2816 # ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation" 3168 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
2817 # ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-06-01." 3169 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
2818 # ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax." 3170 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
2819 # ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported." 3171 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
2820 # ewarn 3172 ewarn
2821 3173
2822 search_paths=("${@#/}") 3174 search_paths=("${@#/}")
2823 search_paths=("${search_paths[@]/#/${root}/}") 3175 search_paths=("${search_paths[@]/#/${root}/}")
2824 fi 3176 fi
2825 3177
2828 3180
2829# ================================================================================================ 3181# ================================================================================================
2830# ===================================== DEPRECATED FUNCTIONS ===================================== 3182# ===================================== DEPRECATED FUNCTIONS =====================================
2831# ================================================================================================ 3183# ================================================================================================
2832 3184
2833# Scheduled for deletion on 2011-01-01. 3185fi # _PYTHON_ECLASS_INHERITED
2834python_version() {
2835 eerror "Use PYTHON() instead of python variable. Use python_get_*() instead of PYVER* variables."
2836 die "${FUNCNAME}() is banned"
2837}
2838
2839# Scheduled for deletion on 2011-01-01.
2840python_mod_exists() {
2841 eerror "Use USE dependencies and/or has_version() instead of ${FUNCNAME}()."
2842 die "${FUNCNAME}() is banned"
2843}
2844
2845# Scheduled for deletion on 2011-01-01.
2846python_tkinter_exists() {
2847 eerror "Use PYTHON_USE_WITH=\"xml\" and python_pkg_setup() instead of ${FUNCNAME}()."
2848 die "${FUNCNAME}() is banned"
2849}
2850
2851# Scheduled for deletion on 2011-04-01.
2852python_mod_compile() {
2853 eerror "Use python_mod_optimize() instead of ${FUNCNAME}()."
2854 die "${FUNCNAME}() is banned"
2855}

Legend:
Removed from v.1.108  
changed lines
  Added in v.1.161

  ViewVC Help
Powered by ViewVC 1.1.20