/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.78 Revision 1.161
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.78 2009/11/15 14:25:55 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.161 2012/11/24 21:07:14 mgorny Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# python@gentoo.org 7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: A utility eclass that should be inherited by anything that deals with Python or Python modules. 8# @BLURB: Eclass for Python packages
9# @DESCRIPTION: 9# @DESCRIPTION:
10# Some useful functions for dealing with Python. 10# The python eclass contains miscellaneous, useful functions for Python packages.
11 11
12inherit multilib 12if [[ ${_PYTHON_UTILS_R1} ]]; then
13 13 die 'python.eclass can not be used with python-r1 suite eclasses.'
14if [[ -n "${NEED_PYTHON}" ]]; then
15 PYTHON_ATOM=">=dev-lang/python-${NEED_PYTHON}"
16 DEPEND="${PYTHON_ATOM}"
17 RDEPEND="${DEPEND}"
18else
19 PYTHON_ATOM="dev-lang/python"
20fi 14fi
21 15
22DEPEND+=" >=app-admin/eselect-python-20090804 16# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning.
23 >=app-shells/bash-3.2" 17if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
24 18 inherit multilib
25__python_eclass_test() {
26 __python_version_extract 2.3
27 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
28 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
29 __python_version_extract 2.3.4
30 echo -n "2.3.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
31 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
32 __python_version_extract 2.3.5
33 echo -n "2.3.5 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
34 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
35 __python_version_extract 2.4
36 echo -n "2.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
37 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
38 __python_version_extract 2.5b3
39 echo -n "2.5b3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
40 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
41}
42
43# @FUNCTION: python_version
44# @DESCRIPTION:
45# Run without arguments and it will export the version of python
46# currently in use as $PYVER; sets PYVER/PYVER_MAJOR/PYVER_MINOR
47__python_version_extract() {
48 local verstr=$1
49 export PYVER_MAJOR=${verstr:0:1}
50 export PYVER_MINOR=${verstr:2:1}
51 if [[ ${verstr:3:1} == . ]]; then
52 export PYVER_MICRO=${verstr:4}
53 fi 19fi
54 export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
55}
56 20
57python_version() { 21# Export pkg_setup every time to avoid issues with eclass inheritance order.
58 [[ -n "${PYVER}" ]] && return 0 22if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
59 local tmpstr 23 EXPORT_FUNCTIONS pkg_setup
60 python=${python:-/usr/bin/python} 24fi
61 tmpstr="$(${python} -V 2>&1 )"
62 export PYVER_ALL="${tmpstr#Python }"
63 __python_version_extract $PYVER_ALL
64}
65 25
66# @FUNCTION: PYTHON 26# Avoid processing this eclass more than once.
67# @USAGE: [-a|--absolute-path] [--] <Python_ABI="${PYTHON_ABI}"> 27if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
68# @DESCRIPTION: 28_PYTHON_ECLASS_INHERITED="1"
69# Get Python interpreter filename for specified Python ABI. If Python_ABI argument 29
70# is ommitted, then PYTHON_ABI environment variable must be set and is used. 30if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
71PYTHON() { 31 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
72 local absolute_path="0" slot= 32fi
33
34_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
35_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2 3.3)
36_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
37_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9)
38_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]})
39
40# ================================================================================================
41# ===================================== HANDLING OF METADATA =====================================
42# ================================================================================================
43
44_PYTHON_ABI_PATTERN_REGEX="([[:alnum:]]|\.|-|\*|\[|\])+"
45
46_python_check_python_abi_matching() {
47 local pattern patterns patterns_list="0" PYTHON_ABI
73 48
74 while (($#)); do 49 while (($#)); do
75 case "$1" in 50 case "$1" in
76 -a|--absolute-path) 51 --patterns-list)
77 absolute_path="1" 52 patterns_list="1"
78 ;; 53 ;;
79 --) 54 --)
55 shift
80 break 56 break
81 ;; 57 ;;
82 -*) 58 -*)
83 die "${FUNCNAME}(): Unrecognized option $1" 59 die "${FUNCNAME}(): Unrecognized option '$1'"
84 ;; 60 ;;
85 *) 61 *)
86 break 62 break
87 ;; 63 ;;
88 esac 64 esac
89 shift 65 shift
90 done 66 done
91 67
92 if [[ "$#" -eq "0" ]]; then 68 if [[ "$#" -ne 2 ]]; then
93 if [[ -n "${PYTHON_ABI}" ]]; then 69 die "${FUNCNAME}() requires 2 arguments"
94 slot="${PYTHON_ABI}" 70 fi
71
72 PYTHON_ABI="$1"
73
74 if [[ "${patterns_list}" == "0" ]]; then
75 pattern="$2"
76
77 if [[ "${pattern}" == *"-cpython" ]]; then
78 [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "${PYTHON_ABI}" == ${pattern%-cpython} ]]
79 elif [[ "${pattern}" == *"-jython" ]]; then
80 [[ "${PYTHON_ABI}" == ${pattern} ]]
81 elif [[ "${pattern}" == *"-pypy-"* ]]; then
82 [[ "${PYTHON_ABI}" == ${pattern} ]]
95 else 83 else
96 die "${FUNCNAME}(): Invalid usage" 84 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
85 [[ "${PYTHON_ABI}" == ${pattern} ]]
86 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
87 [[ "${PYTHON_ABI%-jython}" == ${pattern} ]]
88 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
89 [[ "${PYTHON_ABI%-pypy-*}" == ${pattern} ]]
90 else
91 die "${FUNCNAME}(): Unrecognized Python ABI '${PYTHON_ABI}'"
97 fi 92 fi
98 elif [[ "$#" -eq "1" ]]; then 93 fi
99 slot="$1"
100 else 94 else
101 die "${FUNCNAME}(): Invalid usage" 95 patterns="${2// /$'\n'}"
96
97 while read pattern; do
98 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
99 return 0
102 fi 100 fi
101 done <<< "${patterns}"
103 102
104 if [[ "${absolute_path}" == "1" ]]; then 103 return 1
105 echo -n "/usr/bin/python${slot}" 104 fi
105}
106
107_python_implementation() {
108 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
109 return 0
110 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
111 return 0
112 elif [[ "${CATEGORY}/${PN}" == "dev-python/pypy" ]]; then
113 return 0
106 else 114 else
107 echo -n "python${slot}" 115 return 1
116 fi
117}
118
119_python_package_supporting_installation_for_multiple_python_abis() {
120 [[ -n "${SUPPORT_PYTHON_ABIS}" ]]
121}
122
123# @ECLASS-VARIABLE: PYTHON_DEPEND
124# @DESCRIPTION:
125# Specification of dependency on dev-lang/python.
126# Syntax:
127# PYTHON_DEPEND: [[!]USE_flag? ]<version_components_group>[ version_components_group]
128# version_components_group: <major_version[:[minimal_version][:maximal_version]]>
129# major_version: <2|3|*>
130# minimal_version: <minimal_major_version.minimal_minor_version>
131# maximal_version: <maximal_major_version.maximal_minor_version>
132
133_python_parse_PYTHON_DEPEND() {
134 local major_version maximal_version minimal_version python_all="0" python_maximal_version python_minimal_version python_versions=() python2="0" python2_maximal_version python2_minimal_version python3="0" python3_maximal_version python3_minimal_version USE_flag= version_components_group version_components_group_regex version_components_groups
135
136 version_components_group_regex="(2|3|\*)(:([[:digit:]]+\.[[:digit:]]+)?(:([[:digit:]]+\.[[:digit:]]+)?)?)?"
137 version_components_groups="${PYTHON_DEPEND}"
138
139 if [[ "${version_components_groups}" =~ ^((\!)?[[:alnum:]_-]+\?\ )?${version_components_group_regex}(\ ${version_components_group_regex})?$ ]]; then
140 if [[ "${version_components_groups}" =~ ^(\!)?[[:alnum:]_-]+\? ]]; then
141 USE_flag="${version_components_groups%\? *}"
142 version_components_groups="${version_components_groups#* }"
108 fi 143 fi
109 144 if [[ "${version_components_groups}" =~ ("*".*" "|" *"|^2.*\ (2|\*)|^3.*\ (3|\*)) ]]; then
110 if [[ "${ABI}" != "${DEFAULT_ABI}" ]]; then 145 die "Invalid syntax of PYTHON_DEPEND: Incorrectly specified groups of versions"
111 echo -n "-${ABI}"
112 fi 146 fi
147
148 version_components_groups="${version_components_groups// /$'\n'}"
149 while read version_components_group; do
150 major_version="${version_components_group:0:1}"
151 minimal_version="${version_components_group:2}"
152 minimal_version="${minimal_version%:*}"
153 maximal_version="${version_components_group:$((3 + ${#minimal_version}))}"
154
155 if [[ "${major_version}" =~ ^(2|3)$ ]]; then
156 if [[ -n "${minimal_version}" && "${major_version}" != "${minimal_version:0:1}" ]]; then
157 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' not in specified group of versions"
158 fi
159 if [[ -n "${maximal_version}" && "${major_version}" != "${maximal_version:0:1}" ]]; then
160 die "Invalid syntax of PYTHON_DEPEND: Maximal version '${maximal_version}' not in specified group of versions"
161 fi
162 fi
163
164 if [[ "${major_version}" == "2" ]]; then
165 python2="1"
166 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
167 python2_minimal_version="${minimal_version}"
168 python2_maximal_version="${maximal_version}"
169 elif [[ "${major_version}" == "3" ]]; then
170 python3="1"
171 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
172 python3_minimal_version="${minimal_version}"
173 python3_maximal_version="${maximal_version}"
174 else
175 python_all="1"
176 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
177 python_minimal_version="${minimal_version}"
178 python_maximal_version="${maximal_version}"
179 fi
180
181 if [[ -n "${minimal_version}" ]] && ! has "${minimal_version}" "${python_versions[@]}"; then
182 die "Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '${minimal_version}'"
183 fi
184 if [[ -n "${maximal_version}" ]] && ! has "${maximal_version}" "${python_versions[@]}"; then
185 die "Invalid syntax of PYTHON_DEPEND: Unrecognized maximal version '${maximal_version}'"
186 fi
187
188 if [[ -n "${minimal_version}" && -n "${maximal_version}" && "${minimal_version}" > "${maximal_version}" ]]; then
189 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' greater than maximal version '${maximal_version}'"
190 fi
191 done <<< "${version_components_groups}"
192
193 _PYTHON_ATOMS=()
194
195 _append_accepted_versions_range() {
196 local accepted_version="0" i
197 for ((i = "${#python_versions[@]}"; i >= 0; i--)); do
198 if [[ "${python_versions[${i}]}" == "${python_maximal_version}" ]]; then
199 accepted_version="1"
200 fi
201 if [[ "${accepted_version}" == "1" ]]; then
202 _PYTHON_ATOMS+=("=dev-lang/python-${python_versions[${i}]}*")
203 fi
204 if [[ "${python_versions[${i}]}" == "${python_minimal_version}" ]]; then
205 accepted_version="0"
206 fi
207 done
208 }
209
210 if [[ "${python_all}" == "1" ]]; then
211 if [[ -z "${python_minimal_version}" && -z "${python_maximal_version}" ]]; then
212 _PYTHON_ATOMS+=("dev-lang/python")
213 else
214 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
215 python_minimal_version="${python_minimal_version:-${python_versions[0]}}"
216 python_maximal_version="${python_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
217 _append_accepted_versions_range
218 fi
219 else
220 if [[ "${python3}" == "1" ]]; then
221 if [[ -z "${python3_minimal_version}" && -z "${python3_maximal_version}" ]]; then
222 _PYTHON_ATOMS+=("=dev-lang/python-3*")
223 else
224 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
225 python_minimal_version="${python3_minimal_version:-${python_versions[0]}}"
226 python_maximal_version="${python3_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
227 _append_accepted_versions_range
228 fi
229 fi
230 if [[ "${python2}" == "1" ]]; then
231 if [[ -z "${python2_minimal_version}" && -z "${python2_maximal_version}" ]]; then
232 _PYTHON_ATOMS+=("=dev-lang/python-2*")
233 else
234 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
235 python_minimal_version="${python2_minimal_version:-${python_versions[0]}}"
236 python_maximal_version="${python2_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
237 _append_accepted_versions_range
238 fi
239 fi
240 fi
241
242 unset -f _append_accepted_versions_range
243
244 if [[ "${#_PYTHON_ATOMS[@]}" -gt 1 ]]; then
245 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
246 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
247 else
248 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
249 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
250 fi
251 else
252 die "Invalid syntax of PYTHON_DEPEND"
253 fi
113} 254}
255
256if _python_implementation; then
257 DEPEND=">=app-admin/eselect-python-20091230"
258 RDEPEND="${DEPEND}"
259 PDEPEND="app-admin/python-updater"
260fi
261
262if [[ -n "${PYTHON_DEPEND}" ]]; then
263 _python_parse_PYTHON_DEPEND
264else
265 _PYTHON_ATOMS=("dev-lang/python")
266fi
267unset -f _python_parse_PYTHON_DEPEND
268
269if [[ -n "${NEED_PYTHON}" ]]; then
270 eerror "Use PYTHON_DEPEND variable instead of NEED_PYTHON variable."
271 die "NEED_PYTHON variable is banned"
272fi
273
274# @ECLASS-VARIABLE: PYTHON_USE_WITH
275# @DESCRIPTION:
276# Set this to a space separated list of USE flags the Python slot in use must be built with.
277
278# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR
279# @DESCRIPTION:
280# Set this to a space separated list of USE flags of which one must be turned on for the slot in use.
281
282# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT
283# @DESCRIPTION:
284# Set this to a name of a USE flag if you need to make either PYTHON_USE_WITH or
285# PYTHON_USE_WITH_OR atoms conditional under a USE flag.
286
287if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
288 _PYTHON_USE_WITH_ATOMS_ARRAY=()
289 if [[ -n "${PYTHON_USE_WITH}" ]]; then
290 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
291 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${PYTHON_USE_WITH// /,}]")
292 done
293 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then
294 for _USE_flag in ${PYTHON_USE_WITH_OR}; do
295 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
296 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${_USE_flag}]")
297 done
298 done
299 unset _USE_flag
300 fi
301 if [[ "${#_PYTHON_USE_WITH_ATOMS_ARRAY[@]}" -gt 1 ]]; then
302 _PYTHON_USE_WITH_ATOMS="|| ( ${_PYTHON_USE_WITH_ATOMS_ARRAY[@]} )"
303 else
304 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}"
305 fi
306 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
307 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )"
308 fi
309 DEPEND+="${DEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
310 RDEPEND+="${RDEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
311 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY
312fi
313
314unset _PYTHON_ATOMS
315
316# ================================================================================================
317# =================================== MISCELLANEOUS FUNCTIONS ====================================
318# ================================================================================================
319
320_python_abi-specific_local_scope() {
321 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]]
322}
323
324_python_initialize_prefix_variables() {
325 if has "${EAPI:-0}" 0 1 2; then
326 if [[ -n "${ROOT}" && -z "${EROOT}" ]]; then
327 EROOT="${ROOT%/}${EPREFIX}/"
328 fi
329 if [[ -n "${D}" && -z "${ED}" ]]; then
330 ED="${D%/}${EPREFIX}/"
331 fi
332 fi
333}
334
335unset PYTHON_SANITY_CHECKS_EXECUTED PYTHON_SKIP_SANITY_CHECKS
336
337_python_initial_sanity_checks() {
338 if [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
339 # Ensure that /usr/bin/python and /usr/bin/python-config are valid.
340 if [[ "$(readlink "${EPREFIX}/usr/bin/python")" != "python-wrapper" ]]; then
341 eerror "'${EPREFIX}/usr/bin/python' is not valid symlink."
342 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
343 die "'${EPREFIX}/usr/bin/python' is not valid symlink"
344 fi
345 if [[ "$(<"${EPREFIX}/usr/bin/python-config")" != *"Gentoo python-config wrapper script"* ]]; then
346 eerror "'${EPREFIX}/usr/bin/python-config' is not valid script"
347 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
348 die "'${EPREFIX}/usr/bin/python-config' is not valid script"
349 fi
350 fi
351}
352
353_python_final_sanity_checks() {
354 if ! _python_implementation && [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
355 local PYTHON_ABI="${PYTHON_ABI}"
356 for PYTHON_ABI in ${PYTHON_ABIS-${PYTHON_ABI}}; do
357 # Ensure that appropriate version of Python is installed.
358 if ! has_version "$(python_get_implementational_package)"; then
359 die "$(python_get_implementational_package) is not installed"
360 fi
361
362 # Ensure that EPYTHON variable is respected.
363 if [[ "$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")" != "${PYTHON_ABI}" ]]; then
364 eerror "Path to 'python': '$(type -p python)'"
365 eerror "ABI: '${ABI}'"
366 eerror "DEFAULT_ABI: '${DEFAULT_ABI}'"
367 eerror "EPYTHON: '$(PYTHON)'"
368 eerror "PYTHON_ABI: '${PYTHON_ABI}'"
369 eerror "Locally active version of Python: '$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")'"
370 die "'python' does not respect EPYTHON variable"
371 fi
372 done
373 fi
374 PYTHON_SANITY_CHECKS_EXECUTED="1"
375}
376
377# @ECLASS-VARIABLE: PYTHON_COLORS
378# @DESCRIPTION:
379# User-configurable colored output.
380PYTHON_COLORS="${PYTHON_COLORS:-0}"
381
382_python_set_color_variables() {
383 if [[ "${PYTHON_COLORS}" != "0" && "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then
384 _BOLD=$'\e[1m'
385 _RED=$'\e[1;31m'
386 _GREEN=$'\e[1;32m'
387 _BLUE=$'\e[1;34m'
388 _CYAN=$'\e[1;36m'
389 _NORMAL=$'\e[0m'
390 else
391 _BOLD=
392 _RED=
393 _GREEN=
394 _BLUE=
395 _CYAN=
396 _NORMAL=
397 fi
398}
399
400_python_check_python_pkg_setup_execution() {
401 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
402
403 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
404 die "python_pkg_setup() not called"
405 fi
406}
407
408# @FUNCTION: python_pkg_setup
409# @DESCRIPTION:
410# Perform sanity checks and initialize environment.
411#
412# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable
413# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4.
414python_pkg_setup() {
415 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
416 die "${FUNCNAME}() can be used only in pkg_setup() phase"
417 fi
418
419 if [[ "$#" -ne 0 ]]; then
420 die "${FUNCNAME}() does not accept arguments"
421 fi
422
423 export JYTHON_SYSTEM_CACHEDIR="1"
424 addwrite "${EPREFIX}/var/cache/jython"
425
426 if _python_package_supporting_installation_for_multiple_python_abis; then
427 _python_calculate_PYTHON_ABIS
428 export EPYTHON="$(PYTHON -f)"
429 else
430 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
431 fi
432
433 if ! has "${EAPI:-0}" 0 1 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; then
434 if [[ "${PYTHON_USE_WITH_OPT}" ]]; then
435 if [[ "${PYTHON_USE_WITH_OPT}" == !* ]]; then
436 use ${PYTHON_USE_WITH_OPT#!} && return
437 else
438 use !${PYTHON_USE_WITH_OPT} && return
439 fi
440 fi
441
442 python_pkg_setup_check_USE_flags() {
443 local python_atom USE_flag
444 python_atom="$(python_get_implementational_package)"
445
446 for USE_flag in ${PYTHON_USE_WITH}; do
447 if ! has_version "${python_atom}[${USE_flag}]"; then
448 eerror "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
449 die "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
450 fi
451 done
452
453 for USE_flag in ${PYTHON_USE_WITH_OR}; do
454 if has_version "${python_atom}[${USE_flag}]"; then
455 return
456 fi
457 done
458
459 if [[ ${PYTHON_USE_WITH_OR} ]]; then
460 eerror "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
461 die "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
462 fi
463 }
464
465 if _python_package_supporting_installation_for_multiple_python_abis; then
466 PYTHON_SKIP_SANITY_CHECKS="1" python_execute_function -q python_pkg_setup_check_USE_flags
467 else
468 python_pkg_setup_check_USE_flags
469 fi
470
471 unset -f python_pkg_setup_check_USE_flags
472 fi
473
474 PYTHON_PKG_SETUP_EXECUTED="1"
475}
476
477_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|pypy-c|python)'
478
479# @FUNCTION: python_convert_shebangs
480# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories]
481# @DESCRIPTION:
482# Convert shebangs in specified files. Directories can be specified only with --recursive option.
483python_convert_shebangs() {
484 _python_check_python_pkg_setup_execution
485
486 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0" shebangs_converted="0"
487
488 while (($#)); do
489 case "$1" in
490 -r|--recursive)
491 recursive="1"
492 ;;
493 -q|--quiet)
494 quiet="1"
495 ;;
496 -x|--only-executables)
497 only_executables="1"
498 ;;
499 --)
500 shift
501 break
502 ;;
503 -*)
504 die "${FUNCNAME}(): Unrecognized option '$1'"
505 ;;
506 *)
507 break
508 ;;
509 esac
510 shift
511 done
512
513 if [[ "$#" -eq 0 ]]; then
514 die "${FUNCNAME}(): Missing Python version and files or directories"
515 elif [[ "$#" -eq 1 ]]; then
516 die "${FUNCNAME}(): Missing files or directories"
517 fi
518
519 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
520 python_interpreter="$(PYTHON "$1")"
521 else
522 python_interpreter="python$1"
523 fi
524 shift
525
526 for argument in "$@"; do
527 if [[ ! -e "${argument}" ]]; then
528 die "${FUNCNAME}(): '${argument}' does not exist"
529 elif [[ -f "${argument}" ]]; then
530 files+=("${argument}")
531 elif [[ -d "${argument}" ]]; then
532 if [[ "${recursive}" == "1" ]]; then
533 while read -d $'\0' -r file; do
534 files+=("${file}")
535 done < <(find "${argument}" $([[ "${only_executables}" == "1" ]] && echo -perm /111) -type f -print0)
536 else
537 die "${FUNCNAME}(): '${argument}' is not a regular file"
538 fi
539 else
540 die "${FUNCNAME}(): '${argument}' is not a regular file or a directory"
541 fi
542 done
543
544 for file in "${files[@]}"; do
545 file="${file#./}"
546 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
547
548 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then
549 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue
550
551 shebangs_converted="1"
552
553 if [[ "${quiet}" == "0" ]]; then
554 einfo "Converting shebang in '${file}'"
555 fi
556
557 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|pypy-c\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed"
558 fi
559 done
560
561 if [[ "${shebangs_converted}" == "0" ]]; then
562 ewarn "${FUNCNAME}(): Python scripts not found"
563 fi
564}
565
566# @FUNCTION: python_clean_py-compile_files
567# @USAGE: [-q|--quiet]
568# @DESCRIPTION:
569# Clean py-compile files to disable byte-compilation.
570python_clean_py-compile_files() {
571 _python_check_python_pkg_setup_execution
572
573 local file files=() quiet="0"
574
575 while (($#)); do
576 case "$1" in
577 -q|--quiet)
578 quiet="1"
579 ;;
580 -*)
581 die "${FUNCNAME}(): Unrecognized option '$1'"
582 ;;
583 *)
584 die "${FUNCNAME}(): Invalid usage"
585 ;;
586 esac
587 shift
588 done
589
590 while read -d $'\0' -r file; do
591 files+=("${file#./}")
592 done < <(find -name py-compile -type f -print0)
593
594 for file in "${files[@]}"; do
595 if [[ "${quiet}" == "0" ]]; then
596 einfo "Cleaning '${file}' file"
597 fi
598 echo "#!/bin/sh" > "${file}"
599 done
600}
601
602# @FUNCTION: python_clean_installation_image
603# @USAGE: [-q|--quiet]
604# @DESCRIPTION:
605# Delete needless files in installation image.
606#
607# This function can be used only in src_install() phase.
608python_clean_installation_image() {
609 if [[ "${EBUILD_PHASE}" != "install" ]]; then
610 die "${FUNCNAME}() can be used only in src_install() phase"
611 fi
612
613 _python_check_python_pkg_setup_execution
614 _python_initialize_prefix_variables
615
616 local file files=() quiet="0"
617
618 while (($#)); do
619 case "$1" in
620 -q|--quiet)
621 quiet="1"
622 ;;
623 -*)
624 die "${FUNCNAME}(): Unrecognized option '$1'"
625 ;;
626 *)
627 die "${FUNCNAME}(): Invalid usage"
628 ;;
629 esac
630 shift
631 done
632
633 while read -d $'\0' -r file; do
634 files+=("${file}")
635 done < <(find "${ED}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -type f -print0)
636
637 if [[ "${#files[@]}" -gt 0 ]]; then
638 if [[ "${quiet}" == "0" ]]; then
639 ewarn "Deleting byte-compiled Python modules needlessly generated by build system:"
640 fi
641 for file in "${files[@]}"; do
642 if [[ "${quiet}" == "0" ]]; then
643 ewarn " ${file}"
644 fi
645 rm -f "${file}"
646
647 # Delete empty __pycache__ directories.
648 if [[ "${file%/*}" == *"/__pycache__" ]]; then
649 rmdir "${file%/*}" 2> /dev/null
650 fi
651 done
652 fi
653
654 python_clean_sitedirs() {
655 if [[ -d "${ED}$(python_get_sitedir)" ]]; then
656 find "${ED}$(python_get_sitedir)" "(" -name "*.c" -o -name "*.h" -o -name "*.la" ")" -type f -print0 | xargs -0 rm -f
657 fi
658 }
659 if _python_package_supporting_installation_for_multiple_python_abis; then
660 python_execute_function -q python_clean_sitedirs
661 else
662 python_clean_sitedirs
663 fi
664
665 unset -f python_clean_sitedirs
666}
667
668# ================================================================================================
669# =========== FUNCTIONS FOR PACKAGES SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ============
670# ================================================================================================
671
672# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS
673# @DESCRIPTION:
674# Set this in EAPI <= 4 to indicate that current package supports installation for
675# multiple Python ABIs.
676
677# @ECLASS-VARIABLE: PYTHON_TESTS_RESTRICTED_ABIS
678# @DESCRIPTION:
679# Space-separated list of Python ABI patterns. Testing in Python ABIs matching any Python ABI
680# patterns specified in this list is skipped.
681
682# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS
683# @DESCRIPTION:
684# Set this to export phase functions for the following ebuild phases:
685# src_prepare(), src_configure(), src_compile(), src_test(), src_install().
686if ! has "${EAPI:-0}" 0 1; then
687 python_src_prepare() {
688 if [[ "${EBUILD_PHASE}" != "prepare" ]]; then
689 die "${FUNCNAME}() can be used only in src_prepare() phase"
690 fi
691
692 if ! _python_package_supporting_installation_for_multiple_python_abis; then
693 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
694 fi
695
696 _python_check_python_pkg_setup_execution
697
698 if [[ "$#" -ne 0 ]]; then
699 die "${FUNCNAME}() does not accept arguments"
700 fi
701
702 python_copy_sources
703 }
704
705 for python_default_function in src_configure src_compile src_test; do
706 eval "python_${python_default_function}() {
707 if [[ \"\${EBUILD_PHASE}\" != \"${python_default_function#src_}\" ]]; then
708 die \"\${FUNCNAME}() can be used only in ${python_default_function}() phase\"
709 fi
710
711 if ! _python_package_supporting_installation_for_multiple_python_abis; then
712 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\"
713 fi
714
715 _python_check_python_pkg_setup_execution
716
717 python_execute_function -d -s -- \"\$@\"
718 }"
719 done
720 unset python_default_function
721
722 python_src_install() {
723 if [[ "${EBUILD_PHASE}" != "install" ]]; then
724 die "${FUNCNAME}() can be used only in src_install() phase"
725 fi
726
727 if ! _python_package_supporting_installation_for_multiple_python_abis; then
728 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
729 fi
730
731 _python_check_python_pkg_setup_execution
732
733 if has "${EAPI:-0}" 0 1 2 3; then
734 python_execute_function -d -s -- "$@"
735 else
736 python_installation() {
737 emake DESTDIR="${T}/images/${PYTHON_ABI}" install "$@"
738 }
739 python_execute_function -s python_installation "$@"
740 unset python_installation
741
742 python_merge_intermediate_installation_images "${T}/images"
743 fi
744 }
745
746 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
747 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
748 fi
749fi
114 750
115unset PYTHON_ABIS 751unset PYTHON_ABIS
116unset PYTHON_ABIS_SANITY_CHECKS
117 752
118# @FUNCTION: validate_PYTHON_ABIS 753_python_calculate_PYTHON_ABIS() {
119# @DESCRIPTION: 754 if ! _python_package_supporting_installation_for_multiple_python_abis; then
120# Ensure that PYTHON_ABIS variable has valid value. 755 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
121validate_PYTHON_ABIS() {
122 # Ensure that some functions cannot be accidentally successfully used in EAPI <= 2 without setting SUPPORT_PYTHON_ABIS variable.
123 if has "${EAPI:-0}" 0 1 2 && [[ -z "${SUPPORT_PYTHON_ABIS}" ]]; then
124 die "${FUNCNAME}() cannot be used in this EAPI without setting SUPPORT_PYTHON_ABIS variable"
125 fi 756 fi
126 757
127 # Ensure that /usr/bin/python and /usr/bin/python-config are valid. 758 _python_initial_sanity_checks
128 if [[ "$(readlink /usr/bin/python)" != "python-wrapper" ]]; then
129 die "'/usr/bin/python' isn't valid symlink"
130 fi
131 if [[ "$(</usr/bin/python-config)" != *"Gentoo python-config wrapper script"* ]]; then
132 die "'/usr/bin/python-config' isn't valid script"
133 fi
134 759
135 # USE_${ABI_TYPE^^} and RESTRICT_${ABI_TYPE^^}_ABIS variables hopefully will be included in EAPI >= 4.
136 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3; then 760 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]]; then
137 local PYTHON_ABI python2_supported_versions python3_supported_versions restricted_ABI support_ABI supported_PYTHON_ABIS= 761 local PYTHON_ABI
138 PYTHON_ABI_SUPPORTED_VALUES="2.4 2.5 2.6 2.7 3.0 3.1 3.2"
139 python2_supported_versions="2.4 2.5 2.6 2.7"
140 python3_supported_versions="3.0 3.1 3.2"
141 762
142 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then 763 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
143 local python2_enabled="0" python3_enabled="0" 764 local cpython_enabled="0"
144 765
145 if [[ -z "${USE_PYTHON}" ]]; then 766 if [[ -z "${USE_PYTHON}" ]]; then
146 die "USE_PYTHON variable is empty" 767 die "USE_PYTHON variable is empty"
147 fi 768 fi
148 769
149 for PYTHON_ABI in ${USE_PYTHON}; do 770 for PYTHON_ABI in ${USE_PYTHON}; do
150 if ! has "${PYTHON_ABI}" ${PYTHON_ABI_SUPPORTED_VALUES}; then 771 if ! has "${PYTHON_ABI}" "${_PYTHON_GLOBALLY_SUPPORTED_ABIS[@]}"; then
151 die "USE_PYTHON variable contains invalid value '${PYTHON_ABI}'" 772 die "USE_PYTHON variable contains invalid value '${PYTHON_ABI}'"
152 fi 773 fi
153 774
154 if has "${PYTHON_ABI}" ${python2_supported_versions}; then 775 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then
155 python2_enabled="1" 776 cpython_enabled="1"
777 fi
778
779 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
780 export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
781 fi
782 done
783
784 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
785 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
156 fi 786 fi
157 if has "${PYTHON_ABI}" ${python3_supported_versions}; then 787
158 python3_enabled="1" 788 if [[ "${cpython_enabled}" == "0" ]]; then
789 die "USE_PYTHON variable does not enable any CPython ABI"
159 fi 790 fi
791 else
792 local python_version python2_version python3_version support_python_major_version
160 793
161 support_ABI="1" 794 if ! has_version "dev-lang/python"; then
162 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do 795 die "${FUNCNAME}(): 'dev-lang/python' is not installed"
163 if [[ "${PYTHON_ABI}" == ${restricted_ABI} ]]; then 796 fi
164 support_ABI="0" 797
798 python_version="$("${EPREFIX}/usr/bin/python" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
799
800 if has_version "=dev-lang/python-2*"; then
801 if [[ "$(readlink "${EPREFIX}/usr/bin/python2")" != "python2."* ]]; then
802 die "'${EPREFIX}/usr/bin/python2' is not valid symlink"
803 fi
804
805 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
806
807 support_python_major_version="0"
808 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
809 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
810 support_python_major_version="1"
165 break 811 break
166 fi 812 fi
167 done 813 done
168 [[ "${support_ABI}" == "1" ]] && supported_PYTHON_ABIS+=" ${PYTHON_ABI}" 814 if [[ "${support_python_major_version}" == "1" ]]; then
169 done 815 if _python_check_python_abi_matching --patterns-list "${python2_version}" "${RESTRICT_PYTHON_ABIS}"; then
170 export PYTHON_ABIS="${supported_PYTHON_ABIS# }" 816 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}"
171 817 fi
172 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then 818 else
173 die "USE_PYTHON variable doesn't enable any version of Python supported by ${CATEGORY}/${PF}" 819 python2_version=""
174 fi 820 fi
175
176 if [[ "${python2_enabled}" == "0" ]]; then
177 ewarn "USE_PYTHON variable doesn't enable any version of Python 2. This configuration is unsupported."
178 fi 821 fi
179 if [[ "${python3_enabled}" == "0" ]]; then
180 ewarn "USE_PYTHON variable doesn't enable any version of Python 3. This configuration is unsupported."
181 fi
182 else
183 local python_version python2_version= python3_version= support_python_major_version
184 822
185 python_version="$(/usr/bin/python -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')"
186
187 if has_version "=dev-lang/python-2*"; then 823 if has_version "=dev-lang/python-3*"; then
188 if [[ "$(readlink /usr/bin/python2)" != "python2."* ]]; then 824 if [[ "$(readlink "${EPREFIX}/usr/bin/python3")" != "python3."* ]]; then
189 die "'/usr/bin/python2' isn't valid symlink" 825 die "'${EPREFIX}/usr/bin/python3' is not valid symlink"
190 fi 826 fi
191 827
192 python2_version="$(/usr/bin/python2 -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')" 828 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
193 829
194 for PYTHON_ABI in ${python2_supported_versions}; do 830 support_python_major_version="0"
831 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
832 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
195 support_python_major_version="1" 833 support_python_major_version="1"
196 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do 834 break
197 if [[ "${PYTHON_ABI}" == ${restricted_ABI} ]]; then
198 support_python_major_version="0"
199 fi 835 fi
200 done
201 [[ "${support_python_major_version}" == "1" ]] && break
202 done 836 done
203 if [[ "${support_python_major_version}" == "1" ]]; then 837 if [[ "${support_python_major_version}" == "1" ]]; then
204 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do 838 if _python_check_python_abi_matching --patterns-list "${python3_version}" "${RESTRICT_PYTHON_ABIS}"; then
205 if [[ "${python2_version}" == ${restricted_ABI} ]]; then
206 die "Active version of Python 2 isn't supported by ${CATEGORY}/${PF}"
207 fi
208 done
209 else
210 python2_version=""
211 fi
212 fi
213
214 if has_version "=dev-lang/python-3*"; then
215 if [[ "$(readlink /usr/bin/python3)" != "python3."* ]]; then
216 die "'/usr/bin/python3' isn't valid symlink"
217 fi
218
219 python3_version="$(/usr/bin/python3 -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')"
220
221 for PYTHON_ABI in ${python3_supported_versions}; do
222 support_python_major_version="1"
223 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
224 if [[ "${PYTHON_ABI}" == ${restricted_ABI} ]]; then
225 support_python_major_version="0"
226 fi
227 done
228 [[ "${support_python_major_version}" == "1" ]] && break
229 done
230 if [[ "${support_python_major_version}" == "1" ]]; then
231 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
232 if [[ "${python3_version}" == ${restricted_ABI} ]]; then
233 die "Active version of Python 3 isn't supported by ${CATEGORY}/${PF}" 839 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
234 fi 840 fi
235 done
236 else 841 else
237 python3_version="" 842 python3_version=""
238 fi 843 fi
239 fi 844 fi
240 845
241 if ! has "${python_version}" "${python2_version}" "${python3_version}"; then 846 if [[ -z "${python2_version}" && -z "${python3_version}" ]]; then
847 eerror "${CATEGORY}/${PF} requires at least one of the following packages:"
848 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
849 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
850 eerror " dev-lang/python:${PYTHON_ABI}"
851 fi
852 done
853 die "No supported version of CPython installed"
854 fi
855
856 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
242 eerror "Python wrapper is configured incorrectly or /usr/bin/python2 or /usr/bin/python3 symlink" 857 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
858 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
859 die "Incorrect configuration of Python"
860 fi
861 if [[ -n "${python3_version}" && "${python_version}" == "3."* && "${python_version}" != "${python3_version}" ]]; then
862 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python3' symlink"
243 eerror "is set incorrectly. Use \`eselect python\` to fix configuration." 863 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
244 die "Incorrect configuration of Python" 864 die "Incorrect configuration of Python"
245 fi 865 fi
246 866
247 PYTHON_ABIS="${python2_version} ${python3_version}" 867 PYTHON_ABIS="${python2_version} ${python3_version}"
248 PYTHON_ABIS="${PYTHON_ABIS# }" 868 PYTHON_ABIS="${PYTHON_ABIS# }"
249 export PYTHON_ABIS="${PYTHON_ABIS% }" 869 export PYTHON_ABIS="${PYTHON_ABIS% }"
250 fi 870 fi
251 fi 871 fi
252 872
253 if [[ "$(declare -p PYTHON_ABIS_SANITY_CHECKS 2> /dev/null)" != "declare -- PYTHON_ABIS_SANITY_CHECKS="* ]]; then 873 _python_final_sanity_checks
254 local PYTHON_ABI 874}
255 for PYTHON_ABI in ${PYTHON_ABIS}; do 875
256 # Ensure that appropriate Python version is installed. 876_python_prepare_flags() {
257 if ! has_version "dev-lang/python:${PYTHON_ABI}"; then 877 local array=() deleted_flag element flags new_value old_flag old_value operator pattern prefix variable
258 die "dev-lang/python:${PYTHON_ABI} isn't installed" 878
879 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
880 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\""
881 for prefix in PYTHON_USER_ PYTHON_; do
882 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then
883 eval "array=(\"\${${prefix}${variable}[@]}\")"
884 for element in "${array[@]}"; do
885 if [[ "${element}" =~ ^${_PYTHON_ABI_PATTERN_REGEX}\ (\+|-)\ .+ ]]; then
886 pattern="${element%% *}"
887 element="${element#* }"
888 operator="${element%% *}"
889 flags="${element#* }"
890 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
891 if [[ "${operator}" == "+" ]]; then
892 eval "export ${variable}+=\"\${variable:+ }${flags}\""
893 elif [[ "${operator}" == "-" ]]; then
894 flags="${flags// /$'\n'}"
895 old_value="${!variable// /$'\n'}"
896 new_value=""
897 while read old_flag; do
898 while read deleted_flag; do
899 if [[ "${old_flag}" == ${deleted_flag} ]]; then
900 continue 2
901 fi
902 done <<< "${flags}"
903 new_value+="${new_value:+ }${old_flag}"
904 done <<< "${old_value}"
905 eval "export ${variable}=\"\${new_value}\""
906 fi
907 fi
908 else
909 die "Element '${element}' of ${prefix}${variable} array has invalid syntax"
259 fi 910 fi
260 911 done
261 # Ensure that EPYTHON variable is respected. 912 elif [[ -n "$(declare -p ${prefix}${variable} 2> /dev/null)" ]]; then
262 if [[ "$(EPYTHON="$(PYTHON)" python -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')" != "${PYTHON_ABI}" ]]; then 913 die "${prefix}${variable} should be indexed array"
263 die "'python' doesn't respect EPYTHON variable"
264 fi 914 fi
265 done 915 done
266 PYTHON_ABIS_SANITY_CHECKS="1"
267 fi
268}
269
270# @FUNCTION: python_copy_sources
271# @USAGE: [--no-link] [--] [directory]
272# @DESCRIPTION:
273# Copy unpacked sources of given package for each Python ABI.
274python_copy_sources() {
275 local dir dirs=() no_link="0" PYTHON_ABI
276
277 while (($#)); do
278 case "$1" in
279 --no-link)
280 no_link="1"
281 ;;
282 --)
283 break
284 ;;
285 -*)
286 die "${FUNCNAME}(): Unrecognized option '$1'"
287 ;;
288 *)
289 break
290 ;;
291 esac
292 shift
293 done
294
295 if [[ "$#" -eq "0" ]]; then
296 if [[ "${WORKDIR}" == "${S}" ]]; then
297 die "${FUNCNAME}() cannot be used"
298 fi
299 dirs="${S}"
300 else
301 dirs="$@"
302 fi
303
304 validate_PYTHON_ABIS
305 for PYTHON_ABI in ${PYTHON_ABIS}; do
306 for dir in "${dirs[@]}"; do
307 if [[ "${no_link}" == "1" ]]; then
308 cp -pr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
309 else
310 cp -lpr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
311 fi
312 done 916 done
313 done
314} 917}
315 918
316# @FUNCTION: python_set_build_dir_symlink 919_python_restore_flags() {
317# @USAGE: [directory="build"] 920 local variable
318# @DESCRIPTION:
319# Create build directory symlink.
320python_set_build_dir_symlink() {
321 local dir="$1"
322 921
323 [[ -z "${PYTHON_ABI}" ]] && die "PYTHON_ABI variable not set" 922 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
324 [[ -z "${dir}" ]] && dir="build" 923 eval "${variable}=\"\${_PYTHON_SAVED_${variable}}\""
325 924 unset _PYTHON_SAVED_${variable}
326 # Don't delete preexistent directories. 925 done
327 rm -f "${dir}" || die "Deletion of '${dir}' failed"
328 ln -s "${dir}-${PYTHON_ABI}" "${dir}" || die "Creation of '${dir}' directory symlink failed"
329} 926}
330 927
331# @FUNCTION: python_execute_function 928# @FUNCTION: python_execute_function
332# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--] <function> [arguments] 929# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments]
333# @DESCRIPTION: 930# @DESCRIPTION:
334# Execute specified function for each value of PYTHON_ABIS, optionally passing additional 931# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
335# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables. 932# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
336python_execute_function() { 933python_execute_function() {
337 local action action_message action_message_template= default_function="0" failure_message failure_message_template= function nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" separate_build_dirs="0" 934 if ! _python_package_supporting_installation_for_multiple_python_abis; then
935 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
936 fi
937
938 _python_check_python_pkg_setup_execution
939 _python_set_color_variables
940
941 local action action_message action_message_template default_function="0" failure_message failure_message_template final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir
338 942
339 while (($#)); do 943 while (($#)); do
340 case "$1" in 944 case "$1" in
341 --action-message) 945 --action-message)
342 action_message_template="$2" 946 action_message_template="$2"
347 ;; 951 ;;
348 --failure-message) 952 --failure-message)
349 failure_message_template="$2" 953 failure_message_template="$2"
350 shift 954 shift
351 ;; 955 ;;
956 -f|--final-ABI)
957 final_ABI="1"
958 ;;
352 --nonfatal) 959 --nonfatal)
353 nonfatal="1" 960 nonfatal="1"
354 ;; 961 ;;
355 -q|--quiet) 962 -q|--quiet)
356 quiet="1" 963 quiet="1"
357 ;; 964 ;;
358 -s|--separate-build-dirs) 965 -s|--separate-build-dirs)
359 separate_build_dirs="1" 966 separate_build_dirs="1"
360 ;; 967 ;;
968 --source-dir)
969 source_dir="$2"
970 shift
971 ;;
361 --) 972 --)
973 shift
362 break 974 break
363 ;; 975 ;;
364 -*) 976 -*)
365 die "${FUNCNAME}(): Unrecognized option '$1'" 977 die "${FUNCNAME}(): Unrecognized option '$1'"
366 ;; 978 ;;
369 ;; 981 ;;
370 esac 982 esac
371 shift 983 shift
372 done 984 done
373 985
986 if [[ -n "${source_dir}" && "${separate_build_dirs}" == 0 ]]; then
987 die "${FUNCNAME}(): '--source-dir' option can be specified only with '--separate-build-dirs' option"
988 fi
989
374 if [[ "${default_function}" == "0" ]]; then 990 if [[ "${default_function}" == "0" ]]; then
375 if [[ "$#" -eq "0" ]]; then 991 if [[ "$#" -eq 0 ]]; then
376 die "${FUNCNAME}(): Missing function name" 992 die "${FUNCNAME}(): Missing function name"
377 fi 993 fi
378 function="$1" 994 function="$1"
379 shift 995 shift
380 996
381 if [[ -z "$(type -t "${function}")" ]]; then 997 if [[ -z "$(type -t "${function}")" ]]; then
382 die "${FUNCNAME}(): '${function}' function isn't defined" 998 die "${FUNCNAME}(): '${function}' function is not defined"
383 fi 999 fi
384 else 1000 else
385 if [[ "$#" -ne "0" ]]; then
386 die "${FUNCNAME}(): '--default-function' option and function name cannot be specified simultaneously"
387 fi
388 if has "${EAPI:-0}" 0 1; then 1001 if has "${EAPI:-0}" 0 1; then
389 die "${FUNCNAME}(): '--default-function' option cannot be used in this EAPI" 1002 die "${FUNCNAME}(): '--default-function' option cannot be used in this EAPI"
390 fi 1003 fi
391 1004
392 if [[ "${EBUILD_PHASE}" == "configure" ]]; then 1005 if [[ "${EBUILD_PHASE}" == "configure" ]]; then
393 if has "${EAPI}" 2; then 1006 if has "${EAPI}" 2 3; then
394 python_default_function() { 1007 python_default_function() {
395 econf 1008 econf "$@"
396 } 1009 }
397 else 1010 else
398 python_default_function() { 1011 python_default_function() {
399 nonfatal econf 1012 nonfatal econf "$@"
400 } 1013 }
401 fi 1014 fi
402 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then 1015 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then
403 python_default_function() { 1016 python_default_function() {
404 emake 1017 emake "$@"
405 } 1018 }
406 elif [[ "${EBUILD_PHASE}" == "test" ]]; then 1019 elif [[ "${EBUILD_PHASE}" == "test" ]]; then
407 python_default_function() { 1020 python_default_function() {
1021 # Stolen from portage's _eapi0_src_test()
1022 local emake_cmd="${MAKE:-make} ${MAKEOPTS} ${EXTRA_EMAKE}"
408 if emake -j1 -n check &> /dev/null; then 1023 if ${emake_cmd} -j1 -n check &> /dev/null; then
409 emake -j1 check 1024 ${emake_cmd} -j1 check "$@"
410 elif emake -j1 -n test &> /dev/null; then 1025 elif ${emake_cmd} -j1 -n test &> /dev/null; then
411 emake -j1 test 1026 ${emake_cmd} -j1 test "$@"
412 fi 1027 fi
413 } 1028 }
414 elif [[ "${EBUILD_PHASE}" == "install" ]]; then 1029 elif [[ "${EBUILD_PHASE}" == "install" ]]; then
415 python_default_function() { 1030 python_default_function() {
416 emake DESTDIR="${D}" install 1031 emake DESTDIR="${D}" install "$@"
417 } 1032 }
418 else 1033 else
419 die "${FUNCNAME}(): --default-function option cannot be used in this ebuild phase" 1034 die "${FUNCNAME}(): '--default-function' option cannot be used in this ebuild phase"
420 fi 1035 fi
421 function="python_default_function" 1036 function="python_default_function"
1037 fi
1038
1039 # Ensure that python_execute_function() cannot be directly or indirectly called by python_execute_function().
1040 if _python_abi-specific_local_scope; then
1041 die "${FUNCNAME}(): Invalid call stack"
422 fi 1042 fi
423 1043
424 if [[ "${quiet}" == "0" ]]; then 1044 if [[ "${quiet}" == "0" ]]; then
425 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up" 1045 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up"
426 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking" 1046 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking"
433 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation" 1053 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation"
434 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation" 1054 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation"
435 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation" 1055 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation"
436 fi 1056 fi
437 1057
438 local RED GREEN BLUE NORMAL 1058 _python_calculate_PYTHON_ABIS
439 if [[ "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then 1059 if [[ "${final_ABI}" == "1" ]]; then
440 RED=$'\e[1;31m' 1060 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)"
441 GREEN=$'\e[1;32m'
442 BLUE=$'\e[1;34m'
443 NORMAL=$'\e[0m'
444 else 1061 else
445 RED= 1062 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
446 GREEN=
447 BLUE=
448 NORMAL=
449 fi 1063 fi
450
451 validate_PYTHON_ABIS
452 for PYTHON_ABI in ${PYTHON_ABIS}; do 1064 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1065 if [[ "${EBUILD_PHASE}" == "test" ]] && _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${PYTHON_TESTS_RESTRICTED_ABIS}"; then
1066 if [[ "${quiet}" == "0" ]]; then
1067 echo " ${_GREEN}*${_NORMAL} ${_BLUE}Testing of ${CATEGORY}/${PF} with $(python_get_implementation_and_version) skipped${_NORMAL}"
1068 fi
1069 continue
1070 fi
1071
1072 _python_prepare_flags
1073
453 if [[ "${quiet}" == "0" ]]; then 1074 if [[ "${quiet}" == "0" ]]; then
454 if [[ -n "${action_message_template}" ]]; then 1075 if [[ -n "${action_message_template}" ]]; then
455 action_message="$(eval echo -n "${action_message_template}")" 1076 eval "action_message=\"${action_message_template}\""
456 else 1077 else
457 action_message="${action} of ${CATEGORY}/${PF} with Python ${PYTHON_ABI}..." 1078 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation_and_version)..."
458 fi 1079 fi
459 echo " ${GREEN}*${NORMAL} ${BLUE}${action_message}${NORMAL}" 1080 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}"
460 fi 1081 fi
461 1082
462 if [[ "${separate_build_dirs}" == "1" ]]; then 1083 if [[ "${separate_build_dirs}" == "1" ]]; then
1084 if [[ -n "${source_dir}" ]]; then
1085 export BUILDDIR="${S}/${source_dir}-${PYTHON_ABI}"
1086 else
463 export BUILDDIR="${S}-${PYTHON_ABI}" 1087 export BUILDDIR="${S}-${PYTHON_ABI}"
1088 fi
464 pushd "${BUILDDIR}" > /dev/null || die "pushd failed" 1089 pushd "${BUILDDIR}" > /dev/null || die "pushd failed"
465 else 1090 else
466 export BUILDDIR="${S}" 1091 export BUILDDIR="${S}"
467 fi 1092 fi
468 1093
469 previous_directory="$(pwd)" 1094 previous_directory="$(pwd)"
470 previous_directory_stack="$(dirs -p)" 1095 previous_directory_stack="$(dirs -p)"
471 previous_directory_stack_length="$(dirs -p | wc -l)" 1096 previous_directory_stack_length="$(dirs -p | wc -l)"
472 1097
473 if ! has "${EAPI}" 0 1 2 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then 1098 if ! has "${EAPI}" 0 1 2 3 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
474 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@" 1099 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@"
475 else 1100 else
476 EPYTHON="$(PYTHON)" "${function}" "$@" 1101 EPYTHON="$(PYTHON)" "${function}" "$@"
477 fi 1102 fi
478 1103
479 if [[ "$?" != "0" ]]; then 1104 return_code="$?"
1105
1106 _python_restore_flags
1107
1108 if [[ "${return_code}" -ne 0 ]]; then
480 if [[ -n "${failure_message_template}" ]]; then 1109 if [[ -n "${failure_message_template}" ]]; then
481 failure_message="$(eval echo -n "${failure_message_template}")" 1110 eval "failure_message=\"${failure_message_template}\""
482 else 1111 else
483 failure_message="${action} failed with Python ${PYTHON_ABI} in ${function}() function" 1112 failure_message="${action} failed with $(python_get_implementation_and_version) in ${function}() function"
484 fi 1113 fi
485 1114
486 if [[ "${nonfatal}" == "1" ]]; then 1115 if [[ "${nonfatal}" == "1" ]]; then
487 if [[ "${quiet}" == "0" ]]; then 1116 if [[ "${quiet}" == "0" ]]; then
488 ewarn "${RED}${failure_message}${NORMAL}" 1117 ewarn "${failure_message}"
489 fi 1118 fi
490 elif has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then 1119 elif [[ "${final_ABI}" == "0" ]] && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
491 if [[ "${EBUILD_PHASE}" != "test" ]] || ! has test-fail-continue ${FEATURES}; then 1120 if [[ "${EBUILD_PHASE}" != "test" ]] || ! has test-fail-continue ${FEATURES}; then
492 local enabled_PYTHON_ABIS= other_PYTHON_ABI 1121 local enabled_PYTHON_ABIS= other_PYTHON_ABI
493 for other_PYTHON_ABI in ${PYTHON_ABIS}; do 1122 for other_PYTHON_ABI in ${PYTHON_ABIS}; do
494 [[ "${other_PYTHON_ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+=" ${other_PYTHON_ABI}" 1123 [[ "${other_PYTHON_ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+="${enabled_PYTHON_ABIS:+ }${other_PYTHON_ABI}"
495 done 1124 done
496 export PYTHON_ABIS="${enabled_PYTHON_ABIS# }" 1125 export PYTHON_ABIS="${enabled_PYTHON_ABIS}"
497 fi 1126 fi
498 if [[ "${quiet}" == "0" ]]; then 1127 if [[ "${quiet}" == "0" ]]; then
499 ewarn "${RED}${failure_message}${NORMAL}" 1128 ewarn "${failure_message}"
500 fi 1129 fi
501 if [[ -z "${PYTHON_ABIS}" ]]; then 1130 if [[ -z "${PYTHON_ABIS}" ]]; then
502 die "${function}() function failed with all enabled versions of Python" 1131 die "${function}() function failed with all enabled Python ABIs"
503 fi 1132 fi
504 else 1133 else
505 die "${failure_message}" 1134 die "${failure_message}"
506 fi 1135 fi
507 fi 1136 fi
508 1137
509 # Ensure that directory stack hasn't been decreased. 1138 # Ensure that directory stack has not been decreased.
510 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then 1139 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then
511 die "Directory stack decreased illegally" 1140 die "Directory stack decreased illegally"
512 fi 1141 fi
513 1142
514 # Avoid side effects of earlier returning from the specified function. 1143 # Avoid side effects of earlier returning from the specified function.
515 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do 1144 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do
516 popd > /dev/null || die "popd failed" 1145 popd > /dev/null || die "popd failed"
517 done 1146 done
518 1147
519 # Ensure that the bottom part of directory stack hasn't been changed. Restore 1148 # Ensure that the bottom part of directory stack has not been changed. Restore
520 # previous directory (from before running of the specified function) before 1149 # previous directory (from before running of the specified function) before
521 # comparison of directory stacks to avoid mismatch of directory stacks after 1150 # comparison of directory stacks to avoid mismatch of directory stacks after
522 # potential using of 'cd' to change current directory. Restoration of previous 1151 # potential using of 'cd' to change current directory. Restoration of previous
523 # directory allows to safely use 'cd' to change current directory in the 1152 # directory allows to safely use 'cd' to change current directory in the
524 # specified function without changing it back to original directory. 1153 # specified function without changing it back to original directory.
536 if [[ "${default_function}" == "1" ]]; then 1165 if [[ "${default_function}" == "1" ]]; then
537 unset -f python_default_function 1166 unset -f python_default_function
538 fi 1167 fi
539} 1168}
540 1169
541# @FUNCTION: python_convert_shebangs 1170# @FUNCTION: python_copy_sources
542# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_version> <file|directory> [files|directories] 1171# @USAGE: <directory="${S}"> [directory]
543# @DESCRIPTION: 1172# @DESCRIPTION:
544# Convert shebangs in specified files. Directories can be specified only with --recursive option. 1173# Copy unpacked sources of current package to separate build directory for each Python ABI.
545python_convert_shebangs() { 1174python_copy_sources() {
546 local argument file files=() only_executables="0" python_version quiet="0" recursive="0" 1175 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1176 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1177 fi
1178
1179 _python_check_python_pkg_setup_execution
1180
1181 local dir dirs=() PYTHON_ABI
1182
1183 if [[ "$#" -eq 0 ]]; then
1184 if [[ "${WORKDIR}" == "${S}" ]]; then
1185 die "${FUNCNAME}() cannot be used with current value of S variable"
1186 fi
1187 dirs=("${S%/}")
1188 else
1189 dirs=("$@")
1190 fi
1191
1192 _python_calculate_PYTHON_ABIS
1193 for PYTHON_ABI in ${PYTHON_ABIS}; do
1194 for dir in "${dirs[@]}"; do
1195 cp -pr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
1196 done
1197 done
1198}
1199
1200# @FUNCTION: python_generate_wrapper_scripts
1201# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files]
1202# @DESCRIPTION:
1203# Generate wrapper scripts. Existing files are overwritten only with --force option.
1204# If --respect-EPYTHON option is specified, then generated wrapper scripts will
1205# respect EPYTHON variable at run time.
1206#
1207# This function can be used only in src_install() phase.
1208python_generate_wrapper_scripts() {
1209 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1210 die "${FUNCNAME}() can be used only in src_install() phase"
1211 fi
1212
1213 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1214 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1215 fi
1216
1217 _python_check_python_pkg_setup_execution
1218 _python_initialize_prefix_variables
1219
1220 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0"
547 1221
548 while (($#)); do 1222 while (($#)); do
549 case "$1" in 1223 case "$1" in
550 -r|--recursive) 1224 -E|--respect-EPYTHON)
551 recursive="1" 1225 respect_EPYTHON="1"
1226 ;;
1227 -f|--force)
1228 force="1"
552 ;; 1229 ;;
553 -q|--quiet) 1230 -q|--quiet)
554 quiet="1" 1231 quiet="1"
555 ;; 1232 ;;
556 -x|--only-executables)
557 only_executables="1"
558 ;;
559 --) 1233 --)
1234 shift
560 break 1235 break
561 ;; 1236 ;;
562 -*) 1237 -*)
563 die "${FUNCNAME}(): Unrecognized option '$1'" 1238 die "${FUNCNAME}(): Unrecognized option '$1'"
564 ;; 1239 ;;
568 esac 1243 esac
569 shift 1244 shift
570 done 1245 done
571 1246
572 if [[ "$#" -eq 0 ]]; then 1247 if [[ "$#" -eq 0 ]]; then
573 die "${FUNCNAME}(): Missing Python version and files or directories" 1248 die "${FUNCNAME}(): Missing arguments"
1249 fi
1250
1251 _python_calculate_PYTHON_ABIS
1252 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1253 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1254 python2_enabled="1"
1255 fi
1256 done
1257 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1258 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1259 python3_enabled="1"
1260 fi
1261 done
1262
1263 if [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "1" ]]; then
1264 eselect_python_option=
1265 elif [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "0" ]]; then
1266 eselect_python_option="--python2"
1267 elif [[ "${python2_enabled}" == "0" && "${python3_enabled}" == "1" ]]; then
1268 eselect_python_option="--python3"
1269 else
1270 die "${FUNCNAME}(): Unsupported environment"
1271 fi
1272
1273 PYTHON_ABIS_list="$("$(PYTHON -f)" -c "print(', '.join('\"%s\"' % x for x in reversed('${PYTHON_ABIS}'.split())))")"
1274
1275 for file in "$@"; do
1276 if [[ -f "${file}" && "${force}" == "0" ]]; then
1277 die "${FUNCNAME}(): '${file}' already exists"
1278 fi
1279
1280 if [[ "${quiet}" == "0" ]]; then
1281 einfo "Generating '${file#${ED%/}}' wrapper script"
1282 fi
1283
1284 cat << EOF > "${file}"
1285#!/usr/bin/env python
1286# Gentoo '${file##*/}' wrapper script generated by python_generate_wrapper_scripts()
1287
1288import os
1289import re
1290import subprocess
1291import sys
1292
1293cpython_ABI_re = re.compile(r"^(\d+\.\d+)$")
1294jython_ABI_re = re.compile(r"^(\d+\.\d+)-jython$")
1295pypy_ABI_re = re.compile(r"^\d+\.\d+-pypy-(\d+\.\d+)$")
1296cpython_interpreter_re = re.compile(r"^python(\d+\.\d+)$")
1297jython_interpreter_re = re.compile(r"^jython(\d+\.\d+)$")
1298pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$")
1299cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)")
1300python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)")
1301python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1302
1303pypy_versions_mapping = {
1304 "1.5": "2.7",
1305 "1.6": "2.7",
1306 "1.7": "2.7",
1307 "1.8": "2.7",
1308 "1.9": "2.7",
1309}
1310
1311def get_PYTHON_ABI(python_interpreter):
1312 cpython_matched = cpython_interpreter_re.match(python_interpreter)
1313 jython_matched = jython_interpreter_re.match(python_interpreter)
1314 pypy_matched = pypy_interpreter_re.match(python_interpreter)
1315 if cpython_matched is not None:
1316 PYTHON_ABI = cpython_matched.group(1)
1317 elif jython_matched is not None:
1318 PYTHON_ABI = jython_matched.group(1) + "-jython"
1319 elif pypy_matched is not None:
1320 PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1)
1321 else:
1322 PYTHON_ABI = None
1323 return PYTHON_ABI
1324
1325def get_python_interpreter(PYTHON_ABI):
1326 cpython_matched = cpython_ABI_re.match(PYTHON_ABI)
1327 jython_matched = jython_ABI_re.match(PYTHON_ABI)
1328 pypy_matched = pypy_ABI_re.match(PYTHON_ABI)
1329 if cpython_matched is not None:
1330 python_interpreter = "python" + cpython_matched.group(1)
1331 elif jython_matched is not None:
1332 python_interpreter = "jython" + jython_matched.group(1)
1333 elif pypy_matched is not None:
1334 python_interpreter = "pypy-c" + pypy_matched.group(1)
1335 else:
1336 python_interpreter = None
1337 return python_interpreter
1338
1339EOF
1340 if [[ "$?" != "0" ]]; then
1341 die "${FUNCNAME}(): Generation of '$1' failed"
1342 fi
1343 if [[ "${respect_EPYTHON}" == "1" ]]; then
1344 cat << EOF >> "${file}"
1345python_interpreter = os.environ.get("EPYTHON")
1346if python_interpreter:
1347 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1348 if PYTHON_ABI is None:
1349 sys.stderr.write("%s: EPYTHON variable has unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1350 sys.exit(1)
1351else:
1352 try:
1353 environment = os.environ.copy()
1354 environment["ROOT"] = "/"
1355 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1356 if eselect_process.wait() != 0:
1357 raise ValueError
1358 except (OSError, ValueError):
1359 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1360 sys.exit(1)
1361
1362 python_interpreter = eselect_process.stdout.read()
1363 if not isinstance(python_interpreter, str):
1364 # Python 3
1365 python_interpreter = python_interpreter.decode()
1366 python_interpreter = python_interpreter.rstrip("\n")
1367
1368 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1369 if PYTHON_ABI is None:
1370 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1371 sys.exit(1)
1372
1373wrapper_script_path = os.path.realpath(sys.argv[0])
1374target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1375if not os.path.exists(target_executable_path):
1376 sys.stderr.write("%s: '%s' does not exist\n" % (sys.argv[0], target_executable_path))
1377 sys.exit(1)
1378EOF
1379 if [[ "$?" != "0" ]]; then
1380 die "${FUNCNAME}(): Generation of '$1' failed"
1381 fi
1382 else
1383 cat << EOF >> "${file}"
1384try:
1385 environment = os.environ.copy()
1386 environment["ROOT"] = "/"
1387 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1388 if eselect_process.wait() != 0:
1389 raise ValueError
1390except (OSError, ValueError):
1391 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1392 sys.exit(1)
1393
1394python_interpreter = eselect_process.stdout.read()
1395if not isinstance(python_interpreter, str):
1396 # Python 3
1397 python_interpreter = python_interpreter.decode()
1398python_interpreter = python_interpreter.rstrip("\n")
1399
1400PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1401if PYTHON_ABI is None:
1402 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1403 sys.exit(1)
1404
1405wrapper_script_path = os.path.realpath(sys.argv[0])
1406for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]:
1407 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1408 if os.path.exists(target_executable_path):
1409 break
1410else:
1411 sys.stderr.write("%s: No target script exists for '%s'\n" % (sys.argv[0], wrapper_script_path))
1412 sys.exit(1)
1413
1414python_interpreter = get_python_interpreter(PYTHON_ABI)
1415if python_interpreter is None:
1416 sys.stderr.write("%s: Unrecognized Python ABI '%s'\n" % (sys.argv[0], PYTHON_ABI))
1417 sys.exit(1)
1418EOF
1419 if [[ "$?" != "0" ]]; then
1420 die "${FUNCNAME}(): Generation of '$1' failed"
1421 fi
1422 fi
1423 cat << EOF >> "${file}"
1424
1425target_executable = open(target_executable_path, "rb")
1426target_executable_first_line = target_executable.readline()
1427target_executable.close()
1428if not isinstance(target_executable_first_line, str):
1429 # Python 3
1430 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace")
1431
1432options = []
1433python_shebang_options_matched = python_shebang_options_re.match(target_executable_first_line)
1434if python_shebang_options_matched is not None:
1435 options = [python_shebang_options_matched.group(1)]
1436
1437cpython_shebang_matched = cpython_shebang_re.match(target_executable_first_line)
1438
1439if cpython_shebang_matched is not None:
1440 try:
1441 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % python_interpreter
1442 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1"
1443 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE)
1444 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"]
1445 if python_verification_process.wait() != 0:
1446 raise ValueError
1447
1448 python_verification_output = python_verification_process.stdout.read()
1449 if not isinstance(python_verification_output, str):
1450 # Python 3
1451 python_verification_output = python_verification_output.decode()
1452
1453 if not python_verification_output_re.match(python_verification_output):
1454 raise ValueError
1455
1456 if cpython_interpreter_re.match(python_interpreter) is not None:
1457 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0])
1458 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0]
1459 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path
1460
1461 if hasattr(os, "execv"):
1462 os.execv(python_interpreter_path, [python_interpreter_path] + options + sys.argv)
1463 else:
1464 sys.exit(subprocess.Popen([python_interpreter_path] + options + sys.argv).wait())
1465 except (KeyboardInterrupt, SystemExit):
1466 raise
1467 except:
1468 pass
1469 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"):
1470 if variable in os.environ:
1471 del os.environ[variable]
1472
1473if hasattr(os, "execv"):
1474 os.execv(target_executable_path, sys.argv)
1475else:
1476 sys.exit(subprocess.Popen([target_executable_path] + sys.argv[1:]).wait())
1477EOF
1478 if [[ "$?" != "0" ]]; then
1479 die "${FUNCNAME}(): Generation of '$1' failed"
1480 fi
1481 fperms +x "${file#${ED%/}}" || die "fperms '${file}' failed"
1482 done
1483}
1484
1485# @ECLASS-VARIABLE: PYTHON_VERSIONED_SCRIPTS
1486# @DESCRIPTION:
1487# Array of regular expressions of paths to versioned Python scripts.
1488# Python scripts in /usr/bin and /usr/sbin are versioned by default.
1489
1490# @ECLASS-VARIABLE: PYTHON_VERSIONED_EXECUTABLES
1491# @DESCRIPTION:
1492# Array of regular expressions of paths to versioned executables (including Python scripts).
1493
1494# @ECLASS-VARIABLE: PYTHON_NONVERSIONED_EXECUTABLES
1495# @DESCRIPTION:
1496# Array of regular expressions of paths to nonversioned executables (including Python scripts).
1497
1498# @FUNCTION: python_merge_intermediate_installation_images
1499# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory>
1500# @DESCRIPTION:
1501# Merge intermediate installation images into installation image.
1502#
1503# This function can be used only in src_install() phase.
1504python_merge_intermediate_installation_images() {
1505 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1506 die "${FUNCNAME}() can be used only in src_install() phase"
1507 fi
1508
1509 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1510 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1511 fi
1512
1513 _python_check_python_pkg_setup_execution
1514 _python_initialize_prefix_variables
1515
1516 local absolute_file b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=()
1517
1518 while (($#)); do
1519 case "$1" in
1520 -q|--quiet)
1521 quiet="1"
1522 ;;
1523 --)
1524 shift
1525 break
1526 ;;
1527 -*)
1528 die "${FUNCNAME}(): Unrecognized option '$1'"
1529 ;;
1530 *)
1531 break
1532 ;;
1533 esac
1534 shift
1535 done
1536
1537 if [[ "$#" -ne 1 ]]; then
1538 die "${FUNCNAME}() requires 1 argument"
1539 fi
1540
1541 intermediate_installation_images_directory="$1"
1542
1543 if [[ ! -d "${intermediate_installation_images_directory}" ]]; then
1544 die "${FUNCNAME}(): Intermediate installation images directory '${intermediate_installation_images_directory}' does not exist"
1545 fi
1546
1547 _python_calculate_PYTHON_ABIS
1548 if [[ "$(PYTHON -f --ABI)" == 3.* ]]; then
1549 b="b"
1550 fi
1551
1552 while read -d $'\0' -r file; do
1553 files+=("${file}")
1554 done < <("$(PYTHON -f)" -c \
1555"import os
1556import sys
1557
1558if hasattr(sys.stdout, 'buffer'):
1559 # Python 3
1560 stdout = sys.stdout.buffer
1561else:
1562 # Python 2
1563 stdout = sys.stdout
1564
1565files_set = set()
1566
1567os.chdir(${b}'${intermediate_installation_images_directory}')
1568
1569for PYTHON_ABI in ${b}'${PYTHON_ABIS}'.split():
1570 for root, dirs, files in os.walk(PYTHON_ABI + ${b}'${EPREFIX}'):
1571 root = root[len(PYTHON_ABI + ${b}'${EPREFIX}')+1:]
1572 files_set.update(root + ${b}'/' + file for file in files)
1573
1574for file in sorted(files_set):
1575 stdout.write(file)
1576 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of files in intermediate installation images")
1577
1578 for PYTHON_ABI in ${PYTHON_ABIS}; do
1579 if [[ ! -d "${intermediate_installation_images_directory}/${PYTHON_ABI}" ]]; then
1580 die "${FUNCNAME}(): Intermediate installation image for Python ABI '${PYTHON_ABI}' does not exist"
1581 fi
1582
1583 pushd "${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}" > /dev/null || die "pushd failed"
1584
1585 for file in "${files[@]}"; do
1586 version_executable="0"
1587 for regex in "/usr/bin/.*" "/usr/sbin/.*" "${PYTHON_VERSIONED_SCRIPTS[@]}"; do
1588 if [[ "/${file}" =~ ^${regex}$ ]]; then
1589 version_executable="1"
1590 break
1591 fi
1592 done
1593 for regex in "${PYTHON_VERSIONED_EXECUTABLES[@]}"; do
1594 if [[ "/${file}" =~ ^${regex}$ ]]; then
1595 version_executable="2"
1596 break
1597 fi
1598 done
1599 if [[ "${version_executable}" != "0" ]]; then
1600 for regex in "${PYTHON_NONVERSIONED_EXECUTABLES[@]}"; do
1601 if [[ "/${file}" =~ ^${regex}$ ]]; then
1602 version_executable="0"
1603 break
1604 fi
1605 done
1606 fi
1607
1608 [[ "${version_executable}" == "0" ]] && continue
1609
1610 if [[ -L "${file}" ]]; then
1611 absolute_file="$(readlink "${file}")"
1612 if [[ "${absolute_file}" == /* ]]; then
1613 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file##/}"
1614 else
1615 if [[ "${file}" == */* ]]; then
1616 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file%/*}/${absolute_file}"
1617 else
1618 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file}"
1619 fi
1620 fi
1621 else
1622 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file}"
1623 fi
1624
1625 [[ ! -x "${absolute_file}" ]] && continue
1626
1627 shebang="$(head -n1 "${absolute_file}")" || die "Extraction of shebang from '${absolute_file}' failed"
1628
1629 if [[ "${version_executable}" == "2" ]]; then
1630 wrapper_scripts+=("${ED}${file}")
1631 elif [[ "${version_executable}" == "1" ]]; then
1632 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then
1633 wrapper_scripts+=("${ED}${file}")
1634 else
1635 version_executable="0"
1636 fi
1637 fi
1638
1639 [[ "${version_executable}" == "0" ]] && continue
1640
1641 if [[ -e "${file}-${PYTHON_ABI}" ]]; then
1642 die "${FUNCNAME}(): '${EPREFIX}/${file}-${PYTHON_ABI}' already exists"
1643 fi
1644
1645 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed"
1646
1647 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then
1648 if [[ -L "${file}-${PYTHON_ABI}" ]]; then
1649 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${absolute_file}"
1650 else
1651 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}"
1652 fi
1653 fi
1654 done
1655
1656 popd > /dev/null || die "popd failed"
1657
1658 # This is per bug #390691, without the duplication refactor, and with
1659 # the 3-way structure per comment #6. This enable users with old
1660 # coreutils to upgrade a lot easier (you need to upgrade python+portage
1661 # before coreutils can be upgraded).
1662 if ROOT="/" has_version '>=sys-apps/coreutils-6.9.90'; then
1663 cp -fr --preserve=all --no-preserve=context "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1664 elif ROOT="/" has_version sys-apps/coreutils; then
1665 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1666 else
1667 cp -fpr "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1668 fi
1669 done
1670
1671 rm -fr "${intermediate_installation_images_directory}"
1672
1673 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then
1674 rm -f "${T}/python_wrapper_scripts"
1675
1676 for file in "${wrapper_scripts[@]}"; do
1677 echo -n "${file}" >> "${T}/python_wrapper_scripts"
1678 echo -en "\x00" >> "${T}/python_wrapper_scripts"
1679 done
1680
1681 while read -d $'\0' -r file; do
1682 wrapper_scripts_set+=("${file}")
1683 done < <("$(PYTHON -f)" -c \
1684"import sys
1685
1686if hasattr(sys.stdout, 'buffer'):
1687 # Python 3
1688 stdout = sys.stdout.buffer
1689else:
1690 # Python 2
1691 stdout = sys.stdout
1692
1693python_wrapper_scripts_file = open('${T}/python_wrapper_scripts', 'rb')
1694files = set(python_wrapper_scripts_file.read().rstrip(${b}'\x00').split(${b}'\x00'))
1695python_wrapper_scripts_file.close()
1696
1697for file in sorted(files):
1698 stdout.write(file)
1699 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts")
1700
1701 python_generate_wrapper_scripts $([[ "${quiet}" == "1" ]] && echo --quiet) "${wrapper_scripts_set[@]}"
1702 fi
1703}
1704
1705# ================================================================================================
1706# ========= FUNCTIONS FOR PACKAGES NOT SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ==========
1707# ================================================================================================
1708
1709unset EPYTHON PYTHON_ABI
1710
1711# @FUNCTION: python_set_active_version
1712# @USAGE: <Python_ABI|2|3>
1713# @DESCRIPTION:
1714# Set locally active version of Python.
1715# If Python_ABI argument is specified, then version of Python corresponding to Python_ABI is used.
1716# If 2 argument is specified, then active version of CPython 2 is used.
1717# If 3 argument is specified, then active version of CPython 3 is used.
1718#
1719# This function can be used only in pkg_setup() phase.
1720python_set_active_version() {
1721 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
1722 die "${FUNCNAME}() can be used only in pkg_setup() phase"
1723 fi
1724
1725 if _python_package_supporting_installation_for_multiple_python_abis; then
1726 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1727 fi
1728
1729 if [[ "$#" -ne 1 ]]; then
1730 die "${FUNCNAME}() requires 1 argument"
1731 fi
1732
1733 _python_initial_sanity_checks
1734
1735 if [[ -z "${PYTHON_ABI}" ]]; then
1736 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
1737 # PYTHON_ABI variable is intended to be used only in ebuilds/eclasses,
1738 # so it does not need to be exported to subprocesses.
1739 PYTHON_ABI="$1"
1740 if ! _python_implementation && ! has_version "$(python_get_implementational_package)"; then
1741 die "${FUNCNAME}(): '$(python_get_implementational_package)' is not installed"
1742 fi
1743 export EPYTHON="$(PYTHON "$1")"
1744 elif [[ "$1" == "2" ]]; then
1745 if ! _python_implementation && ! has_version "=dev-lang/python-2*"; then
1746 die "${FUNCNAME}(): '=dev-lang/python-2*' is not installed"
1747 fi
1748 export EPYTHON="$(PYTHON -2)"
1749 PYTHON_ABI="${EPYTHON#python}"
1750 PYTHON_ABI="${PYTHON_ABI%%-*}"
1751 elif [[ "$1" == "3" ]]; then
1752 if ! _python_implementation && ! has_version "=dev-lang/python-3*"; then
1753 die "${FUNCNAME}(): '=dev-lang/python-3*' is not installed"
1754 fi
1755 export EPYTHON="$(PYTHON -3)"
1756 PYTHON_ABI="${EPYTHON#python}"
1757 PYTHON_ABI="${PYTHON_ABI%%-*}"
1758 else
1759 die "${FUNCNAME}(): Unrecognized argument '$1'"
1760 fi
1761 fi
1762
1763 _python_final_sanity_checks
1764
1765 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable.
1766 PYTHON_REQUESTED_ACTIVE_VERSION="$1"
1767}
1768
1769# @FUNCTION: python_need_rebuild
1770# @DESCRIPTION:
1771# Mark current package for rebuilding by python-updater after
1772# switching of active version of Python.
1773python_need_rebuild() {
1774 if _python_package_supporting_installation_for_multiple_python_abis; then
1775 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1776 fi
1777
1778 _python_check_python_pkg_setup_execution
1779
1780 if [[ "$#" -ne 0 ]]; then
1781 die "${FUNCNAME}() does not accept arguments"
1782 fi
1783
1784 export PYTHON_NEED_REBUILD="$(PYTHON --ABI)"
1785}
1786
1787# ================================================================================================
1788# ======================================= GETTER FUNCTIONS =======================================
1789# ================================================================================================
1790
1791_PYTHON_ABI_EXTRACTION_COMMAND=\
1792'import platform
1793import sys
1794sys.stdout.write(".".join(str(x) for x in sys.version_info[:2]))
1795if platform.system()[:4] == "Java":
1796 sys.stdout.write("-jython")
1797elif hasattr(platform, "python_implementation") and platform.python_implementation() == "PyPy":
1798 sys.stdout.write("-pypy-" + ".".join(str(x) for x in sys.pypy_version_info[:2]))'
1799
1800_python_get_implementation() {
1801 local ignore_invalid="0"
1802
1803 while (($#)); do
1804 case "$1" in
1805 --ignore-invalid)
1806 ignore_invalid="1"
1807 ;;
1808 --)
1809 shift
1810 break
1811 ;;
1812 -*)
1813 die "${FUNCNAME}(): Unrecognized option '$1'"
1814 ;;
1815 *)
1816 break
1817 ;;
1818 esac
1819 shift
1820 done
1821
1822 if [[ "$#" -ne 1 ]]; then
1823 die "${FUNCNAME}() requires 1 argument"
1824 fi
1825
1826 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
1827 echo "CPython"
1828 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
1829 echo "Jython"
1830 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
1831 echo "PyPy"
1832 else
1833 if [[ "${ignore_invalid}" == "0" ]]; then
1834 die "${FUNCNAME}(): Unrecognized Python ABI '$1'"
1835 fi
1836 fi
1837}
1838
1839# @FUNCTION: PYTHON
1840# @USAGE: [-2] [-3] [--ABI] [-a|--absolute-path] [-f|--final-ABI] [--] <Python_ABI="${PYTHON_ABI}">
1841# @DESCRIPTION:
1842# Print filename of Python interpreter for specified Python ABI. If Python_ABI argument
1843# is ommitted, then PYTHON_ABI environment variable must be set and is used.
1844# If -2 option is specified, then active version of CPython 2 is used.
1845# If -3 option is specified, then active version of CPython 3 is used.
1846# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1847# -2, -3 and --final-ABI options and Python_ABI argument cannot be specified simultaneously.
1848# If --ABI option is specified, then only specified Python ABI is printed instead of
1849# filename of Python interpreter.
1850# If --absolute-path option is specified, then absolute path to Python interpreter is printed.
1851# --ABI and --absolute-path options cannot be specified simultaneously.
1852PYTHON() {
1853 _python_check_python_pkg_setup_execution
1854
1855 local ABI_output="0" absolute_path_output="0" final_ABI="0" PYTHON_ABI="${PYTHON_ABI}" python_interpreter python2="0" python3="0"
1856
1857 while (($#)); do
1858 case "$1" in
1859 -2)
1860 python2="1"
1861 ;;
1862 -3)
1863 python3="1"
1864 ;;
1865 --ABI)
1866 ABI_output="1"
1867 ;;
1868 -a|--absolute-path)
1869 absolute_path_output="1"
1870 ;;
1871 -f|--final-ABI)
1872 final_ABI="1"
1873 ;;
1874 --)
1875 shift
1876 break
1877 ;;
1878 -*)
1879 die "${FUNCNAME}(): Unrecognized option '$1'"
1880 ;;
1881 *)
1882 break
1883 ;;
1884 esac
1885 shift
1886 done
1887
1888 if [[ "${ABI_output}" == "1" && "${absolute_path_output}" == "1" ]]; then
1889 die "${FUNCNAME}(): '--ABI' and '--absolute-path' options cannot be specified simultaneously"
1890 fi
1891
1892 if [[ "$((${python2} + ${python3} + ${final_ABI}))" -gt 1 ]]; then
1893 die "${FUNCNAME}(): '-2', '-3' or '--final-ABI' options cannot be specified simultaneously"
1894 fi
1895
1896 if [[ "$#" -eq 0 ]]; then
1897 if [[ "${final_ABI}" == "1" ]]; then
1898 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1899 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1900 fi
1901 _python_calculate_PYTHON_ABIS
1902 PYTHON_ABI="${PYTHON_ABIS##* }"
1903 elif [[ "${python2}" == "1" ]]; then
1904 PYTHON_ABI="$(ROOT="/" eselect python show --python2 --ABI)"
1905 if [[ -z "${PYTHON_ABI}" ]]; then
1906 die "${FUNCNAME}(): Active version of CPython 2 not set"
1907 elif [[ "${PYTHON_ABI}" != "2."* ]]; then
1908 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`"
1909 fi
1910 elif [[ "${python3}" == "1" ]]; then
1911 PYTHON_ABI="$(ROOT="/" eselect python show --python3 --ABI)"
1912 if [[ -z "${PYTHON_ABI}" ]]; then
1913 die "${FUNCNAME}(): Active version of CPython 3 not set"
1914 elif [[ "${PYTHON_ABI}" != "3."* ]]; then
1915 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`"
1916 fi
1917 elif _python_package_supporting_installation_for_multiple_python_abis; then
1918 if ! _python_abi-specific_local_scope; then
1919 die "${FUNCNAME}() should be used in ABI-specific local scope"
1920 fi
1921 else
1922 PYTHON_ABI="$("${EPREFIX}/usr/bin/python" -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")"
1923 if [[ -z "${PYTHON_ABI}" ]]; then
1924 die "${FUNCNAME}(): Failure of extraction of locally active version of Python"
1925 fi
1926 fi
574 elif [[ "$#" -eq 1 ]]; then 1927 elif [[ "$#" -eq 1 ]]; then
575 die "${FUNCNAME}(): Missing files or directories"
576 fi
577
578 python_version="$1"
579 shift
580
581 for argument in "$@"; do
582 if [[ ! -e "${argument}" ]]; then
583 die "${FUNCNAME}(): '${argument}' doesn't exist"
584 elif [[ -f "${argument}" ]]; then
585 files+=("${argument}")
586 elif [[ -d "${argument}" ]]; then
587 if [[ "${recursive}" == "1" ]]; then 1928 if [[ "${final_ABI}" == "1" ]]; then
588 if [[ "${only_executables}" == "1" ]]; then 1929 die "${FUNCNAME}(): '--final-ABI' option and Python ABI cannot be specified simultaneously"
589 files+=($(find "${argument}" -perm /111 -type f))
590 else
591 files+=($(find "${argument}" -type f))
592 fi
593 else
594 die "${FUNCNAME}(): '${argument}' isn't a regular file"
595 fi 1930 fi
1931 if [[ "${python2}" == "1" ]]; then
1932 die "${FUNCNAME}(): '-2' option and Python ABI cannot be specified simultaneously"
1933 fi
1934 if [[ "${python3}" == "1" ]]; then
1935 die "${FUNCNAME}(): '-3' option and Python ABI cannot be specified simultaneously"
1936 fi
1937 PYTHON_ABI="$1"
1938 else
1939 die "${FUNCNAME}(): Invalid usage"
1940 fi
1941
1942 if [[ "${ABI_output}" == "1" ]]; then
1943 echo -n "${PYTHON_ABI}"
1944 return
1945 else
1946 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1947 python_interpreter="python${PYTHON_ABI}"
1948 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1949 python_interpreter="jython${PYTHON_ABI%-jython}"
1950 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
1951 python_interpreter="pypy-c${PYTHON_ABI#*-pypy-}"
1952 fi
1953
1954 if [[ "${absolute_path_output}" == "1" ]]; then
1955 echo -n "${EPREFIX}/usr/bin/${python_interpreter}"
596 else 1956 else
597 die "${FUNCNAME}(): '${argument}' isn't a regular file or a directory" 1957 echo -n "${python_interpreter}"
598 fi
599 done
600
601 for file in "${files[@]}"; do
602 file="${file#./}"
603 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
604
605 if [[ "$(head -n1 "${file}")" =~ ^'#!'.*python ]]; then
606 [[ "${quiet}" == "0" ]] && einfo "Converting shebang in '${file}'"
607 sed -e "1s/python\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?/python${python_version}/" -i "${file}" || die "Conversion of shebang in '${file}' failed"
608
609 # Delete potential whitespace after "#!".
610 sed -e '1s/\(^#!\)[[:space:]]*/\1/' -i "${file}" || die "sed '${file}' failed"
611 fi
612 done
613}
614
615# @ECLASS-VARIABLE: PYTHON_USE_WITH
616# @DESCRIPTION:
617# Set this to a space separated list of use flags
618# the python slot in use must be built with.
619
620# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR
621# @DESCRIPTION:
622# Set this to a space separated list of use flags
623# of which one must be turned on for the slot of
624# in use.
625
626# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT
627# @DESCRIPTION:
628# Set this if you need to make either PYTHON_USE_WITH or
629# PYTHON_USE_WITH_OR atoms conditional under a use flag.
630
631# @FUNCTION: python_pkg_setup
632# @DESCRIPTION:
633# Makes sure PYTHON_USE_WITH or PYTHON_USE_WITH_OR listed use flags
634# are respected. Only exported if one of those variables is set.
635if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
636 python_pkg_setup() {
637 python_pkg_setup_fail() {
638 eerror "${1}"
639 die "${1}"
640 }
641
642 [[ ${PYTHON_USE_WITH_OPT} ]] && use !${PYTHON_USE_WITH_OPT} && return
643
644 python_pkg_setup_check_USE_flags() {
645 local pyatom use
646 if [[ -n "${PYTHON_ABI}" ]]; then
647 pyatom="dev-lang/python:${PYTHON_ABI}"
648 else
649 python_version
650 pyatom="dev-lang/python:${PYVER}"
651 fi 1958 fi
1959 fi
652 1960
653 for use in ${PYTHON_USE_WITH}; do 1961 if [[ -n "${ABI}" && "${ABI}" != "${DEFAULT_ABI}" && "${DEFAULT_ABI}" != "default" ]]; then
654 if ! has_version "${pyatom}[${use}]"; then 1962 echo -n "-${ABI}"
655 python_pkg_setup_fail "Please rebuild ${pyatom} with the following USE flags enabled: ${PYTHON_USE_WITH}" 1963 fi
1964}
1965
1966# @FUNCTION: python_get_implementation
1967# @USAGE: [-f|--final-ABI]
1968# @DESCRIPTION:
1969# Print name of Python implementation.
1970# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1971python_get_implementation() {
1972 _python_check_python_pkg_setup_execution
1973
1974 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
1975
1976 while (($#)); do
1977 case "$1" in
1978 -f|--final-ABI)
1979 final_ABI="1"
1980 ;;
1981 -*)
1982 die "${FUNCNAME}(): Unrecognized option '$1'"
1983 ;;
1984 *)
1985 die "${FUNCNAME}(): Invalid usage"
1986 ;;
1987 esac
1988 shift
1989 done
1990
1991 if [[ "${final_ABI}" == "1" ]]; then
1992 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1993 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1994 fi
1995 PYTHON_ABI="$(PYTHON -f --ABI)"
1996 else
1997 if _python_package_supporting_installation_for_multiple_python_abis; then
1998 if ! _python_abi-specific_local_scope; then
1999 die "${FUNCNAME}() should be used in ABI-specific local scope"
656 fi 2000 fi
657 done
658
659 for use in ${PYTHON_USE_WITH_OR}; do
660 if has_version "${pyatom}[${use}]"; then
661 return
662 fi
663 done
664
665 if [[ ${PYTHON_USE_WITH_OR} ]]; then
666 python_pkg_setup_fail "Please rebuild ${pyatom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
667 fi
668 }
669
670 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
671 python_execute_function -q python_pkg_setup_check_USE_flags
672 else 2001 else
673 python_pkg_setup_check_USE_flags 2002 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2003 fi
2004 fi
2005
2006 echo "$(_python_get_implementation "${PYTHON_ABI}")"
2007}
2008
2009# @FUNCTION: python_get_implementational_package
2010# @USAGE: [-f|--final-ABI]
2011# @DESCRIPTION:
2012# Print category, name and slot of package providing Python implementation.
2013# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2014python_get_implementational_package() {
2015 _python_check_python_pkg_setup_execution
2016
2017 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2018
2019 while (($#)); do
2020 case "$1" in
2021 -f|--final-ABI)
2022 final_ABI="1"
2023 ;;
2024 -*)
2025 die "${FUNCNAME}(): Unrecognized option '$1'"
2026 ;;
2027 *)
2028 die "${FUNCNAME}(): Invalid usage"
2029 ;;
2030 esac
2031 shift
2032 done
2033
2034 if [[ "${final_ABI}" == "1" ]]; then
2035 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2036 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2037 fi
2038 PYTHON_ABI="$(PYTHON -f --ABI)"
2039 else
2040 if _python_package_supporting_installation_for_multiple_python_abis; then
2041 if ! _python_abi-specific_local_scope; then
2042 die "${FUNCNAME}() should be used in ABI-specific local scope"
674 fi 2043 fi
2044 else
2045 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2046 fi
2047 fi
2048
2049 if [[ "${EAPI:-0}" == "0" ]]; then
2050 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2051 echo "=dev-lang/python-${PYTHON_ABI}*"
2052 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2053 echo "=dev-java/jython-${PYTHON_ABI%-jython}*"
2054 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2055 echo "=dev-python/pypy-${PYTHON_ABI#*-pypy-}*"
2056 fi
2057 else
2058 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2059 echo "dev-lang/python:${PYTHON_ABI}"
2060 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2061 echo "dev-java/jython:${PYTHON_ABI%-jython}"
2062 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2063 echo "dev-python/pypy:${PYTHON_ABI#*-pypy-}"
2064 fi
2065 fi
2066}
2067
2068# @FUNCTION: python_get_includedir
2069# @USAGE: [-b|--base-path] [-f|--final-ABI]
2070# @DESCRIPTION:
2071# Print path to Python include directory.
2072# If --base-path option is specified, then path not prefixed with "/" is printed.
2073# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2074python_get_includedir() {
2075 _python_check_python_pkg_setup_execution
2076
2077 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2078
2079 while (($#)); do
2080 case "$1" in
2081 -b|--base-path)
2082 base_path="1"
2083 ;;
2084 -f|--final-ABI)
2085 final_ABI="1"
2086 ;;
2087 -*)
2088 die "${FUNCNAME}(): Unrecognized option '$1'"
2089 ;;
2090 *)
2091 die "${FUNCNAME}(): Invalid usage"
2092 ;;
2093 esac
2094 shift
2095 done
2096
2097 if [[ "${base_path}" == "0" ]]; then
2098 prefix="/"
2099 fi
2100
2101 if [[ "${final_ABI}" == "1" ]]; then
2102 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2103 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2104 fi
2105 PYTHON_ABI="$(PYTHON -f --ABI)"
2106 else
2107 if _python_package_supporting_installation_for_multiple_python_abis; then
2108 if ! _python_abi-specific_local_scope; then
2109 die "${FUNCNAME}() should be used in ABI-specific local scope"
2110 fi
2111 else
2112 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2113 fi
2114 fi
2115
2116 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2117 echo "${prefix}usr/include/python${PYTHON_ABI}"
2118 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2119 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include"
2120 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2121 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/include"
2122 fi
2123}
2124
2125# @FUNCTION: python_get_libdir
2126# @USAGE: [-b|--base-path] [-f|--final-ABI]
2127# @DESCRIPTION:
2128# Print path to Python standard library directory.
2129# If --base-path option is specified, then path not prefixed with "/" is printed.
2130# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2131python_get_libdir() {
2132 _python_check_python_pkg_setup_execution
2133
2134 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2135
2136 while (($#)); do
2137 case "$1" in
2138 -b|--base-path)
2139 base_path="1"
2140 ;;
2141 -f|--final-ABI)
2142 final_ABI="1"
2143 ;;
2144 -*)
2145 die "${FUNCNAME}(): Unrecognized option '$1'"
2146 ;;
2147 *)
2148 die "${FUNCNAME}(): Invalid usage"
2149 ;;
2150 esac
2151 shift
2152 done
2153
2154 if [[ "${base_path}" == "0" ]]; then
2155 prefix="/"
2156 fi
2157
2158 if [[ "${final_ABI}" == "1" ]]; then
2159 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2160 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2161 fi
2162 PYTHON_ABI="$(PYTHON -f --ABI)"
2163 else
2164 if _python_package_supporting_installation_for_multiple_python_abis; then
2165 if ! _python_abi-specific_local_scope; then
2166 die "${FUNCNAME}() should be used in ABI-specific local scope"
2167 fi
2168 else
2169 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2170 fi
2171 fi
2172
2173 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2174 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}"
2175 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2176 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib"
2177 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2178 die "${FUNCNAME}(): PyPy has multiple standard library directories"
2179 fi
2180}
2181
2182# @FUNCTION: python_get_sitedir
2183# @USAGE: [-b|--base-path] [-f|--final-ABI]
2184# @DESCRIPTION:
2185# Print path to Python site-packages directory.
2186# If --base-path option is specified, then path not prefixed with "/" is printed.
2187# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2188python_get_sitedir() {
2189 _python_check_python_pkg_setup_execution
2190
2191 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2192
2193 while (($#)); do
2194 case "$1" in
2195 -b|--base-path)
2196 base_path="1"
2197 ;;
2198 -f|--final-ABI)
2199 final_ABI="1"
2200 ;;
2201 -*)
2202 die "${FUNCNAME}(): Unrecognized option '$1'"
2203 ;;
2204 *)
2205 die "${FUNCNAME}(): Invalid usage"
2206 ;;
2207 esac
2208 shift
2209 done
2210
2211 if [[ "${base_path}" == "0" ]]; then
2212 prefix="/"
2213 fi
2214
2215 if [[ "${final_ABI}" == "1" ]]; then
2216 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2217 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2218 fi
2219 PYTHON_ABI="$(PYTHON -f --ABI)"
2220 else
2221 if _python_package_supporting_installation_for_multiple_python_abis; then
2222 if ! _python_abi-specific_local_scope; then
2223 die "${FUNCNAME}() should be used in ABI-specific local scope"
2224 fi
2225 else
2226 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2227 fi
2228 fi
2229
2230 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2231 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}/site-packages"
2232 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2233 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib/site-packages"
2234 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2235 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/site-packages"
2236 fi
2237}
2238
2239# @FUNCTION: python_get_library
2240# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option]
2241# @DESCRIPTION:
2242# Print path to Python library.
2243# If --base-path option is specified, then path not prefixed with "/" is printed.
2244# If --linker-option is specified, then "-l${library}" linker option is printed.
2245# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2246python_get_library() {
2247 _python_check_python_pkg_setup_execution
2248
2249 local base_path="0" final_ABI="0" linker_option="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2250
2251 while (($#)); do
2252 case "$1" in
2253 -b|--base-path)
2254 base_path="1"
2255 ;;
2256 -f|--final-ABI)
2257 final_ABI="1"
2258 ;;
2259 -l|--linker-option)
2260 linker_option="1"
2261 ;;
2262 -*)
2263 die "${FUNCNAME}(): Unrecognized option '$1'"
2264 ;;
2265 *)
2266 die "${FUNCNAME}(): Invalid usage"
2267 ;;
2268 esac
2269 shift
2270 done
2271
2272 if [[ "${base_path}" == "0" ]]; then
2273 prefix="/"
2274 fi
2275
2276 if [[ "${base_path}" == "1" && "${linker_option}" == "1" ]]; then
2277 die "${FUNCNAME}(): '--base-path' and '--linker-option' options cannot be specified simultaneously"
2278 fi
2279
2280 if [[ "${final_ABI}" == "1" ]]; then
2281 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2282 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2283 fi
2284 PYTHON_ABI="$(PYTHON -f --ABI)"
2285 else
2286 if _python_package_supporting_installation_for_multiple_python_abis; then
2287 if ! _python_abi-specific_local_scope; then
2288 die "${FUNCNAME}() should be used in ABI-specific local scope"
2289 fi
2290 else
2291 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2292 fi
2293 fi
2294
2295 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2296 if [[ "${linker_option}" == "1" ]]; then
2297 echo "-lpython${PYTHON_ABI}"
2298 else
2299 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)"
2300 fi
2301 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2302 die "${FUNCNAME}(): Jython does not have shared library"
2303 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2304 die "${FUNCNAME}(): PyPy does not have shared library"
2305 fi
2306}
2307
2308# @FUNCTION: python_get_version
2309# @USAGE: [-f|--final-ABI] [-l|--language] [--full] [--major] [--minor] [--micro]
2310# @DESCRIPTION:
2311# Print version of Python implementation.
2312# --full, --major, --minor and --micro options cannot be specified simultaneously.
2313# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed.
2314# If --language option is specified, then version of Python language is printed.
2315# --language and --full options cannot be specified simultaneously.
2316# --language and --micro options cannot be specified simultaneously.
2317# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2318python_get_version() {
2319 _python_check_python_pkg_setup_execution
2320
2321 local final_ABI="0" language="0" language_version full="0" major="0" minor="0" micro="0" PYTHON_ABI="${PYTHON_ABI}" python_command
2322
2323 while (($#)); do
2324 case "$1" in
2325 -f|--final-ABI)
2326 final_ABI="1"
2327 ;;
2328 -l|--language)
2329 language="1"
2330 ;;
2331 --full)
2332 full="1"
2333 ;;
2334 --major)
2335 major="1"
2336 ;;
2337 --minor)
2338 minor="1"
2339 ;;
2340 --micro)
2341 micro="1"
2342 ;;
2343 -*)
2344 die "${FUNCNAME}(): Unrecognized option '$1'"
2345 ;;
2346 *)
2347 die "${FUNCNAME}(): Invalid usage"
2348 ;;
2349 esac
2350 shift
2351 done
2352
2353 if [[ "${final_ABI}" == "1" ]]; then
2354 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2355 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2356 fi
2357 else
2358 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2359 die "${FUNCNAME}() should be used in ABI-specific local scope"
2360 fi
2361 fi
2362
2363 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2364 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2365 fi
2366
2367 if [[ "${language}" == "1" ]]; then
2368 if [[ "${final_ABI}" == "1" ]]; then
2369 PYTHON_ABI="$(PYTHON -f --ABI)"
2370 elif [[ -z "${PYTHON_ABI}" ]]; then
2371 PYTHON_ABI="$(PYTHON --ABI)"
2372 fi
2373 language_version="${PYTHON_ABI%%-*}"
2374 if [[ "${full}" == "1" ]]; then
2375 die "${FUNCNAME}(): '--language' and '--full' options cannot be specified simultaneously"
2376 elif [[ "${major}" == "1" ]]; then
2377 echo "${language_version%.*}"
2378 elif [[ "${minor}" == "1" ]]; then
2379 echo "${language_version#*.}"
2380 elif [[ "${micro}" == "1" ]]; then
2381 die "${FUNCNAME}(): '--language' and '--micro' options cannot be specified simultaneously"
2382 else
2383 echo "${language_version}"
2384 fi
2385 else
2386 if [[ "${full}" == "1" ]]; then
2387 python_command="import sys; print('.'.join(str(x) for x in getattr(sys, 'pypy_version_info', sys.version_info)[:3]))"
2388 elif [[ "${major}" == "1" ]]; then
2389 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[0])"
2390 elif [[ "${minor}" == "1" ]]; then
2391 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[1])"
2392 elif [[ "${micro}" == "1" ]]; then
2393 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[2])"
2394 else
2395 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2396 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2397 echo "${PYTHON_ABI}"
2398 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2399 echo "${PYTHON_ABI%-jython}"
2400 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2401 echo "${PYTHON_ABI#*-pypy-}"
2402 fi
2403 return
2404 fi
2405 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2406 fi
2407
2408 if [[ "${final_ABI}" == "1" ]]; then
2409 "$(PYTHON -f)" -c "${python_command}"
2410 else
2411 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}"
2412 fi
2413 fi
2414}
2415
2416# @FUNCTION: python_get_implementation_and_version
2417# @USAGE: [-f|--final-ABI]
2418# @DESCRIPTION:
2419# Print name and version of Python implementation.
2420# If version of Python implementation is not bound to version of Python language, then
2421# version of Python language is additionally printed.
2422# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2423python_get_implementation_and_version() {
2424 _python_check_python_pkg_setup_execution
2425
2426 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2427
2428 while (($#)); do
2429 case "$1" in
2430 -f|--final-ABI)
2431 final_ABI="1"
2432 ;;
2433 -*)
2434 die "${FUNCNAME}(): Unrecognized option '$1'"
2435 ;;
2436 *)
2437 die "${FUNCNAME}(): Invalid usage"
2438 ;;
2439 esac
2440 shift
2441 done
2442
2443 if [[ "${final_ABI}" == "1" ]]; then
2444 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2445 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2446 fi
2447 PYTHON_ABI="$(PYTHON -f --ABI)"
2448 else
2449 if _python_package_supporting_installation_for_multiple_python_abis; then
2450 if ! _python_abi-specific_local_scope; then
2451 die "${FUNCNAME}() should be used in ABI-specific local scope"
2452 fi
2453 else
2454 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2455 fi
2456 fi
2457
2458 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-[[:alnum:]]+-[[:digit:]]+\.[[:digit:]]+$ ]]; then
2459 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI##*-} (Python ${PYTHON_ABI%%-*})"
2460 else
2461 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI%%-*}"
2462 fi
2463}
2464
2465# ================================================================================================
2466# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================
2467# ================================================================================================
2468
2469# @ECLASS-VARIABLE: PYTHON_TEST_VERBOSITY
2470# @DESCRIPTION:
2471# User-configurable verbosity of tests of Python modules.
2472# Supported values: 0, 1, 2, 3, 4.
2473PYTHON_TEST_VERBOSITY="${PYTHON_TEST_VERBOSITY:-1}"
2474
2475_python_test_hook() {
2476 if [[ "$#" -ne 1 ]]; then
2477 die "${FUNCNAME}() requires 1 argument"
2478 fi
2479
2480 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${_PYTHON_TEST_FUNCTION}_$1_hook")" == "function" ]]; then
2481 "${_PYTHON_TEST_FUNCTION}_$1_hook"
2482 fi
2483}
2484
2485# @FUNCTION: python_execute_nosetests
2486# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2487# @DESCRIPTION:
2488# Execute nosetests for all enabled Python ABIs.
2489# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2490# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined.
2491python_execute_nosetests() {
2492 _python_check_python_pkg_setup_execution
2493 _python_set_color_variables
2494
2495 local PYTHONPATH_template separate_build_dirs
2496
2497 while (($#)); do
2498 case "$1" in
2499 -P|--PYTHONPATH)
2500 PYTHONPATH_template="$2"
2501 shift
2502 ;;
2503 -s|--separate-build-dirs)
2504 separate_build_dirs="1"
2505 ;;
2506 --)
2507 shift
2508 break
2509 ;;
2510 -*)
2511 die "${FUNCNAME}(): Unrecognized option '$1'"
2512 ;;
2513 *)
2514 break
2515 ;;
2516 esac
2517 shift
2518 done
2519
2520 python_test_function() {
2521 local evaluated_PYTHONPATH
2522
2523 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2524
2525 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook pre
2526
2527 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2528 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2529 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2530 else
2531 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2532 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2533 fi
2534
2535 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook post
675 } 2536 }
2537 if _python_package_supporting_installation_for_multiple_python_abis; then
2538 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2539 else
2540 if [[ -n "${separate_build_dirs}" ]]; then
2541 die "${FUNCNAME}(): Invalid usage"
2542 fi
2543 python_test_function "$@" || die "Testing failed"
2544 fi
676 2545
677 EXPORT_FUNCTIONS pkg_setup 2546 unset -f python_test_function
2547}
678 2548
679 if [[ -n "${PYTHON_USE_WITH}" ]]; then 2549# @FUNCTION: python_execute_py.test
680 PYTHON_USE_WITH_ATOM="${PYTHON_ATOM}[${PYTHON_USE_WITH/ /,}]" 2550# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
681 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then 2551# @DESCRIPTION:
682 PYTHON_USE_WITH_ATOM="|| ( " 2552# Execute py.test for all enabled Python ABIs.
683 for use in ${PYTHON_USE_WITH_OR}; do 2553# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
684 PYTHON_USE_WITH_ATOM+=" ${PYTHON_ATOM}[${use}]" 2554# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined.
2555python_execute_py.test() {
2556 _python_check_python_pkg_setup_execution
2557 _python_set_color_variables
2558
2559 local PYTHONPATH_template separate_build_dirs
2560
2561 while (($#)); do
2562 case "$1" in
2563 -P|--PYTHONPATH)
2564 PYTHONPATH_template="$2"
2565 shift
2566 ;;
2567 -s|--separate-build-dirs)
2568 separate_build_dirs="1"
2569 ;;
2570 --)
2571 shift
2572 break
2573 ;;
2574 -*)
2575 die "${FUNCNAME}(): Unrecognized option '$1'"
2576 ;;
2577 *)
2578 break
2579 ;;
2580 esac
2581 shift
685 done 2582 done
686 unset use 2583
687 PYTHON_USE_WITH_ATOM+=" )" 2584 python_test_function() {
2585 local evaluated_PYTHONPATH
2586
2587 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2588
2589 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook pre
2590
2591 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2592 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL}
2593 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?"
2594 else
2595 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL}
2596 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?"
688 fi 2597 fi
689 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
690 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_OPT}? ( ${PYTHON_USE_WITH_ATOM} )"
691 fi
692 DEPEND+=" ${PYTHON_USE_WITH_ATOM}"
693 RDEPEND+=" ${PYTHON_USE_WITH_ATOM}"
694fi
695 2598
696# @ECLASS-VARIABLE: PYTHON_DEFINE_DEFAULT_FUNCTIONS 2599 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook post
697# @DESCRIPTION:
698# Set this to define default functions for the following ebuild phases:
699# src_prepare, src_configure, src_compile, src_test, src_install.
700if ! has "${EAPI:-0}" 0 1 && [[ -n "${PYTHON_DEFINE_DEFAULT_FUNCTIONS}" ]]; then
701 python_src_prepare() {
702 python_copy_sources
703 } 2600 }
2601 if _python_package_supporting_installation_for_multiple_python_abis; then
2602 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2603 else
2604 if [[ -n "${separate_build_dirs}" ]]; then
2605 die "${FUNCNAME}(): Invalid usage"
2606 fi
2607 python_test_function "$@" || die "Testing failed"
2608 fi
704 2609
705 for python_default_function in src_configure src_compile src_test src_install; do
706 eval "python_${python_default_function}() { python_execute_function -d -s; }"
707 done
708 unset python_default_function 2610 unset -f python_test_function
2611}
709 2612
710 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install 2613# @FUNCTION: python_execute_trial
2614# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2615# @DESCRIPTION:
2616# Execute trial for all enabled Python ABIs.
2617# In ebuilds of packages supporting installation for multiple Python ABIs, this function
2618# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined.
2619python_execute_trial() {
2620 _python_check_python_pkg_setup_execution
2621 _python_set_color_variables
2622
2623 local PYTHONPATH_template separate_build_dirs
2624
2625 while (($#)); do
2626 case "$1" in
2627 -P|--PYTHONPATH)
2628 PYTHONPATH_template="$2"
2629 shift
2630 ;;
2631 -s|--separate-build-dirs)
2632 separate_build_dirs="1"
2633 ;;
2634 --)
2635 shift
2636 break
2637 ;;
2638 -*)
2639 die "${FUNCNAME}(): Unrecognized option '$1'"
2640 ;;
2641 *)
2642 break
2643 ;;
2644 esac
2645 shift
2646 done
2647
2648 python_test_function() {
2649 local evaluated_PYTHONPATH
2650
2651 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2652
2653 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook pre
2654
2655 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2656 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2657 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2658 else
2659 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2660 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2661 fi
2662
2663 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook post
2664 }
2665 if _python_package_supporting_installation_for_multiple_python_abis; then
2666 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2667 else
2668 if [[ -n "${separate_build_dirs}" ]]; then
2669 die "${FUNCNAME}(): Invalid usage"
2670 fi
2671 python_test_function "$@" || die "Testing failed"
711fi 2672 fi
712 2673
713# @FUNCTION: python_disable_pyc 2674 unset -f python_test_function
714# @DESCRIPTION:
715# Tell Python not to automatically recompile modules to .pyc/.pyo
716# even if the timestamps/version stamps don't match. This is done
717# to protect sandbox.
718python_disable_pyc() {
719 export PYTHONDONTWRITEBYTECODE="1"
720} 2675}
2676
2677# ================================================================================================
2678# ======================= FUNCTIONS FOR HANDLING OF BYTE-COMPILED MODULES ========================
2679# ================================================================================================
721 2680
722# @FUNCTION: python_enable_pyc 2681# @FUNCTION: python_enable_pyc
723# @DESCRIPTION: 2682# @DESCRIPTION:
724# Tell Python to automatically recompile modules to .pyc/.pyo if the 2683# Tell Python to automatically recompile modules to .pyc/.pyo if the
725# timestamps/version stamps have changed. 2684# timestamps/version stamps have changed.
726python_enable_pyc() { 2685python_enable_pyc() {
2686 _python_check_python_pkg_setup_execution
2687
2688 if [[ "$#" -ne 0 ]]; then
2689 die "${FUNCNAME}() does not accept arguments"
2690 fi
2691
727 unset PYTHONDONTWRITEBYTECODE 2692 unset PYTHONDONTWRITEBYTECODE
728} 2693}
729 2694
730# @FUNCTION: python_need_rebuild 2695# @FUNCTION: python_disable_pyc
731# @DESCRIPTION: Run without arguments, specifies that the package should be
732# rebuilt after a python upgrade.
733python_need_rebuild() {
734 python_version
735 export PYTHON_NEED_REBUILD=${PYVER}
736}
737
738# @FUNCTION: python_get_includedir
739# @DESCRIPTION: 2696# @DESCRIPTION:
740# Run without arguments, returns the Python include directory. 2697# Tell Python not to automatically recompile modules to .pyc/.pyo
741python_get_includedir() { 2698# even if the timestamps/version stamps do not match. This is done
742 if [[ -n "${PYTHON_ABI}" ]]; then 2699# to protect sandbox.
743 echo "/usr/include/python${PYTHON_ABI}" 2700python_disable_pyc() {
744 else 2701 _python_check_python_pkg_setup_execution
745 python_version 2702
746 echo "/usr/include/python${PYVER}" 2703 if [[ "$#" -ne 0 ]]; then
2704 die "${FUNCNAME}() does not accept arguments"
2705 fi
2706
2707 export PYTHONDONTWRITEBYTECODE="1"
2708}
2709
2710_python_vecho() {
2711 [[ -z ${PORTAGE_VERBOSE} ]] || echo "$@"
2712}
2713
2714_python_clean_compiled_modules() {
2715 _python_initialize_prefix_variables
2716 _python_set_color_variables
2717
2718 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage"
2719
2720 local base_module_name compiled_file compiled_files=() dir path py_file root
2721
2722 # Strip trailing slash from EROOT.
2723 root="${EROOT%/}"
2724
2725 for path in "$@"; do
2726 compiled_files=()
2727 if [[ -d "${path}" ]]; then
2728 while read -d $'\0' -r compiled_file; do
2729 compiled_files+=("${compiled_file}")
2730 done < <(find "${path}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -print0)
2731
2732 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then
2733 # Delete empty child directories.
2734 find "${path}" -type d | sort -r | while read -r dir; do
2735 if rmdir "${dir}" 2> /dev/null; then
2736 _python_vecho "<<< ${dir}"
2737 fi
2738 done
2739 fi
2740 elif [[ "${path}" == *.py ]]; then
2741 base_module_name="${path##*/}"
2742 base_module_name="${base_module_name%.py}"
2743 if [[ -d "${path%/*}/__pycache__" ]]; then
2744 while read -d $'\0' -r compiled_file; do
2745 compiled_files+=("${compiled_file}")
2746 done < <(find "${path%/*}/__pycache__" "(" -name "${base_module_name}.*.py[co]" -o -name "${base_module_name}\$py.class" ")" -print0)
2747 fi
2748 compiled_files+=("${path}c" "${path}o" "${path%.py}\$py.class")
747 fi 2749 fi
748}
749 2750
750# @FUNCTION: python_get_libdir 2751 for compiled_file in "${compiled_files[@]}"; do
751# @DESCRIPTION: 2752 [[ ! -f "${compiled_file}" ]] && continue
752# Run without arguments, returns the Python library directory. 2753 dir="${compiled_file%/*}"
753python_get_libdir() { 2754 dir="${dir##*/}"
754 if [[ -n "${PYTHON_ABI}" ]]; then 2755 if [[ "${compiled_file}" == *.py[co] ]]; then
755 echo "/usr/$(get_libdir)/python${PYTHON_ABI}" 2756 if [[ "${dir}" == "__pycache__" ]]; then
2757 base_module_name="${compiled_file##*/}"
2758 base_module_name="${base_module_name%.*py[co]}"
2759 base_module_name="${base_module_name%.*}"
2760 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2761 else
2762 py_file="${compiled_file%[co]}"
2763 fi
2764 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2765 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2766 else
2767 [[ -f "${py_file}" ]] && continue
2768 fi
2769 _python_vecho "<<< ${compiled_file%[co]}[co]"
2770 rm -f "${compiled_file%[co]}"[co]
2771 elif [[ "${compiled_file}" == *\$py.class ]]; then
2772 if [[ "${dir}" == "__pycache__" ]]; then
2773 base_module_name="${compiled_file##*/}"
2774 base_module_name="${base_module_name%\$py.class}"
2775 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2776 else
2777 py_file="${compiled_file%\$py.class}.py"
2778 fi
2779 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2780 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2781 else
2782 [[ -f "${py_file}" ]] && continue
2783 fi
2784 _python_vecho "<<< ${compiled_file}"
2785 rm -f "${compiled_file}"
756 else 2786 else
757 python_version 2787 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'"
758 echo "/usr/$(get_libdir)/python${PYVER}"
759 fi 2788 fi
760}
761 2789
762# @FUNCTION: python_get_sitedir 2790 # Delete empty parent directories.
763# @DESCRIPTION: 2791 dir="${compiled_file%/*}"
764# Run without arguments, returns the Python site-packages directory. 2792 while [[ "${dir}" != "${root}" ]]; do
765python_get_sitedir() { 2793 if rmdir "${dir}" 2> /dev/null; then
766 echo "$(python_get_libdir)/site-packages" 2794 _python_vecho "<<< ${dir}"
2795 else
2796 break
2797 fi
2798 dir="${dir%/*}"
2799 done
2800 done
2801 done
767} 2802}
768 2803
769# @FUNCTION: python_tkinter_exists
770# @DESCRIPTION:
771# Run without arguments, checks if python was compiled with Tkinter
772# support. If not, prints an error message and dies.
773python_tkinter_exists() {
774 if ! python -c "import Tkinter" >/dev/null 2>&1; then
775 eerror "You need to recompile python with Tkinter support."
776 eerror "Try adding: 'dev-lang/python tk'"
777 eerror "in to /etc/portage/package.use"
778 echo
779 die "missing tkinter support with installed python"
780 fi
781}
782
783# @FUNCTION: python_mod_exists 2804# @FUNCTION: python_mod_optimize
784# @USAGE: <module> 2805# @USAGE: [--allow-evaluated-non-sitedir-paths] [-d directory] [-f] [-l] [-q] [-x regular_expression] [--] <file|directory> [files|directories]
785# @DESCRIPTION: 2806# @DESCRIPTION:
786# Run with the module name as an argument. it will check if a 2807# Byte-compile specified Python modules.
787# python module is installed and loadable. it will return 2808# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py.
788# TRUE(0) if the module exists, and FALSE(1) if the module does
789# not exist.
790# 2809#
791# Example:
792# if python_mod_exists gtk; then
793# echo "gtk support enabled"
794# fi
795python_mod_exists() {
796 [[ "$1" ]] || die "${FUNCNAME} requires an argument!"
797 python -c "import $1" &>/dev/null
798}
799
800# @FUNCTION: python_mod_compile
801# @USAGE: <file> [more files ...]
802# @DESCRIPTION:
803# Given filenames, it will pre-compile the module's .pyc and .pyo.
804# This function should only be run in pkg_postinst()
805#
806# Example:
807# python_mod_compile /usr/lib/python2.3/site-packages/pygoogle.py
808#
809python_mod_compile() {
810 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
811 die "${FUNCNAME}() cannot be used in this EAPI"
812 fi
813
814 local f myroot myfiles=()
815
816 # Check if phase is pkg_postinst()
817 [[ ${EBUILD_PHASE} != postinst ]] &&\
818 die "${FUNCNAME} should only be run in pkg_postinst()"
819
820 # allow compiling for older python versions
821 if [[ "${PYTHON_OVERRIDE_PYVER}" ]]; then
822 PYVER=${PYTHON_OVERRIDE_PYVER}
823 else
824 python_version
825 fi
826
827 # strip trailing slash
828 myroot="${ROOT%/}"
829
830 # respect ROOT
831 for f in "$@"; do
832 [[ -f "${myroot}/${f}" ]] && myfiles+=("${myroot}/${f}")
833 done
834
835 if ((${#myfiles[@]})); then
836 python${PYVER} ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}"
837 python${PYVER} -O ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}" &> /dev/null
838 else
839 ewarn "No files to compile!"
840 fi
841}
842
843# @FUNCTION: python_mod_optimize
844# @USAGE: [options] [directory|file]
845# @DESCRIPTION:
846# If no arguments supplied, it will recompile not recursively all modules
847# under sys.path (eg. /usr/lib/python2.6, /usr/lib/python2.6/site-packages).
848#
849# If supplied with arguments, it will recompile all modules recursively
850# in the supplied directory.
851# This function should only be run in pkg_postinst(). 2810# This function can be used only in pkg_postinst() phase.
852#
853# Options passed to this function are passed to compileall.py.
854#
855# Example:
856# python_mod_optimize ctypesgencore
857python_mod_optimize() { 2811python_mod_optimize() {
858 # Check if phase is pkg_postinst(). 2812 if [[ "${EBUILD_PHASE}" != "postinst" ]]; then
859 [[ ${EBUILD_PHASE} != "postinst" ]] && die "${FUNCNAME} should only be run in pkg_postinst()" 2813 die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2814 fi
860 2815
2816 _python_check_python_pkg_setup_execution
2817 _python_initialize_prefix_variables
2818
2819 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2820 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs.
2821 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() stderr stderr_line
2822
2823 if _python_package_supporting_installation_for_multiple_python_abis; then
861 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 2824 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
862 local dir file options=() other_dirs=() other_files=() PYTHON_ABI return_code root site_packages_absolute_dirs=() site_packages_dirs=() site_packages_absolute_files=() site_packages_files=() 2825 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2826 fi
2827 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
2828 else
2829 if has "${EAPI:-0}" 0 1 2 3; then
2830 iterated_PYTHON_ABIS="${PYTHON_ABI:=$(PYTHON --ABI)}"
2831 else
2832 iterated_PYTHON_ABIS="${PYTHON_ABI}"
2833 fi
2834 fi
863 2835
864 # Strip trailing slash from ROOT. 2836 # Strip trailing slash from EROOT.
865 root="${ROOT%/}" 2837 root="${EROOT%/}"
866 2838
867 # Respect ROOT and options passed to compileall.py.
868 while (($#)); do 2839 while (($#)); do
869 case "$1" in 2840 case "$1" in
2841 --allow-evaluated-non-sitedir-paths)
2842 allow_evaluated_non_sitedir_paths="1"
2843 ;;
870 -l|-f|-q) 2844 -l|-f|-q)
871 options+=("$1") 2845 options+=("$1")
872 ;; 2846 ;;
873 -d|-x) 2847 -d|-x)
874 options+=("$1" "$2") 2848 options+=("$1" "$2")
875 shift 2849 shift
876 ;; 2850 ;;
2851 --)
2852 shift
2853 break
2854 ;;
877 -*) 2855 -*)
878 ewarn "${FUNCNAME}: Ignoring compile option $1" 2856 die "${FUNCNAME}(): Unrecognized option '$1'"
879 ;; 2857 ;;
880 *) 2858 *)
881 if [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
882 die "${FUNCNAME} doesn't support absolute paths of directories/files in site-packages directories"
883 elif [[ "$1" =~ ^/ ]]; then
884 if [[ -d "${root}/$1" ]]; then
885 other_dirs+=("${root}/$1")
886 elif [[ -f "${root}/$1" ]]; then
887 other_files+=("${root}/$1")
888 elif [[ -e "${root}/$1" ]]; then
889 ewarn "'${root}/$1' is not a file or a directory!"
890 else
891 ewarn "'${root}/$1' doesn't exist!"
892 fi
893 else
894 for PYTHON_ABI in ${PYTHON_ABIS}; do
895 if [[ -d "${root}$(python_get_sitedir)/$1" ]]; then
896 site_packages_dirs+=("$1")
897 break 2859 break
898 elif [[ -f "${root}$(python_get_sitedir)/$1" ]]; then
899 site_packages_files+=("$1")
900 break
901 elif [[ -e "${root}$(python_get_sitedir)/$1" ]]; then
902 ewarn "'$1' is not a file or a directory!"
903 else
904 ewarn "'$1' doesn't exist!"
905 fi
906 done
907 fi
908 ;; 2860 ;;
909 esac 2861 esac
910 shift 2862 shift
911 done 2863 done
912 2864
2865 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
2866 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2867 fi
2868
2869 if [[ "$#" -eq 0 ]]; then
2870 die "${FUNCNAME}(): Missing files or directories"
2871 fi
2872
2873 while (($#)); do
2874 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2875 die "${FUNCNAME}(): Invalid argument '$1'"
2876 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
2877 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
2878 elif [[ "$1" =~ ^/ ]]; then
2879 if _python_package_supporting_installation_for_multiple_python_abis; then
2880 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
2881 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
2882 fi
2883 if [[ "$1" != *\$* ]]; then
2884 die "${FUNCNAME}(): '$1' has invalid syntax"
2885 fi
2886 if [[ "$1" == *.py ]]; then
2887 evaluated_files+=("$1")
2888 else
2889 evaluated_dirs+=("$1")
2890 fi
2891 else
2892 if [[ -d "${root}$1" ]]; then
2893 other_dirs+=("${root}$1")
2894 elif [[ -f "${root}$1" ]]; then
2895 other_files+=("${root}$1")
2896 elif [[ -e "${root}$1" ]]; then
2897 eerror "${FUNCNAME}(): '${root}$1' is not a regular file or a directory"
2898 else
2899 eerror "${FUNCNAME}(): '${root}$1' does not exist"
2900 fi
2901 fi
2902 else
2903 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2904 if [[ -d "${root}$(python_get_sitedir)/$1" ]]; then
2905 site_packages_dirs+=("$1")
2906 break
2907 elif [[ -f "${root}$(python_get_sitedir)/$1" ]]; then
2908 site_packages_files+=("$1")
2909 break
2910 elif [[ -e "${root}$(python_get_sitedir)/$1" ]]; then
2911 eerror "${FUNCNAME}(): '$1' is not a regular file or a directory"
2912 else
2913 eerror "${FUNCNAME}(): '$1' does not exist"
2914 fi
2915 done
2916 fi
2917 shift
2918 done
2919
913 # Set additional options. 2920 # Set additional options.
914 options+=("-q") 2921 options+=("-q")
915 2922
916 for PYTHON_ABI in ${PYTHON_ABIS}; do 2923 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
917 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})); then 2924 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then
918 return_code="0" 2925 return_code="0"
919 ebegin "Compilation and optimization of Python modules for Python ${PYTHON_ABI}" 2926 stderr=""
920 if ((${#site_packages_dirs[@]})); then 2927 ebegin "Compilation and optimization of Python modules for $(python_get_implementation_and_version)"
2928 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then
921 for dir in "${site_packages_dirs[@]}"; do 2929 for dir in "${site_packages_dirs[@]}"; do
922 site_packages_absolute_dirs+=("${root}$(python_get_sitedir)/${dir}") 2930 dirs+=("${root}$(python_get_sitedir)/${dir}")
923 done 2931 done
924 "$(PYTHON)" "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${site_packages_absolute_dirs[@]}" || return_code="1" 2932 for dir in "${evaluated_dirs[@]}"; do
2933 eval "dirs+=(\"\${root}${dir}\")"
2934 done
2935 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m compileall "${options[@]}" "${dirs[@]}" 2>&1)" || return_code="1"
2936 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
925 "$(PYTHON)" -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${site_packages_absolute_dirs[@]}" &> /dev/null || return_code="1" 2937 "$(PYTHON)" -O -m compileall "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1"
926 fi 2938 fi
927 if ((${#site_packages_files[@]})); then 2939 _python_clean_compiled_modules "${dirs[@]}"
2940 fi
2941 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then
928 for file in "${site_packages_files[@]}"; do 2942 for file in "${site_packages_files[@]}"; do
929 site_packages_absolute_files+=("${root}$(python_get_sitedir)/${file}") 2943 files+=("${root}$(python_get_sitedir)/${file}")
930 done 2944 done
931 "$(PYTHON)" "${root}$(python_get_libdir)/py_compile.py" "${site_packages_absolute_files[@]}" || return_code="1" 2945 for file in "${evaluated_files[@]}"; do
932 "$(PYTHON)" -O "${root}$(python_get_libdir)/py_compile.py" "${site_packages_absolute_files[@]}" &> /dev/null || return_code="1" 2946 eval "files+=(\"\${root}${file}\")"
2947 done
2948 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m py_compile "${files[@]}" 2>&1)" || return_code="1"
2949 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2950 "$(PYTHON)" -O -m py_compile "${files[@]}" &> /dev/null || return_code="1"
2951 fi
2952 _python_clean_compiled_modules "${files[@]}"
933 fi 2953 fi
934 eend "${return_code}" 2954 eend "${return_code}"
2955 if [[ -n "${stderr}" ]]; then
2956 eerror "Syntax errors / warnings in Python modules for $(python_get_implementation_and_version):" &> /dev/null
2957 while read stderr_line; do
2958 eerror " ${stderr_line}"
2959 done <<< "${stderr}"
935 fi 2960 fi
936 unset site_packages_absolute_dirs site_packages_absolute_files 2961 fi
2962 unset dirs files
937 done 2963 done
938 2964
939 # Don't use PYTHON_ABI in next calls to python_get_libdir(). 2965 if _python_package_supporting_installation_for_multiple_python_abis; then
2966 # Restore previous value of PYTHON_ABI.
2967 if [[ -n "${previous_PYTHON_ABI}" ]]; then
2968 PYTHON_ABI="${previous_PYTHON_ABI}"
2969 else
940 unset PYTHON_ABI 2970 unset PYTHON_ABI
2971 fi
2972 fi
941 2973
942 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then 2974 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then
943 return_code="0" 2975 return_code="0"
2976 stderr=""
944 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for Python ${PYVER}" 2977 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation_and_version)"
945 if ((${#other_dirs[@]})); then 2978 if ((${#other_dirs[@]})); then
946 python${PYVER} "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" || return_code="1" 2979 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m compileall "${options[@]}" "${other_dirs[@]}" 2>&1)" || return_code="1"
947 python${PYVER} -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1" 2980 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2981 "$(PYTHON ${PYTHON_ABI})" -O -m compileall "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1"
2982 fi
2983 _python_clean_compiled_modules "${other_dirs[@]}"
948 fi 2984 fi
949 if ((${#other_files[@]})); then 2985 if ((${#other_files[@]})); then
950 python${PYVER} "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" || return_code="1" 2986 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m py_compile "${other_files[@]}" 2>&1)" || return_code="1"
951 python${PYVER} -O "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" &> /dev/null || return_code="1" 2987 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2988 "$(PYTHON ${PYTHON_ABI})" -O -m py_compile "${other_files[@]}" &> /dev/null || return_code="1"
2989 fi
2990 _python_clean_compiled_modules "${other_files[@]}"
952 fi 2991 fi
953 eend "${return_code}" 2992 eend "${return_code}"
2993 if [[ -n "${stderr}" ]]; then
2994 eerror "Syntax errors / warnings in Python modules placed outside of site-packages directories for $(python_get_implementation_and_version):" &> /dev/null
2995 while read stderr_line; do
2996 eerror " ${stderr_line}"
2997 done <<< "${stderr}"
2998 fi
954 fi 2999 fi
955 else 3000 else
3001 # Deprecated part of python_mod_optimize()
3002 ewarn
3003 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
3004 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
3005 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
3006 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
3007 ewarn
3008
956 local myroot mydirs=() myfiles=() myopts=() return_code="0" 3009 local myroot mydirs=() myfiles=() myopts=() return_code="0"
957 3010
958 # strip trailing slash 3011 # strip trailing slash
959 myroot="${ROOT%/}" 3012 myroot="${EROOT%/}"
960 3013
961 # respect ROOT and options passed to compileall.py 3014 # respect EROOT and options passed to compileall.py
962 while (($#)); do 3015 while (($#)); do
963 case "$1" in 3016 case "$1" in
964 -l|-f|-q) 3017 -l|-f|-q)
965 myopts+=("$1") 3018 myopts+=("$1")
966 ;; 3019 ;;
967 -d|-x) 3020 -d|-x)
968 myopts+=("$1" "$2") 3021 myopts+=("$1" "$2")
969 shift 3022 shift
970 ;; 3023 ;;
3024 --)
3025 shift
3026 break
3027 ;;
971 -*) 3028 -*)
972 ewarn "${FUNCNAME}: Ignoring compile option $1" 3029 die "${FUNCNAME}(): Unrecognized option '$1'"
973 ;; 3030 ;;
974 *) 3031 *)
975 if [[ -d "${myroot}"/$1 ]]; then 3032 break
976 mydirs+=("${myroot}/$1")
977 elif [[ -f "${myroot}"/$1 ]]; then
978 # Files are passed to python_mod_compile which is ROOT-aware
979 myfiles+=("$1")
980 elif [[ -e "${myroot}/$1" ]]; then
981 ewarn "${myroot}/$1 is not a file or directory!"
982 else
983 ewarn "${myroot}/$1 doesn't exist!"
984 fi
985 ;; 3033 ;;
986 esac 3034 esac
987 shift 3035 shift
988 done 3036 done
989 3037
990 # allow compiling for older python versions 3038 if [[ "$#" -eq 0 ]]; then
991 if [ -n "${PYTHON_OVERRIDE_PYVER}" ]; then 3039 die "${FUNCNAME}(): Missing files or directories"
992 PYVER=${PYTHON_OVERRIDE_PYVER} 3040 fi
3041
3042 while (($#)); do
3043 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3044 die "${FUNCNAME}(): Invalid argument '$1'"
3045 elif [[ -d "${myroot}/${1#/}" ]]; then
3046 mydirs+=("${myroot}/${1#/}")
3047 elif [[ -f "${myroot}/${1#/}" ]]; then
3048 myfiles+=("${myroot}/${1#/}")
3049 elif [[ -e "${myroot}/${1#/}" ]]; then
3050 eerror "${FUNCNAME}(): ${myroot}/${1#/} is not a regular file or directory"
993 else 3051 else
994 python_version 3052 eerror "${FUNCNAME}(): ${myroot}/${1#/} does not exist"
995 fi 3053 fi
3054 shift
3055 done
996 3056
997 # set additional opts 3057 # set additional opts
998 myopts+=(-q) 3058 myopts+=(-q)
999 3059
1000 ebegin "Compilation and optimization of Python modules for Python ${PYVER}" 3060 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
3061
3062 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)"
1001 if ((${#mydirs[@]})); then 3063 if ((${#mydirs[@]})); then
1002 python${PYVER} \ 3064 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" || return_code="1"
1003 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \ 3065 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" &> /dev/null || return_code="1"
1004 "${myopts[@]}" "${mydirs[@]}" || return_code="1" 3066 _python_clean_compiled_modules "${mydirs[@]}"
1005 python${PYVER} -O \
1006 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \
1007 "${myopts[@]}" "${mydirs[@]}" &> /dev/null || return_code="1"
1008 fi 3067 fi
1009 3068
1010 if ((${#myfiles[@]})); then 3069 if ((${#myfiles[@]})); then
3070 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" || return_code="1"
3071 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" &> /dev/null || return_code="1"
1011 python_mod_compile "${myfiles[@]}" 3072 _python_clean_compiled_modules "${myfiles[@]}"
1012 fi 3073 fi
1013 3074
1014 eend "${return_code}" 3075 eend "${return_code}"
1015 fi 3076 fi
1016} 3077}
1017 3078
1018# @FUNCTION: python_mod_cleanup 3079# @FUNCTION: python_mod_cleanup
1019# @USAGE: [directory] 3080# @USAGE: [--allow-evaluated-non-sitedir-paths] [--] <file|directory> [files|directories]
1020# @DESCRIPTION: 3081# @DESCRIPTION:
1021# Run with optional arguments, where arguments are directories of 3082# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
1022# python modules. If none given, it will look in /usr/lib/python[0-9].[0-9].
1023# 3083#
1024# It will recursively scan all compiled Python modules in the directories and
1025# determine if they are orphaned (i.e. their corresponding .py files are missing.)
1026# If they are, then it will remove their corresponding .pyc and .pyo files.
1027#
1028# This function should only be run in pkg_postrm(). 3084# This function can be used only in pkg_postrm() phase.
1029python_mod_cleanup() { 3085python_mod_cleanup() {
1030 local path py_file PYTHON_ABI SEARCH_PATH=() root 3086 if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
3087 die "${FUNCNAME}() can be used only in pkg_postrm() phase"
3088 fi
1031 3089
1032 # Check if phase is pkg_postrm(). 3090 _python_check_python_pkg_setup_execution
1033 [[ ${EBUILD_PHASE} != "postrm" ]] && die "${FUNCNAME} should only be run in pkg_postrm()" 3091 _python_initialize_prefix_variables
1034 3092
3093 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
3094
3095 if _python_package_supporting_installation_for_multiple_python_abis; then
3096 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
3097 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
3098 fi
3099 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
3100 else
3101 if has "${EAPI:-0}" 0 1 2 3; then
3102 iterated_PYTHON_ABIS="${PYTHON_ABI:-$(PYTHON --ABI)}"
3103 else
3104 iterated_PYTHON_ABIS="${PYTHON_ABI}"
3105 fi
3106 fi
3107
1035 # Strip trailing slash from ROOT. 3108 # Strip trailing slash from EROOT.
1036 root="${ROOT%/}" 3109 root="${EROOT%/}"
1037 3110
1038 if (($#)); then 3111 while (($#)); do
1039 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 3112 case "$1" in
3113 --allow-evaluated-non-sitedir-paths)
3114 allow_evaluated_non_sitedir_paths="1"
3115 ;;
3116 --)
3117 shift
3118 break
3119 ;;
3120 -*)
3121 die "${FUNCNAME}(): Unrecognized option '$1'"
3122 ;;
3123 *)
3124 break
3125 ;;
3126 esac
3127 shift
3128 done
3129
3130 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
3131 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
3132 fi
3133
3134 if [[ "$#" -eq 0 ]]; then
3135 die "${FUNCNAME}(): Missing files or directories"
3136 fi
3137
3138 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
1040 while (($#)); do 3139 while (($#)); do
3140 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3141 die "${FUNCNAME}(): Invalid argument '$1'"
1041 if [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then 3142 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
1042 die "${FUNCNAME} doesn't support absolute paths of directories/files in site-packages directories" 3143 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
1043 elif [[ "$1" =~ ^/ ]]; then 3144 elif [[ "$1" =~ ^/ ]]; then
1044 SEARCH_PATH+=("${root}/${1#/}") 3145 if _python_package_supporting_installation_for_multiple_python_abis; then
3146 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
3147 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
3148 fi
3149 if [[ "$1" != *\$* ]]; then
3150 die "${FUNCNAME}(): '$1' has invalid syntax"
3151 fi
3152 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
3153 eval "search_paths+=(\"\${root}$1\")"
3154 done
1045 else 3155 else
3156 search_paths+=("${root}$1")
3157 fi
3158 else
1046 for PYTHON_ABI in ${PYTHON_ABIS}; do 3159 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1047 SEARCH_PATH+=("${root}$(python_get_sitedir)/$1") 3160 search_paths+=("${root}$(python_get_sitedir)/$1")
1048 done 3161 done
1049 fi 3162 fi
1050 shift 3163 shift
1051 done 3164 done
1052 else
1053 SEARCH_PATH=("${@#/}")
1054 SEARCH_PATH=("${SEARCH_PATH[@]/#/${root}/}")
1055 fi
1056 else 3165 else
1057 local dir sitedir 3166 # Deprecated part of python_mod_cleanup()
1058 for dir in "${root}"/usr/lib*; do 3167 ewarn
1059 if [[ -d "${dir}" && ! -L "${dir}" ]]; then 3168 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
1060 for sitedir in "${dir}"/python*/site-packages; do 3169 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
1061 if [[ -d "${sitedir}" ]]; then 3170 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
1062 SEARCH_PATH+=("${sitedir}") 3171 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
1063 fi 3172 ewarn
1064 done
1065 fi
1066 done
1067 fi
1068 3173
1069 local BLUE CYAN NORMAL 3174 search_paths=("${@#/}")
1070 if [[ "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then 3175 search_paths=("${search_paths[@]/#/${root}/}")
1071 BLUE=$'\e[34m'
1072 CYAN=$'\e[36m'
1073 NORMAL=$'\e[0m'
1074 else
1075 BLUE=
1076 CYAN=
1077 NORMAL=
1078 fi
1079
1080 for path in "${SEARCH_PATH[@]}"; do
1081 if [[ -d "${path}" ]]; then
1082 find "${path}" -name '*.py[co]' -print0 | while read -rd ''; do
1083 py_file="${REPLY%[co]}"
1084 [[ -f "${py_file}" || (! -f "${py_file}c" && ! -f "${py_file}o") ]] && continue
1085 einfo "${BLUE}<<< ${py_file}[co]${NORMAL}"
1086 rm -f "${py_file}"[co]
1087 done
1088
1089 # Attempt to delete directories, which may be empty.
1090 find "${path}" -type d | sort -r | while read -r dir; do
1091 rmdir "${dir}" 2>/dev/null && einfo "${CYAN}<<< ${dir}${NORMAL}"
1092 done
1093 elif [[ "${path}" == *.py && ! -f "${path}" && (-f "${path}c" || -f "${path}o") ]]; then
1094 einfo "${BLUE}<<< ${path}[co]${NORMAL}"
1095 rm -f "${path}"[co]
1096 fi 3176 fi
1097 done 3177
3178 _python_clean_compiled_modules "${search_paths[@]}"
1098} 3179}
3180
3181# ================================================================================================
3182# ===================================== DEPRECATED FUNCTIONS =====================================
3183# ================================================================================================
3184
3185fi # _PYTHON_ECLASS_INHERITED

Legend:
Removed from v.1.78  
changed lines
  Added in v.1.161

  ViewVC Help
Powered by ViewVC 1.1.20