/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.157 Revision 1.164
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.157 2012/08/16 23:57:32 floppym Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.164 2012/12/20 06:34:57 floppym Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Gentoo Python Project <python@gentoo.org> 7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: Eclass for Python packages 8# @BLURB: Eclass for Python packages
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The python eclass contains miscellaneous, useful functions for Python packages. 10# The python eclass contains miscellaneous, useful functions for Python packages.
11 11
12if [[ ${_PYTHON_UTILS_R1} ]]; then
13 die 'python.eclass can not be used with python-r1 suite eclasses.'
14fi
15
12# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning. 16# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning.
13if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then 17if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
14 inherit multilib 18 inherit multilib
15fi 19fi
16 20
21 25
22# Avoid processing this eclass more than once. 26# Avoid processing this eclass more than once.
23if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then 27if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
24_PYTHON_ECLASS_INHERITED="1" 28_PYTHON_ECLASS_INHERITED="1"
25 29
26if ! has "${EAPI:-0}" 0 1 2 3 4; then 30if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
27 die "API of python.eclass in EAPI=\"${EAPI}\" not established" 31 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
28fi 32fi
29 33
30_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7) 34_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
31_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2) 35_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2 3.3)
32_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython) 36_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
33_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9) 37_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0)
34_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]}) 38_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]})
35 39
36# ================================================================================================ 40# ================================================================================================
37# ===================================== HANDLING OF METADATA ===================================== 41# ===================================== HANDLING OF METADATA =====================================
38# ================================================================================================ 42# ================================================================================================
111 return 1 115 return 1
112 fi 116 fi
113} 117}
114 118
115_python_package_supporting_installation_for_multiple_python_abis() { 119_python_package_supporting_installation_for_multiple_python_abis() {
116 if has "${EAPI:-0}" 0 1 2 3 4; then
117 if [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 120 [[ -n "${SUPPORT_PYTHON_ABIS}" ]]
118 return 0
119 else
120 return 1
121 fi
122 else
123 die "${FUNCNAME}(): Support for EAPI=\"${EAPI}\" not implemented"
124 fi
125} 121}
126 122
127# @ECLASS-VARIABLE: PYTHON_DEPEND 123# @ECLASS-VARIABLE: PYTHON_DEPEND
128# @DESCRIPTION: 124# @DESCRIPTION:
129# Specification of dependency on dev-lang/python. 125# Specification of dependency on dev-lang/python.
750 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then 746 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
751 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install 747 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
752 fi 748 fi
753fi 749fi
754 750
755if has "${EAPI:-0}" 0 1 2 3 4; then
756 unset PYTHON_ABIS 751unset PYTHON_ABIS
757fi
758 752
759_python_calculate_PYTHON_ABIS() { 753_python_calculate_PYTHON_ABIS() {
760 if ! _python_package_supporting_installation_for_multiple_python_abis; then 754 if ! _python_package_supporting_installation_for_multiple_python_abis; then
761 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs" 755 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
762 fi 756 fi
763 757
764 _python_initial_sanity_checks 758 _python_initial_sanity_checks
765 759
766 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3 4; then 760 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]]; then
767 local PYTHON_ABI 761 local PYTHON_ABI
768 762
769 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then 763 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
770 local cpython_enabled="0" 764 local cpython_enabled="0"
771 765
1304pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$") 1298pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$")
1305cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)") 1299cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)")
1306python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)") 1300python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)")
1307python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$") 1301python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1308 1302
1309pypy_versions_mapping = { 1303#pypy_versions_mapping = {
1310 "1.5": "2.7", 1304# "1.5": "2.7",
1311 "1.6": "2.7", 1305# "1.6": "2.7",
1312 "1.7": "2.7", 1306# "1.7": "2.7",
1313 "1.8": "2.7", 1307# "1.8": "2.7",
1314 "1.9": "2.7", 1308# "1.9": "2.7",
1315} 1309# "2.0": "2.7",
1310#}
1316 1311
1317def get_PYTHON_ABI(python_interpreter): 1312def get_PYTHON_ABI(python_interpreter):
1318 cpython_matched = cpython_interpreter_re.match(python_interpreter) 1313 cpython_matched = cpython_interpreter_re.match(python_interpreter)
1319 jython_matched = jython_interpreter_re.match(python_interpreter) 1314 jython_matched = jython_interpreter_re.match(python_interpreter)
1320 pypy_matched = pypy_interpreter_re.match(python_interpreter) 1315 pypy_matched = pypy_interpreter_re.match(python_interpreter)
1321 if cpython_matched is not None: 1316 if cpython_matched is not None:
1322 PYTHON_ABI = cpython_matched.group(1) 1317 PYTHON_ABI = cpython_matched.group(1)
1323 elif jython_matched is not None: 1318 elif jython_matched is not None:
1324 PYTHON_ABI = jython_matched.group(1) + "-jython" 1319 PYTHON_ABI = jython_matched.group(1) + "-jython"
1325 elif pypy_matched is not None: 1320 elif pypy_matched is not None:
1326 PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1) 1321 #PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1)
1322 PYTHON_ABI = "2.7-pypy-" + pypy_matched.group(1)
1327 else: 1323 else:
1328 PYTHON_ABI = None 1324 PYTHON_ABI = None
1329 return PYTHON_ABI 1325 return PYTHON_ABI
1330 1326
1331def get_python_interpreter(PYTHON_ABI): 1327def get_python_interpreter(PYTHON_ABI):

Legend:
Removed from v.1.157  
changed lines
  Added in v.1.164

  ViewVC Help
Powered by ViewVC 1.1.20