/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.24 Revision 1.121
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.24 2006/06/10 16:19:54 swegener Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.121 2011/07/08 07:41:56 djc Exp $
4
5# @ECLASS: python.eclass
6# @MAINTAINER:
7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: Eclass for Python packages
9# @DESCRIPTION:
10# The python eclass contains miscellaneous, useful functions for Python packages.
11
12inherit multilib
13
14if ! has "${EAPI:-0}" 0 1 2 3; then
15 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
16fi
17
18_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
19_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.0 3.1 3.2 3.3)
20_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
21_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]})
22
23# ================================================================================================
24# ===================================== HANDLING OF METADATA =====================================
25# ================================================================================================
26
27_PYTHON_ABI_PATTERN_REGEX="([[:alnum:]]|\.|-|\*|\[|\])+"
28
29_python_check_python_abi_matching() {
30 local pattern patterns patterns_list="0" PYTHON_ABI
31
32 while (($#)); do
33 case "$1" in
34 --patterns-list)
35 patterns_list="1"
36 ;;
37 --)
38 shift
39 break
40 ;;
41 -*)
42 die "${FUNCNAME}(): Unrecognized option '$1'"
43 ;;
44 *)
45 break
46 ;;
47 esac
48 shift
49 done
50
51 if [[ "$#" -ne 2 ]]; then
52 die "${FUNCNAME}() requires 2 arguments"
53 fi
54
55 PYTHON_ABI="$1"
56
57 if [[ "${patterns_list}" == "0" ]]; then
58 pattern="$2"
59
60 if [[ "${pattern}" == *"-cpython" ]]; then
61 [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "${PYTHON_ABI}" == ${pattern%-cpython} ]]
62 elif [[ "${pattern}" == *"-jython" ]]; then
63 [[ "${PYTHON_ABI}" == ${pattern} ]]
64 else
65 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
66 [[ "${PYTHON_ABI}" == ${pattern} ]]
67 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
68 [[ "${PYTHON_ABI%-jython}" == ${pattern} ]]
69 else
70 die "${FUNCNAME}(): Unrecognized Python ABI '${PYTHON_ABI}'"
71 fi
72 fi
73 else
74 patterns="${2// /$'\n'}"
75
76 while read pattern; do
77 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
78 return 0
79 fi
80 done <<< "${patterns}"
81
82 return 1
83 fi
84}
85
86_python_package_supporting_installation_for_multiple_python_abis() {
87 if has "${EAPI:-0}" 0 1 2 3 4; then
88 if [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
89 return 0
90 else
91 return 1
92 fi
93 else
94 die "${FUNCNAME}(): Support for EAPI=\"${EAPI}\" not implemented"
95 fi
96}
97
98# @ECLASS-VARIABLE: PYTHON_DEPEND
99# @DESCRIPTION:
100# Specification of dependency on dev-lang/python.
101# Syntax:
102# PYTHON_DEPEND: [[!]USE_flag? ]<version_components_group>[ version_components_group]
103# version_components_group: <major_version[:[minimal_version][:maximal_version]]>
104# major_version: <2|3|*>
105# minimal_version: <minimal_major_version.minimal_minor_version>
106# maximal_version: <maximal_major_version.maximal_minor_version>
107
108_python_parse_PYTHON_DEPEND() {
109 local major_version maximal_version minimal_version python_all="0" python_maximal_version python_minimal_version python_versions=() python2="0" python2_maximal_version python2_minimal_version python3="0" python3_maximal_version python3_minimal_version USE_flag= version_components_group version_components_group_regex version_components_groups
110
111 version_components_group_regex="(2|3|\*)(:([[:digit:]]+\.[[:digit:]]+)?(:([[:digit:]]+\.[[:digit:]]+)?)?)?"
112 version_components_groups="${PYTHON_DEPEND}"
113
114 if [[ "${version_components_groups}" =~ ^((\!)?[[:alnum:]_-]+\?\ )?${version_components_group_regex}(\ ${version_components_group_regex})?$ ]]; then
115 if [[ "${version_components_groups}" =~ ^(\!)?[[:alnum:]_-]+\? ]]; then
116 USE_flag="${version_components_groups%\? *}"
117 version_components_groups="${version_components_groups#* }"
118 fi
119 if [[ "${version_components_groups}" =~ ("*".*" "|" *"|^2.*\ (2|\*)|^3.*\ (3|\*)) ]]; then
120 die "Invalid syntax of PYTHON_DEPEND: Incorrectly specified groups of versions"
121 fi
122
123 version_components_groups="${version_components_groups// /$'\n'}"
124 while read version_components_group; do
125 major_version="${version_components_group:0:1}"
126 minimal_version="${version_components_group:2}"
127 minimal_version="${minimal_version%:*}"
128 maximal_version="${version_components_group:$((3 + ${#minimal_version}))}"
129
130 if [[ "${major_version}" =~ ^(2|3)$ ]]; then
131 if [[ -n "${minimal_version}" && "${major_version}" != "${minimal_version:0:1}" ]]; then
132 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' not in specified group of versions"
133 fi
134 if [[ -n "${maximal_version}" && "${major_version}" != "${maximal_version:0:1}" ]]; then
135 die "Invalid syntax of PYTHON_DEPEND: Maximal version '${maximal_version}' not in specified group of versions"
136 fi
137 fi
138
139 if [[ "${major_version}" == "2" ]]; then
140 python2="1"
141 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
142 python2_minimal_version="${minimal_version}"
143 python2_maximal_version="${maximal_version}"
144 elif [[ "${major_version}" == "3" ]]; then
145 python3="1"
146 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
147 python3_minimal_version="${minimal_version}"
148 python3_maximal_version="${maximal_version}"
149 else
150 python_all="1"
151 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
152 python_minimal_version="${minimal_version}"
153 python_maximal_version="${maximal_version}"
154 fi
155
156 if [[ -n "${minimal_version}" ]] && ! has "${minimal_version}" "${python_versions[@]}"; then
157 die "Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '${minimal_version}'"
158 fi
159 if [[ -n "${maximal_version}" ]] && ! has "${maximal_version}" "${python_versions[@]}"; then
160 die "Invalid syntax of PYTHON_DEPEND: Unrecognized maximal version '${maximal_version}'"
161 fi
162
163 if [[ -n "${minimal_version}" && -n "${maximal_version}" && "${minimal_version}" > "${maximal_version}" ]]; then
164 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' greater than maximal version '${maximal_version}'"
165 fi
166 done <<< "${version_components_groups}"
167
168 _PYTHON_ATOMS=()
169
170 _append_accepted_versions_range() {
171 local accepted_version="0" i
172 for ((i = "${#python_versions[@]}"; i >= 0; i--)); do
173 if [[ "${python_versions[${i}]}" == "${python_maximal_version}" ]]; then
174 accepted_version="1"
175 fi
176 if [[ "${accepted_version}" == "1" ]]; then
177 _PYTHON_ATOMS+=("=dev-lang/python-${python_versions[${i}]}*")
178 fi
179 if [[ "${python_versions[${i}]}" == "${python_minimal_version}" ]]; then
180 accepted_version="0"
181 fi
182 done
183 }
184
185 if [[ "${python_all}" == "1" ]]; then
186 if [[ -z "${python_minimal_version}" && -z "${python_maximal_version}" ]]; then
187 _PYTHON_ATOMS+=("dev-lang/python")
188 else
189 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
190 python_minimal_version="${python_minimal_version:-${python_versions[0]}}"
191 python_maximal_version="${python_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
192 _append_accepted_versions_range
193 fi
194 else
195 if [[ "${python3}" == "1" ]]; then
196 if [[ -z "${python3_minimal_version}" && -z "${python3_maximal_version}" ]]; then
197 _PYTHON_ATOMS+=("=dev-lang/python-3*")
198 else
199 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
200 python_minimal_version="${python3_minimal_version:-${python_versions[0]}}"
201 python_maximal_version="${python3_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
202 _append_accepted_versions_range
203 fi
204 fi
205 if [[ "${python2}" == "1" ]]; then
206 if [[ -z "${python2_minimal_version}" && -z "${python2_maximal_version}" ]]; then
207 _PYTHON_ATOMS+=("=dev-lang/python-2*")
208 else
209 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
210 python_minimal_version="${python2_minimal_version:-${python_versions[0]}}"
211 python_maximal_version="${python2_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
212 _append_accepted_versions_range
213 fi
214 fi
215 fi
216
217 unset -f _append_accepted_versions_range
218
219 if [[ "${#_PYTHON_ATOMS[@]}" -gt 1 ]]; then
220 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
221 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
222 else
223 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
224 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
225 fi
226 else
227 die "Invalid syntax of PYTHON_DEPEND"
228 fi
229}
230
231DEPEND=">=app-admin/eselect-python-20091230"
232RDEPEND="${DEPEND}"
233
234if [[ -n "${PYTHON_DEPEND}" ]]; then
235 _python_parse_PYTHON_DEPEND
236else
237 _PYTHON_ATOMS=("dev-lang/python")
238fi
239unset -f _python_parse_PYTHON_DEPEND
240
241if [[ -n "${NEED_PYTHON}" ]]; then
242 eerror "Use PYTHON_DEPEND variable instead of NEED_PYTHON variable."
243 die "NEED_PYTHON variable is banned"
244fi
245
246# @ECLASS-VARIABLE: PYTHON_USE_WITH
247# @DESCRIPTION:
248# Set this to a space separated list of USE flags the Python slot in use must be built with.
249
250# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR
251# @DESCRIPTION:
252# Set this to a space separated list of USE flags of which one must be turned on for the slot in use.
253
254# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT
255# @DESCRIPTION:
256# Set this to a name of a USE flag if you need to make either PYTHON_USE_WITH or
257# PYTHON_USE_WITH_OR atoms conditional under a USE flag.
258
259if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
260 _PYTHON_USE_WITH_ATOMS_ARRAY=()
261 if [[ -n "${PYTHON_USE_WITH}" ]]; then
262 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
263 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${PYTHON_USE_WITH// /,}]")
264 done
265 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then
266 for _USE_flag in ${PYTHON_USE_WITH_OR}; do
267 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
268 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${_USE_flag}]")
269 done
270 done
271 unset _USE_flag
272 fi
273 if [[ "${#_PYTHON_USE_WITH_ATOMS_ARRAY[@]}" -gt 1 ]]; then
274 _PYTHON_USE_WITH_ATOMS="|| ( ${_PYTHON_USE_WITH_ATOMS_ARRAY[@]} )"
275 else
276 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}"
277 fi
278 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
279 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )"
280 fi
281 DEPEND+=" ${_PYTHON_USE_WITH_ATOMS}"
282 RDEPEND+=" ${_PYTHON_USE_WITH_ATOMS}"
283 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY
284fi
285
286unset _PYTHON_ATOMS
287
288# ================================================================================================
289# =================================== MISCELLANEOUS FUNCTIONS ====================================
290# ================================================================================================
291
292_python_implementation() {
293 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
294 return 0
295 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
296 return 0
297 else
298 return 1
299 fi
300}
301
302_python_abi-specific_local_scope() {
303 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]]
304}
305
306_python_initialize_prefix_variables() {
307 if has "${EAPI:-0}" 0 1 2; then
308 if [[ -n "${ROOT}" && -z "${EROOT}" ]]; then
309 EROOT="${ROOT%/}${EPREFIX}/"
310 fi
311 if [[ -n "${D}" && -z "${ED}" ]]; then
312 ED="${D%/}${EPREFIX}/"
313 fi
314 fi
315}
316
317unset PYTHON_SANITY_CHECKS_EXECUTED PYTHON_SKIP_SANITY_CHECKS
318
319_python_initial_sanity_checks() {
320 if [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
321 # Ensure that /usr/bin/python and /usr/bin/python-config are valid.
322 if [[ "$(readlink "${EPREFIX}/usr/bin/python")" != "python-wrapper" ]]; then
323 eerror "'${EPREFIX}/usr/bin/python' is not valid symlink."
324 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
325 die "'${EPREFIX}/usr/bin/python' is not valid symlink"
326 fi
327 if [[ "$(<"${EPREFIX}/usr/bin/python-config")" != *"Gentoo python-config wrapper script"* ]]; then
328 eerror "'${EPREFIX}/usr/bin/python-config' is not valid script"
329 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
330 die "'${EPREFIX}/usr/bin/python-config' is not valid script"
331 fi
332 fi
333}
334
335_python_final_sanity_checks() {
336 if ! _python_implementation && [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
337 local PYTHON_ABI="${PYTHON_ABI}"
338 for PYTHON_ABI in ${PYTHON_ABIS-${PYTHON_ABI}}; do
339 # Ensure that appropriate version of Python is installed.
340 if ! has_version "$(python_get_implementational_package)"; then
341 die "$(python_get_implementational_package) is not installed"
342 fi
343
344 # Ensure that EPYTHON variable is respected.
345 if [[ "$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")" != "${PYTHON_ABI}" ]]; then
346 eerror "Path to 'python': '$(type -p python)'"
347 eerror "ABI: '${ABI}'"
348 eerror "DEFAULT_ABI: '${DEFAULT_ABI}'"
349 eerror "EPYTHON: '$(PYTHON)'"
350 eerror "PYTHON_ABI: '${PYTHON_ABI}'"
351 eerror "Locally active version of Python: '$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")'"
352 die "'python' does not respect EPYTHON variable"
353 fi
354 done
355 fi
356 PYTHON_SANITY_CHECKS_EXECUTED="1"
357}
358
359# @ECLASS-VARIABLE: PYTHON_COLORS
360# @DESCRIPTION:
361# User-configurable colored output.
362PYTHON_COLORS="${PYTHON_COLORS:-0}"
363
364_python_set_color_variables() {
365 if [[ "${PYTHON_COLORS}" != "0" && "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then
366 _BOLD=$'\e[1m'
367 _RED=$'\e[1;31m'
368 _GREEN=$'\e[1;32m'
369 _BLUE=$'\e[1;34m'
370 _CYAN=$'\e[1;36m'
371 _NORMAL=$'\e[0m'
372 else
373 _BOLD=
374 _RED=
375 _GREEN=
376 _BLUE=
377 _CYAN=
378 _NORMAL=
379 fi
380}
381
382unset PYTHON_PKG_SETUP_EXECUTED
383
384_python_check_python_pkg_setup_execution() {
385 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
386
387 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
388 die "python_pkg_setup() not called"
389 fi
390}
391
392# @FUNCTION: python_pkg_setup
393# @DESCRIPTION:
394# Perform sanity checks and initialize environment.
4# 395#
5# Author: Alastair Tse <liquidx@gentoo.org> 396# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable
397# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4.
398python_pkg_setup() {
399 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
400 die "${FUNCNAME}() can be used only in pkg_setup() phase"
401 fi
402
403 if [[ "$#" -ne 0 ]]; then
404 die "${FUNCNAME}() does not accept arguments"
405 fi
406
407 export JYTHON_SYSTEM_CACHEDIR="1"
408 addwrite "${EPREFIX}/var/cache/jython"
409
410 if _python_package_supporting_installation_for_multiple_python_abis; then
411 _python_calculate_PYTHON_ABIS
412 export EPYTHON="$(PYTHON -f)"
413 else
414 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
415 fi
416
417 if ! has "${EAPI:-0}" 0 1 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; then
418 if [[ "${PYTHON_USE_WITH_OPT}" ]]; then
419 if [[ "${PYTHON_USE_WITH_OPT}" == !* ]]; then
420 use ${PYTHON_USE_WITH_OPT#!} && return
421 else
422 use !${PYTHON_USE_WITH_OPT} && return
423 fi
424 fi
425
426 python_pkg_setup_check_USE_flags() {
427 local python_atom USE_flag
428 python_atom="$(python_get_implementational_package)"
429
430 for USE_flag in ${PYTHON_USE_WITH}; do
431 if ! has_version "${python_atom}[${USE_flag}]"; then
432 eerror "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
433 die "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
434 fi
435 done
436
437 for USE_flag in ${PYTHON_USE_WITH_OR}; do
438 if has_version "${python_atom}[${USE_flag}]"; then
439 return
440 fi
441 done
442
443 if [[ ${PYTHON_USE_WITH_OR} ]]; then
444 eerror "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
445 die "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
446 fi
447 }
448
449 if _python_package_supporting_installation_for_multiple_python_abis; then
450 PYTHON_SKIP_SANITY_CHECKS="1" python_execute_function -q python_pkg_setup_check_USE_flags
451 else
452 python_pkg_setup_check_USE_flags
453 fi
454
455 unset -f python_pkg_setup_check_USE_flags
456 fi
457
458 PYTHON_PKG_SETUP_EXECUTED="1"
459}
460
461if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
462 EXPORT_FUNCTIONS pkg_setup
463fi
464
465_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|python)'
466
467# @FUNCTION: python_convert_shebangs
468# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories]
469# @DESCRIPTION:
470# Convert shebangs in specified files. Directories can be specified only with --recursive option.
471python_convert_shebangs() {
472 _python_check_python_pkg_setup_execution
473
474 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0"
475
476 while (($#)); do
477 case "$1" in
478 -r|--recursive)
479 recursive="1"
480 ;;
481 -q|--quiet)
482 quiet="1"
483 ;;
484 -x|--only-executables)
485 only_executables="1"
486 ;;
487 --)
488 shift
489 break
490 ;;
491 -*)
492 die "${FUNCNAME}(): Unrecognized option '$1'"
493 ;;
494 *)
495 break
496 ;;
497 esac
498 shift
499 done
500
501 if [[ "$#" -eq 0 ]]; then
502 die "${FUNCNAME}(): Missing Python version and files or directories"
503 elif [[ "$#" -eq 1 ]]; then
504 die "${FUNCNAME}(): Missing files or directories"
505 fi
506
507 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
508 python_interpreter="$(PYTHON "$1")"
509 else
510 python_interpreter="python$1"
511 fi
512 shift
513
514 for argument in "$@"; do
515 if [[ ! -e "${argument}" ]]; then
516 die "${FUNCNAME}(): '${argument}' does not exist"
517 elif [[ -f "${argument}" ]]; then
518 files+=("${argument}")
519 elif [[ -d "${argument}" ]]; then
520 if [[ "${recursive}" == "1" ]]; then
521 while read -d $'\0' -r file; do
522 files+=("${file}")
523 done < <(find "${argument}" $([[ "${only_executables}" == "1" ]] && echo -perm /111) -type f -print0)
524 else
525 die "${FUNCNAME}(): '${argument}' is not a regular file"
526 fi
527 else
528 die "${FUNCNAME}(): '${argument}' is not a regular file or a directory"
529 fi
530 done
531
532 for file in "${files[@]}"; do
533 file="${file#./}"
534 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
535
536 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then
537 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue
538
539 if [[ "${quiet}" == "0" ]]; then
540 einfo "Converting shebang in '${file}'"
541 fi
542
543 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed"
544 fi
545 done
546}
547
548# @FUNCTION: python_clean_installation_image
549# @USAGE: [-q|--quiet]
550# @DESCRIPTION:
551# Delete needless files in installation image.
6# 552#
7# A Utility Eclass that should be inherited by anything that deals with 553# This function can be used only in src_install() phase.
8# Python or Python modules. 554python_clean_installation_image() {
555 if [[ "${EBUILD_PHASE}" != "install" ]]; then
556 die "${FUNCNAME}() can be used only in src_install() phase"
557 fi
558
559 _python_check_python_pkg_setup_execution
560 _python_initialize_prefix_variables
561
562 local file files=() quiet="0"
563
564 while (($#)); do
565 case "$1" in
566 -q|--quiet)
567 quiet="1"
568 ;;
569 -*)
570 die "${FUNCNAME}(): Unrecognized option '$1'"
571 ;;
572 *)
573 die "${FUNCNAME}(): Invalid usage"
574 ;;
575 esac
576 shift
577 done
578
579 while read -d $'\0' -r file; do
580 files+=("${file}")
581 done < <(find "${ED}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -type f -print0)
582
583 if [[ "${#files[@]}" -gt 0 ]]; then
584 if [[ "${quiet}" == "0" ]]; then
585 ewarn "Deleting byte-compiled Python modules needlessly generated by build system:"
586 fi
587 for file in "${files[@]}"; do
588 if [[ "${quiet}" == "0" ]]; then
589 ewarn " ${file}"
590 fi
591 rm -f "${file}"
592
593 # Delete empty __pycache__ directories.
594 if [[ "${file%/*}" == *"/__pycache__" ]]; then
595 rmdir "${file%/*}" 2> /dev/null
596 fi
597 done
598 fi
599
600 python_clean_sitedirs() {
601 if [[ -d "${ED}$(python_get_sitedir)" ]]; then
602 find "${ED}$(python_get_sitedir)" "(" -name "*.c" -o -name "*.h" -o -name "*.la" ")" -type f -print0 | xargs -0 rm -f
603 fi
604 }
605 if _python_package_supporting_installation_for_multiple_python_abis; then
606 python_execute_function -q python_clean_sitedirs
607 else
608 python_clean_sitedirs
609 fi
610
611 unset -f python_clean_sitedirs
612}
613
614# ================================================================================================
615# =========== FUNCTIONS FOR PACKAGES SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ============
616# ================================================================================================
617
618# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS
619# @DESCRIPTION:
620# Set this in EAPI <= 4 to indicate that current package supports installation for
621# multiple Python ABIs.
622
623# @ECLASS-VARIABLE: PYTHON_TESTS_RESTRICTED_ABIS
624# @DESCRIPTION:
625# Space-separated list of Python ABI patterns. Testing in Python ABIs matching any Python ABI
626# patterns specified in this list is skipped.
627
628# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS
629# @DESCRIPTION:
630# Set this to export phase functions for the following ebuild phases:
631# src_prepare(), src_configure(), src_compile(), src_test(), src_install().
632if ! has "${EAPI:-0}" 0 1; then
633 python_src_prepare() {
634 if [[ "${EBUILD_PHASE}" != "prepare" ]]; then
635 die "${FUNCNAME}() can be used only in src_prepare() phase"
636 fi
637
638 if ! _python_package_supporting_installation_for_multiple_python_abis; then
639 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
640 fi
641
642 _python_check_python_pkg_setup_execution
643
644 if [[ "$#" -ne 0 ]]; then
645 die "${FUNCNAME}() does not accept arguments"
646 fi
647
648 python_copy_sources
649 }
650
651 for python_default_function in src_configure src_compile src_test; do
652 eval "python_${python_default_function}() {
653 if [[ \"\${EBUILD_PHASE}\" != \"${python_default_function#src_}\" ]]; then
654 die \"\${FUNCNAME}() can be used only in ${python_default_function}() phase\"
655 fi
656
657 if ! _python_package_supporting_installation_for_multiple_python_abis; then
658 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\"
659 fi
660
661 _python_check_python_pkg_setup_execution
662
663 python_execute_function -d -s -- \"\$@\"
664 }"
665 done
666 unset python_default_function
667
668 python_src_install() {
669 if [[ "${EBUILD_PHASE}" != "install" ]]; then
670 die "${FUNCNAME}() can be used only in src_install() phase"
671 fi
672
673 if ! _python_package_supporting_installation_for_multiple_python_abis; then
674 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
675 fi
676
677 _python_check_python_pkg_setup_execution
678
679 if has "${EAPI:-0}" 0 1 2 3; then
680 python_execute_function -d -s -- "$@"
681 else
682 python_installation() {
683 emake DESTDIR="${T}/images/${PYTHON_ABI}" install "$@"
684 }
685 python_execute_function -s python_installation "$@"
686 unset python_installation
687
688 python_merge_intermediate_installation_images "${T}/images"
689 fi
690 }
691
692 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
693 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
694 fi
695fi
696
697if has "${EAPI:-0}" 0 1 2 3 4; then
698 unset PYTHON_ABIS
699fi
700
701_python_calculate_PYTHON_ABIS() {
702 if ! _python_package_supporting_installation_for_multiple_python_abis; then
703 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
704 fi
705
706 _python_initial_sanity_checks
707
708 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3 4; then
709 local PYTHON_ABI
710
711 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
712 local cpython_enabled="0"
713
714 if [[ -z "${USE_PYTHON}" ]]; then
715 die "USE_PYTHON variable is empty"
716 fi
717
718 for PYTHON_ABI in ${USE_PYTHON}; do
719 if ! has "${PYTHON_ABI}" "${_PYTHON_GLOBALLY_SUPPORTED_ABIS[@]}"; then
720 die "USE_PYTHON variable contains invalid value '${PYTHON_ABI}'"
721 fi
722
723 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then
724 cpython_enabled="1"
725 fi
726
727 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
728 export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
729 fi
730 done
731
732 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
733 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
734 fi
735
736 if [[ "${cpython_enabled}" == "0" ]]; then
737 die "USE_PYTHON variable does not enable any CPython ABI"
738 fi
739 else
740 local python_version python2_version python3_version support_python_major_version
741
742 if ! has_version "dev-lang/python"; then
743 die "${FUNCNAME}(): 'dev-lang/python' is not installed"
744 fi
745
746 python_version="$("${EPREFIX}/usr/bin/python" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
747
748 if has_version "=dev-lang/python-2*"; then
749 if [[ "$(readlink "${EPREFIX}/usr/bin/python2")" != "python2."* ]]; then
750 die "'${EPREFIX}/usr/bin/python2' is not valid symlink"
751 fi
752
753 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
754
755 support_python_major_version="0"
756 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
757 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
758 support_python_major_version="1"
759 break
760 fi
761 done
762 if [[ "${support_python_major_version}" == "1" ]]; then
763 if _python_check_python_abi_matching --patterns-list "${python2_version}" "${RESTRICT_PYTHON_ABIS}"; then
764 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}"
765 fi
766 else
767 python2_version=""
768 fi
769 fi
770
771 if has_version "=dev-lang/python-3*"; then
772 if [[ "$(readlink "${EPREFIX}/usr/bin/python3")" != "python3."* ]]; then
773 die "'${EPREFIX}/usr/bin/python3' is not valid symlink"
774 fi
775
776 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
777
778 support_python_major_version="0"
779 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
780 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
781 support_python_major_version="1"
782 break
783 fi
784 done
785 if [[ "${support_python_major_version}" == "1" ]]; then
786 if _python_check_python_abi_matching --patterns-list "${python3_version}" "${RESTRICT_PYTHON_ABIS}"; then
787 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
788 fi
789 else
790 python3_version=""
791 fi
792 fi
793
794 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
795 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
796 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
797 die "Incorrect configuration of Python"
798 fi
799 if [[ -n "${python3_version}" && "${python_version}" == "3."* && "${python_version}" != "${python3_version}" ]]; then
800 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python3' symlink"
801 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
802 die "Incorrect configuration of Python"
803 fi
804
805 PYTHON_ABIS="${python2_version} ${python3_version}"
806 PYTHON_ABIS="${PYTHON_ABIS# }"
807 export PYTHON_ABIS="${PYTHON_ABIS% }"
808 fi
809 fi
810
811 _python_final_sanity_checks
812}
813
814_python_prepare_flags() {
815 local array=() deleted_flag element flags new_value old_flag old_value operator pattern prefix variable
816
817 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
818 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\""
819 for prefix in PYTHON_USER_ PYTHON_; do
820 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then
821 eval "array=(\"\${${prefix}${variable}[@]}\")"
822 for element in "${array[@]}"; do
823 if [[ "${element}" =~ ^${_PYTHON_ABI_PATTERN_REGEX}\ (\+|-)\ .+ ]]; then
824 pattern="${element%% *}"
825 element="${element#* }"
826 operator="${element%% *}"
827 flags="${element#* }"
828 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
829 if [[ "${operator}" == "+" ]]; then
830 eval "export ${variable}+=\"\${variable:+ }${flags}\""
831 elif [[ "${operator}" == "-" ]]; then
832 flags="${flags// /$'\n'}"
833 old_value="${!variable// /$'\n'}"
834 new_value=""
835 while read old_flag; do
836 while read deleted_flag; do
837 if [[ "${old_flag}" == ${deleted_flag} ]]; then
838 continue 2
839 fi
840 done <<< "${flags}"
841 new_value+="${new_value:+ }${old_flag}"
842 done <<< "${old_value}"
843 eval "export ${variable}=\"\${new_value}\""
844 fi
845 fi
846 else
847 die "Element '${element}' of ${prefix}${variable} array has invalid syntax"
848 fi
849 done
850 elif [[ -n "$(declare -p ${prefix}${variable} 2> /dev/null)" ]]; then
851 die "${prefix}${variable} should be indexed array"
852 fi
853 done
854 done
855}
856
857_python_restore_flags() {
858 local variable
859
860 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
861 eval "${variable}=\"\${_PYTHON_SAVED_${variable}}\""
862 unset _PYTHON_SAVED_${variable}
863 done
864}
865
866# @FUNCTION: python_execute_function
867# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments]
868# @DESCRIPTION:
869# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
870# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
871python_execute_function() {
872 if ! _python_package_supporting_installation_for_multiple_python_abis; then
873 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
874 fi
875
876 _python_check_python_pkg_setup_execution
877 _python_set_color_variables
878
879 local action action_message action_message_template default_function="0" failure_message failure_message_template final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir
880
881 while (($#)); do
882 case "$1" in
883 --action-message)
884 action_message_template="$2"
885 shift
886 ;;
887 -d|--default-function)
888 default_function="1"
889 ;;
890 --failure-message)
891 failure_message_template="$2"
892 shift
893 ;;
894 -f|--final-ABI)
895 final_ABI="1"
896 ;;
897 --nonfatal)
898 nonfatal="1"
899 ;;
900 -q|--quiet)
901 quiet="1"
902 ;;
903 -s|--separate-build-dirs)
904 separate_build_dirs="1"
905 ;;
906 --source-dir)
907 source_dir="$2"
908 shift
909 ;;
910 --)
911 shift
912 break
913 ;;
914 -*)
915 die "${FUNCNAME}(): Unrecognized option '$1'"
916 ;;
917 *)
918 break
919 ;;
920 esac
921 shift
922 done
923
924 if [[ -n "${source_dir}" && "${separate_build_dirs}" == 0 ]]; then
925 die "${FUNCNAME}(): '--source-dir' option can be specified only with '--separate-build-dirs' option"
926 fi
927
928 if [[ "${default_function}" == "0" ]]; then
929 if [[ "$#" -eq 0 ]]; then
930 die "${FUNCNAME}(): Missing function name"
931 fi
932 function="$1"
933 shift
934
935 if [[ -z "$(type -t "${function}")" ]]; then
936 die "${FUNCNAME}(): '${function}' function is not defined"
937 fi
938 else
939 if has "${EAPI:-0}" 0 1; then
940 die "${FUNCNAME}(): '--default-function' option cannot be used in this EAPI"
941 fi
942
943 if [[ "${EBUILD_PHASE}" == "configure" ]]; then
944 if has "${EAPI}" 2 3; then
945 python_default_function() {
946 econf "$@"
947 }
948 else
949 python_default_function() {
950 nonfatal econf "$@"
951 }
952 fi
953 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then
954 python_default_function() {
955 emake "$@"
956 }
957 elif [[ "${EBUILD_PHASE}" == "test" ]]; then
958 python_default_function() {
959 if emake -j1 -n check &> /dev/null; then
960 emake -j1 check "$@"
961 elif emake -j1 -n test &> /dev/null; then
962 emake -j1 test "$@"
963 fi
964 }
965 elif [[ "${EBUILD_PHASE}" == "install" ]]; then
966 python_default_function() {
967 emake DESTDIR="${D}" install "$@"
968 }
969 else
970 die "${FUNCNAME}(): '--default-function' option cannot be used in this ebuild phase"
971 fi
972 function="python_default_function"
973 fi
974
975 # Ensure that python_execute_function() cannot be directly or indirectly called by python_execute_function().
976 if _python_abi-specific_local_scope; then
977 die "${FUNCNAME}(): Invalid call stack"
978 fi
979
980 if [[ "${quiet}" == "0" ]]; then
981 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up"
982 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking"
983 [[ "${EBUILD_PHASE}" == "prepare" ]] && action="Preparation"
984 [[ "${EBUILD_PHASE}" == "configure" ]] && action="Configuration"
985 [[ "${EBUILD_PHASE}" == "compile" ]] && action="Building"
986 [[ "${EBUILD_PHASE}" == "test" ]] && action="Testing"
987 [[ "${EBUILD_PHASE}" == "install" ]] && action="Installation"
988 [[ "${EBUILD_PHASE}" == "preinst" ]] && action="Preinstallation"
989 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation"
990 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation"
991 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation"
992 fi
993
994 _python_calculate_PYTHON_ABIS
995 if [[ "${final_ABI}" == "1" ]]; then
996 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)"
997 else
998 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
999 fi
1000 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1001 if [[ "${EBUILD_PHASE}" == "test" ]] && _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${PYTHON_TESTS_RESTRICTED_ABIS}"; then
1002 if [[ "${quiet}" == "0" ]]; then
1003 echo " ${_GREEN}*${_NORMAL} ${_BLUE}Testing of ${CATEGORY}/${PF} with $(python_get_implementation) $(python_get_version) skipped${_NORMAL}"
1004 fi
1005 continue
1006 fi
1007
1008 _python_prepare_flags
1009
1010 if [[ "${quiet}" == "0" ]]; then
1011 if [[ -n "${action_message_template}" ]]; then
1012 eval "action_message=\"${action_message_template}\""
1013 else
1014 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation) $(python_get_version)..."
1015 fi
1016 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}"
1017 fi
1018
1019 if [[ "${separate_build_dirs}" == "1" ]]; then
1020 if [[ -n "${source_dir}" ]]; then
1021 export BUILDDIR="${S}/${source_dir}-${PYTHON_ABI}"
1022 else
1023 export BUILDDIR="${S}-${PYTHON_ABI}"
1024 fi
1025 pushd "${BUILDDIR}" > /dev/null || die "pushd failed"
1026 else
1027 export BUILDDIR="${S}"
1028 fi
1029
1030 previous_directory="$(pwd)"
1031 previous_directory_stack="$(dirs -p)"
1032 previous_directory_stack_length="$(dirs -p | wc -l)"
1033
1034 if ! has "${EAPI}" 0 1 2 3 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1035 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@"
1036 else
1037 EPYTHON="$(PYTHON)" "${function}" "$@"
1038 fi
1039
1040 return_code="$?"
1041
1042 _python_restore_flags
1043
1044 if [[ "${return_code}" -ne 0 ]]; then
1045 if [[ -n "${failure_message_template}" ]]; then
1046 eval "failure_message=\"${failure_message_template}\""
1047 else
1048 failure_message="${action} failed with $(python_get_implementation) $(python_get_version) in ${function}() function"
1049 fi
1050
1051 if [[ "${nonfatal}" == "1" ]]; then
1052 if [[ "${quiet}" == "0" ]]; then
1053 ewarn "${failure_message}"
1054 fi
1055 elif [[ "${final_ABI}" == "0" ]] && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1056 if [[ "${EBUILD_PHASE}" != "test" ]] || ! has test-fail-continue ${FEATURES}; then
1057 local enabled_PYTHON_ABIS= other_PYTHON_ABI
1058 for other_PYTHON_ABI in ${PYTHON_ABIS}; do
1059 [[ "${other_PYTHON_ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+="${enabled_PYTHON_ABIS:+ }${other_PYTHON_ABI}"
1060 done
1061 export PYTHON_ABIS="${enabled_PYTHON_ABIS}"
1062 fi
1063 if [[ "${quiet}" == "0" ]]; then
1064 ewarn "${failure_message}"
1065 fi
1066 if [[ -z "${PYTHON_ABIS}" ]]; then
1067 die "${function}() function failed with all enabled Python ABIs"
1068 fi
1069 else
1070 die "${failure_message}"
1071 fi
1072 fi
1073
1074 # Ensure that directory stack has not been decreased.
1075 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then
1076 die "Directory stack decreased illegally"
1077 fi
1078
1079 # Avoid side effects of earlier returning from the specified function.
1080 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do
1081 popd > /dev/null || die "popd failed"
1082 done
1083
1084 # Ensure that the bottom part of directory stack has not been changed. Restore
1085 # previous directory (from before running of the specified function) before
1086 # comparison of directory stacks to avoid mismatch of directory stacks after
1087 # potential using of 'cd' to change current directory. Restoration of previous
1088 # directory allows to safely use 'cd' to change current directory in the
1089 # specified function without changing it back to original directory.
1090 cd "${previous_directory}"
1091 if [[ "$(dirs -p)" != "${previous_directory_stack}" ]]; then
1092 die "Directory stack changed illegally"
1093 fi
1094
1095 if [[ "${separate_build_dirs}" == "1" ]]; then
1096 popd > /dev/null || die "popd failed"
1097 fi
1098 unset BUILDDIR
1099 done
1100
1101 if [[ "${default_function}" == "1" ]]; then
1102 unset -f python_default_function
1103 fi
1104}
1105
1106# @FUNCTION: python_copy_sources
1107# @USAGE: <directory="${S}"> [directory]
1108# @DESCRIPTION:
1109# Copy unpacked sources of current package to separate build directory for each Python ABI.
1110python_copy_sources() {
1111 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1112 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1113 fi
1114
1115 _python_check_python_pkg_setup_execution
1116
1117 local dir dirs=() PYTHON_ABI
1118
1119 if [[ "$#" -eq 0 ]]; then
1120 if [[ "${WORKDIR}" == "${S}" ]]; then
1121 die "${FUNCNAME}() cannot be used with current value of S variable"
1122 fi
1123 dirs=("${S%/}")
1124 else
1125 dirs=("$@")
1126 fi
1127
1128 _python_calculate_PYTHON_ABIS
1129 for PYTHON_ABI in ${PYTHON_ABIS}; do
1130 for dir in "${dirs[@]}"; do
1131 cp -pr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
1132 done
1133 done
1134}
1135
1136# @FUNCTION: python_generate_wrapper_scripts
1137# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files]
1138# @DESCRIPTION:
1139# Generate wrapper scripts. Existing files are overwritten only with --force option.
1140# If --respect-EPYTHON option is specified, then generated wrapper scripts will
1141# respect EPYTHON variable at run time.
9# 1142#
10# - Features: 1143# This function can be used only in src_install() phase.
11# python_version() - sets PYVER/PYVER_MAJOR/PYVER_MINOR 1144python_generate_wrapper_scripts() {
12# python_tkinter_exists() - Checks for tkinter support in python 1145 if [[ "${EBUILD_PHASE}" != "install" ]]; then
13# python_mod_exists() - Checks if a python module exists 1146 die "${FUNCNAME}() can be used only in src_install() phase"
14# python_mod_compile() - Compiles a .py file to a .pyc/.pyo
15# python_mod_optimize() - Generates .pyc/.pyo precompiled scripts
16# python_mod_cleanup() - Goes through /usr/lib*/python* to remove
17# orphaned *.pyc *.pyo
18# python_makesym() - Makes /usr/bin/python symlinks
19
20inherit alternatives
21
22
23if [[ -n "${NEED_PYTHON}" ]] ; then
24 DEPEND=">=dev-lang/python-${NEED_PYTHON}"
25 RDEPEND="${DEPEND}"
26fi 1147 fi
27 1148
28__python_eclass_test() { 1149 if ! _python_package_supporting_installation_for_multiple_python_abis; then
29 __python_version_extract 2.3 1150 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
30 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR" 1151 fi
31 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
32 __python_version_extract 2.3.4
33 echo -n "2.3.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
34 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
35 __python_version_extract 2.3.5
36 echo -n "2.3.5 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
37 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
38 __python_version_extract 2.4
39 echo -n "2.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
40 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
41}
42 1152
1153 _python_check_python_pkg_setup_execution
1154 _python_initialize_prefix_variables
1155
1156 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0"
1157
1158 while (($#)); do
1159 case "$1" in
1160 -E|--respect-EPYTHON)
1161 respect_EPYTHON="1"
1162 ;;
1163 -f|--force)
1164 force="1"
1165 ;;
1166 -q|--quiet)
1167 quiet="1"
1168 ;;
1169 --)
1170 shift
1171 break
1172 ;;
1173 -*)
1174 die "${FUNCNAME}(): Unrecognized option '$1'"
1175 ;;
1176 *)
1177 break
1178 ;;
1179 esac
1180 shift
1181 done
1182
1183 if [[ "$#" -eq 0 ]]; then
1184 die "${FUNCNAME}(): Missing arguments"
1185 fi
1186
1187 _python_calculate_PYTHON_ABIS
1188 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1189 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1190 python2_enabled="1"
1191 fi
1192 done
1193 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1194 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1195 python3_enabled="1"
1196 fi
1197 done
1198
1199 if [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "1" ]]; then
1200 eselect_python_option=
1201 elif [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "0" ]]; then
1202 eselect_python_option="--python2"
1203 elif [[ "${python2_enabled}" == "0" && "${python3_enabled}" == "1" ]]; then
1204 eselect_python_option="--python3"
1205 else
1206 die "${FUNCNAME}(): Unsupported environment"
1207 fi
1208
1209 PYTHON_ABIS_list="$("$(PYTHON -f)" -c "print(', '.join('\"%s\"' % x for x in reversed('${PYTHON_ABIS}'.split())))")"
1210
1211 for file in "$@"; do
1212 if [[ -f "${file}" && "${force}" == "0" ]]; then
1213 die "${FUNCNAME}(): '${file}' already exists"
1214 fi
1215
1216 if [[ "${quiet}" == "0" ]]; then
1217 einfo "Generating '${file#${ED%/}}' wrapper script"
1218 fi
1219
1220 cat << EOF > "${file}"
1221#!/usr/bin/env python
1222# Gentoo '${file##*/}' wrapper script generated by python_generate_wrapper_scripts()
1223
1224import os
1225import re
1226import subprocess
1227import sys
1228
1229cpython_re = re.compile(r"^python(\d+\.\d+)$")
1230jython_re = re.compile(r"^jython(\d+\.\d+)$")
1231python_shebang_re = re.compile(r"^#! *(${EPREFIX}/usr/bin/python|(${EPREFIX})?/usr/bin/env +(${EPREFIX}/usr/bin/)?python)")
1232python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1233
1234def get_PYTHON_ABI(EPYTHON):
1235 cpython_matched = cpython_re.match(EPYTHON)
1236 jython_matched = jython_re.match(EPYTHON)
1237 if cpython_matched is not None:
1238 PYTHON_ABI = cpython_matched.group(1)
1239 elif jython_matched is not None:
1240 PYTHON_ABI = jython_matched.group(1) + "-jython"
1241 else:
1242 PYTHON_ABI = None
1243 return PYTHON_ABI
1244
1245EOF
1246 if [[ "$?" != "0" ]]; then
1247 die "${FUNCNAME}(): Generation of '$1' failed"
1248 fi
1249 if [[ "${respect_EPYTHON}" == "1" ]]; then
1250 cat << EOF >> "${file}"
1251EPYTHON = os.environ.get("EPYTHON")
1252if EPYTHON:
1253 PYTHON_ABI = get_PYTHON_ABI(EPYTHON)
1254 if PYTHON_ABI is None:
1255 sys.stderr.write("EPYTHON variable has unrecognized value '%s'\n" % EPYTHON)
1256 sys.exit(1)
1257else:
1258 try:
1259 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], stdout=subprocess.PIPE)
1260 if eselect_process.wait() != 0:
1261 raise ValueError
1262 except (OSError, ValueError):
1263 sys.stderr.write("Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n")
1264 sys.exit(1)
1265
1266 EPYTHON = eselect_process.stdout.read()
1267 if not isinstance(EPYTHON, str):
1268 # Python 3
1269 EPYTHON = EPYTHON.decode()
1270 EPYTHON = EPYTHON.rstrip("\n")
1271
1272 PYTHON_ABI = get_PYTHON_ABI(EPYTHON)
1273 if PYTHON_ABI is None:
1274 sys.stderr.write("'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % EPYTHON)
1275 sys.exit(1)
1276
1277wrapper_script_path = os.path.realpath(sys.argv[0])
1278target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1279if not os.path.exists(target_executable_path):
1280 sys.stderr.write("'%s' does not exist\n" % target_executable_path)
1281 sys.exit(1)
1282EOF
1283 if [[ "$?" != "0" ]]; then
1284 die "${FUNCNAME}(): Generation of '$1' failed"
1285 fi
1286 else
1287 cat << EOF >> "${file}"
1288try:
1289 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], stdout=subprocess.PIPE)
1290 if eselect_process.wait() != 0:
1291 raise ValueError
1292except (OSError, ValueError):
1293 sys.stderr.write("Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n")
1294 sys.exit(1)
1295
1296EPYTHON = eselect_process.stdout.read()
1297if not isinstance(EPYTHON, str):
1298 # Python 3
1299 EPYTHON = EPYTHON.decode()
1300EPYTHON = EPYTHON.rstrip("\n")
1301
1302PYTHON_ABI = get_PYTHON_ABI(EPYTHON)
1303if PYTHON_ABI is None:
1304 sys.stderr.write("'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % EPYTHON)
1305 sys.exit(1)
1306
1307wrapper_script_path = os.path.realpath(sys.argv[0])
1308for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]:
1309 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1310 if os.path.exists(target_executable_path):
1311 break
1312else:
1313 sys.stderr.write("No target script exists for '%s'\n" % wrapper_script_path)
1314 sys.exit(1)
1315EOF
1316 if [[ "$?" != "0" ]]; then
1317 die "${FUNCNAME}(): Generation of '$1' failed"
1318 fi
1319 fi
1320 cat << EOF >> "${file}"
1321
1322target_executable = open(target_executable_path, "rb")
1323target_executable_first_line = target_executable.readline()
1324if not isinstance(target_executable_first_line, str):
1325 # Python 3
1326 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace")
1327
1328python_shebang_matched = python_shebang_re.match(target_executable_first_line)
1329target_executable.close()
1330
1331if python_shebang_matched is not None:
1332 try:
1333 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % EPYTHON
1334 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1"
1335 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE)
1336 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"]
1337 if python_verification_process.wait() != 0:
1338 raise ValueError
1339
1340 python_verification_output = python_verification_process.stdout.read()
1341 if not isinstance(python_verification_output, str):
1342 # Python 3
1343 python_verification_output = python_verification_output.decode()
1344
1345 if not python_verification_output_re.match(python_verification_output):
1346 raise ValueError
1347
1348 if cpython_re.match(EPYTHON) is not None:
1349 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0])
1350 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0]
1351 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path
1352
1353 if hasattr(os, "execv"):
1354 os.execv(python_interpreter_path, [python_interpreter_path] + sys.argv)
1355 else:
1356 sys.exit(subprocess.Popen([python_interpreter_path] + sys.argv).wait())
1357 except (KeyboardInterrupt, SystemExit):
1358 raise
1359 except:
1360 pass
1361 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"):
1362 if variable in os.environ:
1363 del os.environ[variable]
1364
1365if hasattr(os, "execv"):
1366 os.execv(target_executable_path, sys.argv)
1367else:
1368 sys.exit(subprocess.Popen([target_executable_path] + sys.argv[1:]).wait())
1369EOF
1370 if [[ "$?" != "0" ]]; then
1371 die "${FUNCNAME}(): Generation of '$1' failed"
1372 fi
1373 fperms +x "${file#${ED%/}}" || die "fperms '${file}' failed"
1374 done
1375}
1376
1377# @ECLASS-VARIABLE: PYTHON_VERSIONED_SCRIPTS
1378# @DESCRIPTION:
1379# Array of regular expressions of paths to versioned Python scripts.
1380# Python scripts in /usr/bin and /usr/sbin are versioned by default.
1381
1382# @ECLASS-VARIABLE: PYTHON_VERSIONED_EXECUTABLES
1383# @DESCRIPTION:
1384# Array of regular expressions of paths to versioned executables (including Python scripts).
1385
1386# @ECLASS-VARIABLE: PYTHON_NONVERSIONED_EXECUTABLES
1387# @DESCRIPTION:
1388# Array of regular expressions of paths to nonversioned executables (including Python scripts).
1389
1390# @FUNCTION: python_merge_intermediate_installation_images
1391# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory>
1392# @DESCRIPTION:
1393# Merge intermediate installation images into installation image.
43# 1394#
44# name: python_disable/enable_pyc 1395# This function can be used only in src_install() phase.
45# desc: tells python not to automatically recompile modules to .pyc/.pyo 1396python_merge_intermediate_installation_images() {
46# even if the timestamps/version stamps don't match. this is 1397 if [[ "${EBUILD_PHASE}" != "install" ]]; then
47# done to protect sandbox. 1398 die "${FUNCNAME}() can be used only in src_install() phase"
1399 fi
1400
1401 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1402 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1403 fi
1404
1405 _python_check_python_pkg_setup_execution
1406 _python_initialize_prefix_variables
1407
1408 local b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=()
1409
1410 while (($#)); do
1411 case "$1" in
1412 -q|--quiet)
1413 quiet="1"
1414 ;;
1415 --)
1416 shift
1417 break
1418 ;;
1419 -*)
1420 die "${FUNCNAME}(): Unrecognized option '$1'"
1421 ;;
1422 *)
1423 break
1424 ;;
1425 esac
1426 shift
1427 done
1428
1429 if [[ "$#" -ne 1 ]]; then
1430 die "${FUNCNAME}() requires 1 argument"
1431 fi
1432
1433 intermediate_installation_images_directory="$1"
1434
1435 if [[ ! -d "${intermediate_installation_images_directory}" ]]; then
1436 die "${FUNCNAME}(): Intermediate installation images directory '${intermediate_installation_images_directory}' does not exist"
1437 fi
1438
1439 _python_calculate_PYTHON_ABIS
1440 if [[ "$(PYTHON -f --ABI)" == 3.* ]]; then
1441 b="b"
1442 fi
1443
1444 while read -d $'\0' -r file; do
1445 files+=("${file}")
1446 done < <("$(PYTHON -f)" -c \
1447"import os
1448import sys
1449
1450if hasattr(sys.stdout, 'buffer'):
1451 # Python 3
1452 stdout = sys.stdout.buffer
1453else:
1454 # Python 2
1455 stdout = sys.stdout
1456
1457files_set = set()
1458
1459os.chdir(${b}'${intermediate_installation_images_directory}')
1460
1461for PYTHON_ABI in ${b}'${PYTHON_ABIS}'.split():
1462 for root, dirs, files in os.walk(PYTHON_ABI + ${b}'${EPREFIX}'):
1463 root = root[len(PYTHON_ABI + ${b}'${EPREFIX}')+1:]
1464 files_set.update(root + ${b}'/' + file for file in files)
1465
1466for file in sorted(files_set):
1467 stdout.write(file)
1468 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of files in intermediate installation images")
1469
1470 for PYTHON_ABI in ${PYTHON_ABIS}; do
1471 if [[ ! -d "${intermediate_installation_images_directory}/${PYTHON_ABI}" ]]; then
1472 die "${FUNCNAME}(): Intermediate installation image for Python ABI '${PYTHON_ABI}' does not exist"
1473 fi
1474
1475 pushd "${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}" > /dev/null || die "pushd failed"
1476
1477 for file in "${files[@]}"; do
1478 version_executable="0"
1479 for regex in "/usr/bin/.*" "/usr/sbin/.*" "${PYTHON_VERSIONED_SCRIPTS[@]}"; do
1480 if [[ "/${file}" =~ ^${regex}$ ]]; then
1481 version_executable="1"
1482 break
1483 fi
1484 done
1485 for regex in "${PYTHON_VERSIONED_EXECUTABLES[@]}"; do
1486 if [[ "/${file}" =~ ^${regex}$ ]]; then
1487 version_executable="2"
1488 break
1489 fi
1490 done
1491 if [[ "${version_executable}" != "0" ]]; then
1492 for regex in "${PYTHON_NONVERSIONED_EXECUTABLES[@]}"; do
1493 if [[ "/${file}" =~ ^${regex}$ ]]; then
1494 version_executable="0"
1495 break
1496 fi
1497 done
1498 fi
1499
1500 [[ "${version_executable}" == "0" || ! -x "${file}" ]] && continue
1501
1502 shebang="$(head -n1 "${file}")" || die "Extraction of shebang from '${file}' failed"
1503
1504 if [[ "${version_executable}" == "2" ]]; then
1505 wrapper_scripts+=("${ED}${file}")
1506 elif [[ "${version_executable}" == "1" ]]; then
1507 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then
1508 wrapper_scripts+=("${ED}${file}")
1509 else
1510 version_executable="0"
1511 fi
1512 fi
1513
1514 [[ "${version_executable}" == "0" ]] && continue
1515
1516 if [[ -e "${file}-${PYTHON_ABI}" ]]; then
1517 die "${FUNCNAME}(): '${EPREFIX}/${file}-${PYTHON_ABI}' already exists"
1518 fi
1519
1520 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed"
1521
1522 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then
1523 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}"
1524 fi
1525 done
1526
1527 popd > /dev/null || die "popd failed"
1528
1529 if ROOT="/" has_version sys-apps/coreutils; then
1530 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1531 else
1532 cp -fpr "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1533 fi
1534 done
1535
1536 rm -fr "${intermediate_installation_images_directory}"
1537
1538 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then
1539 rm -f "${T}/python_wrapper_scripts"
1540
1541 for file in "${wrapper_scripts[@]}"; do
1542 echo -n "${file}" >> "${T}/python_wrapper_scripts"
1543 echo -en "\x00" >> "${T}/python_wrapper_scripts"
1544 done
1545
1546 while read -d $'\0' -r file; do
1547 wrapper_scripts_set+=("${file}")
1548 done < <("$(PYTHON -f)" -c \
1549"import sys
1550
1551if hasattr(sys.stdout, 'buffer'):
1552 # Python 3
1553 stdout = sys.stdout.buffer
1554else:
1555 # Python 2
1556 stdout = sys.stdout
1557
1558files = set(open('${T}/python_wrapper_scripts', 'rb').read().rstrip(${b}'\x00').split(${b}'\x00'))
1559
1560for file in sorted(files):
1561 stdout.write(file)
1562 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts")
1563
1564 python_generate_wrapper_scripts $([[ "${quiet}" == "1" ]] && echo --quiet) "${wrapper_scripts_set[@]}"
1565 fi
1566}
1567
1568# ================================================================================================
1569# ========= FUNCTIONS FOR PACKAGES NOT SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ==========
1570# ================================================================================================
1571
1572unset EPYTHON PYTHON_ABI
1573
1574# @FUNCTION: python_set_active_version
1575# @USAGE: <Python_ABI|2|3>
1576# @DESCRIPTION:
1577# Set locally active version of Python.
1578# If Python_ABI argument is specified, then version of Python corresponding to Python_ABI is used.
1579# If 2 argument is specified, then active version of CPython 2 is used.
1580# If 3 argument is specified, then active version of CPython 3 is used.
48# 1581#
49# note: supported by >=dev-lang/python-2.2.3-r3 only. 1582# This function can be used only in pkg_setup() phase.
1583python_set_active_version() {
1584 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
1585 die "${FUNCNAME}() can be used only in pkg_setup() phase"
1586 fi
1587
1588 if _python_package_supporting_installation_for_multiple_python_abis; then
1589 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1590 fi
1591
1592 if [[ "$#" -ne 1 ]]; then
1593 die "${FUNCNAME}() requires 1 argument"
1594 fi
1595
1596 _python_initial_sanity_checks
1597
1598 if [[ -z "${PYTHON_ABI}" ]]; then
1599 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
1600 # PYTHON_ABI variable is intended to be used only in ebuilds/eclasses,
1601 # so it does not need to be exported to subprocesses.
1602 PYTHON_ABI="$1"
1603 if ! _python_implementation && ! has_version "$(python_get_implementational_package)"; then
1604 die "${FUNCNAME}(): '$(python_get_implementational_package)' is not installed"
1605 fi
1606 export EPYTHON="$(PYTHON "$1")"
1607 elif [[ "$1" == "2" ]]; then
1608 if ! _python_implementation && ! has_version "=dev-lang/python-2*"; then
1609 die "${FUNCNAME}(): '=dev-lang/python-2*' is not installed"
1610 fi
1611 export EPYTHON="$(PYTHON -2)"
1612 PYTHON_ABI="${EPYTHON#python}"
1613 PYTHON_ABI="${PYTHON_ABI%%-*}"
1614 elif [[ "$1" == "3" ]]; then
1615 if ! _python_implementation && ! has_version "=dev-lang/python-3*"; then
1616 die "${FUNCNAME}(): '=dev-lang/python-3*' is not installed"
1617 fi
1618 export EPYTHON="$(PYTHON -3)"
1619 PYTHON_ABI="${EPYTHON#python}"
1620 PYTHON_ABI="${PYTHON_ABI%%-*}"
1621 else
1622 die "${FUNCNAME}(): Unrecognized argument '$1'"
1623 fi
1624 fi
1625
1626 _python_final_sanity_checks
1627
1628 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable.
1629 PYTHON_REQUESTED_ACTIVE_VERSION="$1"
1630}
1631
1632# @FUNCTION: python_need_rebuild
1633# @DESCRIPTION: Mark current package for rebuilding by python-updater after
1634# switching of active version of Python.
1635python_need_rebuild() {
1636 if _python_package_supporting_installation_for_multiple_python_abis; then
1637 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1638 fi
1639
1640 _python_check_python_pkg_setup_execution
1641
1642 if [[ "$#" -ne 0 ]]; then
1643 die "${FUNCNAME}() does not accept arguments"
1644 fi
1645
1646 export PYTHON_NEED_REBUILD="$(PYTHON --ABI)"
1647}
1648
1649# ================================================================================================
1650# ======================================= GETTER FUNCTIONS =======================================
1651# ================================================================================================
1652
1653_PYTHON_ABI_EXTRACTION_COMMAND='import platform
1654import sys
1655sys.stdout.write(".".join(str(x) for x in sys.version_info[:2]))
1656if platform.system()[:4] == "Java":
1657 sys.stdout.write("-jython")'
1658
1659_python_get_implementation() {
1660 local ignore_invalid="0"
1661
1662 while (($#)); do
1663 case "$1" in
1664 --ignore-invalid)
1665 ignore_invalid="1"
1666 ;;
1667 --)
1668 shift
1669 break
1670 ;;
1671 -*)
1672 die "${FUNCNAME}(): Unrecognized option '$1'"
1673 ;;
1674 *)
1675 break
1676 ;;
1677 esac
1678 shift
1679 done
1680
1681 if [[ "$#" -ne 1 ]]; then
1682 die "${FUNCNAME}() requires 1 argument"
1683 fi
1684
1685 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
1686 echo "CPython"
1687 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
1688 echo "Jython"
1689 else
1690 if [[ "${ignore_invalid}" == "0" ]]; then
1691 die "${FUNCNAME}(): Unrecognized Python ABI '$1'"
1692 fi
1693 fi
1694}
1695
1696# @FUNCTION: PYTHON
1697# @USAGE: [-2] [-3] [--ABI] [-a|--absolute-path] [-f|--final-ABI] [--] <Python_ABI="${PYTHON_ABI}">
1698# @DESCRIPTION:
1699# Print filename of Python interpreter for specified Python ABI. If Python_ABI argument
1700# is ommitted, then PYTHON_ABI environment variable must be set and is used.
1701# If -2 option is specified, then active version of CPython 2 is used.
1702# If -3 option is specified, then active version of CPython 3 is used.
1703# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1704# -2, -3 and --final-ABI options and Python_ABI argument cannot be specified simultaneously.
1705# If --ABI option is specified, then only specified Python ABI is printed instead of
1706# filename of Python interpreter.
1707# If --absolute-path option is specified, then absolute path to Python interpreter is printed.
1708# --ABI and --absolute-path options cannot be specified simultaneously.
1709PYTHON() {
1710 _python_check_python_pkg_setup_execution
1711
1712 local ABI_output="0" absolute_path_output="0" final_ABI="0" PYTHON_ABI="${PYTHON_ABI}" python_interpreter python2="0" python3="0"
1713
1714 while (($#)); do
1715 case "$1" in
1716 -2)
1717 python2="1"
1718 ;;
1719 -3)
1720 python3="1"
1721 ;;
1722 --ABI)
1723 ABI_output="1"
1724 ;;
1725 -a|--absolute-path)
1726 absolute_path_output="1"
1727 ;;
1728 -f|--final-ABI)
1729 final_ABI="1"
1730 ;;
1731 --)
1732 shift
1733 break
1734 ;;
1735 -*)
1736 die "${FUNCNAME}(): Unrecognized option '$1'"
1737 ;;
1738 *)
1739 break
1740 ;;
1741 esac
1742 shift
1743 done
1744
1745 if [[ "${ABI_output}" == "1" && "${absolute_path_output}" == "1" ]]; then
1746 die "${FUNCNAME}(): '--ABI' and '--absolute-path' options cannot be specified simultaneously"
1747 fi
1748
1749 if [[ "$((${python2} + ${python3} + ${final_ABI}))" -gt 1 ]]; then
1750 die "${FUNCNAME}(): '-2', '-3' or '--final-ABI' options cannot be specified simultaneously"
1751 fi
1752
1753 if [[ "$#" -eq 0 ]]; then
1754 if [[ "${final_ABI}" == "1" ]]; then
1755 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1756 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1757 fi
1758 _python_calculate_PYTHON_ABIS
1759 PYTHON_ABI="${PYTHON_ABIS##* }"
1760 elif [[ "${python2}" == "1" ]]; then
1761 PYTHON_ABI="$(eselect python show --python2 --ABI)"
1762 if [[ -z "${PYTHON_ABI}" ]]; then
1763 die "${FUNCNAME}(): Active version of CPython 2 not set"
1764 elif [[ "${PYTHON_ABI}" != "2."* ]]; then
1765 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`"
1766 fi
1767 elif [[ "${python3}" == "1" ]]; then
1768 PYTHON_ABI="$(eselect python show --python3 --ABI)"
1769 if [[ -z "${PYTHON_ABI}" ]]; then
1770 die "${FUNCNAME}(): Active version of CPython 3 not set"
1771 elif [[ "${PYTHON_ABI}" != "3."* ]]; then
1772 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`"
1773 fi
1774 elif _python_package_supporting_installation_for_multiple_python_abis; then
1775 if ! _python_abi-specific_local_scope; then
1776 die "${FUNCNAME}() should be used in ABI-specific local scope"
1777 fi
1778 else
1779 PYTHON_ABI="$("${EPREFIX}/usr/bin/python" -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")"
1780 if [[ -z "${PYTHON_ABI}" ]]; then
1781 die "${FUNCNAME}(): Failure of extraction of locally active version of Python"
1782 fi
1783 fi
1784 elif [[ "$#" -eq 1 ]]; then
1785 if [[ "${final_ABI}" == "1" ]]; then
1786 die "${FUNCNAME}(): '--final-ABI' option and Python ABI cannot be specified simultaneously"
1787 fi
1788 if [[ "${python2}" == "1" ]]; then
1789 die "${FUNCNAME}(): '-2' option and Python ABI cannot be specified simultaneously"
1790 fi
1791 if [[ "${python3}" == "1" ]]; then
1792 die "${FUNCNAME}(): '-3' option and Python ABI cannot be specified simultaneously"
1793 fi
1794 PYTHON_ABI="$1"
1795 else
1796 die "${FUNCNAME}(): Invalid usage"
1797 fi
1798
1799 if [[ "${ABI_output}" == "1" ]]; then
1800 echo -n "${PYTHON_ABI}"
1801 return
1802 else
1803 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1804 python_interpreter="python${PYTHON_ABI}"
1805 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1806 python_interpreter="jython${PYTHON_ABI%-jython}"
1807 fi
1808
1809 if [[ "${absolute_path_output}" == "1" ]]; then
1810 echo -n "${EPREFIX}/usr/bin/${python_interpreter}"
1811 else
1812 echo -n "${python_interpreter}"
1813 fi
1814 fi
1815
1816 if [[ -n "${ABI}" && "${ABI}" != "${DEFAULT_ABI}" && "${DEFAULT_ABI}" != "default" ]]; then
1817 echo -n "-${ABI}"
1818 fi
1819}
1820
1821# @FUNCTION: python_get_implementation
1822# @USAGE: [-f|--final-ABI]
1823# @DESCRIPTION:
1824# Print name of Python implementation.
1825# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1826python_get_implementation() {
1827 _python_check_python_pkg_setup_execution
1828
1829 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
1830
1831 while (($#)); do
1832 case "$1" in
1833 -f|--final-ABI)
1834 final_ABI="1"
1835 ;;
1836 -*)
1837 die "${FUNCNAME}(): Unrecognized option '$1'"
1838 ;;
1839 *)
1840 die "${FUNCNAME}(): Invalid usage"
1841 ;;
1842 esac
1843 shift
1844 done
1845
1846 if [[ "${final_ABI}" == "1" ]]; then
1847 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1848 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1849 fi
1850 PYTHON_ABI="$(PYTHON -f --ABI)"
1851 else
1852 if _python_package_supporting_installation_for_multiple_python_abis; then
1853 if ! _python_abi-specific_local_scope; then
1854 die "${FUNCNAME}() should be used in ABI-specific local scope"
1855 fi
1856 else
1857 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
1858 fi
1859 fi
1860
1861 echo "$(_python_get_implementation "${PYTHON_ABI}")"
1862}
1863
1864# @FUNCTION: python_get_implementational_package
1865# @USAGE: [-f|--final-ABI]
1866# @DESCRIPTION:
1867# Print category, name and slot of package providing Python implementation.
1868# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1869python_get_implementational_package() {
1870 _python_check_python_pkg_setup_execution
1871
1872 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
1873
1874 while (($#)); do
1875 case "$1" in
1876 -f|--final-ABI)
1877 final_ABI="1"
1878 ;;
1879 -*)
1880 die "${FUNCNAME}(): Unrecognized option '$1'"
1881 ;;
1882 *)
1883 die "${FUNCNAME}(): Invalid usage"
1884 ;;
1885 esac
1886 shift
1887 done
1888
1889 if [[ "${final_ABI}" == "1" ]]; then
1890 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1891 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1892 fi
1893 PYTHON_ABI="$(PYTHON -f --ABI)"
1894 else
1895 if _python_package_supporting_installation_for_multiple_python_abis; then
1896 if ! _python_abi-specific_local_scope; then
1897 die "${FUNCNAME}() should be used in ABI-specific local scope"
1898 fi
1899 else
1900 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
1901 fi
1902 fi
1903
1904 if [[ "${EAPI:-0}" == "0" ]]; then
1905 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1906 echo "=dev-lang/python-${PYTHON_ABI}*"
1907 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1908 echo "=dev-java/jython-${PYTHON_ABI%-jython}*"
1909 fi
1910 else
1911 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1912 echo "dev-lang/python:${PYTHON_ABI}"
1913 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1914 echo "dev-java/jython:${PYTHON_ABI%-jython}"
1915 fi
1916 fi
1917}
1918
1919# @FUNCTION: python_get_includedir
1920# @USAGE: [-b|--base-path] [-f|--final-ABI]
1921# @DESCRIPTION:
1922# Print path to Python include directory.
1923# If --base-path option is specified, then path not prefixed with "/" is printed.
1924# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1925python_get_includedir() {
1926 _python_check_python_pkg_setup_execution
1927
1928 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
1929
1930 while (($#)); do
1931 case "$1" in
1932 -b|--base-path)
1933 base_path="1"
1934 ;;
1935 -f|--final-ABI)
1936 final_ABI="1"
1937 ;;
1938 -*)
1939 die "${FUNCNAME}(): Unrecognized option '$1'"
1940 ;;
1941 *)
1942 die "${FUNCNAME}(): Invalid usage"
1943 ;;
1944 esac
1945 shift
1946 done
1947
1948 if [[ "${base_path}" == "0" ]]; then
1949 prefix="/"
1950 fi
1951
1952 if [[ "${final_ABI}" == "1" ]]; then
1953 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1954 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1955 fi
1956 PYTHON_ABI="$(PYTHON -f --ABI)"
1957 else
1958 if _python_package_supporting_installation_for_multiple_python_abis; then
1959 if ! _python_abi-specific_local_scope; then
1960 die "${FUNCNAME}() should be used in ABI-specific local scope"
1961 fi
1962 else
1963 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
1964 fi
1965 fi
1966
1967 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1968 echo "${prefix}usr/include/python${PYTHON_ABI}"
1969 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1970 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include"
1971 fi
1972}
1973
1974# @FUNCTION: python_get_libdir
1975# @USAGE: [-b|--base-path] [-f|--final-ABI]
1976# @DESCRIPTION:
1977# Print path to Python library directory.
1978# If --base-path option is specified, then path not prefixed with "/" is printed.
1979# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1980python_get_libdir() {
1981 _python_check_python_pkg_setup_execution
1982
1983 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
1984
1985 while (($#)); do
1986 case "$1" in
1987 -b|--base-path)
1988 base_path="1"
1989 ;;
1990 -f|--final-ABI)
1991 final_ABI="1"
1992 ;;
1993 -*)
1994 die "${FUNCNAME}(): Unrecognized option '$1'"
1995 ;;
1996 *)
1997 die "${FUNCNAME}(): Invalid usage"
1998 ;;
1999 esac
2000 shift
2001 done
2002
2003 if [[ "${base_path}" == "0" ]]; then
2004 prefix="/"
2005 fi
2006
2007 if [[ "${final_ABI}" == "1" ]]; then
2008 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2009 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2010 fi
2011 PYTHON_ABI="$(PYTHON -f --ABI)"
2012 else
2013 if _python_package_supporting_installation_for_multiple_python_abis; then
2014 if ! _python_abi-specific_local_scope; then
2015 die "${FUNCNAME}() should be used in ABI-specific local scope"
2016 fi
2017 else
2018 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2019 fi
2020 fi
2021
2022 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2023 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}"
2024 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2025 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib"
2026 fi
2027}
2028
2029# @FUNCTION: python_get_sitedir
2030# @USAGE: [-b|--base-path] [-f|--final-ABI]
2031# @DESCRIPTION:
2032# Print path to Python site-packages directory.
2033# If --base-path option is specified, then path not prefixed with "/" is printed.
2034# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2035python_get_sitedir() {
2036 _python_check_python_pkg_setup_execution
2037
2038 local final_ABI="0" options=()
2039
2040 while (($#)); do
2041 case "$1" in
2042 -b|--base-path)
2043 options+=("$1")
2044 ;;
2045 -f|--final-ABI)
2046 final_ABI="1"
2047 options+=("$1")
2048 ;;
2049 -*)
2050 die "${FUNCNAME}(): Unrecognized option '$1'"
2051 ;;
2052 *)
2053 die "${FUNCNAME}(): Invalid usage"
2054 ;;
2055 esac
2056 shift
2057 done
2058
2059 if [[ "${final_ABI}" == "1" ]]; then
2060 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2061 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2062 fi
2063 else
2064 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2065 die "${FUNCNAME}() should be used in ABI-specific local scope"
2066 fi
2067 fi
2068
2069 echo "$(python_get_libdir "${options[@]}")/site-packages"
2070}
2071
2072# @FUNCTION: python_get_library
2073# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option]
2074# @DESCRIPTION:
2075# Print path to Python library.
2076# If --base-path option is specified, then path not prefixed with "/" is printed.
2077# If --linker-option is specified, then "-l${library}" linker option is printed.
2078# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2079python_get_library() {
2080 _python_check_python_pkg_setup_execution
2081
2082 local base_path="0" final_ABI="0" linker_option="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2083
2084 while (($#)); do
2085 case "$1" in
2086 -b|--base-path)
2087 base_path="1"
2088 ;;
2089 -f|--final-ABI)
2090 final_ABI="1"
2091 ;;
2092 -l|--linker-option)
2093 linker_option="1"
2094 ;;
2095 -*)
2096 die "${FUNCNAME}(): Unrecognized option '$1'"
2097 ;;
2098 *)
2099 die "${FUNCNAME}(): Invalid usage"
2100 ;;
2101 esac
2102 shift
2103 done
2104
2105 if [[ "${base_path}" == "0" ]]; then
2106 prefix="/"
2107 fi
2108
2109 if [[ "${base_path}" == "1" && "${linker_option}" == "1" ]]; then
2110 die "${FUNCNAME}(): '--base-path' and '--linker-option' options cannot be specified simultaneously"
2111 fi
2112
2113 if [[ "${final_ABI}" == "1" ]]; then
2114 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2115 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2116 fi
2117 PYTHON_ABI="$(PYTHON -f --ABI)"
2118 else
2119 if _python_package_supporting_installation_for_multiple_python_abis; then
2120 if ! _python_abi-specific_local_scope; then
2121 die "${FUNCNAME}() should be used in ABI-specific local scope"
2122 fi
2123 else
2124 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2125 fi
2126 fi
2127
2128 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2129 if [[ "${linker_option}" == "1" ]]; then
2130 echo "-lpython${PYTHON_ABI}"
2131 else
2132 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)"
2133 fi
2134 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2135 die "${FUNCNAME}(): Jython does not have shared library"
2136 fi
2137}
2138
2139# @FUNCTION: python_get_version
2140# @USAGE: [-f|--final-ABI] [-l|--language] [--full] [--major] [--minor] [--micro]
2141# @DESCRIPTION:
2142# Print Python version.
2143# --full, --major, --minor and --micro options cannot be specified simultaneously.
2144# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed.
2145# If --language option is specified, then Python language version is printed.
2146# --language and --full options cannot be specified simultaneously.
2147# --language and --micro options cannot be specified simultaneously.
2148# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2149python_get_version() {
2150 _python_check_python_pkg_setup_execution
2151
2152 local final_ABI="0" language="0" language_version full="0" major="0" minor="0" micro="0" PYTHON_ABI="${PYTHON_ABI}" python_command
2153
2154 while (($#)); do
2155 case "$1" in
2156 -f|--final-ABI)
2157 final_ABI="1"
2158 ;;
2159 -l|--language)
2160 language="1"
2161 ;;
2162 --full)
2163 full="1"
2164 ;;
2165 --major)
2166 major="1"
2167 ;;
2168 --minor)
2169 minor="1"
2170 ;;
2171 --micro)
2172 micro="1"
2173 ;;
2174 -*)
2175 die "${FUNCNAME}(): Unrecognized option '$1'"
2176 ;;
2177 *)
2178 die "${FUNCNAME}(): Invalid usage"
2179 ;;
2180 esac
2181 shift
2182 done
2183
2184 if [[ "${final_ABI}" == "1" ]]; then
2185 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2186 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2187 fi
2188 else
2189 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2190 die "${FUNCNAME}() should be used in ABI-specific local scope"
2191 fi
2192 fi
2193
2194 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2195 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2196 fi
2197
2198 if [[ "${language}" == "1" ]]; then
2199 if [[ "${final_ABI}" == "1" ]]; then
2200 PYTHON_ABI="$(PYTHON -f --ABI)"
2201 elif [[ -z "${PYTHON_ABI}" ]]; then
2202 PYTHON_ABI="$(PYTHON --ABI)"
2203 fi
2204 language_version="${PYTHON_ABI%%-*}"
2205 if [[ "${full}" == "1" ]]; then
2206 die "${FUNCNAME}(): '--language' and '--full' options cannot be specified simultaneously"
2207 elif [[ "${major}" == "1" ]]; then
2208 echo "${language_version%.*}"
2209 elif [[ "${minor}" == "1" ]]; then
2210 echo "${language_version#*.}"
2211 elif [[ "${micro}" == "1" ]]; then
2212 die "${FUNCNAME}(): '--language' and '--micro' options cannot be specified simultaneously"
2213 else
2214 echo "${language_version}"
2215 fi
2216 else
2217 if [[ "${full}" == "1" ]]; then
2218 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:3]))"
2219 elif [[ "${major}" == "1" ]]; then
2220 python_command="from sys import version_info; print(version_info[0])"
2221 elif [[ "${minor}" == "1" ]]; then
2222 python_command="from sys import version_info; print(version_info[1])"
2223 elif [[ "${micro}" == "1" ]]; then
2224 python_command="from sys import version_info; print(version_info[2])"
2225 else
2226 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2227 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2228 echo "${PYTHON_ABI}"
2229 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2230 echo "${PYTHON_ABI%-jython}"
2231 fi
2232 return
2233 fi
2234 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2235 fi
2236
2237 if [[ "${final_ABI}" == "1" ]]; then
2238 "$(PYTHON -f)" -c "${python_command}"
2239 else
2240 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}"
2241 fi
2242 fi
2243}
2244
2245# ================================================================================================
2246# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================
2247# ================================================================================================
2248
2249# @ECLASS-VARIABLE: PYTHON_TEST_VERBOSITY
2250# @DESCRIPTION:
2251# User-configurable verbosity of tests of Python modules.
2252# Supported values: 0, 1, 2, 3, 4.
2253PYTHON_TEST_VERBOSITY="${PYTHON_TEST_VERBOSITY:-1}"
2254
2255_python_test_hook() {
2256 if [[ "$#" -ne 1 ]]; then
2257 die "${FUNCNAME}() requires 1 argument"
2258 fi
2259
2260 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${FUNCNAME[3]}_$1_hook")" == "function" ]]; then
2261 "${FUNCNAME[3]}_$1_hook"
2262 fi
2263}
2264
2265# @FUNCTION: python_execute_nosetests
2266# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2267# @DESCRIPTION:
2268# Execute nosetests for all enabled Python ABIs.
2269# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2270# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined.
2271python_execute_nosetests() {
2272 _python_check_python_pkg_setup_execution
2273 _python_set_color_variables
2274
2275 local PYTHONPATH_template separate_build_dirs
2276
2277 while (($#)); do
2278 case "$1" in
2279 -P|--PYTHONPATH)
2280 PYTHONPATH_template="$2"
2281 shift
2282 ;;
2283 -s|--separate-build-dirs)
2284 separate_build_dirs="1"
2285 ;;
2286 --)
2287 shift
2288 break
2289 ;;
2290 -*)
2291 die "${FUNCNAME}(): Unrecognized option '$1'"
2292 ;;
2293 *)
2294 break
2295 ;;
2296 esac
2297 shift
2298 done
2299
2300 python_test_function() {
2301 local evaluated_PYTHONPATH
2302
2303 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2304
2305 _python_test_hook pre
2306
2307 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2308 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2309 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2310 else
2311 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2312 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2313 fi
2314
2315 _python_test_hook post
2316 }
2317 if _python_package_supporting_installation_for_multiple_python_abis; then
2318 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2319 else
2320 if [[ -n "${separate_build_dirs}" ]]; then
2321 die "${FUNCNAME}(): Invalid usage"
2322 fi
2323 python_test_function "$@" || die "Testing failed"
2324 fi
2325
2326 unset -f python_test_function
2327}
2328
2329# @FUNCTION: python_execute_py.test
2330# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2331# @DESCRIPTION:
2332# Execute py.test for all enabled Python ABIs.
2333# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2334# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined.
2335python_execute_py.test() {
2336 _python_check_python_pkg_setup_execution
2337 _python_set_color_variables
2338
2339 local PYTHONPATH_template separate_build_dirs
2340
2341 while (($#)); do
2342 case "$1" in
2343 -P|--PYTHONPATH)
2344 PYTHONPATH_template="$2"
2345 shift
2346 ;;
2347 -s|--separate-build-dirs)
2348 separate_build_dirs="1"
2349 ;;
2350 --)
2351 shift
2352 break
2353 ;;
2354 -*)
2355 die "${FUNCNAME}(): Unrecognized option '$1'"
2356 ;;
2357 *)
2358 break
2359 ;;
2360 esac
2361 shift
2362 done
2363
2364 python_test_function() {
2365 local evaluated_PYTHONPATH
2366
2367 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2368
2369 _python_test_hook pre
2370
2371 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2372 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL}
2373 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?"
2374 else
2375 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL}
2376 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?"
2377 fi
2378
2379 _python_test_hook post
2380 }
2381 if _python_package_supporting_installation_for_multiple_python_abis; then
2382 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2383 else
2384 if [[ -n "${separate_build_dirs}" ]]; then
2385 die "${FUNCNAME}(): Invalid usage"
2386 fi
2387 python_test_function "$@" || die "Testing failed"
2388 fi
2389
2390 unset -f python_test_function
2391}
2392
2393# @FUNCTION: python_execute_trial
2394# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2395# @DESCRIPTION:
2396# Execute trial for all enabled Python ABIs.
2397# In ebuilds of packages supporting installation for multiple Python ABIs, this function
2398# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined.
2399python_execute_trial() {
2400 _python_check_python_pkg_setup_execution
2401 _python_set_color_variables
2402
2403 local PYTHONPATH_template separate_build_dirs
2404
2405 while (($#)); do
2406 case "$1" in
2407 -P|--PYTHONPATH)
2408 PYTHONPATH_template="$2"
2409 shift
2410 ;;
2411 -s|--separate-build-dirs)
2412 separate_build_dirs="1"
2413 ;;
2414 --)
2415 shift
2416 break
2417 ;;
2418 -*)
2419 die "${FUNCNAME}(): Unrecognized option '$1'"
2420 ;;
2421 *)
2422 break
2423 ;;
2424 esac
2425 shift
2426 done
2427
2428 python_test_function() {
2429 local evaluated_PYTHONPATH
2430
2431 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2432
2433 _python_test_hook pre
2434
2435 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2436 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2437 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2438 else
2439 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2440 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2441 fi
2442
2443 _python_test_hook post
2444 }
2445 if _python_package_supporting_installation_for_multiple_python_abis; then
2446 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2447 else
2448 if [[ -n "${separate_build_dirs}" ]]; then
2449 die "${FUNCNAME}(): Invalid usage"
2450 fi
2451 python_test_function "$@" || die "Testing failed"
2452 fi
2453
2454 unset -f python_test_function
2455}
2456
2457# ================================================================================================
2458# ======================= FUNCTIONS FOR HANDLING OF BYTE-COMPILED MODULES ========================
2459# ================================================================================================
2460
2461# @FUNCTION: python_enable_pyc
2462# @DESCRIPTION:
2463# Tell Python to automatically recompile modules to .pyc/.pyo if the
2464# timestamps/version stamps have changed.
2465python_enable_pyc() {
2466 _python_check_python_pkg_setup_execution
2467
2468 if [[ "$#" -ne 0 ]]; then
2469 die "${FUNCNAME}() does not accept arguments"
2470 fi
2471
2472 unset PYTHONDONTWRITEBYTECODE
2473}
2474
2475# @FUNCTION: python_disable_pyc
2476# @DESCRIPTION:
2477# Tell Python not to automatically recompile modules to .pyc/.pyo
2478# even if the timestamps/version stamps do not match. This is done
2479# to protect sandbox.
2480python_disable_pyc() {
2481 _python_check_python_pkg_setup_execution
2482
2483 if [[ "$#" -ne 0 ]]; then
2484 die "${FUNCNAME}() does not accept arguments"
2485 fi
2486
2487 export PYTHONDONTWRITEBYTECODE="1"
2488}
2489
2490_python_clean_compiled_modules() {
2491 _python_initialize_prefix_variables
2492 _python_set_color_variables
2493
2494 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage"
2495
2496 local base_module_name compiled_file compiled_files=() dir path py_file root
2497
2498 # Strip trailing slash from EROOT.
2499 root="${EROOT%/}"
2500
2501 for path in "$@"; do
2502 compiled_files=()
2503 if [[ -d "${path}" ]]; then
2504 while read -d $'\0' -r compiled_file; do
2505 compiled_files+=("${compiled_file}")
2506 done < <(find "${path}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -print0)
2507
2508 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then
2509 # Delete empty child directories.
2510 find "${path}" -type d | sort -r | while read -r dir; do
2511 if rmdir "${dir}" 2> /dev/null; then
2512 echo "${_CYAN}<<< ${dir}${_NORMAL}"
2513 fi
2514 done
2515 fi
2516 elif [[ "${path}" == *.py ]]; then
2517 base_module_name="${path##*/}"
2518 base_module_name="${base_module_name%.py}"
2519 if [[ -d "${path%/*}/__pycache__" ]]; then
2520 while read -d $'\0' -r compiled_file; do
2521 compiled_files+=("${compiled_file}")
2522 done < <(find "${path%/*}/__pycache__" "(" -name "${base_module_name}.*.py[co]" -o -name "${base_module_name}\$py.class" ")" -print0)
2523 fi
2524 compiled_files+=("${path}c" "${path}o" "${path%.py}\$py.class")
2525 fi
2526
2527 for compiled_file in "${compiled_files[@]}"; do
2528 [[ ! -f "${compiled_file}" ]] && continue
2529 dir="${compiled_file%/*}"
2530 dir="${dir##*/}"
2531 if [[ "${compiled_file}" == *.py[co] ]]; then
2532 if [[ "${dir}" == "__pycache__" ]]; then
2533 base_module_name="${compiled_file##*/}"
2534 base_module_name="${base_module_name%.*py[co]}"
2535 base_module_name="${base_module_name%.*}"
2536 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2537 else
2538 py_file="${compiled_file%[co]}"
2539 fi
2540 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2541 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2542 else
2543 [[ -f "${py_file}" ]] && continue
2544 fi
2545 echo "${_BLUE}<<< ${compiled_file%[co]}[co]${_NORMAL}"
2546 rm -f "${compiled_file%[co]}"[co]
2547 elif [[ "${compiled_file}" == *\$py.class ]]; then
2548 if [[ "${dir}" == "__pycache__" ]]; then
2549 base_module_name="${compiled_file##*/}"
2550 base_module_name="${base_module_name%\$py.class}"
2551 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2552 else
2553 py_file="${compiled_file%\$py.class}.py"
2554 fi
2555 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2556 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2557 else
2558 [[ -f "${py_file}" ]] && continue
2559 fi
2560 echo "${_BLUE}<<< ${compiled_file}${_NORMAL}"
2561 rm -f "${compiled_file}"
2562 else
2563 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'"
2564 fi
2565
2566 # Delete empty parent directories.
2567 dir="${compiled_file%/*}"
2568 while [[ "${dir}" != "${root}" ]]; do
2569 if rmdir "${dir}" 2> /dev/null; then
2570 echo "${_CYAN}<<< ${dir}${_NORMAL}"
2571 else
2572 break
2573 fi
2574 dir="${dir%/*}"
2575 done
2576 done
2577 done
2578}
2579
2580# @FUNCTION: python_mod_optimize
2581# @USAGE: [--allow-evaluated-non-sitedir-paths] [-d directory] [-f] [-l] [-q] [-x regular_expression] [--] <file|directory> [files|directories]
2582# @DESCRIPTION:
2583# Byte-compile specified Python modules.
2584# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py.
50# 2585#
51python_disable_pyc() { 2586# This function can be used only in pkg_postinst() phase.
52 export PYTHON_DONTCOMPILE=1 2587python_mod_optimize() {
53} 2588 if [[ "${EBUILD_PHASE}" != "postinst" ]]; then
2589 die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2590 fi
54 2591
55python_enable_pyc() { 2592 _python_check_python_pkg_setup_execution
56 unset PYTHON_DONTCOMPILE 2593 _python_initialize_prefix_variables
57}
58 2594
59python_disable_pyc 2595 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2596 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs.
2597 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() stderr stderr_line
60 2598
2599 if _python_package_supporting_installation_for_multiple_python_abis; then
2600 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
2601 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2602 fi
2603 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
2604 else
2605 if has "${EAPI:-0}" 0 1 2 3; then
2606 iterated_PYTHON_ABIS="${PYTHON_ABI:=$(PYTHON --ABI)}"
2607 else
2608 iterated_PYTHON_ABIS="${PYTHON_ABI}"
2609 fi
2610 fi
2611
2612 # Strip trailing slash from EROOT.
2613 root="${EROOT%/}"
2614
2615 while (($#)); do
2616 case "$1" in
2617 --allow-evaluated-non-sitedir-paths)
2618 allow_evaluated_non_sitedir_paths="1"
2619 ;;
2620 -l|-f|-q)
2621 options+=("$1")
2622 ;;
2623 -d|-x)
2624 options+=("$1" "$2")
2625 shift
2626 ;;
2627 --)
2628 shift
2629 break
2630 ;;
2631 -*)
2632 die "${FUNCNAME}(): Unrecognized option '$1'"
2633 ;;
2634 *)
2635 break
2636 ;;
2637 esac
2638 shift
2639 done
2640
2641 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
2642 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2643 fi
2644
2645 if [[ "$#" -eq 0 ]]; then
2646 die "${FUNCNAME}(): Missing files or directories"
2647 fi
2648
2649 while (($#)); do
2650 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2651 die "${FUNCNAME}(): Invalid argument '$1'"
2652 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
2653 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
2654 elif [[ "$1" =~ ^/ ]]; then
2655 if _python_package_supporting_installation_for_multiple_python_abis; then
2656 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
2657 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
2658 fi
2659 if [[ "$1" != *\$* ]]; then
2660 die "${FUNCNAME}(): '$1' has invalid syntax"
2661 fi
2662 if [[ "$1" == *.py ]]; then
2663 evaluated_files+=("$1")
2664 else
2665 evaluated_dirs+=("$1")
2666 fi
2667 else
2668 if [[ -d "${root}$1" ]]; then
2669 other_dirs+=("${root}$1")
2670 elif [[ -f "${root}$1" ]]; then
2671 other_files+=("${root}$1")
2672 elif [[ -e "${root}$1" ]]; then
2673 eerror "${FUNCNAME}(): '${root}$1' is not a regular file or a directory"
2674 else
2675 eerror "${FUNCNAME}(): '${root}$1' does not exist"
2676 fi
2677 fi
2678 else
2679 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2680 if [[ -d "${root}$(python_get_sitedir)/$1" ]]; then
2681 site_packages_dirs+=("$1")
2682 break
2683 elif [[ -f "${root}$(python_get_sitedir)/$1" ]]; then
2684 site_packages_files+=("$1")
2685 break
2686 elif [[ -e "${root}$(python_get_sitedir)/$1" ]]; then
2687 eerror "${FUNCNAME}(): '$1' is not a regular file or a directory"
2688 else
2689 eerror "${FUNCNAME}(): '$1' does not exist"
2690 fi
2691 done
2692 fi
2693 shift
2694 done
2695
2696 # Set additional options.
2697 options+=("-q")
2698
2699 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2700 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then
2701 return_code="0"
2702 stderr=""
2703 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)"
2704 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then
2705 for dir in "${site_packages_dirs[@]}"; do
2706 dirs+=("${root}$(python_get_sitedir)/${dir}")
2707 done
2708 for dir in "${evaluated_dirs[@]}"; do
2709 eval "dirs+=(\"\${root}${dir}\")"
2710 done
2711 stderr+="${stderr:+$'\n'}$("$(PYTHON)" "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${dirs[@]}" 2>&1)" || return_code="1"
2712 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then
2713 "$(PYTHON)" -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1"
2714 fi
2715 _python_clean_compiled_modules "${dirs[@]}"
2716 fi
2717 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then
2718 for file in "${site_packages_files[@]}"; do
2719 files+=("${root}$(python_get_sitedir)/${file}")
2720 done
2721 for file in "${evaluated_files[@]}"; do
2722 eval "files+=(\"\${root}${file}\")"
2723 done
2724 stderr+="${stderr:+$'\n'}$("$(PYTHON)" "${root}$(python_get_libdir)/py_compile.py" "${files[@]}" 2>&1)" || return_code="1"
2725 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then
2726 "$(PYTHON)" -O "${root}$(python_get_libdir)/py_compile.py" "${files[@]}" &> /dev/null || return_code="1"
2727 fi
2728 _python_clean_compiled_modules "${files[@]}"
2729 fi
2730 eend "${return_code}"
2731 if [[ -n "${stderr}" ]]; then
2732 eerror "Syntax errors / warnings in Python modules for $(python_get_implementation) $(python_get_version):" &> /dev/null
2733 while read stderr_line; do
2734 eerror " ${stderr_line}"
2735 done <<< "${stderr}"
2736 fi
2737 fi
2738 unset dirs files
2739 done
2740
2741 if _python_package_supporting_installation_for_multiple_python_abis; then
2742 # Restore previous value of PYTHON_ABI.
2743 if [[ -n "${previous_PYTHON_ABI}" ]]; then
2744 PYTHON_ABI="${previous_PYTHON_ABI}"
2745 else
2746 unset PYTHON_ABI
2747 fi
2748 fi
2749
2750 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then
2751 return_code="0"
2752 stderr=""
2753 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation) $(python_get_version)"
2754 if ((${#other_dirs[@]})); then
2755 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" 2>&1)" || return_code="1"
2756 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then
2757 "$(PYTHON ${PYTHON_ABI})" -O "${root}$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1"
2758 fi
2759 _python_clean_compiled_modules "${other_dirs[@]}"
2760 fi
2761 if ((${#other_files[@]})); then
2762 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" 2>&1)" || return_code="1"
2763 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" != "Jython" ]]; then
2764 "$(PYTHON ${PYTHON_ABI})" -O "${root}$(python_get_libdir)/py_compile.py" "${other_files[@]}" &> /dev/null || return_code="1"
2765 fi
2766 _python_clean_compiled_modules "${other_files[@]}"
2767 fi
2768 eend "${return_code}"
2769 if [[ -n "${stderr}" ]]; then
2770 eerror "Syntax errors / warnings in Python modules placed outside of site-packages directories for $(python_get_implementation) $(python_get_version):" &> /dev/null
2771 while read stderr_line; do
2772 eerror " ${stderr_line}"
2773 done <<< "${stderr}"
2774 fi
2775 fi
2776 else
2777 # Deprecated part of python_mod_optimize()
2778 ewarn
2779 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
2780 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
2781 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
2782 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
2783 ewarn
2784
2785 local myroot mydirs=() myfiles=() myopts=() return_code="0"
2786
2787 # strip trailing slash
2788 myroot="${EROOT%/}"
2789
2790 # respect EROOT and options passed to compileall.py
2791 while (($#)); do
2792 case "$1" in
2793 -l|-f|-q)
2794 myopts+=("$1")
2795 ;;
2796 -d|-x)
2797 myopts+=("$1" "$2")
2798 shift
2799 ;;
2800 --)
2801 shift
2802 break
2803 ;;
2804 -*)
2805 die "${FUNCNAME}(): Unrecognized option '$1'"
2806 ;;
2807 *)
2808 break
2809 ;;
2810 esac
2811 shift
2812 done
2813
2814 if [[ "$#" -eq 0 ]]; then
2815 die "${FUNCNAME}(): Missing files or directories"
2816 fi
2817
2818 while (($#)); do
2819 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2820 die "${FUNCNAME}(): Invalid argument '$1'"
2821 elif [[ -d "${myroot}/${1#/}" ]]; then
2822 mydirs+=("${myroot}/${1#/}")
2823 elif [[ -f "${myroot}/${1#/}" ]]; then
2824 myfiles+=("${myroot}/${1#/}")
2825 elif [[ -e "${myroot}/${1#/}" ]]; then
2826 eerror "${FUNCNAME}(): ${myroot}/${1#/} is not a regular file or directory"
2827 else
2828 eerror "${FUNCNAME}(): ${myroot}/${1#/} does not exist"
2829 fi
2830 shift
2831 done
2832
2833 # set additional opts
2834 myopts+=(-q)
2835
2836 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2837
2838 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)"
2839 if ((${#mydirs[@]})); then
2840 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" || return_code="1"
2841 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" &> /dev/null || return_code="1"
2842 _python_clean_compiled_modules "${mydirs[@]}"
2843 fi
2844
2845 if ((${#myfiles[@]})); then
2846 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" || return_code="1"
2847 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" &> /dev/null || return_code="1"
2848 _python_clean_compiled_modules "${myfiles[@]}"
2849 fi
2850
2851 eend "${return_code}"
2852 fi
2853}
2854
2855# @FUNCTION: python_mod_cleanup
2856# @USAGE: [--allow-evaluated-non-sitedir-paths] [--] <file|directory> [files|directories]
2857# @DESCRIPTION:
2858# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
61# 2859#
62# name: python_version 2860# This function can be used only in pkg_postrm() phase.
63# desc: run without arguments and it will export the version of python
64# currently in use as $PYVER
65#
66
67__python_version_extract() {
68 verstr=$1
69 export PYVER_MAJOR=${verstr:0:1}
70 export PYVER_MINOR=${verstr:2:1}
71 export PYVER_MICRO=${verstr:4}
72 export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
73}
74
75python_version() {
76 local tmpstr
77 python=${python:-/usr/bin/python}
78 tmpstr="$(${python} -V 2>&1 )"
79 export PYVER_ALL="${tmpstr#Python }"
80 __python_version_extract $PYVER_ALL
81}
82
83#
84# name: python_makesym
85# desc: run without arguments, it will create the /usr/bin/python symlinks
86# to the latest installed version
87#
88python_makesym() {
89 alternatives_auto_makesym "/usr/bin/python" "python[0-9].[0-9]"
90 alternatives_auto_makesym "/usr/bin/python2" "python2.[0-9]"
91}
92
93#
94# name: python_tkinter_exists
95# desc: run without arguments, checks if python was compiled with Tkinter
96# support. If not, prints an error message and dies.
97#
98python_tkinter_exists() {
99 if ! python -c "import Tkinter" >/dev/null 2>&1; then
100 eerror "You need to recompile python with Tkinter support."
101 eerror "That means: USE='tcltk' emerge python"
102 echo
103 die "missing tkinter support with installed python"
104 fi
105}
106
107#
108# name: python_mod_exists
109# desc: run with the module name as an argument. it will check if a
110# python module is installed and loadable. it will return
111# TRUE(0) if the module exists, and FALSE(1) if the module does
112# not exist.
113# exam:
114# if python_mod_exists gtk; then
115# echo "gtk support enabled
116# fi
117#
118python_mod_exists() {
119 [ -z "$1" ] && die "${FUNCTION} requires an argument!"
120 if ! python -c "import $1" >/dev/null 2>&1; then
121 return 1
122 fi
123 return 0
124}
125
126#
127# name: python_mod_compile
128# desc: given a filename, it will pre-compile the module's .pyc and .pyo.
129# should only be run in pkg_postinst()
130# exam:
131# python_mod_compile ${ROOT}usr/lib/python2.3/site-packages/pygoogle.py
132#
133python_mod_compile() {
134 # allow compiling for older python versions
135 if [ -n "${PYTHON_OVERRIDE_PYVER}" ]; then
136 PYVER=${PYTHON_OVERRIDE_PYVER}
137 else
138 python_version
139 fi
140
141 if [ -f "$1" ]; then
142 python${PYVER} -c "import py_compile; py_compile.compile('${1}')" || \
143 ewarn "Failed to compile ${1}"
144 python${PYVER} -O -c "import py_compile; py_compile.compile('${1}')" || \
145 ewarn "Failed to compile ${1}"
146 else
147 ewarn "Unable to find ${1}"
148 fi
149}
150
151#
152# name: python_mod_optimize
153# desc: if no arguments supplied, it will recompile all modules under
154# sys.path (eg. /usr/lib/python2.3, /usr/lib/python2.3/site-packages/ ..)
155# no recursively
156#
157# if supplied with arguments, it will recompile all modules recursively
158# in the supplied directory
159# exam:
160# python_mod_optimize ${ROOT}usr/share/codegen
161#
162python_mod_optimize() {
163 local myroot
164 # strip trailing slash
165 myroot="${ROOT%/}"
166
167 # allow compiling for older python versions
168 if [ -n "${PYTHON_OVERRIDE_PYVER}" ]; then
169 PYVER=${PYTHON_OVERRIDE_PYVER}
170 else
171 python_version
172 fi
173
174 # set opts
175 if [ "${PYVER}" = "2.2" ]; then
176 compileopts=""
177 else
178 compileopts="-q"
179 fi
180
181 ebegin "Byte compiling python modules for python-${PYVER} .."
182 python${PYVER} ${myroot}/usr/lib/python${PYVER}/compileall.py ${compileopts} $@
183 python${PYVER} -O ${myroot}/usr/lib/python${PYVER}/compileall.py ${compileopts} $@
184 eend $?
185}
186
187#
188# name: python_mod_cleanup
189# desc: run with optional arguments, where arguments are directories of
190# python modules. if none given, it will look in /usr/lib/python[0-9].[0-9]
191#
192# it will recursively scan all compiled python modules in the directories
193# and determine if they are orphaned (eg. their corresponding .py is missing.)
194# if they are, then it will remove their corresponding .pyc and .pyo
195#
196python_mod_cleanup() { 2861python_mod_cleanup() {
197 local SEARCH_PATH myroot 2862 if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
2863 die "${FUNCNAME}() can be used only in pkg_postrm() phase"
2864 fi
198 2865
2866 _python_check_python_pkg_setup_execution
2867 _python_initialize_prefix_variables
2868
2869 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
2870
2871 if _python_package_supporting_installation_for_multiple_python_abis; then
2872 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
2873 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2874 fi
2875 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
2876 else
2877 if has "${EAPI:-0}" 0 1 2 3; then
2878 iterated_PYTHON_ABIS="${PYTHON_ABI:-$(PYTHON --ABI)}"
2879 else
2880 iterated_PYTHON_ABIS="${PYTHON_ABI}"
2881 fi
2882 fi
2883
199 # strip trailing slash 2884 # Strip trailing slash from EROOT.
200 myroot="${ROOT%/}" 2885 root="${EROOT%/}"
201 2886
2887 while (($#)); do
2888 case "$1" in
2889 --allow-evaluated-non-sitedir-paths)
2890 allow_evaluated_non_sitedir_paths="1"
2891 ;;
2892 --)
2893 shift
2894 break
2895 ;;
2896 -*)
2897 die "${FUNCNAME}(): Unrecognized option '$1'"
2898 ;;
2899 *)
2900 break
2901 ;;
2902 esac
2903 shift
2904 done
2905
2906 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
2907 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2908 fi
2909
202 if [ $# -gt 0 ]; then 2910 if [[ "$#" -eq 0 ]]; then
203 for path in $@; do 2911 die "${FUNCNAME}(): Missing files or directories"
204 SEARCH_PATH="${SEARCH_PATH} ${myroot}/${path#/}" 2912 fi
2913
2914 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2915 while (($#)); do
2916 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2917 die "${FUNCNAME}(): Invalid argument '$1'"
2918 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
2919 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
2920 elif [[ "$1" =~ ^/ ]]; then
2921 if _python_package_supporting_installation_for_multiple_python_abis; then
2922 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
2923 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
2924 fi
2925 if [[ "$1" != *\$* ]]; then
2926 die "${FUNCNAME}(): '$1' has invalid syntax"
2927 fi
2928 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2929 eval "search_paths+=(\"\${root}$1\")"
2930 done
2931 else
2932 search_paths+=("${root}$1")
2933 fi
2934 else
2935 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2936 search_paths+=("${root}$(python_get_sitedir)/$1")
2937 done
2938 fi
2939 shift
205 done 2940 done
206 else 2941 else
207 for path in ${myroot}/usr/lib*/python*/site-packages; do 2942 # Deprecated part of python_mod_cleanup()
208 SEARCH_PATH="${SEARCH_PATH} ${path}" 2943 ewarn
209 done 2944 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
210 fi 2945 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
2946 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
2947 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
2948 ewarn
211 2949
212 for path in ${SEARCH_PATH}; do 2950 search_paths=("${@#/}")
213 einfo "Cleaning orphaned Python bytecode from ${path} .." 2951 search_paths=("${search_paths[@]/#/${root}/}")
214 for obj in $(find ${path} -name *.pyc); do
215 src_py="${obj%c}"
216 if [ ! -f "${src_py}" ]; then
217 einfo "Purging ${src_py}[co]"
218 rm -f ${src_py}[co]
219 fi 2952 fi
220 done 2953
221 # attempt to remove directories that maybe empty 2954 _python_clean_compiled_modules "${search_paths[@]}"
222 for dir in $(find ${path} -type d | sort -r); do
223 rmdir ${dir} 2>/dev/null
224 done
225 done
226} 2955}
2956
2957# ================================================================================================
2958# ===================================== DEPRECATED FUNCTIONS =====================================
2959# ================================================================================================

Legend:
Removed from v.1.24  
changed lines
  Added in v.1.121

  ViewVC Help
Powered by ViewVC 1.1.20