/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.54 Revision 1.153
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.54 2008/10/30 05:21:46 zmedico Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.153 2012/03/20 20:37:21 floppym Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# python@gentoo.org 7# Gentoo Python Project <python@gentoo.org>
8# 8# @BLURB: Eclass for Python packages
9# original author: Alastair Tse <liquidx@gentoo.org>
10# @BLURB: A Utility Eclass that should be inherited by anything that deals with Python or Python modules.
11# @DESCRIPTION: 9# @DESCRIPTION:
12# Some useful functions for dealing with python. 10# The python eclass contains miscellaneous, useful functions for Python packages.
13inherit alternatives multilib
14 11
15 12# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning.
16if [[ -n "${NEED_PYTHON}" ]] ; then 13if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
17 DEPEND=">=dev-lang/python-${NEED_PYTHON}" 14 inherit multilib
18 RDEPEND="${DEPEND}"
19fi 15fi
20 16
21__python_eclass_test() { 17# Export pkg_setup every time to avoid issues with eclass inheritance order.
22 __python_version_extract 2.3 18if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
23 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR" 19 EXPORT_FUNCTIONS pkg_setup
24 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
25 __python_version_extract 2.3.4
26 echo -n "2.3.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
27 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
28 __python_version_extract 2.3.5
29 echo -n "2.3.5 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
30 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
31 __python_version_extract 2.4
32 echo -n "2.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
33 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
34 __python_version_extract 2.5b3
35 echo -n "2.5b3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
36 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
37}
38
39# @FUNCTION: python_version
40# @DESCRIPTION:
41# Run without arguments and it will export the version of python
42# currently in use as $PYVER; sets PYVER/PYVER_MAJOR/PYVER_MINOR
43__python_version_extract() {
44 local verstr=$1
45 export PYVER_MAJOR=${verstr:0:1}
46 export PYVER_MINOR=${verstr:2:1}
47 if [[ ${verstr:3:1} == . ]]; then
48 export PYVER_MICRO=${verstr:4}
49 fi 20fi
50 export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
51}
52 21
53python_version() { 22# Avoid processing this eclass more than once.
54 [[ -n "${PYVER}" ]] && return 0 23if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
55 local tmpstr 24_PYTHON_ECLASS_INHERITED="1"
56 python=${python:-/usr/bin/python}
57 tmpstr="$(${python} -V 2>&1 )"
58 export PYVER_ALL="${tmpstr#Python }"
59 __python_version_extract $PYVER_ALL
60}
61 25
62# @FUNCTION: python_disable_pyc 26if ! has "${EAPI:-0}" 0 1 2 3 4; then
63# @DESCRIPTION: 27 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
64# Tells python not to automatically recompile modules to .pyc/.pyo
65# even if the timestamps/version stamps don't match. This is done
66# to protect sandbox.
67#
68# note: supported by >=dev-lang/python-2.2.3-r3 only.
69#
70python_disable_pyc() {
71 export PYTHONDONTWRITEBYTECODE=1 # For 2.6 and above
72 export PYTHON_DONTCOMPILE=1 # For 2.5 and below
73}
74
75# @FUNCTION: python_enable_pyc
76# @DESCRIPTION:
77# Tells python to automatically recompile modules to .pyc/.pyo if the
78# timestamps/version stamps change
79python_enable_pyc() {
80 unset PYTHONDONTWRITEBYTECODE
81 unset PYTHON_DONTCOMPILE
82}
83
84python_disable_pyc
85
86# @FUNCTION: python_need_rebuild
87# @DESCRIPTION: Run without arguments, specifies that the package should be
88# rebuilt after a python upgrade.
89python_need_rebuild() {
90 python_version
91 export PYTHON_NEED_REBUILD=${PYVER}
92}
93
94# @FUNCTION: python_get_libdir
95# @DESCRIPTION:
96# Run without arguments, returns the python library dir
97python_get_libdir() {
98 python_version
99 echo "/usr/$(get_libdir)/python${PYVER}"
100}
101
102# @FUNCTION: python_get_sitedir
103# @DESCRIPTION:
104# Run without arguments, returns the python site-packages dir
105python_get_sitedir() {
106 echo "$(python_get_libdir)/site-packages"
107}
108
109# @FUNCTION: python_makesym
110# @DESCRIPTION:
111# Run without arguments, it will create the /usr/bin/python symlinks
112# to the latest installed version
113python_makesym() {
114 alternatives_auto_makesym "/usr/bin/python" "python[0-9].[0-9]"
115 alternatives_auto_makesym "/usr/bin/python2" "python2.[0-9]"
116}
117
118# @FUNCTION: python_tkinter_exists
119# @DESCRIPTION:
120# Run without arguments, checks if python was compiled with Tkinter
121# support. If not, prints an error message and dies.
122python_tkinter_exists() {
123 if ! python -c "import Tkinter" >/dev/null 2>&1; then
124 eerror "You need to recompile python with Tkinter support."
125 eerror "Try adding: 'dev-lang/python tk'"
126 eerror "in to /etc/portage/package.use"
127 echo
128 die "missing tkinter support with installed python"
129 fi 28fi
130}
131 29
132# @FUNCTION: python_mod_exists 30_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
133# @USAGE: < module > 31_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2)
134# @DESCRIPTION: 32_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
135# Run with the module name as an argument. it will check if a 33_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8)
136# python module is installed and loadable. it will return 34_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]})
137# TRUE(0) if the module exists, and FALSE(1) if the module does
138# not exist.
139#
140# Example:
141# if python_mod_exists gtk; then
142# echo "gtk support enabled"
143# fi
144python_mod_exists() {
145 [[ "$1" ]] || die "${FUNCNAME} requires an argument!"
146 python -c "import $1" >/dev/null 2>&1
147}
148 35
149# @FUNCTION: python_mod_compile 36# ================================================================================================
150# @USAGE: < file > [more files ...] 37# ===================================== HANDLING OF METADATA =====================================
151# @DESCRIPTION: 38# ================================================================================================
152# Given filenames, it will pre-compile the module's .pyc and .pyo.
153# This function should only be run in pkg_postinst()
154#
155# Example:
156# python_mod_compile /usr/lib/python2.3/site-packages/pygoogle.py
157#
158python_mod_compile() {
159 local f myroot myfiles=()
160 39
161 # Check if phase is pkg_postinst() 40_PYTHON_ABI_PATTERN_REGEX="([[:alnum:]]|\.|-|\*|\[|\])+"
162 [[ ${EBUILD_PHASE} != postinst ]] &&\
163 die "${FUNCNAME} should only be run in pkg_postinst()"
164 41
165 # allow compiling for older python versions 42_python_check_python_abi_matching() {
166 if [[ "${PYTHON_OVERRIDE_PYVER}" ]]; then 43 local pattern patterns patterns_list="0" PYTHON_ABI
167 PYVER=${PYTHON_OVERRIDE_PYVER}
168 else
169 python_version
170 fi
171 44
172 # strip trailing slash
173 myroot="${ROOT%/}"
174
175 # respect ROOT
176 for f in "$@"; do
177 [[ -f "${myroot}/${f}" ]] && myfiles+=("${myroot}/${f}")
178 done
179
180 if ((${#myfiles[@]})); then
181 python${PYVER} ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}"
182 python${PYVER} -O ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}"
183 else
184 ewarn "No files to compile!"
185 fi
186}
187
188# @FUNCTION: python_mod_optimize
189# @USAGE: [ path ]
190# @DESCRIPTION:
191# If no arguments supplied, it will recompile all modules under
192# sys.path (eg. /usr/lib/python2.3, /usr/lib/python2.3/site-packages/ ..)
193# no recursively
194#
195# If supplied with arguments, it will recompile all modules recursively
196# in the supplied directory
197# This function should only be run in pkg_postinst()
198#
199# Options passed to this function are passed to compileall.py
200#
201# Example:
202# python_mod_optimize /usr/share/codegen
203python_mod_optimize() {
204 local myroot mydirs=() myfiles=() myopts=()
205
206 # Check if phase is pkg_postinst()
207 [[ ${EBUILD_PHASE} != postinst ]] &&\
208 die "${FUNCNAME} should only be run in pkg_postinst()"
209
210 # strip trailing slash
211 myroot="${ROOT%/}"
212
213 # respect ROOT and options passed to compileall.py
214 while (($#)); do 45 while (($#)); do
215 case $1 in 46 case "$1" in
216 -l|-f|-q) 47 --patterns-list)
217 myopts+=("$1") 48 patterns_list="1"
218 ;; 49 ;;
219 -d|-x) 50 --)
220 myopts+=("$1" "$2")
221 shift 51 shift
52 break
222 ;; 53 ;;
223 -*) 54 -*)
224 ewarn "${FUNCNAME}: Ignoring compile option $1" 55 die "${FUNCNAME}(): Unrecognized option '$1'"
225 ;; 56 ;;
226 *) 57 *)
227 if [[ -d "${myroot}"/$1 ]]; then 58 break
228 mydirs+=("${myroot}/$1")
229 elif [[ -f "${myroot}"/$1 ]]; then
230 # Files are passed to python_mod_compile which is ROOT-aware
231 myfiles+=("$1")
232 elif [[ -e "${myroot}/$1" ]]; then
233 ewarn "${myroot}/$1 is not a file or directory!"
234 else
235 ewarn "${myroot}/$1 doesn't exist!"
236 fi
237 ;; 59 ;;
238 esac 60 esac
239 shift 61 shift
240 done 62 done
241 63
242 # allow compiling for older python versions 64 if [[ "$#" -ne 2 ]]; then
243 if [ -n "${PYTHON_OVERRIDE_PYVER}" ]; then 65 die "${FUNCNAME}() requires 2 arguments"
244 PYVER=${PYTHON_OVERRIDE_PYVER} 66 fi
67
68 PYTHON_ABI="$1"
69
70 if [[ "${patterns_list}" == "0" ]]; then
71 pattern="$2"
72
73 if [[ "${pattern}" == *"-cpython" ]]; then
74 [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "${PYTHON_ABI}" == ${pattern%-cpython} ]]
75 elif [[ "${pattern}" == *"-jython" ]]; then
76 [[ "${PYTHON_ABI}" == ${pattern} ]]
77 elif [[ "${pattern}" == *"-pypy-"* ]]; then
78 [[ "${PYTHON_ABI}" == ${pattern} ]]
245 else 79 else
246 python_version 80 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
81 [[ "${PYTHON_ABI}" == ${pattern} ]]
82 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
83 [[ "${PYTHON_ABI%-jython}" == ${pattern} ]]
84 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
85 [[ "${PYTHON_ABI%-pypy-*}" == ${pattern} ]]
86 else
87 die "${FUNCNAME}(): Unrecognized Python ABI '${PYTHON_ABI}'"
88 fi
247 fi 89 fi
90 else
91 patterns="${2// /$'\n'}"
248 92
93 while read pattern; do
94 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
95 return 0
96 fi
97 done <<< "${patterns}"
98
99 return 1
100 fi
101}
102
103_python_implementation() {
104 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
105 return 0
106 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
107 return 0
108 elif [[ "${CATEGORY}/${PN}" == "dev-python/pypy" ]]; then
109 return 0
110 else
111 return 1
112 fi
113}
114
115_python_package_supporting_installation_for_multiple_python_abis() {
116 if has "${EAPI:-0}" 0 1 2 3 4; then
117 if [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
118 return 0
119 else
120 return 1
121 fi
122 else
123 die "${FUNCNAME}(): Support for EAPI=\"${EAPI}\" not implemented"
124 fi
125}
126
127# @ECLASS-VARIABLE: PYTHON_DEPEND
128# @DESCRIPTION:
129# Specification of dependency on dev-lang/python.
130# Syntax:
131# PYTHON_DEPEND: [[!]USE_flag? ]<version_components_group>[ version_components_group]
132# version_components_group: <major_version[:[minimal_version][:maximal_version]]>
133# major_version: <2|3|*>
134# minimal_version: <minimal_major_version.minimal_minor_version>
135# maximal_version: <maximal_major_version.maximal_minor_version>
136
137_python_parse_PYTHON_DEPEND() {
138 local major_version maximal_version minimal_version python_all="0" python_maximal_version python_minimal_version python_versions=() python2="0" python2_maximal_version python2_minimal_version python3="0" python3_maximal_version python3_minimal_version USE_flag= version_components_group version_components_group_regex version_components_groups
139
140 version_components_group_regex="(2|3|\*)(:([[:digit:]]+\.[[:digit:]]+)?(:([[:digit:]]+\.[[:digit:]]+)?)?)?"
141 version_components_groups="${PYTHON_DEPEND}"
142
143 if [[ "${version_components_groups}" =~ ^((\!)?[[:alnum:]_-]+\?\ )?${version_components_group_regex}(\ ${version_components_group_regex})?$ ]]; then
144 if [[ "${version_components_groups}" =~ ^(\!)?[[:alnum:]_-]+\? ]]; then
145 USE_flag="${version_components_groups%\? *}"
146 version_components_groups="${version_components_groups#* }"
147 fi
148 if [[ "${version_components_groups}" =~ ("*".*" "|" *"|^2.*\ (2|\*)|^3.*\ (3|\*)) ]]; then
149 die "Invalid syntax of PYTHON_DEPEND: Incorrectly specified groups of versions"
150 fi
151
152 version_components_groups="${version_components_groups// /$'\n'}"
153 while read version_components_group; do
154 major_version="${version_components_group:0:1}"
155 minimal_version="${version_components_group:2}"
156 minimal_version="${minimal_version%:*}"
157 maximal_version="${version_components_group:$((3 + ${#minimal_version}))}"
158
159 if [[ "${major_version}" =~ ^(2|3)$ ]]; then
160 if [[ -n "${minimal_version}" && "${major_version}" != "${minimal_version:0:1}" ]]; then
161 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' not in specified group of versions"
162 fi
163 if [[ -n "${maximal_version}" && "${major_version}" != "${maximal_version:0:1}" ]]; then
164 die "Invalid syntax of PYTHON_DEPEND: Maximal version '${maximal_version}' not in specified group of versions"
165 fi
166 fi
167
168 if [[ "${major_version}" == "2" ]]; then
169 python2="1"
170 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
171 python2_minimal_version="${minimal_version}"
172 python2_maximal_version="${maximal_version}"
173 elif [[ "${major_version}" == "3" ]]; then
174 python3="1"
175 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
176 python3_minimal_version="${minimal_version}"
177 python3_maximal_version="${maximal_version}"
178 else
179 python_all="1"
180 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
181 python_minimal_version="${minimal_version}"
182 python_maximal_version="${maximal_version}"
183 fi
184
185 if [[ -n "${minimal_version}" ]] && ! has "${minimal_version}" "${python_versions[@]}"; then
186 die "Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '${minimal_version}'"
187 fi
188 if [[ -n "${maximal_version}" ]] && ! has "${maximal_version}" "${python_versions[@]}"; then
189 die "Invalid syntax of PYTHON_DEPEND: Unrecognized maximal version '${maximal_version}'"
190 fi
191
192 if [[ -n "${minimal_version}" && -n "${maximal_version}" && "${minimal_version}" > "${maximal_version}" ]]; then
193 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' greater than maximal version '${maximal_version}'"
194 fi
195 done <<< "${version_components_groups}"
196
197 _PYTHON_ATOMS=()
198
199 _append_accepted_versions_range() {
200 local accepted_version="0" i
201 for ((i = "${#python_versions[@]}"; i >= 0; i--)); do
202 if [[ "${python_versions[${i}]}" == "${python_maximal_version}" ]]; then
203 accepted_version="1"
204 fi
205 if [[ "${accepted_version}" == "1" ]]; then
206 _PYTHON_ATOMS+=("=dev-lang/python-${python_versions[${i}]}*")
207 fi
208 if [[ "${python_versions[${i}]}" == "${python_minimal_version}" ]]; then
209 accepted_version="0"
210 fi
211 done
212 }
213
214 if [[ "${python_all}" == "1" ]]; then
215 if [[ -z "${python_minimal_version}" && -z "${python_maximal_version}" ]]; then
216 _PYTHON_ATOMS+=("dev-lang/python")
217 else
218 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
219 python_minimal_version="${python_minimal_version:-${python_versions[0]}}"
220 python_maximal_version="${python_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
221 _append_accepted_versions_range
222 fi
223 else
224 if [[ "${python3}" == "1" ]]; then
225 if [[ -z "${python3_minimal_version}" && -z "${python3_maximal_version}" ]]; then
226 _PYTHON_ATOMS+=("=dev-lang/python-3*")
227 else
228 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
229 python_minimal_version="${python3_minimal_version:-${python_versions[0]}}"
230 python_maximal_version="${python3_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
231 _append_accepted_versions_range
232 fi
233 fi
234 if [[ "${python2}" == "1" ]]; then
235 if [[ -z "${python2_minimal_version}" && -z "${python2_maximal_version}" ]]; then
236 _PYTHON_ATOMS+=("=dev-lang/python-2*")
237 else
238 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
239 python_minimal_version="${python2_minimal_version:-${python_versions[0]}}"
240 python_maximal_version="${python2_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
241 _append_accepted_versions_range
242 fi
243 fi
244 fi
245
246 unset -f _append_accepted_versions_range
247
248 if [[ "${#_PYTHON_ATOMS[@]}" -gt 1 ]]; then
249 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
250 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
251 else
252 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
253 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
254 fi
255 else
256 die "Invalid syntax of PYTHON_DEPEND"
257 fi
258}
259
260if _python_implementation; then
261 DEPEND=">=app-admin/eselect-python-20091230"
262 RDEPEND="${DEPEND}"
263 PDEPEND="app-admin/python-updater"
264fi
265
266if [[ -n "${PYTHON_DEPEND}" ]]; then
267 _python_parse_PYTHON_DEPEND
268else
269 _PYTHON_ATOMS=("dev-lang/python")
270fi
271unset -f _python_parse_PYTHON_DEPEND
272
273if [[ -n "${NEED_PYTHON}" ]]; then
274 eerror "Use PYTHON_DEPEND variable instead of NEED_PYTHON variable."
275 die "NEED_PYTHON variable is banned"
276fi
277
278# @ECLASS-VARIABLE: PYTHON_USE_WITH
279# @DESCRIPTION:
280# Set this to a space separated list of USE flags the Python slot in use must be built with.
281
282# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR
283# @DESCRIPTION:
284# Set this to a space separated list of USE flags of which one must be turned on for the slot in use.
285
286# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT
287# @DESCRIPTION:
288# Set this to a name of a USE flag if you need to make either PYTHON_USE_WITH or
289# PYTHON_USE_WITH_OR atoms conditional under a USE flag.
290
291if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
292 _PYTHON_USE_WITH_ATOMS_ARRAY=()
293 if [[ -n "${PYTHON_USE_WITH}" ]]; then
294 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
295 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${PYTHON_USE_WITH// /,}]")
296 done
297 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then
298 for _USE_flag in ${PYTHON_USE_WITH_OR}; do
299 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
300 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${_USE_flag}]")
301 done
302 done
303 unset _USE_flag
304 fi
305 if [[ "${#_PYTHON_USE_WITH_ATOMS_ARRAY[@]}" -gt 1 ]]; then
306 _PYTHON_USE_WITH_ATOMS="|| ( ${_PYTHON_USE_WITH_ATOMS_ARRAY[@]} )"
307 else
308 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}"
309 fi
310 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
311 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )"
312 fi
313 DEPEND+="${DEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
314 RDEPEND+="${RDEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
315 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY
316fi
317
318unset _PYTHON_ATOMS
319
320# ================================================================================================
321# =================================== MISCELLANEOUS FUNCTIONS ====================================
322# ================================================================================================
323
324_python_abi-specific_local_scope() {
325 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]]
326}
327
328_python_initialize_prefix_variables() {
329 if has "${EAPI:-0}" 0 1 2; then
330 if [[ -n "${ROOT}" && -z "${EROOT}" ]]; then
331 EROOT="${ROOT%/}${EPREFIX}/"
332 fi
333 if [[ -n "${D}" && -z "${ED}" ]]; then
334 ED="${D%/}${EPREFIX}/"
335 fi
336 fi
337}
338
339unset PYTHON_SANITY_CHECKS_EXECUTED PYTHON_SKIP_SANITY_CHECKS
340
341_python_initial_sanity_checks() {
342 if [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
343 # Ensure that /usr/bin/python and /usr/bin/python-config are valid.
344 if [[ "$(readlink "${EPREFIX}/usr/bin/python")" != "python-wrapper" ]]; then
345 eerror "'${EPREFIX}/usr/bin/python' is not valid symlink."
346 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
347 die "'${EPREFIX}/usr/bin/python' is not valid symlink"
348 fi
349 if [[ "$(<"${EPREFIX}/usr/bin/python-config")" != *"Gentoo python-config wrapper script"* ]]; then
350 eerror "'${EPREFIX}/usr/bin/python-config' is not valid script"
351 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
352 die "'${EPREFIX}/usr/bin/python-config' is not valid script"
353 fi
354 fi
355}
356
357_python_final_sanity_checks() {
358 if ! _python_implementation && [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
359 local PYTHON_ABI="${PYTHON_ABI}"
360 for PYTHON_ABI in ${PYTHON_ABIS-${PYTHON_ABI}}; do
361 # Ensure that appropriate version of Python is installed.
362 if ! has_version "$(python_get_implementational_package)"; then
363 die "$(python_get_implementational_package) is not installed"
364 fi
365
366 # Ensure that EPYTHON variable is respected.
367 if [[ "$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")" != "${PYTHON_ABI}" ]]; then
368 eerror "Path to 'python': '$(type -p python)'"
369 eerror "ABI: '${ABI}'"
370 eerror "DEFAULT_ABI: '${DEFAULT_ABI}'"
371 eerror "EPYTHON: '$(PYTHON)'"
372 eerror "PYTHON_ABI: '${PYTHON_ABI}'"
373 eerror "Locally active version of Python: '$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")'"
374 die "'python' does not respect EPYTHON variable"
375 fi
376 done
377 fi
378 PYTHON_SANITY_CHECKS_EXECUTED="1"
379}
380
381# @ECLASS-VARIABLE: PYTHON_COLORS
382# @DESCRIPTION:
383# User-configurable colored output.
384PYTHON_COLORS="${PYTHON_COLORS:-0}"
385
386_python_set_color_variables() {
387 if [[ "${PYTHON_COLORS}" != "0" && "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then
388 _BOLD=$'\e[1m'
389 _RED=$'\e[1;31m'
390 _GREEN=$'\e[1;32m'
391 _BLUE=$'\e[1;34m'
392 _CYAN=$'\e[1;36m'
393 _NORMAL=$'\e[0m'
394 else
395 _BOLD=
396 _RED=
397 _GREEN=
398 _BLUE=
399 _CYAN=
400 _NORMAL=
401 fi
402}
403
404_python_check_python_pkg_setup_execution() {
405 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
406
407 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
408 die "python_pkg_setup() not called"
409 fi
410}
411
412# @FUNCTION: python_pkg_setup
413# @DESCRIPTION:
414# Perform sanity checks and initialize environment.
415#
416# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable
417# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4.
418python_pkg_setup() {
419 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
420 die "${FUNCNAME}() can be used only in pkg_setup() phase"
421 fi
422
423 if [[ "$#" -ne 0 ]]; then
424 die "${FUNCNAME}() does not accept arguments"
425 fi
426
427 export JYTHON_SYSTEM_CACHEDIR="1"
428 addwrite "${EPREFIX}/var/cache/jython"
429
430 if _python_package_supporting_installation_for_multiple_python_abis; then
431 _python_calculate_PYTHON_ABIS
432 export EPYTHON="$(PYTHON -f)"
433 else
434 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
435 fi
436
437 if ! has "${EAPI:-0}" 0 1 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; then
438 if [[ "${PYTHON_USE_WITH_OPT}" ]]; then
439 if [[ "${PYTHON_USE_WITH_OPT}" == !* ]]; then
440 use ${PYTHON_USE_WITH_OPT#!} && return
441 else
442 use !${PYTHON_USE_WITH_OPT} && return
443 fi
444 fi
445
446 python_pkg_setup_check_USE_flags() {
447 local python_atom USE_flag
448 python_atom="$(python_get_implementational_package)"
449
450 for USE_flag in ${PYTHON_USE_WITH}; do
451 if ! has_version "${python_atom}[${USE_flag}]"; then
452 eerror "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
453 die "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
454 fi
455 done
456
457 for USE_flag in ${PYTHON_USE_WITH_OR}; do
458 if has_version "${python_atom}[${USE_flag}]"; then
459 return
460 fi
461 done
462
463 if [[ ${PYTHON_USE_WITH_OR} ]]; then
464 eerror "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
465 die "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
466 fi
467 }
468
469 if _python_package_supporting_installation_for_multiple_python_abis; then
470 PYTHON_SKIP_SANITY_CHECKS="1" python_execute_function -q python_pkg_setup_check_USE_flags
471 else
472 python_pkg_setup_check_USE_flags
473 fi
474
475 unset -f python_pkg_setup_check_USE_flags
476 fi
477
478 PYTHON_PKG_SETUP_EXECUTED="1"
479}
480
481_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|pypy-c|python)'
482
483# @FUNCTION: python_convert_shebangs
484# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories]
485# @DESCRIPTION:
486# Convert shebangs in specified files. Directories can be specified only with --recursive option.
487python_convert_shebangs() {
488 _python_check_python_pkg_setup_execution
489
490 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0" shebangs_converted="0"
491
492 while (($#)); do
493 case "$1" in
494 -r|--recursive)
495 recursive="1"
496 ;;
497 -q|--quiet)
498 quiet="1"
499 ;;
500 -x|--only-executables)
501 only_executables="1"
502 ;;
503 --)
504 shift
505 break
506 ;;
507 -*)
508 die "${FUNCNAME}(): Unrecognized option '$1'"
509 ;;
510 *)
511 break
512 ;;
513 esac
514 shift
515 done
516
517 if [[ "$#" -eq 0 ]]; then
518 die "${FUNCNAME}(): Missing Python version and files or directories"
519 elif [[ "$#" -eq 1 ]]; then
520 die "${FUNCNAME}(): Missing files or directories"
521 fi
522
523 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
524 python_interpreter="$(PYTHON "$1")"
525 else
526 python_interpreter="python$1"
527 fi
528 shift
529
530 for argument in "$@"; do
531 if [[ ! -e "${argument}" ]]; then
532 die "${FUNCNAME}(): '${argument}' does not exist"
533 elif [[ -f "${argument}" ]]; then
534 files+=("${argument}")
535 elif [[ -d "${argument}" ]]; then
536 if [[ "${recursive}" == "1" ]]; then
537 while read -d $'\0' -r file; do
538 files+=("${file}")
539 done < <(find "${argument}" $([[ "${only_executables}" == "1" ]] && echo -perm /111) -type f -print0)
540 else
541 die "${FUNCNAME}(): '${argument}' is not a regular file"
542 fi
543 else
544 die "${FUNCNAME}(): '${argument}' is not a regular file or a directory"
545 fi
546 done
547
548 for file in "${files[@]}"; do
549 file="${file#./}"
550 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
551
552 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then
553 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue
554
555 shebangs_converted="1"
556
557 if [[ "${quiet}" == "0" ]]; then
558 einfo "Converting shebang in '${file}'"
559 fi
560
561 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|pypy-c\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed"
562 fi
563 done
564
565 if [[ "${shebangs_converted}" == "0" ]]; then
566 ewarn "${FUNCNAME}(): Python scripts not found"
567 fi
568}
569
570# @FUNCTION: python_clean_py-compile_files
571# @USAGE: [-q|--quiet]
572# @DESCRIPTION:
573# Clean py-compile files to disable byte-compilation.
574python_clean_py-compile_files() {
575 _python_check_python_pkg_setup_execution
576
577 local file files=() quiet="0"
578
579 while (($#)); do
580 case "$1" in
581 -q|--quiet)
582 quiet="1"
583 ;;
584 -*)
585 die "${FUNCNAME}(): Unrecognized option '$1'"
586 ;;
587 *)
588 die "${FUNCNAME}(): Invalid usage"
589 ;;
590 esac
591 shift
592 done
593
594 while read -d $'\0' -r file; do
595 files+=("${file#./}")
596 done < <(find -name py-compile -type f -print0)
597
598 for file in "${files[@]}"; do
599 if [[ "${quiet}" == "0" ]]; then
600 einfo "Cleaning '${file}' file"
601 fi
602 echo "#!/bin/sh" > "${file}"
603 done
604}
605
606# @FUNCTION: python_clean_installation_image
607# @USAGE: [-q|--quiet]
608# @DESCRIPTION:
609# Delete needless files in installation image.
610#
611# This function can be used only in src_install() phase.
612python_clean_installation_image() {
613 if [[ "${EBUILD_PHASE}" != "install" ]]; then
614 die "${FUNCNAME}() can be used only in src_install() phase"
615 fi
616
617 _python_check_python_pkg_setup_execution
618 _python_initialize_prefix_variables
619
620 local file files=() quiet="0"
621
622 while (($#)); do
623 case "$1" in
624 -q|--quiet)
625 quiet="1"
626 ;;
627 -*)
628 die "${FUNCNAME}(): Unrecognized option '$1'"
629 ;;
630 *)
631 die "${FUNCNAME}(): Invalid usage"
632 ;;
633 esac
634 shift
635 done
636
637 while read -d $'\0' -r file; do
638 files+=("${file}")
639 done < <(find "${ED}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -type f -print0)
640
641 if [[ "${#files[@]}" -gt 0 ]]; then
642 if [[ "${quiet}" == "0" ]]; then
643 ewarn "Deleting byte-compiled Python modules needlessly generated by build system:"
644 fi
645 for file in "${files[@]}"; do
646 if [[ "${quiet}" == "0" ]]; then
647 ewarn " ${file}"
648 fi
649 rm -f "${file}"
650
651 # Delete empty __pycache__ directories.
652 if [[ "${file%/*}" == *"/__pycache__" ]]; then
653 rmdir "${file%/*}" 2> /dev/null
654 fi
655 done
656 fi
657
658 python_clean_sitedirs() {
659 if [[ -d "${ED}$(python_get_sitedir)" ]]; then
660 find "${ED}$(python_get_sitedir)" "(" -name "*.c" -o -name "*.h" -o -name "*.la" ")" -type f -print0 | xargs -0 rm -f
661 fi
662 }
663 if _python_package_supporting_installation_for_multiple_python_abis; then
664 python_execute_function -q python_clean_sitedirs
665 else
666 python_clean_sitedirs
667 fi
668
669 unset -f python_clean_sitedirs
670}
671
672# ================================================================================================
673# =========== FUNCTIONS FOR PACKAGES SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ============
674# ================================================================================================
675
676# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS
677# @DESCRIPTION:
678# Set this in EAPI <= 4 to indicate that current package supports installation for
679# multiple Python ABIs.
680
681# @ECLASS-VARIABLE: PYTHON_TESTS_RESTRICTED_ABIS
682# @DESCRIPTION:
683# Space-separated list of Python ABI patterns. Testing in Python ABIs matching any Python ABI
684# patterns specified in this list is skipped.
685
686# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS
687# @DESCRIPTION:
688# Set this to export phase functions for the following ebuild phases:
689# src_prepare(), src_configure(), src_compile(), src_test(), src_install().
690if ! has "${EAPI:-0}" 0 1; then
691 python_src_prepare() {
692 if [[ "${EBUILD_PHASE}" != "prepare" ]]; then
693 die "${FUNCNAME}() can be used only in src_prepare() phase"
694 fi
695
696 if ! _python_package_supporting_installation_for_multiple_python_abis; then
697 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
698 fi
699
700 _python_check_python_pkg_setup_execution
701
702 if [[ "$#" -ne 0 ]]; then
703 die "${FUNCNAME}() does not accept arguments"
704 fi
705
706 python_copy_sources
707 }
708
709 for python_default_function in src_configure src_compile src_test; do
710 eval "python_${python_default_function}() {
711 if [[ \"\${EBUILD_PHASE}\" != \"${python_default_function#src_}\" ]]; then
712 die \"\${FUNCNAME}() can be used only in ${python_default_function}() phase\"
713 fi
714
715 if ! _python_package_supporting_installation_for_multiple_python_abis; then
716 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\"
717 fi
718
719 _python_check_python_pkg_setup_execution
720
721 python_execute_function -d -s -- \"\$@\"
722 }"
723 done
724 unset python_default_function
725
726 python_src_install() {
727 if [[ "${EBUILD_PHASE}" != "install" ]]; then
728 die "${FUNCNAME}() can be used only in src_install() phase"
729 fi
730
731 if ! _python_package_supporting_installation_for_multiple_python_abis; then
732 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
733 fi
734
735 _python_check_python_pkg_setup_execution
736
737 if has "${EAPI:-0}" 0 1 2 3; then
738 python_execute_function -d -s -- "$@"
739 else
740 python_installation() {
741 emake DESTDIR="${T}/images/${PYTHON_ABI}" install "$@"
742 }
743 python_execute_function -s python_installation "$@"
744 unset python_installation
745
746 python_merge_intermediate_installation_images "${T}/images"
747 fi
748 }
749
750 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
751 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
752 fi
753fi
754
755if has "${EAPI:-0}" 0 1 2 3 4; then
756 unset PYTHON_ABIS
757fi
758
759_python_calculate_PYTHON_ABIS() {
760 if ! _python_package_supporting_installation_for_multiple_python_abis; then
761 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
762 fi
763
764 _python_initial_sanity_checks
765
766 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3 4; then
767 local PYTHON_ABI
768
769 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
770 local cpython_enabled="0"
771
772 if [[ -z "${USE_PYTHON}" ]]; then
773 die "USE_PYTHON variable is empty"
774 fi
775
776 for PYTHON_ABI in ${USE_PYTHON}; do
777 if ! has "${PYTHON_ABI}" "${_PYTHON_GLOBALLY_SUPPORTED_ABIS[@]}"; then
778 die "USE_PYTHON variable contains invalid value '${PYTHON_ABI}'"
779 fi
780
781 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then
782 cpython_enabled="1"
783 fi
784
785 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
786 export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
787 fi
788 done
789
790 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
791 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
792 fi
793
794 if [[ "${cpython_enabled}" == "0" ]]; then
795 die "USE_PYTHON variable does not enable any CPython ABI"
796 fi
797 else
798 local python_version python2_version python3_version support_python_major_version
799
800 if ! has_version "dev-lang/python"; then
801 die "${FUNCNAME}(): 'dev-lang/python' is not installed"
802 fi
803
804 python_version="$("${EPREFIX}/usr/bin/python" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
805
806 if has_version "=dev-lang/python-2*"; then
807 if [[ "$(readlink "${EPREFIX}/usr/bin/python2")" != "python2."* ]]; then
808 die "'${EPREFIX}/usr/bin/python2' is not valid symlink"
809 fi
810
811 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
812
813 support_python_major_version="0"
814 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
815 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
816 support_python_major_version="1"
817 break
818 fi
819 done
820 if [[ "${support_python_major_version}" == "1" ]]; then
821 if _python_check_python_abi_matching --patterns-list "${python2_version}" "${RESTRICT_PYTHON_ABIS}"; then
822 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}"
823 fi
824 else
825 python2_version=""
826 fi
827 fi
828
829 if has_version "=dev-lang/python-3*"; then
830 if [[ "$(readlink "${EPREFIX}/usr/bin/python3")" != "python3."* ]]; then
831 die "'${EPREFIX}/usr/bin/python3' is not valid symlink"
832 fi
833
834 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
835
836 support_python_major_version="0"
837 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
838 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
839 support_python_major_version="1"
840 break
841 fi
842 done
843 if [[ "${support_python_major_version}" == "1" ]]; then
844 if _python_check_python_abi_matching --patterns-list "${python3_version}" "${RESTRICT_PYTHON_ABIS}"; then
845 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
846 fi
847 else
848 python3_version=""
849 fi
850 fi
851
852 if [[ -z "${python2_version}" && -z "${python3_version}" ]]; then
853 eerror "${CATEGORY}/${PF} requires at least one of the following packages:"
854 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
855 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
856 eerror " dev-lang/python:${PYTHON_ABI}"
857 fi
858 done
859 die "No supported version of CPython installed"
860 fi
861
862 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
863 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
864 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
865 die "Incorrect configuration of Python"
866 fi
867 if [[ -n "${python3_version}" && "${python_version}" == "3."* && "${python_version}" != "${python3_version}" ]]; then
868 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python3' symlink"
869 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
870 die "Incorrect configuration of Python"
871 fi
872
873 PYTHON_ABIS="${python2_version} ${python3_version}"
874 PYTHON_ABIS="${PYTHON_ABIS# }"
875 export PYTHON_ABIS="${PYTHON_ABIS% }"
876 fi
877 fi
878
879 _python_final_sanity_checks
880}
881
882_python_prepare_flags() {
883 local array=() deleted_flag element flags new_value old_flag old_value operator pattern prefix variable
884
885 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
886 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\""
887 for prefix in PYTHON_USER_ PYTHON_; do
888 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then
889 eval "array=(\"\${${prefix}${variable}[@]}\")"
890 for element in "${array[@]}"; do
891 if [[ "${element}" =~ ^${_PYTHON_ABI_PATTERN_REGEX}\ (\+|-)\ .+ ]]; then
892 pattern="${element%% *}"
893 element="${element#* }"
894 operator="${element%% *}"
895 flags="${element#* }"
896 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
897 if [[ "${operator}" == "+" ]]; then
898 eval "export ${variable}+=\"\${variable:+ }${flags}\""
899 elif [[ "${operator}" == "-" ]]; then
900 flags="${flags// /$'\n'}"
901 old_value="${!variable// /$'\n'}"
902 new_value=""
903 while read old_flag; do
904 while read deleted_flag; do
905 if [[ "${old_flag}" == ${deleted_flag} ]]; then
906 continue 2
907 fi
908 done <<< "${flags}"
909 new_value+="${new_value:+ }${old_flag}"
910 done <<< "${old_value}"
911 eval "export ${variable}=\"\${new_value}\""
912 fi
913 fi
914 else
915 die "Element '${element}' of ${prefix}${variable} array has invalid syntax"
916 fi
917 done
918 elif [[ -n "$(declare -p ${prefix}${variable} 2> /dev/null)" ]]; then
919 die "${prefix}${variable} should be indexed array"
920 fi
921 done
922 done
923}
924
925_python_restore_flags() {
926 local variable
927
928 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
929 eval "${variable}=\"\${_PYTHON_SAVED_${variable}}\""
930 unset _PYTHON_SAVED_${variable}
931 done
932}
933
934# @FUNCTION: python_execute_function
935# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments]
936# @DESCRIPTION:
937# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
938# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
939python_execute_function() {
940 if ! _python_package_supporting_installation_for_multiple_python_abis; then
941 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
942 fi
943
944 _python_check_python_pkg_setup_execution
945 _python_set_color_variables
946
947 local action action_message action_message_template default_function="0" failure_message failure_message_template final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir
948
949 while (($#)); do
950 case "$1" in
951 --action-message)
952 action_message_template="$2"
953 shift
954 ;;
955 -d|--default-function)
956 default_function="1"
957 ;;
958 --failure-message)
959 failure_message_template="$2"
960 shift
961 ;;
962 -f|--final-ABI)
963 final_ABI="1"
964 ;;
965 --nonfatal)
966 nonfatal="1"
967 ;;
968 -q|--quiet)
969 quiet="1"
970 ;;
971 -s|--separate-build-dirs)
972 separate_build_dirs="1"
973 ;;
974 --source-dir)
975 source_dir="$2"
976 shift
977 ;;
978 --)
979 shift
980 break
981 ;;
982 -*)
983 die "${FUNCNAME}(): Unrecognized option '$1'"
984 ;;
985 *)
986 break
987 ;;
988 esac
989 shift
990 done
991
992 if [[ -n "${source_dir}" && "${separate_build_dirs}" == 0 ]]; then
993 die "${FUNCNAME}(): '--source-dir' option can be specified only with '--separate-build-dirs' option"
994 fi
995
996 if [[ "${default_function}" == "0" ]]; then
997 if [[ "$#" -eq 0 ]]; then
998 die "${FUNCNAME}(): Missing function name"
999 fi
1000 function="$1"
1001 shift
1002
1003 if [[ -z "$(type -t "${function}")" ]]; then
1004 die "${FUNCNAME}(): '${function}' function is not defined"
1005 fi
1006 else
1007 if has "${EAPI:-0}" 0 1; then
1008 die "${FUNCNAME}(): '--default-function' option cannot be used in this EAPI"
1009 fi
1010
1011 if [[ "${EBUILD_PHASE}" == "configure" ]]; then
1012 if has "${EAPI}" 2 3; then
1013 python_default_function() {
1014 econf "$@"
1015 }
1016 else
1017 python_default_function() {
1018 nonfatal econf "$@"
1019 }
1020 fi
1021 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then
1022 python_default_function() {
1023 emake "$@"
1024 }
1025 elif [[ "${EBUILD_PHASE}" == "test" ]]; then
1026 python_default_function() {
1027 # Stolen from portage's _eapi0_src_test()
1028 local emake_cmd="${MAKE:-make} ${MAKEOPTS} ${EXTRA_EMAKE}"
1029 if ${emake_cmd} -j1 -n check &> /dev/null; then
1030 ${emake_cmd} -j1 check "$@"
1031 elif ${emake_cmd} -j1 -n test &> /dev/null; then
1032 ${emake_cmd} -j1 test "$@"
1033 fi
1034 }
1035 elif [[ "${EBUILD_PHASE}" == "install" ]]; then
1036 python_default_function() {
1037 emake DESTDIR="${D}" install "$@"
1038 }
1039 else
1040 die "${FUNCNAME}(): '--default-function' option cannot be used in this ebuild phase"
1041 fi
1042 function="python_default_function"
1043 fi
1044
1045 # Ensure that python_execute_function() cannot be directly or indirectly called by python_execute_function().
1046 if _python_abi-specific_local_scope; then
1047 die "${FUNCNAME}(): Invalid call stack"
1048 fi
1049
1050 if [[ "${quiet}" == "0" ]]; then
1051 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up"
1052 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking"
1053 [[ "${EBUILD_PHASE}" == "prepare" ]] && action="Preparation"
1054 [[ "${EBUILD_PHASE}" == "configure" ]] && action="Configuration"
1055 [[ "${EBUILD_PHASE}" == "compile" ]] && action="Building"
1056 [[ "${EBUILD_PHASE}" == "test" ]] && action="Testing"
1057 [[ "${EBUILD_PHASE}" == "install" ]] && action="Installation"
1058 [[ "${EBUILD_PHASE}" == "preinst" ]] && action="Preinstallation"
1059 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation"
1060 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation"
1061 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation"
1062 fi
1063
1064 _python_calculate_PYTHON_ABIS
1065 if [[ "${final_ABI}" == "1" ]]; then
1066 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)"
1067 else
1068 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
1069 fi
1070 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1071 if [[ "${EBUILD_PHASE}" == "test" ]] && _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${PYTHON_TESTS_RESTRICTED_ABIS}"; then
1072 if [[ "${quiet}" == "0" ]]; then
1073 echo " ${_GREEN}*${_NORMAL} ${_BLUE}Testing of ${CATEGORY}/${PF} with $(python_get_implementation_and_version) skipped${_NORMAL}"
1074 fi
1075 continue
1076 fi
1077
1078 _python_prepare_flags
1079
1080 if [[ "${quiet}" == "0" ]]; then
1081 if [[ -n "${action_message_template}" ]]; then
1082 eval "action_message=\"${action_message_template}\""
1083 else
1084 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation_and_version)..."
1085 fi
1086 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}"
1087 fi
1088
1089 if [[ "${separate_build_dirs}" == "1" ]]; then
1090 if [[ -n "${source_dir}" ]]; then
1091 export BUILDDIR="${S}/${source_dir}-${PYTHON_ABI}"
1092 else
1093 export BUILDDIR="${S}-${PYTHON_ABI}"
1094 fi
1095 pushd "${BUILDDIR}" > /dev/null || die "pushd failed"
1096 else
1097 export BUILDDIR="${S}"
1098 fi
1099
1100 previous_directory="$(pwd)"
1101 previous_directory_stack="$(dirs -p)"
1102 previous_directory_stack_length="$(dirs -p | wc -l)"
1103
1104 if ! has "${EAPI}" 0 1 2 3 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1105 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@"
1106 else
1107 EPYTHON="$(PYTHON)" "${function}" "$@"
1108 fi
1109
1110 return_code="$?"
1111
1112 _python_restore_flags
1113
1114 if [[ "${return_code}" -ne 0 ]]; then
1115 if [[ -n "${failure_message_template}" ]]; then
1116 eval "failure_message=\"${failure_message_template}\""
1117 else
1118 failure_message="${action} failed with $(python_get_implementation_and_version) in ${function}() function"
1119 fi
1120
1121 if [[ "${nonfatal}" == "1" ]]; then
1122 if [[ "${quiet}" == "0" ]]; then
1123 ewarn "${failure_message}"
1124 fi
1125 elif [[ "${final_ABI}" == "0" ]] && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1126 if [[ "${EBUILD_PHASE}" != "test" ]] || ! has test-fail-continue ${FEATURES}; then
1127 local enabled_PYTHON_ABIS= other_PYTHON_ABI
1128 for other_PYTHON_ABI in ${PYTHON_ABIS}; do
1129 [[ "${other_PYTHON_ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+="${enabled_PYTHON_ABIS:+ }${other_PYTHON_ABI}"
1130 done
1131 export PYTHON_ABIS="${enabled_PYTHON_ABIS}"
1132 fi
1133 if [[ "${quiet}" == "0" ]]; then
1134 ewarn "${failure_message}"
1135 fi
1136 if [[ -z "${PYTHON_ABIS}" ]]; then
1137 die "${function}() function failed with all enabled Python ABIs"
1138 fi
1139 else
1140 die "${failure_message}"
1141 fi
1142 fi
1143
1144 # Ensure that directory stack has not been decreased.
1145 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then
1146 die "Directory stack decreased illegally"
1147 fi
1148
1149 # Avoid side effects of earlier returning from the specified function.
1150 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do
1151 popd > /dev/null || die "popd failed"
1152 done
1153
1154 # Ensure that the bottom part of directory stack has not been changed. Restore
1155 # previous directory (from before running of the specified function) before
1156 # comparison of directory stacks to avoid mismatch of directory stacks after
1157 # potential using of 'cd' to change current directory. Restoration of previous
1158 # directory allows to safely use 'cd' to change current directory in the
1159 # specified function without changing it back to original directory.
1160 cd "${previous_directory}"
1161 if [[ "$(dirs -p)" != "${previous_directory_stack}" ]]; then
1162 die "Directory stack changed illegally"
1163 fi
1164
1165 if [[ "${separate_build_dirs}" == "1" ]]; then
1166 popd > /dev/null || die "popd failed"
1167 fi
1168 unset BUILDDIR
1169 done
1170
1171 if [[ "${default_function}" == "1" ]]; then
1172 unset -f python_default_function
1173 fi
1174}
1175
1176# @FUNCTION: python_copy_sources
1177# @USAGE: <directory="${S}"> [directory]
1178# @DESCRIPTION:
1179# Copy unpacked sources of current package to separate build directory for each Python ABI.
1180python_copy_sources() {
1181 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1182 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1183 fi
1184
1185 _python_check_python_pkg_setup_execution
1186
1187 local dir dirs=() PYTHON_ABI
1188
1189 if [[ "$#" -eq 0 ]]; then
1190 if [[ "${WORKDIR}" == "${S}" ]]; then
1191 die "${FUNCNAME}() cannot be used with current value of S variable"
1192 fi
1193 dirs=("${S%/}")
1194 else
1195 dirs=("$@")
1196 fi
1197
1198 _python_calculate_PYTHON_ABIS
1199 for PYTHON_ABI in ${PYTHON_ABIS}; do
1200 for dir in "${dirs[@]}"; do
1201 cp -pr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
1202 done
1203 done
1204}
1205
1206# @FUNCTION: python_generate_wrapper_scripts
1207# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files]
1208# @DESCRIPTION:
1209# Generate wrapper scripts. Existing files are overwritten only with --force option.
1210# If --respect-EPYTHON option is specified, then generated wrapper scripts will
1211# respect EPYTHON variable at run time.
1212#
1213# This function can be used only in src_install() phase.
1214python_generate_wrapper_scripts() {
1215 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1216 die "${FUNCNAME}() can be used only in src_install() phase"
1217 fi
1218
1219 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1220 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1221 fi
1222
1223 _python_check_python_pkg_setup_execution
1224 _python_initialize_prefix_variables
1225
1226 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0"
1227
1228 while (($#)); do
1229 case "$1" in
1230 -E|--respect-EPYTHON)
1231 respect_EPYTHON="1"
1232 ;;
1233 -f|--force)
1234 force="1"
1235 ;;
1236 -q|--quiet)
1237 quiet="1"
1238 ;;
1239 --)
1240 shift
1241 break
1242 ;;
1243 -*)
1244 die "${FUNCNAME}(): Unrecognized option '$1'"
1245 ;;
1246 *)
1247 break
1248 ;;
1249 esac
1250 shift
1251 done
1252
1253 if [[ "$#" -eq 0 ]]; then
1254 die "${FUNCNAME}(): Missing arguments"
1255 fi
1256
1257 _python_calculate_PYTHON_ABIS
1258 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1259 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1260 python2_enabled="1"
1261 fi
1262 done
1263 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1264 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1265 python3_enabled="1"
1266 fi
1267 done
1268
1269 if [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "1" ]]; then
1270 eselect_python_option=
1271 elif [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "0" ]]; then
1272 eselect_python_option="--python2"
1273 elif [[ "${python2_enabled}" == "0" && "${python3_enabled}" == "1" ]]; then
1274 eselect_python_option="--python3"
1275 else
1276 die "${FUNCNAME}(): Unsupported environment"
1277 fi
1278
1279 PYTHON_ABIS_list="$("$(PYTHON -f)" -c "print(', '.join('\"%s\"' % x for x in reversed('${PYTHON_ABIS}'.split())))")"
1280
1281 for file in "$@"; do
1282 if [[ -f "${file}" && "${force}" == "0" ]]; then
1283 die "${FUNCNAME}(): '${file}' already exists"
1284 fi
1285
1286 if [[ "${quiet}" == "0" ]]; then
1287 einfo "Generating '${file#${ED%/}}' wrapper script"
1288 fi
1289
1290 cat << EOF > "${file}"
1291#!/usr/bin/env python
1292# Gentoo '${file##*/}' wrapper script generated by python_generate_wrapper_scripts()
1293
1294import os
1295import re
1296import subprocess
1297import sys
1298
1299cpython_ABI_re = re.compile(r"^(\d+\.\d+)$")
1300jython_ABI_re = re.compile(r"^(\d+\.\d+)-jython$")
1301pypy_ABI_re = re.compile(r"^\d+\.\d+-pypy-(\d+\.\d+)$")
1302cpython_interpreter_re = re.compile(r"^python(\d+\.\d+)$")
1303jython_interpreter_re = re.compile(r"^jython(\d+\.\d+)$")
1304pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$")
1305cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)")
1306python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)")
1307python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1308
1309pypy_versions_mapping = {
1310 "1.5": "2.7"
1311}
1312
1313def get_PYTHON_ABI(python_interpreter):
1314 cpython_matched = cpython_interpreter_re.match(python_interpreter)
1315 jython_matched = jython_interpreter_re.match(python_interpreter)
1316 pypy_matched = pypy_interpreter_re.match(python_interpreter)
1317 if cpython_matched is not None:
1318 PYTHON_ABI = cpython_matched.group(1)
1319 elif jython_matched is not None:
1320 PYTHON_ABI = jython_matched.group(1) + "-jython"
1321 elif pypy_matched is not None:
1322 PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1)
1323 else:
1324 PYTHON_ABI = None
1325 return PYTHON_ABI
1326
1327def get_python_interpreter(PYTHON_ABI):
1328 cpython_matched = cpython_ABI_re.match(PYTHON_ABI)
1329 jython_matched = jython_ABI_re.match(PYTHON_ABI)
1330 pypy_matched = pypy_ABI_re.match(PYTHON_ABI)
1331 if cpython_matched is not None:
1332 python_interpreter = "python" + cpython_matched.group(1)
1333 elif jython_matched is not None:
1334 python_interpreter = "jython" + jython_matched.group(1)
1335 elif pypy_matched is not None:
1336 python_interpreter = "pypy-c" + pypy_matched.group(1)
1337 else:
1338 python_interpreter = None
1339 return python_interpreter
1340
1341EOF
1342 if [[ "$?" != "0" ]]; then
1343 die "${FUNCNAME}(): Generation of '$1' failed"
1344 fi
1345 if [[ "${respect_EPYTHON}" == "1" ]]; then
1346 cat << EOF >> "${file}"
1347python_interpreter = os.environ.get("EPYTHON")
1348if python_interpreter:
1349 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1350 if PYTHON_ABI is None:
1351 sys.stderr.write("%s: EPYTHON variable has unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1352 sys.exit(1)
1353else:
1354 try:
1355 environment = os.environ.copy()
1356 environment["ROOT"] = "/"
1357 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1358 if eselect_process.wait() != 0:
1359 raise ValueError
1360 except (OSError, ValueError):
1361 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1362 sys.exit(1)
1363
1364 python_interpreter = eselect_process.stdout.read()
1365 if not isinstance(python_interpreter, str):
1366 # Python 3
1367 python_interpreter = python_interpreter.decode()
1368 python_interpreter = python_interpreter.rstrip("\n")
1369
1370 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1371 if PYTHON_ABI is None:
1372 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1373 sys.exit(1)
1374
1375wrapper_script_path = os.path.realpath(sys.argv[0])
1376target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1377if not os.path.exists(target_executable_path):
1378 sys.stderr.write("%s: '%s' does not exist\n" % (sys.argv[0], target_executable_path))
1379 sys.exit(1)
1380EOF
1381 if [[ "$?" != "0" ]]; then
1382 die "${FUNCNAME}(): Generation of '$1' failed"
1383 fi
1384 else
1385 cat << EOF >> "${file}"
1386try:
1387 environment = os.environ.copy()
1388 environment["ROOT"] = "/"
1389 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1390 if eselect_process.wait() != 0:
1391 raise ValueError
1392except (OSError, ValueError):
1393 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1394 sys.exit(1)
1395
1396python_interpreter = eselect_process.stdout.read()
1397if not isinstance(python_interpreter, str):
1398 # Python 3
1399 python_interpreter = python_interpreter.decode()
1400python_interpreter = python_interpreter.rstrip("\n")
1401
1402PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1403if PYTHON_ABI is None:
1404 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1405 sys.exit(1)
1406
1407wrapper_script_path = os.path.realpath(sys.argv[0])
1408for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]:
1409 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1410 if os.path.exists(target_executable_path):
1411 break
1412else:
1413 sys.stderr.write("%s: No target script exists for '%s'\n" % (sys.argv[0], wrapper_script_path))
1414 sys.exit(1)
1415
1416python_interpreter = get_python_interpreter(PYTHON_ABI)
1417if python_interpreter is None:
1418 sys.stderr.write("%s: Unrecognized Python ABI '%s'\n" % (sys.argv[0], PYTHON_ABI))
1419 sys.exit(1)
1420EOF
1421 if [[ "$?" != "0" ]]; then
1422 die "${FUNCNAME}(): Generation of '$1' failed"
1423 fi
1424 fi
1425 cat << EOF >> "${file}"
1426
1427target_executable = open(target_executable_path, "rb")
1428target_executable_first_line = target_executable.readline()
1429target_executable.close()
1430if not isinstance(target_executable_first_line, str):
1431 # Python 3
1432 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace")
1433
1434options = []
1435python_shebang_options_matched = python_shebang_options_re.match(target_executable_first_line)
1436if python_shebang_options_matched is not None:
1437 options = [python_shebang_options_matched.group(1)]
1438
1439cpython_shebang_matched = cpython_shebang_re.match(target_executable_first_line)
1440
1441if cpython_shebang_matched is not None:
1442 try:
1443 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % python_interpreter
1444 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1"
1445 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE)
1446 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"]
1447 if python_verification_process.wait() != 0:
1448 raise ValueError
1449
1450 python_verification_output = python_verification_process.stdout.read()
1451 if not isinstance(python_verification_output, str):
1452 # Python 3
1453 python_verification_output = python_verification_output.decode()
1454
1455 if not python_verification_output_re.match(python_verification_output):
1456 raise ValueError
1457
1458 if cpython_interpreter_re.match(python_interpreter) is not None:
1459 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0])
1460 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0]
1461 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path
1462
1463 if hasattr(os, "execv"):
1464 os.execv(python_interpreter_path, [python_interpreter_path] + options + sys.argv)
1465 else:
1466 sys.exit(subprocess.Popen([python_interpreter_path] + options + sys.argv).wait())
1467 except (KeyboardInterrupt, SystemExit):
1468 raise
1469 except:
1470 pass
1471 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"):
1472 if variable in os.environ:
1473 del os.environ[variable]
1474
1475if hasattr(os, "execv"):
1476 os.execv(target_executable_path, sys.argv)
1477else:
1478 sys.exit(subprocess.Popen([target_executable_path] + sys.argv[1:]).wait())
1479EOF
1480 if [[ "$?" != "0" ]]; then
1481 die "${FUNCNAME}(): Generation of '$1' failed"
1482 fi
1483 fperms +x "${file#${ED%/}}" || die "fperms '${file}' failed"
1484 done
1485}
1486
1487# @ECLASS-VARIABLE: PYTHON_VERSIONED_SCRIPTS
1488# @DESCRIPTION:
1489# Array of regular expressions of paths to versioned Python scripts.
1490# Python scripts in /usr/bin and /usr/sbin are versioned by default.
1491
1492# @ECLASS-VARIABLE: PYTHON_VERSIONED_EXECUTABLES
1493# @DESCRIPTION:
1494# Array of regular expressions of paths to versioned executables (including Python scripts).
1495
1496# @ECLASS-VARIABLE: PYTHON_NONVERSIONED_EXECUTABLES
1497# @DESCRIPTION:
1498# Array of regular expressions of paths to nonversioned executables (including Python scripts).
1499
1500# @FUNCTION: python_merge_intermediate_installation_images
1501# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory>
1502# @DESCRIPTION:
1503# Merge intermediate installation images into installation image.
1504#
1505# This function can be used only in src_install() phase.
1506python_merge_intermediate_installation_images() {
1507 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1508 die "${FUNCNAME}() can be used only in src_install() phase"
1509 fi
1510
1511 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1512 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1513 fi
1514
1515 _python_check_python_pkg_setup_execution
1516 _python_initialize_prefix_variables
1517
1518 local absolute_file b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=()
1519
1520 while (($#)); do
1521 case "$1" in
1522 -q|--quiet)
1523 quiet="1"
1524 ;;
1525 --)
1526 shift
1527 break
1528 ;;
1529 -*)
1530 die "${FUNCNAME}(): Unrecognized option '$1'"
1531 ;;
1532 *)
1533 break
1534 ;;
1535 esac
1536 shift
1537 done
1538
1539 if [[ "$#" -ne 1 ]]; then
1540 die "${FUNCNAME}() requires 1 argument"
1541 fi
1542
1543 intermediate_installation_images_directory="$1"
1544
1545 if [[ ! -d "${intermediate_installation_images_directory}" ]]; then
1546 die "${FUNCNAME}(): Intermediate installation images directory '${intermediate_installation_images_directory}' does not exist"
1547 fi
1548
1549 _python_calculate_PYTHON_ABIS
1550 if [[ "$(PYTHON -f --ABI)" == 3.* ]]; then
1551 b="b"
1552 fi
1553
1554 while read -d $'\0' -r file; do
1555 files+=("${file}")
1556 done < <("$(PYTHON -f)" -c \
1557"import os
1558import sys
1559
1560if hasattr(sys.stdout, 'buffer'):
1561 # Python 3
1562 stdout = sys.stdout.buffer
1563else:
1564 # Python 2
1565 stdout = sys.stdout
1566
1567files_set = set()
1568
1569os.chdir(${b}'${intermediate_installation_images_directory}')
1570
1571for PYTHON_ABI in ${b}'${PYTHON_ABIS}'.split():
1572 for root, dirs, files in os.walk(PYTHON_ABI + ${b}'${EPREFIX}'):
1573 root = root[len(PYTHON_ABI + ${b}'${EPREFIX}')+1:]
1574 files_set.update(root + ${b}'/' + file for file in files)
1575
1576for file in sorted(files_set):
1577 stdout.write(file)
1578 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of files in intermediate installation images")
1579
1580 for PYTHON_ABI in ${PYTHON_ABIS}; do
1581 if [[ ! -d "${intermediate_installation_images_directory}/${PYTHON_ABI}" ]]; then
1582 die "${FUNCNAME}(): Intermediate installation image for Python ABI '${PYTHON_ABI}' does not exist"
1583 fi
1584
1585 pushd "${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}" > /dev/null || die "pushd failed"
1586
1587 for file in "${files[@]}"; do
1588 version_executable="0"
1589 for regex in "/usr/bin/.*" "/usr/sbin/.*" "${PYTHON_VERSIONED_SCRIPTS[@]}"; do
1590 if [[ "/${file}" =~ ^${regex}$ ]]; then
1591 version_executable="1"
1592 break
1593 fi
1594 done
1595 for regex in "${PYTHON_VERSIONED_EXECUTABLES[@]}"; do
1596 if [[ "/${file}" =~ ^${regex}$ ]]; then
1597 version_executable="2"
1598 break
1599 fi
1600 done
1601 if [[ "${version_executable}" != "0" ]]; then
1602 for regex in "${PYTHON_NONVERSIONED_EXECUTABLES[@]}"; do
1603 if [[ "/${file}" =~ ^${regex}$ ]]; then
1604 version_executable="0"
1605 break
1606 fi
1607 done
1608 fi
1609
1610 [[ "${version_executable}" == "0" ]] && continue
1611
1612 if [[ -L "${file}" ]]; then
1613 absolute_file="$(readlink "${file}")"
1614 if [[ "${absolute_file}" == /* ]]; then
1615 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file##/}"
1616 else
1617 if [[ "${file}" == */* ]]; then
1618 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file%/*}/${absolute_file}"
1619 else
1620 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file}"
1621 fi
1622 fi
1623 else
1624 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file}"
1625 fi
1626
1627 [[ ! -x "${absolute_file}" ]] && continue
1628
1629 shebang="$(head -n1 "${absolute_file}")" || die "Extraction of shebang from '${absolute_file}' failed"
1630
1631 if [[ "${version_executable}" == "2" ]]; then
1632 wrapper_scripts+=("${ED}${file}")
1633 elif [[ "${version_executable}" == "1" ]]; then
1634 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then
1635 wrapper_scripts+=("${ED}${file}")
1636 else
1637 version_executable="0"
1638 fi
1639 fi
1640
1641 [[ "${version_executable}" == "0" ]] && continue
1642
1643 if [[ -e "${file}-${PYTHON_ABI}" ]]; then
1644 die "${FUNCNAME}(): '${EPREFIX}/${file}-${PYTHON_ABI}' already exists"
1645 fi
1646
1647 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed"
1648
1649 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then
1650 if [[ -L "${file}-${PYTHON_ABI}" ]]; then
1651 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${absolute_file}"
1652 else
1653 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}"
1654 fi
1655 fi
1656 done
1657
1658 popd > /dev/null || die "popd failed"
1659
1660 # This is per bug #390691, without the duplication refactor, and with
1661 # the 3-way structure per comment #6. This enable users with old
1662 # coreutils to upgrade a lot easier (you need to upgrade python+portage
1663 # before coreutils can be upgraded).
1664 if ROOT="/" has_version '>=sys-apps/coreutils-6.9.90'; then
1665 cp -fr --preserve=all --no-preserve=context "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1666 elif ROOT="/" has_version sys-apps/coreutils; then
1667 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1668 else
1669 cp -fpr "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1670 fi
1671 done
1672
1673 rm -fr "${intermediate_installation_images_directory}"
1674
1675 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then
1676 rm -f "${T}/python_wrapper_scripts"
1677
1678 for file in "${wrapper_scripts[@]}"; do
1679 echo -n "${file}" >> "${T}/python_wrapper_scripts"
1680 echo -en "\x00" >> "${T}/python_wrapper_scripts"
1681 done
1682
1683 while read -d $'\0' -r file; do
1684 wrapper_scripts_set+=("${file}")
1685 done < <("$(PYTHON -f)" -c \
1686"import sys
1687
1688if hasattr(sys.stdout, 'buffer'):
1689 # Python 3
1690 stdout = sys.stdout.buffer
1691else:
1692 # Python 2
1693 stdout = sys.stdout
1694
1695python_wrapper_scripts_file = open('${T}/python_wrapper_scripts', 'rb')
1696files = set(python_wrapper_scripts_file.read().rstrip(${b}'\x00').split(${b}'\x00'))
1697python_wrapper_scripts_file.close()
1698
1699for file in sorted(files):
1700 stdout.write(file)
1701 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts")
1702
1703 python_generate_wrapper_scripts $([[ "${quiet}" == "1" ]] && echo --quiet) "${wrapper_scripts_set[@]}"
1704 fi
1705}
1706
1707# ================================================================================================
1708# ========= FUNCTIONS FOR PACKAGES NOT SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ==========
1709# ================================================================================================
1710
1711unset EPYTHON PYTHON_ABI
1712
1713# @FUNCTION: python_set_active_version
1714# @USAGE: <Python_ABI|2|3>
1715# @DESCRIPTION:
1716# Set locally active version of Python.
1717# If Python_ABI argument is specified, then version of Python corresponding to Python_ABI is used.
1718# If 2 argument is specified, then active version of CPython 2 is used.
1719# If 3 argument is specified, then active version of CPython 3 is used.
1720#
1721# This function can be used only in pkg_setup() phase.
1722python_set_active_version() {
1723 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
1724 die "${FUNCNAME}() can be used only in pkg_setup() phase"
1725 fi
1726
1727 if _python_package_supporting_installation_for_multiple_python_abis; then
1728 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1729 fi
1730
1731 if [[ "$#" -ne 1 ]]; then
1732 die "${FUNCNAME}() requires 1 argument"
1733 fi
1734
1735 _python_initial_sanity_checks
1736
1737 if [[ -z "${PYTHON_ABI}" ]]; then
1738 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
1739 # PYTHON_ABI variable is intended to be used only in ebuilds/eclasses,
1740 # so it does not need to be exported to subprocesses.
1741 PYTHON_ABI="$1"
1742 if ! _python_implementation && ! has_version "$(python_get_implementational_package)"; then
1743 die "${FUNCNAME}(): '$(python_get_implementational_package)' is not installed"
1744 fi
1745 export EPYTHON="$(PYTHON "$1")"
1746 elif [[ "$1" == "2" ]]; then
1747 if ! _python_implementation && ! has_version "=dev-lang/python-2*"; then
1748 die "${FUNCNAME}(): '=dev-lang/python-2*' is not installed"
1749 fi
1750 export EPYTHON="$(PYTHON -2)"
1751 PYTHON_ABI="${EPYTHON#python}"
1752 PYTHON_ABI="${PYTHON_ABI%%-*}"
1753 elif [[ "$1" == "3" ]]; then
1754 if ! _python_implementation && ! has_version "=dev-lang/python-3*"; then
1755 die "${FUNCNAME}(): '=dev-lang/python-3*' is not installed"
1756 fi
1757 export EPYTHON="$(PYTHON -3)"
1758 PYTHON_ABI="${EPYTHON#python}"
1759 PYTHON_ABI="${PYTHON_ABI%%-*}"
1760 else
1761 die "${FUNCNAME}(): Unrecognized argument '$1'"
1762 fi
1763 fi
1764
1765 _python_final_sanity_checks
1766
1767 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable.
1768 PYTHON_REQUESTED_ACTIVE_VERSION="$1"
1769}
1770
1771# @FUNCTION: python_need_rebuild
1772# @DESCRIPTION:
1773# Mark current package for rebuilding by python-updater after
1774# switching of active version of Python.
1775python_need_rebuild() {
1776 if _python_package_supporting_installation_for_multiple_python_abis; then
1777 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1778 fi
1779
1780 _python_check_python_pkg_setup_execution
1781
1782 if [[ "$#" -ne 0 ]]; then
1783 die "${FUNCNAME}() does not accept arguments"
1784 fi
1785
1786 export PYTHON_NEED_REBUILD="$(PYTHON --ABI)"
1787}
1788
1789# ================================================================================================
1790# ======================================= GETTER FUNCTIONS =======================================
1791# ================================================================================================
1792
1793_PYTHON_ABI_EXTRACTION_COMMAND=\
1794'import platform
1795import sys
1796sys.stdout.write(".".join(str(x) for x in sys.version_info[:2]))
1797if platform.system()[:4] == "Java":
1798 sys.stdout.write("-jython")
1799elif hasattr(platform, "python_implementation") and platform.python_implementation() == "PyPy":
1800 sys.stdout.write("-pypy-" + ".".join(str(x) for x in sys.pypy_version_info[:2]))'
1801
1802_python_get_implementation() {
1803 local ignore_invalid="0"
1804
1805 while (($#)); do
1806 case "$1" in
1807 --ignore-invalid)
1808 ignore_invalid="1"
1809 ;;
1810 --)
1811 shift
1812 break
1813 ;;
1814 -*)
1815 die "${FUNCNAME}(): Unrecognized option '$1'"
1816 ;;
1817 *)
1818 break
1819 ;;
1820 esac
1821 shift
1822 done
1823
1824 if [[ "$#" -ne 1 ]]; then
1825 die "${FUNCNAME}() requires 1 argument"
1826 fi
1827
1828 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
1829 echo "CPython"
1830 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
1831 echo "Jython"
1832 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
1833 echo "PyPy"
1834 else
1835 if [[ "${ignore_invalid}" == "0" ]]; then
1836 die "${FUNCNAME}(): Unrecognized Python ABI '$1'"
1837 fi
1838 fi
1839}
1840
1841# @FUNCTION: PYTHON
1842# @USAGE: [-2] [-3] [--ABI] [-a|--absolute-path] [-f|--final-ABI] [--] <Python_ABI="${PYTHON_ABI}">
1843# @DESCRIPTION:
1844# Print filename of Python interpreter for specified Python ABI. If Python_ABI argument
1845# is ommitted, then PYTHON_ABI environment variable must be set and is used.
1846# If -2 option is specified, then active version of CPython 2 is used.
1847# If -3 option is specified, then active version of CPython 3 is used.
1848# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1849# -2, -3 and --final-ABI options and Python_ABI argument cannot be specified simultaneously.
1850# If --ABI option is specified, then only specified Python ABI is printed instead of
1851# filename of Python interpreter.
1852# If --absolute-path option is specified, then absolute path to Python interpreter is printed.
1853# --ABI and --absolute-path options cannot be specified simultaneously.
1854PYTHON() {
1855 _python_check_python_pkg_setup_execution
1856
1857 local ABI_output="0" absolute_path_output="0" final_ABI="0" PYTHON_ABI="${PYTHON_ABI}" python_interpreter python2="0" python3="0"
1858
1859 while (($#)); do
1860 case "$1" in
1861 -2)
1862 python2="1"
1863 ;;
1864 -3)
1865 python3="1"
1866 ;;
1867 --ABI)
1868 ABI_output="1"
1869 ;;
1870 -a|--absolute-path)
1871 absolute_path_output="1"
1872 ;;
1873 -f|--final-ABI)
1874 final_ABI="1"
1875 ;;
1876 --)
1877 shift
1878 break
1879 ;;
1880 -*)
1881 die "${FUNCNAME}(): Unrecognized option '$1'"
1882 ;;
1883 *)
1884 break
1885 ;;
1886 esac
1887 shift
1888 done
1889
1890 if [[ "${ABI_output}" == "1" && "${absolute_path_output}" == "1" ]]; then
1891 die "${FUNCNAME}(): '--ABI' and '--absolute-path' options cannot be specified simultaneously"
1892 fi
1893
1894 if [[ "$((${python2} + ${python3} + ${final_ABI}))" -gt 1 ]]; then
1895 die "${FUNCNAME}(): '-2', '-3' or '--final-ABI' options cannot be specified simultaneously"
1896 fi
1897
1898 if [[ "$#" -eq 0 ]]; then
1899 if [[ "${final_ABI}" == "1" ]]; then
1900 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1901 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1902 fi
1903 _python_calculate_PYTHON_ABIS
1904 PYTHON_ABI="${PYTHON_ABIS##* }"
1905 elif [[ "${python2}" == "1" ]]; then
1906 PYTHON_ABI="$(ROOT="/" eselect python show --python2 --ABI)"
1907 if [[ -z "${PYTHON_ABI}" ]]; then
1908 die "${FUNCNAME}(): Active version of CPython 2 not set"
1909 elif [[ "${PYTHON_ABI}" != "2."* ]]; then
1910 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`"
1911 fi
1912 elif [[ "${python3}" == "1" ]]; then
1913 PYTHON_ABI="$(ROOT="/" eselect python show --python3 --ABI)"
1914 if [[ -z "${PYTHON_ABI}" ]]; then
1915 die "${FUNCNAME}(): Active version of CPython 3 not set"
1916 elif [[ "${PYTHON_ABI}" != "3."* ]]; then
1917 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`"
1918 fi
1919 elif _python_package_supporting_installation_for_multiple_python_abis; then
1920 if ! _python_abi-specific_local_scope; then
1921 die "${FUNCNAME}() should be used in ABI-specific local scope"
1922 fi
1923 else
1924 PYTHON_ABI="$("${EPREFIX}/usr/bin/python" -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")"
1925 if [[ -z "${PYTHON_ABI}" ]]; then
1926 die "${FUNCNAME}(): Failure of extraction of locally active version of Python"
1927 fi
1928 fi
1929 elif [[ "$#" -eq 1 ]]; then
1930 if [[ "${final_ABI}" == "1" ]]; then
1931 die "${FUNCNAME}(): '--final-ABI' option and Python ABI cannot be specified simultaneously"
1932 fi
1933 if [[ "${python2}" == "1" ]]; then
1934 die "${FUNCNAME}(): '-2' option and Python ABI cannot be specified simultaneously"
1935 fi
1936 if [[ "${python3}" == "1" ]]; then
1937 die "${FUNCNAME}(): '-3' option and Python ABI cannot be specified simultaneously"
1938 fi
1939 PYTHON_ABI="$1"
1940 else
1941 die "${FUNCNAME}(): Invalid usage"
1942 fi
1943
1944 if [[ "${ABI_output}" == "1" ]]; then
1945 echo -n "${PYTHON_ABI}"
1946 return
1947 else
1948 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1949 python_interpreter="python${PYTHON_ABI}"
1950 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1951 python_interpreter="jython${PYTHON_ABI%-jython}"
1952 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
1953 python_interpreter="pypy-c${PYTHON_ABI#*-pypy-}"
1954 fi
1955
1956 if [[ "${absolute_path_output}" == "1" ]]; then
1957 echo -n "${EPREFIX}/usr/bin/${python_interpreter}"
1958 else
1959 echo -n "${python_interpreter}"
1960 fi
1961 fi
1962
1963 if [[ -n "${ABI}" && "${ABI}" != "${DEFAULT_ABI}" && "${DEFAULT_ABI}" != "default" ]]; then
1964 echo -n "-${ABI}"
1965 fi
1966}
1967
1968# @FUNCTION: python_get_implementation
1969# @USAGE: [-f|--final-ABI]
1970# @DESCRIPTION:
1971# Print name of Python implementation.
1972# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1973python_get_implementation() {
1974 _python_check_python_pkg_setup_execution
1975
1976 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
1977
1978 while (($#)); do
1979 case "$1" in
1980 -f|--final-ABI)
1981 final_ABI="1"
1982 ;;
1983 -*)
1984 die "${FUNCNAME}(): Unrecognized option '$1'"
1985 ;;
1986 *)
1987 die "${FUNCNAME}(): Invalid usage"
1988 ;;
1989 esac
1990 shift
1991 done
1992
1993 if [[ "${final_ABI}" == "1" ]]; then
1994 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1995 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1996 fi
1997 PYTHON_ABI="$(PYTHON -f --ABI)"
1998 else
1999 if _python_package_supporting_installation_for_multiple_python_abis; then
2000 if ! _python_abi-specific_local_scope; then
2001 die "${FUNCNAME}() should be used in ABI-specific local scope"
2002 fi
2003 else
2004 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2005 fi
2006 fi
2007
2008 echo "$(_python_get_implementation "${PYTHON_ABI}")"
2009}
2010
2011# @FUNCTION: python_get_implementational_package
2012# @USAGE: [-f|--final-ABI]
2013# @DESCRIPTION:
2014# Print category, name and slot of package providing Python implementation.
2015# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2016python_get_implementational_package() {
2017 _python_check_python_pkg_setup_execution
2018
2019 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2020
2021 while (($#)); do
2022 case "$1" in
2023 -f|--final-ABI)
2024 final_ABI="1"
2025 ;;
2026 -*)
2027 die "${FUNCNAME}(): Unrecognized option '$1'"
2028 ;;
2029 *)
2030 die "${FUNCNAME}(): Invalid usage"
2031 ;;
2032 esac
2033 shift
2034 done
2035
2036 if [[ "${final_ABI}" == "1" ]]; then
2037 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2038 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2039 fi
2040 PYTHON_ABI="$(PYTHON -f --ABI)"
2041 else
2042 if _python_package_supporting_installation_for_multiple_python_abis; then
2043 if ! _python_abi-specific_local_scope; then
2044 die "${FUNCNAME}() should be used in ABI-specific local scope"
2045 fi
2046 else
2047 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2048 fi
2049 fi
2050
2051 if [[ "${EAPI:-0}" == "0" ]]; then
2052 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2053 echo "=dev-lang/python-${PYTHON_ABI}*"
2054 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2055 echo "=dev-java/jython-${PYTHON_ABI%-jython}*"
2056 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2057 echo "=dev-python/pypy-${PYTHON_ABI#*-pypy-}*"
2058 fi
2059 else
2060 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2061 echo "dev-lang/python:${PYTHON_ABI}"
2062 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2063 echo "dev-java/jython:${PYTHON_ABI%-jython}"
2064 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2065 echo "dev-python/pypy:${PYTHON_ABI#*-pypy-}"
2066 fi
2067 fi
2068}
2069
2070# @FUNCTION: python_get_includedir
2071# @USAGE: [-b|--base-path] [-f|--final-ABI]
2072# @DESCRIPTION:
2073# Print path to Python include directory.
2074# If --base-path option is specified, then path not prefixed with "/" is printed.
2075# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2076python_get_includedir() {
2077 _python_check_python_pkg_setup_execution
2078
2079 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2080
2081 while (($#)); do
2082 case "$1" in
2083 -b|--base-path)
2084 base_path="1"
2085 ;;
2086 -f|--final-ABI)
2087 final_ABI="1"
2088 ;;
2089 -*)
2090 die "${FUNCNAME}(): Unrecognized option '$1'"
2091 ;;
2092 *)
2093 die "${FUNCNAME}(): Invalid usage"
2094 ;;
2095 esac
2096 shift
2097 done
2098
2099 if [[ "${base_path}" == "0" ]]; then
2100 prefix="/"
2101 fi
2102
2103 if [[ "${final_ABI}" == "1" ]]; then
2104 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2105 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2106 fi
2107 PYTHON_ABI="$(PYTHON -f --ABI)"
2108 else
2109 if _python_package_supporting_installation_for_multiple_python_abis; then
2110 if ! _python_abi-specific_local_scope; then
2111 die "${FUNCNAME}() should be used in ABI-specific local scope"
2112 fi
2113 else
2114 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2115 fi
2116 fi
2117
2118 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2119 echo "${prefix}usr/include/python${PYTHON_ABI}"
2120 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2121 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include"
2122 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2123 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/include"
2124 fi
2125}
2126
2127# @FUNCTION: python_get_libdir
2128# @USAGE: [-b|--base-path] [-f|--final-ABI]
2129# @DESCRIPTION:
2130# Print path to Python standard library directory.
2131# If --base-path option is specified, then path not prefixed with "/" is printed.
2132# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2133python_get_libdir() {
2134 _python_check_python_pkg_setup_execution
2135
2136 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2137
2138 while (($#)); do
2139 case "$1" in
2140 -b|--base-path)
2141 base_path="1"
2142 ;;
2143 -f|--final-ABI)
2144 final_ABI="1"
2145 ;;
2146 -*)
2147 die "${FUNCNAME}(): Unrecognized option '$1'"
2148 ;;
2149 *)
2150 die "${FUNCNAME}(): Invalid usage"
2151 ;;
2152 esac
2153 shift
2154 done
2155
2156 if [[ "${base_path}" == "0" ]]; then
2157 prefix="/"
2158 fi
2159
2160 if [[ "${final_ABI}" == "1" ]]; then
2161 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2162 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2163 fi
2164 PYTHON_ABI="$(PYTHON -f --ABI)"
2165 else
2166 if _python_package_supporting_installation_for_multiple_python_abis; then
2167 if ! _python_abi-specific_local_scope; then
2168 die "${FUNCNAME}() should be used in ABI-specific local scope"
2169 fi
2170 else
2171 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2172 fi
2173 fi
2174
2175 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2176 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}"
2177 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2178 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib"
2179 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2180 die "${FUNCNAME}(): PyPy has multiple standard library directories"
2181 fi
2182}
2183
2184# @FUNCTION: python_get_sitedir
2185# @USAGE: [-b|--base-path] [-f|--final-ABI]
2186# @DESCRIPTION:
2187# Print path to Python site-packages directory.
2188# If --base-path option is specified, then path not prefixed with "/" is printed.
2189# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2190python_get_sitedir() {
2191 _python_check_python_pkg_setup_execution
2192
2193 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2194
2195 while (($#)); do
2196 case "$1" in
2197 -b|--base-path)
2198 base_path="1"
2199 ;;
2200 -f|--final-ABI)
2201 final_ABI="1"
2202 ;;
2203 -*)
2204 die "${FUNCNAME}(): Unrecognized option '$1'"
2205 ;;
2206 *)
2207 die "${FUNCNAME}(): Invalid usage"
2208 ;;
2209 esac
2210 shift
2211 done
2212
2213 if [[ "${base_path}" == "0" ]]; then
2214 prefix="/"
2215 fi
2216
2217 if [[ "${final_ABI}" == "1" ]]; then
2218 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2219 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2220 fi
2221 PYTHON_ABI="$(PYTHON -f --ABI)"
2222 else
2223 if _python_package_supporting_installation_for_multiple_python_abis; then
2224 if ! _python_abi-specific_local_scope; then
2225 die "${FUNCNAME}() should be used in ABI-specific local scope"
2226 fi
2227 else
2228 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2229 fi
2230 fi
2231
2232 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2233 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}/site-packages"
2234 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2235 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib/site-packages"
2236 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2237 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/site-packages"
2238 fi
2239}
2240
2241# @FUNCTION: python_get_library
2242# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option]
2243# @DESCRIPTION:
2244# Print path to Python library.
2245# If --base-path option is specified, then path not prefixed with "/" is printed.
2246# If --linker-option is specified, then "-l${library}" linker option is printed.
2247# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2248python_get_library() {
2249 _python_check_python_pkg_setup_execution
2250
2251 local base_path="0" final_ABI="0" linker_option="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2252
2253 while (($#)); do
2254 case "$1" in
2255 -b|--base-path)
2256 base_path="1"
2257 ;;
2258 -f|--final-ABI)
2259 final_ABI="1"
2260 ;;
2261 -l|--linker-option)
2262 linker_option="1"
2263 ;;
2264 -*)
2265 die "${FUNCNAME}(): Unrecognized option '$1'"
2266 ;;
2267 *)
2268 die "${FUNCNAME}(): Invalid usage"
2269 ;;
2270 esac
2271 shift
2272 done
2273
2274 if [[ "${base_path}" == "0" ]]; then
2275 prefix="/"
2276 fi
2277
2278 if [[ "${base_path}" == "1" && "${linker_option}" == "1" ]]; then
2279 die "${FUNCNAME}(): '--base-path' and '--linker-option' options cannot be specified simultaneously"
2280 fi
2281
2282 if [[ "${final_ABI}" == "1" ]]; then
2283 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2284 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2285 fi
2286 PYTHON_ABI="$(PYTHON -f --ABI)"
2287 else
2288 if _python_package_supporting_installation_for_multiple_python_abis; then
2289 if ! _python_abi-specific_local_scope; then
2290 die "${FUNCNAME}() should be used in ABI-specific local scope"
2291 fi
2292 else
2293 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2294 fi
2295 fi
2296
2297 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2298 if [[ "${linker_option}" == "1" ]]; then
2299 echo "-lpython${PYTHON_ABI}"
2300 else
2301 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)"
2302 fi
2303 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2304 die "${FUNCNAME}(): Jython does not have shared library"
2305 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2306 die "${FUNCNAME}(): PyPy does not have shared library"
2307 fi
2308}
2309
2310# @FUNCTION: python_get_version
2311# @USAGE: [-f|--final-ABI] [-l|--language] [--full] [--major] [--minor] [--micro]
2312# @DESCRIPTION:
2313# Print version of Python implementation.
2314# --full, --major, --minor and --micro options cannot be specified simultaneously.
2315# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed.
2316# If --language option is specified, then version of Python language is printed.
2317# --language and --full options cannot be specified simultaneously.
2318# --language and --micro options cannot be specified simultaneously.
2319# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2320python_get_version() {
2321 _python_check_python_pkg_setup_execution
2322
2323 local final_ABI="0" language="0" language_version full="0" major="0" minor="0" micro="0" PYTHON_ABI="${PYTHON_ABI}" python_command
2324
2325 while (($#)); do
2326 case "$1" in
2327 -f|--final-ABI)
2328 final_ABI="1"
2329 ;;
2330 -l|--language)
2331 language="1"
2332 ;;
2333 --full)
2334 full="1"
2335 ;;
2336 --major)
2337 major="1"
2338 ;;
2339 --minor)
2340 minor="1"
2341 ;;
2342 --micro)
2343 micro="1"
2344 ;;
2345 -*)
2346 die "${FUNCNAME}(): Unrecognized option '$1'"
2347 ;;
2348 *)
2349 die "${FUNCNAME}(): Invalid usage"
2350 ;;
2351 esac
2352 shift
2353 done
2354
2355 if [[ "${final_ABI}" == "1" ]]; then
2356 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2357 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2358 fi
2359 else
2360 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2361 die "${FUNCNAME}() should be used in ABI-specific local scope"
2362 fi
2363 fi
2364
2365 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2366 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2367 fi
2368
2369 if [[ "${language}" == "1" ]]; then
2370 if [[ "${final_ABI}" == "1" ]]; then
2371 PYTHON_ABI="$(PYTHON -f --ABI)"
2372 elif [[ -z "${PYTHON_ABI}" ]]; then
2373 PYTHON_ABI="$(PYTHON --ABI)"
2374 fi
2375 language_version="${PYTHON_ABI%%-*}"
2376 if [[ "${full}" == "1" ]]; then
2377 die "${FUNCNAME}(): '--language' and '--full' options cannot be specified simultaneously"
2378 elif [[ "${major}" == "1" ]]; then
2379 echo "${language_version%.*}"
2380 elif [[ "${minor}" == "1" ]]; then
2381 echo "${language_version#*.}"
2382 elif [[ "${micro}" == "1" ]]; then
2383 die "${FUNCNAME}(): '--language' and '--micro' options cannot be specified simultaneously"
2384 else
2385 echo "${language_version}"
2386 fi
2387 else
2388 if [[ "${full}" == "1" ]]; then
2389 python_command="import sys; print('.'.join(str(x) for x in getattr(sys, 'pypy_version_info', sys.version_info)[:3]))"
2390 elif [[ "${major}" == "1" ]]; then
2391 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[0])"
2392 elif [[ "${minor}" == "1" ]]; then
2393 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[1])"
2394 elif [[ "${micro}" == "1" ]]; then
2395 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[2])"
2396 else
2397 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2398 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2399 echo "${PYTHON_ABI}"
2400 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2401 echo "${PYTHON_ABI%-jython}"
2402 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2403 echo "${PYTHON_ABI#*-pypy-}"
2404 fi
2405 return
2406 fi
2407 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2408 fi
2409
2410 if [[ "${final_ABI}" == "1" ]]; then
2411 "$(PYTHON -f)" -c "${python_command}"
2412 else
2413 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}"
2414 fi
2415 fi
2416}
2417
2418# @FUNCTION: python_get_implementation_and_version
2419# @USAGE: [-f|--final-ABI]
2420# @DESCRIPTION:
2421# Print name and version of Python implementation.
2422# If version of Python implementation is not bound to version of Python language, then
2423# version of Python language is additionally printed.
2424# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2425python_get_implementation_and_version() {
2426 _python_check_python_pkg_setup_execution
2427
2428 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2429
2430 while (($#)); do
2431 case "$1" in
2432 -f|--final-ABI)
2433 final_ABI="1"
2434 ;;
2435 -*)
2436 die "${FUNCNAME}(): Unrecognized option '$1'"
2437 ;;
2438 *)
2439 die "${FUNCNAME}(): Invalid usage"
2440 ;;
2441 esac
2442 shift
2443 done
2444
2445 if [[ "${final_ABI}" == "1" ]]; then
2446 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2447 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2448 fi
2449 PYTHON_ABI="$(PYTHON -f --ABI)"
2450 else
2451 if _python_package_supporting_installation_for_multiple_python_abis; then
2452 if ! _python_abi-specific_local_scope; then
2453 die "${FUNCNAME}() should be used in ABI-specific local scope"
2454 fi
2455 else
2456 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2457 fi
2458 fi
2459
2460 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-[[:alnum:]]+-[[:digit:]]+\.[[:digit:]]+$ ]]; then
2461 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI##*-} (Python ${PYTHON_ABI%%-*})"
2462 else
2463 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI%%-*}"
2464 fi
2465}
2466
2467# ================================================================================================
2468# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================
2469# ================================================================================================
2470
2471# @ECLASS-VARIABLE: PYTHON_TEST_VERBOSITY
2472# @DESCRIPTION:
2473# User-configurable verbosity of tests of Python modules.
2474# Supported values: 0, 1, 2, 3, 4.
2475PYTHON_TEST_VERBOSITY="${PYTHON_TEST_VERBOSITY:-1}"
2476
2477_python_test_hook() {
2478 if [[ "$#" -ne 1 ]]; then
2479 die "${FUNCNAME}() requires 1 argument"
2480 fi
2481
2482 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${_PYTHON_TEST_FUNCTION}_$1_hook")" == "function" ]]; then
2483 "${_PYTHON_TEST_FUNCTION}_$1_hook"
2484 fi
2485}
2486
2487# @FUNCTION: python_execute_nosetests
2488# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2489# @DESCRIPTION:
2490# Execute nosetests for all enabled Python ABIs.
2491# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2492# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined.
2493python_execute_nosetests() {
2494 _python_check_python_pkg_setup_execution
2495 _python_set_color_variables
2496
2497 local PYTHONPATH_template separate_build_dirs
2498
2499 while (($#)); do
2500 case "$1" in
2501 -P|--PYTHONPATH)
2502 PYTHONPATH_template="$2"
2503 shift
2504 ;;
2505 -s|--separate-build-dirs)
2506 separate_build_dirs="1"
2507 ;;
2508 --)
2509 shift
2510 break
2511 ;;
2512 -*)
2513 die "${FUNCNAME}(): Unrecognized option '$1'"
2514 ;;
2515 *)
2516 break
2517 ;;
2518 esac
2519 shift
2520 done
2521
2522 python_test_function() {
2523 local evaluated_PYTHONPATH
2524
2525 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2526
2527 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook pre
2528
2529 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2530 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2531 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2532 else
2533 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2534 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2535 fi
2536
2537 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook post
2538 }
2539 if _python_package_supporting_installation_for_multiple_python_abis; then
2540 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2541 else
2542 if [[ -n "${separate_build_dirs}" ]]; then
2543 die "${FUNCNAME}(): Invalid usage"
2544 fi
2545 python_test_function "$@" || die "Testing failed"
2546 fi
2547
2548 unset -f python_test_function
2549}
2550
2551# @FUNCTION: python_execute_py.test
2552# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2553# @DESCRIPTION:
2554# Execute py.test for all enabled Python ABIs.
2555# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2556# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined.
2557python_execute_py.test() {
2558 _python_check_python_pkg_setup_execution
2559 _python_set_color_variables
2560
2561 local PYTHONPATH_template separate_build_dirs
2562
2563 while (($#)); do
2564 case "$1" in
2565 -P|--PYTHONPATH)
2566 PYTHONPATH_template="$2"
2567 shift
2568 ;;
2569 -s|--separate-build-dirs)
2570 separate_build_dirs="1"
2571 ;;
2572 --)
2573 shift
2574 break
2575 ;;
2576 -*)
2577 die "${FUNCNAME}(): Unrecognized option '$1'"
2578 ;;
2579 *)
2580 break
2581 ;;
2582 esac
2583 shift
2584 done
2585
2586 python_test_function() {
2587 local evaluated_PYTHONPATH
2588
2589 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2590
2591 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook pre
2592
2593 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2594 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL}
2595 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?"
2596 else
2597 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL}
2598 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?"
2599 fi
2600
2601 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook post
2602 }
2603 if _python_package_supporting_installation_for_multiple_python_abis; then
2604 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2605 else
2606 if [[ -n "${separate_build_dirs}" ]]; then
2607 die "${FUNCNAME}(): Invalid usage"
2608 fi
2609 python_test_function "$@" || die "Testing failed"
2610 fi
2611
2612 unset -f python_test_function
2613}
2614
2615# @FUNCTION: python_execute_trial
2616# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2617# @DESCRIPTION:
2618# Execute trial for all enabled Python ABIs.
2619# In ebuilds of packages supporting installation for multiple Python ABIs, this function
2620# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined.
2621python_execute_trial() {
2622 _python_check_python_pkg_setup_execution
2623 _python_set_color_variables
2624
2625 local PYTHONPATH_template separate_build_dirs
2626
2627 while (($#)); do
2628 case "$1" in
2629 -P|--PYTHONPATH)
2630 PYTHONPATH_template="$2"
2631 shift
2632 ;;
2633 -s|--separate-build-dirs)
2634 separate_build_dirs="1"
2635 ;;
2636 --)
2637 shift
2638 break
2639 ;;
2640 -*)
2641 die "${FUNCNAME}(): Unrecognized option '$1'"
2642 ;;
2643 *)
2644 break
2645 ;;
2646 esac
2647 shift
2648 done
2649
2650 python_test_function() {
2651 local evaluated_PYTHONPATH
2652
2653 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2654
2655 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook pre
2656
2657 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2658 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2659 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2660 else
2661 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2662 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2663 fi
2664
2665 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook post
2666 }
2667 if _python_package_supporting_installation_for_multiple_python_abis; then
2668 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2669 else
2670 if [[ -n "${separate_build_dirs}" ]]; then
2671 die "${FUNCNAME}(): Invalid usage"
2672 fi
2673 python_test_function "$@" || die "Testing failed"
2674 fi
2675
2676 unset -f python_test_function
2677}
2678
2679# ================================================================================================
2680# ======================= FUNCTIONS FOR HANDLING OF BYTE-COMPILED MODULES ========================
2681# ================================================================================================
2682
2683# @FUNCTION: python_enable_pyc
2684# @DESCRIPTION:
2685# Tell Python to automatically recompile modules to .pyc/.pyo if the
2686# timestamps/version stamps have changed.
2687python_enable_pyc() {
2688 _python_check_python_pkg_setup_execution
2689
2690 if [[ "$#" -ne 0 ]]; then
2691 die "${FUNCNAME}() does not accept arguments"
2692 fi
2693
2694 unset PYTHONDONTWRITEBYTECODE
2695}
2696
2697# @FUNCTION: python_disable_pyc
2698# @DESCRIPTION:
2699# Tell Python not to automatically recompile modules to .pyc/.pyo
2700# even if the timestamps/version stamps do not match. This is done
2701# to protect sandbox.
2702python_disable_pyc() {
2703 _python_check_python_pkg_setup_execution
2704
2705 if [[ "$#" -ne 0 ]]; then
2706 die "${FUNCNAME}() does not accept arguments"
2707 fi
2708
2709 export PYTHONDONTWRITEBYTECODE="1"
2710}
2711
2712_python_clean_compiled_modules() {
2713 _python_initialize_prefix_variables
2714 _python_set_color_variables
2715
2716 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage"
2717
2718 local base_module_name compiled_file compiled_files=() dir path py_file root
2719
2720 # Strip trailing slash from EROOT.
2721 root="${EROOT%/}"
2722
2723 for path in "$@"; do
2724 compiled_files=()
2725 if [[ -d "${path}" ]]; then
2726 while read -d $'\0' -r compiled_file; do
2727 compiled_files+=("${compiled_file}")
2728 done < <(find "${path}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -print0)
2729
2730 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then
2731 # Delete empty child directories.
2732 find "${path}" -type d | sort -r | while read -r dir; do
2733 if rmdir "${dir}" 2> /dev/null; then
2734 echo "${_CYAN}<<< ${dir}${_NORMAL}"
2735 fi
2736 done
2737 fi
2738 elif [[ "${path}" == *.py ]]; then
2739 base_module_name="${path##*/}"
2740 base_module_name="${base_module_name%.py}"
2741 if [[ -d "${path%/*}/__pycache__" ]]; then
2742 while read -d $'\0' -r compiled_file; do
2743 compiled_files+=("${compiled_file}")
2744 done < <(find "${path%/*}/__pycache__" "(" -name "${base_module_name}.*.py[co]" -o -name "${base_module_name}\$py.class" ")" -print0)
2745 fi
2746 compiled_files+=("${path}c" "${path}o" "${path%.py}\$py.class")
2747 fi
2748
2749 for compiled_file in "${compiled_files[@]}"; do
2750 [[ ! -f "${compiled_file}" ]] && continue
2751 dir="${compiled_file%/*}"
2752 dir="${dir##*/}"
2753 if [[ "${compiled_file}" == *.py[co] ]]; then
2754 if [[ "${dir}" == "__pycache__" ]]; then
2755 base_module_name="${compiled_file##*/}"
2756 base_module_name="${base_module_name%.*py[co]}"
2757 base_module_name="${base_module_name%.*}"
2758 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2759 else
2760 py_file="${compiled_file%[co]}"
2761 fi
2762 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2763 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2764 else
2765 [[ -f "${py_file}" ]] && continue
2766 fi
2767 echo "${_BLUE}<<< ${compiled_file%[co]}[co]${_NORMAL}"
2768 rm -f "${compiled_file%[co]}"[co]
2769 elif [[ "${compiled_file}" == *\$py.class ]]; then
2770 if [[ "${dir}" == "__pycache__" ]]; then
2771 base_module_name="${compiled_file##*/}"
2772 base_module_name="${base_module_name%\$py.class}"
2773 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2774 else
2775 py_file="${compiled_file%\$py.class}.py"
2776 fi
2777 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2778 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2779 else
2780 [[ -f "${py_file}" ]] && continue
2781 fi
2782 echo "${_BLUE}<<< ${compiled_file}${_NORMAL}"
2783 rm -f "${compiled_file}"
2784 else
2785 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'"
2786 fi
2787
2788 # Delete empty parent directories.
2789 dir="${compiled_file%/*}"
2790 while [[ "${dir}" != "${root}" ]]; do
2791 if rmdir "${dir}" 2> /dev/null; then
2792 echo "${_CYAN}<<< ${dir}${_NORMAL}"
2793 else
2794 break
2795 fi
2796 dir="${dir%/*}"
2797 done
2798 done
2799 done
2800}
2801
2802# @FUNCTION: python_mod_optimize
2803# @USAGE: [--allow-evaluated-non-sitedir-paths] [-d directory] [-f] [-l] [-q] [-x regular_expression] [--] <file|directory> [files|directories]
2804# @DESCRIPTION:
2805# Byte-compile specified Python modules.
2806# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py.
2807#
2808# This function can be used only in pkg_postinst() phase.
2809python_mod_optimize() {
2810 if [[ "${EBUILD_PHASE}" != "postinst" ]]; then
2811 die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2812 fi
2813
2814 _python_check_python_pkg_setup_execution
2815 _python_initialize_prefix_variables
2816
2817 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2818 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs.
2819 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() stderr stderr_line
2820
2821 if _python_package_supporting_installation_for_multiple_python_abis; then
2822 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
2823 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2824 fi
2825 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
2826 else
2827 if has "${EAPI:-0}" 0 1 2 3; then
2828 iterated_PYTHON_ABIS="${PYTHON_ABI:=$(PYTHON --ABI)}"
2829 else
2830 iterated_PYTHON_ABIS="${PYTHON_ABI}"
2831 fi
2832 fi
2833
2834 # Strip trailing slash from EROOT.
2835 root="${EROOT%/}"
2836
2837 while (($#)); do
2838 case "$1" in
2839 --allow-evaluated-non-sitedir-paths)
2840 allow_evaluated_non_sitedir_paths="1"
2841 ;;
2842 -l|-f|-q)
2843 options+=("$1")
2844 ;;
2845 -d|-x)
2846 options+=("$1" "$2")
2847 shift
2848 ;;
2849 --)
2850 shift
2851 break
2852 ;;
2853 -*)
2854 die "${FUNCNAME}(): Unrecognized option '$1'"
2855 ;;
2856 *)
2857 break
2858 ;;
2859 esac
2860 shift
2861 done
2862
2863 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
2864 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2865 fi
2866
2867 if [[ "$#" -eq 0 ]]; then
2868 die "${FUNCNAME}(): Missing files or directories"
2869 fi
2870
2871 while (($#)); do
2872 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2873 die "${FUNCNAME}(): Invalid argument '$1'"
2874 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
2875 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
2876 elif [[ "$1" =~ ^/ ]]; then
2877 if _python_package_supporting_installation_for_multiple_python_abis; then
2878 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
2879 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
2880 fi
2881 if [[ "$1" != *\$* ]]; then
2882 die "${FUNCNAME}(): '$1' has invalid syntax"
2883 fi
2884 if [[ "$1" == *.py ]]; then
2885 evaluated_files+=("$1")
2886 else
2887 evaluated_dirs+=("$1")
2888 fi
2889 else
2890 if [[ -d "${root}$1" ]]; then
2891 other_dirs+=("${root}$1")
2892 elif [[ -f "${root}$1" ]]; then
2893 other_files+=("${root}$1")
2894 elif [[ -e "${root}$1" ]]; then
2895 eerror "${FUNCNAME}(): '${root}$1' is not a regular file or a directory"
2896 else
2897 eerror "${FUNCNAME}(): '${root}$1' does not exist"
2898 fi
2899 fi
2900 else
2901 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2902 if [[ -d "${root}$(python_get_sitedir)/$1" ]]; then
2903 site_packages_dirs+=("$1")
2904 break
2905 elif [[ -f "${root}$(python_get_sitedir)/$1" ]]; then
2906 site_packages_files+=("$1")
2907 break
2908 elif [[ -e "${root}$(python_get_sitedir)/$1" ]]; then
2909 eerror "${FUNCNAME}(): '$1' is not a regular file or a directory"
2910 else
2911 eerror "${FUNCNAME}(): '$1' does not exist"
2912 fi
2913 done
2914 fi
2915 shift
2916 done
2917
2918 # Set additional options.
2919 options+=("-q")
2920
2921 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2922 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then
2923 return_code="0"
2924 stderr=""
2925 ebegin "Compilation and optimization of Python modules for $(python_get_implementation_and_version)"
2926 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then
2927 for dir in "${site_packages_dirs[@]}"; do
2928 dirs+=("${root}$(python_get_sitedir)/${dir}")
2929 done
2930 for dir in "${evaluated_dirs[@]}"; do
2931 eval "dirs+=(\"\${root}${dir}\")"
2932 done
2933 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m compileall "${options[@]}" "${dirs[@]}" 2>&1)" || return_code="1"
2934 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2935 "$(PYTHON)" -O -m compileall "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1"
2936 fi
2937 _python_clean_compiled_modules "${dirs[@]}"
2938 fi
2939 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then
2940 for file in "${site_packages_files[@]}"; do
2941 files+=("${root}$(python_get_sitedir)/${file}")
2942 done
2943 for file in "${evaluated_files[@]}"; do
2944 eval "files+=(\"\${root}${file}\")"
2945 done
2946 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m py_compile "${files[@]}" 2>&1)" || return_code="1"
2947 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2948 "$(PYTHON)" -O -m py_compile "${files[@]}" &> /dev/null || return_code="1"
2949 fi
2950 _python_clean_compiled_modules "${files[@]}"
2951 fi
2952 eend "${return_code}"
2953 if [[ -n "${stderr}" ]]; then
2954 eerror "Syntax errors / warnings in Python modules for $(python_get_implementation_and_version):" &> /dev/null
2955 while read stderr_line; do
2956 eerror " ${stderr_line}"
2957 done <<< "${stderr}"
2958 fi
2959 fi
2960 unset dirs files
2961 done
2962
2963 if _python_package_supporting_installation_for_multiple_python_abis; then
2964 # Restore previous value of PYTHON_ABI.
2965 if [[ -n "${previous_PYTHON_ABI}" ]]; then
2966 PYTHON_ABI="${previous_PYTHON_ABI}"
2967 else
2968 unset PYTHON_ABI
2969 fi
2970 fi
2971
2972 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then
2973 return_code="0"
2974 stderr=""
2975 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation_and_version)"
2976 if ((${#other_dirs[@]})); then
2977 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m compileall "${options[@]}" "${other_dirs[@]}" 2>&1)" || return_code="1"
2978 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2979 "$(PYTHON ${PYTHON_ABI})" -O -m compileall "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1"
2980 fi
2981 _python_clean_compiled_modules "${other_dirs[@]}"
2982 fi
2983 if ((${#other_files[@]})); then
2984 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m py_compile "${other_files[@]}" 2>&1)" || return_code="1"
2985 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2986 "$(PYTHON ${PYTHON_ABI})" -O -m py_compile "${other_files[@]}" &> /dev/null || return_code="1"
2987 fi
2988 _python_clean_compiled_modules "${other_files[@]}"
2989 fi
2990 eend "${return_code}"
2991 if [[ -n "${stderr}" ]]; then
2992 eerror "Syntax errors / warnings in Python modules placed outside of site-packages directories for $(python_get_implementation_and_version):" &> /dev/null
2993 while read stderr_line; do
2994 eerror " ${stderr_line}"
2995 done <<< "${stderr}"
2996 fi
2997 fi
2998 else
2999 # Deprecated part of python_mod_optimize()
3000 ewarn
3001 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
3002 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
3003 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
3004 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
3005 ewarn
3006
3007 local myroot mydirs=() myfiles=() myopts=() return_code="0"
3008
3009 # strip trailing slash
3010 myroot="${EROOT%/}"
3011
3012 # respect EROOT and options passed to compileall.py
3013 while (($#)); do
3014 case "$1" in
3015 -l|-f|-q)
3016 myopts+=("$1")
3017 ;;
3018 -d|-x)
3019 myopts+=("$1" "$2")
3020 shift
3021 ;;
3022 --)
3023 shift
3024 break
3025 ;;
3026 -*)
3027 die "${FUNCNAME}(): Unrecognized option '$1'"
3028 ;;
3029 *)
3030 break
3031 ;;
3032 esac
3033 shift
3034 done
3035
3036 if [[ "$#" -eq 0 ]]; then
3037 die "${FUNCNAME}(): Missing files or directories"
3038 fi
3039
3040 while (($#)); do
3041 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3042 die "${FUNCNAME}(): Invalid argument '$1'"
3043 elif [[ -d "${myroot}/${1#/}" ]]; then
3044 mydirs+=("${myroot}/${1#/}")
3045 elif [[ -f "${myroot}/${1#/}" ]]; then
3046 myfiles+=("${myroot}/${1#/}")
3047 elif [[ -e "${myroot}/${1#/}" ]]; then
3048 eerror "${FUNCNAME}(): ${myroot}/${1#/} is not a regular file or directory"
3049 else
3050 eerror "${FUNCNAME}(): ${myroot}/${1#/} does not exist"
3051 fi
3052 shift
3053 done
3054
249 # set additional opts 3055 # set additional opts
250 myopts+=(-q) 3056 myopts+=(-q)
251 3057
252 ebegin "Byte compiling python modules for python-${PYVER} .." 3058 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
3059
3060 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)"
253 if ((${#mydirs[@]})); then 3061 if ((${#mydirs[@]})); then
254 python${PYVER} \ 3062 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" || return_code="1"
255 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \ 3063 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" &> /dev/null || return_code="1"
256 "${myopts[@]}" "${mydirs[@]}" 3064 _python_clean_compiled_modules "${mydirs[@]}"
257 python${PYVER} -O \
258 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \
259 "${myopts[@]}" "${mydirs[@]}"
260 fi 3065 fi
261 3066
262 if ((${#myfiles[@]})); then 3067 if ((${#myfiles[@]})); then
3068 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" || return_code="1"
3069 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" &> /dev/null || return_code="1"
263 python_mod_compile "${myfiles[@]}" 3070 _python_clean_compiled_modules "${myfiles[@]}"
264 fi 3071 fi
265 3072
266 eend $? 3073 eend "${return_code}"
3074 fi
267} 3075}
268 3076
269# @FUNCTION: python_mod_cleanup 3077# @FUNCTION: python_mod_cleanup
270# @USAGE: [ dir ] 3078# @USAGE: [--allow-evaluated-non-sitedir-paths] [--] <file|directory> [files|directories]
271# @DESCRIPTION: 3079# @DESCRIPTION:
272# Run with optional arguments, where arguments are directories of 3080# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
273# python modules. if none given, it will look in /usr/lib/python[0-9].[0-9]
274# 3081#
275# It will recursively scan all compiled python modules in the directories 3082# This function can be used only in pkg_postrm() phase.
276# and determine if they are orphaned (eg. their corresponding .py is missing.)
277# if they are, then it will remove their corresponding .pyc and .pyo
278#
279# This function should only be run in pkg_postrm()
280python_mod_cleanup() { 3083python_mod_cleanup() {
281 local SEARCH_PATH=() myroot src_py
282
283 # Check if phase is pkg_postrm()
284 [[ ${EBUILD_PHASE} != postrm ]] &&\ 3084 if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
285 die "${FUNCNAME} should only be run in pkg_postrm()" 3085 die "${FUNCNAME}() can be used only in pkg_postrm() phase"
3086 fi
286 3087
3088 _python_check_python_pkg_setup_execution
3089 _python_initialize_prefix_variables
3090
3091 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
3092
3093 if _python_package_supporting_installation_for_multiple_python_abis; then
3094 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
3095 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
3096 fi
3097 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
3098 else
3099 if has "${EAPI:-0}" 0 1 2 3; then
3100 iterated_PYTHON_ABIS="${PYTHON_ABI:-$(PYTHON --ABI)}"
3101 else
3102 iterated_PYTHON_ABIS="${PYTHON_ABI}"
3103 fi
3104 fi
3105
287 # strip trailing slash 3106 # Strip trailing slash from EROOT.
288 myroot="${ROOT%/}" 3107 root="${EROOT%/}"
289 3108
290 if (($#)); then 3109 while (($#)); do
291 SEARCH_PATH=("${@#/}") 3110 case "$1" in
292 SEARCH_PATH=("${SEARCH_PATH[@]/#/$myroot/}") 3111 --allow-evaluated-non-sitedir-paths)
3112 allow_evaluated_non_sitedir_paths="1"
3113 ;;
3114 --)
3115 shift
3116 break
3117 ;;
3118 -*)
3119 die "${FUNCNAME}(): Unrecognized option '$1'"
3120 ;;
3121 *)
3122 break
3123 ;;
3124 esac
3125 shift
3126 done
3127
3128 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
3129 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
3130 fi
3131
3132 if [[ "$#" -eq 0 ]]; then
3133 die "${FUNCNAME}(): Missing files or directories"
3134 fi
3135
3136 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
3137 while (($#)); do
3138 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3139 die "${FUNCNAME}(): Invalid argument '$1'"
3140 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
3141 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
3142 elif [[ "$1" =~ ^/ ]]; then
3143 if _python_package_supporting_installation_for_multiple_python_abis; then
3144 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
3145 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
3146 fi
3147 if [[ "$1" != *\$* ]]; then
3148 die "${FUNCNAME}(): '$1' has invalid syntax"
3149 fi
3150 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
3151 eval "search_paths+=(\"\${root}$1\")"
3152 done
3153 else
3154 search_paths+=("${root}$1")
3155 fi
293 else 3156 else
294 SEARCH_PATH=("${myroot}"/usr/lib*/python*/site-packages) 3157 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
3158 search_paths+=("${root}$(python_get_sitedir)/$1")
3159 done
295 fi 3160 fi
296 3161 shift
297 for path in "${SEARCH_PATH[@]}"; do
298 einfo "Cleaning orphaned Python bytecode from ${path} .."
299 find "${path}" -name '*.py[co]' -print0 | while read -rd ''; do
300 src_py="${REPLY%[co]}"
301 [[ -f "${src_py}" ]] && continue
302 einfo "Purging ${src_py}[co]"
303 rm -f "${src_py}"[co]
304 done 3162 done
3163 else
3164 # Deprecated part of python_mod_cleanup()
3165 ewarn
3166 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
3167 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
3168 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
3169 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
3170 ewarn
305 3171
306 # attempt to remove directories that maybe empty 3172 search_paths=("${@#/}")
307 find "${path}" -type d | sort -r | while read -r dir; do 3173 search_paths=("${search_paths[@]/#/${root}/}")
308 rmdir "${dir}" 2>/dev/null 3174 fi
309 done 3175
310 done 3176 _python_clean_compiled_modules "${search_paths[@]}"
311} 3177}
3178
3179# ================================================================================================
3180# ===================================== DEPRECATED FUNCTIONS =====================================
3181# ================================================================================================
3182
3183fi # _PYTHON_ECLASS_INHERITED

Legend:
Removed from v.1.54  
changed lines
  Added in v.1.153

  ViewVC Help
Powered by ViewVC 1.1.20