/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.60 Revision 1.158
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.60 2009/08/05 18:31:30 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.158 2012/09/27 15:41:56 floppym Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# python@gentoo.org 7# Gentoo Python Project <python@gentoo.org>
8# 8# @BLURB: Eclass for Python packages
9# original author: Alastair Tse <liquidx@gentoo.org>
10# @BLURB: A Utility Eclass that should be inherited by anything that deals with Python or Python modules.
11# @DESCRIPTION: 9# @DESCRIPTION:
12# Some useful functions for dealing with python. 10# The python eclass contains miscellaneous, useful functions for Python packages.
13inherit alternatives multilib
14 11
15 12# Must call inherit before EXPORT_FUNCTIONS to avoid QA warning.
16if [[ -n "${NEED_PYTHON}" ]] ; then 13if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
17 PYTHON_ATOM=">=dev-lang/python-${NEED_PYTHON}" 14 inherit multilib
18 DEPEND="${PYTHON_ATOM}"
19 RDEPEND="${DEPEND}"
20else
21 PYTHON_ATOM="dev-lang/python"
22fi 15fi
23 16
24if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 17# Export pkg_setup every time to avoid issues with eclass inheritance order.
25 DEPEND="${DEPEND} >=app-admin/eselect-python-20090804" 18if ! has "${EAPI:-0}" 0 1 2 3 || { has "${EAPI:-0}" 2 3 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; }; then
19 EXPORT_FUNCTIONS pkg_setup
26fi 20fi
27 21
28__python_eclass_test() { 22# Avoid processing this eclass more than once.
29 __python_version_extract 2.3 23if [[ -z "${_PYTHON_ECLASS_INHERITED}" ]]; then
30 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR" 24_PYTHON_ECLASS_INHERITED="1"
31 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
32 __python_version_extract 2.3.4
33 echo -n "2.3.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
34 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
35 __python_version_extract 2.3.5
36 echo -n "2.3.5 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
37 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
38 __python_version_extract 2.4
39 echo -n "2.4 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
40 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
41 __python_version_extract 2.5b3
42 echo -n "2.5b3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
43 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
44}
45 25
46# @FUNCTION: python_version 26if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
47# @DESCRIPTION: 27 die "API of python.eclass in EAPI=\"${EAPI}\" not established"
48# Run without arguments and it will export the version of python
49# currently in use as $PYVER; sets PYVER/PYVER_MAJOR/PYVER_MINOR
50__python_version_extract() {
51 local verstr=$1
52 export PYVER_MAJOR=${verstr:0:1}
53 export PYVER_MINOR=${verstr:2:1}
54 if [[ ${verstr:3:1} == . ]]; then
55 export PYVER_MICRO=${verstr:4}
56 fi 28fi
57 export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
58}
59 29
60python_version() { 30_CPYTHON2_GLOBALLY_SUPPORTED_ABIS=(2.4 2.5 2.6 2.7)
61 [[ -n "${PYVER}" ]] && return 0 31_CPYTHON3_GLOBALLY_SUPPORTED_ABIS=(3.1 3.2)
62 local tmpstr 32_JYTHON_GLOBALLY_SUPPORTED_ABIS=(2.5-jython)
63 python=${python:-/usr/bin/python} 33_PYPY_GLOBALLY_SUPPORTED_ABIS=(2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9)
64 tmpstr="$(${python} -V 2>&1 )" 34_PYTHON_GLOBALLY_SUPPORTED_ABIS=(${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]} ${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]} ${_JYTHON_GLOBALLY_SUPPORTED_ABIS[@]} ${_PYPY_GLOBALLY_SUPPORTED_ABIS[@]})
65 export PYVER_ALL="${tmpstr#Python }"
66 __python_version_extract $PYVER_ALL
67}
68 35
69# @FUNCTION: PYTHON 36# ================================================================================================
70# @USAGE: [-a|--absolute-path] <Python_ABI="${PYTHON_ABI}"> 37# ===================================== HANDLING OF METADATA =====================================
71# @DESCRIPTION: 38# ================================================================================================
72# Get Python interpreter filename for specified Python ABI. If Python_ABI argument 39
73# is ommitted, then PYTHON_ABI environment variable must be set and is used. 40_PYTHON_ABI_PATTERN_REGEX="([[:alnum:]]|\.|-|\*|\[|\])+"
74PYTHON() { 41
75 local absolute_path="0" slot= 42_python_check_python_abi_matching() {
43 local pattern patterns patterns_list="0" PYTHON_ABI
76 44
77 while (($#)); do 45 while (($#)); do
78 case "$1" in 46 case "$1" in
79 -a|--absolute-path) 47 --patterns-list)
80 absolute_path="1" 48 patterns_list="1"
49 ;;
50 --)
51 shift
52 break
81 ;; 53 ;;
82 -*) 54 -*)
83 die "${FUNCNAME}(): Unrecognized option $1" 55 die "${FUNCNAME}(): Unrecognized option '$1'"
84 ;; 56 ;;
85 *) 57 *)
86 break 58 break
87 ;; 59 ;;
88 esac 60 esac
89 shift 61 shift
90 done 62 done
91 63
92 if [[ "$#" -eq "0" ]]; then 64 if [[ "$#" -ne 2 ]]; then
93 if [[ -n "${PYTHON_ABI}" ]]; then 65 die "${FUNCNAME}() requires 2 arguments"
94 slot="${PYTHON_ABI}" 66 fi
67
68 PYTHON_ABI="$1"
69
70 if [[ "${patterns_list}" == "0" ]]; then
71 pattern="$2"
72
73 if [[ "${pattern}" == *"-cpython" ]]; then
74 [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ && "${PYTHON_ABI}" == ${pattern%-cpython} ]]
75 elif [[ "${pattern}" == *"-jython" ]]; then
76 [[ "${PYTHON_ABI}" == ${pattern} ]]
77 elif [[ "${pattern}" == *"-pypy-"* ]]; then
78 [[ "${PYTHON_ABI}" == ${pattern} ]]
95 else 79 else
96 die "${FUNCNAME}(): Invalid usage" 80 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
81 [[ "${PYTHON_ABI}" == ${pattern} ]]
82 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
83 [[ "${PYTHON_ABI%-jython}" == ${pattern} ]]
84 elif [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
85 [[ "${PYTHON_ABI%-pypy-*}" == ${pattern} ]]
86 else
87 die "${FUNCNAME}(): Unrecognized Python ABI '${PYTHON_ABI}'"
97 fi 88 fi
98 elif [[ "$#" -eq "1" ]]; then 89 fi
99 slot="$1"
100 else 90 else
101 die "${FUNCNAME}(): Invalid usage" 91 patterns="${2// /$'\n'}"
92
93 while read pattern; do
94 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
95 return 0
102 fi 96 fi
97 done <<< "${patterns}"
103 98
104 if [[ "${absolute_path}" == "1" ]]; then 99 return 1
105 echo -n "/usr/bin/python${slot}" 100 fi
101}
102
103_python_implementation() {
104 if [[ "${CATEGORY}/${PN}" == "dev-lang/python" ]]; then
105 return 0
106 elif [[ "${CATEGORY}/${PN}" == "dev-java/jython" ]]; then
107 return 0
108 elif [[ "${CATEGORY}/${PN}" == "dev-python/pypy" ]]; then
109 return 0
106 else 110 else
107 echo -n "python${slot}" 111 return 1
112 fi
113}
114
115_python_package_supporting_installation_for_multiple_python_abis() {
116 [[ -n "${SUPPORT_PYTHON_ABIS}" ]]
117}
118
119# @ECLASS-VARIABLE: PYTHON_DEPEND
120# @DESCRIPTION:
121# Specification of dependency on dev-lang/python.
122# Syntax:
123# PYTHON_DEPEND: [[!]USE_flag? ]<version_components_group>[ version_components_group]
124# version_components_group: <major_version[:[minimal_version][:maximal_version]]>
125# major_version: <2|3|*>
126# minimal_version: <minimal_major_version.minimal_minor_version>
127# maximal_version: <maximal_major_version.maximal_minor_version>
128
129_python_parse_PYTHON_DEPEND() {
130 local major_version maximal_version minimal_version python_all="0" python_maximal_version python_minimal_version python_versions=() python2="0" python2_maximal_version python2_minimal_version python3="0" python3_maximal_version python3_minimal_version USE_flag= version_components_group version_components_group_regex version_components_groups
131
132 version_components_group_regex="(2|3|\*)(:([[:digit:]]+\.[[:digit:]]+)?(:([[:digit:]]+\.[[:digit:]]+)?)?)?"
133 version_components_groups="${PYTHON_DEPEND}"
134
135 if [[ "${version_components_groups}" =~ ^((\!)?[[:alnum:]_-]+\?\ )?${version_components_group_regex}(\ ${version_components_group_regex})?$ ]]; then
136 if [[ "${version_components_groups}" =~ ^(\!)?[[:alnum:]_-]+\? ]]; then
137 USE_flag="${version_components_groups%\? *}"
138 version_components_groups="${version_components_groups#* }"
108 fi 139 fi
109} 140 if [[ "${version_components_groups}" =~ ("*".*" "|" *"|^2.*\ (2|\*)|^3.*\ (3|\*)) ]]; then
110 141 die "Invalid syntax of PYTHON_DEPEND: Incorrectly specified groups of versions"
111# @FUNCTION: validate_PYTHON_ABIS
112# @DESCRIPTION:
113# Make sure PYTHON_ABIS variable has valid value.
114validate_PYTHON_ABIS() {
115 # Ensure that /usr/bin/python and /usr/bin/python-config are valid.
116 if [[ "$(</usr/bin/python)" != *"Gentoo Python wrapper program"* ]]; then
117 die "/usr/bin/python isn't valid program"
118 fi 142 fi
119 if [[ "$(</usr/bin/python-config)" != *"Gentoo python-config wrapper script"* ]]; then
120 die "/usr/bin/python-config isn't valid script"
121 fi
122 143
123 # USE_${ABI_TYPE^^} and RESTRICT_${ABI_TYPE^^}_ABIS variables hopefully will be included in EAPI >= 4. 144 version_components_groups="${version_components_groups// /$'\n'}"
124 if [[ -z "${PYTHON_ABIS}" ]] && has "${EAPI:-0}" 0 1 2 3; then 145 while read version_components_group; do
125 local ABI support_ABI supported_PYTHON_ABIS= restricted_ABI 146 major_version="${version_components_group:0:1}"
126 PYTHON_ABI_SUPPORTED_VALUES="2.4 2.5 2.6 2.7 3.0 3.1 3.2" 147 minimal_version="${version_components_group:2}"
127 for ABI in ${USE_PYTHON}; do 148 minimal_version="${minimal_version%:*}"
128 if ! has "${ABI}" ${PYTHON_ABI_SUPPORTED_VALUES}; then 149 maximal_version="${version_components_group:$((3 + ${#minimal_version}))}"
129 ewarn "Ignoring unsupported Python ABI '${ABI}'" 150
130 continue 151 if [[ "${major_version}" =~ ^(2|3)$ ]]; then
152 if [[ -n "${minimal_version}" && "${major_version}" != "${minimal_version:0:1}" ]]; then
153 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' not in specified group of versions"
131 fi 154 fi
132 support_ABI="1" 155 if [[ -n "${maximal_version}" && "${major_version}" != "${maximal_version:0:1}" ]]; then
133 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do 156 die "Invalid syntax of PYTHON_DEPEND: Maximal version '${maximal_version}' not in specified group of versions"
134 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${ABI}', '${restricted_ABI}'))"; then 157 fi
135 support_ABI="0" 158 fi
136 break 159
160 if [[ "${major_version}" == "2" ]]; then
161 python2="1"
162 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
163 python2_minimal_version="${minimal_version}"
164 python2_maximal_version="${maximal_version}"
165 elif [[ "${major_version}" == "3" ]]; then
166 python3="1"
167 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
168 python3_minimal_version="${minimal_version}"
169 python3_maximal_version="${maximal_version}"
170 else
171 python_all="1"
172 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
173 python_minimal_version="${minimal_version}"
174 python_maximal_version="${maximal_version}"
175 fi
176
177 if [[ -n "${minimal_version}" ]] && ! has "${minimal_version}" "${python_versions[@]}"; then
178 die "Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '${minimal_version}'"
179 fi
180 if [[ -n "${maximal_version}" ]] && ! has "${maximal_version}" "${python_versions[@]}"; then
181 die "Invalid syntax of PYTHON_DEPEND: Unrecognized maximal version '${maximal_version}'"
182 fi
183
184 if [[ -n "${minimal_version}" && -n "${maximal_version}" && "${minimal_version}" > "${maximal_version}" ]]; then
185 die "Invalid syntax of PYTHON_DEPEND: Minimal version '${minimal_version}' greater than maximal version '${maximal_version}'"
186 fi
187 done <<< "${version_components_groups}"
188
189 _PYTHON_ATOMS=()
190
191 _append_accepted_versions_range() {
192 local accepted_version="0" i
193 for ((i = "${#python_versions[@]}"; i >= 0; i--)); do
194 if [[ "${python_versions[${i}]}" == "${python_maximal_version}" ]]; then
195 accepted_version="1"
196 fi
197 if [[ "${accepted_version}" == "1" ]]; then
198 _PYTHON_ATOMS+=("=dev-lang/python-${python_versions[${i}]}*")
199 fi
200 if [[ "${python_versions[${i}]}" == "${python_minimal_version}" ]]; then
201 accepted_version="0"
137 fi 202 fi
138 done 203 done
139 [[ "${support_ABI}" == "1" ]] && supported_PYTHON_ABIS+=" ${ABI}" 204 }
205
206 if [[ "${python_all}" == "1" ]]; then
207 if [[ -z "${python_minimal_version}" && -z "${python_maximal_version}" ]]; then
208 _PYTHON_ATOMS+=("dev-lang/python")
209 else
210 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
211 python_minimal_version="${python_minimal_version:-${python_versions[0]}}"
212 python_maximal_version="${python_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
213 _append_accepted_versions_range
214 fi
215 else
216 if [[ "${python3}" == "1" ]]; then
217 if [[ -z "${python3_minimal_version}" && -z "${python3_maximal_version}" ]]; then
218 _PYTHON_ATOMS+=("=dev-lang/python-3*")
219 else
220 python_versions=("${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}")
221 python_minimal_version="${python3_minimal_version:-${python_versions[0]}}"
222 python_maximal_version="${python3_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
223 _append_accepted_versions_range
224 fi
225 fi
226 if [[ "${python2}" == "1" ]]; then
227 if [[ -z "${python2_minimal_version}" && -z "${python2_maximal_version}" ]]; then
228 _PYTHON_ATOMS+=("=dev-lang/python-2*")
229 else
230 python_versions=("${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}")
231 python_minimal_version="${python2_minimal_version:-${python_versions[0]}}"
232 python_maximal_version="${python2_maximal_version:-${python_versions[${#python_versions[@]}-1]}}"
233 _append_accepted_versions_range
234 fi
235 fi
236 fi
237
238 unset -f _append_accepted_versions_range
239
240 if [[ "${#_PYTHON_ATOMS[@]}" -gt 1 ]]; then
241 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
242 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }|| ( ${_PYTHON_ATOMS[@]} )${USE_flag:+ )}"
243 else
244 DEPEND+="${DEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
245 RDEPEND+="${RDEPEND:+ }${USE_flag}${USE_flag:+? ( }${_PYTHON_ATOMS[@]}${USE_flag:+ )}"
246 fi
247 else
248 die "Invalid syntax of PYTHON_DEPEND"
249 fi
250}
251
252if _python_implementation; then
253 DEPEND=">=app-admin/eselect-python-20091230"
254 RDEPEND="${DEPEND}"
255 PDEPEND="app-admin/python-updater"
256fi
257
258if [[ -n "${PYTHON_DEPEND}" ]]; then
259 _python_parse_PYTHON_DEPEND
260else
261 _PYTHON_ATOMS=("dev-lang/python")
262fi
263unset -f _python_parse_PYTHON_DEPEND
264
265if [[ -n "${NEED_PYTHON}" ]]; then
266 eerror "Use PYTHON_DEPEND variable instead of NEED_PYTHON variable."
267 die "NEED_PYTHON variable is banned"
268fi
269
270# @ECLASS-VARIABLE: PYTHON_USE_WITH
271# @DESCRIPTION:
272# Set this to a space separated list of USE flags the Python slot in use must be built with.
273
274# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR
275# @DESCRIPTION:
276# Set this to a space separated list of USE flags of which one must be turned on for the slot in use.
277
278# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT
279# @DESCRIPTION:
280# Set this to a name of a USE flag if you need to make either PYTHON_USE_WITH or
281# PYTHON_USE_WITH_OR atoms conditional under a USE flag.
282
283if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
284 _PYTHON_USE_WITH_ATOMS_ARRAY=()
285 if [[ -n "${PYTHON_USE_WITH}" ]]; then
286 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
287 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${PYTHON_USE_WITH// /,}]")
140 done 288 done
141 export PYTHON_ABIS="${supported_PYTHON_ABIS# }" 289 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then
142 fi 290 for _USE_flag in ${PYTHON_USE_WITH_OR}; do
143 291 for _PYTHON_ATOM in "${_PYTHON_ATOMS[@]}"; do
144 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then 292 _PYTHON_USE_WITH_ATOMS_ARRAY+=("${_PYTHON_ATOM}[${_USE_flag}]")
145 python_version 293 done
146 export PYTHON_ABIS="${PYVER}" 294 done
147 fi 295 unset _USE_flag
148}
149
150# @FUNCTION: python_copy_sources
151# @USAGE: [directory]
152# @DESCRIPTION:
153# Copy unpacked sources of given package for each Python ABI.
154python_copy_sources() {
155 local dir dirs=() PYTHON_ABI
156
157 if [[ "$#" -eq "0" ]]; then
158 if [[ "${WORKDIR}" == "${S}" ]]; then
159 die "${FUNCNAME}() cannot be used"
160 fi 296 fi
161 dirs="${S}" 297 if [[ "${#_PYTHON_USE_WITH_ATOMS_ARRAY[@]}" -gt 1 ]]; then
298 _PYTHON_USE_WITH_ATOMS="|| ( ${_PYTHON_USE_WITH_ATOMS_ARRAY[@]} )"
162 else 299 else
163 dirs="$@" 300 _PYTHON_USE_WITH_ATOMS="${_PYTHON_USE_WITH_ATOMS_ARRAY[@]}"
301 fi
302 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
303 _PYTHON_USE_WITH_ATOMS="${PYTHON_USE_WITH_OPT}? ( ${_PYTHON_USE_WITH_ATOMS} )"
304 fi
305 DEPEND+="${DEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
306 RDEPEND+="${RDEPEND:+ }${_PYTHON_USE_WITH_ATOMS}"
307 unset _PYTHON_ATOM _PYTHON_USE_WITH_ATOMS _PYTHON_USE_WITH_ATOMS_ARRAY
308fi
309
310unset _PYTHON_ATOMS
311
312# ================================================================================================
313# =================================== MISCELLANEOUS FUNCTIONS ====================================
314# ================================================================================================
315
316_python_abi-specific_local_scope() {
317 [[ " ${FUNCNAME[@]:2} " =~ " "(_python_final_sanity_checks|python_execute_function|python_mod_optimize|python_mod_cleanup)" " ]]
318}
319
320_python_initialize_prefix_variables() {
321 if has "${EAPI:-0}" 0 1 2; then
322 if [[ -n "${ROOT}" && -z "${EROOT}" ]]; then
323 EROOT="${ROOT%/}${EPREFIX}/"
164 fi 324 fi
325 if [[ -n "${D}" && -z "${ED}" ]]; then
326 ED="${D%/}${EPREFIX}/"
327 fi
328 fi
329}
165 330
166 validate_PYTHON_ABIS 331unset PYTHON_SANITY_CHECKS_EXECUTED PYTHON_SKIP_SANITY_CHECKS
332
333_python_initial_sanity_checks() {
334 if [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
335 # Ensure that /usr/bin/python and /usr/bin/python-config are valid.
336 if [[ "$(readlink "${EPREFIX}/usr/bin/python")" != "python-wrapper" ]]; then
337 eerror "'${EPREFIX}/usr/bin/python' is not valid symlink."
338 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
339 die "'${EPREFIX}/usr/bin/python' is not valid symlink"
340 fi
341 if [[ "$(<"${EPREFIX}/usr/bin/python-config")" != *"Gentoo python-config wrapper script"* ]]; then
342 eerror "'${EPREFIX}/usr/bin/python-config' is not valid script"
343 eerror "Use \`eselect python set \${python_interpreter}\` to fix this problem."
344 die "'${EPREFIX}/usr/bin/python-config' is not valid script"
345 fi
346 fi
347}
348
349_python_final_sanity_checks() {
350 if ! _python_implementation && [[ "$(declare -p PYTHON_SANITY_CHECKS_EXECUTED 2> /dev/null)" != "declare -- PYTHON_SANITY_CHECKS_EXECUTED="* || " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " && -z "${PYTHON_SKIP_SANITY_CHECKS}" ]]; then
351 local PYTHON_ABI="${PYTHON_ABI}"
167 for PYTHON_ABI in ${PYTHON_ABIS}; do 352 for PYTHON_ABI in ${PYTHON_ABIS-${PYTHON_ABI}}; do
168 for dir in "${dirs[@]}"; do 353 # Ensure that appropriate version of Python is installed.
169 cp -lpr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed" 354 if ! has_version "$(python_get_implementational_package)"; then
355 die "$(python_get_implementational_package) is not installed"
356 fi
357
358 # Ensure that EPYTHON variable is respected.
359 if [[ "$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")" != "${PYTHON_ABI}" ]]; then
360 eerror "Path to 'python': '$(type -p python)'"
361 eerror "ABI: '${ABI}'"
362 eerror "DEFAULT_ABI: '${DEFAULT_ABI}'"
363 eerror "EPYTHON: '$(PYTHON)'"
364 eerror "PYTHON_ABI: '${PYTHON_ABI}'"
365 eerror "Locally active version of Python: '$(EPYTHON="$(PYTHON)" python -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")'"
366 die "'python' does not respect EPYTHON variable"
367 fi
170 done 368 done
369 fi
370 PYTHON_SANITY_CHECKS_EXECUTED="1"
371}
372
373# @ECLASS-VARIABLE: PYTHON_COLORS
374# @DESCRIPTION:
375# User-configurable colored output.
376PYTHON_COLORS="${PYTHON_COLORS:-0}"
377
378_python_set_color_variables() {
379 if [[ "${PYTHON_COLORS}" != "0" && "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then
380 _BOLD=$'\e[1m'
381 _RED=$'\e[1;31m'
382 _GREEN=$'\e[1;32m'
383 _BLUE=$'\e[1;34m'
384 _CYAN=$'\e[1;36m'
385 _NORMAL=$'\e[0m'
386 else
387 _BOLD=
388 _RED=
389 _GREEN=
390 _BLUE=
391 _CYAN=
392 _NORMAL=
393 fi
394}
395
396_python_check_python_pkg_setup_execution() {
397 [[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
398
399 if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
400 die "python_pkg_setup() not called"
401 fi
402}
403
404# @FUNCTION: python_pkg_setup
405# @DESCRIPTION:
406# Perform sanity checks and initialize environment.
407#
408# This function is exported in EAPI 2 and 3 when PYTHON_USE_WITH or PYTHON_USE_WITH_OR variable
409# is set and always in EAPI >=4. Calling of this function is mandatory in EAPI >=4.
410python_pkg_setup() {
411 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
412 die "${FUNCNAME}() can be used only in pkg_setup() phase"
413 fi
414
415 if [[ "$#" -ne 0 ]]; then
416 die "${FUNCNAME}() does not accept arguments"
417 fi
418
419 export JYTHON_SYSTEM_CACHEDIR="1"
420 addwrite "${EPREFIX}/var/cache/jython"
421
422 if _python_package_supporting_installation_for_multiple_python_abis; then
423 _python_calculate_PYTHON_ABIS
424 export EPYTHON="$(PYTHON -f)"
425 else
426 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
427 fi
428
429 if ! has "${EAPI:-0}" 0 1 && [[ -n "${PYTHON_USE_WITH}" || -n "${PYTHON_USE_WITH_OR}" ]]; then
430 if [[ "${PYTHON_USE_WITH_OPT}" ]]; then
431 if [[ "${PYTHON_USE_WITH_OPT}" == !* ]]; then
432 use ${PYTHON_USE_WITH_OPT#!} && return
433 else
434 use !${PYTHON_USE_WITH_OPT} && return
435 fi
436 fi
437
438 python_pkg_setup_check_USE_flags() {
439 local python_atom USE_flag
440 python_atom="$(python_get_implementational_package)"
441
442 for USE_flag in ${PYTHON_USE_WITH}; do
443 if ! has_version "${python_atom}[${USE_flag}]"; then
444 eerror "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
445 die "Please rebuild ${python_atom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
446 fi
447 done
448
449 for USE_flag in ${PYTHON_USE_WITH_OR}; do
450 if has_version "${python_atom}[${USE_flag}]"; then
451 return
452 fi
453 done
454
455 if [[ ${PYTHON_USE_WITH_OR} ]]; then
456 eerror "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
457 die "Please rebuild ${python_atom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
458 fi
459 }
460
461 if _python_package_supporting_installation_for_multiple_python_abis; then
462 PYTHON_SKIP_SANITY_CHECKS="1" python_execute_function -q python_pkg_setup_check_USE_flags
463 else
464 python_pkg_setup_check_USE_flags
465 fi
466
467 unset -f python_pkg_setup_check_USE_flags
468 fi
469
470 PYTHON_PKG_SETUP_EXECUTED="1"
471}
472
473_PYTHON_SHEBANG_BASE_PART_REGEX='^#![[:space:]]*([^[:space:]]*/usr/bin/env[[:space:]]+)?([^[:space:]]*/)?(jython|pypy-c|python)'
474
475# @FUNCTION: python_convert_shebangs
476# @USAGE: [-q|--quiet] [-r|--recursive] [-x|--only-executables] [--] <Python_ABI|Python_version> <file|directory> [files|directories]
477# @DESCRIPTION:
478# Convert shebangs in specified files. Directories can be specified only with --recursive option.
479python_convert_shebangs() {
480 _python_check_python_pkg_setup_execution
481
482 local argument file files=() only_executables="0" python_interpreter quiet="0" recursive="0" shebangs_converted="0"
483
484 while (($#)); do
485 case "$1" in
486 -r|--recursive)
487 recursive="1"
488 ;;
489 -q|--quiet)
490 quiet="1"
491 ;;
492 -x|--only-executables)
493 only_executables="1"
494 ;;
495 --)
496 shift
497 break
498 ;;
499 -*)
500 die "${FUNCNAME}(): Unrecognized option '$1'"
501 ;;
502 *)
503 break
504 ;;
505 esac
506 shift
507 done
508
509 if [[ "$#" -eq 0 ]]; then
510 die "${FUNCNAME}(): Missing Python version and files or directories"
511 elif [[ "$#" -eq 1 ]]; then
512 die "${FUNCNAME}(): Missing files or directories"
513 fi
514
515 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
516 python_interpreter="$(PYTHON "$1")"
517 else
518 python_interpreter="python$1"
519 fi
520 shift
521
522 for argument in "$@"; do
523 if [[ ! -e "${argument}" ]]; then
524 die "${FUNCNAME}(): '${argument}' does not exist"
525 elif [[ -f "${argument}" ]]; then
526 files+=("${argument}")
527 elif [[ -d "${argument}" ]]; then
528 if [[ "${recursive}" == "1" ]]; then
529 while read -d $'\0' -r file; do
530 files+=("${file}")
531 done < <(find "${argument}" $([[ "${only_executables}" == "1" ]] && echo -perm /111) -type f -print0)
532 else
533 die "${FUNCNAME}(): '${argument}' is not a regular file"
534 fi
535 else
536 die "${FUNCNAME}(): '${argument}' is not a regular file or a directory"
537 fi
538 done
539
540 for file in "${files[@]}"; do
541 file="${file#./}"
542 [[ "${only_executables}" == "1" && ! -x "${file}" ]] && continue
543
544 if [[ "$(head -n1 "${file}")" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX} ]]; then
545 [[ "$(sed -ne "2p" "${file}")" =~ ^"# Gentoo '".*"' wrapper script generated by python_generate_wrapper_scripts()"$ ]] && continue
546
547 shebangs_converted="1"
548
549 if [[ "${quiet}" == "0" ]]; then
550 einfo "Converting shebang in '${file}'"
551 fi
552
553 sed -e "1s:^#![[:space:]]*\([^[:space:]]*/usr/bin/env[[:space:]]\)\?[[:space:]]*\([^[:space:]]*/\)\?\(jython\|pypy-c\|python\)\([[:digit:]]\+\(\.[[:digit:]]\+\)\?\)\?\(\$\|[[:space:]].*\):#!\1\2${python_interpreter}\6:" -i "${file}" || die "Conversion of shebang in '${file}' failed"
554 fi
555 done
556
557 if [[ "${shebangs_converted}" == "0" ]]; then
558 ewarn "${FUNCNAME}(): Python scripts not found"
559 fi
560}
561
562# @FUNCTION: python_clean_py-compile_files
563# @USAGE: [-q|--quiet]
564# @DESCRIPTION:
565# Clean py-compile files to disable byte-compilation.
566python_clean_py-compile_files() {
567 _python_check_python_pkg_setup_execution
568
569 local file files=() quiet="0"
570
571 while (($#)); do
572 case "$1" in
573 -q|--quiet)
574 quiet="1"
575 ;;
576 -*)
577 die "${FUNCNAME}(): Unrecognized option '$1'"
578 ;;
579 *)
580 die "${FUNCNAME}(): Invalid usage"
581 ;;
582 esac
583 shift
584 done
585
586 while read -d $'\0' -r file; do
587 files+=("${file#./}")
588 done < <(find -name py-compile -type f -print0)
589
590 for file in "${files[@]}"; do
591 if [[ "${quiet}" == "0" ]]; then
592 einfo "Cleaning '${file}' file"
593 fi
594 echo "#!/bin/sh" > "${file}"
595 done
596}
597
598# @FUNCTION: python_clean_installation_image
599# @USAGE: [-q|--quiet]
600# @DESCRIPTION:
601# Delete needless files in installation image.
602#
603# This function can be used only in src_install() phase.
604python_clean_installation_image() {
605 if [[ "${EBUILD_PHASE}" != "install" ]]; then
606 die "${FUNCNAME}() can be used only in src_install() phase"
607 fi
608
609 _python_check_python_pkg_setup_execution
610 _python_initialize_prefix_variables
611
612 local file files=() quiet="0"
613
614 while (($#)); do
615 case "$1" in
616 -q|--quiet)
617 quiet="1"
618 ;;
619 -*)
620 die "${FUNCNAME}(): Unrecognized option '$1'"
621 ;;
622 *)
623 die "${FUNCNAME}(): Invalid usage"
624 ;;
625 esac
626 shift
627 done
628
629 while read -d $'\0' -r file; do
630 files+=("${file}")
631 done < <(find "${ED}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -type f -print0)
632
633 if [[ "${#files[@]}" -gt 0 ]]; then
634 if [[ "${quiet}" == "0" ]]; then
635 ewarn "Deleting byte-compiled Python modules needlessly generated by build system:"
636 fi
637 for file in "${files[@]}"; do
638 if [[ "${quiet}" == "0" ]]; then
639 ewarn " ${file}"
640 fi
641 rm -f "${file}"
642
643 # Delete empty __pycache__ directories.
644 if [[ "${file%/*}" == *"/__pycache__" ]]; then
645 rmdir "${file%/*}" 2> /dev/null
646 fi
171 done 647 done
172} 648 fi
173 649
174# @FUNCTION: python_set_build_dir_symlink 650 python_clean_sitedirs() {
175# @USAGE: [directory="build"] 651 if [[ -d "${ED}$(python_get_sitedir)" ]]; then
176# @DESCRIPTION: 652 find "${ED}$(python_get_sitedir)" "(" -name "*.c" -o -name "*.h" -o -name "*.la" ")" -type f -print0 | xargs -0 rm -f
177# Create build directory symlink. 653 fi
178python_set_build_dir_symlink() { 654 }
179 local dir="$1" 655 if _python_package_supporting_installation_for_multiple_python_abis; then
656 python_execute_function -q python_clean_sitedirs
657 else
658 python_clean_sitedirs
659 fi
180 660
181 [[ -z "${PYTHON_ABIS}" ]] && die "PYTHON_ABIS variable not set" 661 unset -f python_clean_sitedirs
182 [[ -z "${dir}" ]] && dir="build" 662}
183 663
184 # Don't delete preexistent directories. 664# ================================================================================================
185 rm -f "${dir}" || die "Deletion of '${dir}' failed" 665# =========== FUNCTIONS FOR PACKAGES SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ============
186 ln -s "${dir}-${PYTHON_ABI}" "${dir}" || die "Creation of '${dir}' directory symlink failed" 666# ================================================================================================
667
668# @ECLASS-VARIABLE: SUPPORT_PYTHON_ABIS
669# @DESCRIPTION:
670# Set this in EAPI <= 4 to indicate that current package supports installation for
671# multiple Python ABIs.
672
673# @ECLASS-VARIABLE: PYTHON_TESTS_RESTRICTED_ABIS
674# @DESCRIPTION:
675# Space-separated list of Python ABI patterns. Testing in Python ABIs matching any Python ABI
676# patterns specified in this list is skipped.
677
678# @ECLASS-VARIABLE: PYTHON_EXPORT_PHASE_FUNCTIONS
679# @DESCRIPTION:
680# Set this to export phase functions for the following ebuild phases:
681# src_prepare(), src_configure(), src_compile(), src_test(), src_install().
682if ! has "${EAPI:-0}" 0 1; then
683 python_src_prepare() {
684 if [[ "${EBUILD_PHASE}" != "prepare" ]]; then
685 die "${FUNCNAME}() can be used only in src_prepare() phase"
686 fi
687
688 if ! _python_package_supporting_installation_for_multiple_python_abis; then
689 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
690 fi
691
692 _python_check_python_pkg_setup_execution
693
694 if [[ "$#" -ne 0 ]]; then
695 die "${FUNCNAME}() does not accept arguments"
696 fi
697
698 python_copy_sources
699 }
700
701 for python_default_function in src_configure src_compile src_test; do
702 eval "python_${python_default_function}() {
703 if [[ \"\${EBUILD_PHASE}\" != \"${python_default_function#src_}\" ]]; then
704 die \"\${FUNCNAME}() can be used only in ${python_default_function}() phase\"
705 fi
706
707 if ! _python_package_supporting_installation_for_multiple_python_abis; then
708 die \"\${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs\"
709 fi
710
711 _python_check_python_pkg_setup_execution
712
713 python_execute_function -d -s -- \"\$@\"
714 }"
715 done
716 unset python_default_function
717
718 python_src_install() {
719 if [[ "${EBUILD_PHASE}" != "install" ]]; then
720 die "${FUNCNAME}() can be used only in src_install() phase"
721 fi
722
723 if ! _python_package_supporting_installation_for_multiple_python_abis; then
724 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
725 fi
726
727 _python_check_python_pkg_setup_execution
728
729 if has "${EAPI:-0}" 0 1 2 3; then
730 python_execute_function -d -s -- "$@"
731 else
732 python_installation() {
733 emake DESTDIR="${T}/images/${PYTHON_ABI}" install "$@"
734 }
735 python_execute_function -s python_installation "$@"
736 unset python_installation
737
738 python_merge_intermediate_installation_images "${T}/images"
739 fi
740 }
741
742 if [[ -n "${PYTHON_EXPORT_PHASE_FUNCTIONS}" ]]; then
743 EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
744 fi
745fi
746
747unset PYTHON_ABIS
748
749_python_calculate_PYTHON_ABIS() {
750 if ! _python_package_supporting_installation_for_multiple_python_abis; then
751 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
752 fi
753
754 _python_initial_sanity_checks
755
756 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3 4; then
757 local PYTHON_ABI
758
759 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
760 local cpython_enabled="0"
761
762 if [[ -z "${USE_PYTHON}" ]]; then
763 die "USE_PYTHON variable is empty"
764 fi
765
766 for PYTHON_ABI in ${USE_PYTHON}; do
767 if ! has "${PYTHON_ABI}" "${_PYTHON_GLOBALLY_SUPPORTED_ABIS[@]}"; then
768 die "USE_PYTHON variable contains invalid value '${PYTHON_ABI}'"
769 fi
770
771 if has "${PYTHON_ABI}" "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; then
772 cpython_enabled="1"
773 fi
774
775 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
776 export PYTHON_ABIS+="${PYTHON_ABIS:+ }${PYTHON_ABI}"
777 fi
778 done
779
780 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
781 die "USE_PYTHON variable does not enable any Python ABI supported by ${CATEGORY}/${PF}"
782 fi
783
784 if [[ "${cpython_enabled}" == "0" ]]; then
785 die "USE_PYTHON variable does not enable any CPython ABI"
786 fi
787 else
788 local python_version python2_version python3_version support_python_major_version
789
790 if ! has_version "dev-lang/python"; then
791 die "${FUNCNAME}(): 'dev-lang/python' is not installed"
792 fi
793
794 python_version="$("${EPREFIX}/usr/bin/python" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
795
796 if has_version "=dev-lang/python-2*"; then
797 if [[ "$(readlink "${EPREFIX}/usr/bin/python2")" != "python2."* ]]; then
798 die "'${EPREFIX}/usr/bin/python2' is not valid symlink"
799 fi
800
801 python2_version="$("${EPREFIX}/usr/bin/python2" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
802
803 support_python_major_version="0"
804 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
805 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
806 support_python_major_version="1"
807 break
808 fi
809 done
810 if [[ "${support_python_major_version}" == "1" ]]; then
811 if _python_check_python_abi_matching --patterns-list "${python2_version}" "${RESTRICT_PYTHON_ABIS}"; then
812 die "Active version of CPython 2 is not supported by ${CATEGORY}/${PF}"
813 fi
814 else
815 python2_version=""
816 fi
817 fi
818
819 if has_version "=dev-lang/python-3*"; then
820 if [[ "$(readlink "${EPREFIX}/usr/bin/python3")" != "python3."* ]]; then
821 die "'${EPREFIX}/usr/bin/python3' is not valid symlink"
822 fi
823
824 python3_version="$("${EPREFIX}/usr/bin/python3" -c 'from sys import version_info; print(".".join(str(x) for x in version_info[:2]))')"
825
826 support_python_major_version="0"
827 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
828 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
829 support_python_major_version="1"
830 break
831 fi
832 done
833 if [[ "${support_python_major_version}" == "1" ]]; then
834 if _python_check_python_abi_matching --patterns-list "${python3_version}" "${RESTRICT_PYTHON_ABIS}"; then
835 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
836 fi
837 else
838 python3_version=""
839 fi
840 fi
841
842 if [[ -z "${python2_version}" && -z "${python3_version}" ]]; then
843 eerror "${CATEGORY}/${PF} requires at least one of the following packages:"
844 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
845 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
846 eerror " dev-lang/python:${PYTHON_ABI}"
847 fi
848 done
849 die "No supported version of CPython installed"
850 fi
851
852 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
853 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
854 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
855 die "Incorrect configuration of Python"
856 fi
857 if [[ -n "${python3_version}" && "${python_version}" == "3."* && "${python_version}" != "${python3_version}" ]]; then
858 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python3' symlink"
859 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."
860 die "Incorrect configuration of Python"
861 fi
862
863 PYTHON_ABIS="${python2_version} ${python3_version}"
864 PYTHON_ABIS="${PYTHON_ABIS# }"
865 export PYTHON_ABIS="${PYTHON_ABIS% }"
866 fi
867 fi
868
869 _python_final_sanity_checks
870}
871
872_python_prepare_flags() {
873 local array=() deleted_flag element flags new_value old_flag old_value operator pattern prefix variable
874
875 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
876 eval "_PYTHON_SAVED_${variable}=\"\${!variable}\""
877 for prefix in PYTHON_USER_ PYTHON_; do
878 if [[ "$(declare -p ${prefix}${variable} 2> /dev/null)" == "declare -a ${prefix}${variable}="* ]]; then
879 eval "array=(\"\${${prefix}${variable}[@]}\")"
880 for element in "${array[@]}"; do
881 if [[ "${element}" =~ ^${_PYTHON_ABI_PATTERN_REGEX}\ (\+|-)\ .+ ]]; then
882 pattern="${element%% *}"
883 element="${element#* }"
884 operator="${element%% *}"
885 flags="${element#* }"
886 if _python_check_python_abi_matching "${PYTHON_ABI}" "${pattern}"; then
887 if [[ "${operator}" == "+" ]]; then
888 eval "export ${variable}+=\"\${variable:+ }${flags}\""
889 elif [[ "${operator}" == "-" ]]; then
890 flags="${flags// /$'\n'}"
891 old_value="${!variable// /$'\n'}"
892 new_value=""
893 while read old_flag; do
894 while read deleted_flag; do
895 if [[ "${old_flag}" == ${deleted_flag} ]]; then
896 continue 2
897 fi
898 done <<< "${flags}"
899 new_value+="${new_value:+ }${old_flag}"
900 done <<< "${old_value}"
901 eval "export ${variable}=\"\${new_value}\""
902 fi
903 fi
904 else
905 die "Element '${element}' of ${prefix}${variable} array has invalid syntax"
906 fi
907 done
908 elif [[ -n "$(declare -p ${prefix}${variable} 2> /dev/null)" ]]; then
909 die "${prefix}${variable} should be indexed array"
910 fi
911 done
912 done
913}
914
915_python_restore_flags() {
916 local variable
917
918 for variable in CPPFLAGS CFLAGS CXXFLAGS LDFLAGS; do
919 eval "${variable}=\"\${_PYTHON_SAVED_${variable}}\""
920 unset _PYTHON_SAVED_${variable}
921 done
187} 922}
188 923
189# @FUNCTION: python_execute_function 924# @FUNCTION: python_execute_function
190# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] <function> [arguments] 925# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [-f|--final-ABI] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--source-dir source_directory] [--] <function> [arguments]
191# @DESCRIPTION: 926# @DESCRIPTION:
192# Execute specified function for each value of PYTHON_ABIS, optionally passing additional 927# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
193# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables. 928# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
194python_execute_function() { 929python_execute_function() {
195 local action action_message action_message_template= default_function="0" failure_message failure_message_template= function nonfatal="0" PYTHON_ABI quiet="0" separate_build_dirs="0" 930 if ! _python_package_supporting_installation_for_multiple_python_abis; then
931 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
932 fi
933
934 _python_check_python_pkg_setup_execution
935 _python_set_color_variables
936
937 local action action_message action_message_template default_function="0" failure_message failure_message_template final_ABI="0" function iterated_PYTHON_ABIS nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" return_code separate_build_dirs="0" source_dir
196 938
197 while (($#)); do 939 while (($#)); do
198 case "$1" in 940 case "$1" in
199 --action-message) 941 --action-message)
200 action_message_template="$2" 942 action_message_template="$2"
205 ;; 947 ;;
206 --failure-message) 948 --failure-message)
207 failure_message_template="$2" 949 failure_message_template="$2"
208 shift 950 shift
209 ;; 951 ;;
952 -f|--final-ABI)
953 final_ABI="1"
954 ;;
210 --nonfatal) 955 --nonfatal)
211 nonfatal="1" 956 nonfatal="1"
212 ;; 957 ;;
213 -q|--quiet) 958 -q|--quiet)
214 quiet="1" 959 quiet="1"
215 ;; 960 ;;
216 -s|--separate-build-dirs) 961 -s|--separate-build-dirs)
217 separate_build_dirs="1" 962 separate_build_dirs="1"
218 ;; 963 ;;
964 --source-dir)
965 source_dir="$2"
966 shift
967 ;;
968 --)
969 shift
970 break
971 ;;
219 -*) 972 -*)
220 die "${FUNCNAME}(): Unrecognized option $1" 973 die "${FUNCNAME}(): Unrecognized option '$1'"
221 ;; 974 ;;
222 *) 975 *)
223 break 976 break
224 ;; 977 ;;
225 esac 978 esac
226 shift 979 shift
227 done 980 done
228 981
982 if [[ -n "${source_dir}" && "${separate_build_dirs}" == 0 ]]; then
983 die "${FUNCNAME}(): '--source-dir' option can be specified only with '--separate-build-dirs' option"
984 fi
985
229 if [[ "${default_function}" == "0" ]]; then 986 if [[ "${default_function}" == "0" ]]; then
230 if [[ "$#" -eq "0" ]]; then 987 if [[ "$#" -eq 0 ]]; then
231 die "${FUNCNAME}(): Missing function name" 988 die "${FUNCNAME}(): Missing function name"
232 fi 989 fi
233 function="$1" 990 function="$1"
234 shift 991 shift
992
993 if [[ -z "$(type -t "${function}")" ]]; then
994 die "${FUNCNAME}(): '${function}' function is not defined"
995 fi
235 else 996 else
236 if [[ "$#" -ne "0" ]]; then
237 die "${FUNCNAME}(): --default-function option and function name cannot be specified simultaneously"
238 fi
239 if has "${EAPI:-0}" 0 1; then 997 if has "${EAPI:-0}" 0 1; then
240 die "${FUNCNAME}(): --default-function option cannot be used in this EAPI" 998 die "${FUNCNAME}(): '--default-function' option cannot be used in this EAPI"
241 fi 999 fi
242 1000
243 if [[ "${EBUILD_PHASE}" == "configure" ]]; then 1001 if [[ "${EBUILD_PHASE}" == "configure" ]]; then
1002 if has "${EAPI}" 2 3; then
244 python_default_function() { 1003 python_default_function() {
245 econf 1004 econf "$@"
246 } 1005 }
1006 else
1007 python_default_function() {
1008 nonfatal econf "$@"
1009 }
1010 fi
247 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then 1011 elif [[ "${EBUILD_PHASE}" == "compile" ]]; then
248 python_default_function() { 1012 python_default_function() {
249 emake 1013 emake "$@"
250 } 1014 }
251 elif [[ "${EBUILD_PHASE}" == "test" ]]; then 1015 elif [[ "${EBUILD_PHASE}" == "test" ]]; then
252 python_default_function() { 1016 python_default_function() {
1017 # Stolen from portage's _eapi0_src_test()
1018 local emake_cmd="${MAKE:-make} ${MAKEOPTS} ${EXTRA_EMAKE}"
253 if emake -j1 -n check &> /dev/null; then 1019 if ${emake_cmd} -j1 -n check &> /dev/null; then
254 emake -j1 check 1020 ${emake_cmd} -j1 check "$@"
255 elif emake -j1 -n test &> /dev/null; then 1021 elif ${emake_cmd} -j1 -n test &> /dev/null; then
256 emake -j1 test 1022 ${emake_cmd} -j1 test "$@"
257 fi 1023 fi
258 } 1024 }
259 elif [[ "${EBUILD_PHASE}" == "install" ]]; then 1025 elif [[ "${EBUILD_PHASE}" == "install" ]]; then
260 python_default_function() { 1026 python_default_function() {
261 emake DESTDIR="${D}" install 1027 emake DESTDIR="${D}" install "$@"
262 } 1028 }
263 else 1029 else
264 die "${FUNCNAME}(): --default-function option cannot be used in this ebuild phase" 1030 die "${FUNCNAME}(): '--default-function' option cannot be used in this ebuild phase"
265 fi 1031 fi
266 function="python_default_function" 1032 function="python_default_function"
1033 fi
1034
1035 # Ensure that python_execute_function() cannot be directly or indirectly called by python_execute_function().
1036 if _python_abi-specific_local_scope; then
1037 die "${FUNCNAME}(): Invalid call stack"
267 fi 1038 fi
268 1039
269 if [[ "${quiet}" == "0" ]]; then 1040 if [[ "${quiet}" == "0" ]]; then
270 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up" 1041 [[ "${EBUILD_PHASE}" == "setup" ]] && action="Setting up"
271 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking" 1042 [[ "${EBUILD_PHASE}" == "unpack" ]] && action="Unpacking"
278 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation" 1049 [[ "${EBUILD_PHASE}" == "postinst" ]] && action="Postinstallation"
279 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation" 1050 [[ "${EBUILD_PHASE}" == "prerm" ]] && action="Preuninstallation"
280 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation" 1051 [[ "${EBUILD_PHASE}" == "postrm" ]] && action="Postuninstallation"
281 fi 1052 fi
282 1053
283 local RED GREEN BLUE NORMAL 1054 _python_calculate_PYTHON_ABIS
284 if [[ "${NOCOLOR:-false}" =~ ^(false|no)$ ]]; then 1055 if [[ "${final_ABI}" == "1" ]]; then
285 RED=$'\e[1;31m' 1056 iterated_PYTHON_ABIS="$(PYTHON -f --ABI)"
286 GREEN=$'\e[1;32m'
287 BLUE=$'\e[1;34m'
288 NORMAL=$'\e[0m'
289 else 1057 else
290 RED= 1058 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
291 GREEN=
292 BLUE=
293 NORMAL=
294 fi 1059 fi
295
296 validate_PYTHON_ABIS
297 for PYTHON_ABI in ${PYTHON_ABIS}; do 1060 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
1061 if [[ "${EBUILD_PHASE}" == "test" ]] && _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${PYTHON_TESTS_RESTRICTED_ABIS}"; then
1062 if [[ "${quiet}" == "0" ]]; then
1063 echo " ${_GREEN}*${_NORMAL} ${_BLUE}Testing of ${CATEGORY}/${PF} with $(python_get_implementation_and_version) skipped${_NORMAL}"
1064 fi
1065 continue
1066 fi
1067
1068 _python_prepare_flags
1069
298 if [[ "${quiet}" == "0" ]]; then 1070 if [[ "${quiet}" == "0" ]]; then
299 if [[ -n "${action_message_template}" ]]; then 1071 if [[ -n "${action_message_template}" ]]; then
300 action_message="$(eval echo -n "${action_message_template}")" 1072 eval "action_message=\"${action_message_template}\""
301 else 1073 else
302 action_message="${action} of ${CATEGORY}/${PF} with Python ${PYTHON_ABI}..." 1074 action_message="${action} of ${CATEGORY}/${PF} with $(python_get_implementation_and_version)..."
303 fi 1075 fi
304 echo " ${GREEN}*${NORMAL} ${BLUE}${action_message}${NORMAL}" 1076 echo " ${_GREEN}*${_NORMAL} ${_BLUE}${action_message}${_NORMAL}"
305 fi 1077 fi
1078
306 if [[ "${separate_build_dirs}" == "1" ]]; then 1079 if [[ "${separate_build_dirs}" == "1" ]]; then
1080 if [[ -n "${source_dir}" ]]; then
1081 export BUILDDIR="${S}/${source_dir}-${PYTHON_ABI}"
1082 else
307 export BUILDDIR="${S}-${PYTHON_ABI}" 1083 export BUILDDIR="${S}-${PYTHON_ABI}"
1084 fi
308 pushd "${BUILDDIR}" > /dev/null || die "pushd failed" 1085 pushd "${BUILDDIR}" > /dev/null || die "pushd failed"
309 else 1086 else
310 export BUILDDIR="${S}" 1087 export BUILDDIR="${S}"
311 fi 1088 fi
1089
1090 previous_directory="$(pwd)"
1091 previous_directory_stack="$(dirs -p)"
1092 previous_directory_stack_length="$(dirs -p | wc -l)"
1093
1094 if ! has "${EAPI}" 0 1 2 3 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1095 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@"
1096 else
312 if ! EPYTHON="$(PYTHON)" "${function}" "$@"; then 1097 EPYTHON="$(PYTHON)" "${function}" "$@"
1098 fi
1099
1100 return_code="$?"
1101
1102 _python_restore_flags
1103
1104 if [[ "${return_code}" -ne 0 ]]; then
313 if [[ -n "${failure_message_template}" ]]; then 1105 if [[ -n "${failure_message_template}" ]]; then
314 failure_message="$(eval echo -n "${failure_message_template}")" 1106 eval "failure_message=\"${failure_message_template}\""
315 else 1107 else
316 failure_message="${action} failed with Python ${PYTHON_ABI} in ${function}() function" 1108 failure_message="${action} failed with $(python_get_implementation_and_version) in ${function}() function"
317 fi 1109 fi
318 if [[ "${nonfatal}" == "1" ]] || has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then 1110
319 local ABI enabled_PYTHON_ABIS 1111 if [[ "${nonfatal}" == "1" ]]; then
320 for ABI in ${PYTHON_ABIS}; do
321 [[ "${ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+=" ${ABI}"
322 done
323 export PYTHON_ABIS="${enabled_PYTHON_ABIS# }"
324 if [[ "${quiet}" == "0" ]]; then 1112 if [[ "${quiet}" == "0" ]]; then
325 ewarn "${RED}${failure_message}${NORMAL}" 1113 ewarn "${failure_message}"
1114 fi
1115 elif [[ "${final_ABI}" == "0" ]] && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
1116 if [[ "${EBUILD_PHASE}" != "test" ]] || ! has test-fail-continue ${FEATURES}; then
1117 local enabled_PYTHON_ABIS= other_PYTHON_ABI
1118 for other_PYTHON_ABI in ${PYTHON_ABIS}; do
1119 [[ "${other_PYTHON_ABI}" != "${PYTHON_ABI}" ]] && enabled_PYTHON_ABIS+="${enabled_PYTHON_ABIS:+ }${other_PYTHON_ABI}"
1120 done
1121 export PYTHON_ABIS="${enabled_PYTHON_ABIS}"
1122 fi
1123 if [[ "${quiet}" == "0" ]]; then
1124 ewarn "${failure_message}"
1125 fi
1126 if [[ -z "${PYTHON_ABIS}" ]]; then
1127 die "${function}() function failed with all enabled Python ABIs"
326 fi 1128 fi
327 else 1129 else
328 die "${failure_message}" 1130 die "${failure_message}"
329 fi 1131 fi
330 fi 1132 fi
1133
1134 # Ensure that directory stack has not been decreased.
1135 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then
1136 die "Directory stack decreased illegally"
1137 fi
1138
1139 # Avoid side effects of earlier returning from the specified function.
1140 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do
1141 popd > /dev/null || die "popd failed"
1142 done
1143
1144 # Ensure that the bottom part of directory stack has not been changed. Restore
1145 # previous directory (from before running of the specified function) before
1146 # comparison of directory stacks to avoid mismatch of directory stacks after
1147 # potential using of 'cd' to change current directory. Restoration of previous
1148 # directory allows to safely use 'cd' to change current directory in the
1149 # specified function without changing it back to original directory.
1150 cd "${previous_directory}"
1151 if [[ "$(dirs -p)" != "${previous_directory_stack}" ]]; then
1152 die "Directory stack changed illegally"
1153 fi
1154
331 if [[ "${separate_build_dirs}" == "1" ]]; then 1155 if [[ "${separate_build_dirs}" == "1" ]]; then
332 popd > /dev/null || die "popd failed" 1156 popd > /dev/null || die "popd failed"
333 fi 1157 fi
334 unset BUILDDIR 1158 unset BUILDDIR
335 done 1159 done
337 if [[ "${default_function}" == "1" ]]; then 1161 if [[ "${default_function}" == "1" ]]; then
338 unset -f python_default_function 1162 unset -f python_default_function
339 fi 1163 fi
340} 1164}
341 1165
1166# @FUNCTION: python_copy_sources
1167# @USAGE: <directory="${S}"> [directory]
1168# @DESCRIPTION:
1169# Copy unpacked sources of current package to separate build directory for each Python ABI.
1170python_copy_sources() {
1171 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1172 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1173 fi
342 1174
1175 _python_check_python_pkg_setup_execution
1176
1177 local dir dirs=() PYTHON_ABI
1178
1179 if [[ "$#" -eq 0 ]]; then
1180 if [[ "${WORKDIR}" == "${S}" ]]; then
1181 die "${FUNCNAME}() cannot be used with current value of S variable"
1182 fi
1183 dirs=("${S%/}")
1184 else
1185 dirs=("$@")
1186 fi
1187
1188 _python_calculate_PYTHON_ABIS
1189 for PYTHON_ABI in ${PYTHON_ABIS}; do
1190 for dir in "${dirs[@]}"; do
1191 cp -pr "${dir}" "${dir}-${PYTHON_ABI}" > /dev/null || die "Copying of sources failed"
1192 done
1193 done
1194}
1195
1196# @FUNCTION: python_generate_wrapper_scripts
1197# @USAGE: [-E|--respect-EPYTHON] [-f|--force] [-q|--quiet] [--] <file> [files]
1198# @DESCRIPTION:
1199# Generate wrapper scripts. Existing files are overwritten only with --force option.
1200# If --respect-EPYTHON option is specified, then generated wrapper scripts will
1201# respect EPYTHON variable at run time.
1202#
1203# This function can be used only in src_install() phase.
1204python_generate_wrapper_scripts() {
1205 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1206 die "${FUNCNAME}() can be used only in src_install() phase"
1207 fi
1208
1209 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1210 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1211 fi
1212
1213 _python_check_python_pkg_setup_execution
1214 _python_initialize_prefix_variables
1215
1216 local eselect_python_option file force="0" quiet="0" PYTHON_ABI PYTHON_ABIS_list python2_enabled="0" python3_enabled="0" respect_EPYTHON="0"
1217
1218 while (($#)); do
1219 case "$1" in
1220 -E|--respect-EPYTHON)
1221 respect_EPYTHON="1"
1222 ;;
1223 -f|--force)
1224 force="1"
1225 ;;
1226 -q|--quiet)
1227 quiet="1"
1228 ;;
1229 --)
1230 shift
1231 break
1232 ;;
1233 -*)
1234 die "${FUNCNAME}(): Unrecognized option '$1'"
1235 ;;
1236 *)
1237 break
1238 ;;
1239 esac
1240 shift
1241 done
1242
1243 if [[ "$#" -eq 0 ]]; then
1244 die "${FUNCNAME}(): Missing arguments"
1245 fi
1246
1247 _python_calculate_PYTHON_ABIS
1248 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1249 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1250 python2_enabled="1"
1251 fi
1252 done
1253 for PYTHON_ABI in "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
1254 if has "${PYTHON_ABI}" ${PYTHON_ABIS}; then
1255 python3_enabled="1"
1256 fi
1257 done
1258
1259 if [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "1" ]]; then
1260 eselect_python_option=
1261 elif [[ "${python2_enabled}" == "1" && "${python3_enabled}" == "0" ]]; then
1262 eselect_python_option="--python2"
1263 elif [[ "${python2_enabled}" == "0" && "${python3_enabled}" == "1" ]]; then
1264 eselect_python_option="--python3"
1265 else
1266 die "${FUNCNAME}(): Unsupported environment"
1267 fi
1268
1269 PYTHON_ABIS_list="$("$(PYTHON -f)" -c "print(', '.join('\"%s\"' % x for x in reversed('${PYTHON_ABIS}'.split())))")"
1270
1271 for file in "$@"; do
1272 if [[ -f "${file}" && "${force}" == "0" ]]; then
1273 die "${FUNCNAME}(): '${file}' already exists"
1274 fi
1275
1276 if [[ "${quiet}" == "0" ]]; then
1277 einfo "Generating '${file#${ED%/}}' wrapper script"
1278 fi
1279
1280 cat << EOF > "${file}"
1281#!/usr/bin/env python
1282# Gentoo '${file##*/}' wrapper script generated by python_generate_wrapper_scripts()
1283
1284import os
1285import re
1286import subprocess
1287import sys
1288
1289cpython_ABI_re = re.compile(r"^(\d+\.\d+)$")
1290jython_ABI_re = re.compile(r"^(\d+\.\d+)-jython$")
1291pypy_ABI_re = re.compile(r"^\d+\.\d+-pypy-(\d+\.\d+)$")
1292cpython_interpreter_re = re.compile(r"^python(\d+\.\d+)$")
1293jython_interpreter_re = re.compile(r"^jython(\d+\.\d+)$")
1294pypy_interpreter_re = re.compile(r"^pypy-c(\d+\.\d+)$")
1295cpython_shebang_re = re.compile(r"^#![ \t]*(?:${EPREFIX}/usr/bin/python|(?:${EPREFIX})?/usr/bin/env[ \t]+(?:${EPREFIX}/usr/bin/)?python)")
1296python_shebang_options_re = re.compile(r"^#![ \t]*${EPREFIX}/usr/bin/(?:jython|pypy-c|python)(?:\d+(?:\.\d+)?)?[ \t]+(-\S)")
1297python_verification_output_re = re.compile("^GENTOO_PYTHON_TARGET_SCRIPT_PATH supported\n$")
1298
1299pypy_versions_mapping = {
1300 "1.5": "2.7",
1301 "1.6": "2.7",
1302 "1.7": "2.7",
1303 "1.8": "2.7",
1304 "1.9": "2.7",
1305}
1306
1307def get_PYTHON_ABI(python_interpreter):
1308 cpython_matched = cpython_interpreter_re.match(python_interpreter)
1309 jython_matched = jython_interpreter_re.match(python_interpreter)
1310 pypy_matched = pypy_interpreter_re.match(python_interpreter)
1311 if cpython_matched is not None:
1312 PYTHON_ABI = cpython_matched.group(1)
1313 elif jython_matched is not None:
1314 PYTHON_ABI = jython_matched.group(1) + "-jython"
1315 elif pypy_matched is not None:
1316 PYTHON_ABI = pypy_versions_mapping[pypy_matched.group(1)] + "-pypy-" + pypy_matched.group(1)
1317 else:
1318 PYTHON_ABI = None
1319 return PYTHON_ABI
1320
1321def get_python_interpreter(PYTHON_ABI):
1322 cpython_matched = cpython_ABI_re.match(PYTHON_ABI)
1323 jython_matched = jython_ABI_re.match(PYTHON_ABI)
1324 pypy_matched = pypy_ABI_re.match(PYTHON_ABI)
1325 if cpython_matched is not None:
1326 python_interpreter = "python" + cpython_matched.group(1)
1327 elif jython_matched is not None:
1328 python_interpreter = "jython" + jython_matched.group(1)
1329 elif pypy_matched is not None:
1330 python_interpreter = "pypy-c" + pypy_matched.group(1)
1331 else:
1332 python_interpreter = None
1333 return python_interpreter
1334
1335EOF
1336 if [[ "$?" != "0" ]]; then
1337 die "${FUNCNAME}(): Generation of '$1' failed"
1338 fi
1339 if [[ "${respect_EPYTHON}" == "1" ]]; then
1340 cat << EOF >> "${file}"
1341python_interpreter = os.environ.get("EPYTHON")
1342if python_interpreter:
1343 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1344 if PYTHON_ABI is None:
1345 sys.stderr.write("%s: EPYTHON variable has unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1346 sys.exit(1)
1347else:
1348 try:
1349 environment = os.environ.copy()
1350 environment["ROOT"] = "/"
1351 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1352 if eselect_process.wait() != 0:
1353 raise ValueError
1354 except (OSError, ValueError):
1355 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1356 sys.exit(1)
1357
1358 python_interpreter = eselect_process.stdout.read()
1359 if not isinstance(python_interpreter, str):
1360 # Python 3
1361 python_interpreter = python_interpreter.decode()
1362 python_interpreter = python_interpreter.rstrip("\n")
1363
1364 PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1365 if PYTHON_ABI is None:
1366 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1367 sys.exit(1)
1368
1369wrapper_script_path = os.path.realpath(sys.argv[0])
1370target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1371if not os.path.exists(target_executable_path):
1372 sys.stderr.write("%s: '%s' does not exist\n" % (sys.argv[0], target_executable_path))
1373 sys.exit(1)
1374EOF
1375 if [[ "$?" != "0" ]]; then
1376 die "${FUNCNAME}(): Generation of '$1' failed"
1377 fi
1378 else
1379 cat << EOF >> "${file}"
1380try:
1381 environment = os.environ.copy()
1382 environment["ROOT"] = "/"
1383 eselect_process = subprocess.Popen(["${EPREFIX}/usr/bin/eselect", "python", "show"${eselect_python_option:+, $(echo "\"")}${eselect_python_option}${eselect_python_option:+$(echo "\"")}], env=environment, stdout=subprocess.PIPE)
1384 if eselect_process.wait() != 0:
1385 raise ValueError
1386except (OSError, ValueError):
1387 sys.stderr.write("%s: Execution of 'eselect python show${eselect_python_option:+ }${eselect_python_option}' failed\n" % sys.argv[0])
1388 sys.exit(1)
1389
1390python_interpreter = eselect_process.stdout.read()
1391if not isinstance(python_interpreter, str):
1392 # Python 3
1393 python_interpreter = python_interpreter.decode()
1394python_interpreter = python_interpreter.rstrip("\n")
1395
1396PYTHON_ABI = get_PYTHON_ABI(python_interpreter)
1397if PYTHON_ABI is None:
1398 sys.stderr.write("%s: 'eselect python show${eselect_python_option:+ }${eselect_python_option}' printed unrecognized value '%s'\n" % (sys.argv[0], python_interpreter))
1399 sys.exit(1)
1400
1401wrapper_script_path = os.path.realpath(sys.argv[0])
1402for PYTHON_ABI in [PYTHON_ABI, ${PYTHON_ABIS_list}]:
1403 target_executable_path = "%s-%s" % (wrapper_script_path, PYTHON_ABI)
1404 if os.path.exists(target_executable_path):
1405 break
1406else:
1407 sys.stderr.write("%s: No target script exists for '%s'\n" % (sys.argv[0], wrapper_script_path))
1408 sys.exit(1)
1409
1410python_interpreter = get_python_interpreter(PYTHON_ABI)
1411if python_interpreter is None:
1412 sys.stderr.write("%s: Unrecognized Python ABI '%s'\n" % (sys.argv[0], PYTHON_ABI))
1413 sys.exit(1)
1414EOF
1415 if [[ "$?" != "0" ]]; then
1416 die "${FUNCNAME}(): Generation of '$1' failed"
1417 fi
1418 fi
1419 cat << EOF >> "${file}"
1420
1421target_executable = open(target_executable_path, "rb")
1422target_executable_first_line = target_executable.readline()
1423target_executable.close()
1424if not isinstance(target_executable_first_line, str):
1425 # Python 3
1426 target_executable_first_line = target_executable_first_line.decode("utf_8", "replace")
1427
1428options = []
1429python_shebang_options_matched = python_shebang_options_re.match(target_executable_first_line)
1430if python_shebang_options_matched is not None:
1431 options = [python_shebang_options_matched.group(1)]
1432
1433cpython_shebang_matched = cpython_shebang_re.match(target_executable_first_line)
1434
1435if cpython_shebang_matched is not None:
1436 try:
1437 python_interpreter_path = "${EPREFIX}/usr/bin/%s" % python_interpreter
1438 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"] = "1"
1439 python_verification_process = subprocess.Popen([python_interpreter_path, "-c", "pass"], stdout=subprocess.PIPE)
1440 del os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"]
1441 if python_verification_process.wait() != 0:
1442 raise ValueError
1443
1444 python_verification_output = python_verification_process.stdout.read()
1445 if not isinstance(python_verification_output, str):
1446 # Python 3
1447 python_verification_output = python_verification_output.decode()
1448
1449 if not python_verification_output_re.match(python_verification_output):
1450 raise ValueError
1451
1452 if cpython_interpreter_re.match(python_interpreter) is not None:
1453 os.environ["GENTOO_PYTHON_PROCESS_NAME"] = os.path.basename(sys.argv[0])
1454 os.environ["GENTOO_PYTHON_WRAPPER_SCRIPT_PATH"] = sys.argv[0]
1455 os.environ["GENTOO_PYTHON_TARGET_SCRIPT_PATH"] = target_executable_path
1456
1457 if hasattr(os, "execv"):
1458 os.execv(python_interpreter_path, [python_interpreter_path] + options + sys.argv)
1459 else:
1460 sys.exit(subprocess.Popen([python_interpreter_path] + options + sys.argv).wait())
1461 except (KeyboardInterrupt, SystemExit):
1462 raise
1463 except:
1464 pass
1465 for variable in ("GENTOO_PYTHON_PROCESS_NAME", "GENTOO_PYTHON_WRAPPER_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH", "GENTOO_PYTHON_TARGET_SCRIPT_PATH_VERIFICATION"):
1466 if variable in os.environ:
1467 del os.environ[variable]
1468
1469if hasattr(os, "execv"):
1470 os.execv(target_executable_path, sys.argv)
1471else:
1472 sys.exit(subprocess.Popen([target_executable_path] + sys.argv[1:]).wait())
1473EOF
1474 if [[ "$?" != "0" ]]; then
1475 die "${FUNCNAME}(): Generation of '$1' failed"
1476 fi
1477 fperms +x "${file#${ED%/}}" || die "fperms '${file}' failed"
1478 done
1479}
1480
1481# @ECLASS-VARIABLE: PYTHON_VERSIONED_SCRIPTS
1482# @DESCRIPTION:
1483# Array of regular expressions of paths to versioned Python scripts.
1484# Python scripts in /usr/bin and /usr/sbin are versioned by default.
1485
1486# @ECLASS-VARIABLE: PYTHON_VERSIONED_EXECUTABLES
1487# @DESCRIPTION:
1488# Array of regular expressions of paths to versioned executables (including Python scripts).
1489
1490# @ECLASS-VARIABLE: PYTHON_NONVERSIONED_EXECUTABLES
1491# @DESCRIPTION:
1492# Array of regular expressions of paths to nonversioned executables (including Python scripts).
1493
1494# @FUNCTION: python_merge_intermediate_installation_images
1495# @USAGE: [-q|--quiet] [--] <intermediate_installation_images_directory>
1496# @DESCRIPTION:
1497# Merge intermediate installation images into installation image.
1498#
1499# This function can be used only in src_install() phase.
1500python_merge_intermediate_installation_images() {
1501 if [[ "${EBUILD_PHASE}" != "install" ]]; then
1502 die "${FUNCNAME}() can be used only in src_install() phase"
1503 fi
1504
1505 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1506 die "${FUNCNAME}() cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1507 fi
1508
1509 _python_check_python_pkg_setup_execution
1510 _python_initialize_prefix_variables
1511
1512 local absolute_file b file files=() intermediate_installation_images_directory PYTHON_ABI quiet="0" regex shebang version_executable wrapper_scripts=() wrapper_scripts_set=()
1513
1514 while (($#)); do
1515 case "$1" in
1516 -q|--quiet)
1517 quiet="1"
1518 ;;
1519 --)
1520 shift
1521 break
1522 ;;
1523 -*)
1524 die "${FUNCNAME}(): Unrecognized option '$1'"
1525 ;;
1526 *)
1527 break
1528 ;;
1529 esac
1530 shift
1531 done
1532
1533 if [[ "$#" -ne 1 ]]; then
1534 die "${FUNCNAME}() requires 1 argument"
1535 fi
1536
1537 intermediate_installation_images_directory="$1"
1538
1539 if [[ ! -d "${intermediate_installation_images_directory}" ]]; then
1540 die "${FUNCNAME}(): Intermediate installation images directory '${intermediate_installation_images_directory}' does not exist"
1541 fi
1542
1543 _python_calculate_PYTHON_ABIS
1544 if [[ "$(PYTHON -f --ABI)" == 3.* ]]; then
1545 b="b"
1546 fi
1547
1548 while read -d $'\0' -r file; do
1549 files+=("${file}")
1550 done < <("$(PYTHON -f)" -c \
1551"import os
1552import sys
1553
1554if hasattr(sys.stdout, 'buffer'):
1555 # Python 3
1556 stdout = sys.stdout.buffer
1557else:
1558 # Python 2
1559 stdout = sys.stdout
1560
1561files_set = set()
1562
1563os.chdir(${b}'${intermediate_installation_images_directory}')
1564
1565for PYTHON_ABI in ${b}'${PYTHON_ABIS}'.split():
1566 for root, dirs, files in os.walk(PYTHON_ABI + ${b}'${EPREFIX}'):
1567 root = root[len(PYTHON_ABI + ${b}'${EPREFIX}')+1:]
1568 files_set.update(root + ${b}'/' + file for file in files)
1569
1570for file in sorted(files_set):
1571 stdout.write(file)
1572 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of files in intermediate installation images")
1573
1574 for PYTHON_ABI in ${PYTHON_ABIS}; do
1575 if [[ ! -d "${intermediate_installation_images_directory}/${PYTHON_ABI}" ]]; then
1576 die "${FUNCNAME}(): Intermediate installation image for Python ABI '${PYTHON_ABI}' does not exist"
1577 fi
1578
1579 pushd "${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}" > /dev/null || die "pushd failed"
1580
1581 for file in "${files[@]}"; do
1582 version_executable="0"
1583 for regex in "/usr/bin/.*" "/usr/sbin/.*" "${PYTHON_VERSIONED_SCRIPTS[@]}"; do
1584 if [[ "/${file}" =~ ^${regex}$ ]]; then
1585 version_executable="1"
1586 break
1587 fi
1588 done
1589 for regex in "${PYTHON_VERSIONED_EXECUTABLES[@]}"; do
1590 if [[ "/${file}" =~ ^${regex}$ ]]; then
1591 version_executable="2"
1592 break
1593 fi
1594 done
1595 if [[ "${version_executable}" != "0" ]]; then
1596 for regex in "${PYTHON_NONVERSIONED_EXECUTABLES[@]}"; do
1597 if [[ "/${file}" =~ ^${regex}$ ]]; then
1598 version_executable="0"
1599 break
1600 fi
1601 done
1602 fi
1603
1604 [[ "${version_executable}" == "0" ]] && continue
1605
1606 if [[ -L "${file}" ]]; then
1607 absolute_file="$(readlink "${file}")"
1608 if [[ "${absolute_file}" == /* ]]; then
1609 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file##/}"
1610 else
1611 if [[ "${file}" == */* ]]; then
1612 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file%/*}/${absolute_file}"
1613 else
1614 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${absolute_file}"
1615 fi
1616 fi
1617 else
1618 absolute_file="${intermediate_installation_images_directory}/${PYTHON_ABI}${EPREFIX}/${file}"
1619 fi
1620
1621 [[ ! -x "${absolute_file}" ]] && continue
1622
1623 shebang="$(head -n1 "${absolute_file}")" || die "Extraction of shebang from '${absolute_file}' failed"
1624
1625 if [[ "${version_executable}" == "2" ]]; then
1626 wrapper_scripts+=("${ED}${file}")
1627 elif [[ "${version_executable}" == "1" ]]; then
1628 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}([[:digit:]]+(\.[[:digit:]]+)?)?($|[[:space:]]+) ]]; then
1629 wrapper_scripts+=("${ED}${file}")
1630 else
1631 version_executable="0"
1632 fi
1633 fi
1634
1635 [[ "${version_executable}" == "0" ]] && continue
1636
1637 if [[ -e "${file}-${PYTHON_ABI}" ]]; then
1638 die "${FUNCNAME}(): '${EPREFIX}/${file}-${PYTHON_ABI}' already exists"
1639 fi
1640
1641 mv "${file}" "${file}-${PYTHON_ABI}" || die "Renaming of '${file}' failed"
1642
1643 if [[ "${shebang}" =~ ${_PYTHON_SHEBANG_BASE_PART_REGEX}[[:digit:]]*($|[[:space:]]+) ]]; then
1644 if [[ -L "${file}-${PYTHON_ABI}" ]]; then
1645 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${absolute_file}"
1646 else
1647 python_convert_shebangs $([[ "${quiet}" == "1" ]] && echo --quiet) "${PYTHON_ABI}" "${file}-${PYTHON_ABI}"
1648 fi
1649 fi
1650 done
1651
1652 popd > /dev/null || die "popd failed"
1653
1654 # This is per bug #390691, without the duplication refactor, and with
1655 # the 3-way structure per comment #6. This enable users with old
1656 # coreutils to upgrade a lot easier (you need to upgrade python+portage
1657 # before coreutils can be upgraded).
1658 if ROOT="/" has_version '>=sys-apps/coreutils-6.9.90'; then
1659 cp -fr --preserve=all --no-preserve=context "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1660 elif ROOT="/" has_version sys-apps/coreutils; then
1661 cp -fr --preserve=all "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1662 else
1663 cp -fpr "${intermediate_installation_images_directory}/${PYTHON_ABI}/"* "${D}" || die "Merging of intermediate installation image for Python ABI '${PYTHON_ABI} into installation image failed"
1664 fi
1665 done
1666
1667 rm -fr "${intermediate_installation_images_directory}"
1668
1669 if [[ "${#wrapper_scripts[@]}" -ge 1 ]]; then
1670 rm -f "${T}/python_wrapper_scripts"
1671
1672 for file in "${wrapper_scripts[@]}"; do
1673 echo -n "${file}" >> "${T}/python_wrapper_scripts"
1674 echo -en "\x00" >> "${T}/python_wrapper_scripts"
1675 done
1676
1677 while read -d $'\0' -r file; do
1678 wrapper_scripts_set+=("${file}")
1679 done < <("$(PYTHON -f)" -c \
1680"import sys
1681
1682if hasattr(sys.stdout, 'buffer'):
1683 # Python 3
1684 stdout = sys.stdout.buffer
1685else:
1686 # Python 2
1687 stdout = sys.stdout
1688
1689python_wrapper_scripts_file = open('${T}/python_wrapper_scripts', 'rb')
1690files = set(python_wrapper_scripts_file.read().rstrip(${b}'\x00').split(${b}'\x00'))
1691python_wrapper_scripts_file.close()
1692
1693for file in sorted(files):
1694 stdout.write(file)
1695 stdout.write(${b}'\x00')" || die "${FUNCNAME}(): Failure of extraction of set of wrapper scripts")
1696
1697 python_generate_wrapper_scripts $([[ "${quiet}" == "1" ]] && echo --quiet) "${wrapper_scripts_set[@]}"
1698 fi
1699}
1700
1701# ================================================================================================
1702# ========= FUNCTIONS FOR PACKAGES NOT SUPPORTING INSTALLATION FOR MULTIPLE PYTHON ABIS ==========
1703# ================================================================================================
1704
1705unset EPYTHON PYTHON_ABI
1706
1707# @FUNCTION: python_set_active_version
1708# @USAGE: <Python_ABI|2|3>
1709# @DESCRIPTION:
1710# Set locally active version of Python.
1711# If Python_ABI argument is specified, then version of Python corresponding to Python_ABI is used.
1712# If 2 argument is specified, then active version of CPython 2 is used.
1713# If 3 argument is specified, then active version of CPython 3 is used.
1714#
1715# This function can be used only in pkg_setup() phase.
1716python_set_active_version() {
1717 if [[ "${EBUILD_PHASE}" != "setup" ]]; then
1718 die "${FUNCNAME}() can be used only in pkg_setup() phase"
1719 fi
1720
1721 if _python_package_supporting_installation_for_multiple_python_abis; then
1722 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1723 fi
1724
1725 if [[ "$#" -ne 1 ]]; then
1726 die "${FUNCNAME}() requires 1 argument"
1727 fi
1728
1729 _python_initial_sanity_checks
1730
1731 if [[ -z "${PYTHON_ABI}" ]]; then
1732 if [[ -n "$(_python_get_implementation --ignore-invalid "$1")" ]]; then
1733 # PYTHON_ABI variable is intended to be used only in ebuilds/eclasses,
1734 # so it does not need to be exported to subprocesses.
1735 PYTHON_ABI="$1"
1736 if ! _python_implementation && ! has_version "$(python_get_implementational_package)"; then
1737 die "${FUNCNAME}(): '$(python_get_implementational_package)' is not installed"
1738 fi
1739 export EPYTHON="$(PYTHON "$1")"
1740 elif [[ "$1" == "2" ]]; then
1741 if ! _python_implementation && ! has_version "=dev-lang/python-2*"; then
1742 die "${FUNCNAME}(): '=dev-lang/python-2*' is not installed"
1743 fi
1744 export EPYTHON="$(PYTHON -2)"
1745 PYTHON_ABI="${EPYTHON#python}"
1746 PYTHON_ABI="${PYTHON_ABI%%-*}"
1747 elif [[ "$1" == "3" ]]; then
1748 if ! _python_implementation && ! has_version "=dev-lang/python-3*"; then
1749 die "${FUNCNAME}(): '=dev-lang/python-3*' is not installed"
1750 fi
1751 export EPYTHON="$(PYTHON -3)"
1752 PYTHON_ABI="${EPYTHON#python}"
1753 PYTHON_ABI="${PYTHON_ABI%%-*}"
1754 else
1755 die "${FUNCNAME}(): Unrecognized argument '$1'"
1756 fi
1757 fi
1758
1759 _python_final_sanity_checks
1760
1761 # python-updater checks PYTHON_REQUESTED_ACTIVE_VERSION variable.
1762 PYTHON_REQUESTED_ACTIVE_VERSION="$1"
1763}
1764
1765# @FUNCTION: python_need_rebuild
1766# @DESCRIPTION:
1767# Mark current package for rebuilding by python-updater after
1768# switching of active version of Python.
1769python_need_rebuild() {
1770 if _python_package_supporting_installation_for_multiple_python_abis; then
1771 die "${FUNCNAME}() cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
1772 fi
1773
1774 _python_check_python_pkg_setup_execution
1775
1776 if [[ "$#" -ne 0 ]]; then
1777 die "${FUNCNAME}() does not accept arguments"
1778 fi
1779
1780 export PYTHON_NEED_REBUILD="$(PYTHON --ABI)"
1781}
1782
1783# ================================================================================================
1784# ======================================= GETTER FUNCTIONS =======================================
1785# ================================================================================================
1786
1787_PYTHON_ABI_EXTRACTION_COMMAND=\
1788'import platform
1789import sys
1790sys.stdout.write(".".join(str(x) for x in sys.version_info[:2]))
1791if platform.system()[:4] == "Java":
1792 sys.stdout.write("-jython")
1793elif hasattr(platform, "python_implementation") and platform.python_implementation() == "PyPy":
1794 sys.stdout.write("-pypy-" + ".".join(str(x) for x in sys.pypy_version_info[:2]))'
1795
1796_python_get_implementation() {
1797 local ignore_invalid="0"
1798
1799 while (($#)); do
1800 case "$1" in
1801 --ignore-invalid)
1802 ignore_invalid="1"
1803 ;;
1804 --)
1805 shift
1806 break
1807 ;;
1808 -*)
1809 die "${FUNCNAME}(): Unrecognized option '$1'"
1810 ;;
1811 *)
1812 break
1813 ;;
1814 esac
1815 shift
1816 done
1817
1818 if [[ "$#" -ne 1 ]]; then
1819 die "${FUNCNAME}() requires 1 argument"
1820 fi
1821
1822 if [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+$ ]]; then
1823 echo "CPython"
1824 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-jython$ ]]; then
1825 echo "Jython"
1826 elif [[ "$1" =~ ^[[:digit:]]+\.[[:digit:]]+-pypy-[[:digit:]]+\.[[:digit:]]+$ ]]; then
1827 echo "PyPy"
1828 else
1829 if [[ "${ignore_invalid}" == "0" ]]; then
1830 die "${FUNCNAME}(): Unrecognized Python ABI '$1'"
1831 fi
1832 fi
1833}
1834
1835# @FUNCTION: PYTHON
1836# @USAGE: [-2] [-3] [--ABI] [-a|--absolute-path] [-f|--final-ABI] [--] <Python_ABI="${PYTHON_ABI}">
1837# @DESCRIPTION:
1838# Print filename of Python interpreter for specified Python ABI. If Python_ABI argument
1839# is ommitted, then PYTHON_ABI environment variable must be set and is used.
1840# If -2 option is specified, then active version of CPython 2 is used.
1841# If -3 option is specified, then active version of CPython 3 is used.
1842# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1843# -2, -3 and --final-ABI options and Python_ABI argument cannot be specified simultaneously.
1844# If --ABI option is specified, then only specified Python ABI is printed instead of
1845# filename of Python interpreter.
1846# If --absolute-path option is specified, then absolute path to Python interpreter is printed.
1847# --ABI and --absolute-path options cannot be specified simultaneously.
1848PYTHON() {
1849 _python_check_python_pkg_setup_execution
1850
1851 local ABI_output="0" absolute_path_output="0" final_ABI="0" PYTHON_ABI="${PYTHON_ABI}" python_interpreter python2="0" python3="0"
1852
1853 while (($#)); do
1854 case "$1" in
1855 -2)
1856 python2="1"
1857 ;;
1858 -3)
1859 python3="1"
1860 ;;
1861 --ABI)
1862 ABI_output="1"
1863 ;;
1864 -a|--absolute-path)
1865 absolute_path_output="1"
1866 ;;
1867 -f|--final-ABI)
1868 final_ABI="1"
1869 ;;
1870 --)
1871 shift
1872 break
1873 ;;
1874 -*)
1875 die "${FUNCNAME}(): Unrecognized option '$1'"
1876 ;;
1877 *)
1878 break
1879 ;;
1880 esac
1881 shift
1882 done
1883
1884 if [[ "${ABI_output}" == "1" && "${absolute_path_output}" == "1" ]]; then
1885 die "${FUNCNAME}(): '--ABI' and '--absolute-path' options cannot be specified simultaneously"
1886 fi
1887
1888 if [[ "$((${python2} + ${python3} + ${final_ABI}))" -gt 1 ]]; then
1889 die "${FUNCNAME}(): '-2', '-3' or '--final-ABI' options cannot be specified simultaneously"
1890 fi
1891
1892 if [[ "$#" -eq 0 ]]; then
1893 if [[ "${final_ABI}" == "1" ]]; then
1894 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1895 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1896 fi
1897 _python_calculate_PYTHON_ABIS
1898 PYTHON_ABI="${PYTHON_ABIS##* }"
1899 elif [[ "${python2}" == "1" ]]; then
1900 PYTHON_ABI="$(ROOT="/" eselect python show --python2 --ABI)"
1901 if [[ -z "${PYTHON_ABI}" ]]; then
1902 die "${FUNCNAME}(): Active version of CPython 2 not set"
1903 elif [[ "${PYTHON_ABI}" != "2."* ]]; then
1904 die "${FUNCNAME}(): Internal error in \`eselect python show --python2\`"
1905 fi
1906 elif [[ "${python3}" == "1" ]]; then
1907 PYTHON_ABI="$(ROOT="/" eselect python show --python3 --ABI)"
1908 if [[ -z "${PYTHON_ABI}" ]]; then
1909 die "${FUNCNAME}(): Active version of CPython 3 not set"
1910 elif [[ "${PYTHON_ABI}" != "3."* ]]; then
1911 die "${FUNCNAME}(): Internal error in \`eselect python show --python3\`"
1912 fi
1913 elif _python_package_supporting_installation_for_multiple_python_abis; then
1914 if ! _python_abi-specific_local_scope; then
1915 die "${FUNCNAME}() should be used in ABI-specific local scope"
1916 fi
1917 else
1918 PYTHON_ABI="$("${EPREFIX}/usr/bin/python" -c "${_PYTHON_ABI_EXTRACTION_COMMAND}")"
1919 if [[ -z "${PYTHON_ABI}" ]]; then
1920 die "${FUNCNAME}(): Failure of extraction of locally active version of Python"
1921 fi
1922 fi
1923 elif [[ "$#" -eq 1 ]]; then
1924 if [[ "${final_ABI}" == "1" ]]; then
1925 die "${FUNCNAME}(): '--final-ABI' option and Python ABI cannot be specified simultaneously"
1926 fi
1927 if [[ "${python2}" == "1" ]]; then
1928 die "${FUNCNAME}(): '-2' option and Python ABI cannot be specified simultaneously"
1929 fi
1930 if [[ "${python3}" == "1" ]]; then
1931 die "${FUNCNAME}(): '-3' option and Python ABI cannot be specified simultaneously"
1932 fi
1933 PYTHON_ABI="$1"
1934 else
1935 die "${FUNCNAME}(): Invalid usage"
1936 fi
1937
1938 if [[ "${ABI_output}" == "1" ]]; then
1939 echo -n "${PYTHON_ABI}"
1940 return
1941 else
1942 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
1943 python_interpreter="python${PYTHON_ABI}"
1944 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
1945 python_interpreter="jython${PYTHON_ABI%-jython}"
1946 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
1947 python_interpreter="pypy-c${PYTHON_ABI#*-pypy-}"
1948 fi
1949
1950 if [[ "${absolute_path_output}" == "1" ]]; then
1951 echo -n "${EPREFIX}/usr/bin/${python_interpreter}"
1952 else
1953 echo -n "${python_interpreter}"
1954 fi
1955 fi
1956
1957 if [[ -n "${ABI}" && "${ABI}" != "${DEFAULT_ABI}" && "${DEFAULT_ABI}" != "default" ]]; then
1958 echo -n "-${ABI}"
1959 fi
1960}
1961
1962# @FUNCTION: python_get_implementation
1963# @USAGE: [-f|--final-ABI]
1964# @DESCRIPTION:
1965# Print name of Python implementation.
1966# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
1967python_get_implementation() {
1968 _python_check_python_pkg_setup_execution
1969
1970 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
1971
1972 while (($#)); do
1973 case "$1" in
1974 -f|--final-ABI)
1975 final_ABI="1"
1976 ;;
1977 -*)
1978 die "${FUNCNAME}(): Unrecognized option '$1'"
1979 ;;
1980 *)
1981 die "${FUNCNAME}(): Invalid usage"
1982 ;;
1983 esac
1984 shift
1985 done
1986
1987 if [[ "${final_ABI}" == "1" ]]; then
1988 if ! _python_package_supporting_installation_for_multiple_python_abis; then
1989 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
1990 fi
1991 PYTHON_ABI="$(PYTHON -f --ABI)"
1992 else
1993 if _python_package_supporting_installation_for_multiple_python_abis; then
1994 if ! _python_abi-specific_local_scope; then
1995 die "${FUNCNAME}() should be used in ABI-specific local scope"
1996 fi
1997 else
1998 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
1999 fi
2000 fi
2001
2002 echo "$(_python_get_implementation "${PYTHON_ABI}")"
2003}
2004
2005# @FUNCTION: python_get_implementational_package
2006# @USAGE: [-f|--final-ABI]
2007# @DESCRIPTION:
2008# Print category, name and slot of package providing Python implementation.
2009# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2010python_get_implementational_package() {
2011 _python_check_python_pkg_setup_execution
2012
2013 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2014
2015 while (($#)); do
2016 case "$1" in
2017 -f|--final-ABI)
2018 final_ABI="1"
2019 ;;
2020 -*)
2021 die "${FUNCNAME}(): Unrecognized option '$1'"
2022 ;;
2023 *)
2024 die "${FUNCNAME}(): Invalid usage"
2025 ;;
2026 esac
2027 shift
2028 done
2029
2030 if [[ "${final_ABI}" == "1" ]]; then
2031 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2032 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2033 fi
2034 PYTHON_ABI="$(PYTHON -f --ABI)"
2035 else
2036 if _python_package_supporting_installation_for_multiple_python_abis; then
2037 if ! _python_abi-specific_local_scope; then
2038 die "${FUNCNAME}() should be used in ABI-specific local scope"
2039 fi
2040 else
2041 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2042 fi
2043 fi
2044
2045 if [[ "${EAPI:-0}" == "0" ]]; then
2046 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2047 echo "=dev-lang/python-${PYTHON_ABI}*"
2048 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2049 echo "=dev-java/jython-${PYTHON_ABI%-jython}*"
2050 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2051 echo "=dev-python/pypy-${PYTHON_ABI#*-pypy-}*"
2052 fi
2053 else
2054 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2055 echo "dev-lang/python:${PYTHON_ABI}"
2056 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2057 echo "dev-java/jython:${PYTHON_ABI%-jython}"
2058 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2059 echo "dev-python/pypy:${PYTHON_ABI#*-pypy-}"
2060 fi
2061 fi
2062}
2063
2064# @FUNCTION: python_get_includedir
2065# @USAGE: [-b|--base-path] [-f|--final-ABI]
2066# @DESCRIPTION:
2067# Print path to Python include directory.
2068# If --base-path option is specified, then path not prefixed with "/" is printed.
2069# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2070python_get_includedir() {
2071 _python_check_python_pkg_setup_execution
2072
2073 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2074
2075 while (($#)); do
2076 case "$1" in
2077 -b|--base-path)
2078 base_path="1"
2079 ;;
2080 -f|--final-ABI)
2081 final_ABI="1"
2082 ;;
2083 -*)
2084 die "${FUNCNAME}(): Unrecognized option '$1'"
2085 ;;
2086 *)
2087 die "${FUNCNAME}(): Invalid usage"
2088 ;;
2089 esac
2090 shift
2091 done
2092
2093 if [[ "${base_path}" == "0" ]]; then
2094 prefix="/"
2095 fi
2096
2097 if [[ "${final_ABI}" == "1" ]]; then
2098 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2099 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2100 fi
2101 PYTHON_ABI="$(PYTHON -f --ABI)"
2102 else
2103 if _python_package_supporting_installation_for_multiple_python_abis; then
2104 if ! _python_abi-specific_local_scope; then
2105 die "${FUNCNAME}() should be used in ABI-specific local scope"
2106 fi
2107 else
2108 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2109 fi
2110 fi
2111
2112 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2113 echo "${prefix}usr/include/python${PYTHON_ABI}"
2114 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2115 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Include"
2116 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2117 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/include"
2118 fi
2119}
2120
2121# @FUNCTION: python_get_libdir
2122# @USAGE: [-b|--base-path] [-f|--final-ABI]
2123# @DESCRIPTION:
2124# Print path to Python standard library directory.
2125# If --base-path option is specified, then path not prefixed with "/" is printed.
2126# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2127python_get_libdir() {
2128 _python_check_python_pkg_setup_execution
2129
2130 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2131
2132 while (($#)); do
2133 case "$1" in
2134 -b|--base-path)
2135 base_path="1"
2136 ;;
2137 -f|--final-ABI)
2138 final_ABI="1"
2139 ;;
2140 -*)
2141 die "${FUNCNAME}(): Unrecognized option '$1'"
2142 ;;
2143 *)
2144 die "${FUNCNAME}(): Invalid usage"
2145 ;;
2146 esac
2147 shift
2148 done
2149
2150 if [[ "${base_path}" == "0" ]]; then
2151 prefix="/"
2152 fi
2153
2154 if [[ "${final_ABI}" == "1" ]]; then
2155 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2156 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2157 fi
2158 PYTHON_ABI="$(PYTHON -f --ABI)"
2159 else
2160 if _python_package_supporting_installation_for_multiple_python_abis; then
2161 if ! _python_abi-specific_local_scope; then
2162 die "${FUNCNAME}() should be used in ABI-specific local scope"
2163 fi
2164 else
2165 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2166 fi
2167 fi
2168
2169 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2170 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}"
2171 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2172 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib"
2173 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2174 die "${FUNCNAME}(): PyPy has multiple standard library directories"
2175 fi
2176}
2177
2178# @FUNCTION: python_get_sitedir
2179# @USAGE: [-b|--base-path] [-f|--final-ABI]
2180# @DESCRIPTION:
2181# Print path to Python site-packages directory.
2182# If --base-path option is specified, then path not prefixed with "/" is printed.
2183# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2184python_get_sitedir() {
2185 _python_check_python_pkg_setup_execution
2186
2187 local base_path="0" final_ABI="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2188
2189 while (($#)); do
2190 case "$1" in
2191 -b|--base-path)
2192 base_path="1"
2193 ;;
2194 -f|--final-ABI)
2195 final_ABI="1"
2196 ;;
2197 -*)
2198 die "${FUNCNAME}(): Unrecognized option '$1'"
2199 ;;
2200 *)
2201 die "${FUNCNAME}(): Invalid usage"
2202 ;;
2203 esac
2204 shift
2205 done
2206
2207 if [[ "${base_path}" == "0" ]]; then
2208 prefix="/"
2209 fi
2210
2211 if [[ "${final_ABI}" == "1" ]]; then
2212 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2213 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2214 fi
2215 PYTHON_ABI="$(PYTHON -f --ABI)"
2216 else
2217 if _python_package_supporting_installation_for_multiple_python_abis; then
2218 if ! _python_abi-specific_local_scope; then
2219 die "${FUNCNAME}() should be used in ABI-specific local scope"
2220 fi
2221 else
2222 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2223 fi
2224 fi
2225
2226 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2227 echo "${prefix}usr/$(get_libdir)/python${PYTHON_ABI}/site-packages"
2228 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2229 echo "${prefix}usr/share/jython-${PYTHON_ABI%-jython}/Lib/site-packages"
2230 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2231 echo "${prefix}usr/$(get_libdir)/pypy${PYTHON_ABI#*-pypy-}/site-packages"
2232 fi
2233}
2234
2235# @FUNCTION: python_get_library
2236# @USAGE: [-b|--base-path] [-f|--final-ABI] [-l|--linker-option]
2237# @DESCRIPTION:
2238# Print path to Python library.
2239# If --base-path option is specified, then path not prefixed with "/" is printed.
2240# If --linker-option is specified, then "-l${library}" linker option is printed.
2241# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2242python_get_library() {
2243 _python_check_python_pkg_setup_execution
2244
2245 local base_path="0" final_ABI="0" linker_option="0" prefix PYTHON_ABI="${PYTHON_ABI}"
2246
2247 while (($#)); do
2248 case "$1" in
2249 -b|--base-path)
2250 base_path="1"
2251 ;;
2252 -f|--final-ABI)
2253 final_ABI="1"
2254 ;;
2255 -l|--linker-option)
2256 linker_option="1"
2257 ;;
2258 -*)
2259 die "${FUNCNAME}(): Unrecognized option '$1'"
2260 ;;
2261 *)
2262 die "${FUNCNAME}(): Invalid usage"
2263 ;;
2264 esac
2265 shift
2266 done
2267
2268 if [[ "${base_path}" == "0" ]]; then
2269 prefix="/"
2270 fi
2271
2272 if [[ "${base_path}" == "1" && "${linker_option}" == "1" ]]; then
2273 die "${FUNCNAME}(): '--base-path' and '--linker-option' options cannot be specified simultaneously"
2274 fi
2275
2276 if [[ "${final_ABI}" == "1" ]]; then
2277 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2278 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2279 fi
2280 PYTHON_ABI="$(PYTHON -f --ABI)"
2281 else
2282 if _python_package_supporting_installation_for_multiple_python_abis; then
2283 if ! _python_abi-specific_local_scope; then
2284 die "${FUNCNAME}() should be used in ABI-specific local scope"
2285 fi
2286 else
2287 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2288 fi
2289 fi
2290
2291 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2292 if [[ "${linker_option}" == "1" ]]; then
2293 echo "-lpython${PYTHON_ABI}"
2294 else
2295 echo "${prefix}usr/$(get_libdir)/libpython${PYTHON_ABI}$(get_libname)"
2296 fi
2297 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2298 die "${FUNCNAME}(): Jython does not have shared library"
2299 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2300 die "${FUNCNAME}(): PyPy does not have shared library"
2301 fi
2302}
2303
2304# @FUNCTION: python_get_version
2305# @USAGE: [-f|--final-ABI] [-l|--language] [--full] [--major] [--minor] [--micro]
2306# @DESCRIPTION:
2307# Print version of Python implementation.
2308# --full, --major, --minor and --micro options cannot be specified simultaneously.
2309# If --full, --major, --minor and --micro options are not specified, then "${major_version}.${minor_version}" is printed.
2310# If --language option is specified, then version of Python language is printed.
2311# --language and --full options cannot be specified simultaneously.
2312# --language and --micro options cannot be specified simultaneously.
2313# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2314python_get_version() {
2315 _python_check_python_pkg_setup_execution
2316
2317 local final_ABI="0" language="0" language_version full="0" major="0" minor="0" micro="0" PYTHON_ABI="${PYTHON_ABI}" python_command
2318
2319 while (($#)); do
2320 case "$1" in
2321 -f|--final-ABI)
2322 final_ABI="1"
2323 ;;
2324 -l|--language)
2325 language="1"
2326 ;;
2327 --full)
2328 full="1"
2329 ;;
2330 --major)
2331 major="1"
2332 ;;
2333 --minor)
2334 minor="1"
2335 ;;
2336 --micro)
2337 micro="1"
2338 ;;
2339 -*)
2340 die "${FUNCNAME}(): Unrecognized option '$1'"
2341 ;;
2342 *)
2343 die "${FUNCNAME}(): Invalid usage"
2344 ;;
2345 esac
2346 shift
2347 done
2348
2349 if [[ "${final_ABI}" == "1" ]]; then
2350 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2351 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2352 fi
2353 else
2354 if _python_package_supporting_installation_for_multiple_python_abis && ! _python_abi-specific_local_scope; then
2355 die "${FUNCNAME}() should be used in ABI-specific local scope"
2356 fi
2357 fi
2358
2359 if [[ "$((${full} + ${major} + ${minor} + ${micro}))" -gt 1 ]]; then
2360 die "${FUNCNAME}(): '--full', '--major', '--minor' or '--micro' options cannot be specified simultaneously"
2361 fi
2362
2363 if [[ "${language}" == "1" ]]; then
2364 if [[ "${final_ABI}" == "1" ]]; then
2365 PYTHON_ABI="$(PYTHON -f --ABI)"
2366 elif [[ -z "${PYTHON_ABI}" ]]; then
2367 PYTHON_ABI="$(PYTHON --ABI)"
2368 fi
2369 language_version="${PYTHON_ABI%%-*}"
2370 if [[ "${full}" == "1" ]]; then
2371 die "${FUNCNAME}(): '--language' and '--full' options cannot be specified simultaneously"
2372 elif [[ "${major}" == "1" ]]; then
2373 echo "${language_version%.*}"
2374 elif [[ "${minor}" == "1" ]]; then
2375 echo "${language_version#*.}"
2376 elif [[ "${micro}" == "1" ]]; then
2377 die "${FUNCNAME}(): '--language' and '--micro' options cannot be specified simultaneously"
2378 else
2379 echo "${language_version}"
2380 fi
2381 else
2382 if [[ "${full}" == "1" ]]; then
2383 python_command="import sys; print('.'.join(str(x) for x in getattr(sys, 'pypy_version_info', sys.version_info)[:3]))"
2384 elif [[ "${major}" == "1" ]]; then
2385 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[0])"
2386 elif [[ "${minor}" == "1" ]]; then
2387 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[1])"
2388 elif [[ "${micro}" == "1" ]]; then
2389 python_command="import sys; print(getattr(sys, 'pypy_version_info', sys.version_info)[2])"
2390 else
2391 if [[ -n "${PYTHON_ABI}" && "${final_ABI}" == "0" ]]; then
2392 if [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "CPython" ]]; then
2393 echo "${PYTHON_ABI}"
2394 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "Jython" ]]; then
2395 echo "${PYTHON_ABI%-jython}"
2396 elif [[ "$(_python_get_implementation "${PYTHON_ABI}")" == "PyPy" ]]; then
2397 echo "${PYTHON_ABI#*-pypy-}"
2398 fi
2399 return
2400 fi
2401 python_command="from sys import version_info; print('.'.join(str(x) for x in version_info[:2]))"
2402 fi
2403
2404 if [[ "${final_ABI}" == "1" ]]; then
2405 "$(PYTHON -f)" -c "${python_command}"
2406 else
2407 "$(PYTHON ${PYTHON_ABI})" -c "${python_command}"
2408 fi
2409 fi
2410}
2411
2412# @FUNCTION: python_get_implementation_and_version
2413# @USAGE: [-f|--final-ABI]
2414# @DESCRIPTION:
2415# Print name and version of Python implementation.
2416# If version of Python implementation is not bound to version of Python language, then
2417# version of Python language is additionally printed.
2418# If --final-ABI option is specified, then final ABI from the list of enabled ABIs is used.
2419python_get_implementation_and_version() {
2420 _python_check_python_pkg_setup_execution
2421
2422 local final_ABI="0" PYTHON_ABI="${PYTHON_ABI}"
2423
2424 while (($#)); do
2425 case "$1" in
2426 -f|--final-ABI)
2427 final_ABI="1"
2428 ;;
2429 -*)
2430 die "${FUNCNAME}(): Unrecognized option '$1'"
2431 ;;
2432 *)
2433 die "${FUNCNAME}(): Invalid usage"
2434 ;;
2435 esac
2436 shift
2437 done
2438
2439 if [[ "${final_ABI}" == "1" ]]; then
2440 if ! _python_package_supporting_installation_for_multiple_python_abis; then
2441 die "${FUNCNAME}(): '--final-ABI' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2442 fi
2443 PYTHON_ABI="$(PYTHON -f --ABI)"
2444 else
2445 if _python_package_supporting_installation_for_multiple_python_abis; then
2446 if ! _python_abi-specific_local_scope; then
2447 die "${FUNCNAME}() should be used in ABI-specific local scope"
2448 fi
2449 else
2450 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
2451 fi
2452 fi
2453
2454 if [[ "${PYTHON_ABI}" =~ ^[[:digit:]]+\.[[:digit:]]+-[[:alnum:]]+-[[:digit:]]+\.[[:digit:]]+$ ]]; then
2455 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI##*-} (Python ${PYTHON_ABI%%-*})"
2456 else
2457 echo "$(_python_get_implementation "${PYTHON_ABI}") ${PYTHON_ABI%%-*}"
2458 fi
2459}
2460
2461# ================================================================================================
2462# ================================ FUNCTIONS FOR RUNNING OF TESTS ================================
2463# ================================================================================================
2464
343# @ECLASS-VARIABLE: PYTHON_USE_WITH 2465# @ECLASS-VARIABLE: PYTHON_TEST_VERBOSITY
344# @DESCRIPTION: 2466# @DESCRIPTION:
345# Set this to a space separated list of use flags 2467# User-configurable verbosity of tests of Python modules.
346# the python slot in use must be built with. 2468# Supported values: 0, 1, 2, 3, 4.
2469PYTHON_TEST_VERBOSITY="${PYTHON_TEST_VERBOSITY:-1}"
347 2470
348# @ECLASS-VARIABLE: PYTHON_USE_WITH_OR 2471_python_test_hook() {
349# @DESCRIPTION: 2472 if [[ "$#" -ne 1 ]]; then
350# Set this to a space separated list of use flags 2473 die "${FUNCNAME}() requires 1 argument"
351# of which one must be turned on for the slot of 2474 fi
352# in use.
353 2475
354# @ECLASS-VARIABLE: PYTHON_USE_WITH_OPT 2476 if _python_package_supporting_installation_for_multiple_python_abis && [[ "$(type -t "${_PYTHON_TEST_FUNCTION}_$1_hook")" == "function" ]]; then
355# @DESCRIPTION: 2477 "${_PYTHON_TEST_FUNCTION}_$1_hook"
356# Set this if you need to make either PYTHON_USE_WITH or 2478 fi
357# PYTHON_USE_WITH_OR atoms conditional under a use flag. 2479}
358 2480
359# @FUNCTION: python_pkg_setup 2481# @FUNCTION: python_execute_nosetests
2482# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
360# @DESCRIPTION: 2483# @DESCRIPTION:
361# Makes sure PYTHON_USE_WITH or PYTHON_USE_WITH_OR listed use flags 2484# Execute nosetests for all enabled Python ABIs.
362# are respected. Only exported if one of those variables is set. 2485# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
363if ! has ${EAPI} 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then 2486# python_execute_nosetests_pre_hook() and python_execute_nosetests_post_hook(), if they are defined.
364 python_pkg_setup_fail() { 2487python_execute_nosetests() {
365 eerror "${1}" 2488 _python_check_python_pkg_setup_execution
366 die "${1}" 2489 _python_set_color_variables
2490
2491 local PYTHONPATH_template separate_build_dirs
2492
2493 while (($#)); do
2494 case "$1" in
2495 -P|--PYTHONPATH)
2496 PYTHONPATH_template="$2"
2497 shift
2498 ;;
2499 -s|--separate-build-dirs)
2500 separate_build_dirs="1"
2501 ;;
2502 --)
2503 shift
2504 break
2505 ;;
2506 -*)
2507 die "${FUNCNAME}(): Unrecognized option '$1'"
2508 ;;
2509 *)
2510 break
2511 ;;
2512 esac
2513 shift
2514 done
2515
2516 python_test_function() {
2517 local evaluated_PYTHONPATH
2518
2519 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2520
2521 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook pre
2522
2523 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2524 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2525 PYTHONPATH="${evaluated_PYTHONPATH}" nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2526 else
2527 echo ${_BOLD}nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@"${_NORMAL}
2528 nosetests --verbosity="${PYTHON_TEST_VERBOSITY}" "$@" || return "$?"
2529 fi
2530
2531 _PYTHON_TEST_FUNCTION="python_execute_nosetests" _python_test_hook post
367 } 2532 }
2533 if _python_package_supporting_installation_for_multiple_python_abis; then
2534 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2535 else
2536 if [[ -n "${separate_build_dirs}" ]]; then
2537 die "${FUNCNAME}(): Invalid usage"
2538 fi
2539 python_test_function "$@" || die "Testing failed"
2540 fi
368 2541
369 python_pkg_setup() { 2542 unset -f python_test_function
370 [[ ${PYTHON_USE_WITH_OPT} ]] && use !${PYTHON_USE_WITH_OPT} && return 2543}
371 2544
372 python_version 2545# @FUNCTION: python_execute_py.test
373 local failed 2546# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
374 local pyatom="dev-lang/python:${PYVER}" 2547# @DESCRIPTION:
2548# Execute py.test for all enabled Python ABIs.
2549# In ebuilds of packages supporting installation for multiple Python ABIs, this function calls
2550# python_execute_py.test_pre_hook() and python_execute_py.test_post_hook(), if they are defined.
2551python_execute_py.test() {
2552 _python_check_python_pkg_setup_execution
2553 _python_set_color_variables
375 2554
376 for use in ${PYTHON_USE_WITH}; do 2555 local PYTHONPATH_template separate_build_dirs
377 if ! has_version "${pyatom}[${use}]"; then 2556
378 python_pkg_setup_fail \ 2557 while (($#)); do
379 "Please rebuild ${pyatom} with use flags: ${PYTHON_USE_WITH}" 2558 case "$1" in
2559 -P|--PYTHONPATH)
2560 PYTHONPATH_template="$2"
2561 shift
2562 ;;
2563 -s|--separate-build-dirs)
2564 separate_build_dirs="1"
2565 ;;
2566 --)
2567 shift
2568 break
2569 ;;
2570 -*)
2571 die "${FUNCNAME}(): Unrecognized option '$1'"
2572 ;;
2573 *)
2574 break
2575 ;;
2576 esac
2577 shift
2578 done
2579
2580 python_test_function() {
2581 local evaluated_PYTHONPATH
2582
2583 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2584
2585 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook pre
2586
2587 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2588 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@"${_NORMAL}
2589 PYTHONPATH="${evaluated_PYTHONPATH}" py.test $([[ "${PYTHON_TEST_VERBOSITY}" -ge 2 ]] && echo -v) "$@" || return "$?"
2590 else
2591 echo ${_BOLD}py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@"${_NORMAL}
2592 py.test $([[ "${PYTHON_TEST_VERBOSITY}" -gt 1 ]] && echo -v) "$@" || return "$?"
2593 fi
2594
2595 _PYTHON_TEST_FUNCTION="python_execute_py.test" _python_test_hook post
2596 }
2597 if _python_package_supporting_installation_for_multiple_python_abis; then
2598 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2599 else
2600 if [[ -n "${separate_build_dirs}" ]]; then
2601 die "${FUNCNAME}(): Invalid usage"
2602 fi
2603 python_test_function "$@" || die "Testing failed"
2604 fi
2605
2606 unset -f python_test_function
2607}
2608
2609# @FUNCTION: python_execute_trial
2610# @USAGE: [-P|--PYTHONPATH PYTHONPATH] [-s|--separate-build-dirs] [--] [arguments]
2611# @DESCRIPTION:
2612# Execute trial for all enabled Python ABIs.
2613# In ebuilds of packages supporting installation for multiple Python ABIs, this function
2614# calls python_execute_trial_pre_hook() and python_execute_trial_post_hook(), if they are defined.
2615python_execute_trial() {
2616 _python_check_python_pkg_setup_execution
2617 _python_set_color_variables
2618
2619 local PYTHONPATH_template separate_build_dirs
2620
2621 while (($#)); do
2622 case "$1" in
2623 -P|--PYTHONPATH)
2624 PYTHONPATH_template="$2"
2625 shift
2626 ;;
2627 -s|--separate-build-dirs)
2628 separate_build_dirs="1"
2629 ;;
2630 --)
2631 shift
2632 break
2633 ;;
2634 -*)
2635 die "${FUNCNAME}(): Unrecognized option '$1'"
2636 ;;
2637 *)
2638 break
2639 ;;
2640 esac
2641 shift
2642 done
2643
2644 python_test_function() {
2645 local evaluated_PYTHONPATH
2646
2647 eval "evaluated_PYTHONPATH=\"${PYTHONPATH_template}\""
2648
2649 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook pre
2650
2651 if [[ -n "${evaluated_PYTHONPATH}" ]]; then
2652 echo ${_BOLD}PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2653 PYTHONPATH="${evaluated_PYTHONPATH}" trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2654 else
2655 echo ${_BOLD}trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@"${_NORMAL}
2656 trial $([[ "${PYTHON_TEST_VERBOSITY}" -ge 4 ]] && echo --spew) "$@" || return "$?"
2657 fi
2658
2659 _PYTHON_TEST_FUNCTION="python_execute_trial" _python_test_hook post
2660 }
2661 if _python_package_supporting_installation_for_multiple_python_abis; then
2662 python_execute_function ${separate_build_dirs:+-s} python_test_function "$@"
2663 else
2664 if [[ -n "${separate_build_dirs}" ]]; then
2665 die "${FUNCNAME}(): Invalid usage"
2666 fi
2667 python_test_function "$@" || die "Testing failed"
2668 fi
2669
2670 unset -f python_test_function
2671}
2672
2673# ================================================================================================
2674# ======================= FUNCTIONS FOR HANDLING OF BYTE-COMPILED MODULES ========================
2675# ================================================================================================
2676
2677# @FUNCTION: python_enable_pyc
2678# @DESCRIPTION:
2679# Tell Python to automatically recompile modules to .pyc/.pyo if the
2680# timestamps/version stamps have changed.
2681python_enable_pyc() {
2682 _python_check_python_pkg_setup_execution
2683
2684 if [[ "$#" -ne 0 ]]; then
2685 die "${FUNCNAME}() does not accept arguments"
2686 fi
2687
2688 unset PYTHONDONTWRITEBYTECODE
2689}
2690
2691# @FUNCTION: python_disable_pyc
2692# @DESCRIPTION:
2693# Tell Python not to automatically recompile modules to .pyc/.pyo
2694# even if the timestamps/version stamps do not match. This is done
2695# to protect sandbox.
2696python_disable_pyc() {
2697 _python_check_python_pkg_setup_execution
2698
2699 if [[ "$#" -ne 0 ]]; then
2700 die "${FUNCNAME}() does not accept arguments"
2701 fi
2702
2703 export PYTHONDONTWRITEBYTECODE="1"
2704}
2705
2706_python_vecho() {
2707 [[ -z ${PORTAGE_VERBOSE} ]] || echo "$@"
2708}
2709
2710_python_clean_compiled_modules() {
2711 _python_initialize_prefix_variables
2712 _python_set_color_variables
2713
2714 [[ "${FUNCNAME[1]}" =~ ^(python_mod_optimize|python_mod_cleanup)$ ]] || die "${FUNCNAME}(): Invalid usage"
2715
2716 local base_module_name compiled_file compiled_files=() dir path py_file root
2717
2718 # Strip trailing slash from EROOT.
2719 root="${EROOT%/}"
2720
2721 for path in "$@"; do
2722 compiled_files=()
2723 if [[ -d "${path}" ]]; then
2724 while read -d $'\0' -r compiled_file; do
2725 compiled_files+=("${compiled_file}")
2726 done < <(find "${path}" "(" -name "*.py[co]" -o -name "*\$py.class" ")" -print0)
2727
2728 if [[ "${EBUILD_PHASE}" == "postrm" ]]; then
2729 # Delete empty child directories.
2730 find "${path}" -type d | sort -r | while read -r dir; do
2731 if rmdir "${dir}" 2> /dev/null; then
2732 _python_vecho "<<< ${dir}"
2733 fi
2734 done
2735 fi
2736 elif [[ "${path}" == *.py ]]; then
2737 base_module_name="${path##*/}"
2738 base_module_name="${base_module_name%.py}"
2739 if [[ -d "${path%/*}/__pycache__" ]]; then
2740 while read -d $'\0' -r compiled_file; do
2741 compiled_files+=("${compiled_file}")
2742 done < <(find "${path%/*}/__pycache__" "(" -name "${base_module_name}.*.py[co]" -o -name "${base_module_name}\$py.class" ")" -print0)
2743 fi
2744 compiled_files+=("${path}c" "${path}o" "${path%.py}\$py.class")
2745 fi
2746
2747 for compiled_file in "${compiled_files[@]}"; do
2748 [[ ! -f "${compiled_file}" ]] && continue
2749 dir="${compiled_file%/*}"
2750 dir="${dir##*/}"
2751 if [[ "${compiled_file}" == *.py[co] ]]; then
2752 if [[ "${dir}" == "__pycache__" ]]; then
2753 base_module_name="${compiled_file##*/}"
2754 base_module_name="${base_module_name%.*py[co]}"
2755 base_module_name="${base_module_name%.*}"
2756 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2757 else
2758 py_file="${compiled_file%[co]}"
380 fi 2759 fi
2760 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2761 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2762 else
2763 [[ -f "${py_file}" ]] && continue
2764 fi
2765 _python_vecho "<<< ${compiled_file%[co]}[co]"
2766 rm -f "${compiled_file%[co]}"[co]
2767 elif [[ "${compiled_file}" == *\$py.class ]]; then
2768 if [[ "${dir}" == "__pycache__" ]]; then
2769 base_module_name="${compiled_file##*/}"
2770 base_module_name="${base_module_name%\$py.class}"
2771 py_file="${compiled_file%__pycache__/*}${base_module_name}.py"
2772 else
2773 py_file="${compiled_file%\$py.class}.py"
2774 fi
2775 if [[ "${EBUILD_PHASE}" == "postinst" ]]; then
2776 [[ -f "${py_file}" && "${compiled_file}" -nt "${py_file}" ]] && continue
2777 else
2778 [[ -f "${py_file}" ]] && continue
2779 fi
2780 _python_vecho "<<< ${compiled_file}"
2781 rm -f "${compiled_file}"
2782 else
2783 die "${FUNCNAME}(): Unrecognized file type: '${compiled_file}'"
2784 fi
2785
2786 # Delete empty parent directories.
2787 dir="${compiled_file%/*}"
2788 while [[ "${dir}" != "${root}" ]]; do
2789 if rmdir "${dir}" 2> /dev/null; then
2790 _python_vecho "<<< ${dir}"
2791 else
2792 break
2793 fi
2794 dir="${dir%/*}"
2795 done
381 done 2796 done
382
383 for use in ${PYTHON_USE_WITH_OR}; do
384 if has_version "${pyatom}[${use}]"; then
385 return
386 fi
387 done 2797 done
2798}
388 2799
389 if [[ ${PYTHON_USE_WITH_OR} ]]; then 2800# @FUNCTION: python_mod_optimize
390 python_pkg_setup_fail \ 2801# @USAGE: [--allow-evaluated-non-sitedir-paths] [-d directory] [-f] [-l] [-q] [-x regular_expression] [--] <file|directory> [files|directories]
391 "Please rebuild ${pyatom} with one of: ${PYTHON_USE_WITH_OR}"
392 fi
393 }
394
395 EXPORT_FUNCTIONS pkg_setup
396
397 if [[ ${PYTHON_USE_WITH} ]]; then
398 PYTHON_USE_WITH_ATOM="${PYTHON_ATOM}[${PYTHON_USE_WITH/ /,}]"
399 elif [[ ${PYTHON_USE_WITH_OR} ]]; then
400 PYTHON_USE_WITH_ATOM="|| ( "
401 for use in ${PYTHON_USE_WITH_OR}; do
402 PYTHON_USE_WITH_ATOM="
403 ${PYTHON_USE_WITH_ATOM}
404 ${PYTHON_ATOM}[${use}]"
405 done
406 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_ATOM} )"
407 fi
408 if [[ ${PYTHON_USE_WITH_OPT} ]]; then
409 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_OPT}? ( ${PYTHON_USE_WITH_ATOM} )"
410 fi
411 DEPEND="${PYTHON_USE_WITH_ATOM}"
412 RDEPEND="${PYTHON_USE_WITH_ATOM}"
413fi
414
415# @FUNCTION: python_disable_pyc
416# @DESCRIPTION: 2802# @DESCRIPTION:
417# Tells python not to automatically recompile modules to .pyc/.pyo 2803# Byte-compile specified Python modules.
418# even if the timestamps/version stamps don't match. This is done 2804# -d, -f, -l, -q and -x options passed to this function are passed to compileall.py.
419# to protect sandbox.
420# 2805#
421# note: supported by >=dev-lang/python-2.2.3-r3 only.
422#
423python_disable_pyc() {
424 export PYTHONDONTWRITEBYTECODE=1 # For 2.6 and above
425 export PYTHON_DONTCOMPILE=1 # For 2.5 and below
426}
427
428# @FUNCTION: python_enable_pyc
429# @DESCRIPTION:
430# Tells python to automatically recompile modules to .pyc/.pyo if the
431# timestamps/version stamps change
432python_enable_pyc() {
433 unset PYTHONDONTWRITEBYTECODE
434 unset PYTHON_DONTCOMPILE
435}
436
437python_disable_pyc
438
439# @FUNCTION: python_need_rebuild
440# @DESCRIPTION: Run without arguments, specifies that the package should be
441# rebuilt after a python upgrade.
442python_need_rebuild() {
443 python_version
444 export PYTHON_NEED_REBUILD=${PYVER}
445}
446
447# @FUNCTION: python_get_includedir
448# @DESCRIPTION:
449# Run without arguments, returns the Python include directory.
450python_get_includedir() {
451 if [[ -n "${PYTHON_ABI}" ]]; then
452 echo "/usr/include/python${PYTHON_ABI}"
453 else
454 python_version
455 echo "/usr/include/python${PYVER}"
456 fi
457}
458
459# @FUNCTION: python_get_libdir
460# @DESCRIPTION:
461# Run without arguments, returns the Python library directory.
462python_get_libdir() {
463 if [[ -n "${PYTHON_ABI}" ]]; then
464 echo "/usr/$(get_libdir)/python${PYTHON_ABI}"
465 else
466 python_version
467 echo "/usr/$(get_libdir)/python${PYVER}"
468 fi
469}
470
471# @FUNCTION: python_get_sitedir
472# @DESCRIPTION:
473# Run without arguments, returns the Python site-packages directory.
474python_get_sitedir() {
475 echo "$(python_get_libdir)/site-packages"
476}
477
478# @FUNCTION: python_makesym
479# @DESCRIPTION:
480# Run without arguments, it will create the /usr/bin/python symlinks
481# to the latest installed version
482python_makesym() {
483 alternatives_auto_makesym "/usr/bin/python" "python[0-9].[0-9]"
484 alternatives_auto_makesym "/usr/bin/python2" "python2.[0-9]"
485}
486
487# @FUNCTION: python_tkinter_exists
488# @DESCRIPTION:
489# Run without arguments, checks if python was compiled with Tkinter
490# support. If not, prints an error message and dies.
491python_tkinter_exists() {
492 if ! python -c "import Tkinter" >/dev/null 2>&1; then
493 eerror "You need to recompile python with Tkinter support."
494 eerror "Try adding: 'dev-lang/python tk'"
495 eerror "in to /etc/portage/package.use"
496 echo
497 die "missing tkinter support with installed python"
498 fi
499}
500
501# @FUNCTION: python_mod_exists
502# @USAGE: <module>
503# @DESCRIPTION:
504# Run with the module name as an argument. it will check if a
505# python module is installed and loadable. it will return
506# TRUE(0) if the module exists, and FALSE(1) if the module does
507# not exist.
508#
509# Example:
510# if python_mod_exists gtk; then
511# echo "gtk support enabled"
512# fi
513python_mod_exists() {
514 [[ "$1" ]] || die "${FUNCNAME} requires an argument!"
515 python -c "import $1" &>/dev/null
516}
517
518# @FUNCTION: python_mod_compile
519# @USAGE: <file> [more files ...]
520# @DESCRIPTION:
521# Given filenames, it will pre-compile the module's .pyc and .pyo.
522# This function should only be run in pkg_postinst()
523#
524# Example:
525# python_mod_compile /usr/lib/python2.3/site-packages/pygoogle.py
526#
527python_mod_compile() {
528 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
529 die "${FUNCNAME}() cannot be used in this EAPI"
530 fi
531
532 local f myroot myfiles=()
533
534 # Check if phase is pkg_postinst()
535 [[ ${EBUILD_PHASE} != postinst ]] &&\
536 die "${FUNCNAME} should only be run in pkg_postinst()"
537
538 # allow compiling for older python versions
539 if [[ "${PYTHON_OVERRIDE_PYVER}" ]]; then
540 PYVER=${PYTHON_OVERRIDE_PYVER}
541 else
542 python_version
543 fi
544
545 # strip trailing slash
546 myroot="${ROOT%/}"
547
548 # respect ROOT
549 for f in "$@"; do
550 [[ -f "${myroot}/${f}" ]] && myfiles+=("${myroot}/${f}")
551 done
552
553 if ((${#myfiles[@]})); then
554 python${PYVER} ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}"
555 python${PYVER} -O ${myroot}/usr/$(get_libdir)/python${PYVER}/py_compile.py "${myfiles[@]}"
556 else
557 ewarn "No files to compile!"
558 fi
559}
560
561# @FUNCTION: python_mod_optimize
562# @USAGE: [options] [directory|file]
563# @DESCRIPTION:
564# If no arguments supplied, it will recompile not recursively all modules
565# under sys.path (eg. /usr/lib/python2.6, /usr/lib/python2.6/site-packages).
566#
567# If supplied with arguments, it will recompile all modules recursively
568# in the supplied directory.
569# This function should only be run in pkg_postinst(). 2806# This function can be used only in pkg_postinst() phase.
570#
571# Options passed to this function are passed to compileall.py.
572#
573# Example:
574# python_mod_optimize ctypesgencore
575python_mod_optimize() { 2807python_mod_optimize() {
576 # Check if phase is pkg_postinst(). 2808 if [[ "${EBUILD_PHASE}" != "postinst" ]]; then
577 [[ ${EBUILD_PHASE} != "postinst" ]] && die "${FUNCNAME} should only be run in pkg_postinst()" 2809 die "${FUNCNAME}() can be used only in pkg_postinst() phase"
2810 fi
578 2811
2812 _python_check_python_pkg_setup_execution
2813 _python_initialize_prefix_variables
2814
2815 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
2816 # PYTHON_ABI variable cannot be local in packages not supporting installation for multiple Python ABIs.
2817 local allow_evaluated_non_sitedir_paths="0" dir dirs=() evaluated_dirs=() evaluated_files=() file files=() iterated_PYTHON_ABIS options=() other_dirs=() other_files=() previous_PYTHON_ABI="${PYTHON_ABI}" return_code root site_packages_dirs=() site_packages_files=() stderr stderr_line
2818
2819 if _python_package_supporting_installation_for_multiple_python_abis; then
579 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 2820 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
580 local dir file options=() other_dirs=() other_files=() PYTHON_ABI return_code root site_packages_absolute_dirs=() site_packages_dirs=() site_packages_absolute_files=() site_packages_files=() 2821 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
2822 fi
2823 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
2824 else
2825 if has "${EAPI:-0}" 0 1 2 3; then
2826 iterated_PYTHON_ABIS="${PYTHON_ABI:=$(PYTHON --ABI)}"
2827 else
2828 iterated_PYTHON_ABIS="${PYTHON_ABI}"
2829 fi
2830 fi
581 2831
582 # Strip trailing slash from ROOT. 2832 # Strip trailing slash from EROOT.
583 root="${ROOT%/}" 2833 root="${EROOT%/}"
584 2834
585 # Respect ROOT and options passed to compileall.py.
586 while (($#)); do 2835 while (($#)); do
587 case "$1" in 2836 case "$1" in
2837 --allow-evaluated-non-sitedir-paths)
2838 allow_evaluated_non_sitedir_paths="1"
2839 ;;
588 -l|-f|-q) 2840 -l|-f|-q)
589 options+=("$1") 2841 options+=("$1")
590 ;; 2842 ;;
591 -d|-x) 2843 -d|-x)
592 options+=("$1" "$2") 2844 options+=("$1" "$2")
593 shift 2845 shift
594 ;; 2846 ;;
2847 --)
2848 shift
2849 break
2850 ;;
595 -*) 2851 -*)
596 ewarn "${FUNCNAME}: Ignoring compile option $1" 2852 die "${FUNCNAME}(): Unrecognized option '$1'"
597 ;; 2853 ;;
598 *) 2854 *)
599 if [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
600 die "${FUNCNAME} doesn't support absolute paths of directories/files in site-packages directories"
601 elif [[ "$1" =~ ^/ ]]; then
602 if [[ -d "${root}/$1" ]]; then
603 other_dirs+=("${root}/$1")
604 elif [[ -f "${root}/$1" ]]; then
605 other_files+=("${root}/$1")
606 elif [[ -e "${root}/$1" ]]; then
607 ewarn "'${root}/$1' is not a file or a directory!"
608 else
609 ewarn "'${root}/$1' doesn't exist!"
610 fi
611 else
612 for PYTHON_ABI in ${PYTHON_ABIS}; do
613 if [[ -d "${root}/$(python_get_sitedir)/$1" ]]; then
614 site_packages_dirs+=("$1")
615 break 2855 break
616 elif [[ -f "${root}/$(python_get_sitedir)/$1" ]]; then
617 site_packages_files+=("$1")
618 break
619 elif [[ -e "${root}/$(python_get_sitedir)/$1" ]]; then
620 ewarn "'$1' is not a file or a directory!"
621 else
622 ewarn "'$1' doesn't exist!"
623 fi
624 done
625 fi
626 ;; 2856 ;;
627 esac 2857 esac
628 shift 2858 shift
629 done 2859 done
630 2860
2861 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
2862 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
2863 fi
2864
2865 if [[ "$#" -eq 0 ]]; then
2866 die "${FUNCNAME}(): Missing files or directories"
2867 fi
2868
2869 while (($#)); do
2870 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
2871 die "${FUNCNAME}(): Invalid argument '$1'"
2872 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
2873 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
2874 elif [[ "$1" =~ ^/ ]]; then
2875 if _python_package_supporting_installation_for_multiple_python_abis; then
2876 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
2877 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
2878 fi
2879 if [[ "$1" != *\$* ]]; then
2880 die "${FUNCNAME}(): '$1' has invalid syntax"
2881 fi
2882 if [[ "$1" == *.py ]]; then
2883 evaluated_files+=("$1")
2884 else
2885 evaluated_dirs+=("$1")
2886 fi
2887 else
2888 if [[ -d "${root}$1" ]]; then
2889 other_dirs+=("${root}$1")
2890 elif [[ -f "${root}$1" ]]; then
2891 other_files+=("${root}$1")
2892 elif [[ -e "${root}$1" ]]; then
2893 eerror "${FUNCNAME}(): '${root}$1' is not a regular file or a directory"
2894 else
2895 eerror "${FUNCNAME}(): '${root}$1' does not exist"
2896 fi
2897 fi
2898 else
2899 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
2900 if [[ -d "${root}$(python_get_sitedir)/$1" ]]; then
2901 site_packages_dirs+=("$1")
2902 break
2903 elif [[ -f "${root}$(python_get_sitedir)/$1" ]]; then
2904 site_packages_files+=("$1")
2905 break
2906 elif [[ -e "${root}$(python_get_sitedir)/$1" ]]; then
2907 eerror "${FUNCNAME}(): '$1' is not a regular file or a directory"
2908 else
2909 eerror "${FUNCNAME}(): '$1' does not exist"
2910 fi
2911 done
2912 fi
2913 shift
2914 done
2915
631 # Set additional options. 2916 # Set additional options.
632 options+=("-q") 2917 options+=("-q")
633 2918
634 for PYTHON_ABI in ${PYTHON_ABIS}; do 2919 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
635 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})); then 2920 if ((${#site_packages_dirs[@]})) || ((${#site_packages_files[@]})) || ((${#evaluated_dirs[@]})) || ((${#evaluated_files[@]})); then
636 return_code="0" 2921 return_code="0"
637 ebegin "Compilation and optimization of Python modules for Python ${PYTHON_ABI}" 2922 stderr=""
638 if ((${#site_packages_dirs[@]})); then 2923 ebegin "Compilation and optimization of Python modules for $(python_get_implementation_and_version)"
2924 if ((${#site_packages_dirs[@]})) || ((${#evaluated_dirs[@]})); then
639 for dir in "${site_packages_dirs[@]}"; do 2925 for dir in "${site_packages_dirs[@]}"; do
640 site_packages_absolute_dirs+=("${root}/$(python_get_sitedir)/${dir}") 2926 dirs+=("${root}$(python_get_sitedir)/${dir}")
641 done 2927 done
642 "$(PYTHON)" "${root}/$(python_get_libdir)/compileall.py" "${options[@]}" "${site_packages_absolute_dirs[@]}" || return_code="1" 2928 for dir in "${evaluated_dirs[@]}"; do
643 "$(PYTHON)" -O "${root}/$(python_get_libdir)/compileall.py" "${options[@]}" "${site_packages_absolute_dirs[@]}" || return_code="1" 2929 eval "dirs+=(\"\${root}${dir}\")"
2930 done
2931 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m compileall "${options[@]}" "${dirs[@]}" 2>&1)" || return_code="1"
2932 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2933 "$(PYTHON)" -O -m compileall "${options[@]}" "${dirs[@]}" &> /dev/null || return_code="1"
644 fi 2934 fi
645 if ((${#site_packages_files[@]})); then 2935 _python_clean_compiled_modules "${dirs[@]}"
2936 fi
2937 if ((${#site_packages_files[@]})) || ((${#evaluated_files[@]})); then
646 for file in "${site_packages_files[@]}"; do 2938 for file in "${site_packages_files[@]}"; do
647 site_packages_absolute_files+=("${root}/$(python_get_sitedir)/${file}") 2939 files+=("${root}$(python_get_sitedir)/${file}")
648 done 2940 done
649 "$(PYTHON)" "${root}/$(python_get_libdir)/py_compile.py" "${site_packages_absolute_files[@]}" || return_code="1" 2941 for file in "${evaluated_files[@]}"; do
650 "$(PYTHON)" -O "${root}/$(python_get_libdir)/py_compile.py" "${site_packages_absolute_files[@]}" || return_code="1" 2942 eval "files+=(\"\${root}${file}\")"
2943 done
2944 stderr+="${stderr:+$'\n'}$("$(PYTHON)" -m py_compile "${files[@]}" 2>&1)" || return_code="1"
2945 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2946 "$(PYTHON)" -O -m py_compile "${files[@]}" &> /dev/null || return_code="1"
2947 fi
2948 _python_clean_compiled_modules "${files[@]}"
651 fi 2949 fi
652 eend "${return_code}" 2950 eend "${return_code}"
2951 if [[ -n "${stderr}" ]]; then
2952 eerror "Syntax errors / warnings in Python modules for $(python_get_implementation_and_version):" &> /dev/null
2953 while read stderr_line; do
2954 eerror " ${stderr_line}"
2955 done <<< "${stderr}"
653 fi 2956 fi
654 unset site_packages_absolute_dirs site_packages_absolute_files 2957 fi
2958 unset dirs files
655 done 2959 done
656 2960
657 # Don't use PYTHON_ABI in next calls to python_get_libdir(). 2961 if _python_package_supporting_installation_for_multiple_python_abis; then
2962 # Restore previous value of PYTHON_ABI.
2963 if [[ -n "${previous_PYTHON_ABI}" ]]; then
2964 PYTHON_ABI="${previous_PYTHON_ABI}"
2965 else
658 unset PYTHON_ABI 2966 unset PYTHON_ABI
2967 fi
2968 fi
659 2969
660 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then 2970 if ((${#other_dirs[@]})) || ((${#other_files[@]})); then
661 return_code="0" 2971 return_code="0"
2972 stderr=""
662 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for Python ${PYVER}..." 2973 ebegin "Compilation and optimization of Python modules placed outside of site-packages directories for $(python_get_implementation_and_version)"
663 if ((${#other_dirs[@]})); then 2974 if ((${#other_dirs[@]})); then
664 python${PYVER} "${root}/$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" || return_code="1" 2975 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m compileall "${options[@]}" "${other_dirs[@]}" 2>&1)" || return_code="1"
665 python${PYVER} -O "${root}/$(python_get_libdir)/compileall.py" "${options[@]}" "${other_dirs[@]}" || return_code="1" 2976 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2977 "$(PYTHON ${PYTHON_ABI})" -O -m compileall "${options[@]}" "${other_dirs[@]}" &> /dev/null || return_code="1"
2978 fi
2979 _python_clean_compiled_modules "${other_dirs[@]}"
666 fi 2980 fi
667 if ((${#other_files[@]})); then 2981 if ((${#other_files[@]})); then
668 python${PYVER} "${root}/$(python_get_libdir)/py_compile.py" "${other_files[@]}" || return_code="1" 2982 stderr+="${stderr:+$'\n'}$("$(PYTHON ${PYTHON_ABI})" -m py_compile "${other_files[@]}" 2>&1)" || return_code="1"
669 python${PYVER} -O "${root}/$(python_get_libdir)/py_compile.py" "${other_files[@]}" || return_code="1" 2983 if ! has "$(_python_get_implementation "${PYTHON_ABI}")" Jython PyPy; then
2984 "$(PYTHON ${PYTHON_ABI})" -O -m py_compile "${other_files[@]}" &> /dev/null || return_code="1"
2985 fi
2986 _python_clean_compiled_modules "${other_files[@]}"
670 fi 2987 fi
671 eend "${return_code}" 2988 eend "${return_code}"
2989 if [[ -n "${stderr}" ]]; then
2990 eerror "Syntax errors / warnings in Python modules placed outside of site-packages directories for $(python_get_implementation_and_version):" &> /dev/null
2991 while read stderr_line; do
2992 eerror " ${stderr_line}"
2993 done <<< "${stderr}"
2994 fi
672 fi 2995 fi
673 else 2996 else
2997 # Deprecated part of python_mod_optimize()
2998 ewarn
2999 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
3000 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
3001 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
3002 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
3003 ewarn
3004
674 local myroot mydirs=() myfiles=() myopts=() 3005 local myroot mydirs=() myfiles=() myopts=() return_code="0"
675 3006
676 # strip trailing slash 3007 # strip trailing slash
677 myroot="${ROOT%/}" 3008 myroot="${EROOT%/}"
678 3009
679 # respect ROOT and options passed to compileall.py 3010 # respect EROOT and options passed to compileall.py
680 while (($#)); do 3011 while (($#)); do
681 case "$1" in 3012 case "$1" in
682 -l|-f|-q) 3013 -l|-f|-q)
683 myopts+=("$1") 3014 myopts+=("$1")
684 ;; 3015 ;;
685 -d|-x) 3016 -d|-x)
686 myopts+=("$1" "$2") 3017 myopts+=("$1" "$2")
687 shift 3018 shift
688 ;; 3019 ;;
3020 --)
3021 shift
3022 break
3023 ;;
689 -*) 3024 -*)
690 ewarn "${FUNCNAME}: Ignoring compile option $1" 3025 die "${FUNCNAME}(): Unrecognized option '$1'"
691 ;; 3026 ;;
692 *) 3027 *)
693 if [[ -d "${myroot}"/$1 ]]; then 3028 break
694 mydirs+=("${myroot}/$1")
695 elif [[ -f "${myroot}"/$1 ]]; then
696 # Files are passed to python_mod_compile which is ROOT-aware
697 myfiles+=("$1")
698 elif [[ -e "${myroot}/$1" ]]; then
699 ewarn "${myroot}/$1 is not a file or directory!"
700 else
701 ewarn "${myroot}/$1 doesn't exist!"
702 fi
703 ;; 3029 ;;
704 esac 3030 esac
705 shift 3031 shift
706 done 3032 done
707 3033
708 # allow compiling for older python versions 3034 if [[ "$#" -eq 0 ]]; then
709 if [ -n "${PYTHON_OVERRIDE_PYVER}" ]; then 3035 die "${FUNCNAME}(): Missing files or directories"
710 PYVER=${PYTHON_OVERRIDE_PYVER} 3036 fi
3037
3038 while (($#)); do
3039 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3040 die "${FUNCNAME}(): Invalid argument '$1'"
3041 elif [[ -d "${myroot}/${1#/}" ]]; then
3042 mydirs+=("${myroot}/${1#/}")
3043 elif [[ -f "${myroot}/${1#/}" ]]; then
3044 myfiles+=("${myroot}/${1#/}")
3045 elif [[ -e "${myroot}/${1#/}" ]]; then
3046 eerror "${FUNCNAME}(): ${myroot}/${1#/} is not a regular file or directory"
711 else 3047 else
712 python_version 3048 eerror "${FUNCNAME}(): ${myroot}/${1#/} does not exist"
713 fi 3049 fi
3050 shift
3051 done
714 3052
715 # set additional opts 3053 # set additional opts
716 myopts+=(-q) 3054 myopts+=(-q)
717 3055
718 ebegin "Byte compiling python modules for python-${PYVER} .." 3056 PYTHON_ABI="${PYTHON_ABI:-$(PYTHON --ABI)}"
3057
3058 ebegin "Compilation and optimization of Python modules for $(python_get_implementation) $(python_get_version)"
719 if ((${#mydirs[@]})); then 3059 if ((${#mydirs[@]})); then
720 python${PYVER} \ 3060 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" || return_code="1"
721 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \ 3061 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/compileall.py" "${myopts[@]}" "${mydirs[@]}" &> /dev/null || return_code="1"
722 "${myopts[@]}" "${mydirs[@]}" 3062 _python_clean_compiled_modules "${mydirs[@]}"
723 python${PYVER} -O \
724 "${myroot}"/usr/$(get_libdir)/python${PYVER}/compileall.py \
725 "${myopts[@]}" "${mydirs[@]}"
726 fi 3063 fi
727 3064
728 if ((${#myfiles[@]})); then 3065 if ((${#myfiles[@]})); then
3066 "$(PYTHON ${PYTHON_ABI})" "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" || return_code="1"
3067 "$(PYTHON ${PYTHON_ABI})" -O "${myroot}$(python_get_libdir)/py_compile.py" "${myfiles[@]}" &> /dev/null || return_code="1"
729 python_mod_compile "${myfiles[@]}" 3068 _python_clean_compiled_modules "${myfiles[@]}"
730 fi 3069 fi
731 3070
732 eend $? 3071 eend "${return_code}"
733 fi 3072 fi
734} 3073}
735 3074
736# @FUNCTION: python_mod_cleanup 3075# @FUNCTION: python_mod_cleanup
737# @USAGE: [directory] 3076# @USAGE: [--allow-evaluated-non-sitedir-paths] [--] <file|directory> [files|directories]
738# @DESCRIPTION: 3077# @DESCRIPTION:
739# Run with optional arguments, where arguments are directories of 3078# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
740# python modules. If none given, it will look in /usr/lib/python[0-9].[0-9].
741# 3079#
742# It will recursively scan all compiled Python modules in the directories and
743# determine if they are orphaned (i.e. their corresponding .py files are missing.)
744# If they are, then it will remove their corresponding .pyc and .pyo files.
745#
746# This function should only be run in pkg_postrm(). 3080# This function can be used only in pkg_postrm() phase.
747python_mod_cleanup() { 3081python_mod_cleanup() {
748 local PYTHON_ABI SEARCH_PATH=() root src_py 3082 if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
3083 die "${FUNCNAME}() can be used only in pkg_postrm() phase"
3084 fi
749 3085
750 # Check if phase is pkg_postrm(). 3086 _python_check_python_pkg_setup_execution
751 [[ ${EBUILD_PHASE} != "postrm" ]] && die "${FUNCNAME} should only be run in pkg_postrm()" 3087 _python_initialize_prefix_variables
752 3088
3089 local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
3090
3091 if _python_package_supporting_installation_for_multiple_python_abis; then
3092 if has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_ABIS}" ]]; then
3093 die "${FUNCNAME}(): python_pkg_setup() or python_execute_function() not called"
3094 fi
3095 iterated_PYTHON_ABIS="${PYTHON_ABIS}"
3096 else
3097 if has "${EAPI:-0}" 0 1 2 3; then
3098 iterated_PYTHON_ABIS="${PYTHON_ABI:-$(PYTHON --ABI)}"
3099 else
3100 iterated_PYTHON_ABIS="${PYTHON_ABI}"
3101 fi
3102 fi
3103
753 # Strip trailing slash from ROOT. 3104 # Strip trailing slash from EROOT.
754 root="${ROOT%/}" 3105 root="${EROOT%/}"
755 3106
756 if (($#)); then 3107 while (($#)); do
757 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then 3108 case "$1" in
3109 --allow-evaluated-non-sitedir-paths)
3110 allow_evaluated_non_sitedir_paths="1"
3111 ;;
3112 --)
3113 shift
3114 break
3115 ;;
3116 -*)
3117 die "${FUNCNAME}(): Unrecognized option '$1'"
3118 ;;
3119 *)
3120 break
3121 ;;
3122 esac
3123 shift
3124 done
3125
3126 if [[ "${allow_evaluated_non_sitedir_paths}" == "1" ]] && ! _python_package_supporting_installation_for_multiple_python_abis; then
3127 die "${FUNCNAME}(): '--allow-evaluated-non-sitedir-paths' option cannot be used in ebuilds of packages not supporting installation for multiple Python ABIs"
3128 fi
3129
3130 if [[ "$#" -eq 0 ]]; then
3131 die "${FUNCNAME}(): Missing files or directories"
3132 fi
3133
3134 if ! has "${EAPI:-0}" 0 1 2 || _python_package_supporting_installation_for_multiple_python_abis || _python_implementation || [[ "${CATEGORY}/${PN}" == "sys-apps/portage" ]]; then
758 while (($#)); do 3135 while (($#)); do
3136 if [[ "$1" =~ ^($|(\.|\.\.|/)($|/)) ]]; then
3137 die "${FUNCNAME}(): Invalid argument '$1'"
759 if [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then 3138 elif ! _python_implementation && [[ "$1" =~ ^/usr/lib(32|64)?/python[[:digit:]]+\.[[:digit:]]+ ]]; then
760 die "${FUNCNAME} doesn't support absolute paths of directories/files in site-packages directories" 3139 die "${FUNCNAME}(): Paths of directories / files in site-packages directories must be relative to site-packages directories"
761 elif [[ "$1" =~ ^/ ]]; then 3140 elif [[ "$1" =~ ^/ ]]; then
762 SEARCH_PATH+=("${root}/${1#/}") 3141 if _python_package_supporting_installation_for_multiple_python_abis; then
3142 if [[ "${allow_evaluated_non_sitedir_paths}" != "1" ]]; then
3143 die "${FUNCNAME}(): Absolute paths cannot be used in ebuilds of packages supporting installation for multiple Python ABIs"
3144 fi
3145 if [[ "$1" != *\$* ]]; then
3146 die "${FUNCNAME}(): '$1' has invalid syntax"
3147 fi
3148 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
3149 eval "search_paths+=(\"\${root}$1\")"
3150 done
763 else 3151 else
3152 search_paths+=("${root}$1")
3153 fi
3154 else
764 for PYTHON_ABI in ${PYTHON_ABIS}; do 3155 for PYTHON_ABI in ${iterated_PYTHON_ABIS}; do
765 SEARCH_PATH+=("${root}/$(python_get_sitedir)/$1") 3156 search_paths+=("${root}$(python_get_sitedir)/$1")
766 done 3157 done
767 fi 3158 fi
768 shift 3159 shift
769 done 3160 done
770 else
771 SEARCH_PATH=("${@#/}")
772 SEARCH_PATH=("${SEARCH_PATH[@]/#/${root}/}")
773 fi
774 else 3161 else
775 SEARCH_PATH=("${root}"/usr/lib*/python*/site-packages) 3162 # Deprecated part of python_mod_cleanup()
776 fi 3163 ewarn
3164 ewarn "Deprecation Warning: Usage of ${FUNCNAME}() in packages not supporting installation"
3165 ewarn "for multiple Python ABIs in EAPI <=2 is deprecated and will be disallowed on 2011-08-01."
3166 ewarn "Use EAPI >=3 and call ${FUNCNAME}() with paths having appropriate syntax."
3167 ewarn "The ebuild needs to be fixed. Please report a bug, if it has not been already reported."
3168 ewarn
777 3169
778 for path in "${SEARCH_PATH[@]}"; do 3170 search_paths=("${@#/}")
779 einfo "Cleaning orphaned Python bytecode from ${path} .." 3171 search_paths=("${search_paths[@]/#/${root}/}")
780 find "${path}" -name '*.py[co]' -print0 | while read -rd ''; do 3172 fi
781 src_py="${REPLY%[co]}"
782 [[ -f "${src_py}" ]] && continue
783 einfo "Purging ${src_py}[co]"
784 rm -f "${src_py}"[co]
785 done
786 3173
787 # Attempt to remove directories that may be empty. 3174 _python_clean_compiled_modules "${search_paths[@]}"
788 find "${path}" -type d | sort -r | while read -r dir; do
789 rmdir "${dir}" 2>/dev/null
790 done
791 done
792} 3175}
3176
3177# ================================================================================================
3178# ===================================== DEPRECATED FUNCTIONS =====================================
3179# ================================================================================================
3180
3181fi # _PYTHON_ECLASS_INHERITED

Legend:
Removed from v.1.60  
changed lines
  Added in v.1.158

  ViewVC Help
Powered by ViewVC 1.1.20