/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.72 Revision 1.74
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.72 2009/09/11 19:55:05 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.74 2009/10/02 02:02:24 arfrever Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# python@gentoo.org 7# python@gentoo.org
8#
9# original author: Alastair Tse <liquidx@gentoo.org>
10# @BLURB: A Utility Eclass that should be inherited by anything that deals with Python or Python modules. 8# @BLURB: A utility eclass that should be inherited by anything that deals with Python or Python modules.
11# @DESCRIPTION: 9# @DESCRIPTION:
12# Some useful functions for dealing with Python. 10# Some useful functions for dealing with Python.
13 11
14inherit multilib 12inherit multilib
15 13
19 RDEPEND="${DEPEND}" 17 RDEPEND="${DEPEND}"
20else 18else
21 PYTHON_ATOM="dev-lang/python" 19 PYTHON_ATOM="dev-lang/python"
22fi 20fi
23 21
24DEPEND="${DEPEND} >=app-shells/bash-3.2"
25if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
26 DEPEND="${DEPEND} >=app-admin/eselect-python-20090804" 22DEPEND+=" >=app-admin/eselect-python-20090804
27fi 23 >=app-shells/bash-3.2"
28 24
29__python_eclass_test() { 25__python_eclass_test() {
30 __python_version_extract 2.3 26 __python_version_extract 2.3
31 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR" 27 echo -n "2.3 -> PYVER: $PYVER PYVER_MAJOR: $PYVER_MAJOR"
32 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO" 28 echo " PYVER_MINOR: $PYVER_MINOR PYVER_MICRO: $PYVER_MICRO"
129 die "'/usr/bin/python-config' isn't valid script" 125 die "'/usr/bin/python-config' isn't valid script"
130 fi 126 fi
131 127
132 # USE_${ABI_TYPE^^} and RESTRICT_${ABI_TYPE^^}_ABIS variables hopefully will be included in EAPI >= 4. 128 # USE_${ABI_TYPE^^} and RESTRICT_${ABI_TYPE^^}_ABIS variables hopefully will be included in EAPI >= 4.
133 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3; then 129 if [[ "$(declare -p PYTHON_ABIS 2> /dev/null)" != "declare -x PYTHON_ABIS="* ]] && has "${EAPI:-0}" 0 1 2 3; then
134 local ABI support_ABI supported_PYTHON_ABIS= restricted_ABI 130 local ABI restricted_ABI support_ABI supported_PYTHON_ABIS=
135 PYTHON_ABI_SUPPORTED_VALUES="2.4 2.5 2.6 2.7 3.0 3.1 3.2" 131 PYTHON_ABI_SUPPORTED_VALUES="2.4 2.5 2.6 2.7 3.0 3.1 3.2"
136 132
137 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then 133 if [[ "$(declare -p USE_PYTHON 2> /dev/null)" == "declare -x USE_PYTHON="* ]]; then
138 if [[ -z "${USE_PYTHON}" ]]; then 134 if [[ -z "${USE_PYTHON}" ]]; then
139 die "USE_PYTHON variable is empty" 135 die "USE_PYTHON variable is empty"
153 [[ "${support_ABI}" == "1" ]] && supported_PYTHON_ABIS+=" ${ABI}" 149 [[ "${support_ABI}" == "1" ]] && supported_PYTHON_ABIS+=" ${ABI}"
154 done 150 done
155 export PYTHON_ABIS="${supported_PYTHON_ABIS# }" 151 export PYTHON_ABIS="${supported_PYTHON_ABIS# }"
156 152
157 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then 153 if [[ -z "${PYTHON_ABIS//[${IFS}]/}" ]]; then
158 die "USE_PYTHON variable doesn't enable any Python version supported by ${CATEGORY}/${PF}" 154 die "USE_PYTHON variable doesn't enable any version of Python supported by ${CATEGORY}/${PF}"
159 fi 155 fi
160 else 156 else
161 local restricted_ABI 157 local ABI python2_version= python2_supported_versions python3_version= python3_supported_versions restricted_ABI support_python_major_version
162 python_version
163 158
159 if has_version "=dev-lang/python-2*"; then
160 if [[ "$(readlink /usr/bin/python2)" != "python2."* ]]; then
161 die "'/usr/bin/python2' isn't valid symlink"
162 fi
163
164 python2_version="$(/usr/bin/python2 -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')"
165 python2_supported_versions="2.4 2.5 2.6 2.7"
166
167 for ABI in ${python2_supported_versions}; do
168 support_python_major_version="1"
164 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do 169 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
165 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${PYVER}', '${restricted_ABI}'))"; then 170 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${ABI}', '${restricted_ABI}'))"; then
166 die "Active Python version isn't supported by ${CATEGORY}/${PF}" 171 support_python_major_version="0"
167 fi 172 fi
173 done
174 [[ "${support_python_major_version}" == "1" ]] && break
168 done 175 done
176 if [[ "${support_python_major_version}" == "1" ]]; then
177 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
178 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${python2_version}', '${restricted_ABI}'))"; then
179 die "Active version of Python 2 isn't supported by ${CATEGORY}/${PF}"
180 fi
181 done
182 else
183 python2_version=""
184 fi
185 fi
186
187 if has_version "=dev-lang/python-3*"; then
188 if [[ "$(readlink /usr/bin/python3)" != "python3."* ]]; then
189 die "'/usr/bin/python3' isn't valid symlink"
190 fi
191
192 python3_version="$(/usr/bin/python3 -c 'from sys import version_info; print(".".join([str(x) for x in version_info[:2]]))')"
193 python3_supported_versions="3.0 3.1 3.2"
194
195 for ABI in ${python3_supported_versions}; do
196 support_python_major_version="1"
197 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
198 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${ABI}', '${restricted_ABI}'))"; then
199 support_python_major_version="0"
200 fi
201 done
202 [[ "${support_python_major_version}" == "1" ]] && break
203 done
204 if [[ "${support_python_major_version}" == "1" ]]; then
205 for restricted_ABI in ${RESTRICT_PYTHON_ABIS}; do
206 if python -c "from fnmatch import fnmatch; exit(not fnmatch('${python3_version}', '${restricted_ABI}'))"; then
207 die "Active version of Python 3 isn't supported by ${CATEGORY}/${PF}"
208 fi
209 done
210 else
211 python3_version=""
212 fi
213 fi
214
215 PYTHON_ABIS="${python2_version} ${python3_version}"
216 PYTHON_ABIS="${PYTHON_ABIS# }"
169 export PYTHON_ABIS="${PYVER}" 217 export PYTHON_ABIS="${PYTHON_ABIS% }"
170 fi 218 fi
171 fi 219 fi
172 220
173 local PYTHON_ABI 221 local PYTHON_ABI
174 for PYTHON_ABI in ${PYTHON_ABIS}; do 222 for PYTHON_ABI in ${PYTHON_ABIS}; do
249# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--] <function> [arguments] 297# @USAGE: [--action-message message] [-d|--default-function] [--failure-message message] [--nonfatal] [-q|--quiet] [-s|--separate-build-dirs] [--] <function> [arguments]
250# @DESCRIPTION: 298# @DESCRIPTION:
251# Execute specified function for each value of PYTHON_ABIS, optionally passing additional 299# Execute specified function for each value of PYTHON_ABIS, optionally passing additional
252# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables. 300# arguments. The specified function can use PYTHON_ABI and BUILDDIR variables.
253python_execute_function() { 301python_execute_function() {
254 local action action_message action_message_template= default_function="0" failure_message failure_message_template= function nonfatal="0" previous_directory_stack_length PYTHON_ABI quiet="0" separate_build_dirs="0" 302 local action action_message action_message_template= default_function="0" failure_message failure_message_template= function nonfatal="0" previous_directory previous_directory_stack previous_directory_stack_length PYTHON_ABI quiet="0" separate_build_dirs="0"
255 303
256 while (($#)); do 304 while (($#)); do
257 case "$1" in 305 case "$1" in
258 --action-message) 306 --action-message)
259 action_message_template="$2" 307 action_message_template="$2"
381 pushd "${BUILDDIR}" > /dev/null || die "pushd failed" 429 pushd "${BUILDDIR}" > /dev/null || die "pushd failed"
382 else 430 else
383 export BUILDDIR="${S}" 431 export BUILDDIR="${S}"
384 fi 432 fi
385 433
386 previous_directory_stack_length="${#DIRSTACK[@]}" 434 previous_directory="$(pwd)"
435 previous_directory_stack="$(dirs -p)"
436 previous_directory_stack_length="$(dirs -p | wc -l)"
387 437
388 if ! has "${EAPI}" 0 1 2 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then 438 if ! has "${EAPI}" 0 1 2 && has "${PYTHON_ABI}" ${FAILURE_TOLERANT_PYTHON_ABIS}; then
389 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@" 439 EPYTHON="$(PYTHON)" nonfatal "${function}" "$@"
390 else 440 else
391 EPYTHON="$(PYTHON)" "${function}" "$@" 441 EPYTHON="$(PYTHON)" "${function}" "$@"
419 else 469 else
420 die "${failure_message}" 470 die "${failure_message}"
421 fi 471 fi
422 fi 472 fi
423 473
474 # Ensure that directory stack hasn't been decreased.
424 if [[ "${#DIRSTACK[@]}" -lt "${previous_directory_stack_length}" ]]; then 475 if [[ "$(dirs -p | wc -l)" -lt "${previous_directory_stack_length}" ]]; then
425 die "Directory stack decreased illegally" 476 die "Directory stack decreased illegally"
426 fi 477 fi
427 478
479 # Avoid side effects of earlier returning from the specified function.
428 while [[ "${#DIRSTACK[@]}" -gt "${previous_directory_stack_length}" ]]; do 480 while [[ "$(dirs -p | wc -l)" -gt "${previous_directory_stack_length}" ]]; do
429 popd > /dev/null || die "popd failed" 481 popd > /dev/null || die "popd failed"
430 done 482 done
483
484 # Ensure that the bottom part of directory stack hasn't been changed. Restore
485 # previous directory (from before running of the specified function) before
486 # comparison of directory stacks to avoid mismatch of directory stacks after
487 # potential using of 'cd' to change current directory. Restoration of previous
488 # directory allows to safely use 'cd' to change current directory in the
489 # specified function without changing it back to original directory.
490 cd "${previous_directory}"
491 if [[ "$(dirs -p)" != "${previous_directory_stack}" ]]; then
492 die "Directory stack changed illegally"
493 fi
431 494
432 if [[ "${separate_build_dirs}" == "1" ]]; then 495 if [[ "${separate_build_dirs}" == "1" ]]; then
433 popd > /dev/null || die "popd failed" 496 popd > /dev/null || die "popd failed"
434 fi 497 fi
435 unset BUILDDIR 498 unset BUILDDIR
460# @FUNCTION: python_pkg_setup 523# @FUNCTION: python_pkg_setup
461# @DESCRIPTION: 524# @DESCRIPTION:
462# Makes sure PYTHON_USE_WITH or PYTHON_USE_WITH_OR listed use flags 525# Makes sure PYTHON_USE_WITH or PYTHON_USE_WITH_OR listed use flags
463# are respected. Only exported if one of those variables is set. 526# are respected. Only exported if one of those variables is set.
464if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then 527if ! has "${EAPI:-0}" 0 1 && [[ -n ${PYTHON_USE_WITH} || -n ${PYTHON_USE_WITH_OR} ]]; then
528 python_pkg_setup() {
465 python_pkg_setup_fail() { 529 python_pkg_setup_fail() {
466 eerror "${1}" 530 eerror "${1}"
467 die "${1}" 531 die "${1}"
532 }
533
534 [[ ${PYTHON_USE_WITH_OPT} ]] && use !${PYTHON_USE_WITH_OPT} && return
535
536 python_pkg_setup_check_USE_flags() {
537 local pyatom use
538 if [[ -n "${PYTHON_ABI}" ]]; then
539 pyatom="dev-lang/python:${PYTHON_ABI}"
540 else
541 python_version
542 pyatom="dev-lang/python:${PYVER}"
543 fi
544
545 for use in ${PYTHON_USE_WITH}; do
546 if ! has_version "${pyatom}[${use}]"; then
547 python_pkg_setup_fail "Please rebuild ${pyatom} with the following USE flags enabled: ${PYTHON_USE_WITH}"
548 fi
549 done
550
551 for use in ${PYTHON_USE_WITH_OR}; do
552 if has_version "${pyatom}[${use}]"; then
553 return
554 fi
555 done
556
557 if [[ ${PYTHON_USE_WITH_OR} ]]; then
558 python_pkg_setup_fail "Please rebuild ${pyatom} with at least one of the following USE flags enabled: ${PYTHON_USE_WITH_OR}"
559 fi
560 }
561
562 if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
563 python_execute_function -q python_pkg_setup_check_USE_flags
564 else
565 python_pkg_setup_check_USE_flags
566 fi
468 } 567 }
469 568
470 python_pkg_setup() {
471 [[ ${PYTHON_USE_WITH_OPT} ]] && use !${PYTHON_USE_WITH_OPT} && return
472
473 python_version
474 local failed
475 local pyatom="dev-lang/python:${PYVER}"
476
477 for use in ${PYTHON_USE_WITH}; do
478 if ! has_version "${pyatom}[${use}]"; then
479 python_pkg_setup_fail \
480 "Please rebuild ${pyatom} with use flags: ${PYTHON_USE_WITH}"
481 fi
482 done
483
484 for use in ${PYTHON_USE_WITH_OR}; do
485 if has_version "${pyatom}[${use}]"; then
486 return
487 fi
488 done
489
490 if [[ ${PYTHON_USE_WITH_OR} ]]; then
491 python_pkg_setup_fail \
492 "Please rebuild ${pyatom} with one of: ${PYTHON_USE_WITH_OR}"
493 fi
494 }
495
496 EXPORT_FUNCTIONS pkg_setup 569 EXPORT_FUNCTIONS pkg_setup
497 570
498 if [[ ${PYTHON_USE_WITH} ]]; then 571 if [[ -n "${PYTHON_USE_WITH}" ]]; then
499 PYTHON_USE_WITH_ATOM="${PYTHON_ATOM}[${PYTHON_USE_WITH/ /,}]" 572 PYTHON_USE_WITH_ATOM="${PYTHON_ATOM}[${PYTHON_USE_WITH/ /,}]"
500 elif [[ ${PYTHON_USE_WITH_OR} ]]; then 573 elif [[ -n "${PYTHON_USE_WITH_OR}" ]]; then
501 PYTHON_USE_WITH_ATOM="|| ( " 574 PYTHON_USE_WITH_ATOM="|| ( "
502 for use in ${PYTHON_USE_WITH_OR}; do 575 for use in ${PYTHON_USE_WITH_OR}; do
503 PYTHON_USE_WITH_ATOM=" 576 PYTHON_USE_WITH_ATOM+=" ${PYTHON_ATOM}[${use}]"
504 ${PYTHON_USE_WITH_ATOM}
505 ${PYTHON_ATOM}[${use}]"
506 done 577 done
507 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_ATOM} )" 578 unset use
579 PYTHON_USE_WITH_ATOM+=" )"
508 fi 580 fi
509 if [[ ${PYTHON_USE_WITH_OPT} ]]; then 581 if [[ -n "${PYTHON_USE_WITH_OPT}" ]]; then
510 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_OPT}? ( ${PYTHON_USE_WITH_ATOM} )" 582 PYTHON_USE_WITH_ATOM="${PYTHON_USE_WITH_OPT}? ( ${PYTHON_USE_WITH_ATOM} )"
511 fi 583 fi
512 DEPEND="${PYTHON_USE_WITH_ATOM}" 584 DEPEND+=" ${PYTHON_USE_WITH_ATOM}"
513 RDEPEND="${PYTHON_USE_WITH_ATOM}" 585 RDEPEND+=" ${PYTHON_USE_WITH_ATOM}"
514fi 586fi
515 587
516# @ECLASS-VARIABLE: PYTHON_DEFINE_DEFAULT_FUNCTIONS 588# @ECLASS-VARIABLE: PYTHON_DEFINE_DEFAULT_FUNCTIONS
517# @DESCRIPTION: 589# @DESCRIPTION:
518# Set this to define default functions for the following ebuild phases: 590# Set this to define default functions for the following ebuild phases:

Legend:
Removed from v.1.72  
changed lines
  Added in v.1.74

  ViewVC Help
Powered by ViewVC 1.1.20