/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.120 Revision 1.130
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.120 2012/02/28 18:53:45 pesa Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.130 2012/05/22 13:41:59 pesa Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Qt herd <qt@gentoo.org> 7# Qt herd <qt@gentoo.org>
8# @BLURB: Eclass for Qt4 split ebuilds. 8# @BLURB: Eclass for Qt4 split ebuilds.
9# @DESCRIPTION: 9# @DESCRIPTION:
10# This eclass contains various functions that are used when building Qt4. 10# This eclass contains various functions that are used when building Qt4.
11 11
12case ${EAPI} in
13 2|3|4) : ;;
14 *) die "qt4-build.eclass requires EAPI 2, 3 or 4." ;;
15esac
16
12inherit base eutils multilib toolchain-funcs flag-o-matic versionator 17inherit base eutils flag-o-matic multilib toolchain-funcs versionator
18
19if [[ ${PV} == *9999* ]]; then
20 QT4_BUILD_TYPE="live"
21 inherit git-2
22else
23 QT4_BUILD_TYPE="release"
24fi
25
26HOMEPAGE="http://qt-project.org/ http://qt.nokia.com/"
27LICENSE="|| ( LGPL-2.1 GPL-3 )"
13 28
14MY_PV=${PV/_/-} 29MY_PV=${PV/_/-}
15MY_P=qt-everywhere-opensource-src-${MY_PV} 30MY_P=qt-everywhere-opensource-src-${MY_PV}
16 31
17HOMEPAGE="http://qt.nokia.com/ http://qt-project.org/" 32case ${QT4_BUILD_TYPE} in
33 live)
34 EGIT_REPO_URI="git://gitorious.org/qt/qt.git
35 https://git.gitorious.org/qt/qt.git"
36 EGIT_BRANCH="${PV%.9999}"
37 ;;
38 release)
39 if version_is_at_least 4.8.1; then
40 SRC_URI="http://releases.qt-project.org/qt4/source/${MY_P}.tar.gz"
41 else
18SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz" 42 SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
19LICENSE="|| ( LGPL-2.1 GPL-3 )" 43 fi
44 ;;
45esac
20 46
21IUSE="aqua debug pch" 47IUSE="aqua debug pch"
22
23[[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]] && 48if [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]]; then
24[[ ${CATEGORY}/${PN} != x11-themes/qgtkstyle ]] &&
25 IUSE+=" +exceptions" 49 IUSE+=" +exceptions"
26 50fi
27if version_is_at_least 4.7.99999999; then 51if version_is_at_least 4.8; then
28 IUSE+=" c++0x qpa" 52 IUSE+=" c++0x qpa"
29fi 53fi
30 54
31DEPEND="dev-util/pkgconfig" 55DEPEND="virtual/pkgconfig"
56if [[ ${QT4_BUILD_TYPE} == live ]]; then
57 DEPEND+=" dev-lang/perl"
58fi
59
32RDEPEND=" 60RDEPEND="
33 !<x11-libs/qt-assistant-${PV} 61 !<x11-libs/qt-assistant-${PV}
34 !>x11-libs/qt-assistant-${PV}-r9999 62 !>x11-libs/qt-assistant-${PV}-r9999
63 !<x11-libs/qt-bearer-${PV}
64 !>x11-libs/qt-bearer-${PV}-r9999
35 !<x11-libs/qt-core-${PV} 65 !<x11-libs/qt-core-${PV}
36 !>x11-libs/qt-core-${PV}-r9999 66 !>x11-libs/qt-core-${PV}-r9999
37 !<x11-libs/qt-dbus-${PV} 67 !<x11-libs/qt-dbus-${PV}
38 !>x11-libs/qt-dbus-${PV}-r9999 68 !>x11-libs/qt-dbus-${PV}-r9999
39 !<x11-libs/qt-declarative-${PV} 69 !<x11-libs/qt-declarative-${PV}
76 106
77 # Protect users by not allowing downgrades between releases 107 # Protect users by not allowing downgrades between releases
78 # Downgrading revisions within the same release should be allowed 108 # Downgrading revisions within the same release should be allowed
79 if has_version '>'${CATEGORY}/${P}-r9999; then 109 if has_version '>'${CATEGORY}/${P}-r9999; then
80 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 110 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
111 eerror
81 eerror "Sanity check to keep you from breaking your system:" 112 eerror "Sanity check to keep you from breaking your system:"
82 eerror " Downgrading Qt is completely unsupported and will break your system!" 113 eerror " Downgrading Qt is completely unsupported and will break your system!"
114 eerror
83 die "aborting to save your system" 115 die "aborting to save your system"
84 else 116 else
85 ewarn "Downgrading Qt is completely unsupported and will break your system!" 117 ewarn "Downgrading Qt is completely unsupported and will break your system!"
86 fi 118 fi
87 fi 119 fi
88 120
89 if [[ ${PN} == "qt-webkit" ]]; then 121 if [[ ${PN} == qt-webkit ]]; then
90 eshopts_push -s extglob 122 eshopts_push -s extglob
91 if is-flagq '-g?(gdb)?([1-9])'; then 123 if is-flagq '-g?(gdb)?([1-9])'; then
92 echo 124 echo
93 ewarn "You have enabled debug info (probably have -g or -ggdb in your \$C{,XX}FLAGS)." 125 ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
94 ewarn "You may experience really long compilation times and/or increased memory usage." 126 ewarn "You may experience really long compilation times and/or increased memory usage."
95 ewarn "If compilation fails, please try removing -g{,gdb} before reporting a bug." 127 ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
96 ewarn "For more info check out bug #307861" 128 ewarn "For more info check out bug #307861"
97 echo 129 echo
98 fi 130 fi
99 eshopts_pop 131 eshopts_pop
100 fi 132 fi
110 [[ ${CHOST} == *-apple-darwin* ]] && \ 142 [[ ${CHOST} == *-apple-darwin* ]] && \
111 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm 143 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm
112 ${QT4_EXTRACT_DIRECTORIES}" 144 ${QT4_EXTRACT_DIRECTORIES}"
113 fi 145 fi
114 146
115 # Make sure ebuilds use the required EAPI
116 if [[ ${EAPI} != [234] ]]; then
117 eerror "The qt4-build eclass requires EAPI 2,3 or 4 but this ebuild is using"
118 eerror "EAPI=${EAPI:-0}. The ebuild author or editor failed. This ebuild needs to be"
119 eerror "fixed. Using qt4-build eclass without EAPI 2,3 or 4 will fail."
120 die "qt4-build eclass requires EAPI 2,3 or 4"
121 fi
122
123 if ! version_is_at_least 4.1 $(gcc-version); then 147 if ! version_is_at_least 4.1 $(gcc-version); then
124 ewarn "Using a GCC version lower than 4.1 is not supported!" 148 ewarn "Using a GCC version lower than 4.1 is not supported."
125 fi 149 fi
126} 150}
127 151
128# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES 152# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES
129# @DESCRIPTION: 153# @DESCRIPTION:
139# @DESCRIPTION: 163# @DESCRIPTION:
140# Unpacks the sources. 164# Unpacks the sources.
141qt4-build_src_unpack() { 165qt4-build_src_unpack() {
142 setqtenv 166 setqtenv
143 167
168 case ${QT4_BUILD_TYPE} in
169 live)
170 git-2_src_unpack
171 ;;
172 release)
144 local tarball="${MY_P}.tar.gz" target= targets= 173 local tarball="${MY_P}.tar.gz" target= targets=
145 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \ 174 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \
146 src/{qbase,qt_targets,qt_install}.pri bin config.tests \ 175 src/{qbase,qt_targets,qt_install}.pri bin config.tests \
147 mkspecs qmake ${QT4_EXTRACT_DIRECTORIES} 176 mkspecs qmake ${QT4_EXTRACT_DIRECTORIES}
148 do 177 do
149 targets+="${MY_P}/${target} " 178 targets+="${MY_P}/${target} "
150 done 179 done
151 180
152 ebegin "Unpacking parts of ${tarball}:" ${targets//${MY_P}\/} 181 ebegin "Unpacking parts of ${tarball}:" ${targets//${MY_P}\/}
153 tar -xzf "${DISTDIR}/${tarball}" ${targets} 182 tar -xzf "${DISTDIR}/${tarball}" ${targets}
154 eend $? || die "failed to unpack" 183 eend $? || die "failed to unpack"
184 ;;
185 esac
155} 186}
156 187
157# @ECLASS-VARIABLE: PATCHES 188# @ECLASS-VARIABLE: PATCHES
158# @DEFAULT_UNSET 189# @DEFAULT_UNSET
159# @DESCRIPTION: 190# @DESCRIPTION:
171# @DESCRIPTION: 202# @DESCRIPTION:
172# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix 203# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix
173# the build system in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified in /etc/make.conf. 204# the build system in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified in /etc/make.conf.
174qt4-build_src_prepare() { 205qt4-build_src_prepare() {
175 setqtenv 206 setqtenv
176 cd "${S}"
177 207
208 if [[ ${QT4_BUILD_TYPE} == live ]]; then
209 QTDIR="." ./bin/syncqt || die "syncqt failed"
210 fi
211
178 if version_is_at_least "4.7"; then 212 if version_is_at_least 4.7; then
179 # fix libX11 dependency on non X packages 213 # fix libX11 dependency on non X packages
180 local nolibx11_pkgs="qt-core qt-dbus qt-script qt-sql qt-test qt-xmlpatterns" 214 local nolibx11_pkgs="qt-core qt-dbus qt-script qt-sql qt-test qt-xmlpatterns"
181 has ${PN} ${nolibx11_pkgs} && qt_nolibx11 215 has ${PN} ${nolibx11_pkgs} && qt_nolibx11
182 216
183 qt_assistant_cleanup 217 qt_assistant_cleanup
197 skip_project_generation 231 skip_project_generation
198 symlink_binaries_to_buildtree 232 symlink_binaries_to_buildtree
199 fi 233 fi
200 234
201 if [[ ${CHOST} == *86*-apple-darwin* ]]; then 235 if [[ ${CHOST} == *86*-apple-darwin* ]]; then
202 # qmake bus errors with -O2 but -O3 works 236 # qmake bus errors with -O2 or -O3 but -O1 works
237 # Bug 373061
203 replace-flags -O2 -O3 238 replace-flags -O[23] -O1
204 fi 239 fi
205 240
206 # Bug 178652 241 # Bug 178652
207 if [[ $(gcc-major-version) == 3 ]] && use amd64; then 242 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
208 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS" 243 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
209 append-flags -fno-gcse 244 append-flags -fno-gcse
210 fi 245 fi
211 246
212 if use_if_iuse c++0x; then 247 if use_if_iuse c++0x; then
248 echo
213 ewarn "You are about to build Qt4 using the C++11 standard. Even though" 249 ewarn "You are about to build Qt4 using the C++11 standard. Even though"
214 ewarn "this is an official standard, some of the reverse dependencies" 250 ewarn "this is an official standard, some of the reverse dependencies"
215 ewarn "may fail to compile or link againt the Qt4 libraries. Before" 251 ewarn "may fail to compile or link againt the Qt4 libraries. Before"
216 ewarn "reporting a bug, make sure your bug is reproducible with c++0x" 252 ewarn "reporting a bug, make sure your bug is reproducible with c++0x"
217 ewarn "disabled." 253 ewarn "disabled."
254 echo
218 append-flags -std=c++0x 255 append-flags -std=c++0x
219 fi 256 fi
220 257
221 # Unsupported old gcc versions - hardened needs this :( 258 # Unsupported old gcc versions - hardened needs this :(
222 if [[ $(gcc-major-version) -lt 4 ]]; then 259 if [[ $(gcc-major-version) -lt 4 ]]; then
248 sed -i -e "/bin\/qmake/ s: \"QT_BUILD_TREE=: \ 285 sed -i -e "/bin\/qmake/ s: \"QT_BUILD_TREE=: \
249 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \ 286 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
250 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \ 287 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
251 || die "sed config.tests failed" 288 || die "sed config.tests failed"
252 289
290 if ! version_is_at_least 4.8; then
253 # Strip predefined CFLAGS from mkspecs (bug 312689) 291 # Strip predefined CFLAGS from mkspecs (bugs 312689 and 352778)
254 sed -i -e '/^QMAKE_CFLAGS_RELEASE/s:+=.*:+=:' mkspecs/common/g++.conf || die 292 sed -i -e '/^QMAKE_CFLAGS_RELEASE/s:+=.*:+=:' mkspecs/common/g++.conf || die
293 fi
255 294
256 # Bug 172219 295 # Bug 172219
257 sed -e 's:/X11R6/:/:' -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die 296 sed -e 's:/X11R6/:/:' -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
258 297
259 if [[ ${CHOST} == *-darwin* ]]; then 298 if [[ ${CHOST} == *-darwin* ]]; then
260 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib 299 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib
261 # crippled (by design) :/ 300 # crippled (by design) :/
301 local mac_gpp_conf=
302 if [[ -f mkspecs/common/mac-g++.conf ]]; then
303 # qt < 4.8 has mac-g++.conf
304 mac_gpp_conf="mkspecs/common/mac-g++.conf"
305 elif [[ -f mkspecs/common/g++-macx.conf ]]; then
306 # qt >= 4.8 has g++-macx.conf
307 mac_gpp_conf="mkspecs/common/g++-macx.conf"
308 else
309 die "no known conf file for mac found"
310 fi
262 sed \ 311 sed \
263 -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \ 312 -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
264 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \ 313 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
265 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \ 314 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \
266 -e "s:-arch\s\w*::g" \ 315 -e "s:-arch\s\w*::g" \
267 -i mkspecs/common/mac-g++.conf \ 316 -i ${mac_gpp_conf} \
268 || die "sed mkspecs/common/mac-g++.conf failed" 317 || die "sed ${mac_gpp_conf} failed"
269 318
270 # Fix configure's -arch settings that appear in qmake/Makefile and also 319 # Fix configure's -arch settings that appear in qmake/Makefile and also
271 # fix arch handling (automagically duplicates our -arch arg and breaks 320 # fix arch handling (automagically duplicates our -arch arg and breaks
272 # pch). Additionally disable Xarch support. 321 # pch). Additionally disable Xarch support.
322 local mac_gcc_confs="${mac_gpp_conf}"
323 if [[ -f mkspecs/common/gcc-base-macx.conf ]]; then
324 mac_gcc_confs+=" mkspecs/common/gcc-base-macx.conf"
325 fi
273 sed \ 326 sed \
274 -e "s:-arch i386::" \ 327 -e "s:-arch i386::" \
275 -e "s:-arch ppc::" \ 328 -e "s:-arch ppc::" \
276 -e "s:-arch x86_64::" \ 329 -e "s:-arch x86_64::" \
277 -e "s:-arch ppc64::" \ 330 -e "s:-arch ppc64::" \
278 -e "s:-arch \$i::" \ 331 -e "s:-arch \$i::" \
279 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \ 332 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \
280 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \ 333 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \
281 -e "s:-Xarch_x86_64::g" \ 334 -e "s:-Xarch_x86_64::g" \
282 -e "s:-Xarch_ppc64::g" \ 335 -e "s:-Xarch_ppc64::g" \
283 -i configure mkspecs/common/mac-g++.conf \ 336 -i configure ${mac_gcc_confs} \
284 || die "sed -arch/-Xarch failed" 337 || die "sed -arch/-Xarch failed"
285 338
286 # On Snow Leopard don't fall back to 10.5 deployment target. 339 # On Snow Leopard don't fall back to 10.5 deployment target.
287 if [[ ${CHOST} == *-apple-darwin10 ]]; then 340 if [[ ${CHOST} == *-apple-darwin10 ]]; then
288 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \ 341 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \
289 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \ 342 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \
290 -i configure mkspecs/common/mac-g++.conf \ 343 -i configure ${mac_gpp_conf} \
291 || die "sed deployment target failed" 344 || die "sed deployment target failed"
292 fi 345 fi
293 fi 346 fi
294 347
295 # this one is needed for all systems with a separate -liconv, apart from 348 # this one is needed for all systems with a separate -liconv, apart from
315# @FUNCTION: qt4-build_src_configure 368# @FUNCTION: qt4-build_src_configure
316# @DESCRIPTION: 369# @DESCRIPTION:
317# Default configure phase 370# Default configure phase
318qt4-build_src_configure() { 371qt4-build_src_configure() {
319 setqtenv 372 setqtenv
320 myconf="$(standard_configure_options) ${myconf}" 373
374 local conf="
375 -prefix ${QTPREFIXDIR}
376 -bindir ${QTBINDIR}
377 -libdir ${QTLIBDIR}
378 -docdir ${QTDOCDIR}
379 -headerdir ${QTHEADERDIR}
380 -plugindir ${QTPLUGINDIR}
381 $(version_is_at_least 4.7 && echo -importdir ${QTIMPORTDIR})
382 -datadir ${QTDATADIR}
383 -translationdir ${QTTRANSDIR}
384 -sysconfdir ${QTSYSCONFDIR}
385 -examplesdir ${QTEXAMPLESDIR}
386 -demosdir ${QTDEMOSDIR}
387 -opensource -confirm-license
388 -shared -fast -largefile -stl -verbose
389 -nomake examples -nomake demos"
390
391 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
392 # $(tc-arch). Therefore we convert it to supported values.
393 case "$(tc-arch)" in
394 amd64|x64-*) conf+=" -arch x86_64" ;;
395 ppc-macos) conf+=" -arch ppc" ;;
396 ppc|ppc64|ppc-*) conf+=" -arch powerpc" ;;
397 sparc|sparc-*|sparc64-*) conf+=" -arch sparc" ;;
398 x86-macos) conf+=" -arch x86" ;;
399 x86|x86-*) conf+=" -arch i386" ;;
400 alpha|arm|ia64|mips|s390) conf+=" -arch $(tc-arch)" ;;
401 hppa|sh) conf+=" -arch generic" ;;
402 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
403 esac
404
405 conf+=" -platform $(qt_mkspecs_dir)"
406
407 [[ $(get_libdir) != lib ]] && conf+=" -L${EPREFIX}/usr/$(get_libdir)"
408
409 # debug/release
410 if use debug; then
411 conf+=" -debug"
412 else
413 conf+=" -release"
414 fi
415 conf+=" -no-separate-debug-info"
416
417 # exceptions USE flag
418 conf+=" $(in_iuse exceptions && qt_use exceptions || echo -exceptions)"
419
420 # disable RPATH on Qt >= 4.8 (bug 380415)
421 version_is_at_least 4.8 && conf+=" -no-rpath"
422
423 # precompiled headers don't work on hardened, where the flag is masked
424 conf+=" $(qt_use pch)"
425
426 # -reduce-relocations
427 # This flag seems to introduce major breakage to applications,
428 # mostly to be seen as a core dump with the message "QPixmap: Must
429 # construct a QApplication before a QPaintDevice" on Solaris.
430 # -- Daniel Vergien
431 [[ ${CHOST} != *-solaris* ]] && conf+=" -reduce-relocations"
321 432
322 # this one is needed for all systems with a separate -liconv, apart from 433 # this one is needed for all systems with a separate -liconv, apart from
323 # Darwin, for which the sources already cater for -liconv 434 # Darwin, for which the sources already cater for -liconv
324 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then 435 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then
325 myconf+=" -liconv" 436 conf+=" -liconv"
326 fi 437 fi
327 438
328 if use_if_iuse glib; then 439 if use_if_iuse glib; then
329 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)" 440 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
330 # avoid the -pthread argument 441 # avoid the -pthread argument
331 myconf+=" ${glibflags//-pthread}" 442 conf+=" ${glibflags//-pthread}"
332 unset glibflags 443 unset glibflags
333 fi 444 fi
334 445
335 if use_if_iuse qpa; then 446 if use_if_iuse qpa; then
336 ewarn 447 echo
337 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely" 448 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely"
338 ewarn "known as Qt Lighthouse. If you are not sure what that is, then" 449 ewarn "known as Qt Lighthouse. If you are not sure what that is, then"
339 ewarn "disable it before reporting any bugs related to this useflag." 450 ewarn "disable it before reporting any bugs related to this useflag."
340 ewarn 451 echo
341 myconf+=" -qpa" 452 conf+=" -qpa"
342 fi 453 fi
343 454
344 if use aqua; then 455 if use aqua; then
345 # On (snow) leopard use the new (frameworked) cocoa code. 456 # On (snow) leopard use the new (frameworked) cocoa code.
346 if [[ ${CHOST##*-darwin} -ge 9 ]]; then 457 if [[ ${CHOST##*-darwin} -ge 9 ]]; then
347 myconf+=" -cocoa -framework" 458 conf+=" -cocoa -framework"
348 # We need the source's headers, not the installed ones. 459 # We need the source's headers, not the installed ones.
349 myconf+=" -I${S}/include" 460 conf+=" -I${S}/include"
350 # Add hint for the framework location. 461 # Add hint for the framework location.
351 myconf+=" -F${QTLIBDIR}" 462 conf+=" -F${QTLIBDIR}"
352 463
353 # We are crazy and build cocoa + qt3support :-) 464 # We are crazy and build cocoa + qt3support :-)
354 if use qt3support; then 465 if use qt3support; then
355 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \ 466 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \
356 -i configure || die 467 -i configure || die
357 fi 468 fi
358 else 469 else
359 myconf+=" -no-framework" 470 conf+=" -no-framework"
360 fi 471 fi
361 else 472 else
362 # freetype2 include dir is non-standard, thus include it on configure 473 # freetype2 include dir is non-standard, thus pass it to configure
363 # use -I from configure
364 myconf+=" $(pkg-config --cflags freetype2)" 474 conf+=" $(pkg-config --cflags-only-I freetype2)"
365 fi 475 fi
366 476
477 conf+=" ${myconf}"
478 myconf=
479
367 echo ./configure ${myconf} 480 echo ./configure ${conf}
368 ./configure ${myconf} || die "./configure failed" 481 ./configure ${conf} || die "./configure failed"
369 myconf=""
370 482
371 prepare_directories ${QT4_TARGET_DIRECTORIES} 483 prepare_directories ${QT4_TARGET_DIRECTORIES}
372} 484}
373 485
374# @FUNCTION: qt4-build_src_compile 486# @FUNCTION: qt4-build_src_compile
383# @FUNCTION: qt4-build_src_test 495# @FUNCTION: qt4-build_src_test
384# @DESCRIPTION: 496# @DESCRIPTION:
385# Runs tests only in target directories. 497# Runs tests only in target directories.
386qt4-build_src_test() { 498qt4-build_src_test() {
387 # QtMultimedia does not have any test suite (bug #332299) 499 # QtMultimedia does not have any test suite (bug #332299)
388 [[ ${PN} == "qt-multimedia" ]] && return 500 [[ ${PN} == qt-multimedia ]] && return
389 501
390 for dir in ${QT4_TARGET_DIRECTORIES}; do 502 for dir in ${QT4_TARGET_DIRECTORIES}; do
391 emake -j1 check -C ${dir} 503 emake -j1 check -C ${dir}
392 done 504 done
393} 505}
396# @DESCRIPTION: 508# @DESCRIPTION:
397# For MacOS X we need to add some symlinks when frameworks are 509# For MacOS X we need to add some symlinks when frameworks are
398# being used, to avoid complications with some more or less stupid packages. 510# being used, to avoid complications with some more or less stupid packages.
399fix_includes() { 511fix_includes() {
400 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then 512 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
513 local frw dest f h rdir
401 # Some packages tend to include <Qt/...> 514 # Some packages tend to include <Qt/...>
402 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt 515 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt
403 516
404 # Fake normal headers when frameworks are installed... eases life later on 517 # Fake normal headers when frameworks are installed... eases life later
405 local dest f h 518 # on, make sure we use relative links though, as some ebuilds assume
519 # these dirs exist in src_install to add additional files
520 f=${QTHEADERDIR}
521 h=${QTLIBDIR}
522 while [[ -n ${f} && ${f%%/*} == ${h%%/*} ]] ; do
523 f=${f#*/}
524 h=${h#*/}
525 done
526 rdir=${h}
527 f="../"
528 while [[ ${h} == */* ]] ; do
529 f="${f}../"
530 h=${h#*/}
531 done
532 rdir="${f}${rdir}"
533
406 for frw in "${D}${QTLIBDIR}"/*.framework; do 534 for frw in "${D}${QTLIBDIR}"/*.framework; do
407 [[ -e "${frw}"/Headers ]] || continue 535 [[ -e "${frw}"/Headers ]] || continue
408 f=$(basename ${frw}) 536 f=$(basename ${frw})
409 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework} 537 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework}
410 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers "${dest}" 538 dosym "${rdir}"/${f}/Headers "${dest}"
411 539
412 # Link normal headers as well. 540 # Link normal headers as well.
413 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do 541 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do
414 h=$(basename ${hdr}) 542 h=$(basename ${hdr})
415 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers/${h} "${QTHEADERDIR#${EPREFIX}}"/Qt/${h} 543 dosym "../${rdir}"/${f}/Headers/${h} \
544 "${QTHEADERDIR#${EPREFIX}}"/Qt/${h}
416 done 545 done
417 done 546 done
418 fi 547 fi
419} 548}
420 549
453 QTDEMOSDIR=${QTDATADIR}/demos 582 QTDEMOSDIR=${QTDATADIR}/demos
454 QMAKE_LIBDIR_QT=${QTLIBDIR} 583 QMAKE_LIBDIR_QT=${QTLIBDIR}
455 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4 584 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4
456 585
457 PLATFORM=$(qt_mkspecs_dir) 586 PLATFORM=$(qt_mkspecs_dir)
458
459 unset QMAKESPEC 587 unset QMAKESPEC
460}
461 588
462# @FUNCTION: standard_configure_options 589 export XDG_CONFIG_HOME="${T}"
463# @INTERNAL
464# @DESCRIPTION:
465# Sets up some standard configure options, like libdir (if necessary), whether
466# debug info is wanted or not.
467standard_configure_options() {
468 local myconf="
469 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR}
470 -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR}
471 $(version_is_at_least 4.7 && echo -importdir ${QTIMPORTDIR})
472 -datadir ${QTDATADIR} -translationdir ${QTTRANSDIR} -sysconfdir ${QTSYSCONFDIR}
473 -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR}
474 -opensource -confirm-license -shared -fast -largefile -stl -verbose
475 -platform $(qt_mkspecs_dir) -nomake examples -nomake demos"
476
477 [[ $(get_libdir) != lib ]] && myconf+=" -L${EPREFIX}/usr/$(get_libdir)"
478
479 # debug/release
480 if use debug; then
481 myconf+=" -debug"
482 else
483 myconf+=" -release"
484 fi
485 myconf+=" -no-separate-debug-info"
486
487 # exceptions USE flag
488 myconf+=" $(in_iuse exceptions && qt_use exceptions || echo -exceptions)"
489
490 # disable RPATH on Qt >= 4.8 (bug 380415)
491 version_is_at_least 4.8 && myconf+=" -no-rpath"
492
493 # precompiled headers don't work on hardened, where the flag is masked
494 myconf+=" $(qt_use pch)"
495
496 # -reduce-relocations
497 # This flag seems to introduce major breakage to applications,
498 # mostly to be seen as a core dump with the message "QPixmap: Must
499 # construct a QApplication before a QPaintDevice" on Solaris.
500 # -- Daniel Vergien
501 [[ ${CHOST} != *-solaris* ]] && myconf+=" -reduce-relocations"
502
503 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
504 # $(tc-arch). Therefore we convert it to supported values.
505 case "$(tc-arch)" in
506 amd64|x64-*) myconf+=" -arch x86_64" ;;
507 ppc-macos) myconf+=" -arch ppc" ;;
508 ppc|ppc64|ppc-*) myconf+=" -arch powerpc" ;;
509 sparc|sparc-*|sparc64-*) myconf+=" -arch sparc" ;;
510 x86-macos) myconf+=" -arch x86" ;;
511 x86|x86-*) myconf+=" -arch i386" ;;
512 alpha|arm|ia64|mips|s390) myconf+=" -arch $(tc-arch)" ;;
513 hppa|sh) myconf+=" -arch generic" ;;
514 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
515 esac
516
517 echo "${myconf}"
518} 590}
519 591
520# @FUNCTION: prepare_directories 592# @FUNCTION: prepare_directories
521# @USAGE: < directories > 593# @USAGE: < directories >
522# @INTERNAL 594# @INTERNAL
609# @FUNCTION: generate_qconfigs 681# @FUNCTION: generate_qconfigs
610# @INTERNAL 682# @INTERNAL
611# @DESCRIPTION: 683# @DESCRIPTION:
612# Generates gentoo-specific qconfig.{h,pri}. 684# Generates gentoo-specific qconfig.{h,pri}.
613generate_qconfigs() { 685generate_qconfigs() {
614 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then 686 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${PN} == qt-core ]]; then
615 local x qconfig_add qconfig_remove qconfig_new 687 local x qconfig_add qconfig_remove qconfig_new
616 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do 688 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do
617 [[ -f ${x} ]] || continue 689 [[ -f ${x} ]] || continue
618 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")" 690 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")"
619 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")" 691 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")"
750# @RETURN: the specs-directory w/o path 822# @RETURN: the specs-directory w/o path
751# @DESCRIPTION: 823# @DESCRIPTION:
752# Allows us to define which mkspecs dir we want to use. 824# Allows us to define which mkspecs dir we want to use.
753qt_mkspecs_dir() { 825qt_mkspecs_dir() {
754 local spec= 826 local spec=
827
755 case ${CHOST} in 828 case "${CHOST}" in
756 *-freebsd*|*-dragonfly*) 829 *-freebsd*|*-dragonfly*)
757 spec=freebsd ;; 830 spec=freebsd ;;
758 *-openbsd*) 831 *-openbsd*)
759 spec=openbsd ;; 832 spec=openbsd ;;
760 *-netbsd*) 833 *-netbsd*)
771 *-solaris*) 844 *-solaris*)
772 spec=solaris ;; 845 spec=solaris ;;
773 *-linux-*|*-linux) 846 *-linux-*|*-linux)
774 spec=linux ;; 847 spec=linux ;;
775 *) 848 *)
776 die "Unknown CHOST, no platform chosen" 849 die "${FUNCNAME}(): Unknown CHOST '${CHOST}'" ;;
777 esac 850 esac
778 851
779 CXX=$(tc-getCXX) 852 case "$(tc-getCXX)" in
780 if [[ ${CXX} == *g++* ]]; then 853 *g++*)
781 spec+=-g++ 854 spec+=-g++ ;;
782 elif [[ ${CXX} == *icpc* ]]; then 855 *icpc*)
783 spec+=-icc 856 spec+=-icc ;;
784 else 857 *)
785 die "Unknown compiler '${CXX}'" 858 die "${FUNCNAME}(): Unknown compiler '$(tc-getCXX)'" ;;
786 fi 859 esac
787 860
788 # Add -64 for 64bit profiles 861 # Add -64 for 64bit profiles
789 if use x64-freebsd || 862 if use x64-freebsd ||
790 use amd64-linux || 863 use amd64-linux ||
791 use x64-macos || 864 use x64-macos ||
804# Tries to clean up tools.pro for qt-assistant ebuilds. 877# Tries to clean up tools.pro for qt-assistant ebuilds.
805# Meant to be called in src_prepare(). 878# Meant to be called in src_prepare().
806# Since Qt 4.7.4 this function is a no-op. 879# Since Qt 4.7.4 this function is a no-op.
807qt_assistant_cleanup() { 880qt_assistant_cleanup() {
808 # apply patching to qt-assistant ebuilds only 881 # apply patching to qt-assistant ebuilds only
809 [[ ${PN} != "qt-assistant" ]] && return 882 [[ ${PN} != qt-assistant ]] && return
810 883
811 # no longer needed for 4.7.4 and later 884 # no longer needed for 4.7.4 and later
812 version_is_at_least "4.7.4" && return 885 version_is_at_least 4.7.4 && return
813 886
814 # different versions (and branches...) may need different handling, 887 # different versions (and branches...) may need different handling,
815 # add a case if you need special handling 888 # add a case if you need special handling
816 case "${MY_PV_EXTRA}" in 889 case "${MY_PV_EXTRA}" in
817 *kde-qt*) 890 *kde-qt*)

Legend:
Removed from v.1.120  
changed lines
  Added in v.1.130

  ViewVC Help
Powered by ViewVC 1.1.20