/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.25 Revision 1.130
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.25 2009/03/04 20:37:08 yngwin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.130 2012/05/22 13:41:59 pesa Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Ben de Groot <yngwin@gentoo.org>, 7# Qt herd <qt@gentoo.org>
8# Markos Chandras <hwoarang@gentoo.org>,
9# Caleb Tennis <caleb@gentoo.org>
10# @BLURB: Eclass for Qt4 split ebuilds. 8# @BLURB: Eclass for Qt4 split ebuilds.
11# @DESCRIPTION: 9# @DESCRIPTION:
12# This eclass contains various functions that are used when building Qt4 10# This eclass contains various functions that are used when building Qt4.
13 11
14inherit eutils multilib toolchain-funcs flag-o-matic versionator
15
16IUSE="${IUSE} custom-cxxflags debug pch"
17
18case "${PV}" in 12case ${EAPI} in
19 4.?.?_rc*) 13 2|3|4) : ;;
20 SRCTYPE="${SRCTYPE:-opensource-src}" 14 *) die "qt4-build.eclass requires EAPI 2, 3 or 4." ;;
15esac
16
17inherit base eutils flag-o-matic multilib toolchain-funcs versionator
18
19if [[ ${PV} == *9999* ]]; then
20 QT4_BUILD_TYPE="live"
21 inherit git-2
22else
23 QT4_BUILD_TYPE="release"
24fi
25
26HOMEPAGE="http://qt-project.org/ http://qt.nokia.com/"
27LICENSE="|| ( LGPL-2.1 GPL-3 )"
28
21 MY_PV="${PV/_rc/-rc}" 29MY_PV=${PV/_/-}
30MY_P=qt-everywhere-opensource-src-${MY_PV}
31
32case ${QT4_BUILD_TYPE} in
33 live)
34 EGIT_REPO_URI="git://gitorious.org/qt/qt.git
35 https://git.gitorious.org/qt/qt.git"
36 EGIT_BRANCH="${PV%.9999}"
22 ;; 37 ;;
23 *) 38 release)
24 SRCTYPE="${SRCTYPE:-opensource-src}" 39 if version_is_at_least 4.8.1; then
25 MY_PV="${PV}" 40 SRC_URI="http://releases.qt-project.org/qt4/source/${MY_P}.tar.gz"
41 else
42 SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
43 fi
26 ;; 44 ;;
27esac 45esac
28MY_P=qt-x11-${SRCTYPE}-${MY_PV} 46
47IUSE="aqua debug pch"
48if [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]]; then
49 IUSE+=" +exceptions"
50fi
51if version_is_at_least 4.8; then
52 IUSE+=" c++0x qpa"
53fi
54
55DEPEND="virtual/pkgconfig"
56if [[ ${QT4_BUILD_TYPE} == live ]]; then
57 DEPEND+=" dev-lang/perl"
58fi
59
60RDEPEND="
61 !<x11-libs/qt-assistant-${PV}
62 !>x11-libs/qt-assistant-${PV}-r9999
63 !<x11-libs/qt-bearer-${PV}
64 !>x11-libs/qt-bearer-${PV}-r9999
65 !<x11-libs/qt-core-${PV}
66 !>x11-libs/qt-core-${PV}-r9999
67 !<x11-libs/qt-dbus-${PV}
68 !>x11-libs/qt-dbus-${PV}-r9999
69 !<x11-libs/qt-declarative-${PV}
70 !>x11-libs/qt-declarative-${PV}-r9999
71 !<x11-libs/qt-demo-${PV}
72 !>x11-libs/qt-demo-${PV}-r9999
73 !<x11-libs/qt-gui-${PV}
74 !>x11-libs/qt-gui-${PV}-r9999
75 !<x11-libs/qt-multimedia-${PV}
76 !>x11-libs/qt-multimedia-${PV}-r9999
77 !<x11-libs/qt-opengl-${PV}
78 !>x11-libs/qt-opengl-${PV}-r9999
79 !<x11-libs/qt-openvg-${PV}
80 !>x11-libs/qt-openvg-${PV}-r9999
81 !<x11-libs/qt-phonon-${PV}
82 !>x11-libs/qt-phonon-${PV}-r9999
83 !<x11-libs/qt-qt3support-${PV}
84 !>x11-libs/qt-qt3support-${PV}-r9999
85 !<x11-libs/qt-script-${PV}
86 !>x11-libs/qt-script-${PV}-r9999
87 !<x11-libs/qt-sql-${PV}
88 !>x11-libs/qt-sql-${PV}-r9999
89 !<x11-libs/qt-svg-${PV}
90 !>x11-libs/qt-svg-${PV}-r9999
91 !<x11-libs/qt-test-${PV}
92 !>x11-libs/qt-test-${PV}-r9999
93 !<x11-libs/qt-webkit-${PV}
94 !>x11-libs/qt-webkit-${PV}-r9999
95 !<x11-libs/qt-xmlpatterns-${PV}
96 !>x11-libs/qt-xmlpatterns-${PV}-r9999
97"
98
29S=${WORKDIR}/${MY_P} 99S=${WORKDIR}/${MY_P}
30 100
31HOMEPAGE="http://www.qtsoftware.com/" 101# @FUNCTION: qt4-build_pkg_setup
32SRC_URI="http://download.qtsoftware.com/qt/source/${MY_P}.tar.bz2" 102# @DESCRIPTION:
33 103# Sets up PATH and LD_LIBRARY_PATH.
34case "${PV}" in
35 4.4.?) SRC_URI="${SRC_URI} mirror://gentoo/${MY_P}-headers.tar.bz2" ;;
36 *) ;;
37esac
38
39if version_is_at_least 4.5 ${PV} ; then
40 LICENSE="|| ( LGPL-2.1 GPL-3 )"
41fi
42
43qt4-build_pkg_setup() { 104qt4-build_pkg_setup() {
44 # EAPI=2 ebuilds set use-deps, others need this: 105 [[ ${EAPI} == 2 ]] && use !prefix && EPREFIX=
45 if [[ $EAPI != 2 ]]; then 106
46 # Make sure debug setting corresponds with qt-core (bug 258512) 107 # Protect users by not allowing downgrades between releases
47 if [[ $PN != "qt-core" ]]; then 108 # Downgrading revisions within the same release should be allowed
48 use debug && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} 109 if has_version '>'${CATEGORY}/${P}-r9999; then
49 ~x11-libs/qt-core-${PV} debug" 110 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
111 eerror
112 eerror "Sanity check to keep you from breaking your system:"
113 eerror " Downgrading Qt is completely unsupported and will break your system!"
114 eerror
115 die "aborting to save your system"
116 else
117 ewarn "Downgrading Qt is completely unsupported and will break your system!"
50 fi 118 fi
119 fi
51 120
52 # Check USE requirements 121 if [[ ${PN} == qt-webkit ]]; then
53 qt4-build_check_use 122 eshopts_push -s extglob
123 if is-flagq '-g?(gdb)?([1-9])'; then
124 echo
125 ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
126 ewarn "You may experience really long compilation times and/or increased memory usage."
127 ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
128 ewarn "For more info check out bug #307861"
129 echo
54 fi 130 fi
131 eshopts_pop
132 fi
55 133
134 PATH="${S}/bin${PATH:+:}${PATH}"
135 if [[ ${CHOST} != *-darwin* ]]; then
136 LD_LIBRARY_PATH="${S}/lib${LD_LIBRARY_PATH:+:}${LD_LIBRARY_PATH}"
137 else
138 DYLD_LIBRARY_PATH="${S}/lib${DYLD_LIBRARY_PATH:+:}${DYLD_LIBRARY_PATH}"
139 # On MacOS we *need* at least src/gui/kernel/qapplication_mac.mm for
140 # platform detection. Note: needs to come before any directories to
141 # avoid extract failure.
142 [[ ${CHOST} == *-apple-darwin* ]] && \
143 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm
144 ${QT4_EXTRACT_DIRECTORIES}"
145 fi
146
147 if ! version_is_at_least 4.1 $(gcc-version); then
148 ewarn "Using a GCC version lower than 4.1 is not supported."
149 fi
150}
151
152# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES
153# @DESCRIPTION:
154# Arguments for build_target_directories. Takes the directories in which the
155# code should be compiled. This is a space-separated list.
156
157# @ECLASS-VARIABLE: QT4_EXTRACT_DIRECTORIES
158# @DESCRIPTION:
159# Space-separated list including the directories that will be extracted from
160# Qt tarball.
161
162# @FUNCTION: qt4-build_src_unpack
163# @DESCRIPTION:
164# Unpacks the sources.
165qt4-build_src_unpack() {
166 setqtenv
167
168 case ${QT4_BUILD_TYPE} in
169 live)
170 git-2_src_unpack
171 ;;
172 release)
173 local tarball="${MY_P}.tar.gz" target= targets=
174 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \
175 src/{qbase,qt_targets,qt_install}.pri bin config.tests \
176 mkspecs qmake ${QT4_EXTRACT_DIRECTORIES}
177 do
178 targets+="${MY_P}/${target} "
179 done
180
181 ebegin "Unpacking parts of ${tarball}:" ${targets//${MY_P}\/}
182 tar -xzf "${DISTDIR}/${tarball}" ${targets}
183 eend $? || die "failed to unpack"
184 ;;
185 esac
186}
187
188# @ECLASS-VARIABLE: PATCHES
189# @DEFAULT_UNSET
190# @DESCRIPTION:
191# PATCHES array variable containing all various patches to be applied.
192# This variable is expected to be defined in global scope of ebuild.
193# Make sure to specify the full path. This variable is utilised in
194# src_unpack/src_prepare phase, based on EAPI.
195#
196# @CODE
197# PATCHES=( "${FILESDIR}/mypatch.patch"
198# "${FILESDIR}/patches_folder/" )
199# @CODE
200
201# @FUNCTION: qt4-build_src_prepare
202# @DESCRIPTION:
203# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix
204# the build system in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified in /etc/make.conf.
205qt4-build_src_prepare() {
206 setqtenv
207
208 if [[ ${QT4_BUILD_TYPE} == live ]]; then
209 QTDIR="." ./bin/syncqt || die "syncqt failed"
210 fi
211
212 if version_is_at_least 4.7; then
213 # fix libX11 dependency on non X packages
214 local nolibx11_pkgs="qt-core qt-dbus qt-script qt-sql qt-test qt-xmlpatterns"
215 has ${PN} ${nolibx11_pkgs} && qt_nolibx11
216
217 qt_assistant_cleanup
218 fi
219
220 if use aqua; then
221 # provide a proper macx-g++-64
222 use x64-macos && ln -s macx-g++ mkspecs/$(qt_mkspecs_dir)
223
224 sed -e '/^CONFIG/s:app_bundle::' \
225 -e '/^CONFIG/s:plugin_no_soname:plugin_with_soname absolute_library_soname:' \
226 -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
227 fi
228
229 if [[ ${PN} != qt-core ]]; then
230 skip_qmake_build
231 skip_project_generation
232 symlink_binaries_to_buildtree
233 fi
234
235 if [[ ${CHOST} == *86*-apple-darwin* ]]; then
236 # qmake bus errors with -O2 or -O3 but -O1 works
237 # Bug 373061
238 replace-flags -O[23] -O1
239 fi
240
241 # Bug 178652
242 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
243 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
244 append-flags -fno-gcse
245 fi
246
247 if use_if_iuse c++0x; then
248 echo
249 ewarn "You are about to build Qt4 using the C++11 standard. Even though"
250 ewarn "this is an official standard, some of the reverse dependencies"
251 ewarn "may fail to compile or link againt the Qt4 libraries. Before"
252 ewarn "reporting a bug, make sure your bug is reproducible with c++0x"
253 ewarn "disabled."
254 echo
255 append-flags -std=c++0x
256 fi
257
258 # Unsupported old gcc versions - hardened needs this :(
259 if [[ $(gcc-major-version) -lt 4 ]]; then
260 ewarn "Appending -fno-stack-protector to CXXFLAGS"
261 append-cxxflags -fno-stack-protector
262 # Bug 253127
263 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \
264 -i mkspecs/common/g++.conf || die
265 fi
266
267 # Bug 261632
268 if use ppc64; then
269 ewarn "Appending -mminimal-toc to CFLAGS/CXXFLAGS"
270 append-flags -mminimal-toc
271 fi
272
273 # Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
274 sed -e "/^SYSTEM_VARIABLES=/i \
275 CC='$(tc-getCC)'\n\
276 CXX='$(tc-getCXX)'\n\
277 CFLAGS='${CFLAGS}'\n\
278 CXXFLAGS='${CXXFLAGS}'\n\
279 LDFLAGS='${LDFLAGS}'\n" \
280 -i configure \
281 || die "sed SYSTEM_VARIABLES failed"
282
283 # Respect CC, CXX, LINK and *FLAGS in config.tests
284 find config.tests/unix -name '*.test' -type f -print0 | xargs -0 \
285 sed -i -e "/bin\/qmake/ s: \"QT_BUILD_TREE=: \
286 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
287 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
288 || die "sed config.tests failed"
289
290 if ! version_is_at_least 4.8; then
291 # Strip predefined CFLAGS from mkspecs (bugs 312689 and 352778)
292 sed -i -e '/^QMAKE_CFLAGS_RELEASE/s:+=.*:+=:' mkspecs/common/g++.conf || die
293 fi
294
295 # Bug 172219
296 sed -e 's:/X11R6/:/:' -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
297
298 if [[ ${CHOST} == *-darwin* ]]; then
299 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib
300 # crippled (by design) :/
301 local mac_gpp_conf=
302 if [[ -f mkspecs/common/mac-g++.conf ]]; then
303 # qt < 4.8 has mac-g++.conf
304 mac_gpp_conf="mkspecs/common/mac-g++.conf"
305 elif [[ -f mkspecs/common/g++-macx.conf ]]; then
306 # qt >= 4.8 has g++-macx.conf
307 mac_gpp_conf="mkspecs/common/g++-macx.conf"
308 else
309 die "no known conf file for mac found"
310 fi
311 sed \
312 -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
313 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
314 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \
315 -e "s:-arch\s\w*::g" \
316 -i ${mac_gpp_conf} \
317 || die "sed ${mac_gpp_conf} failed"
318
319 # Fix configure's -arch settings that appear in qmake/Makefile and also
320 # fix arch handling (automagically duplicates our -arch arg and breaks
321 # pch). Additionally disable Xarch support.
322 local mac_gcc_confs="${mac_gpp_conf}"
323 if [[ -f mkspecs/common/gcc-base-macx.conf ]]; then
324 mac_gcc_confs+=" mkspecs/common/gcc-base-macx.conf"
325 fi
326 sed \
327 -e "s:-arch i386::" \
328 -e "s:-arch ppc::" \
329 -e "s:-arch x86_64::" \
330 -e "s:-arch ppc64::" \
331 -e "s:-arch \$i::" \
332 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \
333 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \
334 -e "s:-Xarch_x86_64::g" \
335 -e "s:-Xarch_ppc64::g" \
336 -i configure ${mac_gcc_confs} \
337 || die "sed -arch/-Xarch failed"
338
339 # On Snow Leopard don't fall back to 10.5 deployment target.
340 if [[ ${CHOST} == *-apple-darwin10 ]]; then
341 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \
342 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \
343 -i configure ${mac_gpp_conf} \
344 || die "sed deployment target failed"
345 fi
346 fi
347
348 # this one is needed for all systems with a separate -liconv, apart from
349 # Darwin, for which the sources already cater for -liconv
350 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then
351 sed -e 's|mac:\(LIBS += -liconv\)|\1|g' \
352 -i config.tests/unix/iconv/iconv.pro \
353 || die "sed iconv.pro failed"
354 fi
355
356 # we need some patches for Solaris
357 sed -i -e '/^QMAKE_LFLAGS_THREAD/a\QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,' \
358 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
359 # use GCC over SunStudio
360 sed -i -e '/PLATFORM=solaris-cc/s/cc/g++/' configure || die
361 # do not flirt with non-Prefix stuff, we're quite possessive
362 sed -i -e '/^QMAKE_\(LIB\|INC\)DIR\(_X11\|_OPENGL\|\)\t/s/=.*$/=/' \
363 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
364
365 base_src_prepare
366}
367
368# @FUNCTION: qt4-build_src_configure
369# @DESCRIPTION:
370# Default configure phase
371qt4-build_src_configure() {
372 setqtenv
373
374 local conf="
375 -prefix ${QTPREFIXDIR}
376 -bindir ${QTBINDIR}
377 -libdir ${QTLIBDIR}
378 -docdir ${QTDOCDIR}
379 -headerdir ${QTHEADERDIR}
380 -plugindir ${QTPLUGINDIR}
381 $(version_is_at_least 4.7 && echo -importdir ${QTIMPORTDIR})
382 -datadir ${QTDATADIR}
383 -translationdir ${QTTRANSDIR}
384 -sysconfdir ${QTSYSCONFDIR}
385 -examplesdir ${QTEXAMPLESDIR}
386 -demosdir ${QTDEMOSDIR}
387 -opensource -confirm-license
388 -shared -fast -largefile -stl -verbose
389 -nomake examples -nomake demos"
390
391 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
392 # $(tc-arch). Therefore we convert it to supported values.
393 case "$(tc-arch)" in
394 amd64|x64-*) conf+=" -arch x86_64" ;;
395 ppc-macos) conf+=" -arch ppc" ;;
396 ppc|ppc64|ppc-*) conf+=" -arch powerpc" ;;
397 sparc|sparc-*|sparc64-*) conf+=" -arch sparc" ;;
398 x86-macos) conf+=" -arch x86" ;;
399 x86|x86-*) conf+=" -arch i386" ;;
400 alpha|arm|ia64|mips|s390) conf+=" -arch $(tc-arch)" ;;
401 hppa|sh) conf+=" -arch generic" ;;
402 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
403 esac
404
405 conf+=" -platform $(qt_mkspecs_dir)"
406
407 [[ $(get_libdir) != lib ]] && conf+=" -L${EPREFIX}/usr/$(get_libdir)"
408
409 # debug/release
410 if use debug; then
411 conf+=" -debug"
412 else
413 conf+=" -release"
414 fi
415 conf+=" -no-separate-debug-info"
416
417 # exceptions USE flag
418 conf+=" $(in_iuse exceptions && qt_use exceptions || echo -exceptions)"
419
420 # disable RPATH on Qt >= 4.8 (bug 380415)
421 version_is_at_least 4.8 && conf+=" -no-rpath"
422
423 # precompiled headers don't work on hardened, where the flag is masked
424 conf+=" $(qt_use pch)"
425
426 # -reduce-relocations
427 # This flag seems to introduce major breakage to applications,
428 # mostly to be seen as a core dump with the message "QPixmap: Must
429 # construct a QApplication before a QPaintDevice" on Solaris.
430 # -- Daniel Vergien
431 [[ ${CHOST} != *-solaris* ]] && conf+=" -reduce-relocations"
432
433 # this one is needed for all systems with a separate -liconv, apart from
434 # Darwin, for which the sources already cater for -liconv
435 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]]; then
436 conf+=" -liconv"
437 fi
438
439 if use_if_iuse glib; then
440 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
441 # avoid the -pthread argument
442 conf+=" ${glibflags//-pthread}"
443 unset glibflags
444 fi
445
446 if use_if_iuse qpa; then
447 echo
448 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely"
449 ewarn "known as Qt Lighthouse. If you are not sure what that is, then"
450 ewarn "disable it before reporting any bugs related to this useflag."
451 echo
452 conf+=" -qpa"
453 fi
454
455 if use aqua; then
456 # On (snow) leopard use the new (frameworked) cocoa code.
457 if [[ ${CHOST##*-darwin} -ge 9 ]]; then
458 conf+=" -cocoa -framework"
459 # We need the source's headers, not the installed ones.
460 conf+=" -I${S}/include"
461 # Add hint for the framework location.
462 conf+=" -F${QTLIBDIR}"
463
464 # We are crazy and build cocoa + qt3support :-)
465 if use qt3support; then
466 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \
467 -i configure || die
468 fi
469 else
470 conf+=" -no-framework"
471 fi
472 else
473 # freetype2 include dir is non-standard, thus pass it to configure
474 conf+=" $(pkg-config --cflags-only-I freetype2)"
475 fi
476
477 conf+=" ${myconf}"
478 myconf=
479
480 echo ./configure ${conf}
481 ./configure ${conf} || die "./configure failed"
482
483 prepare_directories ${QT4_TARGET_DIRECTORIES}
484}
485
486# @FUNCTION: qt4-build_src_compile
487# @DESCRIPTION:
488# Actual compile phase
489qt4-build_src_compile() {
490 setqtenv
491
492 build_directories ${QT4_TARGET_DIRECTORIES}
493}
494
495# @FUNCTION: qt4-build_src_test
496# @DESCRIPTION:
497# Runs tests only in target directories.
498qt4-build_src_test() {
499 # QtMultimedia does not have any test suite (bug #332299)
500 [[ ${PN} == qt-multimedia ]] && return
501
502 for dir in ${QT4_TARGET_DIRECTORIES}; do
503 emake -j1 check -C ${dir}
504 done
505}
506
507# @FUNCTION: fix_includes
508# @DESCRIPTION:
509# For MacOS X we need to add some symlinks when frameworks are
510# being used, to avoid complications with some more or less stupid packages.
511fix_includes() {
512 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
513 local frw dest f h rdir
514 # Some packages tend to include <Qt/...>
515 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt
516
517 # Fake normal headers when frameworks are installed... eases life later
518 # on, make sure we use relative links though, as some ebuilds assume
519 # these dirs exist in src_install to add additional files
520 f=${QTHEADERDIR}
521 h=${QTLIBDIR}
522 while [[ -n ${f} && ${f%%/*} == ${h%%/*} ]] ; do
523 f=${f#*/}
524 h=${h#*/}
525 done
526 rdir=${h}
527 f="../"
528 while [[ ${h} == */* ]] ; do
529 f="${f}../"
530 h=${h#*/}
531 done
532 rdir="${f}${rdir}"
533
534 for frw in "${D}${QTLIBDIR}"/*.framework; do
535 [[ -e "${frw}"/Headers ]] || continue
536 f=$(basename ${frw})
537 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework}
538 dosym "${rdir}"/${f}/Headers "${dest}"
539
540 # Link normal headers as well.
541 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do
542 h=$(basename ${hdr})
543 dosym "../${rdir}"/${f}/Headers/${h} \
544 "${QTHEADERDIR#${EPREFIX}}"/Qt/${h}
545 done
546 done
547 fi
548}
549
550# @FUNCTION: qt4-build_src_install
551# @DESCRIPTION:
552# Perform the actual installation including some library fixes.
553qt4-build_src_install() {
554 [[ ${EAPI} == 2 ]] && use !prefix && ED=${D}
555 setqtenv
556
557 install_directories ${QT4_TARGET_DIRECTORIES}
558 install_qconfigs
559 fix_library_files
560 fix_includes
561
562 # remove .la files since we are building only shared Qt libraries
563 find "${D}"${QTLIBDIR} -type f -name '*.la' -print0 | xargs -0 rm -f
564}
565
566# @FUNCTION: setqtenv
567# @INTERNAL
568setqtenv() {
56 # Set up installation directories 569 # Set up installation directories
57 QTBASEDIR=/usr/$(get_libdir)/qt4
58 QTPREFIXDIR=/usr 570 QTPREFIXDIR=${EPREFIX}/usr
59 QTBINDIR=/usr/bin 571 QTBINDIR=${EPREFIX}/usr/bin
60 QTLIBDIR=/usr/$(get_libdir)/qt4 572 QTLIBDIR=${EPREFIX}/usr/$(get_libdir)/qt4
61 QTPCDIR=/usr/$(get_libdir)/pkgconfig 573 QTPCDIR=${EPREFIX}/usr/$(get_libdir)/pkgconfig
62 QTDATADIR=/usr/share/qt4
63 QTDOCDIR=/usr/share/doc/qt-${PV} 574 QTDOCDIR=${EPREFIX}/usr/share/doc/qt-${PV}
64 QTHEADERDIR=/usr/include/qt4 575 QTHEADERDIR=${EPREFIX}/usr/include/qt4
65 QTPLUGINDIR=${QTLIBDIR}/plugins 576 QTPLUGINDIR=${QTLIBDIR}/plugins
66 QTSYSCONFDIR=/etc/qt4 577 QTIMPORTDIR=${QTLIBDIR}/imports
578 QTDATADIR=${EPREFIX}/usr/share/qt4
67 QTTRANSDIR=${QTDATADIR}/translations 579 QTTRANSDIR=${QTDATADIR}/translations
580 QTSYSCONFDIR=${EPREFIX}/etc/qt4
68 QTEXAMPLESDIR=${QTDATADIR}/examples 581 QTEXAMPLESDIR=${QTDATADIR}/examples
69 QTDEMOSDIR=${QTDATADIR}/demos 582 QTDEMOSDIR=${QTDATADIR}/demos
583 QMAKE_LIBDIR_QT=${QTLIBDIR}
584 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4
70 585
71 PLATFORM=$(qt_mkspecs_dir) 586 PLATFORM=$(qt_mkspecs_dir)
587 unset QMAKESPEC
72 588
73 PATH="${S}/bin:${PATH}" 589 export XDG_CONFIG_HOME="${T}"
74 LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
75
76 if ! version_is_at_least 4.1 $(gcc-version) ; then
77 ewarn "Using a GCC version lower than 4.1 is not supported!"
78 echo
79 ebeep 5
80 fi
81
82 if use custom-cxxflags; then
83 echo
84 ewarn "You have set USE=custom-cxxflags, which means Qt will be built with the"
85 ewarn "CXXFLAGS you have set in /etc/make.conf. This is not supported, and we"
86 ewarn "recommend to unset this useflag. But you are free to experiment with it."
87 ewarn "Just do not start crying if it breaks your system, or eats your kitten"
88 ewarn "for breakfast. ;-) "
89 echo
90 fi
91
92} 590}
93 591
94qt4-build_src_unpack() { 592# @FUNCTION: prepare_directories
95 local target targets 593# @USAGE: < directories >
96 for target in configure LICENSE.{GPL2,GPL3} projects.pro \ 594# @INTERNAL
97 src/{qbase,qt_targets,qt_install}.pri bin config.tests mkspecs qmake \ 595# @DESCRIPTION:
98 ${QT4_EXTRACT_DIRECTORIES}; do 596# Generates Makefiles for the given list of directories.
99 targets="${targets} ${MY_P}/${target}" 597prepare_directories() {
598 for x in "$@"; do
599 pushd "${S}"/${x} >/dev/null || die
600 einfo "Running qmake in: ${x}"
601 # avoid running over the maximum argument number, bug #299810
602 {
603 echo "${S}"/mkspecs/common/*.conf
604 find "${S}" -name '*.pr[io]'
605 } | xargs sed -i \
606 -e "s:\$\$\[QT_INSTALL_LIBS\]:${QTLIBDIR}:g" \
607 -e "s:\$\$\[QT_INSTALL_PLUGINS\]:${QTPLUGINDIR}:g" \
608 || die
609 "${S}"/bin/qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" || die "qmake failed"
610 popd >/dev/null || die
100 done 611 done
101
102 echo tar xjpf "${DISTDIR}"/${MY_P}.tar.bz2 ${targets}
103 tar xjpf "${DISTDIR}"/${MY_P}.tar.bz2 ${targets}
104
105 case "${PV}" in
106 4.4.?)
107 echo tar xjpf "${DISTDIR}"/${MY_P}-headers.tar.bz2
108 tar xjpf "${DISTDIR}"/${MY_P}-headers.tar.bz2
109 ;;
110 esac
111
112 # Be backwards compatible for now
113 if [[ $EAPI != 2 ]]; then
114 qt4-build_src_prepare
115 fi
116} 612}
117 613
118qt4-build_src_prepare() {
119 cd "${S}"
120 614
121 if [[ ${PN} != qt-core ]]; then 615# @FUNCTION: build_directories
122 skip_qmake_build_patch 616# @USAGE: < directories >
123 skip_project_generation_patch 617# @INTERNAL
124 symlink_binaries_to_buildtree 618# @DESCRIPTION:
125 fi 619# Compiles the code in the given list of directories.
126
127 if ! use custom-cxxflags;then
128 # Don't let the user go too overboard with flags.
129 strip-flags
130 replace-flags -O3 -O2
131 fi
132
133 # Bug 253127
134 # Unsupported old gcc versions - hardened needs this :(
135 if [[ $(gcc-major-version) -lt "4" ]] ; then
136 ewarn "Appending -fno-stack-protector to CXXFLAGS"
137 append-cxxflags -fno-stack-protector
138 fi
139
140 # Bug 178652
141 if [[ "$(gcc-major-version)" == "3" ]] && use amd64; then
142 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
143 append-flags -fno-gcse
144 fi
145
146 # Bug 172219
147 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
148 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
149 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
150 -e "s:X11R6/::" \
151 -i "${S}"/mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed ${S}/mkspecs/$(qt_mkspecs_dir)/qmake.conf failed"
152
153 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
154 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
155 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
156 -i "${S}"/mkspecs/common/g++.conf || die "sed ${S}/mkspecs/common/g++.conf failed"
157
158}
159
160qt4-build_src_configure() {
161
162 myconf="$(standard_configure_options) ${myconf}"
163
164 echo ./configure ${myconf}
165 ./configure ${myconf} || die "./configure failed"
166}
167
168qt4-build_src_compile() {
169 # Be backwards compatible for now
170 if [[ $EAPI != 2 ]]; then
171 qt4-build_src_configure
172 fi
173
174 build_directories "${QT4_TARGET_DIRECTORIES}"
175}
176
177qt4-build_src_install() {
178 install_directories "${QT4_TARGET_DIRECTORIES}"
179 install_qconfigs
180 fix_library_files
181}
182
183standard_configure_options() {
184 local myconf=""
185
186 [[ $(get_libdir) != "lib" ]] && myconf="${myconf} -L/usr/$(get_libdir)"
187
188 # Disable visibility explicitly if gcc version isn't 4
189 if [[ "$(gcc-major-version)" -lt "4" ]]; then
190 myconf="${myconf} -no-reduce-exports"
191 fi
192
193 # precompiled headers doesn't work on hardened, where the flag is masked.
194 if use pch; then
195 myconf="${myconf} -pch"
196 else
197 myconf="${myconf} -no-pch"
198 fi
199
200 if use debug; then
201 myconf="${myconf} -debug -no-separate-debug-info"
202 else
203 myconf="${myconf} -release -no-separate-debug-info"
204 fi
205
206 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
207 # ${ARCH}. Therefore we convert it to supported values.
208 case "${ARCH}" in
209 amd64) myconf="${myconf} -arch x86_64" ;;
210 ppc|ppc64) myconf="${myconf} -arch powerpc" ;;
211 x86|x86-*) myconf="${myconf} -arch i386" ;;
212 alpha|arm|ia64|mips|s390|sparc) myconf="${myconf} -arch ${ARCH}" ;;
213 hppa|sh) myconf="${myconf} -arch generic" ;;
214 *) die "${ARCH} is unsupported by this eclass. Please file a bug." ;;
215 esac
216
217 myconf="${myconf} -stl -verbose -largefile -confirm-license -no-rpath
218 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR}
219 -datadir ${QTDATADIR} -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR}
220 -plugindir ${QTPLUGINDIR} -sysconfdir ${QTSYSCONFDIR}
221 -translationdir ${QTTRANSDIR} -examplesdir ${QTEXAMPLESDIR}
222 -demosdir ${QTDEMOSDIR} -silent -fast
223 $([[ ${PN} == qt-xmlpatterns ]] || echo -no-exceptions)
224 $(use x86-fbsd || echo -reduce-relocations)
225 -nomake examples -nomake demos"
226
227 echo "${myconf}"
228}
229
230build_directories() { 620build_directories() {
231 local dirs="$@"
232 for x in ${dirs}; do 621 for x in "$@"; do
233 cd "${S}"/${x} 622 pushd "${S}"/${x} >/dev/null || die
234 "${S}"/bin/qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" || die "qmake failed" 623 emake CC="$(tc-getCC)" \
235 emake || die "emake failed" 624 CXX="$(tc-getCXX)" \
625 LINK="$(tc-getCXX)" || die "emake failed"
626 popd >/dev/null || die
236 done 627 done
237} 628}
238 629
630# @FUNCTION: install_directories
631# @USAGE: < directories >
632# @INTERNAL
633# @DESCRIPTION:
634# Runs emake install in the given directories, which are separated by spaces.
239install_directories() { 635install_directories() {
240 local dirs="$@"
241 for x in ${dirs}; do 636 for x in "$@"; do
242 pushd "${S}"/${x} >/dev/null || die "Can't pushd ${S}/${x}" 637 pushd "${S}"/${x} >/dev/null || die
243 emake INSTALL_ROOT="${D}" install || die "emake install failed" 638 emake INSTALL_ROOT="${D}" install || die "emake install failed"
244 popd >/dev/null || die "Can't popd from ${S}/${x}" 639 popd >/dev/null || die
245 done 640 done
246} 641}
247 642
248# @ECLASS-VARIABLE: QCONFIG_ADD 643# @ECLASS-VARIABLE: QCONFIG_ADD
249# @DESCRIPTION: 644# @DESCRIPTION:
250# List options that need to be added to QT_CONFIG in qconfig.pri 645# List options that need to be added to QT_CONFIG in qconfig.pri
251QCONFIG_ADD="${QCONFIG_ADD:-}" 646: ${QCONFIG_ADD:=}
252 647
253# @ECLASS-VARIABLE: QCONFIG_REMOVE 648# @ECLASS-VARIABLE: QCONFIG_REMOVE
254# @DESCRIPTION: 649# @DESCRIPTION:
255# List options that need to be removed from QT_CONFIG in qconfig.pri 650# List options that need to be removed from QT_CONFIG in qconfig.pri
256QCONFIG_REMOVE="${QCONFIG_REMOVE:-}" 651: ${QCONFIG_REMOVE:=}
257 652
258# @ECLASS-VARIABLE: QCONFIG_DEFINE 653# @ECLASS-VARIABLE: QCONFIG_DEFINE
259# @DESCRIPTION: 654# @DESCRIPTION:
260# List variables that should be defined at the top of QtCore/qconfig.h 655# List variables that should be defined at the top of QtCore/qconfig.h
261QCONFIG_DEFINE="${QCONFIG_DEFINE:-}" 656: ${QCONFIG_DEFINE:=}
262 657
658# @FUNCTION: install_qconfigs
659# @INTERNAL
660# @DESCRIPTION:
661# Install gentoo-specific mkspecs configurations.
263install_qconfigs() { 662install_qconfigs() {
264 local x 663 local x
265 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} ]]; then 664 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} ]]; then
266 for x in QCONFIG_ADD QCONFIG_REMOVE; do 665 for x in QCONFIG_ADD QCONFIG_REMOVE; do
267 [[ -n ${!x} ]] && echo ${x}=${!x} >> "${T}"/${PN}-qconfig.pri 666 [[ -n ${!x} ]] && echo ${x}=${!x} >> "${T}"/${PN}-qconfig.pri
268 done 667 done
269 insinto ${QTDATADIR}/mkspecs/gentoo 668 insinto ${QTDATADIR#${EPREFIX}}/mkspecs/gentoo
270 doins "${T}"/${PN}-qconfig.pri || die "installing ${PN}-qconfig.pri failed" 669 doins "${T}"/${PN}-qconfig.pri || die "installing ${PN}-qconfig.pri failed"
271 fi 670 fi
272 671
273 if [[ -n ${QCONFIG_DEFINE} ]]; then 672 if [[ -n ${QCONFIG_DEFINE} ]]; then
274 for x in ${QCONFIG_DEFINE}; do 673 for x in ${QCONFIG_DEFINE}; do
275 echo "#define ${x}" >> "${T}"/gentoo-${PN}-qconfig.h 674 echo "#define ${x}" >> "${T}"/gentoo-${PN}-qconfig.h
276 done 675 done
277 insinto ${QTHEADERDIR}/Gentoo 676 insinto ${QTHEADERDIR#${EPREFIX}}/Gentoo
278 doins "${T}"/gentoo-${PN}-qconfig.h || die "installing ${PN}-qconfig.h failed" 677 doins "${T}"/gentoo-${PN}-qconfig.h || die "installing ${PN}-qconfig.h failed"
279 fi 678 fi
280} 679}
281 680
681# @FUNCTION: generate_qconfigs
682# @INTERNAL
683# @DESCRIPTION:
684# Generates gentoo-specific qconfig.{h,pri}.
282generate_qconfigs() { 685generate_qconfigs() {
283 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then 686 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${PN} == qt-core ]]; then
284 local x qconfig_add qconfig_remove qconfig_new 687 local x qconfig_add qconfig_remove qconfig_new
285 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do 688 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do
286 [[ -f ${x} ]] || continue 689 [[ -f ${x} ]] || continue
287 qconfig_add="${qconfig_add} $(sed -n 's/^QCONFIG_ADD=//p' "${x}")" 690 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")"
288 qconfig_remove="${qconfig_remove} $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")" 691 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")"
289 done 692 done
290 693
291 # these error checks do not use die because dying in pkg_post{inst,rm} 694 # these error checks do not use die because dying in pkg_post{inst,rm}
292 # just makes things worse. 695 # just makes things worse.
293 if [[ -e "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri ]]; then 696 if [[ -e "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri ]]; then
300 703
301 # generate list of QT_CONFIG entries from the existing list 704 # generate list of QT_CONFIG entries from the existing list
302 # including qconfig_add and excluding qconfig_remove 705 # including qconfig_add and excluding qconfig_remove
303 for x in $(sed -n 's/^QT_CONFIG +=//p' \ 706 for x in $(sed -n 's/^QT_CONFIG +=//p' \
304 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri) ${qconfig_add}; do 707 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri) ${qconfig_add}; do
305 hasq ${x} ${qconfig_remove} || qconfig_new="${qconfig_new} ${x}" 708 has ${x} ${qconfig_remove} || qconfig_new+=" ${x}"
306 done 709 done
307 710
308 # replace the existing QT_CONFIG list with qconfig_new 711 # replace the existing QT_CONFIG list with qconfig_new
309 if ! sed -i -e "s/QT_CONFIG +=.*/QT_CONFIG += ${qconfig_new}/" \ 712 if ! sed -i -e "s/QT_CONFIG +=.*/QT_CONFIG += ${qconfig_new}/" \
310 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then 713 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then
333 "${ROOT}${QTHEADERDIR}" 2>/dev/null 736 "${ROOT}${QTHEADERDIR}" 2>/dev/null
334 fi 737 fi
335 fi 738 fi
336} 739}
337 740
741# @FUNCTION: qt4-build_pkg_postrm
742# @DESCRIPTION:
743# Regenerate configuration when the package is completely removed.
338qt4-build_pkg_postrm() { 744qt4-build_pkg_postrm() {
339 generate_qconfigs 745 generate_qconfigs
340} 746}
341 747
748# @FUNCTION: qt4-build_pkg_postinst
749# @DESCRIPTION:
750# Regenerate configuration, plus throw a message about possible
751# breakages and proposed solutions.
342qt4-build_pkg_postinst() { 752qt4-build_pkg_postinst() {
343 generate_qconfigs 753 generate_qconfigs
344 echo
345 ewarn "After a rebuild or upgrade of Qt, it can happen that Qt plugins (such as Qt"
346 ewarn "and KDE styles and widgets) can no longer be loaded. In this situation you"
347 ewarn "should recompile the packages providing these plugins. Also, make sure you"
348 ewarn "compile the Qt packages, and the packages that depend on it, with the same"
349 ewarn "GCC version and the same USE flag settings (especially the debug flag)."
350 ewarn
351 ewarn "Packages that typically need to be recompiled are kdelibs from KDE4, any"
352 ewarn "additional KDE4/Qt4 styles, qscintilla and PyQt4. Before filing a bug report,"
353 ewarn "make sure all your Qt4 packages are up-to-date and built with the same"
354 ewarn "configuration."
355 ewarn
356 ewarn "For more information, see http://doc.trolltech.com/4.4/plugins-howto.html"
357 echo
358} 754}
359 755
756# @FUNCTION: skip_qmake_build
757# @INTERNAL
758# @DESCRIPTION:
759# Patches configure to skip qmake compilation, as it's already installed by qt-core.
360skip_qmake_build_patch() { 760skip_qmake_build() {
361 # Don't need to build qmake, as it's already installed from qt-core
362 sed -i -e "s:if true:if false:g" "${S}"/configure || die "Sed failed" 761 sed -i -e "s:if true:if false:g" "${S}"/configure || die
363} 762}
364 763
365skip_project_generation_patch() { 764# @FUNCTION: skip_project_generation
765# @INTERNAL
766# @DESCRIPTION:
366 # Exit the script early by throwing in an exit before all of the .pro files are scanned 767# Exit the script early by throwing in an exit before all of the .pro files are scanned.
768skip_project_generation() {
367 sed -e "s:echo \"Finding:exit 0\n\necho \"Finding:g" \ 769 sed -i -e "s:echo \"Finding:exit 0\n\necho \"Finding:g" "${S}"/configure || die
368 -i "${S}"/configure || die "Sed failed"
369} 770}
370 771
772# @FUNCTION: symlink_binaries_to_buildtree
773# @INTERNAL
774# @DESCRIPTION:
775# Symlinks generated binaries to buildtree, so they can be used during compilation time.
371symlink_binaries_to_buildtree() { 776symlink_binaries_to_buildtree() {
372 for bin in qmake moc uic rcc; do 777 for bin in qmake moc uic rcc; do
373 ln -s ${QTBINDIR}/${bin} "${S}"/bin/ || die "Symlinking ${bin} to ${S}/bin failed." 778 ln -s "${QTBINDIR}"/${bin} "${S}"/bin/ || die "symlinking ${bin} to ${S}/bin failed"
374 done 779 done
375} 780}
376 781
782# @FUNCTION: fix_library_files
783# @INTERNAL
784# @DESCRIPTION:
785# Fixes the paths in *.la, *.prl, *.pc, as they are wrong due to sandbox and
786# moves the *.pc files into the pkgconfig directory.
377fix_library_files() { 787fix_library_files() {
788 local libfile
378 for libfile in "${D}"/${QTLIBDIR}/{*.la,*.prl,pkgconfig/*.pc}; do 789 for libfile in "${D}"/${QTLIBDIR}/{*.la,*.prl,pkgconfig/*.pc}; do
379 if [[ -e ${libfile} ]]; then 790 if [[ -e ${libfile} ]]; then
380 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${libfile} || die "Sed on ${libfile} failed." 791 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${libfile} || die "sed on ${libfile} failed"
381 fi 792 fi
382 done 793 done
383 794
384 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations. Fix: 795 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations
385 for libfile in "${D}"/${QTLIBDIR}/pkgconfig/*.pc; do 796 for libfile in "${D}"/${QTLIBDIR}/pkgconfig/*.pc; do
386 if [[ -e ${libfile} ]]; then 797 if [[ -e ${libfile} ]]; then
387 sed -i -e "s:${S}/bin:${QTBINDIR}:g" ${libfile} || die "Sed failed" 798 sed -i -e "s:${S}/bin:${QTBINDIR}:g" ${libfile} || die "sed on ${libfile} failed"
388 799
389 # Move .pc files into the pkgconfig directory 800 # Move .pc files into the pkgconfig directory
390
391 dodir ${QTPCDIR} 801 dodir ${QTPCDIR#${EPREFIX}}
392 mv ${libfile} "${D}"/${QTPCDIR}/ \ 802 mv ${libfile} "${D}"/${QTPCDIR}/ || die "moving ${libfile} to ${D}/${QTPCDIR}/ failed"
393 || die "Moving ${libfile} to ${D}/${QTPCDIR}/ failed."
394 fi 803 fi
395 done 804 done
396 805
397 # Don't install an empty directory 806 # Don't install an empty directory
398 rmdir "${D}"/${QTLIBDIR}/pkgconfig 807 rmdir "${D}"/${QTLIBDIR}/pkgconfig
399} 808}
400 809
810# @FUNCTION: qt_use
811# @USAGE: < flag > [ feature ] [ enableval ]
812# @DESCRIPTION:
813# This will echo "-${enableval}-${feature}" if <flag> is enabled, or
814# "-no-${feature}" if it's disabled. If [feature] is not specified, <flag>
815# will be used for that. If [enableval] is not specified, it omits the
816# "-${enableval}" part.
401qt_use() { 817qt_use() {
402 local flag="${1}" 818 use "$1" && echo "${3:+-$3}-${2:-$1}" || echo "-no-${2:-$1}"
403 local feature="${1}"
404 local enableval=
405
406 [[ -n ${2} ]] && feature=${2}
407 [[ -n ${3} ]] && enableval="-${3}"
408
409 if use ${flag}; then
410 echo "${enableval}-${feature}"
411 else
412 echo "-no-${feature}"
413 fi
414} 819}
415 820
416# @ECLASS-VARIABLE: QT4_BUILT_WITH_USE_CHECK 821# @FUNCTION: qt_mkspecs_dir
822# @RETURN: the specs-directory w/o path
417# @DESCRIPTION: 823# @DESCRIPTION:
418# The contents of $QT4_BUILT_WITH_USE_CHECK gets fed to built_with_use 824# Allows us to define which mkspecs dir we want to use.
419# (eutils.eclass), line per line.
420#
421# Example:
422# @CODE
423# pkg_setup() {
424# use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
425# ~x11-libs/qt-gui-${PV} qt3support"
426# qt4-build_check_use
427# }
428# @CODE
429
430# Run built_with_use on each flag and print appropriate error messages if any
431# flags are missing
432_qt_built_with_use() {
433 local missing opt pkg flag flags
434
435 if [[ ${1} = "--missing" ]]; then
436 missing="${1} ${2}" && shift 2
437 fi
438 if [[ ${1:0:1} = "-" ]]; then
439 opt=${1} && shift
440 fi
441
442 pkg=${1} && shift
443
444 for flag in "${@}"; do
445 flags="${flags} ${flag}"
446 if ! built_with_use ${missing} ${opt} ${pkg} ${flag}; then
447 flags="${flags}*"
448 else
449 [[ ${opt} = "-o" ]] && return 0
450 fi
451 done
452 if [[ "${flags# }" = "${@}" ]]; then
453 return 0
454 fi
455 if [[ ${opt} = "-o" ]]; then
456 eerror "This package requires '${pkg}' to be built with any of the following USE flags: '$*'."
457 else
458 eerror "This package requires '${pkg}' to be built with the following USE flags: '${flags# }'."
459 fi
460 return 1
461}
462
463# @FUNCTION: qt4-build_check_use
464# @DESCRIPTION:
465# Check if the listed packages in $QT4_BUILT_WITH_USE_CHECK are built with the
466# USE flags listed.
467#
468# If any of the required USE flags are missing, an eerror will be printed for
469# each package with missing USE flags.
470qt4-build_check_use() {
471 local line missing
472 while read line; do
473 [[ -z ${line} ]] && continue
474 if ! _qt_built_with_use ${line}; then
475 missing=true
476 fi
477 done <<< "${QT4_BUILT_WITH_USE_CHECK}"
478 if [[ -n ${missing} ]]; then
479 echo
480 eerror "Flags marked with an * are missing."
481 die "Missing USE flags found"
482 fi
483}
484
485qt_mkspecs_dir() { 825qt_mkspecs_dir() {
486 # Allows us to define which mkspecs dir we want to use.
487 local spec 826 local spec=
488 827
489 case ${CHOST} in 828 case "${CHOST}" in
490 *-freebsd*|*-dragonfly*) 829 *-freebsd*|*-dragonfly*)
491 spec="freebsd" ;; 830 spec=freebsd ;;
492 *-openbsd*) 831 *-openbsd*)
493 spec="openbsd" ;; 832 spec=openbsd ;;
494 *-netbsd*) 833 *-netbsd*)
495 spec="netbsd" ;; 834 spec=netbsd ;;
496 *-darwin*) 835 *-darwin*)
836 if use aqua; then
837 # mac with carbon/cocoa
838 spec=macx
839 else
840 # darwin/mac with x11
497 spec="darwin" ;; 841 spec=darwin
842 fi
843 ;;
844 *-solaris*)
845 spec=solaris ;;
498 *-linux-*|*-linux) 846 *-linux-*|*-linux)
499 spec="linux" ;; 847 spec=linux ;;
500 *) 848 *)
501 die "Unknown CHOST, no platform choosen." 849 die "${FUNCNAME}(): Unknown CHOST '${CHOST}'" ;;
502 esac 850 esac
503 851
504 CXX=$(tc-getCXX) 852 case "$(tc-getCXX)" in
505 if [[ ${CXX/g++/} != ${CXX} ]]; then 853 *g++*)
506 spec="${spec}-g++" 854 spec+=-g++ ;;
507 elif [[ ${CXX/icpc/} != ${CXX} ]]; then 855 *icpc*)
508 spec="${spec}-icc" 856 spec+=-icc ;;
509 else 857 *)
510 die "Unknown compiler ${CXX}." 858 die "${FUNCNAME}(): Unknown compiler '$(tc-getCXX)'" ;;
859 esac
860
861 # Add -64 for 64bit profiles
862 if use x64-freebsd ||
863 use amd64-linux ||
864 use x64-macos ||
865 use x64-solaris ||
866 use sparc64-solaris
867 then
868 spec+=-64
511 fi 869 fi
512 870
513 echo "${spec}" 871 echo "${spec}"
514} 872}
515 873
516case ${EAPI:-0} in 874# @FUNCTION: qt_assistant_cleanup
517 0|1) EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postrm pkg_postinst ;; 875# @INTERNAL
876# @DESCRIPTION:
877# Tries to clean up tools.pro for qt-assistant ebuilds.
878# Meant to be called in src_prepare().
879# Since Qt 4.7.4 this function is a no-op.
880qt_assistant_cleanup() {
881 # apply patching to qt-assistant ebuilds only
882 [[ ${PN} != qt-assistant ]] && return
883
884 # no longer needed for 4.7.4 and later
885 version_is_at_least 4.7.4 && return
886
887 # different versions (and branches...) may need different handling,
888 # add a case if you need special handling
889 case "${MY_PV_EXTRA}" in
890 *kde-qt*)
891 sed -e "/^[ \t]*porting/,/^[ \t]*win32.*activeqt$/d" \
892 -e "/mac/,/^embedded.*makeqpf$/d" \
893 -i tools/tools.pro || die "patching tools.pro failed"
894 ;;
895 *)
896 sed -e "/^[ \t]*porting/,/^[ \t]*win32.*activeqt$/d" \
897 -e "/mac/,/^embedded.*makeqpf$/d" \
898 -e "s/^\([ \t]*pixeltool\) /\1 qdoc3 /" \
899 -i tools/tools.pro || die "patching tools.pro failed"
900 ;;
901 esac
902}
903
904# @FUNCTION: qt_nolibx11
905# @INTERNAL
906# @DESCRIPTION:
907# Ignore X11 tests for packages that don't need X libraries installed.
908qt_nolibx11() {
909 sed -i "/unixtests\/compile.test.*config.tests\/x11\/xlib/,/fi$/d" "${S}"/configure ||
910 die "x11 check sed failed"
911}
912
518 2) EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_install pkg_postrm pkg_postinst ;; 913EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_install src_test pkg_postrm pkg_postinst
519esac

Legend:
Removed from v.1.25  
changed lines
  Added in v.1.130

  ViewVC Help
Powered by ViewVC 1.1.20