/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.55 Revision 1.56
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.55 2009/12/22 16:04:13 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.56 2009/12/22 17:04:07 abcd Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Ben de Groot <yngwin@gentoo.org>, 7# Ben de Groot <yngwin@gentoo.org>,
8# Markos Chandras <hwoarang@gentoo.org>, 8# Markos Chandras <hwoarang@gentoo.org>,
70 70
71 # Make sure ebuilds use the required EAPI 71 # Make sure ebuilds use the required EAPI
72 if [[ ${EAPI} != 2 ]]; then 72 if [[ ${EAPI} != 2 ]]; then
73 eerror "The qt4-build eclass requires EAPI=2, but this ebuild does not" 73 eerror "The qt4-build eclass requires EAPI=2, but this ebuild does not"
74 eerror "have EAPI=2 set. The ebuild author or editor failed. This ebuild needs" 74 eerror "have EAPI=2 set. The ebuild author or editor failed. This ebuild needs"
75 eerror "to be fixed. Using qt4-build-edge eclass without EAPI=2 will fail." 75 eerror "to be fixed. Using qt4-build eclass without EAPI=2 will fail."
76 die "qt4-build-edge eclass requires EAPI=2" 76 die "qt4-build eclass requires EAPI=2"
77 fi 77 fi
78 78
79 if ! version_is_at_least 4.1 $(gcc-version); then 79 if ! version_is_at_least 4.1 $(gcc-version); then
80 ewarn "Using a GCC version lower than 4.1 is not supported!" 80 ewarn "Using a GCC version lower than 4.1 is not supported!"
81 echo 81 echo

Legend:
Removed from v.1.55  
changed lines
  Added in v.1.56

  ViewVC Help
Powered by ViewVC 1.1.20