/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.20 Revision 1.68
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.20 2009/02/11 21:14:59 yngwin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.68 2010/05/22 19:23:51 wired Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Ben de Groot <yngwin@gentoo.org> 7# Ben de Groot <yngwin@gentoo.org>,
8# Markos Chandras <hwoarang@gentoo.org> 8# Markos Chandras <hwoarang@gentoo.org>,
9# Caleb Tennis <caleb@gentoo.org> 9# Caleb Tennis <caleb@gentoo.org>
10# Alex Alexander <wired@gentoo.org>
10# @BLURB: Eclass for Qt4 split ebuilds. 11# @BLURB: Eclass for Qt4 split ebuilds.
11# @DESCRIPTION: 12# @DESCRIPTION:
12# This eclass contains various functions that are used when building Qt4 13# This eclass contains various functions that are used when building Qt4
13 14
14inherit eutils multilib toolchain-funcs flag-o-matic versionator 15inherit base eutils multilib toolchain-funcs flag-o-matic versionator
15 16
16IUSE="${IUSE} custom-cxxflags debug pch"
17
18case "${PV}" in
19 4.?.?_rc*)
20 SRCTYPE="${SRCTYPE:-opensource-src}"
21 MY_PV="${PV/_rc/-rc}" 17MY_PV=${PV/_/-}
22 ;; 18if version_is_at_least 4.5.99999999; then
23 *) 19 MY_P=qt-everywhere-opensource-src-${MY_PV}
24 SRCTYPE="${SRCTYPE:-opensource-src}" 20 [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]] && IUSE="+exceptions"
25 MY_PV="${PV}" 21else
26 ;; 22 MY_P=qt-x11-opensource-src-${MY_PV}
27esac 23fi
28MY_P=qt-x11-${SRCTYPE}-${MY_PV} 24
25HOMEPAGE="http://qt.nokia.com/"
26SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
27
28LICENSE="|| ( LGPL-2.1 GPL-3 )"
29IUSE+=" debug pch aqua"
30
31RDEPEND="
32 !<x11-libs/qt-assistant-${PV}
33 !>x11-libs/qt-assistant-${PV}-r9999
34 !<x11-libs/qt-core-${PV}
35 !>x11-libs/qt-core-${PV}-r9999
36 !<x11-libs/qt-dbus-${PV}
37 !>x11-libs/qt-dbus-${PV}-r9999
38 !<x11-libs/qt-demo-${PV}
39 !>x11-libs/qt-demo-${PV}-r9999
40 !<x11-libs/qt-gui-${PV}
41 !>x11-libs/qt-gui-${PV}-r9999
42 !<x11-libs/qt-multimedia-${PV}
43 !>x11-libs/qt-multimedia-${PV}-r9999
44 !<x11-libs/qt-opengl-${PV}
45 !>x11-libs/qt-opengl-${PV}-r9999
46 !<x11-libs/qt-phonon-${PV}
47 !>x11-libs/qt-phonon-${PV}-r9999
48 !<x11-libs/qt-qt3support-${PV}
49 !>x11-libs/qt-qt3support-${PV}-r9999
50 !<x11-libs/qt-script-${PV}
51 !>x11-libs/qt-script-${PV}-r9999
52 !<x11-libs/qt-sql-${PV}
53 !>x11-libs/qt-sql-${PV}-r9999
54 !<x11-libs/qt-svg-${PV}
55 !>x11-libs/qt-svg-${PV}-r9999
56 !<x11-libs/qt-test-${PV}
57 !>x11-libs/qt-test-${PV}-r9999
58 !<x11-libs/qt-webkit-${PV}
59 !>x11-libs/qt-webkit-${PV}-r9999
60 !<x11-libs/qt-xmlpatterns-${PV}
61 !>x11-libs/qt-xmlpatterns-${PV}-r9999
62"
63
29S=${WORKDIR}/${MY_P} 64S=${WORKDIR}/${MY_P}
30 65
31HOMEPAGE="http://www.qtsoftware.com/" 66# @FUNCTION: qt4-build_pkg_setup
32SRC_URI="ftp://ftp.trolltech.com/qt/source/${MY_P}.tar.bz2" 67# @DESCRIPTION:
33 68# Sets up S, MY_P, PATH, and LD_LIBRARY_PATH
34case "${PV}" in
35 4.4.?) SRC_URI="${SRC_URI} mirror://gentoo/${MY_P}-headers.tar.bz2" ;;
36 *) ;;
37esac
38
39qt4-build_pkg_setup() { 69qt4-build_pkg_setup() {
40 # EAPI=2 ebuilds set use-deps, others need this:
41 if [[ $EAPI != 2 ]]; then
42 # Make sure debug setting corresponds with qt-core (bug 258512)
43 if [[ $PN != "qt-core" ]]; then 70 if [[ "${PN}" == "qt-webkit" ]]; then
44 use debug && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} 71 if [[ "${CFLAGS}" =~ "-ggdb" ]] || [[ "${CXXFLAGS}" =~ "-ggdb" ]]; then
45 ~x11-libs/qt-core-${PV} debug" 72 echo
73 ewarn "Your \$C{,XX}FLAGS contain -ggdb. You may experience really"
74 ewarn "long compilation times and/or increased memory usage."
75 ewarn "If compilation fails, please try removing -ggdb before"
76 ewarn "reporting a bug."
77 ewarn "For more info check out bug #307861"
78 echo
46 fi 79 fi
80 fi
47 81
48 # Check USE requirements 82 [[ ${EAPI} == 2 ]] && use !prefix && EPREFIX=
49 qt4-build_check_use 83
84 # Protect users by not allowing downgrades between releases
85 # Downgrading revisions within the same release should be allowed
86 if has_version '>'${CATEGORY}/${P}-r9999 ; then
87 if [[ -z $I_KNOW_WHAT_I_AM_DOING ]] ; then
88 eerror "Sanity check to keep you from breaking your system:"
89 eerror " Downgrading Qt is completely unsupported and will break your system!"
90 die "aborting to save your system"
91 else
92 ewarn "Downgrading Qt is completely unsupported and will break your system!"
50 fi 93 fi
94 fi
51 95
52 # Set up installation directories
53 QTBASEDIR=/usr/$(get_libdir)/qt4
54 QTPREFIXDIR=/usr
55 QTBINDIR=/usr/bin
56 QTLIBDIR=/usr/$(get_libdir)/qt4
57 QTPCDIR=/usr/$(get_libdir)/pkgconfig
58 QTDATADIR=/usr/share/qt4
59 QTDOCDIR=/usr/share/doc/qt-${PV}
60 QTHEADERDIR=/usr/include/qt4
61 QTPLUGINDIR=${QTLIBDIR}/plugins
62 QTSYSCONFDIR=/etc/qt4
63 QTTRANSDIR=${QTDATADIR}/translations
64 QTEXAMPLESDIR=${QTDATADIR}/examples
65 QTDEMOSDIR=${QTDATADIR}/demos
66
67 PLATFORM=$(qt_mkspecs_dir)
68
69 PATH="${S}/bin:${PATH}" 96 PATH="${S}/bin${PATH:+:}${PATH}"
97 if [[ ${CHOST} != *-darwin* ]]; then
70 LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" 98 LD_LIBRARY_PATH="${S}/lib${LD_LIBRARY_PATH:+:}${LD_LIBRARY_PATH}"
99 else
100 DYLD_LIBRARY_PATH="${S}/lib${DYLD_LIBRARY_PATH:+:}${DYLD_LIBRARY_PATH}"
101 # On MacOS we *need* at least src/gui/kernel/qapplication_mac.mm for
102 # platform detection. Note: needs to come before any directories to
103 # avoid extract failure.
104 [[ ${CHOST} == *-apple-darwin* ]] && \
105 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm
106 ${QT4_EXTRACT_DIRECTORIES}"
107 fi
71 108
109 # Make sure ebuilds use the required EAPI
110 if [[ ${EAPI} != [23] ]]; then
111 eerror "The qt4-build eclass requires EAPI=2 or EAPI=3, but this ebuild is using"
112 eerror "EAPI=${EAPI:-0}. The ebuild author or editor failed. This ebuild needs to be"
113 eerror "fixed. Using qt4-build eclass without EAPI=2 or EAPI=3 will fail."
114 die "qt4-build eclass requires EAPI=2 or EAPI=3"
115 fi
116
72 if ! version_is_at_least 4.1 $(gcc-version) ; then 117 if ! version_is_at_least 4.1 $(gcc-version); then
73 ewarn "Using a GCC version lower than 4.1 is not supported!" 118 ewarn "Using a GCC version lower than 4.1 is not supported!"
74 echo
75 ebeep 5
76 fi 119 fi
77} 120}
78 121
122# @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES
123# @DESCRIPTION:
124# Arguments for build_target_directories. Takes the directories, in which the
125# code should be compiled. This is a space-separated list
126
127# @ECLASS-VARIABLE: QT4_EXTRACT_DIRECTORIES
128# @DESCRIPTION:
129# Space separated list including the directories that will be extracted from Qt
130# tarball
131
132# @FUNCTION: qt4-build_src_unpack
133# @DESCRIPTION:
134# Unpacks the sources
79qt4-build_src_unpack() { 135qt4-build_src_unpack() {
136 setqtenv
80 local target targets 137 local target targets=
81 for target in configure LICENSE.{GPL2,GPL3} projects.pro \ 138 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \
82 src/{qbase,qt_targets,qt_install}.pri bin config.tests mkspecs qmake \ 139 src/{qbase,qt_targets,qt_install}.pri bin config.tests mkspecs qmake \
83 ${QT4_EXTRACT_DIRECTORIES}; do 140 ${QT4_EXTRACT_DIRECTORIES}; do
84 targets="${targets} ${MY_P}/${target}" 141 targets+=" ${MY_P}/${target}"
85 done 142 done
86 143
87 echo tar xjpf "${DISTDIR}"/${MY_P}.tar.bz2 ${targets} 144 echo tar xzpf "${DISTDIR}"/${MY_P}.tar.gz ${targets}
88 tar xjpf "${DISTDIR}"/${MY_P}.tar.bz2 ${targets} 145 tar xzpf "${DISTDIR}"/${MY_P}.tar.gz ${targets} || die
89
90 case "${PV}" in
91 4.4.?)
92 echo tar xjpf "${DISTDIR}"/${MY_P}-headers.tar.bz2
93 tar xjpf "${DISTDIR}"/${MY_P}-headers.tar.bz2
94 ;;
95 esac
96
97 # Be backwards compatible for now
98 if [[ $EAPI != 2 ]]; then
99 qt4-build_src_prepare
100 fi
101} 146}
102 147
148# @ECLASS-VARIABLE: PATCHES
149# @DESCRIPTION:
150# In case you have patches to apply, specify them in PATCHES variable. Make sure
151# to specify the full path. This variable is necessary for src_prepare phase.
152# example:
153# PATCHES="${FILESDIR}"/mypatch.patch
154# ${FILESDIR}"/mypatch2.patch"
155#
156
157# @FUNCTION: qt4-build_src_prepare
158# @DESCRIPTION:
159# Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix
160# source files in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified on /etc/make.conf.
103qt4-build_src_prepare() { 161qt4-build_src_prepare() {
162 setqtenv
104 cd "${S}" 163 cd "${S}"
164
165 if use aqua; then
166 # provide a proper macx-g++-64
167 use x64-macos && ln -s macx-g++ mkspecs/$(qt_mkspecs_dir)
168
169 sed -e '/^CONFIG/s:app_bundle::' \
170 -e '/^CONFIG/s:plugin_no_soname:plugin_with_soname absolute_library_soname:' \
171 -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed failed"
172 fi
105 173
106 if [[ ${PN} != qt-core ]]; then 174 if [[ ${PN} != qt-core ]]; then
107 skip_qmake_build_patch 175 skip_qmake_build_patch
108 skip_project_generation_patch 176 skip_project_generation_patch
109 symlink_binaries_to_buildtree 177 symlink_binaries_to_buildtree
110 fi 178 fi
111 179
112 # Bug 253127 180 if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
181 # qmake bus errors with -O2 but -O3 works
182 replace-flags -O2 -O3
183 fi
184
185 # Bug 178652
186 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
187 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
188 append-flags -fno-gcse
189 fi
190
191 # Unsupported old gcc versions - hardened needs this :(
113 if [[ $(gcc-major-version) -lt "4" ]] ; then 192 if [[ $(gcc-major-version) -lt 4 ]] ; then
193 ewarn "Appending -fno-stack-protector to CXXFLAGS"
194 append-cxxflags -fno-stack-protector
195 # Bug 253127
114 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \ 196 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \
115 -i "${S}"/mkspecs/common/g++.conf || die "sed ${S}/mkspecs/common/g++.conf failed" 197 -i "${S}"/mkspecs/common/g++.conf || die "sed ${S}/mkspecs/common/g++.conf failed"
116 fi 198 fi
117 199
118 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \ 200 # Bug 261632
119 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \ 201 if use ppc64; then
120 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \ 202 ewarn "Appending -mminimal-toc to CFLAGS/CXXFLAGS"
203 append-flags -mminimal-toc
204 fi
205
206 # Bug 282984 && Bug 295530
207 sed -e "s:\(^SYSTEM_VARIABLES\):CC=$(tc-getCC)\nCXX=$(tc-getCXX)\nCFLAGS=\"${CFLAGS}\"\nCXXFLAGS=\"${CXXFLAGS}\"\nLDFLAGS=\"${LDFLAGS}\"\n\1:" \
208 -i configure || die "sed qmake compilers failed"
209 sed -e "s:\(\$MAKE\):\1 CC=$(tc-getCC) CXX=$(tc-getCXX) LD=$(tc-getCXX) LINK=$(tc-getCXX):" \
210 -i config.tests/unix/compile.test || die "sed test compilers failed"
211
212 # Bug 172219
121 -e "s:X11R6/::" \ 213 sed -e "s:X11R6/::" \
122 -i "${S}"/mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed ${S}/mkspecs/$(qt_mkspecs_dir)/qmake.conf failed" 214 -i "${S}"/mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed ${S}/mkspecs/$(qt_mkspecs_dir)/qmake.conf failed"
123 215
216 if [[ ${CHOST} == *-darwin* ]]; then
217 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib
218 # crippled (by design) :/
124 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \ 219 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
125 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \ 220 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
126 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \ 221 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \
222 -e "s:-arch\s\w*::g" \
127 -i "${S}"/mkspecs/common/g++.conf || die "sed ${S}/mkspecs/common/g++.conf failed" 223 -i mkspecs/common/mac-g++.conf || die "sed mkspecs/common/mac-g++.conf failed"
128}
129 224
225 # Fix configure's -arch settings that appear in qmake/Makefile and also
226 # fix arch handling (automagically duplicates our -arch arg and breaks
227 # pch). Additionally disable Xarch support.
228 sed \
229 -e "s:-arch i386::" \
230 -e "s:-arch ppc::" \
231 -e "s:-arch x86_64::" \
232 -e "s:-arch ppc64::" \
233 -e "s:-arch \$i::" \
234 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \
235 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \
236 -e "s:-Xarch_x86_64::g" \
237 -e "s:-Xarch_ppc64::g" \
238 -i configure mkspecs/common/mac-g++.conf || die "sed configure failed"
239
240 # On Snow Leopard don't fall back to 10.5 deployment target.
241 if [[ ${CHOST} == *-apple-darwin10 ]] ; then
242 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \
243 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \
244 -i configure mkspecs/common/mac-g++.conf || die "sed configure failed"
245 fi
246 fi
247
248 # this one is needed for all systems with a separate -liconv, apart from
249 # Darwin, for which the sources already cater for -liconv
250 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] ; then
251 sed \
252 -e "s|mac:LIBS += -liconv|LIBS += -liconv|g" \
253 -i config.tests/unix/iconv/iconv.pro \
254 || die "sed on iconv.pro failed"
255 fi
256
257 # we need some patches for Solaris
258 sed -i \
259 -e '/^QMAKE_LFLAGS_THREAD/a\QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,' \
260 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
261 # use GCC over SunStudio
262 sed -i -e '/PLATFORM=solaris-cc/s/cc/g++/' configure || die
263 # don't flirt with non-Prefix stuff, we're quite possessive
264 sed -i -e '/^QMAKE_\(LIB\|INC\)DIR\(_X11\|_OPENGL\|\)\t/s/=.*$/=/' \
265 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
266
267 base_src_prepare
268}
269
270# @FUNCTION: qt4-build_src_configure
271# @DESCRIPTION:
272# Default configure phase
130qt4-build_src_configure() { 273qt4-build_src_configure() {
131 if use custom-cxxflags; then 274 setqtenv
132 echo 275 myconf="$(standard_configure_options) ${myconf}"
133 ewarn "You have set USE=custom-cxxflags, which means Qt will be built with the" 276
134 ewarn "CXXFLAGS you have set in /etc/make.conf. This is not supported, and we" 277 # this one is needed for all systems with a separate -liconv, apart from
135 ewarn "recommend to unset this useflag. But you are free to experiment with it." 278 # Darwin, for which the sources already cater for -liconv
136 ewarn "Just do not start crying if it breaks your system, or eats your kitten" 279 use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] && \
137 ewarn "for breakfast. ;-) " 280 myconf+=" -liconv"
138 echo 281
282 if has glib ${IUSE//+} && use glib; then
283 # use -I, -L and -l from configure
284 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
285 # avoid the -pthread argument
286 myconf+=" ${glibflags//-pthread}"
287 unset glibflags
288 fi
289
290 if use aqua ; then
291 # On (snow) leopard use the new (frameworked) cocoa code.
292 if [[ ${CHOST##*-darwin} -ge 9 ]] ; then
293 myconf+=" -cocoa -framework"
294
295 # We are crazy and build cocoa + qt3support :-)
296 if use qt3support; then
297 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \
298 -i configure
299 fi
300
301 # We need the source's headers, not the installed ones.
302 myconf+=" -I${S}/include"
303
304 # Add hint for the framework location.
305 myconf+=" -F${QTLIBDIR}"
306 fi
139 else 307 else
140 # Don't let the user go too overboard with flags. 308 # freetype2 include dir is non-standard, thus include it on configure
141 strip-flags 309 # use -I from configure
142 replace-flags -O3 -O2 310 myconf+=" $(pkg-config --cflags freetype2)"
143 fi 311 fi
144
145 # Unsupported old gcc versions - hardened needs this :(
146 if [[ $(gcc-major-version) -lt "4" ]] ; then
147 ewarn "Appending -fno-stack-protector to CXXFLAGS"
148 append-cxxflags -fno-stack-protector
149 fi
150
151 # Bug 178652
152 if [[ "$(gcc-major-version)" == "3" ]] && use amd64; then
153 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
154 append-flags -fno-gcse
155 fi
156
157 myconf="$(standard_configure_options) ${myconf}"
158 312
159 echo ./configure ${myconf} 313 echo ./configure ${myconf}
160 ./configure ${myconf} || die "./configure failed" 314 ./configure ${myconf} || die "./configure failed"
315 myconf=""
161} 316}
162 317
318# @FUNCTION: qt4-build_src_compile
319# @DESCRIPTION: Actual compile phase
163qt4-build_src_compile() { 320qt4-build_src_compile() {
164 # Be backwards compatible for now 321 setqtenv
165 if [[ $EAPI != 2 ]]; then
166 qt4-build_src_configure
167 fi
168 322
169 build_directories "${QT4_TARGET_DIRECTORIES}" 323 build_directories ${QT4_TARGET_DIRECTORIES}
170} 324}
171 325
326# @FUNCTION: fix_includes
327# @DESCRIPTION:
328# For MacOSX we need to add some symlinks when frameworks are
329# being used, to avoid complications with some more or less stupid packages.
330fix_includes() {
331 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
332 # Some packages tend to include <Qt/...>
333 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt
334
335 # Fake normal headers when frameworks are installed... eases life later on
336 local dest f
337 for frw in "${D}${QTLIBDIR}"/*.framework; do
338 [[ -e "${frw}"/Headers ]] || continue
339 f=$(basename ${frw})
340 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework}
341 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers "${dest}"
342
343 # Link normal headers as well.
344 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do
345 h=$(basename ${hdr})
346 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers/${h} "${QTHEADERDIR#${EPREFIX}}"/Qt/${h}
347 done
348 done
349 fi
350}
351
352# @FUNCTION: qt4-build_src_install
353# @DESCRIPTION:
354# Perform the actual installation including some library fixes.
172qt4-build_src_install() { 355qt4-build_src_install() {
356 [[ ${EAPI} == 2 ]] && use !prefix && ED=${D}
357 setqtenv
173 install_directories "${QT4_TARGET_DIRECTORIES}" 358 install_directories ${QT4_TARGET_DIRECTORIES}
174 install_qconfigs 359 install_qconfigs
175 fix_library_files 360 fix_library_files
361 fix_includes
176} 362}
177 363
364# @FUNCTION: setqtenv
365setqtenv() {
366 # Set up installation directories
367 QTBASEDIR=${EPREFIX}/usr/$(get_libdir)/qt4
368 QTPREFIXDIR=${EPREFIX}/usr
369 QTBINDIR=${EPREFIX}/usr/bin
370 QTLIBDIR=${EPREFIX}/usr/$(get_libdir)/qt4
371 QMAKE_LIBDIR_QT=${QTLIBDIR}
372 QTPCDIR=${EPREFIX}/usr/$(get_libdir)/pkgconfig
373 QTDATADIR=${EPREFIX}/usr/share/qt4
374 QTDOCDIR=${EPREFIX}/usr/share/doc/qt-${PV}
375 QTHEADERDIR=${EPREFIX}/usr/include/qt4
376 QTPLUGINDIR=${QTLIBDIR}/plugins
377 QTSYSCONFDIR=${EPREFIX}/etc/qt4
378 QTTRANSDIR=${QTDATADIR}/translations
379 QTEXAMPLESDIR=${QTDATADIR}/examples
380 QTDEMOSDIR=${QTDATADIR}/demos
381 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4
382 PLATFORM=$(qt_mkspecs_dir)
383
384 unset QMAKESPEC
385}
386
387# @FUNCTION: standard_configure_options
388# @DESCRIPTION:
389# Sets up some standard configure options, like libdir (if necessary), whether
390# debug info is wanted or not.
178standard_configure_options() { 391standard_configure_options() {
179 local myconf="" 392 local myconf=
180 393
181 [[ $(get_libdir) != "lib" ]] && myconf="${myconf} -L/usr/$(get_libdir)" 394 [[ $(get_libdir) != lib ]] && myconf+=" -L${EPREFIX}/usr/$(get_libdir)"
182 395
183 # Disable visibility explicitly if gcc version isn't 4 396 # Disable visibility explicitly if gcc version isn't 4
184 if [[ "$(gcc-major-version)" -lt "4" ]]; then 397 if [[ $(gcc-major-version) -lt 4 ]]; then
185 myconf="${myconf} -no-reduce-exports" 398 myconf+=" -no-reduce-exports"
186 fi 399 fi
187 400
188 # precompiled headers doesn't work on hardened, where the flag is masked. 401 # precompiled headers doesn't work on hardened, where the flag is masked.
402 myconf+=" $(qt_use pch)"
403
189 if use pch; then 404 if use debug; then
190 myconf="${myconf} -pch" 405 myconf+=" -debug"
191 else 406 else
192 myconf="${myconf} -no-pch" 407 myconf+=" -release"
193 fi 408 fi
194
195 if use debug; then
196 myconf="${myconf} -debug -no-separate-debug-info" 409 myconf+=" -no-separate-debug-info"
197 else 410
198 myconf="${myconf} -release -no-separate-debug-info" 411 use aqua && myconf+=" -no-framework"
199 fi
200 412
201 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported 413 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
202 # ${ARCH}. Therefore we convert it to supported values. 414 # $(tc-arch). Therefore we convert it to supported values.
203 case "${ARCH}" in 415 case "$(tc-arch)" in
204 amd64) myconf="${myconf} -arch x86_64" ;; 416 amd64|x64-*) myconf+=" -arch x86_64" ;;
417 ppc-macos) myconf+=" -arch ppc" ;;
205 ppc|ppc64) myconf="${myconf} -arch powerpc" ;; 418 ppc|ppc64|ppc-*) myconf+=" -arch powerpc" ;;
419 sparc|sparc-*) myconf+=" -arch sparc" ;;
420 x86-macos) myconf+=" -arch x86" ;;
206 x86|x86-*) myconf="${myconf} -arch i386" ;; 421 x86|x86-*) myconf+=" -arch i386" ;;
207 alpha|arm|ia64|mips|s390|sparc) myconf="${myconf} -arch ${ARCH}" ;; 422 alpha|arm|ia64|mips|s390|sparc) myconf+=" -arch $(tc-arch)" ;;
208 hppa|sh) myconf="${myconf} -arch generic" ;; 423 hppa|sh) myconf+=" -arch generic" ;;
209 *) die "${ARCH} is unsupported by this eclass. Please file a bug." ;; 424 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
210 esac 425 esac
211 426
212 myconf="${myconf} -stl -verbose -largefile -confirm-license -no-rpath 427 # 4.5: build everything but qt-xmlpatterns w/o exceptions
428 # 4.6: exceptions USE flag
429 local exceptions="-exceptions"
430 case "${PV}" in
431 4.5.*)
432 [[ ${PN} == "qt-xmlpatterns" ]] || exceptions="-no-exceptions"
433 ;;
434 *)
435 has exceptions "${IUSE//+}" && exceptions="$(qt_use exceptions)"
436 ;;
437 esac
438
439 # note about -reduce-relocations:
440 # That flag seems to introduce major breakage to applications,
441 # mostly to be seen as a core dump with the message "QPixmap: Must
442 # construct a QApplication before a QPaintDevice" on Solaris
443 # -- Daniel Vergien
444 [[ ${CHOST} != *-solaris* ]] && myconf+=" -reduce-relocations"
445
446 myconf+=" -platform $(qt_mkspecs_dir) -stl -verbose -largefile -confirm-license
213 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} 447 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR}
214 -datadir ${QTDATADIR} -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} 448 -datadir ${QTDATADIR} -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR}
215 -plugindir ${QTPLUGINDIR} -sysconfdir ${QTSYSCONFDIR} 449 -plugindir ${QTPLUGINDIR} -sysconfdir ${QTSYSCONFDIR}
216 -translationdir ${QTTRANSDIR} -examplesdir ${QTEXAMPLESDIR} 450 -translationdir ${QTTRANSDIR} -examplesdir ${QTEXAMPLESDIR}
217 -demosdir ${QTDEMOSDIR} -silent -fast 451 -demosdir ${QTDEMOSDIR} -silent -fast -opensource
218 $([[ ${PN} == qt-xmlpatterns ]] || echo -no-exceptions) 452 ${exceptions}
219 $(use x86-fbsd || echo -reduce-relocations)
220 -nomake examples -nomake demos" 453 -nomake examples -nomake demos"
221 454
222 echo "${myconf}" 455 echo "${myconf}"
223} 456}
224 457
458# @FUNCTION: build_directories
459# @USAGE: < directories >
460# @DESCRIPTION:
461# Compiles the code in $QT4_TARGET_DIRECTORIES
225build_directories() { 462build_directories() {
226 local dirs="$@"
227 for x in ${dirs}; do 463 for x in "$@"; do
228 cd "${S}"/${x} 464 pushd "${S}"/${x} >/dev/null
465 # avoid running over the maximum argument number, bug #299810
466 {
467 echo "${S}"/mkspecs/common/*.conf
468 find "${S}" -name '*.pr[io]'
469 } | xargs sed -i -e "s:\$\$\[QT_INSTALL_LIBS\]:${EPREFIX}/usr/$(get_libdir)/qt4:g" || die
229 "${S}"/bin/qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" || die "qmake failed" 470 "${S}"/bin/qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" || die "qmake failed"
230 emake || die "emake failed" 471 emake CC="$(tc-getCC)" \
472 CXX="$(tc-getCXX)" \
473 LINK="$(tc-getCXX)" || die "emake failed"
474 popd >/dev/null
231 done 475 done
232} 476}
233 477
478# @FUNCTION: install_directories
479# @USAGE: < directories >
480# @DESCRIPTION:
481# run emake install in the given directories, which are separated by spaces
234install_directories() { 482install_directories() {
235 local dirs="$@"
236 for x in ${dirs}; do 483 for x in "$@"; do
237 pushd "${S}"/${x} >/dev/null || die "Can't pushd ${S}/${x}" 484 pushd "${S}"/${x} >/dev/null || die "Can't pushd ${S}/${x}"
238 emake INSTALL_ROOT="${D}" install || die "emake install failed" 485 emake INSTALL_ROOT="${D}" install || die "emake install failed"
239 popd >/dev/null || die "Can't popd from ${S}/${x}" 486 popd >/dev/null || die "Can't popd from ${S}/${x}"
240 done 487 done
241} 488}
242 489
243# @ECLASS-VARIABLE: QCONFIG_ADD 490# @ECLASS-VARIABLE: QCONFIG_ADD
244# @DESCRIPTION: 491# @DESCRIPTION:
245# List options that need to be added to QT_CONFIG in qconfig.pri 492# List options that need to be added to QT_CONFIG in qconfig.pri
246QCONFIG_ADD="${QCONFIG_ADD:-}" 493: ${QCONFIG_ADD:=}
247 494
248# @ECLASS-VARIABLE: QCONFIG_REMOVE 495# @ECLASS-VARIABLE: QCONFIG_REMOVE
249# @DESCRIPTION: 496# @DESCRIPTION:
250# List options that need to be removed from QT_CONFIG in qconfig.pri 497# List options that need to be removed from QT_CONFIG in qconfig.pri
251QCONFIG_REMOVE="${QCONFIG_REMOVE:-}" 498: ${QCONFIG_REMOVE:=}
252 499
253# @ECLASS-VARIABLE: QCONFIG_DEFINE 500# @ECLASS-VARIABLE: QCONFIG_DEFINE
254# @DESCRIPTION: 501# @DESCRIPTION:
255# List variables that should be defined at the top of QtCore/qconfig.h 502# List variables that should be defined at the top of QtCore/qconfig.h
256QCONFIG_DEFINE="${QCONFIG_DEFINE:-}" 503: ${QCONFIG_DEFINE:=}
257 504
505# @FUNCTION: install_qconfigs
506# @DESCRIPTION: Install gentoo-specific mkspecs configurations
258install_qconfigs() { 507install_qconfigs() {
259 local x 508 local x
260 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} ]]; then 509 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} ]]; then
261 for x in QCONFIG_ADD QCONFIG_REMOVE; do 510 for x in QCONFIG_ADD QCONFIG_REMOVE; do
262 [[ -n ${!x} ]] && echo ${x}=${!x} >> "${T}"/${PN}-qconfig.pri 511 [[ -n ${!x} ]] && echo ${x}=${!x} >> "${T}"/${PN}-qconfig.pri
263 done 512 done
264 insinto ${QTDATADIR}/mkspecs/gentoo 513 insinto ${QTDATADIR#${EPREFIX}}/mkspecs/gentoo
265 doins "${T}"/${PN}-qconfig.pri || die "installing ${PN}-qconfig.pri failed" 514 doins "${T}"/${PN}-qconfig.pri || die "installing ${PN}-qconfig.pri failed"
266 fi 515 fi
267 516
268 if [[ -n ${QCONFIG_DEFINE} ]]; then 517 if [[ -n ${QCONFIG_DEFINE} ]]; then
269 for x in ${QCONFIG_DEFINE}; do 518 for x in ${QCONFIG_DEFINE}; do
270 echo "#define ${x}" >> "${T}"/gentoo-${PN}-qconfig.h 519 echo "#define ${x}" >> "${T}"/gentoo-${PN}-qconfig.h
271 done 520 done
272 insinto ${QTHEADERDIR}/Gentoo 521 insinto ${QTHEADERDIR#${EPREFIX}}/Gentoo
273 doins "${T}"/gentoo-${PN}-qconfig.h || die "installing ${PN}-qconfig.h failed" 522 doins "${T}"/gentoo-${PN}-qconfig.h || die "installing ${PN}-qconfig.h failed"
274 fi 523 fi
275} 524}
276 525
526# @FUNCTION: generate_qconfigs
527# @DESCRIPTION: Generates gentoo-specific configurations
277generate_qconfigs() { 528generate_qconfigs() {
278 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then 529 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then
279 local x qconfig_add qconfig_remove qconfig_new 530 local x qconfig_add qconfig_remove qconfig_new
280 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do 531 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do
281 [[ -f ${x} ]] || continue 532 [[ -f ${x} ]] || continue
282 qconfig_add="${qconfig_add} $(sed -n 's/^QCONFIG_ADD=//p' "${x}")" 533 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")"
283 qconfig_remove="${qconfig_remove} $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")" 534 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")"
284 done 535 done
285 536
286 # these error checks do not use die because dying in pkg_post{inst,rm} 537 # these error checks do not use die because dying in pkg_post{inst,rm}
287 # just makes things worse. 538 # just makes things worse.
288 if [[ -e "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri ]]; then 539 if [[ -e "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri ]]; then
295 546
296 # generate list of QT_CONFIG entries from the existing list 547 # generate list of QT_CONFIG entries from the existing list
297 # including qconfig_add and excluding qconfig_remove 548 # including qconfig_add and excluding qconfig_remove
298 for x in $(sed -n 's/^QT_CONFIG +=//p' \ 549 for x in $(sed -n 's/^QT_CONFIG +=//p' \
299 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri) ${qconfig_add}; do 550 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri) ${qconfig_add}; do
300 hasq ${x} ${qconfig_remove} || qconfig_new="${qconfig_new} ${x}" 551 hasq ${x} ${qconfig_remove} || qconfig_new+=" ${x}"
301 done 552 done
302 553
303 # replace the existing QT_CONFIG list with qconfig_new 554 # replace the existing QT_CONFIG list with qconfig_new
304 if ! sed -i -e "s/QT_CONFIG +=.*/QT_CONFIG += ${qconfig_new}/" \ 555 if ! sed -i -e "s/QT_CONFIG +=.*/QT_CONFIG += ${qconfig_new}/" \
305 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then 556 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then
328 "${ROOT}${QTHEADERDIR}" 2>/dev/null 579 "${ROOT}${QTHEADERDIR}" 2>/dev/null
329 fi 580 fi
330 fi 581 fi
331} 582}
332 583
584# @FUNCTION: qt4-build_pkg_postrm
585# @DESCRIPTION: Generate configurations when the package is completely removed
333qt4-build_pkg_postrm() { 586qt4-build_pkg_postrm() {
334 generate_qconfigs 587 generate_qconfigs
335} 588}
336 589
590# @FUNCTION: qt4-build_pkg_postinst
591# @DESCRIPTION: Generate configuration, plus throws a message about possible
592# breakages and proposed solutions.
337qt4-build_pkg_postinst() { 593qt4-build_pkg_postinst() {
338 generate_qconfigs 594 generate_qconfigs
339 echo
340 ewarn "After a rebuild or upgrade of Qt, it can happen that Qt plugins (such as Qt"
341 ewarn "and KDE styles and widgets) can no longer be loaded. In this situation you"
342 ewarn "should recompile the packages providing these plugins. Also, make sure you"
343 ewarn "compile the Qt packages, and the packages that depend on it, with the same"
344 ewarn "GCC version and the same USE flag settings (especially the debug flag)."
345 ewarn
346 ewarn "Packages that typically need to be recompiled are kdelibs from KDE4, any"
347 ewarn "additional KDE4/Qt4 styles, qscintilla and PyQt4. Before filing a bug report,"
348 ewarn "make sure all your Qt4 packages are up-to-date and built with the same"
349 ewarn "configuration."
350 ewarn
351 ewarn "For more information, see http://doc.trolltech.com/4.4/plugins-howto.html"
352 echo
353} 595}
354 596
597# @FUNCTION: skip_qmake_build_patch
598# @DESCRIPTION:
599# Don't need to build qmake, as it's already installed from qt-core
355skip_qmake_build_patch() { 600skip_qmake_build_patch() {
356 # Don't need to build qmake, as it's already installed from qt-core 601 # Don't need to build qmake, as it's already installed from qt-core
357 sed -i -e "s:if true:if false:g" "${S}"/configure || die "Sed failed" 602 sed -i -e "s:if true:if false:g" "${S}"/configure || die "Sed failed"
358} 603}
359 604
605# @FUNCTION: skip_project_generation_patch
606# @DESCRIPTION:
607# Exit the script early by throwing in an exit before all of the .pro files are scanned
360skip_project_generation_patch() { 608skip_project_generation_patch() {
361 # Exit the script early by throwing in an exit before all of the .pro files are scanned 609 # Exit the script early by throwing in an exit before all of the .pro files are scanned
362 sed -e "s:echo \"Finding:exit 0\n\necho \"Finding:g" \ 610 sed -e "s:echo \"Finding:exit 0\n\necho \"Finding:g" \
363 -i "${S}"/configure || die "Sed failed" 611 -i "${S}"/configure || die "Sed failed"
364} 612}
365 613
614# @FUNCTION: symlink_binaries_to_buildtree
615# @DESCRIPTION:
616# Symlink generated binaries to buildtree so they can be used during compilation
617# time
366symlink_binaries_to_buildtree() { 618symlink_binaries_to_buildtree() {
367 for bin in qmake moc uic rcc; do 619 for bin in qmake moc uic rcc; do
368 ln -s ${QTBINDIR}/${bin} "${S}"/bin/ || die "Symlinking ${bin} to ${S}/bin failed." 620 ln -s ${QTBINDIR}/${bin} "${S}"/bin/ || die "Symlinking ${bin} to ${S}/bin failed."
369 done 621 done
370} 622}
371 623
624# @FUNCTION: fix_library_files
625# @DESCRIPTION:
626# Fixes the pathes in *.la, *.prl, *.pc, as they are wrong due to sandbox and
627# moves the *.pc-files into the pkgconfig directory
372fix_library_files() { 628fix_library_files() {
373 for libfile in "${D}"/${QTLIBDIR}/{*.la,*.prl,pkgconfig/*.pc}; do 629 for libfile in "${D}"/${QTLIBDIR}/{*.la,*.prl,pkgconfig/*.pc}; do
374 if [[ -e ${libfile} ]]; then 630 if [[ -e ${libfile} ]]; then
375 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${libfile} || die "Sed on ${libfile} failed." 631 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${libfile} || die "Sed on ${libfile} failed."
376 fi 632 fi
379 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations. Fix: 635 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations. Fix:
380 for libfile in "${D}"/${QTLIBDIR}/pkgconfig/*.pc; do 636 for libfile in "${D}"/${QTLIBDIR}/pkgconfig/*.pc; do
381 if [[ -e ${libfile} ]]; then 637 if [[ -e ${libfile} ]]; then
382 sed -i -e "s:${S}/bin:${QTBINDIR}:g" ${libfile} || die "Sed failed" 638 sed -i -e "s:${S}/bin:${QTBINDIR}:g" ${libfile} || die "Sed failed"
383 639
384 # Move .pc files into the pkgconfig directory 640 # Move .pc files into the pkgconfig directory
385
386 dodir ${QTPCDIR} 641 dodir ${QTPCDIR#${EPREFIX}}
387 mv ${libfile} "${D}"/${QTPCDIR}/ \ 642 mv ${libfile} "${D}"/${QTPCDIR}/ \
388 || die "Moving ${libfile} to ${D}/${QTPCDIR}/ failed." 643 || die "Moving ${libfile} to ${D}/${QTPCDIR}/ failed."
389 fi 644 fi
390 done 645 done
391 646
392 # Don't install an empty directory 647 # Don't install an empty directory
393 rmdir "${D}"/${QTLIBDIR}/pkgconfig 648 rmdir "${D}"/${QTLIBDIR}/pkgconfig
394} 649}
395 650
651# @FUNCTION: qt_use
652# @USAGE: < flag > [ feature ] [ enableval ]
653# @DESCRIPTION:
654# This will echo "${enableval}-${feature}" if <flag> is enabled, or
655# "-no-${feature} if the flag is disabled. If [feature] is not specified <flag>
656# will be used for that. If [enableval] is not specified, it omits the
657# assignment-part
396qt_use() { 658qt_use() {
397 local flag="${1}" 659 local flag=$1
398 local feature="${1}" 660 local feature=$1
399 local enableval= 661 local enableval=
400 662
401 [[ -n ${2} ]] && feature=${2} 663 [[ -n $2 ]] && feature=$2
402 [[ -n ${3} ]] && enableval="-${3}" 664 [[ -n $3 ]] && enableval=-$3
403 665
404 if use ${flag}; then 666 if use ${flag}; then
405 echo "${enableval}-${feature}" 667 echo "${enableval}-${feature}"
406 else 668 else
407 echo "-no-${feature}" 669 echo "-no-${feature}"
408 fi 670 fi
409} 671}
410 672
411# @ECLASS-VARIABLE: QT4_BUILT_WITH_USE_CHECK 673# @FUNCTION: qt_mkspecs_dir
674# @RETURN: the specs-directory w/o path
412# @DESCRIPTION: 675# @DESCRIPTION:
413# The contents of $QT4_BUILT_WITH_USE_CHECK gets fed to built_with_use 676# Allows us to define which mkspecs dir we want to use.
414# (eutils.eclass), line per line.
415#
416# Example:
417# @CODE
418# pkg_setup() {
419# use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
420# ~x11-libs/qt-gui-${PV} qt3support"
421# qt4-build_check_use
422# }
423# @CODE
424
425# Run built_with_use on each flag and print appropriate error messages if any
426# flags are missing
427_qt_built_with_use() {
428 local missing opt pkg flag flags
429
430 if [[ ${1} = "--missing" ]]; then
431 missing="${1} ${2}" && shift 2
432 fi
433 if [[ ${1:0:1} = "-" ]]; then
434 opt=${1} && shift
435 fi
436
437 pkg=${1} && shift
438
439 for flag in "${@}"; do
440 flags="${flags} ${flag}"
441 if ! built_with_use ${missing} ${opt} ${pkg} ${flag}; then
442 flags="${flags}*"
443 else
444 [[ ${opt} = "-o" ]] && return 0
445 fi
446 done
447 if [[ "${flags# }" = "${@}" ]]; then
448 return 0
449 fi
450 if [[ ${opt} = "-o" ]]; then
451 eerror "This package requires '${pkg}' to be built with any of the following USE flags: '$*'."
452 else
453 eerror "This package requires '${pkg}' to be built with the following USE flags: '${flags# }'."
454 fi
455 return 1
456}
457
458# @FUNCTION: qt4-build_check_use
459# @DESCRIPTION:
460# Check if the listed packages in $QT4_BUILT_WITH_USE_CHECK are built with the
461# USE flags listed.
462#
463# If any of the required USE flags are missing, an eerror will be printed for
464# each package with missing USE flags.
465qt4-build_check_use() {
466 local line missing
467 while read line; do
468 [[ -z ${line} ]] && continue
469 if ! _qt_built_with_use ${line}; then
470 missing=true
471 fi
472 done <<< "${QT4_BUILT_WITH_USE_CHECK}"
473 if [[ -n ${missing} ]]; then
474 echo
475 eerror "Flags marked with an * are missing."
476 die "Missing USE flags found"
477 fi
478}
479
480qt_mkspecs_dir() { 677qt_mkspecs_dir() {
481 # Allows us to define which mkspecs dir we want to use. 678 # Allows us to define which mkspecs dir we want to use.
482 local spec 679 local spec
483 680
484 case ${CHOST} in 681 case ${CHOST} in
485 *-freebsd*|*-dragonfly*) 682 *-freebsd*|*-dragonfly*)
486 spec="freebsd" ;; 683 spec=freebsd ;;
487 *-openbsd*) 684 *-openbsd*)
488 spec="openbsd" ;; 685 spec=openbsd ;;
489 *-netbsd*) 686 *-netbsd*)
490 spec="netbsd" ;; 687 spec=netbsd ;;
491 *-darwin*) 688 *-darwin*)
689 if use aqua; then
690 # mac with carbon/cocoa
691 spec=macx
692 else
693 # darwin/mac with x11
492 spec="darwin" ;; 694 spec=darwin
695 fi
696 ;;
697 *-solaris*)
698 spec=solaris ;;
493 *-linux-*|*-linux) 699 *-linux-*|*-linux)
494 spec="linux" ;; 700 spec=linux ;;
495 *) 701 *)
496 die "Unknown CHOST, no platform choosen." 702 die "Unknown CHOST, no platform choosen."
497 esac 703 esac
498 704
499 CXX=$(tc-getCXX) 705 CXX=$(tc-getCXX)
500 if [[ ${CXX/g++/} != ${CXX} ]]; then 706 if [[ ${CXX} == *g++* ]]; then
501 spec="${spec}-g++" 707 spec+=-g++
502 elif [[ ${CXX/icpc/} != ${CXX} ]]; then 708 elif [[ ${CXX} == *icpc* ]]; then
503 spec="${spec}-icc" 709 spec+=-icc
504 else 710 else
505 die "Unknown compiler ${CXX}." 711 die "Unknown compiler ${CXX}."
506 fi 712 fi
713 if [[ -n ${LIBDIR/lib} ]]; then
714 spec+=-${LIBDIR/lib}
715 fi
716
717 # Add -64 for 64bit profiles
718 if use x64-freebsd ||
719 use amd64-linux ||
720 use x64-macos ||
721 use x64-solaris ||
722 use sparc64-solaris
723 then
724 spec+=-64
725 fi
507 726
508 echo "${spec}" 727 echo "${spec}"
509} 728}
510 729
511case ${EAPI:-0} in
512 0|1) EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postrm pkg_postinst ;;
513 2) EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_install pkg_postrm pkg_postinst ;; 730EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_install pkg_postrm pkg_postinst
514esac

Legend:
Removed from v.1.20  
changed lines
  Added in v.1.68

  ViewVC Help
Powered by ViewVC 1.1.20