/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Diff of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.95 Revision 1.96
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.95 2011/10/16 09:59:39 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.96 2011/10/30 14:21:14 hwoarang Exp $
4 4
5# @ECLASS: qt4-build.eclass 5# @ECLASS: qt4-build.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Ben de Groot <yngwin@gentoo.org>, 7# Ben de Groot <yngwin@gentoo.org>,
8# Markos Chandras <hwoarang@gentoo.org>, 8# Markos Chandras <hwoarang@gentoo.org>,
20 [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]] && 20 [[ ${CATEGORY}/${PN} != x11-libs/qt-xmlpatterns ]] &&
21 [[ ${CATEGORY}/${PN} != x11-themes/qgtkstyle ]] && 21 [[ ${CATEGORY}/${PN} != x11-themes/qgtkstyle ]] &&
22 IUSE="+exceptions" 22 IUSE="+exceptions"
23else 23else
24 MY_P=qt-x11-opensource-src-${MY_PV} 24 MY_P=qt-x11-opensource-src-${MY_PV}
25fi
26
27if version_is_at_least 4.7.99999999; then
28 IUSE+=" c++0x qpa"
25fi 29fi
26 30
27HOMEPAGE="http://qt.nokia.com/" 31HOMEPAGE="http://qt.nokia.com/"
28SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz" 32SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
29 33
207 211
208 if [[ ${CHOST} == *86*-apple-darwin* ]] ; then 212 if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
209 # qmake bus errors with -O2 but -O3 works 213 # qmake bus errors with -O2 but -O3 works
210 replace-flags -O2 -O3 214 replace-flags -O2 -O3
211 fi 215 fi
212 216
213 # Bug 178652 217 # Bug 178652
214 if [[ $(gcc-major-version) == 3 ]] && use amd64; then 218 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
215 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS" 219 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
216 append-flags -fno-gcse 220 append-flags -fno-gcse
217 fi 221 fi
218 222
223 if has c++0x ${IUSE//+} && use c++0x; then
224 ewarn "You are about to build Qt4 using the C++11 standard. Even though"
225 ewarn "this is an official standard, some of the reverse dependencies"
226 ewarn "may fail to compile or link againt the Qt4 libraries. Before"
227 ewarn "reporting a bug, make sure your bug is reproducible with c++0x"
228 ewarn "disabled."
229 append-flags -std=c++0x
230 fi
219 # Unsupported old gcc versions - hardened needs this :( 231 # Unsupported old gcc versions - hardened needs this :(
220 if [[ $(gcc-major-version) -lt 4 ]] ; then 232 if [[ $(gcc-major-version) -lt 4 ]] ; then
221 ewarn "Appending -fno-stack-protector to CXXFLAGS" 233 ewarn "Appending -fno-stack-protector to CXXFLAGS"
222 append-cxxflags -fno-stack-protector 234 append-cxxflags -fno-stack-protector
223 # Bug 253127 235 # Bug 253127
318 # use -I, -L and -l from configure 330 # use -I, -L and -l from configure
319 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)" 331 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
320 # avoid the -pthread argument 332 # avoid the -pthread argument
321 myconf+=" ${glibflags//-pthread}" 333 myconf+=" ${glibflags//-pthread}"
322 unset glibflags 334 unset glibflags
335 fi
336
337 if has qpa ${IUSE//+} && use qpa; then
338 ewarn
339 ewarn "The qpa useflag enables the Qt Platform Abstraction, formely"
340 ewarn "known as Qt Lighthouse. If you are not sure what that is, then"
341 ewarn "disable it before reporting any bugs related to this useflag."
342 ewarn
343 myconf+=" -qpa"
323 fi 344 fi
324 345
325 if use aqua ; then 346 if use aqua ; then
326 # On (snow) leopard use the new (frameworked) cocoa code. 347 # On (snow) leopard use the new (frameworked) cocoa code.
327 if [[ ${CHOST##*-darwin} -ge 9 ]] ; then 348 if [[ ${CHOST##*-darwin} -ge 9 ]] ; then

Legend:
Removed from v.1.95  
changed lines
  Added in v.1.96

  ViewVC Help
Powered by ViewVC 1.1.20