/[gentoo-x86]/eclass/qt4-build.eclass
Gentoo

Contents of /eclass/qt4-build.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.63 - (show annotations) (download)
Wed Feb 10 20:34:17 2010 UTC (4 years, 9 months ago) by yngwin
Branch: MAIN
Changes since 1.62: +6 -10 lines
Small patch to fix Darwinbuild issues with qt4-build.eclass

1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/qt4-build.eclass,v 1.62 2010/01/21 05:57:09 vapier Exp $
4
5 # @ECLASS: qt4-build.eclass
6 # @MAINTAINER:
7 # Ben de Groot <yngwin@gentoo.org>,
8 # Markos Chandras <hwoarang@gentoo.org>,
9 # Caleb Tennis <caleb@gentoo.org>
10 # Alex Alexander <wired@gentoo.org>
11 # @BLURB: Eclass for Qt4 split ebuilds.
12 # @DESCRIPTION:
13 # This eclass contains various functions that are used when building Qt4
14
15 inherit base eutils multilib toolchain-funcs flag-o-matic versionator
16
17 MY_PV=${PV/_/-}
18 if version_is_at_least 4.5.99999999; then
19 MY_P=qt-everywhere-opensource-src-${MY_PV}
20 else
21 MY_P=qt-x11-opensource-src-${MY_PV}
22 fi
23
24 HOMEPAGE="http://qt.nokia.com/"
25 SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
26
27 LICENSE="|| ( LGPL-2.1 GPL-3 )"
28 IUSE="debug pch aqua"
29
30 RDEPEND="
31 !<x11-libs/qt-assistant-${PV}
32 !>x11-libs/qt-assistant-${PV}-r9999
33 !<x11-libs/qt-core-${PV}
34 !>x11-libs/qt-core-${PV}-r9999
35 !<x11-libs/qt-dbus-${PV}
36 !>x11-libs/qt-dbus-${PV}-r9999
37 !<x11-libs/qt-demo-${PV}
38 !>x11-libs/qt-demo-${PV}-r9999
39 !<x11-libs/qt-gui-${PV}
40 !>x11-libs/qt-gui-${PV}-r9999
41 !<x11-libs/qt-opengl-${PV}
42 !>x11-libs/qt-opengl-${PV}-r9999
43 !<x11-libs/qt-phonon-${PV}
44 !>x11-libs/qt-phonon-${PV}-r9999
45 !<x11-libs/qt-qt3support-${PV}
46 !>x11-libs/qt-qt3support-${PV}-r9999
47 !<x11-libs/qt-script-${PV}
48 !>x11-libs/qt-script-${PV}-r9999
49 !<x11-libs/qt-sql-${PV}
50 !>x11-libs/qt-sql-${PV}-r9999
51 !<x11-libs/qt-svg-${PV}
52 !>x11-libs/qt-svg-${PV}-r9999
53 !<x11-libs/qt-test-${PV}
54 !>x11-libs/qt-test-${PV}-r9999
55 !<x11-libs/qt-webkit-${PV}
56 !>x11-libs/qt-webkit-${PV}-r9999
57 !<x11-libs/qt-xmlpatterns-${PV}
58 !>x11-libs/qt-xmlpatterns-${PV}-r9999
59 "
60
61 S=${WORKDIR}/${MY_P}
62
63 # @FUNCTION: qt4-build_pkg_setup
64 # @DESCRIPTION:
65 # Sets up S, MY_P, PATH, and LD_LIBRARY_PATH
66 qt4-build_pkg_setup() {
67 [[ ${EAPI} == 2 ]] && use !prefix && EPREFIX=
68
69
70 PATH="${S}/bin${PATH:+:}${PATH}"
71 if [[ ${CHOST} != *-darwin* ]]; then
72 LD_LIBRARY_PATH="${S}/lib${LD_LIBRARY_PATH:+:}${LD_LIBRARY_PATH}"
73 else
74 DYLD_LIBRARY_PATH="${S}/lib${DYLD_LIBRARY_PATH:+:}${DYLD_LIBRARY_PATH}"
75 # On MacOS we *need* at least src/gui/kernel/qapplication_mac.mm for
76 # platform detection. Note: needs to come before any directories to
77 # avoid extract failure.
78 [[ ${CHOST} == *-apple-darwin* ]] && \
79 QT4_EXTRACT_DIRECTORIES="src/gui/kernel/qapplication_mac.mm ${QT4_EXTRACT_DIRECTORIES}"
80 fi
81
82 # Make sure ebuilds use the required EAPI
83 if [[ ${EAPI} != [23] ]]; then
84 eerror "The qt4-build eclass requires EAPI=2 or EAPI=3, but this ebuild is using"
85 eerror "EAPI=${EAPI:-0}. The ebuild author or editor failed. This ebuild needs to be"
86 eerror "fixed. Using qt4-build eclass without EAPI=2 or EAPI=3 will fail."
87 die "qt4-build eclass requires EAPI=2 or EAPI=3"
88 fi
89
90 if ! version_is_at_least 4.1 $(gcc-version); then
91 ewarn "Using a GCC version lower than 4.1 is not supported!"
92 echo
93 ebeep 3
94 fi
95 }
96
97 # @ECLASS-VARIABLE: QT4_TARGET_DIRECTORIES
98 # @DESCRIPTION:
99 # Arguments for build_target_directories. Takes the directories, in which the
100 # code should be compiled. This is a space-separated list
101
102 # @ECLASS-VARIABLE: QT4_EXTRACT_DIRECTORIES
103 # @DESCRIPTION:
104 # Space separated list including the directories that will be extracted from Qt
105 # tarball
106
107 # @FUNCTION: qt4-build_src_unpack
108 # @DESCRIPTION:
109 # Unpacks the sources
110 qt4-build_src_unpack() {
111 setqtenv
112 local target targets=
113 for target in configure LICENSE.GPL3 LICENSE.LGPL projects.pro \
114 src/{qbase,qt_targets,qt_install}.pri bin config.tests mkspecs qmake \
115 ${QT4_EXTRACT_DIRECTORIES}; do
116 targets+=" ${MY_P}/${target}"
117 done
118
119 echo tar xzpf "${DISTDIR}"/${MY_P}.tar.gz ${targets}
120 tar xzpf "${DISTDIR}"/${MY_P}.tar.gz ${targets} || die
121 }
122
123 # @ECLASS-VARIABLE: PATCHES
124 # @DESCRIPTION:
125 # In case you have patches to apply, specify them in PATCHES variable. Make sure
126 # to specify the full path. This variable is necessary for src_prepare phase.
127 # example:
128 # PATCHES="${FILESDIR}"/mypatch.patch
129 # ${FILESDIR}"/mypatch2.patch"
130 #
131
132 # @FUNCTION: qt4-build_src_prepare
133 # @DESCRIPTION:
134 # Prepare the sources before the configure phase. Strip CFLAGS if necessary, and fix
135 # source files in order to respect CFLAGS/CXXFLAGS/LDFLAGS specified on /etc/make.conf.
136 qt4-build_src_prepare() {
137 setqtenv
138 cd "${S}"
139
140 if use aqua; then
141 # provide a proper macx-g++-64
142 use x64-macos && ln -s macx-g++ mkspecs/$(qt_mkspecs_dir)
143
144 sed -e '/^CONFIG/s:app_bundle::' \
145 -e '/^CONFIG/s:plugin_no_soname:plugin_with_soname absolute_library_soname:' \
146 -i mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed failed"
147 fi
148
149 if [[ ${PN} != qt-core ]]; then
150 skip_qmake_build_patch
151 skip_project_generation_patch
152 symlink_binaries_to_buildtree
153 fi
154
155 if [[ ${CHOST} == *86*-apple-darwin* ]] ; then
156 # qmake bus errors with -O2 but -O3 works
157 replace-flags -O2 -O3
158 fi
159
160 # Bug 282984 && Bug 295530
161 sed -e "s:\(^SYSTEM_VARIABLES\):CC=$(tc-getCC)\nCXX=$(tc-getCXX)\n\1:" \
162 -i configure || die "sed qmake compilers failed"
163 sed -e "s:\(\$MAKE\):\1 CC=$(tc-getCC) CXX=$(tc-getCXX) LD=$(tc-getCXX):" \
164 -i config.tests/unix/compile.test || die "sed test compilers failed"
165
166 # Bug 178652
167 if [[ $(gcc-major-version) == 3 ]] && use amd64; then
168 ewarn "Appending -fno-gcse to CFLAGS/CXXFLAGS"
169 append-flags -fno-gcse
170 fi
171
172 # Unsupported old gcc versions - hardened needs this :(
173 if [[ $(gcc-major-version) -lt 4 ]] ; then
174 ewarn "Appending -fno-stack-protector to CXXFLAGS"
175 append-cxxflags -fno-stack-protector
176 # Bug 253127
177 sed -e "/^QMAKE_CFLAGS\t/ s:$: -fno-stack-protector-all:" \
178 -i "${S}"/mkspecs/common/g++.conf || die "sed ${S}/mkspecs/common/g++.conf failed"
179 fi
180
181 # Bug 261632
182 if use ppc64; then
183 ewarn "Appending -mminimal-toc to CFLAGS/CXXFLAGS"
184 append-flags -mminimal-toc
185 fi
186
187 # Bug 172219
188 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
189 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
190 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
191 -e "s:X11R6/::" \
192 -i "${S}"/mkspecs/$(qt_mkspecs_dir)/qmake.conf || die "sed ${S}/mkspecs/$(qt_mkspecs_dir)/qmake.conf failed"
193
194 if [[ ${CHOST} != *-darwin* ]]; then
195 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
196 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
197 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
198 -i mkspecs/common/g++.conf || die "sed mkspecs/common/g++.conf failed"
199 else
200 # Set FLAGS *and* remove -arch, since our gcc-apple is multilib
201 # crippled (by design) :/
202 sed -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
203 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
204 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=-headerpad_max_install_names ${LDFLAGS}:" \
205 -e "s:-arch\s\w*::g" \
206 -i mkspecs/common/mac-g++.conf || die "sed mkspecs/common/mac-g++.conf failed"
207
208 # Fix configure's -arch settings that appear in qmake/Makefile and also
209 # fix arch handling (automagically duplicates our -arch arg and breaks
210 # pch). Additionally disable Xarch support.
211 sed \
212 -e "s:-arch i386::" \
213 -e "s:-arch ppc::" \
214 -e "s:-arch x86_64::" \
215 -e "s:-arch ppc64::" \
216 -e "s:-arch \$i::" \
217 -e "/if \[ ! -z \"\$NATIVE_64_ARCH\" \]; then/,/fi/ d" \
218 -e "s:CFG_MAC_XARCH=yes:CFG_MAC_XARCH=no:g" \
219 -e "s:-Xarch_x86_64::g" \
220 -e "s:-Xarch_ppc64::g" \
221 -i configure mkspecs/common/mac-g++.conf || die "sed configure failed"
222
223 # On Snow Leopard don't fall back to 10.5 deployment target.
224 if [[ ${CHOST} == *-apple-darwin10 ]] ; then
225 sed -e "s:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET.*:QMakeVar set QMAKE_MACOSX_DEPLOYMENT_TARGET 10.6:g" \
226 -e "s:-mmacosx-version-min=10.[0-9]:-mmacosx-version-min=10.6:g" \
227 -i configure mkspecs/common/mac-g++.conf || die "sed configure failed"
228 fi
229 fi
230
231 # this one is needed for all systems with a separate -liconv, apart from
232 # Darwin, for which the sources already cater for -liconv
233 if use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] ; then
234 sed \
235 -e "s|mac:LIBS += -liconv|LIBS += -liconv|g" \
236 -i config.tests/unix/iconv/iconv.pro \
237 || die "sed on iconv.pro failed"
238 fi
239
240 # we need some patches for Solaris
241 sed -i \
242 -e '/^QMAKE_LFLAGS_THREAD/a\QMAKE_LFLAGS_DYNAMIC_LIST = -Wl,--dynamic-list,' \
243 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
244 # use GCC over SunStudio
245 sed -i -e '/PLATFORM=solaris-cc/s/cc/g++/' configure || die
246 # don't flirt with non-Prefix stuff, we're quite possessive
247 sed -i -e '/^QMAKE_\(LIB\|INC\)DIR\(_X11\|_OPENGL\|\)\t/s/=.*$/=/' \
248 mkspecs/$(qt_mkspecs_dir)/qmake.conf || die
249
250 base_src_prepare
251 }
252
253 # @FUNCTION: qt4-build_src_configure
254 # @DESCRIPTION:
255 # Default configure phase
256 qt4-build_src_configure() {
257 setqtenv
258 myconf="$(standard_configure_options) ${myconf}"
259
260 # this one is needed for all systems with a separate -liconv, apart from
261 # Darwin, for which the sources already cater for -liconv
262 use !elibc_glibc && [[ ${CHOST} != *-darwin* ]] && \
263 myconf+=" -liconv"
264
265 if has glib ${IUSE//+} && use glib; then
266 # use -I, -L and -l from configure
267 local glibflags="$(pkg-config --cflags --libs glib-2.0 gthread-2.0)"
268 # avoid the -pthread argument
269 myconf+=" ${glibflags//-pthread}"
270 unset glibflags
271 fi
272
273 if use aqua ; then
274 # On (snow) leopard use the new (frameworked) cocoa code.
275 if [[ ${CHOST##*-darwin} -ge 9 ]] ; then
276 myconf+=" -cocoa -framework"
277
278 # We are crazy and build cocoa + qt3support :-)
279 if use qt3support; then
280 sed -e "/case \"\$PLATFORM,\$CFG_MAC_COCOA\" in/,/;;/ s|CFG_QT3SUPPORT=\"no\"|CFG_QT3SUPPORT=\"yes\"|" \
281 -i configure
282 fi
283
284 # We need the source's headers, not the installed ones.
285 myconf+=" -I${S}/include"
286
287 # Add hint for the framework location.
288 myconf+=" -F${QTLIBDIR}"
289 fi
290 else
291 # freetype2 include dir is non-standard, thus include it on configure
292 # use -I from configure
293 myconf+=" $(pkg-config --cflags freetype2)"
294 fi
295
296 echo ./configure ${myconf}
297 ./configure ${myconf} || die "./configure failed"
298 myconf=""
299 }
300
301 # @FUNCTION: qt4-build_src_compile
302 # @DESCRIPTION: Actual compile phase
303 qt4-build_src_compile() {
304 setqtenv
305
306 build_directories ${QT4_TARGET_DIRECTORIES}
307 }
308
309 # @FUNCTION: fix_includes
310 # @DESCRIPTION:
311 # For MacOSX we need to add some symlinks when frameworks are
312 # being used, to avoid complications with some more or less stupid packages.
313 fix_includes() {
314 if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
315 # Some packages tend to include <Qt/...>
316 dodir "${QTHEADERDIR#${EPREFIX}}"/Qt
317
318 # Fake normal headers when frameworks are installed... eases life later on
319 local dest f
320 for frw in "${D}${QTLIBDIR}"/*.framework; do
321 [[ -e "${frw}"/Headers ]] || continue
322 f=$(basename ${frw})
323 dest="${QTHEADERDIR#${EPREFIX}}"/${f%.framework}
324 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers "${dest}"
325
326 # Link normal headers as well.
327 for hdr in "${D}/${QTLIBDIR}/${f}"/Headers/*; do
328 h=$(basename ${hdr})
329 dosym "${QTLIBDIR#${EPREFIX}}"/${f}/Headers/${h} "${QTHEADERDIR#${EPREFIX}}"/Qt/${h}
330 done
331 done
332 fi
333 }
334
335 # @FUNCTION: qt4-build_src_install
336 # @DESCRIPTION:
337 # Perform the actual installation including some library fixes.
338 qt4-build_src_install() {
339 [[ ${EAPI} == 2 ]] && use !prefix && ED=${D}
340 setqtenv
341 install_directories ${QT4_TARGET_DIRECTORIES}
342 install_qconfigs
343 fix_library_files
344 fix_includes
345 }
346
347 # @FUNCTION: setqtenv
348 setqtenv() {
349 # Set up installation directories
350 QTBASEDIR=${EPREFIX}/usr/$(get_libdir)/qt4
351 QTPREFIXDIR=${EPREFIX}/usr
352 QTBINDIR=${EPREFIX}/usr/bin
353 QTLIBDIR=${EPREFIX}/usr/$(get_libdir)/qt4
354 QMAKE_LIBDIR_QT=${QTLIBDIR}
355 QTPCDIR=${EPREFIX}/usr/$(get_libdir)/pkgconfig
356 QTDATADIR=${EPREFIX}/usr/share/qt4
357 QTDOCDIR=${EPREFIX}/usr/share/doc/qt-${PV}
358 QTHEADERDIR=${EPREFIX}/usr/include/qt4
359 QTPLUGINDIR=${QTLIBDIR}/plugins
360 QTSYSCONFDIR=${EPREFIX}/etc/qt4
361 QTTRANSDIR=${QTDATADIR}/translations
362 QTEXAMPLESDIR=${QTDATADIR}/examples
363 QTDEMOSDIR=${QTDATADIR}/demos
364 QT_INSTALL_PREFIX=${EPREFIX}/usr/$(get_libdir)/qt4
365 PLATFORM=$(qt_mkspecs_dir)
366
367 unset QMAKESPEC
368 }
369
370 # @FUNCTION: standard_configure_options
371 # @DESCRIPTION:
372 # Sets up some standard configure options, like libdir (if necessary), whether
373 # debug info is wanted or not.
374 standard_configure_options() {
375 local myconf=
376
377 [[ $(get_libdir) != lib ]] && myconf+=" -L${EPREFIX}/usr/$(get_libdir)"
378
379 # Disable visibility explicitly if gcc version isn't 4
380 if [[ $(gcc-major-version) -lt 4 ]]; then
381 myconf+=" -no-reduce-exports"
382 fi
383
384 # precompiled headers doesn't work on hardened, where the flag is masked.
385 myconf+=" $(qt_use pch)"
386
387 if use debug; then
388 myconf+=" -debug"
389 else
390 myconf+=" -release"
391 fi
392 myconf+=" -no-separate-debug-info"
393
394 use aqua && myconf+=" -no-framework"
395
396 # ARCH is set on Gentoo. Qt now falls back to generic on an unsupported
397 # $(tc-arch). Therefore we convert it to supported values.
398 case "$(tc-arch)" in
399 amd64|x64-*) myconf+=" -arch x86_64" ;;
400 ppc-macos) myconf+=" -arch ppc" ;;
401 ppc|ppc64|ppc-*) myconf+=" -arch powerpc" ;;
402 sparc|sparc-*) myconf+=" -arch sparc" ;;
403 x86-macos) myconf+=" -arch x86" ;;
404 x86|x86-*) myconf+=" -arch i386" ;;
405 alpha|arm|ia64|mips|s390|sparc) myconf+=" -arch $(tc-arch)" ;;
406 hppa|sh) myconf+=" -arch generic" ;;
407 *) die "$(tc-arch) is unsupported by this eclass. Please file a bug." ;;
408 esac
409
410 # 4.6: build qt-core with exceptions or qt-xmlpatterns won't build
411 local exceptions=
412 case "${PV}" in
413 4.6.*)
414 if [[ ${PN} != "qt-core" ]] && [[ ${PN} != "qt-xmlpatterns" ]]; then
415 case "${PV}:${CHOST}" in
416 4.6.0*:*-darwin*)
417 : # http://bugreports.qt.nokia.com/browse/QTBUG-5909
418 # workaround for compilation error on OSX (qt-gui)
419 ;;
420 *)
421 exceptions="-no-exceptions"
422 ;;
423 esac
424 fi
425 ;;
426 *)
427 [[ ${PN} == "qt-xmlpatterns" ]] || exceptions="-no-exceptions"
428 ;;
429 esac
430
431 # note about -reduce-relocations:
432 # That flag seems to introduce major breakage to applications,
433 # mostly to be seen as a core dump with the message "QPixmap: Must
434 # construct a QApplication before a QPaintDevice" on Solaris
435 # -- Daniel Vergien
436 [[ ${CHOST} != *-solaris* ]] && myconf+=" -reduce-relocations"
437
438 myconf+=" -platform $(qt_mkspecs_dir) -stl -verbose -largefile -confirm-license
439 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR}
440 -datadir ${QTDATADIR} -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR}
441 -plugindir ${QTPLUGINDIR} -sysconfdir ${QTSYSCONFDIR}
442 -translationdir ${QTTRANSDIR} -examplesdir ${QTEXAMPLESDIR}
443 -demosdir ${QTDEMOSDIR} -silent -fast -opensource
444 ${exceptions}
445 -nomake examples -nomake demos"
446
447 echo "${myconf}"
448 }
449
450 # @FUNCTION: build_directories
451 # @USAGE: < directories >
452 # @DESCRIPTION:
453 # Compiles the code in $QT4_TARGET_DIRECTORIES
454 build_directories() {
455 for x in "$@"; do
456 pushd "${S}"/${x} >/dev/null
457 # avoid running over the maximum argument number, bug #299810
458 {
459 echo "${S}"/mkspecs/common/*.conf
460 find "${S}" -name '*.pr[io]'
461 } | xargs sed -i -e "s:\$\$\[QT_INSTALL_LIBS\]:${EPREFIX}/usr/$(get_libdir)/qt4:g" || die
462 "${S}"/bin/qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" || die "qmake failed"
463 emake CC="@echo compiling \$< && $(tc-getCC)" \
464 CXX="@echo compiling \$< && $(tc-getCXX)" \
465 LINK="@echo linking \$@ && $(tc-getCXX)" || die "emake failed"
466 popd >/dev/null
467 done
468 }
469
470 # @FUNCTION: install_directories
471 # @USAGE: < directories >
472 # @DESCRIPTION:
473 # run emake install in the given directories, which are separated by spaces
474 install_directories() {
475 for x in "$@"; do
476 pushd "${S}"/${x} >/dev/null || die "Can't pushd ${S}/${x}"
477 emake INSTALL_ROOT="${D}" install || die "emake install failed"
478 popd >/dev/null || die "Can't popd from ${S}/${x}"
479 done
480 }
481
482 # @ECLASS-VARIABLE: QCONFIG_ADD
483 # @DESCRIPTION:
484 # List options that need to be added to QT_CONFIG in qconfig.pri
485 : ${QCONFIG_ADD:=}
486
487 # @ECLASS-VARIABLE: QCONFIG_REMOVE
488 # @DESCRIPTION:
489 # List options that need to be removed from QT_CONFIG in qconfig.pri
490 : ${QCONFIG_REMOVE:=}
491
492 # @ECLASS-VARIABLE: QCONFIG_DEFINE
493 # @DESCRIPTION:
494 # List variables that should be defined at the top of QtCore/qconfig.h
495 : ${QCONFIG_DEFINE:=}
496
497 # @FUNCTION: install_qconfigs
498 # @DESCRIPTION: Install gentoo-specific mkspecs configurations
499 install_qconfigs() {
500 local x
501 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} ]]; then
502 for x in QCONFIG_ADD QCONFIG_REMOVE; do
503 [[ -n ${!x} ]] && echo ${x}=${!x} >> "${T}"/${PN}-qconfig.pri
504 done
505 insinto ${QTDATADIR#${EPREFIX}}/mkspecs/gentoo
506 doins "${T}"/${PN}-qconfig.pri || die "installing ${PN}-qconfig.pri failed"
507 fi
508
509 if [[ -n ${QCONFIG_DEFINE} ]]; then
510 for x in ${QCONFIG_DEFINE}; do
511 echo "#define ${x}" >> "${T}"/gentoo-${PN}-qconfig.h
512 done
513 insinto ${QTHEADERDIR#${EPREFIX}}/Gentoo
514 doins "${T}"/gentoo-${PN}-qconfig.h || die "installing ${PN}-qconfig.h failed"
515 fi
516 }
517
518 # @FUNCTION: generate_qconfigs
519 # @DESCRIPTION: Generates gentoo-specific configurations
520 generate_qconfigs() {
521 if [[ -n ${QCONFIG_ADD} || -n ${QCONFIG_REMOVE} || -n ${QCONFIG_DEFINE} || ${CATEGORY}/${PN} == x11-libs/qt-core ]]; then
522 local x qconfig_add qconfig_remove qconfig_new
523 for x in "${ROOT}${QTDATADIR}"/mkspecs/gentoo/*-qconfig.pri; do
524 [[ -f ${x} ]] || continue
525 qconfig_add+=" $(sed -n 's/^QCONFIG_ADD=//p' "${x}")"
526 qconfig_remove+=" $(sed -n 's/^QCONFIG_REMOVE=//p' "${x}")"
527 done
528
529 # these error checks do not use die because dying in pkg_post{inst,rm}
530 # just makes things worse.
531 if [[ -e "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri ]]; then
532 # start with the qconfig.pri that qt-core installed
533 if ! cp "${ROOT}${QTDATADIR}"/mkspecs/gentoo/qconfig.pri \
534 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then
535 eerror "cp qconfig failed."
536 return 1
537 fi
538
539 # generate list of QT_CONFIG entries from the existing list
540 # including qconfig_add and excluding qconfig_remove
541 for x in $(sed -n 's/^QT_CONFIG +=//p' \
542 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri) ${qconfig_add}; do
543 hasq ${x} ${qconfig_remove} || qconfig_new+=" ${x}"
544 done
545
546 # replace the existing QT_CONFIG list with qconfig_new
547 if ! sed -i -e "s/QT_CONFIG +=.*/QT_CONFIG += ${qconfig_new}/" \
548 "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri; then
549 eerror "Sed for QT_CONFIG failed"
550 return 1
551 fi
552
553 # create Gentoo/qconfig.h
554 if [[ ! -e ${ROOT}${QTHEADERDIR}/Gentoo ]]; then
555 if ! mkdir -p "${ROOT}${QTHEADERDIR}"/Gentoo; then
556 eerror "mkdir ${QTHEADERDIR}/Gentoo failed"
557 return 1
558 fi
559 fi
560 : > "${ROOT}${QTHEADERDIR}"/Gentoo/gentoo-qconfig.h
561 for x in "${ROOT}${QTHEADERDIR}"/Gentoo/gentoo-*-qconfig.h; do
562 [[ -f ${x} ]] || continue
563 cat "${x}" >> "${ROOT}${QTHEADERDIR}"/Gentoo/gentoo-qconfig.h
564 done
565 else
566 rm -f "${ROOT}${QTDATADIR}"/mkspecs/qconfig.pri
567 rm -f "${ROOT}${QTHEADERDIR}"/Gentoo/gentoo-qconfig.h
568 rmdir "${ROOT}${QTDATADIR}"/mkspecs \
569 "${ROOT}${QTDATADIR}" \
570 "${ROOT}${QTHEADERDIR}"/Gentoo \
571 "${ROOT}${QTHEADERDIR}" 2>/dev/null
572 fi
573 fi
574 }
575
576 # @FUNCTION: qt4-build_pkg_postrm
577 # @DESCRIPTION: Generate configurations when the package is completely removed
578 qt4-build_pkg_postrm() {
579 generate_qconfigs
580 }
581
582 # @FUNCTION: qt4-build_pkg_postinst
583 # @DESCRIPTION: Generate configuration, plus throws a message about possible
584 # breakages and proposed solutions.
585 qt4-build_pkg_postinst() {
586 generate_qconfigs
587
588 if [[ "${PN}" == "qt-core" ]]; then
589 echo
590 ewarn "After a rebuild or upgrade of Qt, it can happen that Qt plugins (such as Qt"
591 ewarn "and KDE styles and widgets) can no longer be loaded. In this situation you"
592 ewarn "should recompile the packages providing these plugins. Also, make sure you"
593 ewarn "compile the Qt packages, and the packages that depend on it, with the same"
594 ewarn "GCC version and the same USE flag settings (especially the debug flag)."
595 ewarn
596 ewarn "Packages that typically need to be recompiled are kdelibs from KDE4, any"
597 ewarn "additional KDE4/Qt4 styles, qscintilla and PyQt4. Before filing a bug report,"
598 ewarn "make sure all your Qt4 packages are up-to-date and built with the same"
599 ewarn "configuration."
600 ewarn
601 ewarn "For more information, see http://doc.trolltech.com/${PV%.*}/plugins-howto.html"
602 echo
603 fi
604 }
605
606 # @FUNCTION: skip_qmake_build_patch
607 # @DESCRIPTION:
608 # Don't need to build qmake, as it's already installed from qt-core
609 skip_qmake_build_patch() {
610 # Don't need to build qmake, as it's already installed from qt-core
611 sed -i -e "s:if true:if false:g" "${S}"/configure || die "Sed failed"
612 }
613
614 # @FUNCTION: skip_project_generation_patch
615 # @DESCRIPTION:
616 # Exit the script early by throwing in an exit before all of the .pro files are scanned
617 skip_project_generation_patch() {
618 # Exit the script early by throwing in an exit before all of the .pro files are scanned
619 sed -e "s:echo \"Finding:exit 0\n\necho \"Finding:g" \
620 -i "${S}"/configure || die "Sed failed"
621 }
622
623 # @FUNCTION: symlink_binaries_to_buildtree
624 # @DESCRIPTION:
625 # Symlink generated binaries to buildtree so they can be used during compilation
626 # time
627 symlink_binaries_to_buildtree() {
628 for bin in qmake moc uic rcc; do
629 ln -s ${QTBINDIR}/${bin} "${S}"/bin/ || die "Symlinking ${bin} to ${S}/bin failed."
630 done
631 }
632
633 # @FUNCTION: fix_library_files
634 # @DESCRIPTION:
635 # Fixes the pathes in *.la, *.prl, *.pc, as they are wrong due to sandbox and
636 # moves the *.pc-files into the pkgconfig directory
637 fix_library_files() {
638 for libfile in "${D}"/${QTLIBDIR}/{*.la,*.prl,pkgconfig/*.pc}; do
639 if [[ -e ${libfile} ]]; then
640 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${libfile} || die "Sed on ${libfile} failed."
641 fi
642 done
643
644 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations. Fix:
645 for libfile in "${D}"/${QTLIBDIR}/pkgconfig/*.pc; do
646 if [[ -e ${libfile} ]]; then
647 sed -i -e "s:${S}/bin:${QTBINDIR}:g" ${libfile} || die "Sed failed"
648
649 # Move .pc files into the pkgconfig directory
650 dodir ${QTPCDIR#${EPREFIX}}
651 mv ${libfile} "${D}"/${QTPCDIR}/ \
652 || die "Moving ${libfile} to ${D}/${QTPCDIR}/ failed."
653 fi
654 done
655
656 # Don't install an empty directory
657 rmdir "${D}"/${QTLIBDIR}/pkgconfig
658 }
659
660 # @FUNCTION: qt_use
661 # @USAGE: < flag > [ feature ] [ enableval ]
662 # @DESCRIPTION:
663 # This will echo "${enableval}-${feature}" if <flag> is enabled, or
664 # "-no-${feature} if the flag is disabled. If [feature] is not specified <flag>
665 # will be used for that. If [enableval] is not specified, it omits the
666 # assignment-part
667 qt_use() {
668 local flag=$1
669 local feature=$1
670 local enableval=
671
672 [[ -n $2 ]] && feature=$2
673 [[ -n $3 ]] && enableval=-$3
674
675 if use ${flag}; then
676 echo "${enableval}-${feature}"
677 else
678 echo "-no-${feature}"
679 fi
680 }
681
682 # @FUNCTION: qt_mkspecs_dir
683 # @RETURN: the specs-directory w/o path
684 # @DESCRIPTION:
685 # Allows us to define which mkspecs dir we want to use.
686 qt_mkspecs_dir() {
687 # Allows us to define which mkspecs dir we want to use.
688 local spec
689
690 case ${CHOST} in
691 *-freebsd*|*-dragonfly*)
692 spec=freebsd ;;
693 *-openbsd*)
694 spec=openbsd ;;
695 *-netbsd*)
696 spec=netbsd ;;
697 *-darwin*)
698 if use aqua; then
699 # mac with carbon/cocoa
700 spec=macx
701 else
702 # darwin/mac with x11
703 spec=darwin
704 fi
705 ;;
706 *-solaris*)
707 spec=solaris ;;
708 *-linux-*|*-linux)
709 spec=linux ;;
710 *)
711 die "Unknown CHOST, no platform choosen."
712 esac
713
714 CXX=$(tc-getCXX)
715 if [[ ${CXX} == *g++* ]]; then
716 spec+=-g++
717 elif [[ ${CXX} == *icpc* ]]; then
718 spec+=-icc
719 else
720 die "Unknown compiler ${CXX}."
721 fi
722 if [[ -n ${LIBDIR/lib} ]]; then
723 spec+=-${LIBDIR/lib}
724 fi
725
726 # Add -64 for 64bit profiles
727 if use x64-freebsd ||
728 use amd64-linux ||
729 use x64-macos ||
730 use x64-solaris ||
731 use sparc64-solaris
732 then
733 spec+=-64
734 fi
735
736 echo "${spec}"
737 }
738
739 EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_install pkg_postrm pkg_postinst

  ViewVC Help
Powered by ViewVC 1.1.20