/[gentoo-x86]/eclass/qt4.eclass
Gentoo

Diff of /eclass/qt4.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.31 Revision 1.32
1# Copyright 2005 Gentoo Foundation 1# Copyright 2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/qt4.eclass,v 1.31 2007/12/31 18:55:53 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/qt4.eclass,v 1.32 2008/01/05 18:44:38 caleb Exp $
4 4
5# @ECLASS: qt4.eclass 5# @ECLASS: qt4.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Caleb Tennis <caleb@gentoo.org> 7# Caleb Tennis <caleb@gentoo.org>
8# @BLURB: 8# @BLURB:
97 elif [[ ${x} == opengl || ${x} == dbus || ${x} == qt3support ]]; then 97 elif [[ ${x} == opengl || ${x} == dbus || ${x} == qt3support ]]; then
98 # Make sure the qt-${x} package has been already installed 98 # Make sure the qt-${x} package has been already installed
99 99
100 if ! has_version x11-libs/qt-${x}; then 100 if ! has_version x11-libs/qt-${x}; then
101 eerror "You must first install the x11-libs/qt-${x} package." 101 eerror "You must first install the x11-libs/qt-${x} package."
102 die 102 die "Install x11-libs/qt-${x}"
103 fi 103 fi
104 elif [ ${x} == ssl ]; then 104 elif [[ ${x} == ssl ]]; then
105 if [ ! has_version x11-libs/qt-core || ! built_with_use x11-libs/qt-core ssl ]; then 105 if ! has_version x11-libs/qt-core || ! built_with_use x11-libs/qt-core ssl; then
106 eerror "You must first install the x11-libs/qt-core package with the ssl flag enabled." 106 eerror "You must first install the x11-libs/qt-core package with the ssl flag enabled."
107 die 107 die "Install x1-libs/qt-core with USE=\"ssl\""
108 fi 108 fi
109 elif [ ${x} == sqlite3 ]; then 109 elif [[ ${x} == sqlite3 ]]; then
110 if [ ! has_version x11-libs/qt-sql || ! built_with_use x11-libs/qt-sql sqlite ]; then 110 if ! has_version x11-libs/qt-sql || ! built_with_use x11-libs/qt-sql sqlite; then
111 eerror "You must first install the x11-libs/qt-sql package with the sqlite flag enabled." 111 eerror "You must first install the x11-libs/qt-sql package with the sqlite flag enabled."
112 die 112 die "Install x11-libs/qt-sql with USE="\sqlite\""
113 fi 113 fi
114 fi 114 fi
115 elif ! built_with_use =x11-libs/qt-4* ${x}; then 115 elif ! built_with_use =x11-libs/qt-4* ${x}; then
116 requiredflags="${requiredflags} ${x}" 116 requiredflags="${requiredflags} ${x}"
117 fi 117 fi

Legend:
Removed from v.1.31  
changed lines
  Added in v.1.32

  ViewVC Help
Powered by ViewVC 1.1.20