/[gentoo-x86]/eclass/qt4.eclass
Gentoo

Diff of /eclass/qt4.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.32 Revision 1.44
1# Copyright 2005 Gentoo Foundation 1# Copyright 2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/qt4.eclass,v 1.32 2008/01/05 18:44:38 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/qt4.eclass,v 1.44 2008/07/17 00:03:33 zlin Exp $
4 4
5# @ECLASS: qt4.eclass 5# @ECLASS: qt4.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Caleb Tennis <caleb@gentoo.org> 7# Caleb Tennis <caleb@gentoo.org>
8# @BLURB:
9# Eclass for Qt4 packages 8# @BLURB: Eclass for Qt4 packages
10# @DESCRIPTION: 9# @DESCRIPTION:
11# This eclass contains various functions that may be useful 10# This eclass contains various functions that may be useful
12# when dealing with packages using Qt4 libraries. 11# when dealing with packages using Qt4 libraries.
13 12
14# 08.16.06 - Renamed qt_min_* to qt4_min_* to avoid conflicts with the qt3 eclass. 13# 08.16.06 - Renamed qt_min_* to qt4_min_* to avoid conflicts with the qt3 eclass.
16 15
17inherit eutils multilib toolchain-funcs versionator 16inherit eutils multilib toolchain-funcs versionator
18 17
19QTPKG="x11-libs/qt-" 18QTPKG="x11-libs/qt-"
20QT4MAJORVERSIONS="4.4 4.3 4.2 4.1 4.0" 19QT4MAJORVERSIONS="4.4 4.3 4.2 4.1 4.0"
21QT4VERSIONS="4.4.0_rc1 4.3.3 4.3.2-r1 4.3.2 4.3.1-r1 4.3.1 4.3.0-r2 4.3.0-r1 4.3.0 4.3.0_rc1 4.3.0_beta1 4.2.3-r1 4.2.3 4.2.2 4.2.1 4.2.0-r2 4.2.0-r1 4.2.0 4.1.4-r2 4.1.4-r1 4.1.4 4.1.3 4.1.2 4.1.1 4.1.0 4.0.1 4.0.0" 20QT4VERSIONS="4.4.0 4.4.0_beta1 4.4.0_rc1
21 4.3.4-r1 4.3.4 4.3.3 4.3.2-r1 4.3.2 4.3.1-r1 4.3.1
22 4.3.0-r2 4.3.0-r1 4.3.0 4.3.0_rc1 4.3.0_beta1
23 4.2.3-r1 4.2.3 4.2.2 4.2.1 4.2.0-r2 4.2.0-r1 4.2.0
24 4.1.4-r2 4.1.4-r1 4.1.4 4.1.3 4.1.2 4.1.1 4.1.0
25 4.0.1 4.0.0"
22 26
23# @FUNCTION: qt4_min_version 27# @FUNCTION: qt4_min_version
24# @USAGE: [minimum version] 28# @USAGE: [minimum version]
25# @DESCRIPTION: 29# @DESCRIPTION:
26# This function should be called in package DEPENDs whenever it depends on qt4. 30# This function should be called in package DEPENDs whenever it depends on qt4.
27# Simple example - in your depend, do something like this: 31# Simple example - in your depend, do something like this:
28# DEPEND="$(qt4_min_version 4.2)" 32# DEPEND="$(qt4_min_version 4.2)"
29# if package can be build with qt-4.2 or higher. 33# if the package can be build with qt-4.2 or higher.
34#
35# For builds that use an EAPI with support for SLOT dependencies, this will
36# return a SLOT dependency, rather than a list of versions.
30qt4_min_version() { 37qt4_min_version() {
31 # This is much simpler for EAPI 1, we can use a slot dependency 38 case ${EAPI:-0} in
32 if [[ "${EAPI}" -ge 1 ]]; then 39 # EAPIs without SLOT dependencies
33 echo ">=${QTPKG}${1}:4"
34 else
35 echo "|| (" 40 0) echo "|| ("
36 qt4_min_version_list "$@" 41 qt4_min_version_list "$@"
37 echo ")" 42 echo ")"
38 fi 43 ;;
44 # EAPIS with SLOT dependencies.
45 *) echo ">=${QTPKG}${1}:4"
46 ;;
47 esac
39} 48}
40 49
41qt4_min_version_list() { 50qt4_min_version_list() {
42 local MINVER="$1" 51 local MINVER="$1"
43 local VERSIONS="" 52 local VERSIONS=""
44 53
45 case "${MINVER}" in 54 case "${MINVER}" in
46 4|4.0|4.0.0) VERSIONS="=${QTPKG}4*";; 55 4|4.0|4.0.0) VERSIONS="=${QTPKG}4*";;
47 4.1|4.1.0|4.2|4.2.0|4.3|4.3.0|4.4|4.4.0) 56 4.1|4.1.0|4.2|4.2.0|4.3|4.3.0|4.4|4.4.0)
48 for x in ${QT4MAJORVERSIONS}; do 57 for x in ${QT4MAJORVERSIONS}; do
49 if $(version_is_at_least "${MINVER}" "${x}"); then 58 if version_is_at_least "${MINVER}" "${x}"; then
50 VERSIONS="${VERSIONS} =${QTPKG}${x}*" 59 VERSIONS="${VERSIONS} =${QTPKG}${x}*"
51 fi 60 fi
52 done 61 done
53 ;; 62 ;;
54 4*) 63 4*)
55 for x in ${QT4VERSIONS}; do 64 for x in ${QT4VERSIONS}; do
56 if $(version_is_at_least "${MINVER}" "${x}"); then 65 if version_is_at_least "${MINVER}" "${x}"; then
57 VERSIONS="${VERSIONS} =${QTPKG}${x}" 66 VERSIONS="${VERSIONS} =${QTPKG}${x}"
58 fi 67 fi
59 done 68 done
60 ;; 69 ;;
61 *) VERSIONS="=${QTPKG}4*";; 70 *) VERSIONS="=${QTPKG}4*";;
62 esac 71 esac
63 72
64 echo "${VERSIONS}" 73 echo "${VERSIONS}"
74}
75
76qt4_monolithic_to_split_flag() {
77 case ${1} in
78 zlib)
79 # Qt 4.4+ is always built with zlib enabled, so this flag isn't needed
80 ;;
81 gif|jpeg|png)
82 # qt-gui always installs with these enabled
83 checkpkgs+=" x11-libs/qt-gui"
84 ;;
85 dbus|opengl)
86 # Make sure the qt-${1} package has been installed already
87 checkpkgs+=" x11-libs/qt-${1}"
88 ;;
89 qt3support)
90 checkpkgs+=" x11-libs/qt-${1}"
91 checkflags+=" x11-libs/qt-core:${1} x11-libs/qt-gui:${1} x11-libs/qt-sql:${1}"
92 ;;
93 ssl)
94 # qt-core controls this flag
95 checkflags+=" x11-libs/qt-core:${1}"
96 ;;
97 cups|mng|nas|nis|tiff|xinerama|input_devices_wacom)
98 # qt-gui controls these flags
99 checkflags+=" x11-libs/qt-gui:${1}"
100 ;;
101 firebird|mysql|odbc|postgres|sqlite3)
102 # qt-sql controls these flags. sqlite2 is no longer supported so it uses sqlite instead of sqlite3.
103 checkflags+=" x11-libs/qt-sql:${1%3}"
104 ;;
105 accessibility)
106 eerror "(QA message): Use guiaccessibility and/or qt3accessibility to specify which of qt-gui and qt-qt3support are relevant for this package."
107 # deal with this gracefully by checking the flag for what is available
108 for y in gui qt3support; do
109 has_version x11-libs/qt-${y} && checkflags+=" x11-libs/qt-${y}:${1}"
110 done
111 ;;
112 guiaccessibility)
113 checkflags+=" x11-libs/qt-gui:accessibility"
114 ;;
115 qt3accessibility)
116 checkflags+=" x11-libs/qt-qt3support:accessibility"
117 ;;
118 debug|doc|examples|glib|pch|sqlite|*)
119 # packages probably shouldn't be checking these flags so we don't handle them currently
120 eerror "qt4.eclass currently doesn't handle the use flag ${1} in QT4_BUILT_WITH_USE_CHECK for qt-4.4. This is either an"
121 eerror "eclass bug or an ebuild bug. Please report it at http://bugs.gentoo.org/"
122 ((fatalerrors+=1))
123 ;;
124 esac
65} 125}
66 126
67# @FUNCTION: qt4_pkg_setup 127# @FUNCTION: qt4_pkg_setup
68# @MAINTAINER: 128# @MAINTAINER:
69# Caleb Tennis <caleb@gentoo.org> 129# Caleb Tennis <caleb@gentoo.org>
79# (so qt4 don't have to be recompiled) 139# (so qt4 don't have to be recompiled)
80# 140#
81# flags to watch for for Qt4.4: 141# flags to watch for for Qt4.4:
82# zlib png | opengl dbus qt3support | sqlite3 ssl 142# zlib png | opengl dbus qt3support | sqlite3 ssl
83qt4_pkg_setup() { 143qt4_pkg_setup() {
144 local x y checkpkgs checkflags fatalerrors=0 requiredflags=""
84 145
85 QT4_BEST_VERSION="$(best_version =x11-libs/qt-4*)" 146 # lots of has_version calls can be very expensive
86 QT4_MINOR_VERSION="$(get_version_component_range 2 ${QT4_BEST_VERSION/*qt-/})" 147 if [[ -n ${QT4_BUILT_WITH_USE_CHECK}${QT4_OPTIONAL_BUILT_WITH_USE_CHECK} ]]; then
148 has_version x11-libs/qt-core && local QT44=true
149 fi
87 150
88 local requiredflags=""
89 for x in ${QT4_BUILT_WITH_USE_CHECK}; do 151 for x in ${QT4_BUILT_WITH_USE_CHECK}; do
90 if [[ "${QT4_MINOR_VERSION}" -ge 4 ]]; then 152 if [[ -n ${QT44} ]]; then
91 # The use flags are different in 4.4 and above, and it's a split package, so this is used to catch 153 # The use flags are different in 4.4 and above, and it's split packages, so this is used to catch
92 # the various use flag combos specified in the ebuilds to make sure we don't error out. 154 # the various use flag combos specified in the ebuilds to make sure we don't error out for no reason.
93 155 qt4_monolithic_to_split_flag ${x}
94 if [[ ${x} == zlib || ${x} == png ]]; then 156 else
95 # Qt 4.4+ is built with zlib and png by default, so the use flags aren't needed 157 [[ ${x} == *accessibility ]] && x=${x#gui} && x=${x#qt3}
96 continue; 158 if ! built_with_use =x11-libs/qt-4* ${x}; then
97 elif [[ ${x} == opengl || ${x} == dbus || ${x} == qt3support ]]; then 159 requiredflags="${requiredflags} ${x}"
98 # Make sure the qt-${x} package has been already installed
99
100 if ! has_version x11-libs/qt-${x}; then
101 eerror "You must first install the x11-libs/qt-${x} package."
102 die "Install x11-libs/qt-${x}"
103 fi
104 elif [[ ${x} == ssl ]]; then
105 if ! has_version x11-libs/qt-core || ! built_with_use x11-libs/qt-core ssl; then
106 eerror "You must first install the x11-libs/qt-core package with the ssl flag enabled."
107 die "Install x1-libs/qt-core with USE=\"ssl\""
108 fi
109 elif [[ ${x} == sqlite3 ]]; then
110 if ! has_version x11-libs/qt-sql || ! built_with_use x11-libs/qt-sql sqlite; then
111 eerror "You must first install the x11-libs/qt-sql package with the sqlite flag enabled."
112 die "Install x11-libs/qt-sql with USE="\sqlite\""
113 fi
114 fi 160 fi
115 elif ! built_with_use =x11-libs/qt-4* ${x}; then
116 requiredflags="${requiredflags} ${x}"
117 fi 161 fi
118 done 162 done
119 163
120 local optionalflags="" 164 local optionalflags=""
121 for x in ${QT4_OPTIONAL_BUILT_WITH_USE_CHECK}; do 165 for x in ${QT4_OPTIONAL_BUILT_WITH_USE_CHECK}; do
166 if use ${x}; then
167 if [[ -n ${QT44} ]]; then
168 # The use flags are different in 4.4 and above, and it's split packages, so this is used to catch
169 # the various use flag combos specified in the ebuilds to make sure we don't error out for no reason.
170 qt4_monolithic_to_split_flag ${x}
122 if use ${x} && ! built_with_use =x11-libs/qt-4* ${x}; then 171 elif ! built_with_use =x11-libs/qt-4* ${x}; then
123 optionalflags="${optionalflags} ${x}" 172 optionalflags="${optionalflags} ${x}"
173 fi
174 fi
175 done
176
177 # The use flags are different in 4.4 and above, and it's split packages, so this is used to catch
178 # the various use flag combos specified in the ebuilds to make sure we don't error out for no reason.
179 for y in ${checkpkgs}; do
180 if ! has_version ${y}; then
181 eerror "You must first install the ${y} package. It should be added to the dependencies for this package (${CATEGORY}/${PN}). See bug #217161."
182 ((fatalerrors+=1))
183 fi
184 done
185 for y in ${checkflags}; do
186 if ! has_version ${y%:*}; then
187 eerror "You must first install the ${y%:*} package with the ${y##*:} flag enabled."
188 eerror "It should be added to the dependencies for this package (${CATEGORY}/${PN}). See bug #217161."
189 ((fatalerrors+=1))
190 else
191 if ! built_with_use ${y%:*} ${y##*:}; then
192 eerror "You must first install the ${y%:*} package with the ${y##*:} flag enabled."
193 ((fatalerrors+=1))
194 fi
124 fi 195 fi
125 done 196 done
126 197
127 local diemessage="" 198 local diemessage=""
199 if [[ ${fatalerrors} -ne 0 ]]; then
200 diemessage="${fatalerrors} fatal errors were detected. Please read the above error messages and act accordingly."
201 fi
128 if [[ ${requiredflags} != "" ]]; then 202 if [[ -n ${requiredflags} ]]; then
129 eerror 203 eerror
130 eerror "(1) In order to compile ${CATEGORY}/${PN} first you need to build" 204 eerror "(1) In order to compile ${CATEGORY}/${PN} first you need to build"
131 eerror "=x11-libs/qt-4* with USE=\"${requiredflags}\" flag(s)" 205 eerror "=x11-libs/qt-4* with USE=\"${requiredflags}\" flag(s)"
132 eerror 206 eerror
133 diemessage="(1) recompile qt4 with \"${requiredflags}\" USE flag(s) ; " 207 diemessage="(1) recompile qt4 with \"${requiredflags}\" USE flag(s) ; "
134 fi 208 fi
135 if [[ ${optionalflags} != "" ]]; then 209 if [[ -n ${optionalflags} ]]; then
136 eerror 210 eerror
137 eerror "(2) You are trying to compile ${CATEGORY}/${PN} package with" 211 eerror "(2) You are trying to compile ${CATEGORY}/${PN} package with"
138 eerror "USE=\"${optionalflags}\"" 212 eerror "USE=\"${optionalflags}\""
139 eerror "while qt4 is built without this particular flag(s): it will" 213 eerror "while qt4 is built without this particular flag(s): it will"
140 eerror "not work." 214 eerror "not work."
144 eerror "b) re-emerge qt4 with \"${optionalflags}\" USE flag(s)" 218 eerror "b) re-emerge qt4 with \"${optionalflags}\" USE flag(s)"
145 eerror 219 eerror
146 diemessage="${diemessage}(2) recompile qt4 with \"${optionalflags}\" USE flag(s) or disable them for ${PN} package\n" 220 diemessage="${diemessage}(2) recompile qt4 with \"${optionalflags}\" USE flag(s) or disable them for ${PN} package\n"
147 fi 221 fi
148 222
149 [[ ${diemessage} != "" ]] && die "can't emerge ${CATEGORY}/${PN}: ${diemessage}" 223 [[ -n ${diemessage} ]] && die "can't install ${CATEGORY}/${PN}: ${diemessage}"
150} 224}
151 225
152# @FUNCTION: eqmake4 226# @FUNCTION: eqmake4
153# @USAGE: [.pro file] [additional parameters to qmake] 227# @USAGE: [.pro file] [additional parameters to qmake]
154# @MAINTAINER: 228# @MAINTAINER:
199 QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \ 273 QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
200 QMAKE_CXXFLAGS_DEBUG="${CXXFLAGS}" \ 274 QMAKE_CXXFLAGS_DEBUG="${CXXFLAGS}" \
201 QMAKE_LFLAGS_RELEASE="${LDFLAGS}" \ 275 QMAKE_LFLAGS_RELEASE="${LDFLAGS}" \
202 QMAKE_LFLAGS_DEBUG="${LDFLAGS}" \ 276 QMAKE_LFLAGS_DEBUG="${LDFLAGS}" \
203 QMAKE_RPATH= \ 277 QMAKE_RPATH= \
204 ${@} >> ${LOGFILE} 2>&1 278 "${@}" >> ${LOGFILE} 2>&1
205 279
206 local result=$? 280 local result=$?
207 eend ${result} 281 eend ${result}
208 282
209 # was qmake successful? 283 # was qmake successful?

Legend:
Removed from v.1.32  
changed lines
  Added in v.1.44

  ViewVC Help
Powered by ViewVC 1.1.20