/[gentoo-x86]/eclass/qt4.eclass
Gentoo

Contents of /eclass/qt4.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Sat Oct 21 09:56:28 2006 UTC (7 years, 9 months ago) by flameeyes
Branch: MAIN
Changes since 1.5: +4 -4 lines
Add support for Qt 4.2.0 as masked psi does.

1 # Copyright 2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/qt4.eclass,v 1.5 2006/10/21 09:53:15 flameeyes Exp $
4 #
5 # Author Caleb Tennis <caleb@gentoo.org>
6 #
7 # This eclass is simple. Inherit it, and in your depend, do something like this:
8 #
9 # DEPEND="$(qt_min_version 4)"
10 #
11 # and it handles the rest for you
12 #
13 # 08.16.06 - Renamed qt_min_* to qt4_min_* to avoid conflicts with the qt3 eclass.
14 # - Caleb Tennis <caleb@gentoo.org>
15
16 inherit versionator
17
18 QTPKG="x11-libs/qt-"
19 QT4MAJORVERSIONS="4.2 4.1 4.0"
20 QT4VERSIONS="4.2.0-r2 4.2.0-r1 4.2.0 4.1.4-r2 4.1.4-r2 4.1.4 4.1.3 4.1.2 4.1.1 4.1.0 4.0.1 4.0.0"
21
22 qt4_min_version() {
23 echo "|| ("
24 qt4_min_version_list "$@"
25 echo ")"
26 }
27
28 qt4_min_version_list() {
29 local MINVER="$1"
30 local VERSIONS=""
31
32 case "${MINVER}" in
33 4|4.0|4.0.0) VERSIONS="=${QTPKG}4*";;
34 4.1|4.1.0|4.2|4.2.0)
35 for x in ${QT4MAJORVERSIONS}; do
36 if $(version_is_at_least "${MINVER}" "${x}"); then
37 VERSIONS="${VERSIONS} =${QTPKG}${x}*"
38 fi
39 done
40 ;;
41 4*)
42 for x in ${QT4VERSIONS}; do
43 if $(version_is_at_least "${MINVER}" "${x}"); then
44 VERSIONS="${VERSIONS} =${QTPKG}${x}"
45 fi
46 done
47 ;;
48 *) VERSIONS="=${QTPKG}4*";;
49 esac
50
51 echo "${VERSIONS}"
52 }

  ViewVC Help
Powered by ViewVC 1.1.20