/[gentoo-x86]/eclass/ruby-ng.eclass
Gentoo

Diff of /eclass/ruby-ng.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.44 Revision 1.45
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/ruby-ng.eclass,v 1.44 2011/12/18 21:33:50 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/ruby-ng.eclass,v 1.45 2012/02/23 23:06:13 a3li Exp $
4 4
5# @ECLASS: ruby-ng.eclass 5# @ECLASS: ruby-ng.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Ruby herd <ruby@gentoo.org> 7# Ruby herd <ruby@gentoo.org>
8# @AUTHOR: 8# @AUTHOR:
382 fi 382 fi
383 383
384 unset RUBY 384 unset RUBY
385 done 385 done
386 386
387 [[ ${invoked} == "no" ]] && die "You need to select at least one Ruby implementation by setting RUBY_TARGETS in /etc/make.conf." 387 if [[ ${invoked} == "no" ]]; then
388 eerror "You need to select at least one compatible Ruby installation target via RUBY_TARGETS in make.conf."
389 eerror "Compatible targets for this package are: ${USE_RUBY}"
390 eerror
391 eerror "See http://www.gentoo.org/proj/en/prog_lang/ruby/index.xml#doc_chap3 for more information."
392 eerror
393 die "No compatible Ruby target selected."
394 fi
388} 395}
389 396
390# @FUNCTION: ruby-ng_pkg_setup 397# @FUNCTION: ruby-ng_pkg_setup
391# @DESCRIPTION: 398# @DESCRIPTION:
392# Check whether at least one ruby target implementation is present. 399# Check whether at least one ruby target implementation is present.

Legend:
Removed from v.1.44  
changed lines
  Added in v.1.45

  ViewVC Help
Powered by ViewVC 1.1.20