/[gentoo-x86]/eclass/vdr-plugin.eclass
Gentoo

Diff of /eclass/vdr-plugin.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.65 Revision 1.69
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/vdr-plugin.eclass,v 1.65 2008/07/03 11:18:13 zzam Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/vdr-plugin.eclass,v 1.69 2009/03/24 21:10:13 zzam Exp $
4# 4#
5# Author: 5# Author:
6# Matthias Schwarzott <zzam@gentoo.org> 6# Matthias Schwarzott <zzam@gentoo.org>
7# Joerg Bornkessel <hd_brummy@gentoo.org> 7# Joerg Bornkessel <hd_brummy@gentoo.org>
8 8
77 77
78DEPEND="${COMMON_DEPEND} 78DEPEND="${COMMON_DEPEND}
79 media-tv/linuxtv-dvb-headers" 79 media-tv/linuxtv-dvb-headers"
80RDEPEND="${COMMON_DEPEND} 80RDEPEND="${COMMON_DEPEND}
81 >=app-admin/eselect-vdr-0.0.2" 81 >=app-admin/eselect-vdr-0.0.2"
82
83# this is a hack for ebuilds like vdr-xineliboutput that want to
84# conditionally install a vdr-plugin
85if [[ "${GENTOO_VDR_CONDITIONAL:-no}" = "yes" ]]; then
86 # make DEPEND conditional
87 IUSE="${IUSE} vdr"
88 DEPEND="vdr? ( ${DEPEND} )"
89 RDEPEND="vdr? ( ${RDEPEND} )"
90fi
82 91
83# New method of storing plugindb 92# New method of storing plugindb
84# Called from src_install 93# Called from src_install
85# file maintained by normal portage-methods 94# file maintained by normal portage-methods
86create_plugindb_file() { 95create_plugindb_file() {
355 elog "To activate a plugin execute this command:" 364 elog "To activate a plugin execute this command:"
356 elog "\teselect vdr-plugin enable <plugin_name> ..." 365 elog "\teselect vdr-plugin enable <plugin_name> ..."
357 elog 366 elog
358} 367}
359 368
369has_vdr() {
370 [[ -f "${VDR_INCLUDE_DIR}"/config.h ]]
371}
360 372
361## exported functions 373## exported functions
362 374
363vdr-plugin_pkg_setup() { 375vdr-plugin_pkg_setup() {
364 # -fPIC is needed for shared objects on some platforms (amd64 and others) 376 # -fPIC is needed for shared objects on some platforms (amd64 and others)
377 DVB_INCLUDE_DIR="/usr/include" 389 DVB_INCLUDE_DIR="/usr/include"
378 390
379 TMP_LOCALE_DIR="${WORKDIR}/tmp-locale" 391 TMP_LOCALE_DIR="${WORKDIR}/tmp-locale"
380 LOCDIR="/usr/share/vdr/locale" 392 LOCDIR="/usr/share/vdr/locale"
381 393
394 if ! has_vdr; then
395 # set to invalid values to detect abuses
396 VDRVERSION="eclass_no_vdr_installed"
397 APIVERSION="eclass_no_vdr_installed"
398
399 if [[ "${GENTOO_VDR_CONDITIONAL:-no}" = "yes" ]] && ! use vdr; then
400 einfo "VDR not found!"
401 else
402 # if vdr is required
403 die "VDR not found!"
404 fi
405 return
406 fi
407
382 VDRVERSION=$(awk -F'"' '/define VDRVERSION/ {print $2}' "${VDR_INCLUDE_DIR}"/config.h) 408 VDRVERSION=$(awk -F'"' '/define VDRVERSION/ {print $2}' "${VDR_INCLUDE_DIR}"/config.h)
383 APIVERSION=$(awk -F'"' '/define APIVERSION/ {print $2}' "${VDR_INCLUDE_DIR}"/config.h) 409 APIVERSION=$(awk -F'"' '/define APIVERSION/ {print $2}' "${VDR_INCLUDE_DIR}"/config.h)
384 [[ -z ${APIVERSION} ]] && APIVERSION="${VDRVERSION}" 410 [[ -z ${APIVERSION} ]] && APIVERSION="${VDRVERSION}"
385 411
386 einfo "Compiling against" 412 einfo "Compiling against"
387 einfo "\tvdr-${VDRVERSION} [API version ${APIVERSION}]" 413 einfo "\tvdr-${VDRVERSION} [API version ${APIVERSION}]"
414}
415
416vdr-plugin_src_util() {
417
418 while [ "$1" ]; do
419
420 case "$1" in
421 all)
422 vdr-plugin_src_util unpack add_local_patch patchmakefile i18n
423 ;;
424 prepare|all_but_unpack)
425 vdr-plugin_src_util add_local_patch patchmakefile i18n
426 ;;
427 unpack)
428 base_src_unpack
429 ;;
430 add_local_patch)
431 cd "${S}" || die "Could not change to plugin-source-directory!"
432 vdr_add_local_patch
433 ;;
434 patchmakefile)
435 cd "${S}" || die "Could not change to plugin-source-directory!"
436 vdr_patchmakefile
437 ;;
438 i18n)
439 cd "${S}" || die "Could not change to plugin-source-directory!"
440 vdr_i18n
441 ;;
442 esac
443
444 shift
445 done
388} 446}
389 447
390vdr-plugin_src_unpack() { 448vdr-plugin_src_unpack() {
391 if [[ -z ${VDR_INCLUDE_DIR} ]]; then 449 if [[ -z ${VDR_INCLUDE_DIR} ]]; then
392 eerror "Wrong use of vdr-plugin.eclass." 450 eerror "Wrong use of vdr-plugin.eclass."
393 eerror "An ebuild for a vdr-plugin will not work without calling vdr-plugin_pkg_setup." 451 eerror "An ebuild for a vdr-plugin will not work without calling vdr-plugin_pkg_setup."
394 echo 452 echo
395 eerror "Please report this at bugs.gentoo.org." 453 eerror "Please report this at bugs.gentoo.org."
396 die "vdr-plugin_pkg_setup not called!" 454 die "vdr-plugin_pkg_setup not called!"
397 fi 455 fi
398 [ -z "$1" ] && vdr-plugin_src_unpack unpack add_local_patch patchmakefile i18n 456 if [ -z "$1" ]; then
457 case "${EAPI:-0}" in
458 2)
459 vdr-plugin_src_util unpack
460 ;;
461 *)
462 vdr-plugin_src_util all
463 ;;
464 esac
465
466 else
467 vdr-plugin_src_util $@
468 fi
469}
470
471vdr-plugin_src_prepare() {
472 base_src_prepare
473 vdr-plugin_src_util prepare
474}
475
476vdr-plugin_src_compile() {
477 [ -z "$1" ] && vdr-plugin_src_compile copy_source compile
399 478
400 while [ "$1" ]; do 479 while [ "$1" ]; do
401 480
402 case "$1" in 481 case "$1" in
403 all_but_unpack) 482 copy_source)
404 vdr-plugin_src_unpack add_local_patch patchmakefile i18n
405 ;;
406 unpack)
407 base_src_unpack
408 ;;
409 add_local_patch)
410 cd "${S}" || die "Could not change to plugin-source-directory!"
411 vdr_add_local_patch
412 ;;
413 patchmakefile)
414 cd "${S}" || die "Could not change to plugin-source-directory!"
415 vdr_patchmakefile
416 ;;
417 i18n)
418 cd "${S}" || die "Could not change to plugin-source-directory!"
419 vdr_i18n
420 ;;
421 esac
422
423 shift
424 done
425}
426
427vdr-plugin_src_compile() {
428 [ -z "$1" ] && vdr-plugin_src_compile prepare compile
429
430 while [ "$1" ]; do
431
432 case "$1" in
433 prepare)
434 [[ -n "${VDRSOURCE_DIR}" ]] && vdr-plugin_copy_source_tree 483 [[ -n "${VDRSOURCE_DIR}" ]] && vdr-plugin_copy_source_tree
435 ;; 484 ;;
436 compile) 485 compile)
437 if [[ ! -f ${WORKDIR}/.vdr-plugin_makefile_patched ]]; then 486 if [[ ! -f ${WORKDIR}/.vdr-plugin_makefile_patched ]]; then
438 eerror "Wrong use of vdr-plugin.eclass." 487 eerror "Wrong use of vdr-plugin.eclass."
546vdr-plugin_pkg_config() { 595vdr-plugin_pkg_config() {
547 ewarn "emerge --config ${PN} is no longer supported" 596 ewarn "emerge --config ${PN} is no longer supported"
548 vdr-plugin_print_enable_command 597 vdr-plugin_print_enable_command
549} 598}
550 599
600case "${EAPI:-0}" in
601 2)
602 EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_compile src_install pkg_postinst pkg_postrm pkg_config
603 ;;
604 *)
551EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst pkg_postrm pkg_config 605 EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst pkg_postrm pkg_config
606 ;;
607esac

Legend:
Removed from v.1.65  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20