/[gentoo-x86]/eclass/vdr-plugin.eclass
Gentoo

Diff of /eclass/vdr-plugin.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.64 Revision 1.68
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/vdr-plugin.eclass,v 1.64 2008/06/25 21:35:27 zzam Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/vdr-plugin.eclass,v 1.68 2009/03/06 09:09:29 zzam Exp $
4# 4#
5# Author: 5# Author:
6# Matthias Schwarzott <zzam@gentoo.org> 6# Matthias Schwarzott <zzam@gentoo.org>
7# Joerg Bornkessel <hd_brummy@gentoo.org> 7# Joerg Bornkessel <hd_brummy@gentoo.org>
8 8
71 71
72# works in most cases 72# works in most cases
73S="${WORKDIR}/${VDRPLUGIN}-${PV}" 73S="${WORKDIR}/${VDRPLUGIN}-${PV}"
74 74
75# depend on headers for DVB-driver 75# depend on headers for DVB-driver
76DEPEND=">=media-tv/gentoo-vdr-scripts-0.3.8 76COMMON_DEPEND=">=media-tv/gentoo-vdr-scripts-0.4.2"
77 || ( >=media-tv/gentoo-vdr-scripts-0.4.2 >=media-tv/vdrplugin-rebuild-0.2 ) 77
78 >=app-admin/eselect-vdr-0.0.2 78DEPEND="${COMMON_DEPEND}
79 media-tv/linuxtv-dvb-headers" 79 media-tv/linuxtv-dvb-headers"
80 80RDEPEND="${COMMON_DEPEND}
81 >=app-admin/eselect-vdr-0.0.2"
81 82
82# New method of storing plugindb 83# New method of storing plugindb
83# Called from src_install 84# Called from src_install
84# file maintained by normal portage-methods 85# file maintained by normal portage-methods
85create_plugindb_file() { 86create_plugindb_file() {
384 385
385 einfo "Compiling against" 386 einfo "Compiling against"
386 einfo "\tvdr-${VDRVERSION} [API version ${APIVERSION}]" 387 einfo "\tvdr-${VDRVERSION} [API version ${APIVERSION}]"
387} 388}
388 389
390vdr-plugin_src_util() {
391
392 while [ "$1" ]; do
393
394 case "$1" in
395 all)
396 vdr-plugin_src_util unpack add_local_patch patchmakefile i18n
397 ;;
398 prepare|all_but_unpack)
399 vdr-plugin_src_util add_local_patch patchmakefile i18n
400 ;;
401 unpack)
402 base_src_unpack
403 ;;
404 add_local_patch)
405 cd "${S}" || die "Could not change to plugin-source-directory!"
406 vdr_add_local_patch
407 ;;
408 patchmakefile)
409 cd "${S}" || die "Could not change to plugin-source-directory!"
410 vdr_patchmakefile
411 ;;
412 i18n)
413 cd "${S}" || die "Could not change to plugin-source-directory!"
414 vdr_i18n
415 ;;
416 esac
417
418 shift
419 done
420}
421
389vdr-plugin_src_unpack() { 422vdr-plugin_src_unpack() {
390 if [[ -z ${VDR_INCLUDE_DIR} ]]; then 423 if [[ -z ${VDR_INCLUDE_DIR} ]]; then
391 eerror "Wrong use of vdr-plugin.eclass." 424 eerror "Wrong use of vdr-plugin.eclass."
392 eerror "An ebuild for a vdr-plugin will not work without calling vdr-plugin_pkg_setup." 425 eerror "An ebuild for a vdr-plugin will not work without calling vdr-plugin_pkg_setup."
393 echo 426 echo
394 eerror "Please report this at bugs.gentoo.org." 427 eerror "Please report this at bugs.gentoo.org."
395 die "vdr-plugin_pkg_setup not called!" 428 die "vdr-plugin_pkg_setup not called!"
396 fi 429 fi
397 [ -z "$1" ] && vdr-plugin_src_unpack unpack add_local_patch patchmakefile i18n 430 if [ -z "$1" ]; then
431 case "${EAPI:-0}" in
432 2)
433 vdr-plugin_src_util unpack
434 ;;
435 *)
436 vdr-plugin_src_util all
437 ;;
438 esac
439
440 else
441 vdr-plugin_src_util $@
442 fi
443}
444
445vdr-plugin_src_prepare() {
446 base_src_prepare
447 vdr-plugin_src_util prepare
448}
449
450vdr-plugin_src_compile() {
451 [ -z "$1" ] && vdr-plugin_src_compile copy_source compile
398 452
399 while [ "$1" ]; do 453 while [ "$1" ]; do
400 454
401 case "$1" in 455 case "$1" in
402 all_but_unpack) 456 copy_source)
403 vdr-plugin_src_unpack add_local_patch patchmakefile i18n
404 ;;
405 unpack)
406 base_src_unpack
407 ;;
408 add_local_patch)
409 cd "${S}" || die "Could not change to plugin-source-directory!"
410 vdr_add_local_patch
411 ;;
412 patchmakefile)
413 cd "${S}" || die "Could not change to plugin-source-directory!"
414 vdr_patchmakefile
415 ;;
416 i18n)
417 cd "${S}" || die "Could not change to plugin-source-directory!"
418 vdr_i18n
419 ;;
420 esac
421
422 shift
423 done
424}
425
426vdr-plugin_src_compile() {
427 [ -z "$1" ] && vdr-plugin_src_compile prepare compile
428
429 while [ "$1" ]; do
430
431 case "$1" in
432 prepare)
433 [[ -n "${VDRSOURCE_DIR}" ]] && vdr-plugin_copy_source_tree 457 [[ -n "${VDRSOURCE_DIR}" ]] && vdr-plugin_copy_source_tree
434 ;; 458 ;;
435 compile) 459 compile)
436 if [[ ! -f ${WORKDIR}/.vdr-plugin_makefile_patched ]]; then 460 if [[ ! -f ${WORKDIR}/.vdr-plugin_makefile_patched ]]; then
437 eerror "Wrong use of vdr-plugin.eclass." 461 eerror "Wrong use of vdr-plugin.eclass."
441 eerror "Please report this at bugs.gentoo.org." 465 eerror "Please report this at bugs.gentoo.org."
442 die "vdr-plugin_src_unpack not called!" 466 die "vdr-plugin_src_unpack not called!"
443 fi 467 fi
444 cd "${S}" 468 cd "${S}"
445 469
470 BUILD_TARGETS=${BUILD_TARGETS:-${VDRPLUGIN_MAKE_TARGET:-all}}
471
446 emake ${BUILD_PARAMS} \ 472 emake ${BUILD_PARAMS} \
447 ${VDRPLUGIN_MAKE_TARGET:-all} \ 473 ${BUILD_TARGETS} \
448 LOCALEDIR="${TMP_LOCALE_DIR}" \ 474 LOCALEDIR="${TMP_LOCALE_DIR}" \
449 LIBDIR="${S}" \ 475 LIBDIR="${S}" \
450 TMPDIR="${T}" \ 476 TMPDIR="${T}" \
451 || die "emake failed" 477 || die "emake failed"
452 ;; 478 ;;
543vdr-plugin_pkg_config() { 569vdr-plugin_pkg_config() {
544 ewarn "emerge --config ${PN} is no longer supported" 570 ewarn "emerge --config ${PN} is no longer supported"
545 vdr-plugin_print_enable_command 571 vdr-plugin_print_enable_command
546} 572}
547 573
574case "${EAPI:-0}" in
575 2)
576 EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_compile src_install pkg_postinst pkg_postrm pkg_config
577 ;;
578 *)
548EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst pkg_postrm pkg_config 579 EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst pkg_postrm pkg_config
580 ;;
581esac

Legend:
Removed from v.1.64  
changed lines
  Added in v.1.68

  ViewVC Help
Powered by ViewVC 1.1.20