/[gentoo-x86]/eclass/wxwidgets.eclass
Gentoo

Diff of /eclass/wxwidgets.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.22 Revision 1.23
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/wxwidgets.eclass,v 1.22 2007/11/21 01:29:13 dirtyepic Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/wxwidgets.eclass,v 1.23 2007/11/25 14:19:39 swegener Exp $
4 4
5# @ECLASS: wxwidgets.eclass 5# @ECLASS: wxwidgets.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# dirtyepic@gentoo.org 7# dirtyepic@gentoo.org
8# wxwindows@gentoo.org 8# wxwindows@gentoo.org
160 160
161 # since we're no longer in global scope we call built_with_use instead of 161 # since we're no longer in global scope we call built_with_use instead of
162 # all the crazy looping 162 # all the crazy looping
163 163
164 # base can be provided by both gtk2 and base installations 164 # base can be provided by both gtk2 and base installations
165 if $(built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* X); then 165 if built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* X; then
166 wxtoolkit="gtk2" 166 wxtoolkit="gtk2"
167 else 167 else
168 wxtoolkit="base" 168 wxtoolkit="base"
169 fi 169 fi
170 170
171 debug-print "wxtoolkit is ${wxtoolkit}" 171 debug-print "wxtoolkit is ${wxtoolkit}"
172 172
173 # debug or release? 173 # debug or release?
174 if $(built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* debug); then 174 if built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* debug; then
175 wxdebug="debug" 175 wxdebug="debug"
176 else 176 else
177 wxdebug="release" 177 wxdebug="release"
178 fi 178 fi
179 179
222 [[ -n ${WX_GTK_VER} ]] \ 222 [[ -n ${WX_GTK_VER} ]] \
223 || _wxerror "WX_GTK_VER must be set before calling" 223 || _wxerror "WX_GTK_VER must be set before calling"
224 224
225 225
226 ebegin "Checking wxGTK-${WX_GTK_VER} for ${1} support" 226 ebegin "Checking wxGTK-${WX_GTK_VER} for ${1} support"
227 if $(built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* "${1}"); then 227 if built_with_use =x11-libs/wxGTK-${WX_GTK_VER}* "${1}"; then
228 eend 0 228 eend 0
229 else 229 else
230 eend 1 230 eend 1
231 echo 231 echo
232 eerror "${FUNCNAME} - You have requested functionality that requires ${1} support to" 232 eerror "${FUNCNAME} - You have requested functionality that requires ${1} support to"

Legend:
Removed from v.1.22  
changed lines
  Added in v.1.23

  ViewVC Help
Powered by ViewVC 1.1.20