/[gentoo-x86]/eclass/x-modular.eclass
Gentoo

Diff of /eclass/x-modular.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.66
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.59 2006/05/16 06:23:43 exg Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.66 2006/06/30 16:21:38 spyderous Exp $
4# 4#
5# Author: Donnie Berkholz <spyderous@gentoo.org> 5# Author: Donnie Berkholz <spyderous@gentoo.org>
6# 6#
7# This eclass is designed to reduce code duplication in the modularized X11 7# This eclass is designed to reduce code duplication in the modularized X11
8# ebuilds. 8# ebuilds.
175 msg="${PN} does not work with hardened gcc specs. Switch to vanilla gcc specs to emerge ${PN}." 175 msg="${PN} does not work with hardened gcc specs. Switch to vanilla gcc specs to emerge ${PN}."
176 eerror "$msg" 176 eerror "$msg"
177 die "$msg" 177 die "$msg"
178 fi 178 fi
179 179
180 append-ldflags -Wl,-z,lazy
180 # (#116698) breaks loading 181 # (#116698) breaks loading
181 filter-ldflags -Wl,-z,now 182 filter-ldflags -Wl,-z,now
182 fi 183 fi
183} 184}
184 185
188 if [[ -n "${DRIVER}" ]]; then 189 if [[ -n "${DRIVER}" ]]; then
189 if has dri ${IUSE} && use dri; then 190 if has dri ${IUSE} && use dri; then
190 einfo "Checking for direct rendering capabilities ..." 191 einfo "Checking for direct rendering capabilities ..."
191 if ! built_with_use x11-base/xorg-server dri; then 192 if ! built_with_use x11-base/xorg-server dri; then
192 die "You must build x11-base/xorg-server with USE=dri." 193 die "You must build x11-base/xorg-server with USE=dri."
194 fi
195 fi
196 fi
197}
198
199x-modular_server_supports_drivers_check() {
200 # (#135873) Only certain servers will actually use or be capable of
201 # building external drivers, including binary drivers.
202 if [[ -n "${DRIVER}" ]]; then
203 if has_version >=x11-base/xorg-server-1.1; then
204 if ! built_with_use x11-base/xorg-server xorg; then
205 eerror "x11-base/xorg-server is not built with support for external drivers."
206 die "You must build x11-base/xorg-server with USE=xorg."
193 fi 207 fi
194 fi 208 fi
195 fi 209 fi
196} 210}
197 211
250 elibtoolize 264 elibtoolize
251} 265}
252 266
253x-modular_src_unpack() { 267x-modular_src_unpack() {
254 x-modular_specs_check 268 x-modular_specs_check
269 x-modular_server_supports_drivers_check
255 x-modular_dri_check 270 x-modular_dri_check
256 x-modular_unpack_source 271 x-modular_unpack_source
257 x-modular_patch_source 272 x-modular_patch_source
258 x-modular_reconf_source 273 x-modular_reconf_source
259} 274}
324 install 339 install
325# Shouldn't be necessary in XDIR=/usr 340# Shouldn't be necessary in XDIR=/usr
326# einstall forces datadir, so we need to re-force it 341# einstall forces datadir, so we need to re-force it
327# datadir=${XDIR}/share \ 342# datadir=${XDIR}/share \
328# mandir=${XDIR}/share/man \ 343# mandir=${XDIR}/share/man \
344
345 if [[ -e ${S}/ChangeLog ]]; then
346 dodoc ${S}/ChangeLog
347 fi
329 348
330 # Make sure docs get compressed 349 # Make sure docs get compressed
331 prepalldocs 350 prepalldocs
332 351
333 # Don't install libtool archives for server modules 352 # Don't install libtool archives for server modules

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.66

  ViewVC Help
Powered by ViewVC 1.1.20