/[gentoo-x86]/eclass/x-modular.eclass
Gentoo

Diff of /eclass/x-modular.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.63 Revision 1.69
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.63 2006/06/30 03:52:57 spyderous Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.69 2006/07/01 06:46:52 spyderous Exp $
4# 4#
5# Author: Donnie Berkholz <spyderous@gentoo.org> 5# Author: Donnie Berkholz <spyderous@gentoo.org>
6# 6#
7# This eclass is designed to reduce code duplication in the modularized X11 7# This eclass is designed to reduce code duplication in the modularized X11
8# ebuilds. 8# ebuilds.
155 fi 155 fi
156 fi 156 fi
157fi 157fi
158 158
159DEPEND="${DEPEND} 159DEPEND="${DEPEND}
160 >=dev-util/pkgconfig-0.18 160 >=dev-util/pkgconfig-0.18"
161 >=sys-devel/binutils-2.16.1-r3"
162 161
163if [[ "${PN/util-macros}" = "${PN}" ]]; then 162if [[ "${PN/util-macros}" = "${PN}" ]]; then
164 DEPEND="${DEPEND} 163 DEPEND="${DEPEND}
165 >=x11-misc/util-macros-0.99.2" 164 >=x11-misc/util-macros-0.99.2
165 !alpha? ( >=sys-devel/binutils-2.16.1-r3 )"
166fi 166fi
167 167
168RDEPEND="${RDEPEND} 168RDEPEND="${RDEPEND}
169 !<=x11-base/xorg-x11-6.9" 169 !<=x11-base/xorg-x11-6.9"
170# Provides virtual/x11 for temporary use until packages are ported 170# Provides virtual/x11 for temporary use until packages are ported
193 193
194x-modular_server_supports_drivers_check() { 194x-modular_server_supports_drivers_check() {
195 # (#135873) Only certain servers will actually use or be capable of 195 # (#135873) Only certain servers will actually use or be capable of
196 # building external drivers, including binary drivers. 196 # building external drivers, including binary drivers.
197 if [[ -n "${DRIVER}" ]]; then 197 if [[ -n "${DRIVER}" ]]; then
198 if has_version '>=x11-base/xorg-server-1.1'; then
198 if ! built_with_use x11-base/xorg-server xorg; then 199 if ! built_with_use x11-base/xorg-server xorg; then
199 eerror "x11-base/xorg-server is not built with support for external drivers." 200 eerror "x11-base/xorg-server is not built with support for external drivers."
200 die "You must build x11-base/xorg-server with USE=xorg." 201 die "You must build x11-base/xorg-server with USE=xorg."
202 fi
201 fi 203 fi
202 fi 204 fi
203} 205}
204 206
205x-modular_unpack_source() { 207x-modular_unpack_source() {

Legend:
Removed from v.1.63  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20