/[gentoo-x86]/eclass/x-modular.eclass
Gentoo

Diff of /eclass/x-modular.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.63 Revision 1.73
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.63 2006/06/30 03:52:57 spyderous Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.73 2006/08/21 00:22:52 dberkholz Exp $
4# 4#
5# Author: Donnie Berkholz <spyderous@gentoo.org> 5# Author: Donnie Berkholz <spyderous@gentoo.org>
6# 6#
7# This eclass is designed to reduce code duplication in the modularized X11 7# This eclass is designed to reduce code duplication in the modularized X11
8# ebuilds. 8# ebuilds.
25# 25#
26# Pretty much everything else should be automatic. 26# Pretty much everything else should be automatic.
27 27
28EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_postrm 28EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_postrm
29 29
30inherit eutils libtool toolchain-funcs flag-o-matic autotools 30inherit eutils libtool multilib toolchain-funcs flag-o-matic autotools
31 31
32# Directory prefix to use for everything 32# Directory prefix to use for everything
33XDIR="/usr" 33XDIR="/usr"
34 34
35# Set up default patchset version(s) if necessary 35# Set up default patchset version(s) if necessary
130# If we're a driver package 130# If we're a driver package
131if [[ "${PN/#xf86-video}" != "${PN}" ]] || [[ "${PN/#xf86-input}" != "${PN}" ]]; then 131if [[ "${PN/#xf86-video}" != "${PN}" ]] || [[ "${PN/#xf86-input}" != "${PN}" ]]; then
132 # Enable driver code in the rest of the eclass 132 # Enable driver code in the rest of the eclass
133 DRIVER="yes" 133 DRIVER="yes"
134 134
135 if [[ ${XDPVER} != -1 ]]; then
135 # Add driver patchset to SRC_URI 136 # Add driver patchset to SRC_URI
136 SRC_URI="${SRC_URI} 137 SRC_URI="${SRC_URI}
137 http://dev.gentoo.org/~joshuabaergen/distfiles/x11-driver-patches-${XDPVER}.tar.bz2" 138 http://dev.gentoo.org/~joshuabaergen/distfiles/x11-driver-patches-${XDPVER}.tar.bz2"
139 fi
138fi 140fi
139 141
140# Debugging -- ignore packages that can't be built with debugging 142# Debugging -- ignore packages that can't be built with debugging
141if [[ -z "${FONT}" ]] \ 143if [[ -z "${FONT}" ]] \
142 || [[ "${PN/app-doc}" != "${PN}" ]] \ 144 || [[ "${PN/app-doc}" != "${PN}" ]] \
155 fi 157 fi
156 fi 158 fi
157fi 159fi
158 160
159DEPEND="${DEPEND} 161DEPEND="${DEPEND}
160 >=dev-util/pkgconfig-0.18 162 >=dev-util/pkgconfig-0.18"
161 >=sys-devel/binutils-2.16.1-r3"
162 163
163if [[ "${PN/util-macros}" = "${PN}" ]]; then 164if [[ "${PN/util-macros}" = "${PN}" ]]; then
164 DEPEND="${DEPEND} 165 DEPEND="${DEPEND}
165 >=x11-misc/util-macros-0.99.2" 166 >=x11-misc/util-macros-0.99.2
167 >=sys-devel/binutils-2.16.1-r3"
166fi 168fi
167 169
168RDEPEND="${RDEPEND} 170RDEPEND="${RDEPEND}
171 >=sys-apps/man-1.6b-r2
169 !<=x11-base/xorg-x11-6.9" 172 !<=x11-base/xorg-x11-6.9"
170# Provides virtual/x11 for temporary use until packages are ported 173# Provides virtual/x11 for temporary use until packages are ported
171# x11-base/x11-env" 174# x11-base/x11-env"
172 175
173x-modular_specs_check() { 176x-modular_specs_check() {
193 196
194x-modular_server_supports_drivers_check() { 197x-modular_server_supports_drivers_check() {
195 # (#135873) Only certain servers will actually use or be capable of 198 # (#135873) Only certain servers will actually use or be capable of
196 # building external drivers, including binary drivers. 199 # building external drivers, including binary drivers.
197 if [[ -n "${DRIVER}" ]]; then 200 if [[ -n "${DRIVER}" ]]; then
201 if has_version '>=x11-base/xorg-server-1.1'; then
198 if ! built_with_use x11-base/xorg-server xorg; then 202 if ! built_with_use x11-base/xorg-server xorg; then
199 eerror "x11-base/xorg-server is not built with support for external drivers." 203 eerror "x11-base/xorg-server is not built with support for external drivers."
200 die "You must build x11-base/xorg-server with USE=xorg." 204 die "You must build x11-base/xorg-server with USE=xorg."
205 fi
201 fi 206 fi
202 fi 207 fi
203} 208}
204 209
205x-modular_unpack_source() { 210x-modular_unpack_source() {
220 fi 225 fi
221 226
222 # If this is a driver package we need to fix man page install location. 227 # If this is a driver package we need to fix man page install location.
223 # Running autoreconf will use the patched util-macros to make the 228 # Running autoreconf will use the patched util-macros to make the
224 # change for us, so we only need to patch if it is not going to run. 229 # change for us, so we only need to patch if it is not going to run.
225 if [[ -n "${DRIVER}" ]] && [[ "${SNAPSHOT}" != "yes" ]]; then 230 if [[ -n "${DRIVER}" ]] && [[ "${SNAPSHOT}" != "yes" ]]\
231 && [[ ${XDPVER} != -1 ]]; then
226 PATCHES="${PATCHES} ${DISTDIR}/x11-driver-patches-${XDPVER}.tar.bz2" 232 PATCHES="${PATCHES} ${DISTDIR}/x11-driver-patches-${XDPVER}.tar.bz2"
227 fi 233 fi
228 234
229 # For specific list of patches 235 # For specific list of patches
230 if [[ -n "${PATCHES}" ]] ; then 236 if [[ -n "${PATCHES}" ]] ; then
341 347
342 # Make sure docs get compressed 348 # Make sure docs get compressed
343 prepalldocs 349 prepalldocs
344 350
345 # Don't install libtool archives for server modules 351 # Don't install libtool archives for server modules
346 if [[ -e ${D}/usr/lib/xorg/modules ]]; then 352 if [[ -e ${D}/usr/$(get_libdir)/xorg/modules ]]; then
347 find ${D}/usr/lib/xorg/modules -name '*.la' \ 353 find ${D}/usr/$(get_libdir)/xorg/modules -name '*.la' \
348 | xargs rm -f 354 | xargs rm -f
349 fi 355 fi
350 356
351 # Don't install overlapping fonts.* files 357 # Don't install overlapping fonts.* files
352 # Generate them instead when possible 358 # Generate them instead when possible

Legend:
Removed from v.1.63  
changed lines
  Added in v.1.73

  ViewVC Help
Powered by ViewVC 1.1.20