/[gentoo-x86]/eclass/x-modular.eclass
Gentoo

Diff of /eclass/x-modular.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.58 Revision 1.69
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.58 2006/05/15 03:23:32 spyderous Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.69 2006/07/01 06:46:52 spyderous Exp $
4# 4#
5# Author: Donnie Berkholz <spyderous@gentoo.org> 5# Author: Donnie Berkholz <spyderous@gentoo.org>
6# 6#
7# This eclass is designed to reduce code duplication in the modularized X11 7# This eclass is designed to reduce code duplication in the modularized X11
8# ebuilds. 8# ebuilds.
159DEPEND="${DEPEND} 159DEPEND="${DEPEND}
160 >=dev-util/pkgconfig-0.18" 160 >=dev-util/pkgconfig-0.18"
161 161
162if [[ "${PN/util-macros}" = "${PN}" ]]; then 162if [[ "${PN/util-macros}" = "${PN}" ]]; then
163 DEPEND="${DEPEND} 163 DEPEND="${DEPEND}
164 >=x11-misc/util-macros-0.99.2" 164 >=x11-misc/util-macros-0.99.2
165 !alpha? ( >=sys-devel/binutils-2.16.1-r3 )"
165fi 166fi
166 167
167# >=sys-apps/man-1.6b-r2 required to look in [0-8]x/ directories
168RDEPEND="${RDEPEND} 168RDEPEND="${RDEPEND}
169 !<=x11-base/xorg-x11-6.9 169 !<=x11-base/xorg-x11-6.9"
170 >=sys-apps/man-1.6b-r2"
171# Provides virtual/x11 for temporary use until packages are ported 170# Provides virtual/x11 for temporary use until packages are ported
172# x11-base/x11-env" 171# x11-base/x11-env"
173 172
174x-modular_specs_check() { 173x-modular_specs_check() {
175 if [[ ${PN:0:11} = "xorg-server" ]] || [[ -n "${DRIVER}" ]]; then 174 if [[ ${PN:0:11} = "xorg-server" ]] || [[ -n "${DRIVER}" ]]; then
176 if gcc-specs-now; then 175 append-ldflags -Wl,-z,lazy
177 msg="${PN} does not work with hardened gcc specs. Switch to vanilla gcc specs to emerge ${PN}."
178 eerror "$msg"
179 die "$msg"
180 fi
181
182 # (#116698) breaks loading 176 # (#116698) breaks loading
183 filter-ldflags -Wl,-z,now 177 filter-ldflags -Wl,-z,now
184 fi 178 fi
185} 179}
186 180
190 if [[ -n "${DRIVER}" ]]; then 184 if [[ -n "${DRIVER}" ]]; then
191 if has dri ${IUSE} && use dri; then 185 if has dri ${IUSE} && use dri; then
192 einfo "Checking for direct rendering capabilities ..." 186 einfo "Checking for direct rendering capabilities ..."
193 if ! built_with_use x11-base/xorg-server dri; then 187 if ! built_with_use x11-base/xorg-server dri; then
194 die "You must build x11-base/xorg-server with USE=dri." 188 die "You must build x11-base/xorg-server with USE=dri."
189 fi
190 fi
191 fi
192}
193
194x-modular_server_supports_drivers_check() {
195 # (#135873) Only certain servers will actually use or be capable of
196 # building external drivers, including binary drivers.
197 if [[ -n "${DRIVER}" ]]; then
198 if has_version '>=x11-base/xorg-server-1.1'; then
199 if ! built_with_use x11-base/xorg-server xorg; then
200 eerror "x11-base/xorg-server is not built with support for external drivers."
201 die "You must build x11-base/xorg-server with USE=xorg."
195 fi 202 fi
196 fi 203 fi
197 fi 204 fi
198} 205}
199 206
252 elibtoolize 259 elibtoolize
253} 260}
254 261
255x-modular_src_unpack() { 262x-modular_src_unpack() {
256 x-modular_specs_check 263 x-modular_specs_check
264 x-modular_server_supports_drivers_check
257 x-modular_dri_check 265 x-modular_dri_check
258 x-modular_unpack_source 266 x-modular_unpack_source
259 x-modular_patch_source 267 x-modular_patch_source
260 x-modular_reconf_source 268 x-modular_reconf_source
261} 269}
326 install 334 install
327# Shouldn't be necessary in XDIR=/usr 335# Shouldn't be necessary in XDIR=/usr
328# einstall forces datadir, so we need to re-force it 336# einstall forces datadir, so we need to re-force it
329# datadir=${XDIR}/share \ 337# datadir=${XDIR}/share \
330# mandir=${XDIR}/share/man \ 338# mandir=${XDIR}/share/man \
339
340 if [[ -e ${S}/ChangeLog ]]; then
341 dodoc ${S}/ChangeLog
342 fi
331 343
332 # Make sure docs get compressed 344 # Make sure docs get compressed
333 prepalldocs 345 prepalldocs
334 346
335 # Don't install libtool archives for server modules 347 # Don't install libtool archives for server modules

Legend:
Removed from v.1.58  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20