/[gentoo-x86]/games-rpg/nwn-cep/nwn-cep-2.0.ebuild
Gentoo

Contents of /games-rpg/nwn-cep/nwn-cep-2.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.8 - (show annotations) (download)
Sun Oct 7 11:26:09 2012 UTC (2 years, 2 months ago) by pacho
Branch: MAIN
Changes since 1.7: +4 -4 lines
Rely on unpack.eclass to pull unrar deps, if other RAR alternatives are found to really fully replace unrar, this needs to be discussed centrally with eclass authors instead of in every ebuild using rar files (#244987 by drantin).

(Portage version: 2.1.11.24/cvs/Linux x86_64)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-2.0.ebuild,v 1.7 2010/07/12 17:07:46 mr_bones_ Exp $
4
5 EAPI=2
6 inherit eutils games unpacker
7
8 DESCRIPTION="High quality custom content addon for Neverwinter Nights"
9 HOMEPAGE="http://nwvault.ign.com/cep/"
10 SRC_URI="http://vnfiles.ign.com/nwvault.ign.com/fms/files/hakpaks/7000/CEPv2_full.rar"
11
12 LICENSE="as-is"
13 SLOT="2"
14 KEYWORDS="-* amd64 x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND=">=games-rpg/nwn-1.68"
19
20 S=${WORKDIR}
21
22 dir=${GAMES_PREFIX_OPT}/nwn
23
24 pkg_setup() {
25 games_pkg_setup
26 if ! has_version 'games-rpg/nwn-data[hou,sou]' ; then
27 eerror "${P} requires NWN v1.68, Shadows of Undrentide, and Hordes of"
28 eerror "the Underdark. Please make sure you have all three before using"
29 eerror "this patch."
30 die "Requirements not met"
31 fi
32 }
33
34 src_install() {
35 local i
36 for i in hak tlk erf
37 do
38 insinto "${dir}"/${i}
39 doins *.${i} || die "${i} failed"
40 done
41 insinto "${dir}"/modules
42 doins *.mod || die "mod failed"
43 insinto "${dir}"/cep
44 doins *.pdf || die "pdf failed"
45 prepgamesdirs
46 }

  ViewVC Help
Powered by ViewVC 1.1.20