/[gentoo-x86]/gnome-base/gnome-shell/gnome-shell-3.4.1.ebuild
Gentoo

Contents of /gnome-base/gnome-shell/gnome-shell-3.4.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Wed Nov 7 21:48:09 2012 UTC (23 months, 2 weeks ago) by tetromino
Branch: MAIN
Changes since 1.4: +6 -6 lines
Slot gstreamer dependencies in preparation for gstreamer-1.0; update license.

(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.4.1.ebuild,v 1.4 2012/10/10 00:23:54 tetromino Exp $
4
5 EAPI="4"
6 GCONF_DEBUG="no"
7 GNOME2_LA_PUNT="yes"
8 PYTHON_DEPEND="2:2.5"
9
10 inherit autotools eutils gnome2 multilib pax-utils python
11
12 DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
13 HOMEPAGE="http://live.gnome.org/GnomeShell"
14
15 LICENSE="GPL-2+ LGPL-2+"
16 SLOT="0"
17 IUSE="+bluetooth +networkmanager systemd"
18 KEYWORDS="~amd64 ~x86"
19
20 # gnome-desktop-2.91.2 is needed due to header changes, db82a33 in gnome-desktop
21 # latest g-c-c is needed due to https://bugs.gentoo.org/show_bug.cgi?id=360057
22 # libXfixes-5.0 needed for pointer barriers
23 COMMON_DEPEND=">=app-crypt/gcr-3.3.90[introspection]
24 >=dev-libs/glib-2.31.6:2
25 >=dev-libs/gjs-1.31.22
26 >=dev-libs/gobject-introspection-0.10.1
27 >=x11-libs/gtk+-3.3.9:3[introspection]
28 >=media-libs/clutter-1.9.16:1.0[introspection]
29 >=dev-libs/folks-0.5.2
30 >=dev-libs/json-glib-0.13.2
31 >=dev-libs/libcroco-0.6.2:0.6
32 >=gnome-base/gnome-desktop-2.91.2:3
33 >=gnome-base/gsettings-desktop-schemas-2.91.91
34 >=gnome-base/gnome-keyring-3.3.90
35 >=gnome-base/gnome-menus-2.29.10:3[introspection]
36 gnome-base/libgnome-keyring
37 >=gnome-extra/evolution-data-server-2.91.6
38 >=media-libs/gstreamer-0.10.16:0.10
39 >=media-libs/gst-plugins-base-0.10.16:0.10
40 >=net-im/telepathy-logger-0.2.4[introspection]
41 >=net-libs/telepathy-glib-0.17.5[introspection]
42 >=sys-auth/polkit-0.100[introspection]
43 >=x11-libs/libXfixes-5.0
44 >=x11-wm/mutter-3.4.1[introspection]
45 >=x11-libs/startup-notification-0.11
46
47 app-misc/ca-certificates
48 dev-libs/dbus-glib
49 dev-libs/libxml2:2
50 gnome-base/librsvg
51 media-libs/libcanberra
52 media-libs/mesa
53 media-sound/pulseaudio
54 net-libs/libsoup:2.4[introspection]
55 x11-libs/libX11
56 x11-libs/gdk-pixbuf:2[introspection]
57 x11-libs/pango[introspection]
58 x11-apps/mesa-progs
59
60 bluetooth? ( >=net-wireless/gnome-bluetooth-3.1.0[introspection] )
61 networkmanager? ( >=net-misc/networkmanager-0.8.999[introspection] )
62 systemd? ( >=sys-apps/systemd-31 )
63 "
64 # Runtime-only deps are probably incomplete and approximate.
65 # Each block:
66 # 1. Pull in polkit-0.101 for pretty authorization dialogs
67 # 2. Introspection stuff + dconf needed via imports.gi.*
68 # 3. gnome-session is needed for gnome-session-quit
69 # 4. Control shell settings
70 # 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
71 # user switching with gdm-3.1.x)
72 # 6. caribou needed for on-screen keyboard
73 # 7. xdg-utils needed for xdg-open, used by extension tool
74 # 8. gnome-icon-theme-symbolic and dejavu font neeed for various icons & arrows
75 # 9. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
76 RDEPEND="${COMMON_DEPEND}
77 >=sys-auth/polkit-0.101[introspection]
78
79 >=gnome-base/dconf-0.4.1
80 >=gnome-base/libgnomekbd-2.91.4[introspection]
81 sys-power/upower[introspection]
82
83 >=gnome-base/gnome-session-2.91.91
84
85 >=gnome-base/gnome-settings-daemon-2.91
86 >=gnome-base/gnome-control-center-2.91.92-r1[bluetooth(+)?]
87
88 >=sys-apps/accountsservice-0.6.14[introspection]
89
90 >=app-accessibility/caribou-0.3
91
92 x11-misc/xdg-utils
93
94 media-fonts/dejavu
95 x11-themes/gnome-icon-theme-symbolic
96
97 networkmanager? (
98 net-misc/mobile-broadband-provider-info
99 sys-libs/timezone-data )
100
101 !systemd? ( sys-auth/consolekit )
102 "
103 DEPEND="${COMMON_DEPEND}
104 >=sys-devel/gettext-0.17
105 >=dev-util/intltool-0.40
106 gnome-base/gnome-common
107 virtual/pkgconfig
108 !!=dev-lang/spidermonkey-1.8.2*"
109 # libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
110 # https://bugs.gentoo.org/show_bug.cgi?id=360413
111
112 pkg_setup() {
113 DOCS="AUTHORS NEWS README"
114 # Don't error out on warnings
115 G2CONF="${G2CONF}
116 --enable-compile-warnings=maximum
117 --disable-schemas-compile
118 --disable-jhbuild-wrapper-script
119 $(use_with bluetooth)
120 $(use_enable networkmanager)
121 $(use_with systemd)
122 --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
123 BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
124 python_set_active_version 2
125 python_pkg_setup
126 }
127
128 src_prepare() {
129 # Fix automagic gnome-bluetooth dep, bug #398145
130 epatch "${FILESDIR}/${PN}-3.2.1-automagic-gnome-bluetooth.patch"
131
132 # Make networkmanager optional, bug #398593
133 epatch "${FILESDIR}/${PN}-3.4.0-optional-networkmanager.patch"
134
135 # Force /usr/bin/gnome-shell to link to libgnome-shell-js; fixes extensions
136 # https://bugzilla.gnome.org/show_bug.cgi?id=670477
137 epatch "${FILESDIR}/${PN}-3.4.0-libgnome-shell-js.so-link"-{1,2}.patch
138
139 eautoreconf
140 gnome2_src_prepare
141
142 # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
143 # Note: sed Makefile.in because it is generated from several Makefile.ams
144 sed -e 's/-DG_DISABLE_DEPRECATED//g' \
145 -i src/Makefile.in browser-plugin/Makefile.in || die "sed failed"
146 }
147
148 src_install() {
149 gnome2_src_install
150 python_convert_shebangs 2 "${ED}/usr/bin/gnome-shell-extension-tool"
151
152 # Required for gnome-shell on hardened/PaX, bug #398941
153 pax-mark mr "${ED}usr/bin/gnome-shell"
154 }
155
156 pkg_postinst() {
157 gnome2_pkg_postinst
158
159 if ! has_version '>=media-libs/gst-plugins-good-0.10.23:0.10' || \
160 ! has_version 'media-plugins/gst-plugins-vp8:0.10'; then
161 ewarn "To make use of GNOME Shell's built-in screen recording utility,"
162 ewarn "you need to either install >=media-libs/gst-plugins-good-0.10.23:0.10"
163 ewarn "and media-plugins/gst-plugins-vp8:0.10, or use dconf-editor to change"
164 ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
165 fi
166
167 if ! has_version ">=x11-base/xorg-server-1.11"; then
168 ewarn "If you use multiple screens, it is highly recommended that you"
169 ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
170 ewarn "pointer barriers which will make it easier to use hot corners."
171 fi
172
173 if has_version "<x11-drivers/ati-drivers-12"; then
174 ewarn "GNOME Shell has been reported to show graphical corruption under"
175 ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
176 ewarn "fallback mode, or switch to open-source drivers."
177 fi
178
179 if has_version "media-libs/mesa[video_cards_radeon]"; then
180 elog "GNOME Shell is unstable under classic-mode r300/r600 mesa drivers."
181 elog "Make sure that gallium architecture for r300 and r600 drivers is"
182 elog "selected using 'eselect mesa'."
183 if ! has_version "media-libs/mesa[gallium]"; then
184 ewarn "You will need to emerge media-libs/mesa with USE=gallium."
185 fi
186 fi
187
188 if has_version "media-libs/mesa[video_cards_intel]"; then
189 elog "GNOME Shell is unstable under gallium-mode i915/i965 mesa drivers."
190 elog "Make sure that classic architecture for i915 and i965 drivers is"
191 elog "selected using 'eselect mesa'."
192 if ! has_version "media-libs/mesa[classic]"; then
193 ewarn "You will need to emerge media-libs/mesa with USE=classic."
194 fi
195 fi
196 }

  ViewVC Help
Powered by ViewVC 1.1.20