/[gentoo-x86]/gnome-base/gnome-shell/gnome-shell-3.8.3-r2.ebuild
Gentoo

Contents of /gnome-base/gnome-shell/gnome-shell-3.8.3-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (show annotations) (download)
Sun Jul 28 12:43:53 2013 UTC (11 months, 3 weeks ago) by pacho
Branch: MAIN
Changes since 1.3: +7 -1 lines
Tell people that they need to run systemd

(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)

1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.8.3-r2.ebuild,v 1.3 2013/07/28 00:02:23 eva Exp $
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7 GNOME2_LA_PUNT="yes"
8 PYTHON_COMPAT=( python2_{6,7} )
9
10 inherit autotools eutils gnome2 multilib pax-utils python-r1
11
12 DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
13 HOMEPAGE="http://live.gnome.org/GnomeShell"
14
15 SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.xz"
16
17 LICENSE="GPL-2+ LGPL-2+"
18 SLOT="0"
19 IUSE="+bluetooth +i18n +networkmanager"
20 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
21
22 # libXfixes-5.0 needed for pointer barriers
23 # TODO: gstreamer support is currently automagical:
24 # gstreamer? ( >=media-libs/gstreamer-0.11.92 )
25 #
26 # gnome-shell/gnome-control-center/mutter/gnome-settings-daemon better to be in sync for 3.8.3
27 # https://mail.gnome.org/archives/gnome-announce-list/2013-June/msg00005.html
28 COMMON_DEPEND="
29 app-crypt/libsecret
30 >=app-accessibility/at-spi2-atk-2.5.3
31 >=dev-libs/atk-2[introspection]
32 >=app-crypt/gcr-3.7.5[introspection]
33 >=dev-libs/glib-2.35:2
34 >=dev-libs/gjs-1.35.8
35 >=dev-libs/gobject-introspection-0.10.1
36 >=x11-libs/gtk+-3.7.9:3[introspection]
37 >=media-libs/clutter-1.13.4:1.0[introspection]
38 >=dev-libs/json-glib-0.13.2
39 >=dev-libs/libcroco-0.6.8:0.6
40 >=gnome-base/gnome-desktop-3.7.90:3=[introspection]
41 >=gnome-base/gsettings-desktop-schemas-3.7.4
42 >=gnome-base/gnome-keyring-3.3.90
43 >=gnome-base/gnome-menus-3.5.3:3[introspection]
44 gnome-base/libgnome-keyring
45 >=gnome-extra/evolution-data-server-3.5.3:=
46 >=media-libs/gstreamer-0.11.92:1.0
47 >=net-im/telepathy-logger-0.2.4[introspection]
48 >=net-libs/telepathy-glib-0.19[introspection]
49 >=sys-auth/polkit-0.100[introspection]
50 >=x11-libs/libXfixes-5.0
51 >=x11-wm/mutter-3.8.3[introspection]
52 >=x11-libs/startup-notification-0.11
53
54 ${PYTHON_DEPS}
55 dev-python/pygobject:3[${PYTHON_USEDEP}]
56
57 dev-libs/dbus-glib
58 dev-libs/libxml2:2
59 gnome-base/librsvg
60 media-libs/libcanberra[gtk3]
61 media-libs/mesa
62 >=media-sound/pulseaudio-2
63 >=net-libs/libsoup-2.40:2.4[introspection]
64 x11-libs/libX11
65 x11-libs/gdk-pixbuf:2[introspection]
66 x11-libs/pango[introspection]
67 x11-apps/mesa-progs
68
69 bluetooth? ( >=net-wireless/gnome-bluetooth-3.5[introspection] )
70 networkmanager? ( >=net-misc/networkmanager-0.9.6[introspection] )
71 "
72 # Runtime-only deps are probably incomplete and approximate.
73 # Introspection deps generated using:
74 # grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
75 # Each block:
76 # 1. Pull in polkit-0.101 for pretty authorization dialogs
77 # 2. Introspection stuff needed via imports.gi.*
78 # 3. gnome-session is needed for gnome-session-quit
79 # 4. Control shell settings
80 # 5. Systemd needed for suspending support
81 # 6. xdg-utils needed for xdg-open, used by extension tool
82 # 7. gnome-icon-theme-symbolic and dejavu font neeed for various icons & arrows
83 # 8. IBus is needed for i18n integration
84 # 9. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
85 RDEPEND="${COMMON_DEPEND}
86 >=sys-auth/polkit-0.101[introspection]
87
88 >=app-accessibility/caribou-0.4.8
89 >=gnome-base/gdm-3.5[introspection]
90 >=gnome-base/libgnomekbd-2.91.4[introspection]
91 media-libs/cogl[introspection]
92 >=sys-apps/accountsservice-0.6.14[introspection]
93 sys-power/upower[introspection]
94
95 >=gnome-base/gnome-session-2.91.91
96 >=gnome-base/gnome-settings-daemon-3.8.3
97 >=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?]
98
99 >=sys-apps/systemd-31
100
101 x11-misc/xdg-utils
102
103 media-fonts/dejavu
104 x11-themes/gnome-icon-theme-symbolic
105
106 i18n? ( >=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] )
107 networkmanager? (
108 net-misc/mobile-broadband-provider-info
109 sys-libs/timezone-data )
110 "
111 DEPEND="${COMMON_DEPEND}
112 dev-libs/libxslt
113 >=dev-util/gtk-doc-am-1.17
114 >=dev-util/intltool-0.40
115 gnome-base/gnome-common
116 >=sys-devel/gettext-0.17
117 virtual/pkgconfig
118 !!=dev-lang/spidermonkey-1.8.2*
119 "
120 # libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
121 # https://bugs.gentoo.org/show_bug.cgi?id=360413
122
123 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
124
125 src_prepare() {
126 # Fix automagic gnome-bluetooth dep, bug #398145
127 epatch "${FILESDIR}/${PN}-3.7.90-bluetooth-flag.patch"
128
129 # Make networkmanager optional, bug #398593
130 epatch "${FILESDIR}/${PN}-3.8.3-networkmanager-flag.patch"
131
132 # Re-lock the screen if we're restarted from a previously crashed shell (from 'master')
133 epatch "${FILESDIR}/${PN}-3.8.3-relock-screen.patch"
134
135 # Apply patches from gnome-3.8 branch
136 epatch "${WORKDIR}/${P}-patches/"*.patch
137
138 epatch_user
139
140 eautoreconf
141 gnome2_src_prepare
142 }
143
144 src_configure() {
145 # Do not error out on warnings
146 gnome2_src_configure \
147 --enable-man \
148 --disable-jhbuild-wrapper-script \
149 $(use_with bluetooth) \
150 $(use_enable networkmanager) \
151 BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
152 }
153
154 src_install() {
155 gnome2_src_install
156 python_replicate_script "${ED}/usr/bin/gnome-shell-extension-tool"
157 python_replicate_script "${ED}/usr/bin/gnome-shell-perf-tool"
158
159 # Required for gnome-shell on hardened/PaX, bug #398941
160 # Future-proof for >=spidermonkey-1.8.7 following polkit's example
161 if has_version '<dev-lang/spidermonkey-1.8.7'; then
162 pax-mark mr "${ED}usr/bin/gnome-shell"
163 elif has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
164 pax-mark m "${ED}usr/bin/gnome-shell"
165 fi
166 # Required for gnome-shell on hardened/PaX #457146 and #457194
167 # PaX EMUTRAMP need to be on
168 if has_version '>=dev-libs/libffi-3.0.13[pax_kernel]'; then
169 pax-mark E "${ED}usr/bin/gnome-shell"
170 fi
171 }
172
173 pkg_postinst() {
174 gnome2_pkg_postinst
175
176 if ! has_version 'media-libs/gst-plugins-good:1.0' || \
177 ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
178 ewarn "To make use of GNOME Shell's built-in screen recording utility,"
179 ewarn "you need to either install media-libs/gst-plugins-good:1.0"
180 ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
181 ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
182 fi
183
184 if ! has_version ">=x11-base/xorg-server-1.11"; then
185 ewarn "If you use multiple screens, it is highly recommended that you"
186 ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
187 ewarn "pointer barriers which will make it easier to use hot corners."
188 fi
189
190 if has_version "<x11-drivers/ati-drivers-12"; then
191 ewarn "GNOME Shell has been reported to show graphical corruption under"
192 ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
193 ewarn "fallback mode, or switch to open-source drivers."
194 fi
195
196 if has_version "media-libs/mesa[video_cards_radeon]" ||
197 has_version "media-libs/mesa[video_cards_r300]" ||
198 has_version "media-libs/mesa[video_cards_r600]"; then
199 elog "GNOME Shell is unstable under classic-mode r300/r600 mesa drivers."
200 elog "Make sure that gallium architecture for r300 and r600 drivers is"
201 elog "selected using 'eselect mesa'."
202 if ! has_version "media-libs/mesa[gallium]"; then
203 ewarn "You will need to emerge media-libs/mesa with USE=gallium."
204 fi
205 fi
206
207 if has_version "media-libs/mesa[video_cards_intel]" ||
208 has_version "media-libs/mesa[video_cards_i915]" ||
209 has_version "media-libs/mesa[video_cards_i965]"; then
210 elog "GNOME Shell is unstable under gallium-mode i915/i965 mesa drivers."
211 elog "Make sure that classic architecture for i915 and i965 drivers is"
212 elog "selected using 'eselect mesa'."
213 if ! has_version "media-libs/mesa[classic]"; then
214 ewarn "You will need to emerge media-libs/mesa with USE=classic."
215 fi
216 fi
217
218 if ! systemd_is_booted; then
219 ewarn "${PN} needs Systemd to be *running* for working"
220 ewarn "properly. Please follow the this guide to migrate:"
221 ewarn "http://wiki.gentoo.org/wiki/Systemd"
222 fi
223 }

  ViewVC Help
Powered by ViewVC 1.1.20