/[gentoo-x86]/net-irc/irssi/ChangeLog
Gentoo

Contents of /net-irc/irssi/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.48 - (hide annotations) (download)
Fri Jun 18 20:48:04 2004 UTC (10 years, 4 months ago) by swegener
Branch: MAIN
Changes since 1.47: +4 -1 lines
Added dev-libs/glib to RDEPEND. Closes bug #54323.

1 vapier 1.14 # ChangeLog for net-irc/irssi
2 weeve 1.42 # Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
3 swegener 1.48 # $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.47 2004/04/27 22:11:45 agriffis Exp $
4    
5     18 Jun 2004; Sven Wegener <swegener@gentoo.org> irssi-0.8.9.ebuild:
6     Added dev-libs/glib to RDEPEND. Closes bug #54323.
7 agriffis 1.47
8     27 Apr 2004; Aron Griffis <agriffis@gentoo.org> irssi-0.8.6-r5.ebuild,
9     irssi-0.8.6-r6.ebuild:
10     Add inherit eutils
11 randy 1.46
12     12 Apr 2004; <randy@gentoo.org> irssi-0.8.9.ebuild:
13     Adding s390 keywords
14 tgall 1.45
15     05 Mar 2004; Tom Gall <tgall@gentoo.org> irssi-0.8.9.ebuild:
16     marked stable on ppc64
17 seemant 1.44
18     21 Feb 2004; Seemant Kulleen <seemant@gentoo.org> irssi-0.8.9.ebuild:
19     added perl, ssl and socks to RDEPENDS for livecd irssi to run properly
20 avenj 1.43
21     15 Jan 2004; Jon Portnoy <avenj@gentoo.org> irssi-0.8.9.ebuild :
22     Stable on AMD64.
23 weeve 1.42
24     09 Jan 2004; Jason Wever <weeve@gentoo.org> irssi-0.8.9.ebuild:
25     Marked stable on sparc.
26 gmsoft 1.41
27     09 Jan 2004; root <root@gentoo.org> irssi-0.8.9.ebuild:
28     Marked stable on hppa.
29 agriffis 1.40
30     05 Jan 2004; Aron Griffis <agriffis@gentoo.org> irssi-0.8.9.ebuild:
31     Use glib2 (this ebuild accidentally regressed from 0.8.6-r6). Don't
32     build the bot, which is apparently broken and unsupported. Mark
33     stable on x86, alpha and ia64. These changes fix bugs 33603, 35614
34     and 35532 and follow discussion with Greg F. in December.
35 gregf 1.39
36     12 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.9.ebuild:
37     Fixed patch problem, closes bug #35657
38 gregf 1.38
39     *irssi-0.8.9 (11 Dec 2003)
40    
41     11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
42     irssi-0.8.8.ebuild, irssi-0.8.9.ebuild:
43     Version Bump, fixes ssl bug #35532
44    
45     11 Dec 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild,
46     irssi-0.8.8.ebuild:
47     Removed because of remoate crash bug
48 gregf 1.37
49     *irssi-0.8.8-r1 (26 Nov 2003)
50    
51     26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8-r1.ebuild:
52     Force glib2, removed bot (obsolete).
53 gregf 1.36
54     *irssi-0.8.6-r6 (26 Nov 2003)
55    
56     26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r6.ebuild:
57     Removed --with-bot, no used anymore and it was broken. Forced usage of glib2.
58     This closes bug #33603.
59 mholzer 1.35
60     23 Nov 2003; Martin Holzer <mholzer@gentoo.org> irssi-0.8.8.ebuild,
61     files/irssi-0.8.8-configure.patch:
62     fixing head -1 issue. Closes #34186.
63 gregf 1.34
64     *irssi-0.8.8 (23 Nov 2003)
65    
66     23 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.8.ebuild:
67     Version bump.
68 zul 1.33
69     *irssi-0.8.6-r5 (11 Nov 2003)
70    
71     11 Nov 2003; Chuck Short <zul@gentoo.org> irssi-0.8.6-r5.ebuild:
72     New version, fixes use handling and new socks functionaility at compile time.
73     Ebuild submitted by Aron Griffis <agriffis@gentoo.org>
74     Closes bug #33230.
75 gregf 1.32
76     *irssi-0.8.6-r4 (05 Oct 2003)
77    
78     05 Oct 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r4.ebuild:
79     Fix for use=perl, this closes bug #30029
80 kumba 1.30
81 taviso 1.31 01 Oct 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r3.ebuild:
82     Stable on alpha
83 kumba 1.30
84     *irssi-0.8.6-r3 (30 Sep 2003)
85    
86     30 Sep 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r3.ebuild:
87     Changed ~mips to mips in KEYWORDS
88 avenj 1.29
89     18 Sep 2003; Jon Portnoy <avenj@gentoo.org> :
90     ia64 keywords.
91 zul 1.28
92     21 Aug 2003; <chuck@gentoo.org> :
93     Added SSL suport, closes bug #26343.
94 taviso 1.27
95 kumba 1.30 *irssi-0.8.6-r2 (10 Feb 2003)
96    
97 taviso 1.27 07 Aug 2003; Tavis Ormandy <taviso@gentoo.org> irssi-0.8.6-r2.ebuild:
98     stable on alpha
99 tester 1.26
100     18 Jul 2003; Olivier Crete <tester@gentoo.org> irssi-0.8.6-r2.ebuild,
101     files/irssi-0.8.6-configure.patch:
102     Fix tail use to make it posix compliant
103 johnm 1.25
104     18 Jul 2003; John Mylchreest <johnm@gentoo.org>; irssi-0.8.6-r2.ebuild:
105     adding irssi-cvs block
106 kumba 1.23
107 msterret 1.24 19 Jun 2003; <msterret@gentoo.org> irssi-0.8.6-r2.ebuild:
108     Ugly hack to work around compression of the html files. (bug 23048)
109 kumba 1.23
110     01 Jun 2003; Joshua Kinard <kumba@gentoo.org> irssi-0.8.6-r2.ebuild:
111     Added ~mips to KEYWORDS
112 gmsoft 1.20
113     11 Feb 2003; Guy Martin <gmsoft@gentoo.org> irssi-0.8.6-r2.ebuild :
114     Added hppa to keywords.
115 weeve 1.22
116     04 Apr 2003; Jason Wever <weeve@gentoo.org> irssi-0.8.6-r2.ebuild:
117     Changed ~sparc keyword to sparc.
118 viz 1.18
119 latexer 1.19 10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
120     Added ~alpha to KEYWORDS.
121    
122 viz 1.18 10 Feb 2002; Tobias Eichert <viz@gentoo.org> :
123     Removed older irssi ebuilds and revisions to
124     make the directory more concise..now we
125     have an ebuild for irssi-0.8.5 and irssi-0.8.6.
126     Changed =dev-libs/glib-2.2* dependency to
127     >=dev-libs/glib-1.2.
128     Changed "~x86" to "x86" in KEYWORDS.
129 viz 1.17
130     10 Feb 2003; Tobias Eichert <viz@gentoo.org> irssi-0.8.6-r2.ebuild:
131     Removed glib-1.2* as a dependency. Therefor added glib-2.2*.
132     Closes bug #13991.
133 blizzy 1.15
134 blizzy 1.16 *irssi-0.8.6-r1 (22 Dec 2002)
135    
136     22 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : Obey USE="-ssl" (bug
137     #12566).
138    
139     21 Dec 2002; Maik Schreiber <blizzy@gentoo.org> irssi-0.8.6.ebuild: Changed
140     "~x86" to "x86" in KEYWORDS.
141 lamer 1.4
142 blizzy 1.13 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
143 manson 1.12
144 blizzy 1.11 *irssi-0.8.6 (19 Nov 2002)
145    
146     19 Nov 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
147 murphy 1.9
148 vapier 1.10 20 Oct 2002; Mike Frysinger <vapier@gentoo.org> irssi-0.8.5-r2.ebuild :
149     Added 'prepalldocs' to src_install since `make install` was putting them there
150    
151     16 Sep 2002; Maarten Thibaut <murphy@gentoo.org> irssi-0.8.5-r2.ebuild :
152     Added sparc/sparc64 keywords.
153 mcummings 1.8
154     13 Sep 2002; Michael Cummings <mcummings@gentoo.org>: Corrected perl
155     syntax to use perl eclass for perl Makefile.PL actions, bug 7868.
156 blizzy 1.11
157     *irssi-0.8.5-r2 (12 Sep 2002)
158 latexer 1.19
159     10 Feb 2003; Peter Johanson <latexer@gentoo.org> :
160     Added ~alpha to KEYWORDS.
161 gerk 1.5
162 drobbins 1.6 12 Sep 2002; Daniel Robbins <drobbins@gentoo.org>: new rev bump with
163     configuration flag fixes: several use/configure combos were toggled, the
164 drobbins 1.7 ebuild had "--enable-perl" instead of "--with-perl", etc. Lamer's socks
165     stuff has been commented out for the time being so that I can unmask
166     this now (but is being kept so that it can be uncommented later.)
167 lamer 1.4
168 drobbins 1.6 *irssi-0.8.5-r1 (15 Jul 2002)
169 lamer 1.4
170 drobbins 1.6 24 Jul 2002; Mark Guertin <gerk@gentoo.org>: Added ppc to keywords
171 spider 1.2
172 drobbins 1.6 15 Jul 2002; Ben Lutgens <lamer@gentoo.org> ChangeLog: Incremented the
173     version number. Anyone with socks in use gets an additional depend on
174     net-misc/dante-1.1.13. It's needed for libsocks.so and socks.h (otherwise
175     toggling the option --with-socks does no good) needs more socks testing
176     however so it's getting masked)
177 spider 1.2
178 drobbins 1.6 *irssi-0.8.5 (23 Jun 2002)
179 spider 1.2
180 drobbins 1.6 23 Jun 2002; lamer <lamer@gentoo.org>: Updated to latest version from
181     upstream. Fixes a topic string overflow DoS attack. Upgrade now.
182 gbevin 1.1
183 drobbins 1.6 11 Apr 2002; Spider <spider@gentoo.org>: Update all glib dependencies to use
184     glib-1.2* in preparation of unmasking the glib-2.0.1 packages

  ViewVC Help
Powered by ViewVC 1.1.20