/[gentoo-x86]/net-misc/networkmanager/files/networkmanager-0.9.8.2-allow-new-dhcpcd.patch
Gentoo

Contents of /net-misc/networkmanager/files/networkmanager-0.9.8.2-allow-new-dhcpcd.patch

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Fri Jul 19 19:07:13 2013 UTC (14 months ago) by abcd
Branch: MAIN
CVS Tags: HEAD
Add missing eutils inherits; add patch and bump to allow building against dhcpcd 6.x (previously silently failed to use dhcpcd, but still compiled and installed)

(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 229E5838)

1 From 89512ec5c49de8d29e25d2758f7065ded09a1bd9 Mon Sep 17 00:00:00 2001
2 From: Dan Williams <dcbw@redhat.com>
3 Date: Fri, 19 Jul 2013 18:32:44 +0000
4 Subject: build: allow dhcpcd versions higher than 5
5
6 No reason to exclude them, just that configure.ac hasn't tracked new
7 versions of dhcpcd.
8 ---
9 diff --git a/configure.ac b/configure.ac
10 index d28e4bf..6b70bbd 100644
11 --- a/configure.ac
12 +++ b/configure.ac
13 @@ -506,8 +506,8 @@ fi
14 if test "$with_dhcpcd" = "yes"; then
15 AC_PATH_PROGS(with_dhcpcd, dhcpcd, no, /sbin:/usr/sbin:/usr/local/sbin)
16 if test "$with_dhcpcd" != "no"; then
17 - if ! $with_dhcpcd --version 2>&1 | grep -q "^dhcpcd [[45]]\."; then
18 - AC_MSG_WARN([Cannot use dhcpcd, version 4.x or 5.x is required])
19 + if ! $with_dhcpcd --version 2>&1 | grep -q "^dhcpcd [[456789]]\."; then
20 + AC_MSG_WARN([Cannot use dhcpcd, version 4.x or higher is required])
21 with_dhcpcd=no
22 fi
23 fi
24 --
25 cgit v0.9.0.2-2-gbebe

  ViewVC Help
Powered by ViewVC 1.1.20