/[gentoo-x86]/profiles/package.mask
Gentoo

Contents of /profiles/package.mask

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.14428 - (show annotations) (download)
Sat Feb 2 19:21:02 2013 UTC (17 months, 1 week ago) by dilfridge
Branch: MAIN
Changes since 1.14427: +1 -6 lines
Remove xboing mask.

1 ####################################################################
2 # $Header: /var/cvsroot/gentoo-x86/profiles/package.mask,v 1.14427 2013/02/01 21:12:34 fuzzyray Exp $
3 #
4 # When you add an entry to the top of this file, add your name, the date, and
5 # an explanation of why something is getting masked. Please be extremely
6 # careful not to commit atoms that are not valid, as it can cause large-scale
7 # breakage, especially if it ends up in the daily snapshot.
8 #
9 ## Example:
10 ##
11 ## # Dev E. Loper <developer@gentoo.org> (28 Jun 2012)
12 ## # Masking these versions until we can get the
13 ## # v4l stuff to work properly again
14 ## =media-video/mplayer-0.90_pre5
15 ## =media-video/mplayer-0.90_pre5-r1
16 #
17 # - Best last rites (removal) practices -
18 # Include the following info:
19 # a) reason for masking
20 # b) bug # for the removal (and yes you should have one)
21 # c) date of removal (either the date or "in x days")
22 # d) the word "removal"
23 #
24 ## Example:
25 ##
26 ## Dev E. Loper <developer@gentoo.org> (25 Jan 2013)
27 ## Masked for removal in 30 days. Doesn't work
28 ## with new libfoo. Upstream dead, gtk-1, smells
29 ## funny. (bug #987654)
30 ## app-misc/some-package
31
32 #--- END OF EXAMPLES ---
33
34 # Michael Sterrett <mr_bones_@gentoo.org> (31 Jan 2013)
35 # Old, dead upstream and require guile[deprecated]
36 # Masked for removal on 20130302
37 games-action/trackballs
38 games-misc/gnurobots
39
40 # Michael Sterrett <mr_bones_@gentoo.org> (31 Jan 2013)
41 # Upstream is dead and gone.
42 # Masked for removal on 20130302
43 games-arcade/bitefusion
44
45 # Rafael G. Martins <rafaelmartins@gentoo.org> (31 Jan 2013)
46 # Renamed to xombrero. Please install www-client/xombrero (bug #417555)
47 # The package was not pkg-moved to fix the upstream versioning mess.
48 # Removal in 30 days
49 www-client/xxxterm
50
51 # Michael Sterrett <mr_bones_@gentoo.org> (28 Jan 2013)
52 # Doesn't work with newer KDE and upstream seems dead (bug #453756)
53 # Masked for removal on 20130227
54 games-puzzle/kmagnet
55
56 # Samuli Suominen <ssuominen@gentoo.org> (28 Jan 2013)
57 # Uncompatible with current udev and baselayout
58 # Bug 220121 and the ones it Blocks
59 # Removal in 30 days
60 x11-misc/mkxf86config
61 <app-misc/livecd-tools-2.0
62
63 # Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jan 2013)
64 # Beta versions masked for testing
65 =net-misc/modemmanager-0.7*
66 =net-misc/networkmanager-0.9.7*
67
68 # Tim Harder <radhermit@gentoo.org> (27 Jan 2013)
69 # Masked due to deprecated API, use dev-python/PyGithub instead
70 # Removal in 30 days
71 dev-python/github2
72
73 # Diego Elio Pettenò <flameeyes@gentoo.org> (25 Jan 2013)
74 # Masked for testing
75 >=dev-libs/boost-1.53.0_beta1
76 >=dev-util/boost-build-1.53.0_beta1
77
78 # Julian Ospald <hasufell@gentoo.org> (25 Jan 2013)
79 # functionality now provided by >=net-misc/youtube-viewer[gtk]-3.0.3
80 # bug 453580, removal in 30 days
81 net-misc/gtk-youtube-viewer
82
83 # Doug Goldstein <cardoe@gentoo.org> (22 Jan 2013)
84 # Masked for development
85 =sys-block/open-iscsi-2.0.873
86
87 # Samuli Suominen <ssuominen@gentoo.org> (22 Jan 2013)
88 # Remove coldplug, hotplug and hotplug-base in 30 days wrt bug #145809
89 sys-apps/ezusb2131
90 sys-apps/hotplug
91 sys-apps/hotplug-base
92 sys-apps/coldplug
93
94 # Doug Goldstein <cardoe@gentoo.org> (20 Jan 2013)
95 # Under development, feel free to test and report back
96 =app-emulation/qemu-1.2.2-r100
97
98 # Hans de Graaff <graaff@gentoo.org> (20 Jan 2013) Mask
99 # dev-lang/ruby-enterprise for removal, bug 453178. The current
100 # versions have minor security issues, the latest versions are masked
101 # and don't work, and upstream announced end-of-life almost a year
102 # ago. Ruby 1.9 has almost all of the benefits of REE, so the
103 # recommendation is to switch to that if you are still using REE.
104 dev-lang/ruby-enterprise
105
106 # Ben de Groot <yngwin@gentoo.org> (20 Jan 2013)
107 # 2.5* has known security and other issues due to bundled ffmpeg,
108 # see (bugs #446468 and #444262)
109 # 2.6* is masked for testing, and may have unknown issues due to bundled ffmpeg
110 # This package needs a new, dedicated maintainer. We voted for keeping it in
111 # the tree for now, so users who are willing to accept the known issues can
112 # still easily install it by unmasking this.
113 media-video/avidemux
114
115 # Marien Zwart <marienz@gentoo.org>
116 # Patch tarball is broken, meaning this builds 1.2.0 (bug #452918)
117 =app-emulation/qemu-1.2.2-r1
118
119 # Mike Pagano <mpagano@gentoo.org>
120 # Mask for testing
121 >=app-portage/portpeek-2.1.6
122
123 # Mike Gilbert <floppym@gentoo.org (18 Jan 2013)
124 # Release made by unofficial maintainer. Drops support for Python 3 with
125 # very few improvements. Should be replaced by dev-python/charade eventually.
126 =dev-python/chardet-2.1.1
127
128 # Pacho Ramos <pacho@gentoo.org>
129 # Dead since 2003, doesn't work with journaling filesystems.
130 # Also collides with dev-util/smem (#288721). Removal in a month.
131 app-misc/secure-delete
132
133 # Pacho Ramos <pacho@gentoo.org>
134 # No upstream, doesn't work well (#350559). Removal in a month.
135 app-misc/ccal
136
137 # Pacho Ramos <pacho@gentoo.org>
138 # Upstream dead for a long time, broken php support (#356841).
139 # Removal in a month.
140 www-apache/mod_vhs
141
142 # Pacho Ramos <pacho@gentoo.org>
143 # Still uses depend.php (#449820), upstream dead for ages and
144 # newer versions don't work. Removal in a month.
145 www-apps/online-bookmarks
146
147 # Pacho Ramos <pacho@gentoo.org>
148 # It's for kernel-2.4 only (#450594). Removal in a month.
149 sys-apps/i2c
150
151 # Michał Górny <mgorny@gentoo.org>
152 # Unmaintained and replaced by built-in sqlite3 module in Python.
153 # Masked for removal in 30 days, bug 452122.
154 >=dev-python/pysqlite-2
155
156 # Maciej Mrozowski <reavertm@gentoo.org>
157 # API change breaks packages, bug 449534.
158 =app-text/poppler-0.22.0
159
160 # Alexis Ballier <aballier@gentoo.org>
161 # Not really compatible with TeX Live 2012, breaks texdoc, produces some non
162 # fatal errors in some documents, mask until fixed or TeX Live 2013 is out.
163 >=dev-tex/luatex-0.74
164
165 # Pawel Hajdan jr <phajdan.jr@gentoo.org> (14 Jan 2013)
166 # Dev channel releases are only for people who are developers or want more
167 # experimental features and accept a more unstable release.
168 >=www-client/chromium-26
169
170 # Pawel Hajdan jr <phajdan.jr@gentoo.org> (14 Jan 2013)
171 # Mask v8 versions used for www-client/chromium dev channel releases.
172 >=dev-lang/v8-3.16
173
174 # Mike Gilbert <floppym@gentoo.org> (13 Jan 2013)
175 # Dev channel releases are only for people who are developers or want more
176 # experimental features and accept a more unstable release.
177 >=www-client/google-chrome-26
178
179 # Tim Harder <radhermit@gentoo.org> (13 Jan 2013)
180 # Masked for testing
181 =mail-client/roundcube-0.9*
182
183 # Doug Goldstein <cardoe@gentoo.org> (12 Jan 2013)
184 # Under development
185 =app-emulation/qemu-1.3.0
186
187 # Sergey Popov <pinkbyte@gentoo.org> (12 Jan 2013)
188 # Does not build(bug #450850), upstream is dead for ages
189 # nothing depends on it in tree
190 # Removal in 30 days
191 dev-libs/libole2
192
193 # Jeroen Roovers <jer@gentoo.org> (09 Jan 2013)
194 # Testing branch, unstable upstream
195 >net-nntp/tin-2.1
196
197 # Torsten Veller <tove@gentoo.org> (08 Jan 2013)
198 # Mask dev-perl/Class-MOP. It was merge with dev-perl/Moose-2.
199 # Now as the last arch stabilized Moose-2, dev-perl/Class-MOP will be removed.
200 # bug #350612
201 dev-perl/Class-MOP
202
203 # Alexander Vershilov <qnikst@gentoo.org> (06 Jan 2013)
204 # Requires >=net-fs/samba-4 (bug #450226)
205 >=sys-auth/sssd-1.9.3
206
207 # Sergei Trofimovich <slyfox@gentoo.org> (05 Jan 2013)
208 # Masked for testing. Is not compatible with cvsps-2 (bug #450424).
209 # But can be used on it's own! Try 'cvsps --fast-export'.
210 >=dev-vcs/cvsps-3
211
212 # Ole Markus With <olemarkus@gentoo.org> (04 Jan 2013)
213 # No release in four years. Replaced by Zeta Components, which also has yet to
214 # have had any releases.
215 # Masked for removal.
216 dev-php/ezc-Archive
217 dev-php/ezc-Authentication
218 dev-php/ezc-AuthenticationDatabaseTiein
219 dev-php/ezc-Cache
220 dev-php/ezc-Configuration
221 dev-php/ezc-ConsoleTools
222 dev-php/ezc-Database
223 dev-php/ezc-DatabaseSchema
224 dev-php/ezc-Debug
225 dev-php/ezc-Document
226 dev-php/ezc-EventLog
227 dev-php/ezc-EventLogDatabaseTiein
228 dev-php/ezc-Execution
229 dev-php/ezc-eZcomponents
230 dev-php/ezc-Feed
231 dev-php/ezc-File
232 dev-php/ezc-GraphDatabaseTiein
233 dev-php/ezc-ImageAnalysis
234 dev-php/ezc-ImageConversion
235 dev-php/ezc-Mail
236 dev-php/ezc-MvcAuthenticationTiein
237 dev-php/ezc-MvcFeedTiein
238 dev-php/ezc-MvcMailTiein
239 dev-php/ezc-MvcTemplateTiein
240 dev-php/ezc-MvcTools
241 dev-php/ezc-PersistentObject
242 dev-php/ezc-PersistentObjectDatabaseSchemaTiein
243 dev-php/ezc-PhpGenerator
244 dev-php/ezc-Search
245 dev-php/ezc-SignalSlot
246 dev-php/ezc-SystemInformation
247 dev-php/ezc-Template
248 dev-php/ezc-TemplateTranslationTiein
249 dev-php/ezc-Translation
250 dev-php/ezc-TranslationCacheTiein
251 dev-php/ezc-Tree
252 dev-php/ezc-TreeDatabaseTiein
253 dev-php/ezc-TreePersistentObjectTiein
254 dev-php/ezc-Url
255 dev-php/ezc-UserInput
256 dev-php/ezc-Webdav
257 dev-php/ezc-Workflow
258 dev-php/ezc-WorkflowDatabaseTiein
259 dev-php/ezc-WorkflowEventLogTiein
260 dev-php/ezc-WorkflowSignalSlotTiein
261
262 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (04 Jan 2013)
263 # Mask some prerelease x11 packages
264 =x11-base/xorg-server-1.13.99*
265 =x11-libs/libXi-1.6.99*
266 =x11-proto/inputproto-2.2.99*
267
268 # Mike Gilbert <floppym@gentoo.org> (03 Jan 2013)
269 # No longer maintained upstream.
270 # Please upgrade to PyPy 1.9 or 2.0.
271 # Make sure to update USE_PYTHON and PYTHON_TARGETS as well.
272 # Removal in 30 days.
273 dev-python/pypy:1.8
274
275 # Sergei Trofimovich <slyfox@gentoo.org> (01 Jan 2013)
276 # Masked for removal (moved to haskell overlay).
277 # Fails to build (bug #423763). Needs severe code cleanup
278 # for modern ghc.
279 dev-haskell/wash
280
281 # Sergei Trofimovich <slyfox@gentoo.org> (28 Dec 2012)
282 # Masked as needs masked version of wxGTK:2.9:
283 dev-haskell/wxc:2.9
284 dev-haskell/wxcore:2.9
285 dev-haskell/wxhaskell:2.9
286
287 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (25 Dec 2012)
288 # Does not build against modern kernels or X servers. Users of pre-HD5000
289 # Radeon hardware should use 12.6_beta_pre897 ("12.6 Legacy") instead.
290 =x11-drivers/ati-drivers-12.4
291
292 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
293 # Will be maintained in squeezebox overlay, please switch to it.
294 # See bug #251494. Removal from the tree in a month.
295 media-sound/logitechmediaserver-bin
296
297 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
298 # Doesn't compile with recent kernels (#265581) and is not needed on
299 # them. Removal in a month.
300 net-dialup/misdn
301 net-dialup/misdnuser
302 net-misc/asterisk-chan_misdn
303
304 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
305 # Upstream dead, some problems (#277348), one possible replacement
306 # includes mod_authnz_external. Removal in a month.
307 www-apache/mod_authn_pam
308
309 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
310 # Incompatible with recent kernels (#300047) , upstream dead,
311 # net-dialup/martian-modem can be used instead in most cases.
312 net-dialup/ltmodem
313
314 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
315 # Old SLOT is not maintained by upstream for a long time,
316 # nothing requires it (#311497). Removal in a month.
317 =dev-libs/gmime-2.2.27-r1
318
319 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
320 # Fails to build (#326799), upstream dead. Removal in a month.
321 www-apache/mod_spin
322
323 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
324 # Dead stuff that shouldn't be used and that is required by
325 # nothing (#407697). Removal in a month.
326 dev-dotnet/galago-sharp
327 sys-apps/galago-daemon
328 dev-libs/libgalago
329
330 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
331 # Really old snapshot that is not compatible with apache-2.4,
332 # upstream looks dead (#411465). Removal in a month.
333 www-apache/mod_transform
334
335 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
336 # Upstream dropped them (#435842). Removal in a month.
337 dev-util/monodevelop-java
338 dev-util/monodevelop-python
339 dev-util/monodevelop-vala
340
341 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
342 # As distfiles are no longer provided by upstream and license
343 # doesn't let us mirror them, it will be removed in a month (#444322).
344 app-admin/flexlm
345
346 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
347 # EOL for a long time as Cisco dropped its support in favor of Anyconnect,
348 # it no longer works with current kernels (#444420). Removal in a month.
349 net-misc/cisco-vpnclient-3des
350
351 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
352 # Upstream dead for ages, numerous bubgs, uses old tcl (#445206).
353 # Removal in a month.
354 app-emulation/systemsim-cell
355
356 # Pacho Ramos <pacho@gentoo.org> (25 Dec 2012)
357 # Fails to build, always links statically (#448288). Removal in a month.
358 sys-block/gcloop
359
360 # Panagiotis Christopoulos <pchrist@gentoo.org> (25 Dec 2012)
361 # mask again these, temporarily, because more testing must be done.
362 >=dev-lisp/gentoo-init-1.0
363 >=dev-lisp/asdf-2.26
364 >=dev-lisp/sbcl-1.1.2
365
366 # Christian Ruppert <idl0r@gentoo.org> (22 Dec 2012)
367 # Experimental
368 =net-proxy/haproxy-1.5*
369
370 # Sven Wegener <swegener@gentoo.org> (21 Dec 2012)
371 # temporary mask for socket location change
372 =app-misc/screen-4.0.3-r8
373
374 # Rick Farina <zerochaos@gentoo.org> (21 Dec 2012)
375 # madwifi has been replaced by ath5k and ath9k in kernel
376 # drivers and is subject to numerous long standing bugs
377 # stable wpa_supplicant sometimes wants madwifi-ng-tools
378 #net-wireless/madwifi-ng-tools
379 net-wireless/madwifi-ng
380
381 # Julian Ospald <hasufell@gentoo.org> (20 Dev 2012)
382 # old and subject to removal
383 # version scheme collides with new release
384 =games-roguelike/tomenet-100310
385
386 # Anthony G. Basile <blueness@gentoo.org> (17 Dec 2012)
387 # Masked for removal in 30 days. (17 Jan 2012)
388 # This is provided by USE=xtended webalizer, bug #445226
389 app-admin/webalizer-xtended
390
391 # Michał Górny <mgorny@gentoo.org> (07 Dec 2012)
392 # Experimental version disabling XDM-AUTHENTICATION-1 (in favor
393 # of MIT-MAGIC-COOKIE-1). It should fix bug #306223 but it can also
394 # raise unknown issues. Bug #445662 for more details.
395 =x11-apps/xdm-1.1.11-r2
396
397 # Alexandre Rostovtsev <tetromino@gentoo.org> (05 Dec 2012)
398 # Masked for removal in 30 days.
399 # Incompatible with recent cogl and clutter versions (bug #435164)
400 mail-client/claws-mail-geolocation
401 <media-libs/libchamplain-0.9
402 <media-libs/clutter-gtk-1.0
403
404 # Sebastian Pipping <sping@gentoo.org> (27 Nov 2012)
405 # Masked for removal in 30 days.
406 # Licensing issues, turned out not distributable (bug #444332)
407 app-admin/profiler
408
409 # Sebastian Pipping <sping@gentoo.org> (27 Nov 2012)
410 # Masked for removal in 30 days.
411 # Server and software development discontinued upstream (bug #438082)
412 app-admin/smolt
413
414 # Tim Harder <radhermit@gentoo.org> (27 Nov 2012)
415 # Masked for testing
416 =media-libs/libsfml-2*
417
418 # Pacho Ramos <pacho@gentoo.org> (24 Nov 2012)
419 # Doesn't build with current kernels (#351225), some work is done
420 # by Ubuntu users but a lot of mantainance work is still needed
421 # and nobody will take care of it now (#351225#c7).
422 # Looks like a proxy maintainer is working on this...
423 net-dialup/hsfmodem
424
425 # Richard Freeman <rich0@gentoo.org> (24 Nov 2012)
426 # Live ebuild.
427 =app-misc/sleepyhead-9999
428
429 # Robin H. Johnson <robbat2@gentoo.org> (18 Nov 2012)
430 # Dead upstream, replaced by gitolite
431 dev-vcs/gitosis
432 dev-vcs/gitosis-gentoo
433
434 # Ole Markus With <olemarkus@gentoo.org> (15 Nov 2012)
435 # Masked for testing
436 >=dev-lang/php-5.4.9999
437
438 # Diego Elio Pettenò <flameeyes@gentoo.org> (14 Nov 2012)
439 # Masked for testing as too many packages fail.
440 # See bug #443230 for tracking the progress
441 =media-video/libav-9.1*
442 ~virtual/ffmpeg-9
443
444 # Joerg Bornkessel <hd_brummy@gentoo.org> (04 Nov 2012)
445 # masked for testing, bug #422605
446 =media-plugins/vdr-softdevice-0.5.0.20110417
447
448 # Markos Chandras <hwoarang@gentoo.org> (03 Nov 2012)
449 # Masked for testing
450 app-benchmarks/ltp
451
452 # Ulrich Müller <ulm@gentoo.org> (02 Nov 2012)
453 # Emacs live ebuilds. Use at your own risk.
454 ~app-editors/emacs-vcs-24.2.9999
455 ~app-editors/emacs-vcs-24.3.9999
456
457 # Alexis Ballier <aballier@gentoo.org> (1 Nov 2012)
458 # Still requires ocaml-3, mask it until it is ported. If this does not happen in
459 # the near future, we should consider removing it.
460 dev-ml/ocamlduce
461
462 # Diego Elio Pettenò <flameeyes@gentoo.org> (1 Nov 2012)
463 # See tracker bug #440342. Will probably require GNOME 3.6 to be
464 # unmasked first.
465 =dev-libs/libtasn1-3*
466
467 # Sébastien Fabbro <bicatali@gentoo.org> (31 Oct 2012)
468 # live ebuild
469 =sys-fs/redirfs-9999
470
471 # Gilles Dartiguelongue <eva@gentoo.org> (25 Oct 2012)
472 # Too broken to be used but adding for testing purpose (bug #438560)
473 =media-sound/rhythmbox-2.98
474
475 # Pacho Ramos <pacho@gentoo.org> (25 Oct 2012)
476 # obexd changed its API without any warning, it's recommended to ship
477 # 0.46 until https://bugzilla.gnome.org/682106 is fixed to prevent
478 # bluetooth-sendto breakage.
479 >=app-mobilephone/obexd-0.47
480
481 # Eray Aslan <eras@gentoo.org> (24 Oct 2012)
482 # Mask experimental software
483 =mail-client/squirrelmail-1.4.23*
484
485 # Sergey Popov <pinkbyte@gentoo.org> (22 Oct 2012)
486 # Mask net-misc/libteam snapshot ebuilds until release
487 net-misc/libteam
488
489 # Michael Palimaka <kensington@gentoo.org> (19 Oct 2012)
490 # New major release breaks almost all existing consumers.
491 # Masked until each package can update its dependencies.
492 >=net-libs/libotr-4.0.0
493 >=x11-plugins/pidgin-otr-4.0.0
494
495 # Tim Harder <radhermit@gentoo.org> (15 Oct 2012)
496 # Mask development releases
497 =media-libs/libraw-0.15*
498
499 # Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2012)
500 # Masked for testing
501 =sys-libs/db-5.3*
502 =sys-libs/db-5.2*
503 =sys-libs/db-5.1*
504 =sys-libs/db-5.0*
505
506 # Richard Yao <ryao@gentoo.org> (06 Oct 2012)
507 # sys-apps/grep-2.13 falsely reports some files as binary, causing build
508 # failures. Bug #425668
509 =sys-apps/grep-2.13
510
511 # Tim Harder <radhermit@gentoo.org> (01 Sep 2012)
512 # Mask development releases
513 =media-sound/lilypond-2.17*
514
515 # Markos Chandras <hwoarang@gentoo.org> (17 August 2012)
516 # Masked for testing. Required by dev-lang/jimctl-0.73
517 =dev-embedded/openocd-0.6.1
518
519 # Benedikt Böhm <hollow@gentoo.org> (11 Aug 2012)
520 # Regression in iproute code, does not detect IP addresses correctly anymore.
521 ~dev-ruby/ohai-6.14.0
522
523 # Jeroen Roovers <jer@gentoo.org> (2 Aug 2012)
524 # Development version
525 >app-admin/sysstat-10.1
526
527 # Ralph Sennhauser <sera@gentoo.org> (18 Jul 2012)
528 # Unmaintained, multiple vulnarabilities. #351626
529 # A more recent source build maintained by the community is available in the
530 # seden overlay. A more recent binary is available in the java-overlay.
531 <=dev-util/eclipse-sdk-3.5.1-r1
532
533 # Michael Weber <xmw@gentoo.org> (07 Jul 2012)
534 # Masked for testing only beta (bug 424866)
535 =sci-electronics/eagle-6.2.1_beta
536
537 # Michael Weber <xmw@gentoo.org> (29 Jun 2012)
538 # Masking for security reasons (bug 424025, CVE-2012-3366)
539 # Users of trigger plugin, update asap.
540 <app-admin/bcfg2-1.2.2-r1
541
542 # Andreas K. Huettel <dilfridge@gentoo.org> (25 Jun 2012)
543 # Mask live ebuild
544 =net-print/cups-9999
545
546 # Maxim Koltsov <maksbotan@gentoo.org> (21 Jun 2012)
547 # It's not what it's called now, mask it not protect people
548 =dev-util/febootstrap-3*
549
550 # Ian Stakenvicius <axs@gentoo.org> (19 Jun 2012)
551 # Mask new spidermonkey until rdeps can accept it
552 ~dev-lang/spidermonkey-1.8.7
553
554 # Michael Weber <xmw@gentoo.org> (13 Jun 2012)
555 # Mask beta versions for testing
556 >sci-electronics/magic-8
557 >sci-electronics/xcircuit-3.8
558
559 # Justin Lecher <jlec@gentoo.org> (13 Jun 2012)
560 # Justin Lecher <jlec@gentoo.org> (01 Nov 2012)
561 # Mask old version numbers
562 # Shows newest unstable to users easily
563 >=sci-biology/ncbi-tools-20080302
564 >=sci-chemistry/dssp-070831
565 >=sci-biology/ncbi-tools++-2010.06.15
566
567 # Patrick Lauer <patrick@gentoo.org> (06 Jun 2012)
568 # Temporarily mask nginx >=1.3 see #411937
569 >=www-servers/nginx-1.3
570
571 # Markos Chandras <hwoarang@getnoo.org> (27 May 2012)
572 # Mask alpha release
573 =sci-electronics/qelectrotech-0.30_alpha*
574
575 # Alexis Ballier <aballier@gentoo.org> (26 May 2012)
576 # API/ABI has changed with this release.
577 # Mask until the tree is fine.
578 # https://bugs.gentoo.org/show_bug.cgi?id=417677
579 >=media-video/ffmpeg-0.11
580
581 # Benda Xu <heroxbd@gentoo.org> (20 May 2012)
582 # geant-4.9.5_p01 has a major class declaration change that renders
583 # geant-python (g4py upstream) unable to compile
584 # upstream bug http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1317
585 =sci-physics/geant-python-4.9.5_p01
586
587 # Alexandre Rostovtsev <tetromino@gentoo.org> (20 May 2012)
588 # Requires dev-scheme/guile-2.0.5 which is in lisp overlay and masked;
589 # bug #416683
590 >=games-board/aisleriot-3.3.1
591
592 # Ultrabug <ultrabug@gentoo.org> (16 May 2012)
593 # Masked for testing
594 >=sys-cluster/corosync-2.0.0
595
596 # Alistair Bush <ali_bush@gentoo.org> (10 May 2012)
597 # Mask alpha version of mono for testing
598 >=dev-lang/mono-2.11.1
599 >=dev-lang/mono-tools-2.11
600 >=virtual/monodoc-2.11
601
602 # Johannes Huber <johu@gentoo.org> (03 May 2012)
603 # Unstable dev channel release. Fixes build with gcc47
604 # (bug #413941).
605 >=media-sound/mp3diags-1.1
606
607 # Robin H. Johnson <robbat2@gentoo.org> (09 Feb 2012)
608 # Needs to be slotted better
609 =dev-libs/yaz-4*
610
611 # Maxim Koltsov <maksbotan@gentoo.org> (19 Apr 2012)
612 # Broken, masking by maintainer's request
613 net-ftp/leechcraft-lcftp
614 net-p2p/leechcraft-eiskaltdcpp
615
616 # Jeroen Roovers <jer@gentoo.org> (04 Apr 2012)
617 # Alpha versions of dev-libs/libevent are considered unstable
618 >dev-libs/libevent-2.1
619
620 # Andreas K. Huettel <dilfridge@gentoo.org> (22 Mar 2012)
621 # Even its author admits that it's an ugly hack. Crashes e.g.
622 # firefox with kde-4.8. Unmask at your own risk.
623 kde-misc/kgtk
624
625 # Samuli Suominen <ssuominen@gentoo.org> (06 Mar 2012)
626 # Masked for testing since this is known to break nearly
627 # every reverse dependency wrt bug 407091
628 >=dev-lang/lua-5.2.0
629
630 # Sébastien Fabbro <bicatali@gentoo.org> (26 Feb 2012)
631 # Needs development version x11-libs/wxGTK
632 >=sci-visualization/fityk-1.1
633
634 # Michał Górny <mgorny@gentoo.org> (21 Jan 2012)
635 # Blocks sysvinit yet doesn't provide all tools provided by it.
636 # Masking until we get the necessary tools out of sysvinit.
637 sys-apps/systemd-sysv-utils
638
639 # Eray Aslan <eras@gentoo.org> (19 Jan 2012)
640 # Mask experimental software
641 =mail-mta/postfix-2.10*
642
643 # Jeroen Roovers <jer@gentoo.org> (27 Mar 2012)
644 # Opera Next and Opera snapshots are unsupported and eternally unstable.
645 # <http://my.opera.com/desktopteam/blog>
646 www-client/opera-next
647
648 # Ulrich Mueller <ulm@gentoo.org> (13 Dec 2011)
649 # SLOTs 21 and 22 of app-editors/emacs, corresponding to
650 # GNU Emacs versions 21.4 and 22.3. These versions were
651 # released in February 2005 and September 2008, respectively.
652 # Please upgrade to >=app-editors/emacs-23 and update your
653 # Emacs Lisp packages with emacs-updater.
654 # Keeping these versions in the tree masked indefinitely,
655 # by popular request. Bug 394589.
656 =app-editors/emacs-21*
657 =app-editors/emacs-22*
658 <virtual/emacs-23
659
660 # Christoph Junghans <ottxor@gentoo.org> (15 Nov 2011)
661 # current version of google-talkplugin never clear what you get
662 =www-plugins/google-talkplugin-9999
663
664 # Diego E. Pettenò <flameeyes@gentoo.org> (30 Oct 2011)
665 # Working on more reliable versioning, consider experimental for now.
666 >=dev-lang/luajit-2.0.0_beta8
667
668 # Samuli Suominen <ssuominen@gentoo.org> (30 Oct 2011)
669 # Masked for security bug #294253, use only at your own risk!
670 =media-libs/fmod-3*
671 games-puzzle/candycrisis
672 games-simulation/stoned-bin
673 games-sports/racer-bin
674 games-strategy/dark-oberon
675 games-strategy/savage-bin
676
677 # MATSUU Takuto <matsuu@gentoo.org> (27 Oct 2011)
678 # Mask for testing
679 >=sys-devel/distcc-3.2_rc1
680
681 # Justin Bronder <jsbronder@gentoo.org> (27 Sep 2011)
682 # Masking the torque 2.3 series due to bug #372959. This allows
683 # sites that are ok with the vulnerability but prefer the stability
684 # of 2.3.x to continue to get updates (if any).
685 <sys-cluster/torque-2.4
686 dev-perl/perl-PBS
687
688 # Joerg Bornkessel <hd_brummy@gentoo.org> (17 Sep 2011)
689 # media-video/vdr-xvdr-9999, masked git live ebuild
690 =media-plugins/vdr-xvdr-9999
691
692 # Alexis Ballier <aballier@gentoo.org> (20 Aug 2011)
693 # dev-tex/pdftex-1.40.11 is 100% identical to the one in TeX Live 2010;
694 # TeX Live 2011 has a newer version, which makes the standalone package useless;
695 # mask it for now, we'll see about removing it later.
696 dev-tex/pdftex
697
698 # Robin H. Johnson <robbat2@gentoo.org> (01 Nov 2012)
699 # Update of mask to 5.6 instead of 5.5
700 # Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (28 Jul 2011)
701 # A new update of the mysql / mariadb mask
702 # Robin H. Johnson <robbat2@gentoo.org> (01 Feb 2010)
703 # Mask 5.6/6.0 series that are alpha and and crazy experimental.
704 # Mask 5.2/5.3 virtual that exists in the overlay as well (it is MariaDB only)
705 >=dev-db/mariadb-5.6
706 >=dev-db/mysql-5.6
707 >=virtual/mysql-5.6
708 =dev-db/mariadb-5.2*
709 =virtual/mysql-5.2*
710 =dev-db/mariadb-5.3*
711 =virtual/mysql-5.3*
712
713 # Peter Volkov <pva@gentoo.org> (23 Jul 2011)
714 # Mask release candidates
715 =dev-libs/guiloader-2.99.0
716 =dev-libs/guiloader-c++-2.99.0
717 =dev-util/crow-designer-2.99.0
718
719 # Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (15 July 2011)
720 # Masking mariadb-5.1.55 until we have feedback about the unit tests
721 # as they build for me but fail for Robin
722 ~dev-db/mariadb-5.1.55
723
724 # Justin Lecher <jlec@gentoo.org> (27 Jun 2011)
725 # Only avalable version isn't in the tree.
726 # Mask until it is bumped
727 sci-chemistry/webmo
728
729 # Torsten Veller <tove@gentoo.org> (18 Jun 2011)
730 # Mask perl-5.14. See tracker bug #356171
731 =dev-lang/perl-5.14*
732
733 # Hans de Graaff <graaff@gentoo.org> (15 May 2011)
734 # Mask new versions until thread-related crashes have been fixed.
735 # See bug 367423.
736 =dev-lang/ruby-enterprise-1.8.7.2011.03
737 =dev-lang/ruby-enterprise-1.8.7.2012.02
738
739 # Alexis Ballier <aballier@gentoo.org> (20 Apr 2011)
740 # Tiziano Müller <dev-zero@gentoo.org> (11 Aug 2010)
741 # Breaks net-voip/sflphone, non maintainer update, but is needed by
742 # media-video/ffmpeg
743 >=media-libs/celt-0.8.1
744
745 # Marijn Schouten <hkBst@gentoo.org> (07 April 2011)
746 # Masked for number of issues, but can be used to
747 # test against if people are impatient ;P
748 # Known issues:
749 # - Broken emacs support (ulm has promised to look)
750 # - doesn't build when boehm-gc is built without threads
751 # - no SLOTting yet!
752 =dev-scheme/guile-2.0.0
753
754 # Ryan Hill <dirtyepic@gentoo.org> (02 Apr 2011)
755 # Masked for testing
756 >=sys-devel/gcc-4.7.0
757 >=sys-devel/kgcc64-4.7.0
758 >=dev-java/gcj-jdk-4.7.0
759
760 # Christian Faulhammer <fauli@gentoo.org> (12 Mar 2011)
761 # Mask for testing
762 >=www-apps/joomla-1.6.0
763
764 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
765 # Masked indefinitely (until 0.40 is released).
766 # http://bugs.gentoo.org/354423
767 >=app-pda/libopensync-0.30
768 >=app-pda/libopensync-plugin-file-0.30
769 >=app-pda/libopensync-plugin-irmc-0.30
770 >=app-pda/libopensync-plugin-palm-0.30
771 >=app-pda/libopensync-plugin-python-0.30
772 app-pda/libopensync-plugin-syncml
773 app-pda/libopensync-plugin-vformat
774 app-pda/osynctool
775
776 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
777 # Work in progress
778 # http://bugs.gentoo.org/show_bug.cgi?id=354423
779 app-pda/libopensync-plugin-evolution2
780 app-pda/libopensync-plugin-gnokii
781 app-pda/libopensync-plugin-gpe
782 app-pda/multisync-gui
783
784 # Ryan Hill <dirtyepic@gentoo.org> (22 Jan 2011)
785 # Mask development versions due to unstable API
786 # as requested by leio
787 >=dev-python/wxpython-2.9
788 >=x11-libs/wxGTK-2.9
789
790 # Michael Sterrett <mr_bones_@gentoo.org> (20 Jan 2010)
791 # testing mask for upcoming exult release
792 >=games-engines/exult-1.3
793
794 # Torsten Veller <tove@gentoo.org> (06 Jan 2011)
795 # Next step to remove old perl and libperl versions.
796 # Versions prior 5.12 are masked and will be removed when 5.14 is available.
797 # If you are a sparc-fbsd user and your only keyworded perl version was masked,
798 # test perl-5.12.2 and reply to bug 288028
799 # For other complaints go to bug 350785
800 <dev-lang/perl-5.12.2
801 <sys-devel/libperl-5.10.1
802
803 # Gilles Dartiguelongue <eva@gentoo.org> (07 Dec 2010)
804 # Part of GNOME 2.32 release set by breaks my machine as hell
805 # Needs more testing before unleashing
806 >=gnome-base/libbonobo-2.32
807
808 # Markos Chandras <hwoarang@gentoo.org> (01 Nov 2010)
809 # Masking alpha releases
810 net-analyzer/ncrack
811
812 # Peter Volkov <pva@gentoo.org> (29 Oct 2010)
813 # mask beta release
814 =net-analyzer/tcpreplay-3.4.5*
815
816 # Markos Chandras <hwoarang@gentoo.org> (26 Oct 2010)
817 # master branch is heavily broken at the moment. Use
818 # 2.0.9999 instead if you want a kmess
819 # that actually builds
820 =net-im/kmess-9999
821
822 # Luca Barbato <lu_zero@gentoo.org> (21 Jul 2010)
823 # Not ready for public consumption, clashes with current mesa-git
824 media-libs/shivavg
825
826 # Stefan Briesenick <sbriesen@gentoo.org> (21 Jul 2010)
827 # doesn't compile against latest media-libs/spandsp.
828 # not needed anymore for Asterisk 1.6.
829 net-misc/asterisk-spandsp_codec_g726
830
831 # Doug Goldstein <cardoe@gentoo.org> (07 Jul 2010)
832 # No actual Gentoo support yet. If you're interested, please see bug #295993
833 net-misc/netcf
834
835 # Justin Lecher <jlec@gentoo.org> (16 Jun 10)
836 # Just working with the masked experimental version of refmac
837 >=sci-libs/monomer-db-5.16
838
839 # Robin H. Johnson <robbat2@gentoo.org> (09 Jun 2010)
840 # Fails to self-verify/sign in FIPS mode, pending upstream response before
841 # usage for GSoC project.
842 app-crypt/hmaccalc
843
844 # Luca Barbato <lu_zero@gentoo.org> (21 May 2010)
845 # development release
846 =dev-db/mongodb-1.5*
847
848 # Justin Lecher <jlec@gentoo.org> (16 May 2010)
849 # Upstreams testing version
850 # Added on request
851 >=sci-chemistry/refmac-5.6
852
853 # Patrick Lauer <patrick@gentoo.org> (07 Apr 2010)
854 # Keeping samba-4 masked until release.
855 >net-fs/samba-4
856
857 # Mike Frysinger <vapier@gentoo.org> (07 Mar 2010)
858 # Very old packages that people should have upgraded away from
859 # long ago. Courtesy mask ... time to upgrade.
860 # Added <sys-fs/e2fsprogs as well (halcy0n)
861 <sys-libs/e2fsprogs-libs-1.41.8
862 <sys-fs/e2fsprogs-1.41.9
863
864 # Robert Piasek <dagger@gentoo.org> (23 Feb 2010)
865 # Masking libmapi as it depends on masked samba4
866 >=net-libs/libmapi-0.9
867
868 # Christian Parpart <trapni@gentoo.org> (23 Dec 2009)
869 # Masked for testing/feedback.
870 media-sound/teamspeak-server-bin
871
872 # Joerg Bornkessel <hd_brummy@gentoo.org> (02 Dec 2009)
873 # cvs ebuild vdr-xineliboutput-9999 masked for lifetime
874 =media-plugins/vdr-xineliboutput-9999
875
876 # Peter Alfredsen <loki_val@gentoo.org> (21 Oct 2009)
877 # Masked because this needs a patch to be applied to portage
878 # to not install the kitchensink and everything else
879 # into /usr/src/debug with FEATURES=installsources
880 =dev-util/debugedit-4.4.6-r2
881
882 # Diego E. Pettenò <flameeyes@gmail.com> (09 Oct 2009)
883 # Untested yet; documented only in Russian, help is appreciated.
884 sys-auth/pam_keystore
885
886 # Diego E. Pettenò <flameeyes@gentoo.org> (08 Aug 2009)
887 # on behalf of QA Team
888 #
889 # Mass-masking of live ebuilds; we cannot guarantee working state of
890 # live ebuilds, nor the availability of the server hosting them. As
891 # per QA team policy, all these need to be kept masked by default, if
892 # available in the tree.
893 ~app-i18n/skk-jisyo-9999
894 net-misc/netcomics-cvs
895 app-portage/layman-dbtools
896 sci-astronomy/casa-data
897 # rdep on the one above
898 sci-astronomy/casacore
899 sci-electronics/kicad
900 dev-ruby/rcsparse
901 # rdep on the one above
902 dev-vcs/fromcvs
903 sci-biology/picard
904 ~dev-libs/libg15-9999
905
906 # Federico Ferri <mescalinum@gentoo.org> (08 Aug 2009)
907 # Doesn't build with Tcl 8.5, has several bugs open
908 =dev-tcltk/tcl-debug-2.0
909
910 # Marijn Schouten <hkBst@gentoo.org> (29 Jul 2009)
911 # Masked for increasingly many problems. Upstream is flaky and hasn't released since 2005.
912 # Maxima is the only consumer and can be built with sbcl or clisp.
913 # Hopefully upstream will do a release that we can add to revive this package.
914 dev-lisp/gcl
915
916 # Jeremy Olexa <darkside@gentoo.org> (28 Jul 2009)
917 # On behalf of Robin H. Johnson <robbat2@gentoo.org>.
918 # These versions are vulnerable to GLSA's and should not be used. They will stay
919 # in the tree because they are useful to tracking down bugs. You have been
920 # warned. bug 271686
921 <dev-db/mysql-5.1.56
922 <virtual/mysql-5.1
923
924 # Nirbheek Chauhan <nirbheek@gentoo.org> (10 Jun 2009)
925 # Several feature regressions that will make our users
926 # go on a witchhunt if unmasked
927 # * No XDMCP connection UI
928 # * No configuration/theming support
929 # * No support for auth backends other than PAM
930 # * Many more...
931 =gnome-base/gdm-2.3*
932
933 # Tiziano Müller <dev-zero@gentoo.org> (08 Apr 2009)
934 # pre-releases
935 net-libs/libinfinity
936 >=app-editors/gobby-0.4.91
937
938 # Paul Varner <fuzzyray@gentoo.org> (06 Apr 2009)
939 # Dead upstream and has issues with newer portages.
940 # Due to popular demand and no suitable replacement, it will stay in the tree
941 # in a masked status until it completely breaks or is replaced.
942 app-portage/udept
943
944 # Diego E. Pettenò <flameeyes@gentoo.org> (03 Jan 2009)
945 # These packages are not supposed to be merged directly, instead
946 # please use sys-devel/crossdev to install them.
947 dev-libs/cygwin
948 dev-util/mingw-runtime
949 dev-util/mingw64-runtime
950 dev-util/w32api
951 sys-libs/newlib
952 dev-embedded/msp430-binutils
953 dev-embedded/msp430-gcc
954 dev-embedded/msp430-gdb
955 dev-embedded/msp430-libc
956 dev-embedded/msp430mcu
957 dev-embedded/avr-libc
958
959 # Peter Volkov <pva@gentoo.org> (16 Nov 2008)
960 # The development branch, to be unmasked when out of beta by upstream.
961 =net-misc/socat-2.0.0*
962
963 # Steve Dibb <beandog@gentoo.org> (05 Nov 2008)
964 # Mask realplayer codecs for security bug 245662
965 media-libs/amd64codecs
966 media-libs/realcodecs
967
968 # Doug Goldstein <cardoe@gentoo.org> (17 Sep 2008)
969 # under development
970 gnome-extra/gnome-lirc-properties
971
972 # Markus Ullmann <jokey@gentoo.org> (07 Jul 2008)
973 # mask for security bug #190667 (CVE-2007-{4584,5839})
974 # and for various other build problems (bug #425634)
975 #
976 # both CVEs are fixed in upstream version control as per:
977 # http://bitchx.svn.sourceforge.net/svnroot/bitchx/trunk/Changelog
978 net-irc/bitchx
979
980 # Vlastimil Babka <caster@gentoo.org> (20 May 2008)
981 # Masked for testing
982 app-arch/rpm5
983
984 # Chris Gianelloni <wolf31o2@gentoo.org> (03 Mar 2008)
985 # Masking due to security bug #194607 and security bug #204067
986 games-fps/doom3
987 games-fps/doom3-cdoom
988 games-fps/doom3-chextrek
989 games-fps/doom3-data
990 games-fps/doom3-demo
991 games-fps/doom3-ducttape
992 games-fps/doom3-eventhorizon
993 games-fps/doom3-hellcampaign
994 games-fps/doom3-inhell
995 games-fps/doom3-lms
996 games-fps/doom3-mitm
997 games-fps/doom3-phantasm
998 games-fps/doom3-roe
999 games-fps/quake4-bin
1000 games-fps/quake4-data
1001 games-fps/quake4-demo
1002
1003 # Piotr Jaroszyński <peper@gentoo.org> (26 Nov 2007)
1004 # opensync live ebuilds
1005 =app-pda/libsyncml-9999
1006 =app-pda/libopensync-9999
1007 =app-pda/osynctool-9999
1008 =app-pda/libopensync-plugin-evolution2-9999
1009 =app-pda/libopensync-plugin-file-9999
1010 =app-pda/libopensync-plugin-gnokii-9999
1011 =app-pda/libopensync-plugin-gpe-9999
1012 =app-pda/libopensync-plugin-irmc-9999
1013 =app-pda/libopensync-plugin-palm-9999
1014 =app-pda/libopensync-plugin-python-9999
1015 =app-pda/libopensync-plugin-syncml-9999
1016 =app-pda/libopensync-plugin-vformat-9999
1017
1018 # MATSUU Takuto <matsuu@gentoo.org> (05 Apr 2007)
1019 # to be tested, seems unstable
1020 >=app-i18n/scim-anthy-1.3.0
1021
1022 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
1023 # masked pending unresolved security issues #127167
1024 games-roguelike/slashem
1025
1026 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
1027 # masked pending unresolved security issues #125902
1028 games-roguelike/nethack
1029 games-util/hearse
1030
1031 # Robin H. Johnson <robbat2@gentoo.org> (11 Feb 2006)
1032 # zlib interaction is badly broken. See bug #124733.
1033 =dev-vcs/cvs-1.12.13*
1034
1035 # <klieber@gentoo.org> (01 Apr 2004)
1036 # The following packages contain a remotely-exploitable
1037 # security vulnerability and have been hard masked accordingly.
1038 #
1039 # Please see http://bugs.gentoo.org/show_bug.cgi?id=44351 for more info
1040 #
1041 games-fps/unreal-tournament-goty
1042 games-fps/unreal-tournament-strikeforce
1043 games-fps/unreal-tournament-bonuspacks
1044 games-fps/aaut

  ViewVC Help
Powered by ViewVC 1.1.20