/[gentoo-x86]/profiles/package.mask
Gentoo

Contents of /profiles/package.mask

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.14505 - (show annotations) (download)
Tue Feb 26 07:25:09 2013 UTC (21 months, 4 weeks ago) by mgorny
Branch: MAIN
Changes since 1.14504: +7 -1 lines
Temporarily mask new fontconfig & freetype because of USE=utils being broken.

1 ####################################################################
2 # $Header: /var/cvsroot/gentoo-x86/profiles/package.mask,v 1.14504 2013/02/25 15:09:24 lu_zero Exp $
3 #
4 # When you add an entry to the top of this file, add your name, the date, and
5 # an explanation of why something is getting masked. Please be extremely
6 # careful not to commit atoms that are not valid, as it can cause large-scale
7 # breakage, especially if it ends up in the daily snapshot.
8 #
9 ## Example:
10 ##
11 ## # Dev E. Loper <developer@gentoo.org> (28 Jun 2012)
12 ## # Masking these versions until we can get the
13 ## # v4l stuff to work properly again
14 ## =media-video/mplayer-0.90_pre5
15 ## =media-video/mplayer-0.90_pre5-r1
16 #
17 # - Best last rites (removal) practices -
18 # Include the following info:
19 # a) reason for masking
20 # b) bug # for the removal (and yes you should have one)
21 # c) date of removal (either the date or "in x days")
22 # d) the word "removal"
23 #
24 ## Example:
25 ##
26 ## Dev E. Loper <developer@gentoo.org> (25 Jan 2013)
27 ## Masked for removal in 30 days. Doesn't work
28 ## with new libfoo. Upstream dead, gtk-1, smells
29 ## funny. (bug #987654)
30 ## app-misc/some-package
31
32 #--- END OF EXAMPLES ---
33
34 # Michał Górny <mgorny@gentoo.org> (26 Feb 2013)
35 # Building freetype with USE=utils is broken. Masking until I fix it.
36 # Bug #455070.
37 =media-libs/fontconfig-2.10.2-r1
38 =media-libs/freetype-2.4.11-r1
39
40 # Doug Goldstein <cardoe@gentoo.org> (24 Feb 2013)
41 # Working on the next stable patchset
42 =app-emulation/qemu-1.2.2-r4
43
44 # Markos Chandras <hwoarang@gentoo.org> (24 Feb 2013)
45 # Not functional as cia.vc is gone
46 # No maintainer, dead upstream, last bump in 2005
47 # See #445644. Removal in 30 days
48 dev-util/ciabot-svn
49
50 # Mike Gilbert <floppym@gentoo.org> (23 Feb 2013)
51 # Uses deprecated version of dev-db/sqlite.
52 # Removal in 30 days.
53 dev-python/pysqlite:0
54
55 # Dion Moult <moult@gentoo.org> (23 Feb 2013)
56 # Crashing with promises for a next version which never came
57 # See bug #457832
58 # Masked for removal in 30 days, on 2013-03-23
59 net-misc/wxdfast
60
61 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (22 Feb 2013)
62 # Packages building against it still act funny
63 =net-libs/h323plus-1.25.0
64
65 # Jeroen Roovers <jer@gentoo.org> (22 Feb 2013)
66 # Masked until bug #456788 is fixed.
67 =net-analyzer/mtr-0.83
68
69 # Jeroen Roovers <jer@gentoo.org> (22 Feb 2013)
70 # Development versions of net-analyzer/wireshark
71 =net-analyzer/wireshark-1.9*
72
73 # Eray Aslan <eras@gentoo.org> (22 Feb 2013)
74 # Mask beta versions
75 =net-mail/dovecot-2.2_beta*
76
77 # Justin Lecher <jlec@gentoo.org> (21 Feb 2013)
78 # Temporary mask, because compatibility with recent tcl is not proven
79 =dev-tcltk/tcllib-1.15
80
81 # Michael Sterrett <mr_bones_@gentoo.org> (18 Feb 2013)
82 # Quite dead. Use games-engines/stratagus instead.
83 # Masked for removal on 20130320.
84 games-strategy/freecraft
85
86 # Eray Aslan <eras@gentoo.org> (18 Feb 2013)
87 # Mask beta versions
88 =mail-filter/opendkim-2.8.0_beta*
89
90 # Davide Pesavento <pesa@gentoo.org> (17 Feb 2013)
91 # Mask beta version for testing.
92 =dev-util/qt-creator-2.7.0_beta*
93
94 # Markos Chandras <hwoarang@gentoo.org> (17 Feb 2013)
95 # Does not build with libav-0.8
96 =media-video/qx11grab-0.4.7
97
98 # Rick Farina <zerochaos@gentoo.org> (15 Feb 2013)
99 # these firmware packages have been merged into the sys-kernel/linux-firmware
100 # package. USE=savedconfig can be used to limit the firmware which gets installed.
101 # removal on 18 March 2013
102 sys-firmware/iwl3945-ucode
103 sys-firmware/iwl4965-ucode
104
105 # Alexis Ballier <aballier@gentoo.org> (15 Feb 2013)
106 # Starting from this version, some decoders and encoders (like AAC or APE)
107 # switched to outputing or needing planar audio, this breaks some applications
108 # at runtime and the tree needs to be checked. For instance, <xbmc-12,
109 # <vlc-2.0.6 break.
110 >=media-video/ffmpeg-1.1
111
112 # Michael Sterrett <mr_bones_@gentoo.org> (13 Feb 2013)
113 # No longer licensed for sale upstream.
114 # Masked for removal on 20130315.
115 games-strategy/x2
116 games-strategy/x2-demo
117
118 # Eray Aslan <eras@gentoo.org> (13 Feb 2013)
119 # Mask experimental software
120 =mail-mta/postfix-2.11*
121
122 # Ian Delaney <idella4@gentoo.org> (12 Feb 2013)
123 # This is a work in progress targeting an old bug
124 # but followed by very keen users. It will be either
125 # abandonned or implemented down the track pending further support
126 =app-emulation/xen-tools-4.2.1-r2
127
128 # Samuli Suominen <ssuominen@gentoo.org> (11 Feb 2013)
129 # The 3 files from this package are part of the linux-firmware
130 # package now. Removal in 30 days.
131 media-tv/cx18-firmware
132
133 # Hans de Graaff <graaff@gentoo.org> (11 Feb 2013)
134 # No longer supported upstream even for security bugs.
135 # Port your application to another version of Rails.
136 # The Rails 3.0 version in the tree has security issues
137 # and no new 3.0 versions will be released anymore.
138 # Removal in 30 days.
139 dev-ruby/rails:3.0
140 dev-ruby/railties:3.0
141 dev-ruby/activerecord:3.0
142 dev-ruby/actionmailer:3.0
143 dev-ruby/actionpack:3.0
144 dev-ruby/activeresource:3.0
145 dev-ruby/activemodel:3.0
146 dev-ruby/activesupport:3.0
147 dev-ruby/arel:2.0
148 dev-ruby/i18n:0.5
149 dev-ruby/rack-mount:0.6
150 dev-ruby/rack-test:0.5
151 dev-ruby/mysql2:0.2
152
153 # Doug Goldstein <cardoe@gentoo.org> (10 Feb 2013)
154 # Use the in-kernel saa717x driver, available since at least 2.6.25
155 # Removal in 30 days
156 media-tv/ivtv
157
158 # Matt Turner <mattst88@gentoo.org> (10 Feb 2013)
159 # Use the in-kernel AT76C50X_USB driver.
160 # Removal in 30 days.
161 net-wireless/at76c503a
162
163 # Doug Goldstein <cardoe@gentoo.org> (10 Feb 2013)
164 # For most use cases you can unmask this and use this
165 # as there has been ample interested. This however breaks
166 # a number of features fundamental to me.
167 # * migration from previous versions is broken and migration
168 # to future versions is broken
169 # * snapshoting (blockcommit) is not safe/stable as it will
170 # report success when the write has not completed
171 # Upstream considers this series EOL and recommends 1.4
172 # which at the time of this writing is unreleased. So
173 # this is in the tree for people that want/need it but its masked.
174 =app-emulation/qemu-1.3.1
175
176 # Pacho Ramos <pacho@gentoo.org> (10 Feb 2013)
177 # Upstream dropped support for linux time ago (#434390),
178 # possible security issues (#360539). You can use Windows
179 # version with PlayOnLinux. Removal in a month.
180 media-gfx/picasa
181
182 # Pacho Ramos <pacho@gentoo.org> (10 Feb 2013)
183 # Abandoned by upstream, problems building (#362611).
184 # Removal in a month.
185 dev-python/papyon
186 net-voip/telepathy-butterfly
187
188 # Pacho Ramos <pacho@gentoo.org> (10 Feb 2013)
189 # Doesn't support kernel >= 2.6.22, #453202. Removal in a month.
190 x11-misc/xdaf
191
192 # Samuli Suominen <ssuominen@gentoo.org> (10 Feb 2013)
193 # The firmware cleanup, part #1. Can be unmasked after
194 # cleaning up the package if it's still needed.
195 # Some of these install to wrong directory, /lib64/firmware
196 # as opposed to correct /lib/firmware
197 # Some of these don't have maintainer
198 # Some of these are replaced by the firmware from the
199 # linux-firmware package:
200 # emerge -av linux-firmware
201 # If you still have a reason to keep the package, please
202 # let us know by filing a bug report.
203 # Removal in 30 days
204 net-wireless/ar9271-firmware
205 net-wireless/libertas-firmware
206 net-wireless/rt2860-firmware
207 net-wireless/rt2870-firmware
208 net-wireless/rt73-firmware
209 sys-firmware/rt61-firmware
210 net-wireless/i2400m-fw
211
212 # Samuli Suominen <ssuominen@gentoo.org> (10 Feb 2013)
213 # There is no license file available for prism54-firmware
214 # since it's been extracted from windows binary blob
215 # drivers. And this is for very old hardware.
216 # Removal in 30 days
217 net-wireless/prism54-firmware
218
219 # Rick Farina <zerochaos@gentoo.org> (10 Feb 2013)
220 # This firmware has been replaced by rtlwifi/*
221 # which is already in the linux-firmware package.
222 # Removal in 30 days
223 net-wireless/rtl8192su-firmware
224
225 # Ryan Hill <dirtyepic@gentoo.org> (07 Feb 2013)
226 # Breaks everything (bug #456108)
227 =dev-libs/openssl-1.0.1d
228
229 # Diego Elio Pettenò <flameeyes@gentoo.org> (05 Feb 2013)
230 # Needs a complete ebuild rewrite to use CMake, and a new patchset to
231 # unbundle the bundled libraries. Use at your own risk; don't ask for
232 # a bump unless you can provide the two needed items (see bug #364291).
233 media-gfx/blender
234
235 # Michael Sterrett <mr_bones_@gentoo.org> (31 Jan 2013)
236 # Old, dead upstream and require guile[deprecated]
237 # Masked for removal on 20130302
238 games-action/trackballs
239 games-misc/gnurobots
240
241 # Michael Sterrett <mr_bones_@gentoo.org> (31 Jan 2013)
242 # Upstream is dead and gone.
243 # Masked for removal on 20130302
244 games-arcade/bitefusion
245
246 # Rafael G. Martins <rafaelmartins@gentoo.org> (31 Jan 2013)
247 # Renamed to xombrero. Please install www-client/xombrero (bug #417555)
248 # The package was not pkg-moved to fix the upstream versioning mess.
249 # Removal in 30 days
250 www-client/xxxterm
251
252 # Michael Sterrett <mr_bones_@gentoo.org> (28 Jan 2013)
253 # Doesn't work with newer KDE and upstream seems dead (bug #453756)
254 # Masked for removal on 20130227
255 games-puzzle/kmagnet
256
257 # Samuli Suominen <ssuominen@gentoo.org> (28 Jan 2013)
258 # Uncompatible with current udev and baselayout
259 # Bug 220121 and the ones it Blocks
260 # Removal in 30 days
261 x11-misc/mkxf86config
262 <app-misc/livecd-tools-2.0
263
264 # Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jan 2013)
265 # Beta versions masked for testing
266 =net-misc/modemmanager-0.7*
267 =net-misc/networkmanager-0.9.7*
268
269 # Tim Harder <radhermit@gentoo.org> (27 Jan 2013)
270 # Masked due to deprecated API, use dev-python/PyGithub instead
271 # Removal in 30 days
272 dev-python/github2
273
274 # Diego Elio Pettenò <flameeyes@gentoo.org> (25 Jan 2013)
275 # Masked for testing
276 >=dev-libs/boost-1.53.0_beta1
277 >=dev-util/boost-build-1.53.0_beta1
278
279 # Doug Goldstein <cardoe@gentoo.org> (22 Jan 2013)
280 # Masked for development
281 =sys-block/open-iscsi-2.0.873
282
283 # Hans de Graaff <graaff@gentoo.org> (20 Jan 2013) Mask
284 # dev-lang/ruby-enterprise for removal, bug 453178. The current
285 # versions have minor security issues, the latest versions are masked
286 # and don't work, and upstream announced end-of-life almost a year
287 # ago. Ruby 1.9 has almost all of the benefits of REE, so the
288 # recommendation is to switch to that if you are still using REE.
289 dev-lang/ruby-enterprise
290 =virtual/rubygems-3
291 =virtual/ruby-rdoc-3
292 =virtual/ruby-ssl-3
293 =virtual/ruby-threads-3
294
295 # Ben de Groot <yngwin@gentoo.org> (20 Jan 2013)
296 # 2.5* has known security and other issues due to bundled ffmpeg,
297 # see (bugs #446468 and #444262)
298 # 2.6* is masked for testing, and may have unknown issues due to bundled ffmpeg
299 # This package needs a new, dedicated maintainer. We voted for keeping it in
300 # the tree for now, so users who are willing to accept the known issues can
301 # still easily install it by unmasking this.
302 media-video/avidemux
303
304 # Marien Zwart <marienz@gentoo.org>
305 # Patch tarball is broken, meaning this builds 1.2.0 (bug #452918)
306 =app-emulation/qemu-1.2.2-r1
307
308 # Mike Pagano <mpagano@gentoo.org>
309 # Mask for testing
310 >=app-portage/portpeek-2.1.6
311
312 # Mike Gilbert <floppym@gentoo.org (18 Jan 2013)
313 # Release made by unofficial maintainer. Drops support for Python 3 with
314 # very few improvements. Should be replaced by dev-python/charade eventually.
315 =dev-python/chardet-2.1.1
316
317 # Pacho Ramos <pacho@gentoo.org>
318 # Dead since 2003, doesn't work with journaling filesystems.
319 # Also collides with dev-util/smem (#288721). Removal in a month.
320 app-misc/secure-delete
321
322 # Pacho Ramos <pacho@gentoo.org>
323 # No upstream, doesn't work well (#350559). Removal in a month.
324 app-misc/ccal
325
326 # Pacho Ramos <pacho@gentoo.org>
327 # It's for kernel-2.4 only (#450594). Removal in a month.
328 sys-apps/i2c
329
330 # Michał Górny <mgorny@gentoo.org>
331 # Unmaintained and replaced by built-in sqlite3 module in Python.
332 # Masked for removal in 30 days, bug 452122.
333 >=dev-python/pysqlite-2
334
335 # Maciej Mrozowski <reavertm@gentoo.org>
336 # API change breaks packages, bug 449534.
337 >=app-text/poppler-0.22.0
338
339 # Alexis Ballier <aballier@gentoo.org>
340 # Not really compatible with TeX Live 2012, breaks texdoc, produces some non
341 # fatal errors in some documents, mask until fixed or TeX Live 2013 is out.
342 >=dev-tex/luatex-0.74
343
344 # Pawel Hajdan jr <phajdan.jr@gentoo.org> (14 Jan 2013)
345 # Dev channel releases are only for people who are developers or want more
346 # experimental features and accept a more unstable release.
347 >=www-client/chromium-26
348
349 # Pawel Hajdan jr <phajdan.jr@gentoo.org> (14 Jan 2013)
350 # Mask v8 versions used for www-client/chromium dev channel releases.
351 >=dev-lang/v8-3.16
352
353 # Mike Gilbert <floppym@gentoo.org> (13 Jan 2013)
354 # Dev channel releases are only for people who are developers or want more
355 # experimental features and accept a more unstable release.
356 >=www-client/google-chrome-26
357
358 # Tim Harder <radhermit@gentoo.org> (13 Jan 2013)
359 # Masked for testing
360 =mail-client/roundcube-0.9*
361
362 # Doug Goldstein <cardoe@gentoo.org> (12 Jan 2013)
363 # Under development
364 =app-emulation/qemu-1.3.0
365
366 # Jeroen Roovers <jer@gentoo.org> (09 Jan 2013)
367 # Testing branch, unstable upstream
368 >net-nntp/tin-2.1
369
370 # Torsten Veller <tove@gentoo.org> (08 Jan 2013)
371 # Mask dev-perl/Class-MOP. It was merge with dev-perl/Moose-2.
372 # Now as the last arch stabilized Moose-2, dev-perl/Class-MOP will be removed.
373 # bug #350612
374 dev-perl/Class-MOP
375
376 # Alexander Vershilov <qnikst@gentoo.org> (06 Jan 2013)
377 # Requires >=net-fs/samba-4 (bug #450226)
378 =sys-auth/sssd-1.9.4
379
380 # Sergei Trofimovich <slyfox@gentoo.org> (05 Jan 2013)
381 # Masked for testing. Is not compatible with cvsps-2 (bug #450424).
382 # But can be used on it's own! Try 'cvsps --fast-export'.
383 >=dev-vcs/cvsps-3
384
385 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (04 Jan 2013)
386 # Mask some prerelease x11 packages
387 =x11-base/xorg-server-1.13.99*
388 =x11-libs/libXi-1.6.99*
389 =x11-proto/inputproto-2.2.99*
390
391 # Sergei Trofimovich <slyfox@gentoo.org> (28 Dec 2012)
392 # Masked as needs masked version of wxGTK:2.9:
393 dev-haskell/wxc:2.9
394 dev-haskell/wxcore:2.9
395 dev-haskell/wxhaskell:2.9
396
397 # Panagiotis Christopoulos <pchrist@gentoo.org> (25 Dec 2012)
398 # mask again these, temporarily, because more testing must be done.
399 >=dev-lisp/gentoo-init-1.0
400 >=dev-lisp/asdf-2.26
401 >=dev-lisp/sbcl-1.1.2
402
403 # Christian Ruppert <idl0r@gentoo.org> (22 Dec 2012)
404 # Experimental
405 =net-proxy/haproxy-1.5*
406
407 # Sven Wegener <swegener@gentoo.org> (21 Dec 2012)
408 # temporary mask for socket location change
409 =app-misc/screen-4.0.3-r8
410
411 # Rick Farina <zerochaos@gentoo.org> (21 Dec 2012)
412 # madwifi has been replaced by ath5k and ath9k in kernel
413 # drivers and is subject to numerous long standing bugs
414 # stable wpa_supplicant sometimes wants madwifi-ng-tools
415 #net-wireless/madwifi-ng-tools
416 net-wireless/madwifi-ng
417
418 # Michał Górny <mgorny@gentoo.org> (07 Dec 2012)
419 # Experimental version disabling XDM-AUTHENTICATION-1 (in favor
420 # of MIT-MAGIC-COOKIE-1). It should fix bug #306223 but it can also
421 # raise unknown issues. Bug #445662 for more details.
422 =x11-apps/xdm-1.1.11-r2
423
424 # Tim Harder <radhermit@gentoo.org> (27 Nov 2012)
425 # Masked for testing
426 =media-libs/libsfml-2*
427
428 # Pacho Ramos <pacho@gentoo.org> (24 Nov 2012)
429 # Doesn't build with current kernels (#351225), some work is done
430 # by Ubuntu users but a lot of mantainance work is still needed
431 # and nobody will take care of it now (#351225#c7).
432 # Looks like a proxy maintainer is working on this...
433 net-dialup/hsfmodem
434
435 # Richard Freeman <rich0@gentoo.org> (24 Nov 2012)
436 # Live ebuild.
437 =app-misc/sleepyhead-9999
438
439 # Robin H. Johnson <robbat2@gentoo.org> (18 Nov 2012)
440 # Dead upstream, replaced by gitolite
441 dev-vcs/gitosis
442 dev-vcs/gitosis-gentoo
443
444 # Ole Markus With <olemarkus@gentoo.org> (15 Nov 2012)
445 # Masked for testing
446 >=dev-lang/php-5.4.9999
447
448 # Diego Elio Pettenò <flameeyes@gentoo.org> (14 Nov 2012)
449 # Masked for testing as too many packages fail.
450 # See bug #443230 for tracking the progress
451 =media-video/libav-9.1*
452 =media-video/libav-9.2*
453 ~virtual/ffmpeg-9
454
455 # Joerg Bornkessel <hd_brummy@gentoo.org> (04 Nov 2012)
456 # masked for testing, bug #422605
457 =media-plugins/vdr-softdevice-0.5.0.20110417
458
459 # Markos Chandras <hwoarang@gentoo.org> (03 Nov 2012)
460 # Masked for testing
461 app-benchmarks/ltp
462
463 # Ulrich Müller <ulm@gentoo.org> (02 Nov 2012)
464 # Emacs live ebuilds. Use at your own risk.
465 ~app-editors/emacs-vcs-24.2.9999
466 ~app-editors/emacs-vcs-24.3.9999
467
468 # Alexis Ballier <aballier@gentoo.org> (1 Nov 2012)
469 # Still requires ocaml-3, mask it until it is ported. If this does not happen in
470 # the near future, we should consider removing it.
471 dev-ml/ocamlduce
472
473 # Diego Elio Pettenò <flameeyes@gentoo.org> (1 Nov 2012)
474 # See tracker bug #440342. Will probably require GNOME 3.6 to be
475 # unmasked first.
476 =dev-libs/libtasn1-3*
477
478 # Sébastien Fabbro <bicatali@gentoo.org> (31 Oct 2012)
479 # live ebuild
480 =sys-fs/redirfs-9999
481
482 # Gilles Dartiguelongue <eva@gentoo.org> (25 Oct 2012)
483 # Too broken to be used but adding for testing purpose (bug #438560)
484 =media-sound/rhythmbox-2.98
485
486 # Pacho Ramos <pacho@gentoo.org> (25 Oct 2012)
487 # obexd changed its API without any warning, it's recommended to ship
488 # 0.46 until https://bugzilla.gnome.org/682106 is fixed to prevent
489 # bluetooth-sendto breakage.
490 >=app-mobilephone/obexd-0.47
491
492 # Eray Aslan <eras@gentoo.org> (24 Oct 2012)
493 # Mask experimental software
494 =mail-client/squirrelmail-1.4.23*
495
496 # Sergey Popov <pinkbyte@gentoo.org> (22 Oct 2012)
497 # Mask net-misc/libteam snapshot ebuilds until release
498 net-misc/libteam
499
500 # Michael Palimaka <kensington@gentoo.org> (19 Oct 2012)
501 # New major release breaks almost all existing consumers.
502 # Masked until each package can update its dependencies.
503 >=net-libs/libotr-4.0.0
504 >=x11-plugins/pidgin-otr-4.0.0
505
506 # Tim Harder <radhermit@gentoo.org> (15 Oct 2012)
507 # Mask development releases
508 =media-libs/libraw-0.15*
509
510 # Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2012)
511 # Masked for testing
512 =sys-libs/db-5.3*
513 =sys-libs/db-5.2*
514 =sys-libs/db-5.1*
515 =sys-libs/db-5.0*
516
517 # Richard Yao <ryao@gentoo.org> (06 Oct 2012)
518 # sys-apps/grep-2.13 falsely reports some files as binary, causing build
519 # failures. Bug #425668
520 =sys-apps/grep-2.13
521
522 # Tim Harder <radhermit@gentoo.org> (01 Sep 2012)
523 # Mask development releases
524 =media-sound/lilypond-2.17*
525
526 # Markos Chandras <hwoarang@gentoo.org> (17 August 2012)
527 # Masked for testing. Required by dev-lang/jimctl-0.73
528 =dev-embedded/openocd-0.6.1
529
530 # Benedikt Böhm <hollow@gentoo.org> (11 Aug 2012)
531 # Regression in iproute code, does not detect IP addresses correctly anymore.
532 ~dev-ruby/ohai-6.14.0
533
534 # Jeroen Roovers <jer@gentoo.org> (2 Aug 2012)
535 # Development version
536 >app-admin/sysstat-10.1
537
538 # Ralph Sennhauser <sera@gentoo.org> (18 Jul 2012)
539 # Unmaintained, multiple vulnarabilities. #351626
540 # A more recent source build maintained by the community is available in the
541 # seden overlay. A more recent binary is available in the java-overlay.
542 <=dev-util/eclipse-sdk-3.5.1-r1
543
544 # Michael Weber <xmw@gentoo.org> (07 Jul 2012)
545 # Masked for testing only beta (bug 424866)
546 =sci-electronics/eagle-6.2.1_beta
547
548 # Michael Weber <xmw@gentoo.org> (29 Jun 2012)
549 # Masking for security reasons (bug 424025, CVE-2012-3366)
550 # Users of trigger plugin, update asap.
551 <app-admin/bcfg2-1.2.2-r1
552
553 # Andreas K. Huettel <dilfridge@gentoo.org> (25 Jun 2012)
554 # Mask live ebuild
555 =net-print/cups-9999
556
557 # Maxim Koltsov <maksbotan@gentoo.org> (21 Jun 2012)
558 # It's not what it's called now, mask it not protect people
559 =dev-util/febootstrap-3*
560
561 # Ian Stakenvicius <axs@gentoo.org> (19 Jun 2012)
562 # Mask new spidermonkey until rdeps can accept it
563 ~dev-lang/spidermonkey-1.8.7
564
565 # Michael Weber <xmw@gentoo.org> (13 Jun 2012)
566 # Mask beta versions for testing
567 >sci-electronics/magic-8
568 >sci-electronics/xcircuit-3.8
569
570 # Justin Lecher <jlec@gentoo.org> (13 Jun 2012)
571 # Justin Lecher <jlec@gentoo.org> (01 Nov 2012)
572 # Mask old version numbers
573 # Shows newest unstable to users easily
574 >=sci-biology/ncbi-tools-20080302
575 >=sci-chemistry/dssp-070831
576 >=sci-biology/ncbi-tools++-2010.06.15
577
578 # Patrick Lauer <patrick@gentoo.org> (06 Jun 2012)
579 # Temporarily mask nginx >=1.3 see #411937
580 >=www-servers/nginx-1.3
581
582 # Markos Chandras <hwoarang@getnoo.org> (27 May 2012)
583 # Mask alpha release
584 =sci-electronics/qelectrotech-0.30_alpha*
585
586 # Benda Xu <heroxbd@gentoo.org> (20 May 2012)
587 # geant-4.9.5_p01 has a major class declaration change that renders
588 # geant-python (g4py upstream) unable to compile
589 # upstream bug http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1317
590 =sci-physics/geant-python-4.9.5_p01
591
592 # Alexandre Rostovtsev <tetromino@gentoo.org> (20 May 2012)
593 # Requires dev-scheme/guile-2.0.5 which is in lisp overlay and masked;
594 # bug #416683
595 >=games-board/aisleriot-3.3.1
596
597 # Ultrabug <ultrabug@gentoo.org> (16 May 2012)
598 # Masked for testing
599 >=sys-cluster/corosync-2.0.0
600
601 # Alistair Bush <ali_bush@gentoo.org> (10 May 2012)
602 # Mask alpha version of mono for testing
603 >=dev-lang/mono-2.11.1
604 >=dev-util/mono-tools-2.11
605 >=virtual/monodoc-2.11
606
607 # Johannes Huber <johu@gentoo.org> (03 May 2012)
608 # Unstable dev channel release. Fixes build with gcc47
609 # (bug #413941).
610 >=media-sound/mp3diags-1.1
611
612 # Robin H. Johnson <robbat2@gentoo.org> (09 Feb 2012)
613 # Needs to be slotted better
614 =dev-libs/yaz-4*
615
616 # Maxim Koltsov <maksbotan@gentoo.org> (19 Apr 2012)
617 # Broken, masking by maintainer's request
618 net-ftp/leechcraft-lcftp
619 net-p2p/leechcraft-eiskaltdcpp
620
621 # Jeroen Roovers <jer@gentoo.org> (04 Apr 2012)
622 # Alpha versions of dev-libs/libevent are considered unstable
623 >dev-libs/libevent-2.1
624
625 # Andreas K. Huettel <dilfridge@gentoo.org> (22 Mar 2012)
626 # Even its author admits that it's an ugly hack. Crashes e.g.
627 # firefox with kde-4.8. Unmask at your own risk.
628 kde-misc/kgtk
629
630 # Samuli Suominen <ssuominen@gentoo.org> (06 Mar 2012)
631 # Masked for testing since this is known to break nearly
632 # every reverse dependency wrt bug 407091
633 >=dev-lang/lua-5.2.0
634
635 # Sébastien Fabbro <bicatali@gentoo.org> (26 Feb 2012)
636 # Needs development version x11-libs/wxGTK
637 >=sci-visualization/fityk-1.1
638
639 # Michał Górny <mgorny@gentoo.org> (21 Jan 2012)
640 # Blocks sysvinit yet doesn't provide all tools provided by it.
641 # Masking until we get the necessary tools out of sysvinit.
642 sys-apps/systemd-sysv-utils
643
644 # Jeroen Roovers <jer@gentoo.org> (27 Mar 2012)
645 # Opera Next and Opera snapshots are unsupported and eternally unstable.
646 # <http://my.opera.com/desktopteam/blog>
647 www-client/opera-next
648
649 # Ulrich Mueller <ulm@gentoo.org> (13 Dec 2011)
650 # SLOTs 21 and 22 of app-editors/emacs, corresponding to
651 # GNU Emacs versions 21.4 and 22.3. These versions were
652 # released in February 2005 and September 2008, respectively.
653 # Please upgrade to >=app-editors/emacs-23 and update your
654 # Emacs Lisp packages with emacs-updater.
655 # Keeping these versions in the tree masked indefinitely,
656 # by popular request. Bug 394589.
657 =app-editors/emacs-21*
658 =app-editors/emacs-22*
659 <virtual/emacs-23
660
661 # Christoph Junghans <ottxor@gentoo.org> (15 Nov 2011)
662 # current version of google-talkplugin never clear what you get
663 =www-plugins/google-talkplugin-9999
664
665 # Diego E. Pettenò <flameeyes@gentoo.org> (30 Oct 2011)
666 # Working on more reliable versioning, consider experimental for now.
667 >=dev-lang/luajit-2.0.0_beta8
668
669 # Samuli Suominen <ssuominen@gentoo.org> (30 Oct 2011)
670 # Masked for security bug #294253, use only at your own risk!
671 =media-libs/fmod-3*
672 games-puzzle/candycrisis
673 games-simulation/stoned-bin
674 games-sports/racer-bin
675 games-strategy/dark-oberon
676 games-strategy/savage-bin
677
678 # MATSUU Takuto <matsuu@gentoo.org> (27 Oct 2011)
679 # Mask for testing
680 >=sys-devel/distcc-3.2_rc1
681
682 # Justin Bronder <jsbronder@gentoo.org> (27 Sep 2011)
683 # Masking the torque 2.3 series due to bug #372959. This allows
684 # sites that are ok with the vulnerability but prefer the stability
685 # of 2.3.x to continue to get updates (if any).
686 <sys-cluster/torque-2.4
687 dev-perl/perl-PBS
688
689 # Joerg Bornkessel <hd_brummy@gentoo.org> (17 Sep 2011)
690 # media-video/vdr-xvdr-9999, masked git live ebuild
691 =media-plugins/vdr-xvdr-9999
692
693 # Alexis Ballier <aballier@gentoo.org> (20 Aug 2011)
694 # dev-tex/pdftex-1.40.11 is 100% identical to the one in TeX Live 2010;
695 # TeX Live 2011 has a newer version, which makes the standalone package useless;
696 # mask it for now, we'll see about removing it later.
697 dev-tex/pdftex
698
699 # Robin H. Johnson <robbat2@gentoo.org> (01 Nov 2012)
700 # Update of mask to 5.6 instead of 5.5
701 # Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (28 Jul 2011)
702 # A new update of the mysql / mariadb mask
703 # Robin H. Johnson <robbat2@gentoo.org> (01 Feb 2010)
704 # Mask 5.6/6.0 series that are alpha and and crazy experimental.
705 # Mask 5.2/5.3 virtual that exists in the overlay as well (it is MariaDB only)
706 >=dev-db/mariadb-5.6
707 >=dev-db/mysql-5.6
708 >=virtual/mysql-5.6
709 =dev-db/mariadb-5.2*
710 =virtual/mysql-5.2*
711 =dev-db/mariadb-5.3*
712 =virtual/mysql-5.3*
713
714 # Peter Volkov <pva@gentoo.org> (23 Jul 2011)
715 # Mask release candidates
716 =dev-libs/guiloader-2.99.0
717 =dev-libs/guiloader-c++-2.99.0
718 =dev-util/crow-designer-2.99.0
719
720 # Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (15 July 2011)
721 # Masking mariadb-5.1.55 until we have feedback about the unit tests
722 # as they build for me but fail for Robin
723 ~dev-db/mariadb-5.1.55
724
725 # Justin Lecher <jlec@gentoo.org> (27 Jun 2011)
726 # Only avalable version isn't in the tree.
727 # Mask until it is bumped
728 sci-chemistry/webmo
729
730 # Torsten Veller <tove@gentoo.org> (18 Jun 2011)
731 # Mask perl-5.14. See tracker bug #356171
732 =dev-lang/perl-5.14*
733
734 # Hans de Graaff <graaff@gentoo.org> (15 May 2011)
735 # Mask new versions until thread-related crashes have been fixed.
736 # See bug 367423.
737 =dev-lang/ruby-enterprise-1.8.7.2011.03
738 =dev-lang/ruby-enterprise-1.8.7.2012.02
739
740 # Alexis Ballier <aballier@gentoo.org> (20 Apr 2011)
741 # Tiziano Müller <dev-zero@gentoo.org> (11 Aug 2010)
742 # Breaks net-voip/sflphone, non maintainer update, but is needed by
743 # media-video/ffmpeg
744 >=media-libs/celt-0.8.1
745
746 # Marijn Schouten <hkBst@gentoo.org> (07 April 2011)
747 # Masked for number of issues, but can be used to
748 # test against if people are impatient ;P
749 # Known issues:
750 # - Broken emacs support (ulm has promised to look)
751 # - doesn't build when boehm-gc is built without threads
752 # - no SLOTting yet!
753 =dev-scheme/guile-2.0.0
754
755 # Ryan Hill <dirtyepic@gentoo.org> (02 Apr 2011)
756 # Masked for testing
757 >=sys-devel/gcc-4.7.0
758 >=sys-devel/kgcc64-4.7.0
759 >=dev-java/gcj-jdk-4.7.0
760
761 # Christian Faulhammer <fauli@gentoo.org> (12 Mar 2011)
762 # Mask for testing
763 >=www-apps/joomla-1.6.0
764
765 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
766 # Masked indefinitely (until 0.40 is released).
767 # http://bugs.gentoo.org/354423
768 >=app-pda/libopensync-0.30
769 >=app-pda/libopensync-plugin-file-0.30
770 >=app-pda/libopensync-plugin-irmc-0.30
771 >=app-pda/libopensync-plugin-palm-0.30
772 >=app-pda/libopensync-plugin-python-0.30
773 app-pda/libopensync-plugin-syncml
774 app-pda/libopensync-plugin-vformat
775 app-pda/osynctool
776
777 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
778 # Work in progress
779 # http://bugs.gentoo.org/show_bug.cgi?id=354423
780 app-pda/libopensync-plugin-evolution2
781 app-pda/libopensync-plugin-gnokii
782 app-pda/libopensync-plugin-gpe
783 app-pda/multisync-gui
784
785 # Ryan Hill <dirtyepic@gentoo.org> (22 Jan 2011)
786 # Mask development versions due to unstable API
787 # as requested by leio
788 >=dev-python/wxpython-2.9
789 >=x11-libs/wxGTK-2.9
790
791 # Michael Sterrett <mr_bones_@gentoo.org> (20 Jan 2010)
792 # testing mask for upcoming exult release
793 >=games-engines/exult-1.3
794
795 # Torsten Veller <tove@gentoo.org> (06 Jan 2011)
796 # Next step to remove old perl and libperl versions.
797 # Versions prior 5.12 are masked and will be removed when 5.14 is available.
798 # If you are a sparc-fbsd user and your only keyworded perl version was masked,
799 # test perl-5.12.2 and reply to bug 288028
800 # For other complaints go to bug 350785
801 <dev-lang/perl-5.12.2
802 <sys-devel/libperl-5.10.1
803
804 # Gilles Dartiguelongue <eva@gentoo.org> (07 Dec 2010)
805 # Part of GNOME 2.32 release set by breaks my machine as hell
806 # Needs more testing before unleashing
807 >=gnome-base/libbonobo-2.32
808
809 # Markos Chandras <hwoarang@gentoo.org> (01 Nov 2010)
810 # Masking alpha releases
811 net-analyzer/ncrack
812
813 # Peter Volkov <pva@gentoo.org> (29 Oct 2010)
814 # mask beta release
815 =net-analyzer/tcpreplay-3.4.5*
816
817 # Markos Chandras <hwoarang@gentoo.org> (26 Oct 2010)
818 # master branch is heavily broken at the moment. Use
819 # 2.0.9999 instead if you want a kmess
820 # that actually builds
821 =net-im/kmess-9999
822
823 # Luca Barbato <lu_zero@gentoo.org> (21 Jul 2010)
824 # Not ready for public consumption, clashes with current mesa-git
825 media-libs/shivavg
826
827 # Stefan Briesenick <sbriesen@gentoo.org> (21 Jul 2010)
828 # doesn't compile against latest media-libs/spandsp.
829 # not needed anymore for Asterisk 1.6.
830 net-misc/asterisk-spandsp_codec_g726
831
832 # Doug Goldstein <cardoe@gentoo.org> (07 Jul 2010)
833 # No actual Gentoo support yet. If you're interested, please see bug #295993
834 net-misc/netcf
835
836 # Justin Lecher <jlec@gentoo.org> (16 Jun 10)
837 # Just working with the masked experimental version of refmac
838 >=sci-libs/monomer-db-5.16
839
840 # Robin H. Johnson <robbat2@gentoo.org> (09 Jun 2010)
841 # Fails to self-verify/sign in FIPS mode, pending upstream response before
842 # usage for GSoC project.
843 app-crypt/hmaccalc
844
845 # Luca Barbato <lu_zero@gentoo.org> (21 May 2010)
846 # development release
847 =dev-db/mongodb-1.5*
848
849 # Justin Lecher <jlec@gentoo.org> (16 May 2010)
850 # Upstreams testing version
851 # Added on request
852 >=sci-chemistry/refmac-5.6
853
854 # Patrick Lauer <patrick@gentoo.org> (07 Apr 2010)
855 # Keeping samba-4 masked until release.
856 >net-fs/samba-4
857
858 # Mike Frysinger <vapier@gentoo.org> (07 Mar 2010)
859 # Very old packages that people should have upgraded away from
860 # long ago. Courtesy mask ... time to upgrade.
861 # Added <sys-fs/e2fsprogs as well (halcy0n)
862 <sys-libs/e2fsprogs-libs-1.41.8
863 <sys-fs/e2fsprogs-1.41.9
864
865 # Robert Piasek <dagger@gentoo.org> (23 Feb 2010)
866 # Masking libmapi as it depends on masked samba4
867 >=net-libs/libmapi-0.9
868
869 # Christian Parpart <trapni@gentoo.org> (23 Dec 2009)
870 # Masked for testing/feedback.
871 media-sound/teamspeak-server-bin
872
873 # Joerg Bornkessel <hd_brummy@gentoo.org> (02 Dec 2009)
874 # cvs ebuild vdr-xineliboutput-9999 masked for lifetime
875 =media-plugins/vdr-xineliboutput-9999
876
877 # Peter Alfredsen <loki_val@gentoo.org> (21 Oct 2009)
878 # Masked because this needs a patch to be applied to portage
879 # to not install the kitchensink and everything else
880 # into /usr/src/debug with FEATURES=installsources
881 =dev-util/debugedit-4.4.6-r2
882
883 # Diego E. Pettenò <flameeyes@gmail.com> (09 Oct 2009)
884 # Untested yet; documented only in Russian, help is appreciated.
885 sys-auth/pam_keystore
886
887 # Diego E. Pettenò <flameeyes@gentoo.org> (08 Aug 2009)
888 # on behalf of QA Team
889 #
890 # Mass-masking of live ebuilds; we cannot guarantee working state of
891 # live ebuilds, nor the availability of the server hosting them. As
892 # per QA team policy, all these need to be kept masked by default, if
893 # available in the tree.
894 ~app-i18n/skk-jisyo-9999
895 net-misc/netcomics-cvs
896 app-portage/layman-dbtools
897 sci-astronomy/casa-data
898 # rdep on the one above
899 sci-astronomy/casacore
900 sci-electronics/kicad
901 dev-ruby/rcsparse
902 # rdep on the one above
903 dev-vcs/fromcvs
904 sci-biology/picard
905 ~dev-libs/libg15-9999
906
907 # Federico Ferri <mescalinum@gentoo.org> (08 Aug 2009)
908 # Doesn't build with Tcl 8.5, has several bugs open
909 =dev-tcltk/tcl-debug-2.0
910
911 # Marijn Schouten <hkBst@gentoo.org> (29 Jul 2009)
912 # Masked for increasingly many problems. Upstream is flaky and hasn't released since 2005.
913 # Maxima is the only consumer and can be built with sbcl or clisp.
914 # Hopefully upstream will do a release that we can add to revive this package.
915 dev-lisp/gcl
916
917 # Jeremy Olexa <darkside@gentoo.org> (28 Jul 2009)
918 # On behalf of Robin H. Johnson <robbat2@gentoo.org>.
919 # These versions are vulnerable to GLSA's and should not be used. They will stay
920 # in the tree because they are useful to tracking down bugs. You have been
921 # warned. bug 271686
922 <dev-db/mysql-5.1.56
923 <virtual/mysql-5.1
924
925 # Nirbheek Chauhan <nirbheek@gentoo.org> (10 Jun 2009)
926 # Several feature regressions that will make our users
927 # go on a witchhunt if unmasked
928 # * No XDMCP connection UI
929 # * No configuration/theming support
930 # * No support for auth backends other than PAM
931 # * Many more...
932 =gnome-base/gdm-2.3*
933
934 # Tiziano Müller <dev-zero@gentoo.org> (08 Apr 2009)
935 # pre-releases
936 net-libs/libinfinity
937 >=app-editors/gobby-0.4.91
938
939 # Paul Varner <fuzzyray@gentoo.org> (06 Apr 2009)
940 # Dead upstream and has issues with newer portages.
941 # Due to popular demand and no suitable replacement, it will stay in the tree
942 # in a masked status until it completely breaks or is replaced.
943 app-portage/udept
944
945 # Diego E. Pettenò <flameeyes@gentoo.org> (03 Jan 2009)
946 # These packages are not supposed to be merged directly, instead
947 # please use sys-devel/crossdev to install them.
948 dev-libs/cygwin
949 dev-util/mingw-runtime
950 dev-util/mingw64-runtime
951 dev-util/w32api
952 sys-libs/newlib
953 dev-embedded/msp430-binutils
954 dev-embedded/msp430-gcc
955 dev-embedded/msp430-gdb
956 dev-embedded/msp430-libc
957 dev-embedded/msp430mcu
958 dev-embedded/avr-libc
959
960 # Peter Volkov <pva@gentoo.org> (16 Nov 2008)
961 # The development branch, to be unmasked when out of beta by upstream.
962 =net-misc/socat-2.0.0*
963
964 # Steve Dibb <beandog@gentoo.org> (05 Nov 2008)
965 # Mask realplayer codecs for security bug 245662
966 media-libs/amd64codecs
967 media-libs/realcodecs
968
969 # Doug Goldstein <cardoe@gentoo.org> (17 Sep 2008)
970 # under development
971 gnome-extra/gnome-lirc-properties
972
973 # Markus Ullmann <jokey@gentoo.org> (07 Jul 2008)
974 # mask for security bug #190667 (CVE-2007-{4584,5839})
975 # and for various other build problems (bug #425634)
976 #
977 # both CVEs are fixed in upstream version control as per:
978 # http://bitchx.svn.sourceforge.net/svnroot/bitchx/trunk/Changelog
979 net-irc/bitchx
980
981 # Vlastimil Babka <caster@gentoo.org> (20 May 2008)
982 # Masked for testing
983 app-arch/rpm5
984
985 # Chris Gianelloni <wolf31o2@gentoo.org> (03 Mar 2008)
986 # Masking due to security bug #194607 and security bug #204067
987 games-fps/doom3
988 games-fps/doom3-cdoom
989 games-fps/doom3-chextrek
990 games-fps/doom3-data
991 games-fps/doom3-demo
992 games-fps/doom3-ducttape
993 games-fps/doom3-eventhorizon
994 games-fps/doom3-hellcampaign
995 games-fps/doom3-inhell
996 games-fps/doom3-lms
997 games-fps/doom3-mitm
998 games-fps/doom3-phantasm
999 games-fps/doom3-roe
1000 games-fps/quake4-bin
1001 games-fps/quake4-data
1002 games-fps/quake4-demo
1003
1004 # Piotr Jaroszyński <peper@gentoo.org> (26 Nov 2007)
1005 # opensync live ebuilds
1006 =app-pda/libsyncml-9999
1007 =app-pda/libopensync-9999
1008 =app-pda/osynctool-9999
1009 =app-pda/libopensync-plugin-evolution2-9999
1010 =app-pda/libopensync-plugin-file-9999
1011 =app-pda/libopensync-plugin-gnokii-9999
1012 =app-pda/libopensync-plugin-gpe-9999
1013 =app-pda/libopensync-plugin-irmc-9999
1014 =app-pda/libopensync-plugin-palm-9999
1015 =app-pda/libopensync-plugin-python-9999
1016 =app-pda/libopensync-plugin-syncml-9999
1017 =app-pda/libopensync-plugin-vformat-9999
1018
1019 # MATSUU Takuto <matsuu@gentoo.org> (05 Apr 2007)
1020 # to be tested, seems unstable
1021 >=app-i18n/scim-anthy-1.3.0
1022
1023 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
1024 # masked pending unresolved security issues #127167
1025 games-roguelike/slashem
1026
1027 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
1028 # masked pending unresolved security issues #125902
1029 games-roguelike/nethack
1030 games-util/hearse
1031
1032 # Robin H. Johnson <robbat2@gentoo.org> (11 Feb 2006)
1033 # zlib interaction is badly broken. See bug #124733.
1034 =dev-vcs/cvs-1.12.13*
1035
1036 # <klieber@gentoo.org> (01 Apr 2004)
1037 # The following packages contain a remotely-exploitable
1038 # security vulnerability and have been hard masked accordingly.
1039 #
1040 # Please see http://bugs.gentoo.org/show_bug.cgi?id=44351 for more info
1041 #
1042 games-fps/unreal-tournament-goty
1043 games-fps/unreal-tournament-strikeforce
1044 games-fps/unreal-tournament-bonuspacks
1045 games-fps/aaut

  ViewVC Help
Powered by ViewVC 1.1.20