/[gentoo-x86]/sys-apps/gradm/gradm-2.1.14.200907110111.ebuild
Gentoo

Contents of /sys-apps/gradm/gradm-2.1.14.200907110111.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Thu Sep 2 22:14:11 2010 UTC (4 years ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Bump and remove deprecated versions
(Portage version: 2.1.8.3/cvs/Linux x86_64)

1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.1.14.200907110111.ebuild,v 1.2 2009/09/23 20:24:21 patrick Exp $
4
5 inherit flag-o-matic toolchain-funcs eutils versionator
6
7 myPV="$(replace_version_separator 3 -)"
8
9 DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
10 HOMEPAGE="http://www.grsecurity.net/"
11 SRC_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/${PN}-${myPV}.tar.gz"
12 #RESTRICT=primaryuri
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
16 IUSE="pam"
17 RDEPEND=""
18 DEPEND="sys-devel/bison
19 sys-devel/flex
20 pam? ( virtual/pam )
21 || ( sys-apps/paxctl sys-apps/chpax )"
22
23 S="${WORKDIR}/${PN}2"
24
25 src_unpack() {
26 unpack ${A}
27 cd "${S}"
28 epatch "${FILESDIR}"/2.1.7.200511041858-non-lazy-bindings.patch
29 sed -i -e s/MKNOD=/'MKNOD ?='/ -e s/STRIP=/'STRIP ?='/ "${S}/Makefile"
30 }
31
32 src_compile() {
33 local target=""
34 use pam || target="nopam"
35
36 emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}" || die "compile problem"
37 }
38
39 src_install() {
40 einstall DESTDIR="${D}" MKNOD=true STRIP=true || die "einstall failed"
41 fperms 711 /sbin/gradm
42 }
43
44 pkg_postinst() {
45 [ -e "${ROOT}"/dev/grsec ] && rm -f "${ROOT}"/dev/grsec
46 einfo "Making character device for grsec2 learning mode"
47 mkdir -p -m 755 "${ROOT}"/dev/
48 mknod -m 0622 "${ROOT}"/dev/grsec c 1 13 || die "Cant mknod for grsec learning device"
49
50 ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
51 ewarn
52 ewarn "This version of gradm is only supported with a kernel >=2.6.29!"
53 }

  ViewVC Help
Powered by ViewVC 1.1.20