/[gentoo-x86]/sys-apps/gradm/gradm-2.1.14.201004061746.ebuild
Gentoo

Contents of /sys-apps/gradm/gradm-2.1.14.201004061746.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Tue Dec 21 14:14:41 2010 UTC (3 years, 6 months ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -1 lines
FILE REMOVED
Removed deprecated versions

(Portage version: 2.1.9.24/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.1.14.201004061746.ebuild,v 1.1 2010/04/13 14:58:31 zorry Exp $
4
5 EAPI=2
6
7 inherit flag-o-matic toolchain-funcs versionator
8
9 MY_PV="$(replace_version_separator 3 -)"
10
11 DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
12 HOMEPAGE="http://www.grsecurity.net/"
13 SRC_URI="http://dev.gentoo.org/~zorry/distfiles/${CATEGORY}/${PN}/${PN}-${MY_PV}.tar.gz"
14 LICENSE="GPL-2"
15
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
18 IUSE="pam"
19
20 RDEPEND=""
21 DEPEND="sys-devel/bison
22 sys-devel/flex
23 pam? ( virtual/pam )
24 || ( sys-apps/paxctl sys-apps/chpax )"
25
26 S="${WORKDIR}/${PN}2"
27
28 src_prepare() {
29 sed -i -e s:^LDFLAGS=:LDFLAGS+=: \
30 -e s:^MKNOD=.*:MKNOD=true: \
31 -e s:^STRIP=.*:STRIP=true: Makefile
32
33 append-ldflags -Wl,-z,now
34 }
35
36 src_compile() {
37 local target
38 use pam || target="nopam"
39
40 emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}" || die "emake failed"
41 }
42
43 src_install() {
44 einstall DESTDIR="${D}" || die "einstall failed"
45 fperms 711 /sbin/gradm
46 }
47
48 pkg_postinst() {
49 [ -e "${ROOT}"/dev/grsec ] && rm -f "${ROOT}"/dev/grsec
50 einfo "Making character device for grsec2 learning mode"
51 mkdir -p -m 755 "${ROOT}"/dev/
52 mknod -m 0622 "${ROOT}"/dev/grsec c 1 13 || die "mknod on grsec learning device failed"
53
54 einfo
55 ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
56 ewarn
57 ewarn "This version of gradm is only supported with a kernel >=2.6.29!"
58 einfo
59 }

  ViewVC Help
Powered by ViewVC 1.1.20