/[gentoo-x86]/sys-apps/gradm/gradm-2.2.0.201009022049.ebuild
Gentoo

Contents of /sys-apps/gradm/gradm-2.2.0.201009022049.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (hide annotations) (download)
Tue Dec 21 14:14:41 2010 UTC (3 years, 7 months ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +1 -1 lines
FILE REMOVED
Removed deprecated versions

(Portage version: 2.1.9.24/cvs/Linux x86_64)

1 blueness 1.1 # Copyright 1999-2010 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 blueness 1.5 # $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.2.0.201009022049.ebuild,v 1.4 2010/12/14 13:34:59 blueness Exp $
4 blueness 1.1
5     EAPI=2
6    
7     inherit flag-o-matic toolchain-funcs versionator
8    
9     MY_PV="$(replace_version_separator 3 -)"
10    
11     DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
12     HOMEPAGE="http://www.grsecurity.net/"
13     SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
14     LICENSE="GPL-2"
15    
16     SLOT="0"
17 blueness 1.4 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ppc64 ~sparc x86"
18 blueness 1.1 IUSE="pam"
19    
20     RDEPEND=""
21     DEPEND="sys-devel/bison
22     sys-devel/flex
23     pam? ( virtual/pam )
24     || ( sys-apps/paxctl sys-apps/chpax )"
25    
26     S="${WORKDIR}/${PN}2"
27    
28     src_prepare() {
29     epatch "${FILESDIR}/${P}.patch"
30     }
31    
32     src_compile() {
33     local target
34     use pam || target="nopam"
35    
36     emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}" || die "emake failed"
37     }
38    
39     src_install() {
40     einstall DESTDIR="${D}" || die "einstall failed"
41     fperms 711 /sbin/gradm
42     }
43    
44     pkg_postinst() {
45     local UDEVADM="/sbin/udevadm"
46     if [[ -x ${UDEVADM} ]] ; then
47     $UDEVADM trigger --action=add --sysname-match=grsec
48     fi
49     einfo
50     ewarn
51     ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
52     ewarn "This version of gradm is only supported with hardened-sources >= 2.6.32-r10"
53     ewarn
54     einfo
55     }

  ViewVC Help
Powered by ViewVC 1.1.20