/[gentoo-x86]/sys-apps/gradm/gradm-2.9.1.201206091838-r1.ebuild
Gentoo

Contents of /sys-apps/gradm/gradm-2.9.1.201206091838-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (hide annotations) (download)
Thu Jul 12 08:27:17 2012 UTC (2 years, 2 months ago) by blueness
Branch: MAIN
Changes since 1.1: +2 -2 lines
Stable amd64, x84: moving udev rules to /lib/udev/rules.d

(Portage version: 2.1.10.65/cvs/Linux x86_64)

1 blueness 1.1 # Copyright 1999-2012 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 blueness 1.2 # $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.9.1.201206091838-r1.ebuild,v 1.1 2012/07/09 11:45:44 blueness Exp $
4 blueness 1.1
5     EAPI="4"
6    
7     inherit flag-o-matic toolchain-funcs versionator eutils
8    
9     MY_PV="$(replace_version_separator 3 -)"
10    
11     DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
12     HOMEPAGE="http://www.grsecurity.net/"
13     SRC_URI="http://dev.gentoo.org/~blueness/hardened-sources/gradm/${PN}-${MY_PV}.tar.gz"
14     LICENSE="GPL-2"
15    
16     SLOT="0"
17 blueness 1.2 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
18 blueness 1.1 IUSE="pam"
19    
20     CDEPEND="sys-fs/udev"
21     RDEPEND="${CDEPEND}"
22     DEPEND="
23     ${CDEPEND}
24     sys-devel/bison
25     sys-devel/flex
26     pam? ( virtual/pam )
27     sys-apps/paxctl"
28    
29     S="${WORKDIR}/${PN}2"
30    
31     src_prepare() {
32     epatch "${FILESDIR}/respect-gentoo-env.patch"
33     }
34    
35     src_compile() {
36     local target
37     use pam || target="nopam"
38    
39     emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}"
40     }
41    
42     src_install() {
43     einstall DESTDIR="${D}"
44     fperms 711 /sbin/gradm
45     }
46    
47     pkg_postinst() {
48     udevadm control --reload-rules && udevadm trigger --action=add --sysname-match=grsec
49     einfo
50     ewarn
51     ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
52     ewarn "This version of gradm is only supported with hardened-sources >= 2.6.32-r10"
53     ewarn
54     einfo
55     }

  ViewVC Help
Powered by ViewVC 1.1.20