/[gentoo-x86]/sys-apps/hal/hal-0.4.5-r2.ebuild
Gentoo

Contents of /sys-apps/hal/hal-0.4.5-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (show annotations) (download)
Sun Apr 24 10:27:20 2005 UTC (9 years, 3 months ago) by dsd
Branch: MAIN
Changes since 1.8: +4 -11 lines
Add sanity to pkg_setup.. also fixes usage with portage-HEAD
(Portage version: 1.586-cvs)

1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.5-r2.ebuild,v 1.8 2005/04/09 12:59:48 corsair Exp $
4
5 inherit eutils python linux-info versionator flag-o-matic
6
7 DESCRIPTION="Hardware Abstraction Layer"
8 HOMEPAGE="http://www.freedesktop.org/Software/hal"
9 SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
10
11 LICENSE="|| ( GPL-2 AFL-2.0 )"
12 SLOT="0"
13 KEYWORDS="x86 amd64 ~ia64 ppc ppc64"
14 IUSE="debug pcmcia doc"
15
16 RDEPEND=">=dev-libs/glib-2.4
17 >=sys-apps/dbus-0.22-r1
18 dev-libs/expat
19 sys-fs/udev
20 sys-apps/hotplug
21 sys-libs/libcap
22 dev-libs/popt
23 >=sys-apps/util-linux-2.12i
24 || ( >=sys-kernel/linux-headers-2.6 sys-kernel/linux26-headers )"
25
26 DEPEND="${RDEPEND}
27 dev-util/pkgconfig
28 >=dev-util/intltool-0.29
29 doc? ( app-doc/doxygen )"
30 # dep on a specific util-linux version for
31 # managed mount patches #70873
32
33 # We need to run at least a 2.6.10 kernel, this is a
34 # way to ensure that to some extent
35 pkg_setup() {
36
37 linux-info_pkg_setup
38 kernel_is ge 2 6 10 \
39 || die "You need a 2.6.10 or newer kernel to build this package"
40
41 }
42
43 src_unpack() {
44
45 unpack ${A}
46
47 cd ${S}
48 # remove pamconsole option
49 epatch ${FILESDIR}/${PN}-0.4.1-old_storage_policy.patch
50 # pick up the gentoo usermap
51 epatch ${FILESDIR}/${P}-gentoo_gphoto2_usermap.patch
52 # fix issues with certain misbehaving kernel drivers (#78564)
53 cd ${S}/hald/linux
54 epatch ${FILESDIR}/${P}-net_lockup.patch
55 cd ${S}/hald/linux/volume_id
56 epatch ${FILESDIR}/${P}-vat_ntfs_labels.patch
57
58 }
59
60 src_compile() {
61
62 # use sysfs stuff added in 2.6.10 kernel
63 append-flags -DSYSFS_CARRIER_ENABLE
64
65 # FIXME : docs
66 econf \
67 `use_enable debug verbose-mode` \
68 `use_enable pcmcia pcmcia-support` \
69 --enable-fstab-sync \
70 --enable-hotplug-map \
71 --disable-docbook-docs \
72 `use_enable doc doxygen-docs` \
73 --with-pid-file=/var/run/hald/hald.pid \
74 || die
75
76 emake || die
77
78 }
79
80 src_install() {
81
82 make DESTDIR=${D} install || die
83
84 # We install this in a seperate package to avoid gnome-python dep
85 rm ${D}/usr/bin/hal-device-manager
86
87 # initscript
88 exeinto /etc/init.d/
89 doexe ${FILESDIR}/hald
90
91 # place our pid file
92 keepdir /var/run/hald
93
94 dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
95
96 }
97
98 pkg_preinst() {
99
100 enewgroup haldaemon || die "Problem adding haldaemon group"
101 enewuser haldaemon -1 /bin/false /dev/null haldaemon || die "Problem adding haldaemon user"
102
103 }
104
105 pkg_postinst() {
106
107 # make sure the permissions on the pid dir are alright & after preinst
108 chown haldaemon:haldaemon /var/run/hald
109
110 ewarn "Enabled in this ebuild by default is the usage of fstab-sync"
111 ewarn "that will create mount rules for non-existing devices in"
112 ewarn "fstab if needed, mount points will be created in /media."
113 ewarn "This functionality alters /etc/fstab runtime on the filesystem"
114 ewarn "and should be considered a security risk."
115 echo
116 einfo "The HAL daemon needs to be running for certain applications to"
117 einfo "work. Suggested is to add the init script to your start-up"
118 einfo "scripts, this should be done like this :"
119 einfo "\`rc-update add hald default\`"
120
121 }

  ViewVC Help
Powered by ViewVC 1.1.20