/[gentoo-x86]/sys-apps/hal/hal-0.4.8.ebuild
Gentoo

Contents of /sys-apps/hal/hal-0.4.8.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.15 - (show annotations) (download)
Fri Sep 22 00:23:16 2006 UTC (8 years, 3 months ago) by cardoe
Branch: MAIN
CVS Tags: HEAD
Changes since 1.14: +1 -1 lines
FILE REMOVED
Remove old hal-0.4x series\!
(Portage version: 2.1.2_pre1)
 (Signed Manifest commit)

1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.8.ebuild,v 1.14 2006/07/05 06:03:27 vapier Exp $
4
5 inherit eutils python linux-info versionator flag-o-matic
6
7 DESCRIPTION="Hardware Abstraction Layer"
8 HOMEPAGE="http://www.freedesktop.org/Software/hal"
9 SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
10
11 LICENSE="|| ( GPL-2 AFL-2.0 )"
12 SLOT="0"
13 KEYWORDS="amd64 arm hppa ia64 ~mips ppc ppc64 sh ~sparc x86"
14 IUSE="debug pcmcia doc livecd"
15
16 RDEPEND=">=dev-libs/glib-2.4
17 =sys-apps/dbus-0.23*
18 dev-libs/expat
19 sys-fs/udev
20 sys-apps/hotplug
21 sys-libs/libcap
22 dev-libs/popt
23 >=sys-apps/util-linux-2.12i
24 || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )"
25
26 DEPEND="${RDEPEND}
27 dev-util/pkgconfig
28 >=dev-util/intltool-0.29
29 doc? ( app-doc/doxygen )"
30 # dep on a specific util-linux version for
31 # managed mount patches #70873
32
33 # We need to run at least a 2.6.10 kernel, this is a
34 # way to ensure that to some extent
35 pkg_setup() {
36
37 if get_version; then
38 kernel_is ge 2 6 10 && return
39 elif get_running_version; then
40 kernel_is ge 2 6 10 && return
41 fi
42 die "You need to run a 2.6.10 or newer kernel to build & use this pack"
43
44 }
45
46 src_unpack() {
47
48 unpack ${A}
49
50 cd ${S}
51 # remove pamconsole option
52 epatch ${FILESDIR}/${PN}-0.4.1-old_storage_policy.patch
53 # pick up the gentoo usermap
54 epatch ${FILESDIR}/${PN}-0.4.5-gentoo_gphoto2_usermap.patch
55 # fix memleaks
56 cd ${S}/hald
57 # detect floppy drives on >=2.6.12 kernels as well
58 epatch ${FILESDIR}/${PN}-0.4.7-sys_floppy_detection.patch
59 # set defaultpolicy for vfat from iocharset=utf8 to utf8 (#83025)
60 cd ${S}
61 epatch ${FILESDIR}/${PN}-0.4.7-vfat_mount_utf8.patch
62 # fix dvdram entry
63 epatch ${FILESDIR}/${P}-fix_dvdram.patch
64
65 }
66
67 src_compile() {
68
69 # FIXME : docs
70 econf \
71 `use_enable debug verbose-mode` \
72 `use_enable pcmcia pcmcia-support` \
73 --enable-sysfs-carrier \
74 --enable-fstab-sync \
75 --enable-hotplug-map \
76 --disable-docbook-docs \
77 `use_enable doc doxygen-docs` \
78 --with-pid-file=/var/run/hald/hald.pid \
79 || die
80
81 emake || die
82
83 }
84
85 src_install() {
86
87 make DESTDIR=${D} install || die
88
89 # We install this in a seperate package to avoid gnome-python dep
90 rm ${D}/usr/bin/hal-device-manager
91
92 # initscript
93 exeinto /etc/init.d/
94 doexe ${FILESDIR}/hald
95
96 # place our pid file
97 keepdir /var/run/hald
98
99 # keep the policy setup intact
100 keepdir /usr/share/hal/fdi/{95userpolicy,50user,40oem,30osvendor,10generic}
101
102 dodoc AUTHORS ChangeLog NEWS README
103
104 }
105
106 pkg_preinst() {
107
108 enewgroup haldaemon || die "Problem adding haldaemon group"
109 enewuser haldaemon -1 "-1" /dev/null haldaemon || die "Problem adding haldaemon user"
110
111 }
112
113 pkg_postinst() {
114
115 # make sure the permissions on the pid dir are alright & after preinst
116 chown haldaemon:haldaemon /var/run/hald
117
118 ewarn "Enabled in this ebuild by default is the usage of fstab-sync"
119 ewarn "that will create mount rules for non-existing devices in"
120 ewarn "fstab if needed, mount points will be created in /media."
121 ewarn "This functionality alters /etc/fstab runtime on the filesystem"
122 ewarn "and should be considered a security risk."
123 echo
124 einfo "The HAL daemon needs to be running for certain applications to"
125 einfo "work. Suggested is to add the init script to your start-up"
126 einfo "scripts, this should be done like this :"
127 einfo "\`rc-update add hald default\`"
128
129 }

  ViewVC Help
Powered by ViewVC 1.1.20