/[gentoo-x86]/sys-apps/policycoreutils/ChangeLog
Gentoo

Diff of /sys-apps/policycoreutils/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.75 Revision 1.110
1# ChangeLog for sys-apps/policycoreutils 1# ChangeLog for sys-apps/policycoreutils
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.75 2009/09/14 18:25:54 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.110 2012/12/30 15:12:00 swift Exp $
4
5*policycoreutils-2.1.13-r6 (30 Dec 2012)
6
7 30 Dec 2012; Sven Vermeulen +policycoreutils-2.1.13-r6.ebuild,
8 policycoreutils-2.1.13-r5.ebuild:
9 Stabilize r5, get r6 available as well which fixes rlpkg to include zfs
10 support
11
12*policycoreutils-2.1.13-r5 (17 Nov 2012)
13
14 17 Nov 2012; <swift@gentoo.org> policycoreutils-2.1.13-r4.ebuild,
15 +policycoreutils-2.1.13-r5.ebuild:
16 Stabilization, move sesandbox support to next release
17
18*policycoreutils-2.1.13-r4 (14 Oct 2012)
19
20 14 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r4.ebuild:
21 Remove support for python3 until upstream supports it
22
23 13 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.13-r3.ebuild:
24 Supporting user-provided patches using epatch_user
25
26*policycoreutils-2.1.13-r3 (09 Oct 2012)
27
28 09 Oct 2012; <swift@gentoo.org> +policycoreutils-2.1.13-r3.ebuild:
29 Introducing new upstream release
30
31 06 Oct 2012; <swift@gentoo.org> policycoreutils-2.1.10-r5.ebuild:
32 Stabilize
33
34*policycoreutils-2.1.10-r5 (08 Sep 2012)
35
36 08 Sep 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r5.ebuild:
37 Fix bug #427596 and #430806
38
39 10 Jul 2012; <swift@gentoo.org> policycoreutils-2.1.10-r3.ebuild:
40 Stabilization, drop libcgroup dependency along the way
41
42*policycoreutils-2.1.10-r4 (10 Jul 2012)
43
44 10 Jul 2012; <swift@gentoo.org> +policycoreutils-2.1.10-r4.ebuild:
45 Support refpolicy style audit2allow (#417199)
46
47 26 Jun 2012; Mike Gilbert <floppym@gentoo.org>
48 policycoreutils-2.1.10-r1.ebuild, policycoreutils-2.1.10-r3.ebuild,
49 policycoreutils-2.1.10.ebuild:
50 Restrict pypy per Arfrever.
51
52*policycoreutils-2.1.10-r3 (25 Jun 2012)
53
54 25 Jun 2012; <swift@gentoo.org>
55 +files/policycoreutils-extra-1.21-fix-python3.patch,
56 +policycoreutils-2.1.10-r3.ebuild:
57 Improve support for python3, fixes bug #416301
58
59 13 May 2012; <swift@gentoo.org> -policycoreutils-2.1.0-r1.ebuild,
60 -policycoreutils-2.1.0-r2.ebuild:
61 Removing obsoleted ebuilds
62
63*policycoreutils-2.1.10-r1 (29 Apr 2012)
64
65 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild,
66 +policycoreutils-2.1.10-r1.ebuild:
67 Remove dependency on libcgroup (but drop sesandbox support along the way)
68
69 29 Apr 2012; <swift@gentoo.org> policycoreutils-2.1.10.ebuild:
70 Stabilization
71
72*policycoreutils-2.1.10 (31 Mar 2012)
73
74 31 Mar 2012; <swift@gentoo.org> +policycoreutils-2.1.10.ebuild, metadata.xml:
75 Bump to version 2.1.10
76
77 26 Feb 2012; <swift@gentoo.org> policycoreutils-2.1.0-r2.ebuild:
78 Stabilization
79
80 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild,
81 metadata.xml:
82 Mark audit as a local USE flag
83
84*policycoreutils-2.1.0-r2 (14 Jan 2012)
85
86 14 Jan 2012; <swift@gentoo.org> +policycoreutils-2.1.0-r2.ebuild:
87 Override auto-detection of pam and audit, use USE flags for this
88
89 12 Nov 2011; <swift@gentoo.org> -policycoreutils-2.0.82.ebuild,
90 -policycoreutils-2.0.82-r1.ebuild, -policycoreutils-2.0.85.ebuild,
91 -policycoreutils-2.1.0.ebuild:
92 removing obsoleted ebuilds
93
94 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.1.0-r1.ebuild:
95 Stabilization (tracker #384231)
96
97 23 Oct 2011; <swift@gentoo.org> policycoreutils-2.0.82-r1.ebuild:
98 Stabilize 2.0.82-r1 to fix #372807
99
100*policycoreutils-2.1.0-r1 (17 Sep 2011)
101
102 17 Sep 2011; <swift@gentoo.org> +policycoreutils-2.1.0-r1.ebuild:
103 Add /var/lib/selinux directory, needed for 'semodule permissive' support (bug
104 #381755)
105
106 02 Sep 2011; <swift@gentoo.org> policycoreutils-2.0.85.ebuild,
107 policycoreutils-2.1.0.ebuild:
108 Update patch locations to dev.g.o instead of files/ folder
109
110 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
111 -policycoreutils-2.0.55.ebuild, -policycoreutils-2.0.69.ebuild,
112 -policycoreutils-2.0.69-r1.ebuild, -policycoreutils-2.0.69-r2.ebuild,
113 -files/policycoreutils-2.0.69-setfiles.diff:
114 Removed deprecated versions
115
116*policycoreutils-2.1.0 (03 Aug 2011)
117
118 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
119 +policycoreutils-2.1.0.ebuild:
120 Bump to 20110727 SELinux userspace release
121
122*policycoreutils-2.0.85 (15 Jul 2011)
123
124 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
125 +policycoreutils-2.0.85.ebuild,
126 +files/policycoreutils-2.0.85-fix-seunshare-vuln.patch.gz,
127 +files/policycoreutils-2.0.85-sesandbox.patch.gz:
128 Add fix for bug #374897 and initial support for python3
129
130 08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
131 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
132 policycoreutils-2.0.69-r1.ebuild, policycoreutils-2.0.69-r2.ebuild:
133 Convert from "useq" to "use".
134
135*policycoreutils-2.0.82-r1 (30 Jun 2011)
136
137 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
138 +policycoreutils-2.0.82-r1.ebuild:
139 Overwrite invalid .po files with valid ones, fixes bug #372807
140
141 16 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
142 policycoreutils-2.0.82.ebuild:
143 Drop use_nls dependency on gettext. Its mandatory. See bug #299681.
144 Also put gettext in COMMON_DEPS, it is more than a RDEPEND.
145
146 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
147 policycoreutils-2.0.82.ebuild:
148 Stable amd64 x86
149
150 16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
151 Updated metadata info.
152
153 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
154 policycoreutils-2.0.82.ebuild:
155 Set SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation
156 with FEATURES="multilib-strict".
157
158*policycoreutils-2.0.82 (05 Feb 2011)
159
160 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
161 +policycoreutils-2.0.82.ebuild:
162 New upstream release.
163
164*policycoreutils-2.0.69-r2 (05 Feb 2011)
165
166 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
167 +policycoreutils-2.0.69-r2.ebuild,
168 +files/policycoreutils-2.0.69-setfiles.diff:
169 Fixed bug #300613
170
171 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
172 policycoreutils-2.0.55.ebuild, policycoreutils-2.0.69.ebuild,
173 policycoreutils-2.0.69-r1.ebuild:
174 Delete calls to deprecated python_version().
175
176*policycoreutils-2.0.69-r1 (20 Sep 2009)
177
178 20 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
179 +policycoreutils-2.0.69-r1.ebuild:
180 Update rlpkg for ext4 and btrfs.
4 181
5 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org> 182 14 Sep 2009; Chris PeBenito <pebenito@gentoo.org>
6 policycoreutils-2.0.69.ebuild: 183 policycoreutils-2.0.69.ebuild:
7 Fix libsemanage DEP. 184 Fix libsemanage DEP.
8 185
368*policycoreutils-1.0 (03 Aug 2003) 545*policycoreutils-1.0 (03 Aug 2003)
369 546
370 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml, 547 03 Aug 2003; Chris PeBenito <pebenito@gentoo.org> metadata.xml,
371 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff: 548 policycoreutils-1.0.ebuild, files/policycoreutils-1.0-gentoo.diff:
372 Initial commit 549 Initial commit
373

Legend:
Removed from v.1.75  
changed lines
  Added in v.1.110

  ViewVC Help
Powered by ViewVC 1.1.20