/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.96 - (hide annotations) (download)
Mon Jul 2 16:29:47 2012 UTC (2 years ago) by ssuominen
Branch: MAIN
Changes since 1.95: +8 -1 lines
RESTRICT="multilib-strict" since it's not compatible with the whole /usr/libexec -> u/usr/lib/$package migration wrt #424423. This will move polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.

(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)

1 eva 1.1 # ChangeLog for sys-auth/polkit
2 ssuominen 1.62 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 ssuominen 1.96 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.95 2012/07/01 13:30:22 ssuominen Exp $
4    
5     *polkit-0.106-r7 (02 Jul 2012)
6    
7     02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
8     RESTRICT="multilib-strict" since it's not compatible with the whole
9     /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
10     polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
11 ssuominen 1.95
12     *polkit-0.106-r6 (01 Jul 2012)
13    
14     01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
15     Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
16     /usr/lib to /usr/lib64 symlink.
17 swift 1.94
18     30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
19     polkit-0.106-r5.ebuild:
20     Adding dependency on SELinux policykit module if USE=selinux is set
21 ssuominen 1.92
22     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
23 ssuominen 1.93 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
24     'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
25 ssuominen 1.91
26     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
27     -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
28     old
29 ssuominen 1.90
30     *polkit-0.106-r5 (27 Jun 2012)
31    
32     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
33     Revert entire unix-group:wheel experiment back to unix-user:0 because
34     PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
35     Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
36     by Doug Goldstein.
37 ssuominen 1.89
38     *polkit-0.106-r4 (27 Jun 2012)
39    
40     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
41     Stop installing polkit-backend-1.pc because upstream changed
42     libpolkit-backend-1.la to be noinst_LTLIBRARIES in
43     src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
44 ssuominen 1.88
45     27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
46     Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
47     Palimaka
48 tetromino 1.87
49     *polkit-0.106-r3 (25 Jun 2012)
50    
51     25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
52     +polkit-0.106-r3.ebuild:
53     pax-mark polkitd to fix crashes on hardened/PaX systems.
54 ssuominen 1.86
55     23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
56     Convert pkg_postinst() message about polkitd home directory to new
57     user.eclass function esethome().
58 ssuominen 1.85
59     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
60     Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
61 ssuominen 1.84
62     19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
63     Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
64 ssuominen 1.83
65     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
66     old
67 ssuominen 1.82
68     *polkit-0.106-r2 (17 Jun 2012)
69    
70     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
71     Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
72     existing directories.
73 ssuominen 1.81
74     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
75     old
76 ssuominen 1.79
77 ssuominen 1.80 *polkit-0.106-r1 (17 Jun 2012)
78    
79     17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
80     Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
81     unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
82     for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
83     /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
84 ssuominen 1.78
85     13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
86 ssuominen 1.80 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
87     #420173 and #420307.
88 ssuominen 1.77
89     *polkit-0.106 (07 Jun 2012)
90    
91     07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
92 ssuominen 1.80 Version bump.
93 ssuominen 1.76
94     20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
95     Improve systemd handling wrt #416317 by Christoph Brill
96 ssuominen 1.75
97     *polkit-0.105 (14 May 2012)
98    
99     14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
100     Version bump.
101 jdhore 1.74
102     04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
103     dev-util/pkgconfig -> virtual/pkgconfig
104 ssuominen 1.73
105     18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
106     -polkit-0.103.ebuild, -polkit-0.104.ebuild:
107     old
108 armin76 1.72
109     25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
110     ia64/sh/sparc stable wrt #401513
111 ssuominen 1.71
112     09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
113     ppc/ppc64 stable wrt #401513
114 klausman 1.70
115     17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
116     Stable on alpha, bug #401513
117 tomka 1.69
118     17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
119     marked x86 per bug 401513
120 maekke 1.68
121     13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
122     arm stable, bug #401513
123 jer 1.67
124     02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
125     Stable for HPPA (bug #401513).
126 ago 1.66
127     30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
128     Stable for AMD64, wrt security bug #401513
129 ssuominen 1.65
130     *polkit-0.104-r1 (30 Jan 2012)
131    
132     30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
133     Restore the default value of AdminIdentities from "wheel" to "0" like it was
134     in polkit-0.102 and ones before that. You should see files
135     50-localauthority.conf and 60-gentoo.conf in
136     /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
137     with "man 8 pklocalauthority" as soon as possible.
138 maekke 1.64
139     29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
140     arm stable, bug #397755
141 ago 1.63
142     07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
143     Stable for AMD64, wrt bug #397755
144 ssuominen 1.62
145     *polkit-0.104 (05 Jan 2012)
146    
147     05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
148     metadata.xml:
149     Version bump.
150 ssuominen 1.61
151     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
152     old
153 ssuominen 1.60
154     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
155     ppc/ppc64 stable wrt #387163
156 ssuominen 1.59
157     08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
158     Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
159 ssuominen 1.58
160     *polkit-0.103 (07 Dec 2011)
161    
162     07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
163     Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
164     "i.Dark_Templar"
165 armin76 1.57
166     05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
167     alpha/arm/ia64/sh/sparc stable wrt #387163
168 maekke 1.56
169     29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
170     arm stable, bug #387163
171 jer 1.55
172     19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
173     Stable for HPPA (bug #387163).
174 phajdan.jr 1.54
175     18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
176     x86 stable wrt bug #387163
177 hwoarang 1.53
178     15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
179     Stable on amd64 wrt bug #387163
180 nirbheek 1.52
181     28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
182     polkit-0.102.ebuild:
183     pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
184 ssuominen 1.51
185     *polkit-0.102 (06 Aug 2011)
186    
187     06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
188     Version bump.
189 mattst88 1.50
190     10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
191     Added ~mips, bug 296548
192 eva 1.49
193     14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
194     Add missing dtd to DEPEND, bug #355505.
195 armin76 1.48
196     30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
197     alpha/arm/ia64/sh/sparc stable wrt #364973
198 phajdan.jr 1.47
199     28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
200     polkit-0.101-r1.ebuild:
201     x86 stable wrt security bug #364973
202 jer 1.46
203     27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
204     Stable for HPPA (bug #364973).
205 angelos 1.45
206     27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
207     Stable on amd64 wrt bug #364973
208 xarthisius 1.44
209     27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
210     ppc/ppc64 stable wrt #364973
211 nirbheek 1.43
212     *polkit-0.101-r1 (25 Apr 2011)
213    
214     25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
215     +polkit-0.101-r1.ebuild:
216     Add patches for CVE-2011-1485, remove vulnerable 0.100 version
217 xarthisius 1.42
218     22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
219     ppc/ppc64 stable wrt #354509
220 armin76 1.41
221     19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
222     alpha/ia64/sh/sparc stable wrt #354509
223 nirbheek 1.40
224     15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
225     PDEPEND on 0.101 version of polkit-gnome
226 maekke 1.39
227     13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
228     arm stable, bug #354509
229 ssuominen 1.38
230     *polkit-0.101 (11 Mar 2011)
231    
232     11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
233     Version bump.
234 jer 1.37
235     07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
236     Stable for HPPA (bug #354509).
237 tomka 1.36
238     04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
239     x86 stable per bug 354509
240 hwoarang 1.35
241     23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
242     Stable on amd64 wrt bug #354509
243 nirbheek 1.34
244     *polkit-0.100 (23 Feb 2011)
245    
246     23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
247     Bump to 0.100
248 ssuominen 1.32
249     24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
250 ssuominen 1.33 USE="kde" to pull in authentication agent for KDE.
251 jer 1.31
252     21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
253     Marked ~hppa (bug #296548).
254 ssuominen 1.30
255     *polkit-0.99-r1 (25 Dec 2010)
256    
257     25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
258     Revision bump to remove static archives (.a) and libtool archives (.la).
259 ssuominen 1.33 USE="gtk" to pull in authentication agent for GTK+ based desktops.
260 nirbheek 1.27
261     *polkit-0.99 (25 Sep 2010)
262    
263     25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
264     Bump to 0.99, masked due to >=glib-2.25 requirement
265 maekke 1.26
266     18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
267     arm stable, bug #314899
268 armin76 1.24
269 armin76 1.25 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
270     polkit-0.96-r2.ebuild:
271     alpha/ia64/sh/sparc stable
272 josejx 1.23
273     09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
274     Marked ppc/ppc64 stable.
275 klausman 1.22
276     25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
277     Stable on alpha, bug #329621
278 jer 1.21
279     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
280     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
281     Stable for HPPA (bug #314899).
282 jer 1.20
283     20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
284     polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
285     Drop HPPA keywording (bug #324511).
286 nirbheek 1.19
287     07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
288     polkit-0.96-r2.ebuild:
289     Add ewarn about ensuring that consolekit sessions are working. Either the
290     user needs to login using a login-manager with consolekit support, or use
291     ck-launch-session to launch the DE as suggested in bug 291116 comment 13
292 nirbheek 1.18
293     *polkit-0.96-r2 (02 Jul 2010)
294    
295     02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
296     +polkit-0.96-r2.ebuild, metadata.xml:
297     USE=expat was quite useless, expat is mandatory in polkit. Don't create
298     user 'polkituser', it was used by policykit, but isn't by polkit. Also,
299     add introspection support
300 maekke 1.17
301     04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
302     x86 stable, bug #314899
303 tester 1.16
304     03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
305     amd64 stable, bug #314899
306 armin76 1.15
307     25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
308     polkit-0.96-r1.ebuild:
309     Add ~sh
310 aballier 1.14
311     13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
312     +files/polkit-0.96-getcwd.patch:
313     Fix build on fbsd and keyword it x86-fbsd
314 nirbheek 1.13
315     25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
316     polkit-0.96-r1.ebuild:
317     Raise gtk-doc{,-am} dependencies. Fixes bug 311085
318 nirbheek 1.12
319     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
320     -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
321     -polkit-0.95.ebuild:
322     Remove old
323 nirbheek 1.11
324     *polkit-0.96-r1 (21 Mar 2010)
325    
326     21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
327     +polkit-0.96-r1.ebuild:
328     Update with newer version of polkit-shadow patch
329 nirbheek 1.10
330     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
331     Fix minor problems with SRC_URI
332 nirbheek 1.9
333     07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
334     Add experimental shadow support, bug 291116 . Patch thanks to the
335     slackware folks.
336 armin76 1.8
337     28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
338     Add ~alpha/~arm/~ia64/~sparc
339 josejx 1.7
340     16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
341     Marked ~ppc/~ppc64 for bug #296548.
342 nirbheek 1.6
343     *polkit-0.96 (23 Jan 2010)
344    
345     23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
346     Version bump to 0.96; lots of bugfixes, see NEWS
347 jer 1.5
348     06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
349     Marked ~hppa (bug #296548).
350 nirbheek 1.4
351     11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
352     Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
353     the user is in an active/local session via dbus methods
354 nirbheek 1.3
355     *polkit-0.95 (14 Nov 2009)
356    
357     14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
358     Bump to 0.95 -- new lockdown API, last dev version till 1.0
359 nirbheek 1.2
360     30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
361     -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
362     Remove zsh-completion (bug 291114), force pam support on (bug 291116)
363 eva 1.1
364     *polkit-0.94 (29 Oct 2009)
365    
366     29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
367     +files/polkit-0.92-zsh-completions.patch,
368     +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
369     +metadata.xml:
370     Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20