/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.110 - (show annotations) (download)
Sun Nov 18 07:11:54 2012 UTC (17 months ago) by ssuominen
Branch: MAIN
Changes since 1.109: +7 -2 lines
Version bump.

(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.109 2012/10/28 15:49:09 naota Exp $
4
5 *polkit-0.108 (18 Nov 2012)
6
7 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
8 Version bump.
9
10 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
11 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
12 Drop ~x86-fbsd due to bug #439968.
13
14 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
15 polkit-0.107-r1.ebuild:
16 Drop HPPA keywording (bug #438368).
17
18 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
19 Set QA_MULTILIB_PATHS for bug #424423.
20
21 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
22 Marked ~hppa (bug #436668).
23
24 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
25 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
26 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
27 and emphatize it's an Portage issue instead of polkit issue in src_install()
28 message.
29
30 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
31 Stable for amd64, wrt bug #436666
32
33 *polkit-0.107-r1 (20 Sep 2012)
34
35 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
36 +files/polkit-0.107-fallback.patch:
37 Introduce upstream patch for falling back to uid 0 for authentication if list
38 of admin identities is empty.
39
40 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
41 -polkit-0.106-r7.ebuild:
42 old
43
44 *polkit-0.107 (13 Jul 2012)
45
46 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
47 Version bump.
48
49 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
50 -polkit-0.106-r6.ebuild:
51 old
52
53 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
54 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
55 #391865 by Maksim Melnikau
56
57 *polkit-0.106-r7 (02 Jul 2012)
58
59 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
60 RESTRICT="multilib-strict" since it's not compatible with the whole
61 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
62 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
63
64 *polkit-0.106-r6 (01 Jul 2012)
65
66 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
67 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
68 /usr/lib to /usr/lib64 symlink.
69
70 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
71 polkit-0.106-r5.ebuild:
72 Adding dependency on SELinux policykit module if USE=selinux is set
73
74 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
75 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
76 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
77
78 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
79 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
80 old
81
82 *polkit-0.106-r5 (27 Jun 2012)
83
84 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
85 Revert entire unix-group:wheel experiment back to unix-user:0 because
86 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
87 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
88 by Doug Goldstein.
89
90 *polkit-0.106-r4 (27 Jun 2012)
91
92 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
93 Stop installing polkit-backend-1.pc because upstream changed
94 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
95 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
96
97 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
98 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
99 Palimaka
100
101 *polkit-0.106-r3 (25 Jun 2012)
102
103 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
104 +polkit-0.106-r3.ebuild:
105 pax-mark polkitd to fix crashes on hardened/PaX systems.
106
107 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
108 Convert pkg_postinst() message about polkitd home directory to new
109 user.eclass function esethome().
110
111 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
112 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
113
114 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
115 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
116
117 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
118 old
119
120 *polkit-0.106-r2 (17 Jun 2012)
121
122 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
123 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
124 existing directories.
125
126 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
127 old
128
129 *polkit-0.106-r1 (17 Jun 2012)
130
131 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
132 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
133 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
134 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
135 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
136
137 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
138 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
139 #420173 and #420307.
140
141 *polkit-0.106 (07 Jun 2012)
142
143 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
144 Version bump.
145
146 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
147 Improve systemd handling wrt #416317 by Christoph Brill
148
149 *polkit-0.105 (14 May 2012)
150
151 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
152 Version bump.
153
154 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
155 dev-util/pkgconfig -> virtual/pkgconfig
156
157 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
158 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
159 old
160
161 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
162 ia64/sh/sparc stable wrt #401513
163
164 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
165 ppc/ppc64 stable wrt #401513
166
167 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
168 Stable on alpha, bug #401513
169
170 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
171 marked x86 per bug 401513
172
173 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
174 arm stable, bug #401513
175
176 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
177 Stable for HPPA (bug #401513).
178
179 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
180 Stable for AMD64, wrt security bug #401513
181
182 *polkit-0.104-r1 (30 Jan 2012)
183
184 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
185 Restore the default value of AdminIdentities from "wheel" to "0" like it was
186 in polkit-0.102 and ones before that. You should see files
187 50-localauthority.conf and 60-gentoo.conf in
188 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
189 with "man 8 pklocalauthority" as soon as possible.
190
191 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
192 arm stable, bug #397755
193
194 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
195 Stable for AMD64, wrt bug #397755
196
197 *polkit-0.104 (05 Jan 2012)
198
199 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
200 metadata.xml:
201 Version bump.
202
203 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
204 old
205
206 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
207 ppc/ppc64 stable wrt #387163
208
209 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
210 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
211
212 *polkit-0.103 (07 Dec 2011)
213
214 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
215 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
216 "i.Dark_Templar"
217
218 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
219 alpha/arm/ia64/sh/sparc stable wrt #387163
220
221 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
222 arm stable, bug #387163
223
224 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
225 Stable for HPPA (bug #387163).
226
227 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
228 x86 stable wrt bug #387163
229
230 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
231 Stable on amd64 wrt bug #387163
232
233 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
234 polkit-0.102.ebuild:
235 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
236
237 *polkit-0.102 (06 Aug 2011)
238
239 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
240 Version bump.
241
242 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
243 Added ~mips, bug 296548
244
245 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
246 Add missing dtd to DEPEND, bug #355505.
247
248 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
249 alpha/arm/ia64/sh/sparc stable wrt #364973
250
251 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
252 polkit-0.101-r1.ebuild:
253 x86 stable wrt security bug #364973
254
255 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
256 Stable for HPPA (bug #364973).
257
258 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
259 Stable on amd64 wrt bug #364973
260
261 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
262 ppc/ppc64 stable wrt #364973
263
264 *polkit-0.101-r1 (25 Apr 2011)
265
266 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
267 +polkit-0.101-r1.ebuild:
268 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
269
270 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
271 ppc/ppc64 stable wrt #354509
272
273 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
274 alpha/ia64/sh/sparc stable wrt #354509
275
276 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
277 PDEPEND on 0.101 version of polkit-gnome
278
279 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
280 arm stable, bug #354509
281
282 *polkit-0.101 (11 Mar 2011)
283
284 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
285 Version bump.
286
287 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
288 Stable for HPPA (bug #354509).
289
290 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
291 x86 stable per bug 354509
292
293 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
294 Stable on amd64 wrt bug #354509
295
296 *polkit-0.100 (23 Feb 2011)
297
298 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
299 Bump to 0.100
300
301 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
302 USE="kde" to pull in authentication agent for KDE.
303
304 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
305 Marked ~hppa (bug #296548).
306
307 *polkit-0.99-r1 (25 Dec 2010)
308
309 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
310 Revision bump to remove static archives (.a) and libtool archives (.la).
311 USE="gtk" to pull in authentication agent for GTK+ based desktops.
312
313 *polkit-0.99 (25 Sep 2010)
314
315 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
316 Bump to 0.99, masked due to >=glib-2.25 requirement
317
318 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
319 arm stable, bug #314899
320
321 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
322 polkit-0.96-r2.ebuild:
323 alpha/ia64/sh/sparc stable
324
325 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
326 Marked ppc/ppc64 stable.
327
328 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
329 Stable on alpha, bug #329621
330
331 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
332 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
333 Stable for HPPA (bug #314899).
334
335 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
336 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
337 Drop HPPA keywording (bug #324511).
338
339 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
340 polkit-0.96-r2.ebuild:
341 Add ewarn about ensuring that consolekit sessions are working. Either the
342 user needs to login using a login-manager with consolekit support, or use
343 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
344
345 *polkit-0.96-r2 (02 Jul 2010)
346
347 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
348 +polkit-0.96-r2.ebuild, metadata.xml:
349 USE=expat was quite useless, expat is mandatory in polkit. Don't create
350 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
351 add introspection support
352
353 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
354 x86 stable, bug #314899
355
356 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
357 amd64 stable, bug #314899
358
359 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
360 polkit-0.96-r1.ebuild:
361 Add ~sh
362
363 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
364 +files/polkit-0.96-getcwd.patch:
365 Fix build on fbsd and keyword it x86-fbsd
366
367 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
368 polkit-0.96-r1.ebuild:
369 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
370
371 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
372 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
373 -polkit-0.95.ebuild:
374 Remove old
375
376 *polkit-0.96-r1 (21 Mar 2010)
377
378 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
379 +polkit-0.96-r1.ebuild:
380 Update with newer version of polkit-shadow patch
381
382 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
383 Fix minor problems with SRC_URI
384
385 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
386 Add experimental shadow support, bug 291116 . Patch thanks to the
387 slackware folks.
388
389 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
390 Add ~alpha/~arm/~ia64/~sparc
391
392 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
393 Marked ~ppc/~ppc64 for bug #296548.
394
395 *polkit-0.96 (23 Jan 2010)
396
397 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
398 Version bump to 0.96; lots of bugfixes, see NEWS
399
400 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
401 Marked ~hppa (bug #296548).
402
403 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
404 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
405 the user is in an active/local session via dbus methods
406
407 *polkit-0.95 (14 Nov 2009)
408
409 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
410 Bump to 0.95 -- new lockdown API, last dev version till 1.0
411
412 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
413 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
414 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
415
416 *polkit-0.94 (29 Oct 2009)
417
418 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
419 +files/polkit-0.92-zsh-completions.patch,
420 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
421 +metadata.xml:
422 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20