/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.94 - (show annotations) (download)
Sat Jun 30 10:27:11 2012 UTC (21 months, 2 weeks ago) by swift
Branch: MAIN
Changes since 1.93: +5 -1 lines
Adding SELinux dependency, fixes bug #424177

(Portage version: 2.1.10.49/cvs/Linux x86_64)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.93 2012/06/27 11:56:12 ssuominen Exp $
4
5 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
6 polkit-0.106-r5.ebuild:
7 Adding dependency on SELinux policykit module if USE=selinux is set
8
9 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
10 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
11 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
12
13 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
14 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
15 old
16
17 *polkit-0.106-r5 (27 Jun 2012)
18
19 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
20 Revert entire unix-group:wheel experiment back to unix-user:0 because
21 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
22 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
23 by Doug Goldstein.
24
25 *polkit-0.106-r4 (27 Jun 2012)
26
27 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
28 Stop installing polkit-backend-1.pc because upstream changed
29 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
30 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
31
32 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
33 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
34 Palimaka
35
36 *polkit-0.106-r3 (25 Jun 2012)
37
38 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
39 +polkit-0.106-r3.ebuild:
40 pax-mark polkitd to fix crashes on hardened/PaX systems.
41
42 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
43 Convert pkg_postinst() message about polkitd home directory to new
44 user.eclass function esethome().
45
46 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
47 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
48
49 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
50 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
51
52 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
53 old
54
55 *polkit-0.106-r2 (17 Jun 2012)
56
57 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
58 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
59 existing directories.
60
61 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
62 old
63
64 *polkit-0.106-r1 (17 Jun 2012)
65
66 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
67 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
68 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
69 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
70 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
71
72 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
73 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
74 #420173 and #420307.
75
76 *polkit-0.106 (07 Jun 2012)
77
78 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
79 Version bump.
80
81 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
82 Improve systemd handling wrt #416317 by Christoph Brill
83
84 *polkit-0.105 (14 May 2012)
85
86 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
87 Version bump.
88
89 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
90 dev-util/pkgconfig -> virtual/pkgconfig
91
92 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
93 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
94 old
95
96 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
97 ia64/sh/sparc stable wrt #401513
98
99 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
100 ppc/ppc64 stable wrt #401513
101
102 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
103 Stable on alpha, bug #401513
104
105 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
106 marked x86 per bug 401513
107
108 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
109 arm stable, bug #401513
110
111 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
112 Stable for HPPA (bug #401513).
113
114 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
115 Stable for AMD64, wrt security bug #401513
116
117 *polkit-0.104-r1 (30 Jan 2012)
118
119 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
120 Restore the default value of AdminIdentities from "wheel" to "0" like it was
121 in polkit-0.102 and ones before that. You should see files
122 50-localauthority.conf and 60-gentoo.conf in
123 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
124 with "man 8 pklocalauthority" as soon as possible.
125
126 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
127 arm stable, bug #397755
128
129 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
130 Stable for AMD64, wrt bug #397755
131
132 *polkit-0.104 (05 Jan 2012)
133
134 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
135 metadata.xml:
136 Version bump.
137
138 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
139 old
140
141 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
142 ppc/ppc64 stable wrt #387163
143
144 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
145 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
146
147 *polkit-0.103 (07 Dec 2011)
148
149 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
150 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
151 "i.Dark_Templar"
152
153 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
154 alpha/arm/ia64/sh/sparc stable wrt #387163
155
156 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
157 arm stable, bug #387163
158
159 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
160 Stable for HPPA (bug #387163).
161
162 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
163 x86 stable wrt bug #387163
164
165 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
166 Stable on amd64 wrt bug #387163
167
168 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
169 polkit-0.102.ebuild:
170 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
171
172 *polkit-0.102 (06 Aug 2011)
173
174 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
175 Version bump.
176
177 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
178 Added ~mips, bug 296548
179
180 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
181 Add missing dtd to DEPEND, bug #355505.
182
183 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
184 alpha/arm/ia64/sh/sparc stable wrt #364973
185
186 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
187 polkit-0.101-r1.ebuild:
188 x86 stable wrt security bug #364973
189
190 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
191 Stable for HPPA (bug #364973).
192
193 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
194 Stable on amd64 wrt bug #364973
195
196 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
197 ppc/ppc64 stable wrt #364973
198
199 *polkit-0.101-r1 (25 Apr 2011)
200
201 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
202 +polkit-0.101-r1.ebuild:
203 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
204
205 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
206 ppc/ppc64 stable wrt #354509
207
208 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
209 alpha/ia64/sh/sparc stable wrt #354509
210
211 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
212 PDEPEND on 0.101 version of polkit-gnome
213
214 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
215 arm stable, bug #354509
216
217 *polkit-0.101 (11 Mar 2011)
218
219 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
220 Version bump.
221
222 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
223 Stable for HPPA (bug #354509).
224
225 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
226 x86 stable per bug 354509
227
228 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
229 Stable on amd64 wrt bug #354509
230
231 *polkit-0.100 (23 Feb 2011)
232
233 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
234 Bump to 0.100
235
236 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
237 USE="kde" to pull in authentication agent for KDE.
238
239 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
240 Marked ~hppa (bug #296548).
241
242 *polkit-0.99-r1 (25 Dec 2010)
243
244 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
245 Revision bump to remove static archives (.a) and libtool archives (.la).
246 USE="gtk" to pull in authentication agent for GTK+ based desktops.
247
248 *polkit-0.99 (25 Sep 2010)
249
250 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
251 Bump to 0.99, masked due to >=glib-2.25 requirement
252
253 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
254 arm stable, bug #314899
255
256 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
257 polkit-0.96-r2.ebuild:
258 alpha/ia64/sh/sparc stable
259
260 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
261 Marked ppc/ppc64 stable.
262
263 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
264 Stable on alpha, bug #329621
265
266 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
267 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
268 Stable for HPPA (bug #314899).
269
270 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
271 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
272 Drop HPPA keywording (bug #324511).
273
274 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
275 polkit-0.96-r2.ebuild:
276 Add ewarn about ensuring that consolekit sessions are working. Either the
277 user needs to login using a login-manager with consolekit support, or use
278 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
279
280 *polkit-0.96-r2 (02 Jul 2010)
281
282 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
283 +polkit-0.96-r2.ebuild, metadata.xml:
284 USE=expat was quite useless, expat is mandatory in polkit. Don't create
285 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
286 add introspection support
287
288 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
289 x86 stable, bug #314899
290
291 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
292 amd64 stable, bug #314899
293
294 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
295 polkit-0.96-r1.ebuild:
296 Add ~sh
297
298 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
299 +files/polkit-0.96-getcwd.patch:
300 Fix build on fbsd and keyword it x86-fbsd
301
302 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
303 polkit-0.96-r1.ebuild:
304 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
305
306 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
307 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
308 -polkit-0.95.ebuild:
309 Remove old
310
311 *polkit-0.96-r1 (21 Mar 2010)
312
313 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
314 +polkit-0.96-r1.ebuild:
315 Update with newer version of polkit-shadow patch
316
317 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
318 Fix minor problems with SRC_URI
319
320 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
321 Add experimental shadow support, bug 291116 . Patch thanks to the
322 slackware folks.
323
324 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
325 Add ~alpha/~arm/~ia64/~sparc
326
327 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
328 Marked ~ppc/~ppc64 for bug #296548.
329
330 *polkit-0.96 (23 Jan 2010)
331
332 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
333 Version bump to 0.96; lots of bugfixes, see NEWS
334
335 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
336 Marked ~hppa (bug #296548).
337
338 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
339 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
340 the user is in an active/local session via dbus methods
341
342 *polkit-0.95 (14 Nov 2009)
343
344 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
345 Bump to 0.95 -- new lockdown API, last dev version till 1.0
346
347 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
348 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
349 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
350
351 *polkit-0.94 (29 Oct 2009)
352
353 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
354 +files/polkit-0.92-zsh-completions.patch,
355 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
356 +metadata.xml:
357 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20