/[gentoo-x86]/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
Gentoo

Contents of /sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.19 - (show annotations) (download)
Sat Sep 10 09:02:31 2011 UTC (2 years, 10 months ago) by scarabeus
Branch: MAIN
Changes since 1.18: +2 -2 lines
Cleanup the latest ebuild. Remove weird info. Reword the warning in 2.4 kernel support. Remove overshadowed version.

(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild,v 1.18 2011/06/06 05:00:08 robbat2 Exp $
4
5 inherit linux-info
6
7 PATCHLEVEL="11"
8 MY_PV="${PV}-${PATCHLEVEL}"
9 MY_P="${PN}-${MY_PV}"
10
11 DESCRIPTION="ipvsadm is a utility to administer the IP virtual server services offered by the Linux kernel with IP virtual server support."
12 HOMEPAGE="http://linuxvirtualserver.org"
13 LICENSE="GPL-2"
14 DEPEND=">=sys-libs/ncurses-5.2"
15
16 SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.4/${MY_P}.tar.gz"
17
18 SLOT="0"
19 KEYWORDS="~ppc ~ppc64 x86"
20 IUSE=""
21
22 S="${WORKDIR}/${MY_P}"
23
24 pkg_setup() {
25 if kernel_is -ge 2 6; then
26 eerror "${P} does not support 2.6 kernels, please try newer versions"
27 die "wrong kernel version"
28 fi
29 }
30
31 src_compile() {
32 emake || die "error compiling source"
33 }
34
35 src_install() {
36 into /
37 dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
38
39 doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8
40
41 newinitd "${FILESDIR}"/ipvsadm-init ipvsadm || die
42 keepdir /var/lib/ipvsadm
43
44 insinto /usr/lib
45 doins libipvs/libipvs.a || die
46
47 insinto /usr/include/ipvs
48 newins libipvs/libipvs.h ipvs.h || die
49
50 einfo "You will need a kernel that has ipvs patches to use LVS"
51 }

  ViewVC Help
Powered by ViewVC 1.1.20