/[gentoo-x86]/sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild
Gentoo

Contents of /sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Fri May 4 07:20:31 2012 UTC (2 years, 2 months ago) by jdhore
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +3 -3 lines
dev-util/pkgconfig -> virtual/pkgconfig

(Portage version: 2.2.0_alpha101/cvs/Linux i686)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild,v 1.2 2011/10/27 16:15:12 jer Exp $
4
5 EAPI=4
6
7 inherit eutils linux-info toolchain-funcs
8
9 DESCRIPTION="utility to administer the IP virtual server services"
10 HOMEPAGE="http://linuxvirtualserver.org/"
11 SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.6/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ia64 ppc ppc64 s390 sparc x86"
16 IUSE="static-libs"
17
18 RDEPEND=">=sys-libs/ncurses-5.2
19 dev-libs/libnl:1.1
20 >=dev-libs/popt-1.16"
21 DEPEND="${RDEPEND}
22 virtual/pkgconfig"
23
24 pkg_pretend() {
25 if kernel_is 2 4; then
26 eerror "${P} supports only 2.6 series and later kernels, please try ${PN}-1.21 for 2.4 kernels"
27 die "wrong kernel version"
28 fi
29 }
30
31 src_prepare() {
32 epatch "${FILESDIR}"/${P}-buildsystem.patch
33 epatch "${FILESDIR}/${P}-stack_smashing.patch" # bug 371903
34 use static-libs && export STATIC=1
35 }
36
37 src_compile() {
38 emake -e \
39 INCLUDE="-I.. -I." \
40 CC="$(tc-getCC)" \
41 HAVE_NL=1 \
42 STATIC_LIB=${STATIC} \
43 POPT_LIB="$(pkg-config --libs popt)"
44 }
45
46 src_install() {
47 into /
48 dosbin ipvsadm ipvsadm-save ipvsadm-restore
49
50 into /usr
51 doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8
52
53 newinitd "${FILESDIR}"/ipvsadm-init ipvsadm
54 keepdir /var/lib/ipvsadm
55
56 use static-libs && dolib.a libipvs/libipvs.a
57 dolib.so libipvs/libipvs.so
58
59 insinto /usr/include/ipvs
60 newins libipvs/libipvs.h ipvs.h
61 }
62
63 pkg_postinst() {
64 einfo "You will need a kernel that has ipvs patches to use LVS."
65 }

  ViewVC Help
Powered by ViewVC 1.1.20