/[gentoo-x86]/sys-cluster/openmpi/openmpi-1.4.2.ebuild
Gentoo

Diff of /sys-cluster/openmpi/openmpi-1.4.2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.14 Revision 1.15
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/Attic/openmpi-1.4.2.ebuild,v 1.14 2011/01/14 08:06:47 xarthisius Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/Attic/openmpi-1.4.2.ebuild,v 1.15 2011/06/21 09:57:18 jlec Exp $
4 4
5EAPI=3 5EAPI=3
6inherit eutils multilib flag-o-matic toolchain-funcs 6inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
7 7
8MY_P=${P/-mpi} 8MY_P=${P/-mpi}
9S=${WORKDIR}/${MY_P} 9S=${WORKDIR}/${MY_P}
10 10
11DESCRIPTION="A high-performance message passing library (MPI)" 11DESCRIPTION="A high-performance message passing library (MPI)"
27 !sys-cluster/mpich2 27 !sys-cluster/mpich2
28 !sys-cluster/mpiexec" 28 !sys-cluster/mpiexec"
29DEPEND="${RDEPEND}" 29DEPEND="${RDEPEND}"
30 30
31pkg_setup() { 31pkg_setup() {
32 fortran-2_pkg_setup
32 if use mpi-threads; then 33 if use mpi-threads; then
33 echo 34 echo
34 ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by" 35 ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
35 ewarn "default and officially unsupported by upstream." 36 ewarn "default and officially unsupported by upstream."
36 ewarn "You may stop now and set USE=-mpi-threads" 37 ewarn "You may stop now and set USE=-mpi-threads"

Legend:
Removed from v.1.14  
changed lines
  Added in v.1.15

  ViewVC Help
Powered by ViewVC 1.1.20