/[gentoo-x86]/sys-devel/gcc/gcc-3.4.6-r2.ebuild
Gentoo

Contents of /sys-devel/gcc/gcc-3.4.6-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.25 - (show annotations) (download)
Tue Mar 8 03:05:44 2011 UTC (3 years, 9 months ago) by dirtyepic
Branch: MAIN
Changes since 1.24: +3 -3 lines
Lock down gtk+ dependencies.

(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.24 2010/01/09 20:42:21 vapier Exp $
4
5 MAN_VER=""
6 PATCH_VER="1.6"
7 UCLIBC_VER="1.1"
8 UCLIBC_GCC_VER="3.4.5"
9 PIE_VER="8.7.10"
10 PIE_GCC_VER="3.4.6"
11 PP_VER="1.0"
12 PP_GCC_VER="3.4.6"
13 HTB_VER="1.00.1"
14 HTB_GCC_VER="3.4.4"
15 D_VER="0.24"
16
17 GCC_LIBSSP_SUPPORT="true"
18
19 ETYPE="gcc-compiler"
20
21 # arch/libc configurations known to be stable with {PIE,SSP}-by-default
22 SSP_STABLE="x86 sparc amd64 ppc ppc64 ia64"
23 SSP_UCLIBC_STABLE="arm mips ppc x86"
24 PIE_GLIBC_STABLE="x86 sparc amd64 ppc ppc64 ia64"
25 PIE_UCLIBC_STABLE="x86 mips ppc"
26
27 # arch/libc configurations known to be broken with {PIE,SSP}-by-default
28 SSP_UNSUPPORTED="hppa sh"
29 SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
30 PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
31 PIE_GLIBC_UNSUPPORTED="hppa"
32
33 # whether we should split out specs files for multiple {PIE,SSP}-by-default
34 # and vanilla configurations.
35 SPLIT_SPECS=${SPLIT_SPECS-true}
36
37 #GENTOO_PATCH_EXCLUDE=""
38 #PIEPATCH_EXCLUDE=""
39
40 inherit toolchain eutils
41
42 DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
43
44 KEYWORDS="-* alpha amd64 arm ~ia64 ~mips ppc ppc64 ~s390 sh sparc x86 ~x86-fbsd"
45 IUSE="ip28 ip32r10k"
46
47 # we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
48 # NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
49 # .eh_frame ld optimisation and symbol visibility support, but it hasnt been
50 # well tested in gentoo on any arch other than amd64!!
51 RDEPEND=">=sys-devel/gcc-config-1.4
52 >=sys-libs/zlib-1.1.4
53 virtual/libiconv
54 elibc_glibc? (
55 >=sys-libs/glibc-2.3.3_pre20040420-r1
56 hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
57 )
58 !build? (
59 gcj? (
60 gtk? (
61 x11-libs/libXt
62 x11-libs/libX11
63 x11-libs/libXtst
64 x11-proto/xproto
65 x11-proto/xextproto
66 =x11-libs/gtk+-2*
67 )
68 >=media-libs/libart_lgpl-2.1
69 )
70 >=sys-libs/ncurses-5.2-r2
71 nls? ( sys-devel/gettext )
72 )"
73
74 if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
75 RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
76 fi
77
78 DEPEND="${RDEPEND}
79 >=sys-apps/texinfo-4.2-r4
80 >=sys-devel/bison-1.875
81 sys-devel/flex
82 >=sys-devel/binutils-2.14.90.0.8-r1
83 amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
84 PDEPEND=">=sys-devel/gcc-config-1.4"
85
86 src_unpack() {
87 gcc_src_unpack
88
89 # misc patches that havent made it into a patch tarball yet
90 [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
91
92 # nothing in the tree provides libssp.so, so nothing will ever trigger this
93 # logic, but having the patch in the tree makes life so much easier for me
94 # since I dont have to also have an overlay for this.
95 want_libssp && epatch "${FILESDIR}"/3.4.3/libssp.patch
96
97 # Anything useful and objc will require libffi. Seriously. Lets just force
98 # libffi to install with USE="objc", even though it normally only installs
99 # if you attempt to build gcj.
100 if ! use build && use objc && ! use gcj ; then
101 epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
102 #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
103 fi
104
105 # Fix cross-compiling
106 epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
107
108 [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-softfloat.patch
109
110 # Arch stuff
111 case $(tc-arch) in
112 mips)
113 # If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
114 if ! is_multilib; then
115 use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
116 use n64 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n64only.patch
117 fi
118
119 # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
120 # -mtune=r10000 support to gcc (Allows the compiler to generate code to
121 # take advantage of R10k's second ALU, perform shifts, etc..
122 #
123 # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
124 epatch ${FILESDIR}/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
125
126 # This is a very special patch -- it allows us to build semi-usable kernels
127 # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
128 # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
129 # but for our purposes of building a kernel, it works.
130 # Unless you're building an IP28 kernel, you really don't need care about what
131 # this patch does, because if you are, you are probably already aware of what
132 # it does.
133 # All that said, the abilities of this patch are disabled by default and need
134 # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
135 # There is the possibility it may be used for very specific userland apps too.
136 if use ip28 || use ip32r10k; then
137 epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
138 fi
139 ;;
140 amd64)
141 if is_multilib ; then
142 sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
143 fi
144 ;;
145 esac
146 }

  ViewVC Help
Powered by ViewVC 1.1.20