/[gentoo-x86]/sys-devel/gcc/gcc-3.4.6-r2.ebuild
Gentoo

Contents of /sys-devel/gcc/gcc-3.4.6-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.28 - (show annotations) (download)
Wed Nov 9 19:22:56 2011 UTC (2 years, 10 months ago) by vapier
Branch: MAIN
Changes since 1.27: +2 -32 lines
Drop most dependencies now that toolchain.eclass takes care of them.  Also drop the ncurses dep as that seems to be purely a workaround for an ancient issue #4411 which we have addressed in different ways.

(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.27 2011/09/26 17:38:49 vapier Exp $
4
5 MAN_VER=""
6 PATCH_VER="1.6"
7 UCLIBC_VER="1.1"
8 UCLIBC_GCC_VER="3.4.5"
9 PIE_VER="8.7.10"
10 PIE_GCC_VER="3.4.6"
11 PP_VER="1.0"
12 PP_GCC_VER="3.4.6"
13 HTB_VER="1.00.1"
14 HTB_GCC_VER="3.4.4"
15 D_VER="0.24"
16
17 GCC_LIBSSP_SUPPORT="true"
18
19 # arch/libc configurations known to be stable with {PIE,SSP}-by-default
20 SSP_STABLE="x86 sparc amd64 ppc ppc64 ia64"
21 SSP_UCLIBC_STABLE="arm mips ppc x86"
22 PIE_GLIBC_STABLE="x86 sparc amd64 ppc ppc64 ia64"
23 PIE_UCLIBC_STABLE="x86 mips ppc"
24
25 # arch/libc configurations known to be broken with {PIE,SSP}-by-default
26 SSP_UNSUPPORTED="hppa sh"
27 SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
28 PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
29 PIE_GLIBC_UNSUPPORTED="hppa"
30
31 # whether we should split out specs files for multiple {PIE,SSP}-by-default
32 # and vanilla configurations.
33 SPLIT_SPECS=${SPLIT_SPECS-true}
34
35 #GENTOO_PATCH_EXCLUDE=""
36 #PIEPATCH_EXCLUDE=""
37
38 inherit toolchain eutils
39
40 DESCRIPTION="The GNU Compiler Collection"
41
42 KEYWORDS="-* alpha amd64 arm ~ia64 ~mips ppc ppc64 ~s390 sh sparc x86 ~x86-fbsd"
43 IUSE="ip28 ip32r10k n32 n64"
44
45 # we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
46 # NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
47 # .eh_frame ld optimisation and symbol visibility support, but it hasnt been
48 # well tested in gentoo on any arch other than amd64!!
49 RDEPEND=""
50 DEPEND="${RDEPEND}
51 >=sys-devel/binutils-2.14.90.0.8-r1
52 amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
53
54 src_unpack() {
55 toolchain_src_unpack
56
57 # misc patches that havent made it into a patch tarball yet
58 [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
59
60 # nothing in the tree provides libssp.so, so nothing will ever trigger this
61 # logic, but having the patch in the tree makes life so much easier for me
62 # since I dont have to also have an overlay for this.
63 want_libssp && epatch "${FILESDIR}"/3.4.3/libssp.patch
64
65 # Anything useful and objc will require libffi. Seriously. Lets just force
66 # libffi to install with USE="objc", even though it normally only installs
67 # if you attempt to build gcj.
68 if ! use build && use objc && ! use gcj ; then
69 epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
70 #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
71 fi
72
73 # Fix cross-compiling
74 epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
75
76 [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-softfloat.patch
77
78 # Arch stuff
79 case $(tc-arch) in
80 mips)
81 # If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
82 if ! is_multilib; then
83 use n32 && epatch "${FILESDIR}"/3.4.1/gcc-3.4.1-mips-n32only.patch
84 use n64 && epatch "${FILESDIR}"/3.4.1/gcc-3.4.1-mips-n64only.patch
85 fi
86
87 # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
88 # -mtune=r10000 support to gcc (Allows the compiler to generate code to
89 # take advantage of R10k's second ALU, perform shifts, etc..
90 #
91 # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
92 epatch "${FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
93
94 # This is a very special patch -- it allows us to build semi-usable kernels
95 # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
96 # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
97 # but for our purposes of building a kernel, it works.
98 # Unless you're building an IP28 kernel, you really don't need care about what
99 # this patch does, because if you are, you are probably already aware of what
100 # it does.
101 # All that said, the abilities of this patch are disabled by default and need
102 # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
103 # There is the possibility it may be used for very specific userland apps too.
104 if use ip28 || use ip32r10k; then
105 epatch "${FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
106 fi
107 ;;
108 amd64)
109 if is_multilib ; then
110 sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
111 fi
112 ;;
113 esac
114 }

  ViewVC Help
Powered by ViewVC 1.1.20