/[gentoo-x86]/sys-devel/gcc/gcc-3.4.6-r2.ebuild
Gentoo

Contents of /sys-devel/gcc/gcc-3.4.6-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (show annotations) (download)
Thu Dec 28 20:51:59 2006 UTC (8 years ago) by kloeri
Branch: MAIN
Changes since 1.8: +2 -2 lines
Stable on Alpha.
(Portage version: 2.1.2_rc4-r1)

1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.8 2006/11/29 15:13:30 gustavoz Exp $
4
5 MAN_VER=""
6 PATCH_VER="1.3"
7 UCLIBC_VER="1.1"
8 UCLIBC_GCC_VER="3.4.5"
9 PIE_VER="8.7.9"
10 PIE_GCC_VER="3.4.6"
11 PP_VER="1.0"
12 PP_GCC_VER="3.4.6"
13 HTB_VER="1.00"
14 HTB_GCC_VER="3.4.4"
15
16 GCC_LIBSSP_SUPPORT="true"
17
18 ETYPE="gcc-compiler"
19
20 # arch/libc configurations known to be stable with {PIE,SSP}-by-default
21 SSP_STABLE="x86 sparc amd64 ppc ppc64"
22 SSP_UCLIBC_STABLE="arm mips ppc x86"
23 PIE_GLIBC_STABLE="x86 sparc amd64 ppc ppc64"
24 PIE_UCLIBC_STABLE="x86 mips ppc"
25
26 # arch/libc configurations known to be broken with {PIE,SSP}-by-default
27 SSP_UNSUPPORTED="hppa sh"
28 SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
29 PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
30 PIE_GLIBC_UNSUPPORTED="hppa"
31
32 # whether we should split out specs files for multiple {PIE,SSP}-by-default
33 # and vanilla configurations.
34 SPLIT_SPECS=${SPLIT_SPECS-true}
35
36 #GENTOO_PATCH_EXCLUDE=""
37 #PIEPATCH_EXCLUDE=""
38
39 inherit toolchain eutils
40
41 DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
42
43 KEYWORDS="-* alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh sparc ~x86 ~x86-fbsd"
44
45 # we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
46 # NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
47 # .eh_frame ld optimisation and symbol visibility support, but it hasnt been
48 # well tested in gentoo on any arch other than amd64!!
49 RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
50 >=sys-libs/zlib-1.1.4
51 virtual/libiconv
52 elibc_glibc? (
53 >=sys-libs/glibc-2.3.3_pre20040420-r1
54 hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
55 )
56 !build? (
57 gcj? (
58 gtk? (
59 || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
60 >=x11-libs/gtk+-2.2
61 )
62 >=media-libs/libart_lgpl-2.1
63 )
64 >=sys-libs/ncurses-5.2-r2
65 nls? ( sys-devel/gettext )
66 )"
67
68 if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
69 RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
70 fi
71
72 DEPEND="${RDEPEND}
73 >=sys-apps/texinfo-4.2-r4
74 >=sys-devel/bison-1.875
75 >=sys-devel/binutils-2.14.90.0.8-r1
76 amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
77 PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
78
79 src_unpack() {
80 gcc_src_unpack
81
82 # misc patches that havent made it into a patch tarball yet
83 [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
84
85 # nothing in the tree provides libssp.so, so nothing will ever trigger this
86 # logic, but having the patch in the tree makes life so much easier for me
87 # since I dont have to also have an overlay for this.
88 want_libssp && epatch "${FILESDIR}"/3.4.3/libssp.patch
89
90 # Anything useful and objc will require libffi. Seriously. Lets just force
91 # libffi to install with USE="objc", even though it normally only installs
92 # if you attempt to build gcj.
93 if ! use build && use objc && ! use gcj ; then
94 epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
95 #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
96 fi
97
98 # Fix cross-compiling
99 epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
100
101 [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-softfloat.patch
102
103 # Arch stuff
104 case $(tc-arch) in
105 mips)
106 # If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
107 if ! is_multilib; then
108 use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
109 use n64 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n64only.patch
110 fi
111
112 # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
113 # -mtune=r10000 support to gcc (Allows the compiler to generate code to
114 # take advantage of R10k's second ALU, perform shifts, etc..
115 #
116 # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
117 epatch ${FILESDIR}/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
118
119 # This is a very special patch -- it allows us to build semi-usable kernels
120 # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
121 # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
122 # but for our purposes of building a kernel, it works.
123 # Unless you're building an IP28 kernel, you really don't need care about what
124 # this patch does, because if you are, you are probably already aware of what
125 # it does.
126 # All that said, the abilities of this patch are disabled by default and need
127 # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
128 # There is the possibility it may be used for very specific userland apps too.
129 if use ip28 or use ip32r10k; then
130 epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
131 fi
132 ;;
133 amd64)
134 if is_multilib ; then
135 sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
136 fi
137 ;;
138 esac
139 }

  ViewVC Help
Powered by ViewVC 1.1.20