/[gentoo-x86]/sys-devel/gcc/gcc-4.6.0.ebuild
Gentoo

Contents of /sys-devel/gcc/gcc-4.6.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Mon Sep 26 17:38:49 2011 UTC (3 years, 3 months ago) by vapier
Branch: MAIN
Changes since 1.4: +1 -3 lines
Scrub now unused ETYPE logic.

(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.4 2011/08/06 00:55:14 dirtyepic Exp $
4
5 PATCH_VER="1.2"
6 UCLIBC_VER="1.0"
7
8 # Hardened gcc 4 stuff
9 PIE_VER="0.4.5"
10 SPECS_VER="0.2.0"
11 SPECS_GCC_VER="4.4.3"
12 # arch/libc configurations known to be stable with {PIE,SSP}-by-default
13 PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
14 PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
15 SSP_STABLE="amd64 x86 ppc ppc64 arm"
16 # uclibc need tls and nptl support for SSP support
17 SSP_UCLIBC_STABLE=""
18 #end Hardened stuff
19
20 inherit toolchain
21
22 DESCRIPTION="The GNU Compiler Collection"
23
24 LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
25 KEYWORDS=""
26 IUSE=""
27
28 RDEPEND=">=sys-libs/zlib-1.1.4
29 virtual/libiconv
30 >=dev-libs/gmp-4.3.2
31 >=dev-libs/mpfr-2.4.2
32 >=dev-libs/mpc-0.8.1
33 graphite? (
34 >=dev-libs/cloog-ppl-0.15.10
35 >=dev-libs/ppl-0.11
36 )
37 !build? (
38 gcj? (
39 gtk? (
40 x11-libs/libXt
41 x11-libs/libX11
42 x11-libs/libXtst
43 x11-proto/xproto
44 x11-proto/xextproto
45 =x11-libs/gtk+-2*
46 x11-libs/pango
47 )
48 >=media-libs/libart_lgpl-2.1
49 app-arch/zip
50 app-arch/unzip
51 )
52 nls? ( sys-devel/gettext )
53 )"
54 DEPEND="${RDEPEND}
55 test? (
56 >=dev-util/dejagnu-1.4.4
57 >=sys-devel/autogen-5.5.4
58 )
59 >=sys-apps/texinfo-4.8
60 >=sys-devel/bison-1.875
61 >=sys-devel/flex-2.5.4
62 amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
63 >=${CATEGORY}/binutils-2.18"
64 PDEPEND=">=sys-devel/gcc-config-1.4
65 go? ( >=sys-devel/gcc-config-1.5 )"
66
67 if [[ ${CATEGORY} != cross-* ]] ; then
68 PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
69 fi
70
71 src_unpack() {
72 toolchain_src_unpack
73
74 use vanilla && return 0
75
76 [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
77 }
78
79 pkg_setup() {
80 toolchain_pkg_setup
81
82 ewarn
83 ewarn "LTO support is still experimental and unstable."
84 ewarn "Any bugs resulting from the use of LTO will not be fixed."
85 ewarn
86 }

  ViewVC Help
Powered by ViewVC 1.1.20