/[gentoo-x86]/sys-fs/udev/udev-9999.ebuild
Gentoo

Diff of /sys-fs/udev/udev-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.108 Revision 1.109
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.108 2012/08/11 17:03:29 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.109 2012/08/13 16:05:15 ssuominen Exp $
4 4
5EAPI=4 5EAPI=4
6 6
7KV_min=2.6.39 7KV_min=2.6.39
8 8
65 !<sys-kernel/dracut-017-r1 65 !<sys-kernel/dracut-017-r1
66 !<sys-kernel/genkernel-3.4.25" 66 !<sys-kernel/genkernel-3.4.25"
67 67
68S="${WORKDIR}/systemd-${PV}" 68S="${WORKDIR}/systemd-${PV}"
69 69
70check_KV() 70udev_check_KV()
71{ 71{
72 if kernel_is lt ${KV_min//./ } 72 if kernel_is lt ${KV_min//./ }
73 then 73 then
74 return 1 74 return 1
75 fi 75 fi
97 CONFIG_CHECK="~DEVTMPFS" 97 CONFIG_CHECK="~DEVTMPFS"
98 ERROR_DEVTMPFS="DEVTMPFS is not set in this kernel. Udev will not run." 98 ERROR_DEVTMPFS="DEVTMPFS is not set in this kernel. Udev will not run."
99 99
100 linux-info_pkg_setup 100 linux-info_pkg_setup
101 101
102 if ! check_KV 102 if ! udev_check_KV
103 then 103 then
104 eerror "Your kernel version (${KV_FULL}) is too old to run ${P}" 104 eerror "Your kernel version (${KV_FULL}) is too old to run ${P}"
105 eerror "It must be at least ${KV_min}!" 105 eerror "It must be at least ${KV_min}!"
106 fi 106 fi
107 107
108 KV_FULL_SRC=${KV_FULL} 108 KV_FULL_SRC=${KV_FULL}
109 get_running_version 109 get_running_version
110 if ! check_KV 110 if ! udev_check_KV
111 then 111 then
112 eerror 112 eerror
113 eerror "Your running kernel version (${KV_FULL}) is too old" 113 eerror "Your running kernel version (${KV_FULL}) is too old"
114 eerror "for this version of udev." 114 eerror "for this version of udev."
115 eerror "You must upgrade your kernel or downgrade udev." 115 eerror "You must upgrade your kernel or downgrade udev."

Legend:
Removed from v.1.108  
changed lines
  Added in v.1.109

  ViewVC Help
Powered by ViewVC 1.1.20